ロング リーチ イーサネット(LRE)とデジタル加入者線(xDSL) : 非対称デジタル加入者線(ADSL)

Cisco DSL ルータの設定とトラブルシューティング ガイド - 固定 IP アドレス ブロックによる RFC1483 ルーティングの段階的設定手順

2004 年 9 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 10 月 2 日) | フィードバック

ご使用中の Cisco Digital Subscriber Line(DSL; デジタル加入者線)ルータには、Internet Service Provider(ISP; インターネット サービス プロバイダー)から固定パブリック IP アドレスが割り当てられています。

注: このセクションでのタスクを「設定」セクションでの設定例に関連付けるために、カラー コードが使用されています。 設定には、次のようにカラー コードが付けられています。

Dynamic Host Configuration Protocol(DHCP)サーバ

段階的設定手順

重要: はじめに、COM ポートのモニタリングを実行している可能性のある、PC 上のすべてのプログラムを終了します。 PDA やデジタル カメラなどのデバイスによってプログラムがシステム トレイに配置され、これにより、Cisco DSL ルータ設定のために COM ポートが使用できなくなる場合が多くあります。

Cisco DSL ルータと PC を接続

コンソール接続にはロール型ケーブルを使用し、これによって Cisco DSL ルータのコンソール ポートと PC の COM ポートを接続します。 Cisco DSL ルータに用意されているコンソール ケーブルは、明るい青色のフラット ケーブルです。 ロール型ケーブルのピン割り当て、または RJ-45 から DB9 コンバータへのピン割り当ての詳細については、『コンソールおよび AUX ポートのためのケーブル接続ガイド』を参照してください。

  1. シスコ コンソール ケーブルの一端の RJ-45 コネクタを Cisco DSL ルータのコンソール ポートへ接続します。
  2. コンソール ケーブルのもう一端の RJ-45 コネクタを、RJ-45 から DB9 へのコンバータに接続します。
  3. この DB9 コネクタを PC の空いている COM ポートに接続します。

HyperTerminal の起動とセットアップ

  1. PC で HyperTerminal プログラムを起動します。
  2. HyperTerminal セッションをセットアップします。
    1. セッションに名前を割り当て、OK をクリックします。
    2. Connect To ウィンドウで、Cancel をクリックします。
    3. File メニューから Properties をクリックします。
    4. Properties ウィンドウの Connect Using リストで、コンソール ケーブルの DB9 側を接続する COM ポートを選択します。
    5. Properties ウィンドウで Configure をクリックし、次の値を入力します。

        Bits per second:9600
        Data bits: 8
        Parity:None
        Stop bits: 1
        Flow Control:None

    6. OK をクリックします。
    7. Call メニューから Disconnect をクリックします。
    8. Call メニューから Call をクリックします。
    9. HyperTerminal 画面上にルータ プロンプトが表示されるまで、Enter キーを押します。

Cisco DSL ルータ上の既存設定のクリア

  1. 特権モードに入るために、ルータ プロンプトで enable と入力します。
    Router>enable
       Router#
       !--- # 記号は特権モードであることを示しています。
  2. ルータ上の既存設定をクリアします。
    Router#write erase
  3. ルータをリロードすると、ブランクのスタートアップ コンフィギュレーションを使用してブートされます。
    Router#reload
       System configuration has been modified. Save? [yes/no]:no
       Proceed with reload? [confirm]yes
       !--- ルータのリロードには数分かかる場合があります。
  4. ルータのリロード後、enable モードを再度入力します。
    Router>enable
       Router#
       

Cisco DSL ルータの設定

  1. トラブルシューティング セクションの debug 出力を適切に記録して表示するために、service timestamp を設定します。
    Router#configure terminal
       Router(config)#service timestamps debug datetime msec
       Router(config)#service timestamps log datetime msec
       Router(config)#end
  2. ルータの設定中にトリガされる可能性のあるコンソール メッセージを非表示にするために、Cisco DSL ルータ上でロギング コンソールを無効にします。
             Router#configure terminal
             Router(config)#no logging console
             Router(config)#end
       
  3. ルーティング設定オプションに柔軟性を持たせるために、ip routing, ip subnet-zero, ip classless を設定します。
    Router#configure terminal
       Router(config)#ip routing
       Router(config)#ip subnet-zero
       Router(config)#ip classless
       Router(config)#end
  4. Cisco DSL ルータのイーサネット インターフェイスに IP アドレスとサブネット マスクを設定します。
             Router#configure terminal
             Router(config)#interface ethernet 0
             Router(config-if)#ip address <ip address> <subnet mask>
             Router(config-if)#no shut
             Router(config-if)#end
       
  5. Cisco DSL ルータの ATM インターフェイスに no shut コマンドを設定して、インターフェイスを始動します。
       Router#configure terminal
       Router(config)#interface atm 0
       Router(config-if)#no shut
       Router(config-if)#end
  6. Cisco DSL ルータの ATM サブインターフェイスに ATM Permanent Virtual Circuit(PVC; 相手先固定接続)、カプセル化タイプ、および番号なしの Ethernet0 IP アドレスを設定します。
       Router#configure terminal
       Router(config)#interface atm 0.1 point-to-point
       Router(config-subif)#ip unnumbered ethernet0
       Router(config-subif)#pvc <vpi/vci>
       Router(config-subif-atm-vc)#encapsulation aal5snap
       Router(config-subif-atm-vc)#end
  7. 発信インターフェイスとして ATM0.1 を使用して、デフォルト ルートを設定します。
    Router#configure terminal
       Router(config)#ip route 0.0.0.0 0.0.0.0 atm0.1
       Router(config)#end
  8. (オプション)Cisco DSL ルータのイーサネット インターフェイスに接続されたホストへ割り当てる IP アドレスのプールを備えた DHCP サーバとして、Cisco DSL ルータを設定します。  DHCP サーバによって、IP アドレス、DNS、およびデフォルト ゲートウェイ IP アドレスが、ホストに動的に割り当てられます。
    Router#configure terminal
       Router(config)#ip dhcp excluded-address <ip address of ethernet0>
       Router(config)#ip dhcp pool <dhcp pool name>
       Router(dhcp-config)#network <ip network address of ethernet0> <subnet mask>  
       Router(dhcp-config)#default-router <ip address of ethernet0> 
       Router(dhcp-config)#dns-server <ip address of primary dns server> 
        <ip address of secondary dns server>
       Router(dhcp-config)#end
  9. Cisco DSL ルータ上でロギング コンソールを有効にします。これにより、すべての変更がメモリに書き込まれます。
    Router#configure terminal
       Router(config)#logging console
       Router(config)#end
       *Jan 1 00:00:00.100: %SYS-5-CONFIG_I: Configured from console by console
       Router#write memory
       Building configuration... [OK]
       Router#

設定の表示

これで、Cisco DSL ルータは Asymmetric Digital Subscriber Line(ADSL; 非対称デジタル加入者線)サービスに運用できるようになっています。 show run コマンドを発行すると、設定を表示できます。

Router#show run
   Building configuration...
   

設定

前述の「段階的設定手順」セクションで構築した設定を、次に示します。

固定 IP アドレス ブロックが備わった Cisco DSL ルータ
   !--- コメントには説明と追加情報が含まれています。
   service timestamps debug datetime msec
   service timestamps log datetime msec
   ip subnet-zero
   !
   ip dhcp excluded-address <ip address of ethernet0>
   ip dhcp pool <dhcp pool name>
    network <ip network address of ethernet0> <subnet mask>
    default-router <ip address of ethernet0>
    dns-server <ip address of dns server>
   !
   interface ethernet0
    no shut
    ip address <ip address> <subnet mask>
    no ip directed-broadcast
   !
   interface atm0
    no shut
    no ip address
    no ip directed-broadcast
    no atm ilmi-keepalive
   !
   interface atm0.1 point-to-point
    ip unnumbered ethernet0
    pvc <vpi/vci>
     encapsulation aal5snap
    !--- ISP によってサポートされる一般的な PVC 値は 0/35 または 8/35 です。
    !--- PVC 値は ISP に確認してください。
    !
   !
   ip classless 
   ip route 0.0.0.0 0.0.0.0 <default gateway to isp>
   ip route <default gateway to isp> 255.255.255.255 atm0.1
   !
   end       
   


設定のトラブルシューティング

ADSL サービスが適切に動作しない場合、『RFC1483 ルーティングのトラブルシューティング』を参照してください。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 71131