アベイラビリティ : ハイ アベイラビリティ

障害通知設定例(EEM)

2006 年 6 月 21 日 - 日本オリジナル版
その他のバージョン: PDFpdf | フィードバック

1.ネットワーク構成図

ネットワーク構成図

※ 画像をクリックすると、大きく表示されます。popup_icon

2.システムの前提条件

広域イーサネットなどで接続された2拠点において、支社側より本社のイントラネットへの通信が確保できなくなった時、フレッツグループアクセスなどの閉域網を介した監視サービスへ障害通知を行い、社内のIT管理者にメール通知を送る為の設定をおこないます。

3.想定する環境

広域イーサネットのサービスを主回線として、2つの拠点ネットワークが接続されています。ルーティングはスタティックルーティングを使用しており、支社側より本社の広域イーサネット側のIPアドレスにICMPによる到達性を確認しています。また支社側はPPPoE方式を利用して監視サービスへの通信経路を確保し、本社側イントラネットへのIPリーチャビリティを確保できない時、SMTPを利用した障害通知が送付されます。

4.必要なハードウェア/ソフトウェア

ISRシリーズは全てオンボードにて2FE(もしくは2GE)を具備します。ISRシリーズにてにて本構成が実現可能なハードウェア/ソフトウェアの組み合わせは下記になります。

プラットホーム Tトレイン メイントレイン
871 12.4(2)T以上 N/A
1812J 12.4(2)T以上 N/A
1841 12.4(2)T以上 N/A
2800シリーズ
(2801/2811/2821/2851)
12.4(2)T以上 N/A
3800シリーズ
(3825/3845)
12.4(2)T以上 N/A

本設定例においては、本社側:Cisco2811: IOS12.4(5a),支社側:Cisco1812J : IOS12.4(6)Tを使用しています。

5.サンプルコンフィグレーション

(1) 1812J

hostname C1812J-A
!
ip cef
!
ip name-server 192.168.100.200
ip sla 1
icmp-echo 172.16.10.1 source-interface FastEthernet0
timeout 500
frequency 10
ip sla schedule 1 life forever start-time now

!
track 1 rtr 1 reachability
!
interface FastEthernet0
ip address 172.16.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface FastEthernet3
switchport access vlan 20
!
interface Vlan20
ip address 172.16.11.1 255.255.255.0
ip tcp adjust-mss 1414
!
interface Dialer1
ip address negotiated
ip mtu 1454
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname Flet's@cisco.com
ppp chap password 0 cisco
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.1.1
ip route 192.168.100.0 255.255.0.0 Dialer1
!
dialer-list 1 protocol ip permit
!
event manager applet eem
event track 1 state down
action sendmail mail server "abc.cisco.com" to "eemtesting@cisco.com" from "eemdetector@cisco.com"
subject "Network down" body "172.16.10.1 down detected. This message is sent from C1812J. Please
check the router for further details."

!
end

6.キーとなるコマンドの解説

----------------------------
"ip name-servern 192.168.100.200"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
DNSサーバを指定します。
----------------------------
"ip sla 1"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
IP SLAを定義します。
----------------------------
"type icmp-echo 172.16.10.1 source-interface FastEthernet0"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
Icmp Echoを送信する宛先IPアドレスおよび送信元になるインタフェースを指定します。
----------------------------
"timeout 500"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
Icmp Echoリクエストに対する応答を待つ時間をミリ秒で指定します。ご使用になるネットワークの状態により調整をして下さい。
----------------------------
"frequency 10"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
ICMP Echoリクエストを送信する周期を秒で指定します。
----------------------------
"ip sla schedule 1 key life forever start-time now"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
定義された IP SLA のスケジュールの開始時間を"now"と指定し、IP SLAの有効期限を無限に指定します。sla プロセスを開始します。
----------------------------
"track 1 rtr 1reachability"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
トラックするオブジェクトを指定し、定義されたIP SLA番号を割り当てます。
----------------------------
"event manager applet eem"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
Embedded Event Manager(EEM)登録用アプレットを作成します。
----------------------------
"event track 1 state down"
<コマンド種別>
アプレットコンフィグレーションコマンド
<コマンドの機能>
Embedded Event Manager(EEM)アプレットのイベント発生のクライテリアを指定します。この例では、Cisco IOS オブジェクトトラッキングを利用したサブシステムリポートをイベント発生のトリガーとして指定しています。
----------------------------
"action sendmail mail server " abc.cisco.com " to " " eemtesting@cisco.com" from
" eemdetector@cisco.com " subject " Network down " body " 172.16.10.1 down detected.
This message is sent from C1812J. Please check the router for further details."
<コマンド種別>
アプレットコンフィグレーションコマンド
<コマンドの機能>
EEMアプレットのトリガーの際に、ショートe-mailによる通知を指定します。ここではメール送信に必要なメールサーバ/To/From/Subject(件名)およびBody(内容)を指定します。
----------------------------

7.設定に際しての注意点

本設定で利用しているEnhanced Object Trackingによるイベント検知は、EEM2.2の機能でありIOS12.4(2)T以上が必要となります。EEMはまずIOS12.3(4)Tよりサポートされ、12.3(14)TでEEM2.1への拡張が行なわれております。使用するactionや監視するeventによりサポートできるIOSのバージョンも異なりますので、導入前のIOSの選択には注意が必要です。

PPPoE 使用時の MTU サイズは、通常時よりも小さくなります。(フレッツでは、1454 バイトを推奨)そのため、MTU サイズを変更すると共に、TCP の MSS(最大セグメントサイズ)の値をそれに合わせて調整することが必要となる点に注意してください。

PPPoE インターフェース上での ip route 0.0.0.0 0.0.0.0 Dialer1 と指定した際にはファーストスイッチとなります。PPPoE にてより高速な CEF スイッチを実現する為にはサービスプロバイダーの BAS アドレスが PPP ネゴシエーション時にルータにインストールされている必要があります。インストールされている様であれば、dialer インターフェースにて ppp ipcp route default を設定し、再度 PPPoE セッション確立してください。PPP ネゴシエーション終了時に BAS アドレスを nexthop としたデフォルトルートが作成されます。

以前IOSではPPPoEクライアントにおいて、下記のコマンドが必要でしたが、現在のIOSでは必要がありません。またこのコマンドを設定する事によりPPPoEサーバの機能が有効になり、WAN側の同一セグメントにおいて、PPPoEクライアントが存在する際には、broadcastで送られるPADIに対し、PADOを返してしまいます。こちらの設定は行わないで下さい。
vpdn enable
vpdn-group 1
request-dialin
protocol pppoe

1812Jや871の様なSW内臓のプラットホームまたはHWIC-4ESW/HWIC-9DESWなどのスイッチモジュールを使用し、vlanを使用する際には、vlan databaseコマンドにて追加するvlanを指定する必要があります。

8.Embedded Event Managerについて

8.1概要

Embedded Event Managerはイベントモニタを行い、対象となるイベントが発生した際やカウンタが閾値を超えた場合にそれを検知し、そのイベントと関連づけたアクションを起こすことのできる機能です。

下記の図は、Embedded Event Managerの中での各項目の関連性を表しています。

Embedded Event Manager

※ 画像をクリックすると、大きく表示されます。popup_icon

EEM AppletないしはScriptにより指定されたEEMポリシーはEEM Policy Directorによりポリシー内で設定したイベントおよびアクションを管理されます。各種Event Detectorによりイベントが検知された場合、EEM Policy Directorがそのイベントと関連するEEMポリシー内のActionを実行します。

<Event Detector>

Embedded Event ManagerはEvent Detectorとよばれるソフトウェアプログラムを利用してイベント検知を行います。
今回の例ではEnhanced Object Trackingによりイベント(ネットワークダウン)を検知しましたが、他にも下記のEvent Detectorを利用することが可能です。

Event Detector種類 説明
Application Specific Event Detector アプリケーションによるイベント検知
CLI Event Detector 正規表現によりCLIイベントをモニタ 検知
Counter Event Detector 特定のカウンタが閾値を超えた場合を検知
Enhanced Object Tracking Event Detector インターフェースのカウンタが閾値を越えた場合を検知
None Event Detector "event manager run"コマンドによりEEMポリシーを実行
OIR(Online Insertion and Removal)
Event Detector
ルートプロセッサ、ラインカード、フィーチャーカードの抜き差しを検知
Resource Event Detector Embedded Resource Manager(ERM)による状況検知
RF(Redundancy Framework)
Event Detector
デュアルルートプロセッサシステムの同期の際に起こるRFイベントの検知
SNMP Event Detector SNMP MIBオブジェクトによる検知
Syslog Event Detector Syslogメッセージによる検知
Timer Event Detector タイマーによる検知:
-absolute-time-of-dayタイマー
-カウントダウンタイマー
-Watchdogタイマー
-CRONタイマー
Watchdog System Monitor Event Detector WatchdogシステムモニターイベントによるCPU メモリ利用率を閾値を超えた場合検知

<Embedded Event Manager Action>

Event Detectorによりイベント検知が行われた場合、Embedded Event Managerはそれに対応するActionを実行します。
Embedded Event Managerは今回の例で利用したSMTPによるショートメール送信以外に、下記Actionを実行することが可能です。

  • IOS CLIコマンドの実行
  • CNSイベントの作成
  • カウンタの変更
  • セカンダリプロセッサへのスイッチオーバー
  • システム情報の取得
  • 他EEMポリシーの実行
  • アプリケーションイベントの実行
  • Cisco IOSソフトウェアのリブート
  • SNMPトラップの生成
  • Syslogメッセージの生成
  • Trackオブジェクトの設定
  • SMTPによるショートメール送信

8.2 Syslogメッセージ検知によるショートメール送信

Enhanced Event Managerでは、数あるEvent Detectorプログラムの中から最適なプログラムを選択し、イベント検知を行います。ダイナミックルーティングを用いたネットワーク環境の構築の場合、ルータ側に出力されるSyslogメッセージを用いてEnhanced Event Manager機能を利用することが可能です。

OSPFネイバーダウンを検知した際に出力されるSyslogメッセージにより障害通知のショートメールを送信する場合のEEM設定例を下記に示します。

EEM設定例

※ 画像をクリックすると、大きく表示されます。popup_icon

OSPFネイバールータの172.16.10.1からルーティングアップデートを受信せず、Dead タイマがExpireした時点で出力されるSyslogをトリガーとしてSMTPによるショートメール送信が行われます。またそれぞれのパターンは正規表現も使用可能です。

Jun 21, 2006 Document ID: jtac_20060621_7