ロング リーチ イーサネット(LRE)とデジタル加入者線(xDSL) : ISDN デジタル加入者線(ISDL)

BRI ポートを使用したフレームリレー接続設定例(128k bps)

2006 年 6 月 21 日 - 日本オリジナル版
その他のバージョン: PDFpdf | フィードバック

1.ネットワーク構成図

設定の前提となるネットワーク構成図

※ 画像をクリックすると、大きく表示されます。popup_icon

2.システムの前提条件

ISR ルータの BRI ポートを使用して、フレームリレー接続の設定を行います。
回線速度は 128kbps です。

3.想定する環境

フレームリレーサービスを利用して、本社側と支社側にてのハブ アンド スポーク型の接続を行ないます。

ルーティングプロトコルは "OSPF(Open Shortest Path First Protocol)" を使用し、ダイナミックにルーティング情報の交換を行います。

4.必要なハードウェア/ソフトウェア

ISR シリーズにて本構成が実現可能なハードウェア/ソフトウェアの組み合わせは下記になります。
* 下記はルータにて BRI インターフェースを具備した場合の構成となります。Serial インターフェースなどで TA と接続する際には別途モジュールが必要となります。

プラットホーム モジュール T トレイン メイントレイン
1812J Onboad 12.4(2)T 以上 N/A
1841/2801 WIC-1B-S/T-V3 12.3(8)T 以上 12.4(1)以上
2811/2821/2851 WIC-1B-S/T-V3
NM-4B-S/T
NM-8B-S/T
12.3(8)T 以上 12.4(1)以上
3825/3845 WIC-1B-S/T-V3
NM-4B-S/T
NM-8B-S/T
12.3(11)T 以上 12.4(1)以上

本設定例においては、支社側にて Cisco1812J : IOS12.4(6)T、本社側にて Cisco 2811: IOS12.4(5a)を使用しています。

5.サンプルコンフィグレーション

1. 1812J-A

hostname 1812J-A
!
!
isdn switch-type ntt
isdn leased-line BRI0 128

!
interface Loopback0
ip address 192.168.255.2 255.255.255.255
!
interface FastEthernet0
description Branch-LAN
ip address 192.168.1.254 255.255.255.0
duplex auto
speed auto
!
interface BRI0
no ip address
encapsulation frame-relay
frame-relay lmi-type q933a

!
interface BRI0.16 point-to-point
description To-HeadQuater-Ofiice
ip address 192.168.10.2 255.255.255.252
frame-relay interface-dlci 16 ietf
!
!
router ospf 1
log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.3 area 0
network 192.168.255.2 0.0.0.0 area 0
!
end

2. 1812J-B

hostname 1812J-B
!
isdn switch-type ntt
isdn leased-line BRI0 128

!
!
interface Loopback0
ip address 192.168.255.3 255.255.255.255
!
interface BRI0
no ip address
encapsulation frame-relay
frame-relay lmi-type q933a

!
interface BRI0.17 point-to-point
description To-HeadQuater-Ofiice
ip address 192.168.20.2 255.255.255.252
frame-relay interface-dlci 17 ietf
!
interface FastEthernet0
description Branch-LAN
ip address 192.168.2.254 255.255.255.0
duplex auto
speed auto
!
!
router ospf 1
log-adjacency-changes
network 192.168.2.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.3 area 0
network 192.168.255.3 0.0.0.0 area 0
!
end

3. 2811

hostname 2811-A
!
isdn switch-type ntt
isdn leased-line BRI0/0/0 128

!
interface Loopback0
ip address 192.168.255.1 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.101.254 255.255.255.0
duplex auto
speed auto
!
!
interface BRI0/0/0
no ip address
encapsulation frame-relay
frame-relay lmi-type q933a

!
interface BRI0/0/0.18 point-to-point
ip address 192.168.10.1 255.255.255.0
frame-relay interface-dlci 18 ietf
!
interface BRI0/0/0.19 point-to-point
ip address 192.168.20.1 255.255.255.0
frame-relay interface-dlci 19 ietf
!
router ospf 1
log-adjacency-changes
network 192.168.10.0 0.0.0.3 area 0
network 192.168.20.0 0.0.0.3 area 0
network 192.168.101.0 0.0.0.255 area 0
network 192.168.255.1 0.0.0.0 area 0
! end

6.キーとなるコマンドの解説

----------------------------
"isdn switch-type ntt"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
このコマンドは、ISDN 回線の交換機の種別を指定します。BRI ポートを使用したフレームリレー接続の場合は "ntt" を使用します。
----------------------------
"isdn leased-line BRI0 128"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
回線速度 128kbps の専用線接続を行なう BRI ポートを指定するコマンドです。
----------------------------
"encapsulation frame-relay"
<コマンド種別>
インタフェースコンフィグレーションコマンド
<コマンドの機能>
このコマンドにより、適用するインタフェースに対してフレームリレーのカプセリングを行います。また、カプセリング方式として、そのインタフェースに接続する接続先全てに対して IETF 方式を用いる場合は、インタフェースに下記コマンドを設定します。

interface BRI0
encapsuration frame-relay ietf

----------------------------

"" frame-relay lmi-type q933a"
<コマンド種別>
インタフェースコンフィグレーションコマンド
<コマンドの機能>
フレームリレー交換機の LMI(Local Management Interface/PVC 状態確認手順)タイプを指定します。
LMI タイプは、接続するフレームリレーの交換機によって異なりますので、契約する回線業者にお問い合わせ下さい。
なお、シスコルータがサポートしている LMI タイプは、下記表を参照して下さい。

LMI タイプ 説明
cisco Cisco、Strata Com、Nothern Telecom、DEC が共同開発した LMI タイプ(4社仕様)
ansi ANSI 規格に規定された、T1.617 Annex D
q933a ITU-T 勧告に規定された、Q.933 Annex A

----------------------------
"frame-relay interface-dlci 16 ietf"
<コマンド種別>
インタフェースコンフィグレーションコマンド
<コマンドの機能>
DLCI(Data Link Connection Identifier/ データリンク識別子)の番号により接続先と、カプセリング方式を指定します。デフォルトのカプセリング方式は CISCO です。IETF 方式のカプセリングを利用する場合は明示的にietfを指定します。
----------------------------
"interface BRI0.1 point-to-point"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
仮想インタフェース(サブインタフェース)を作成するコマンドです。
仮想インタフェースは、PVC の数にあわせて作成する必要があります。
----------------------------

7.設定に際しての注意点

64kbps の回線速度にて、使用する際には下記のような設定となります。

isdn switch-type ntt
isdn leased-line BRI0
!

interface BRI0
no ip address
!
interface BRI0:1
no ip address
encapsulation frame-relay
frame-relay lmi-type q933a
!
interface BRI0:1.1 point-to-point
ip address 192.168.10.1 255.255.255.0
frame-relay interface-dlci 18
!
interface BRI0:1.2 point-to-point
ip address 192.168.20.1 255.255.255.0
frame-relay interface-dlci 19
!
interface BRI0:2
no ip address
shutdown

実際に導入し、運用される際には障害解析などの観点により下記の様なコマンドも追加する事を推奨いたします。

service timestamps debug datetime localtime msec
service timestamps log datetime localtime msec
clock timezone JST 9 !
logging buffered 512000 debugging
!
clock calendar-valid

低帯域の回線にて、OSPF などのダイナミックルーティングを使用する際には、ルーティングプロトコルが使用する帯域にも注意してください。

Jun 21, 2006 Document ID: jtac_20060621_4