IP : IP アドレッシング サービス

DHCP でアドレスが配布されるブロードバンド回線への接続設定例

2006 年 1 月 27 日 - 日本オリジナル版
その他のバージョン: PDFpdf | フィードバック

1. ネットワーク構成図

設定の前提となるネットワーク構成図になります。

※ 画像をクリックすると、大きく表示されます。popup_icon

2. システムの前提条件

DHCP 方式を利用するブロードバンド回線接続を提供するサービスにて、Cisco ISR サービス統合型ルータを使用し、インターネットと接続するための設定を行います。

3. 想定する環境

ルータを ADSL モデムなどに接続し、WAN 側の IP アドレスをサービスプロバイダより DHCP で取得するように設定します。LAN 側のネットワークに対してルータが DHCP サーバーとなり DHCP で IP アドレスを配布するようにします。

LAN 側のネットワークに接続された PC-A は、ルータより配布された IP アドレスを利用して、インターネットへのアクセスを行います。またこの時ルータでは LAN 側セグメントのアドレスを PAT(Port Address Translation)により、サービスプロバイダーより配布された WAN 側の IP アドレスに変換します。

4. 必要なハードウェア/ソフトウェア要件

Cisco ISR サービス統合型ルータ シリーズは全てオンボードにて 2FE(もしくは 2GE)を具備します。Cisco ISR シリーズにて本構成が実現可能なハードウェア/ソフトウェアの組み合わせは下記になります。

プラットホーム T トレイン メイントレイン
871 12.4(2)T 以上 N/A
1812J 12.4(2)T 以上 N/A
1841 12.3(8)T 以上 12.4(1)以上
2800 シリーズ
(2801/2811/2821/2851)
12.3(8)T 以上 12.4(1)以上
3800 シリーズ
(3825/3845)
12.3(11)T 以上 12.4(1)以上

本設定例においては、Cisco1812J、IOS12.4(2)T2 を使用しています。

5. サンプルコンフィグレーション

hostname 1812J-A
!
ip dhcp excluded-address 192.168.32.254
!
ip dhcp pool LAN_Client_Pool
network 192.168.32.0 255.255.255.0
default-router 192.168.32.254
domain-name in.cisco.com
dns-server 64.0.0.1

!
interface FastEthernet0
ip address dhcp
ip nat outside

!
interface Vlan1
ip address 192.168.32.254 255.255.255.0
ip nat inside
!
ip route 0.0.0.0 0.0.0.0 dhcp
!
ip nat inside source list 1 interface FastEthernet0 overload
!
access-list 1 permit 192.168.32.0 0.0.0.255
!
end

6. キーとなるコマンドの解説

----------------------------
"ip dhcp pool name"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
ルータ上に DHCP アドレス プールを作成します。続いて、DHCP プール コンフィギュレーションモードを開始します。
----------------------------
"network network-number [ mask | prefix-length ]"
<コマンド種別>
DHCP コンフィグコマンド
<コマンドの機能>
DHCP アドレス プールのネットワークアドレスを定義します。
----------------------------
"default-router address"
<コマンド種別>
DHCP コンフィグコマンド
<コマンドの機能>
DHCP クライアントに割り当てるデフォルトゲートウェイを設定します。
----------------------------
"domain-name domain"
<コマンド種別>
DHCP コンフィグコマンド
<コマンドの機能>
DHCP クライアントのドメイン名を指定します。
----------------------------
"dns-server address"
<コマンド種別>
DHCP コンフィグコマンド
<コマンドの機能>
DHCP クライアントに割り当てる DNS サーバーを指定します。
----------------------------
"ip dhcp excluded-address address"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
DHCP サーバが DHCP クライアントに割り当てる IP アドレスの内、除外する IP アドレスを指定します。
この例では、ルータのアドレスを除外します。
----------------------------
"ip route 0.0.0.0 0.0.0.0 dhcp"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
DHCP サーバから割り当てられたデフォルトゲートウェイを使用します。
----------------------------
"ip address dhcp"
<コマンド種別>
インターフェースコマンド
<コマンドの機能>
IP アドレスを DHCP サーバにより払い出す設定をします。
ルータはこのインターフェースにて DHCP クライアントとして動作します。
----------------------------
"ip nat inside source list 1 interface FastEthernet0 overload"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
プライベート IP アドレスからパブリック IP アドレスへの変換をコントロールします。この例では、"ip nat inside"コマンドが設定されたインタフェース(vlan1=内部セグメント)から"ipnat outside"コマンドが設定されたインタフェース(FastEthernet0=外部セグメント)への変換を定義しています。
overload パラメータを指定することにより、TCP/UDP ポートでコネクションを識別し複数のプライベート IP アドレスで、外部セグメントに接続されたインタフェースに割り当てられた 1 つのパブリック IP アドレスを共有します。(外部から見た場合、送信元アドレスが書き換えられていることになります。) NAT 変換の対象となるパケットは、access-list で設定します。この例では、access-list 1 にマッチするパケットのみを NAT 変換します。access-list 1 では、全ての IP パケットを許可してあるので、この例では社内セグメントの全てのクライアントから外部へのアクセスが可能です。
----------------------------
"ip nat inside/outside"
<コマンド種別>
config-if コマンド
<コマンドの機能>
各インタフェースが、内部のプライベートネットワークに属するのか、または外部のパブリックネットワークに属するのかを設定するために使用します。内部のプライベートネットワークから入ってくるトラフィックは、"ip nat inside source list 1 interface FastEthernet0 overload"コマンドで定義された NAT 変換の対象になります。
----------------------------
"access-list 1 permit 192.168.32.0 0.0.0.255"
<コマンド種別>
グローバルコンフィグレーションコマンド
<コマンドの機能>
アクセスリスト 1 を作成します。LAN 側のネットワークアドレス(192.168.32.0/24)が対象となります。
----------------------------

7. 設定に際しての注意点

クライアントに IP アドレスが払い出されない場合にはクライアントの設定(「IP アドレスを自動的に取得する」になっているかどうか)をご確認下さい。

1812J や 871の様な SW 内蔵のプラットホームまたは HWIC-4ESW/HWIC-9DESW などのスイッチモジュールを使用し、vlan を使用する際には、vlan database コマンドにて追加する vlan を指定する必要があります。

接続するプロバイダーによっては、DHCP の option などによりクライアントを識別し、接続を限定している場合があります。使用する前にプロバイダーの仕様を確認してください。

実際に導入し、運用される際には障害解析などの観点により下記の様なコマンドも追加する事を推奨いたします。

service timestamps debug datetime localtime msec
service timestamps log datetime localtime msec
clock timezone JST 9
!
logging buffered 512000 debugging
!
clock calendar-valid

Jan 27, 2006 Document ID: jtac_20060127_9