音声とユニファイド コミュニケーション : Cisco Unified Communications Manager Express

Cisco Unified Communications Manager Express: SIP 実装ガイド

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

この資料はスタンドアロン Cisco Unified Communications Manager Express な(CME)その使用 SIP 電話を設定するためにステップバイステップの説明を提供したものです。 ドキュメント アウトライン Cisco Unified Communications Manager Express な システムおよび SIP 電話を設定するためのコンフィギュレーションの 4 台の SIP 電話との Cisco Unified Communications Manager Express な システム。

注: しかし資料はこの用紙のスコープの外に Cisco Unity Express と相互運用することを割り当てるようにコンフィギュレーションのステップを Cisco Unified Communications Manager Express Cisco Unity Express 設定あります取り扱っています。 Cisco Unified Communications Manager Express なおよび Cisco Unity Express コンフィギュレーションに関する詳細については Cisco Unified CallManager Express/Cisco Unity Express 設定例を参照して下さい。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のハードウェアのバージョンに基づくものです。

  • Cisco 2801 Cisco IOS によって Cisco Unified Communications Manager Express な 4.2 を実行するか。 ソフトウェア リリース 12.4(11)XW2

  • 9 ポート 2 倍幅 10/100BASE-T イーサネット スイッチ HWIC

  • Cisco 7970 台の SIP 電話

  • Cisco 3911 SIP Phone

この文書に記載されている情報はこれらのファームウェアのバージョンに基づいています:

  • 7970 IP Phone (SIP) — SIP70.8-2-1S

  • 3911 IP Phone (SIP) — SIP3951.8-0-2-9

適切な SIP ファームウェアを各々の Cisco Unified Communications Manager Express なバージョンのために使用するために判別するために Cisco Unified CME および Cisco IOS ソフトウェア バージョン 互換性 マトリックスを参照して下さい。 Cisco Unified Communications Manager Express な 4.2 が使用されるので、Cisco Unified Communications Manager Express な 4.2 仕様リンクを参照して下さい。

SIP phoneloads はこれらの場所からダウンロードすることができます:

両方とも TFTP フォルダの ZIP ファイル解凍した後、TFTPサーバの Cisco Unified Communications Manager Express な フラッシュするにすべてのファームウェアファイルをコピーして下さい。 コピー フラッシュするにすべてのこれらのファイル確かめて下さい。

SIP3951.8-0-2-9.loads
SIP3951.8-0-2-9.zz
DSP3951.0-0-0-1.zz
BOOT3951.0-0-0-9.zz
SIP70.8-2-1S.loads
term70.default.loads
term71.default.loads
apps70.8-0-2-55.sbn
cnu70.8-2-0-55.sbn 
cvm70.sip.8-2-0-55.sbn
dsp70.8-2-0-55.sbn
jar70.sip.8-0-2-25.sbn

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

これらの表はこのセットアップで使用するアドレス方式の輪郭を描きます。

目的 VLAN ネットワーク Interface インターフェイスのアドレス
音声 192 192.168.10.0/24 VLAN 192 192.168.10.1/24
データ 100 10.10.10.0/24 VLAN 100 10.10.10.1/24

プロトコル 電話のタイプ 拡張番号 電話番号外部マスク
SIP 7970 101 4085251001
SIP 7970 102 4085251002
SIP 3911 103 4085251003
SIP 3911 104 4085251004

音声メール パイロット番号 100 AA パイロット 110
MWI On 800 MWI Off 801

注: このセクションで使用されるコマンドに関する詳細を得るために使用して下さい。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/99946/cme-sip-guide01.gif

システム構成

このドキュメントでは、次の設定を使用します。

DHCP を設定して下さい

2 つの別々の DHCP プールを設定することは必要です; IP 電話 使用は音声 DHCPプールおよび PC データ DHCPプールを使用します。 IP 電話必要 Use DHCP オプション 150 TFTPサーバの IP アドレスを提供するため。

静的な IP アドレスのどちらのプールでもデバイスがある場合、これらのアドレスが DHCPプールから競合を当たることを避けるために除かれることを確かめて下さい。 ルータからの IP 電話および PC レシーブが当たるかどれによってが確認するために show ip dhcp binding コマンドを使用できます。

DHCP の設定
ip dhcp excluded-address 10.10.10.1 10.10.10.10
ip dhcp excluded-address 192.168.10.1 192.168.10.10
!
ip dhcp pool data
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1 
!
ip dhcp pool voice
   network 192.168.10.0 255.255.255.0
   option 150 ip 192.168.10.1
   default-router 192.168.10.1

ファーストイーサネットインターフェイスおよびスイッチポートを設定して下さい

このセクションでは、データおよび Voice VLAN 両方のための VLANインターフェイスを設定し、それぞれのVLAN にスイッチポートを割り当てます。

注: VLAN の設定前に、これらのコマンドで VLANデータベースに前の VLAN を追加すること確実でであって下さい:

ファーストイーサネットインターフェイスおよびスイッチポート設定
CME-SIP#vlan database
% Warning: It is recommended to configure VLAN from config mode,
 as VLAN database mode is being deprecated. Please consult user
  documentation for configuring VTP/VLAN in config mode.

CME-SIP(vlan)#vlan 100
VLAN 100 modified:
CME-SIP(vlan)#vlan 192
VLAN 192 modified:
CME-SIP(vlan)#exit
APPLY completed.
Exiting....
CME-SIP#

スイッチポートを音声およびデータVLAN 両方に接続されるために設定して下さい。 IP 電話はスイッチポートに直接接続されるか、またはデータVLAN に割り当てられる IP Phone のスイッチポートに接続される Voice VLAN および PC に自動的に割り当てられます。

DHCP の設定
interface FastEthernet0/3/0
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/1
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
! 
 interface FastEthernet0/3/2
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/3
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
! !
interface Vlan100
description Data VLAN
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan192
description Voice VLAN
 ip address 192.168.10.1 255.255.255.0

TFTP を設定して下さい

この設定は Cisco Unified Communications Manager Express IP 電話を動作することをファームウェア割り当てます。

注: この設定は必須です。

TFTP の設定
tftp-server flash:SIP3951.8-0-2-9.loads
tftp-server flash:SIP3951.8-0-2-9.zz
tftp-server flash:DSP3951.0-0-0-1.zz
tftp-server flash:BOOT3951.0-0-0-9.zz
tftp-server flash:SIP70.8-2-1S.loads
tftp-server flash:term70.default.loads
tftp-server flash:term71.default.loads
tftp-server flash:apps70.8-0-2-55.sbn
tftp-server flash:cnu70.8-2-0-55.sbn 
tftp-server flash:cvm70.sip.8-2-0-55.sbn
tftp-server flash:dsp70.8-2-0-55.sbn
tftp-server flash:jar70.sip.8-0-2-25.sbn

基本的なテレフォニー機能を設定して下さい

音声 サービス パラメータを設定して下さい

SIP から SIP エンドポイントに呼び出しを許可し、SIP レジストラを有効に するためにシステムを設定して下さい。

注: この設定は必須です。

音声 サービス パラメータ 設定
voice service voip
allow-connections sip to sip 

!--- Enable SIP to SIP calls.

sip
registrar server expires max 1200 min 300 

!--- Enable Cisco IOS SIP registrar.

音声 レジスタ グローバル な パラメータを設定して下さい

このセクションでは、音声 レジスタ グローバル な パラメータを設定します。

注: SIP のための音声 レジスタ グローバルコンフィギュレーションは SCCP 電話のための telephony-service コンフィギュレーションパラメータに類似したです。

注: この設定は必須です。

音声 レジスタ グローバル な パラメータ 設定
voice register global                     
 mode cme  

!--- Set Cisco IOS SIP registrar to CME mode.

 source-address 192.168.10.1 port 5060 

!--- Set the source address for phone registration.

 max-dn 20 

!--- Set max extensions.

 max-pool 10 

!--- Set max phones.

 load 7970 SIP7 SIP70.8-2-1S 

!--- Specify phone loads for each phone type.

 load 3911 SIP3951.8-0-2-9 

!--- Specify phone loads for each phone type.

 authenticate register 

!--- Set authentication for phone registration.

 authenticate realm cisco.com 
 tftp-path flash:  

!--- Specify path for tftp files.

 create profile 

!--- Create configuration files for all phones.

 dialplan-pattern 1 4085251... extension-length 3  

!--- Configure dial-plan pattern for the system.

リンクは SIP プロトコルを使用して Cisco Unified Communications Manager Express の IP Phone を(CME)leavingcisco.com 登録するためにプロシージャを説明する Ciscoサポート コミュニティのビデオにここにあります:

CUCME の SIP プロトコルを使用して 79xx シリーズ IP Phone の登録 leavingcisco.com

/image/gif/paws/99946/cme-sip-guide02.gif

Cisco Unity Express への接続を設定して下さい

Cisco Unity Express と相互運用するために必要なダイヤル ピアおよび MWI ephone dns を設定して下さい。 Cisco Unity Express と相互運用するべき Cisco Unified Communications Manager Express のために Cisco Unified Communications Manager Express な ユーザ エージェント続けて設定することは必要(B2BUA)で SIP をです、つまりすべてのシグナリングおよび RTP ストリームが Cisco Unified Communications Manager Express のを通過することを意味します。 この設定が Cisco Unity Express への接続を可能にするために必要となります。

Cisco Unity Express 接続コンフィギュレーション
dial-peer voice 2 voip
    destination-pattern 1.0  

!--- Specify destination-pattern to reach CUE VM and AA.

    session target ipv4:10.1.10.1  

!--- Configure IP address to reach Cisco Unity Express.

    session protocol sipv2
    dtmf-relay sip-notify  

!--- Configure DTMF method to communicate with Cisco Unity Express.

    b2bua  

!--- Enable B2BUA for Cisco Unified Communications Manager Express
!--- for calls to Cisco Unity Express.

    codec g711ulaw 
    no vad

SIP 電話のための MWI を有効に するためにアウトコールしますのための Cisco Unity Express MWI サポートを設定して下さい。

Cisco Unity Express MWI 設定
ephone-dn 11
number 800
mwi on
!
ephone-dn 12
number 801
mwi off

拡張およびパラメータを設定して下さい

ephone のための拡張番号を作成するために音声 レジスタ dn を設定して下さい。 前のネットワーク トポロジでは、ここに与えられるように作成される必要がある 4 つの拡張があります。

注: この設定は必須です。

拡張 設定
voice register dn 1 
name Phone1 

!--- Set display name.

label 4085251001  

!--- Set display label.

number 101 

!--- Set extension number.

call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch  

!--- Allow this number to be watched (presence).

! 
voice register dn 2 
name Phone2
label 4085251002
number 102 
call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch
!
voice register dn 3 
name Phone3
label 4085251003
number 103 
call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch 
! 
voice register dn 4 
name Phone4
label 4085251004
number 104 
call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch

SIP Phone を設定して下さい

各 SIP Phone のための音声 レジスタ プール パラメータを設定して下さい。

注: SIP 電話のための音声 レジスタ プールは SCCP 電話のための ephone と同一です。

注: この設定は必須です。

音声 レジスタ プール パラメータ 設定
voice register pool  3
 id mac 001A.A11B.500E  

!--- Specify phone mac-address.

 type 3911  

!--- Specify phone type.

 number 1 dn 3  

!--- Assign button 1 dn tag 3.

 dtmf-relay sip-notify  

!--- Configure dtmf-relay sip-notify to work 
!--- with Cisco Unity Express.

 codec g711ulaw  

!--- Specify codec.

 username user1 password cisco  

!--- Configure username and password for SIP registrar.

注: DTMF における複数の方式は Cisco Unity Express の音声メール ボックスがある音声 レジスタ プールの下で、各 SIP Phone のために、設定します dtmf-relay 一口呼出を設定することができますが。

configure パラメータを進めました

このセクションでは、使用中ランプ フィールド(BLF)ステータスで存在のような SIP 電話のための高度パラメータを設定します。 BLF の存在は SCCP 電話か SIP Phone が電話間のプレゼンス情報を有効に する別の SIP 拡張のステータスを監察するようにします。

注: これはオプショナルコンフィギュレーションです。

これらの電話は Cisco Unified Communications Manager Express の SIP 存在サービスをサポートします。

制約事項

BLF Call-List
Supported only on Cisco Unified IP Phone 7941G, 7941GE, 7961G, 7961GE, 7970G, and 7971GE.
BLF Speed-Dial
Supported only on Cisco Unified IP Phone 7941G, 7941GE, 7961G, 7961GE, 7970G, and 7971GE.

内部行のためのイネーブル存在

ルータが内部監視および SIP トランクからの着信存在要求を受け入れることを可能にするためにこれらのステップを完了して下さい。

1.  enable 
2.  configure terminal 
3.  sip-ua 
4.  presence enable 
5.  exit 
6.  presence 
7.  max-subscription number 
8.  presence call-list 
9.  end
内部行のための存在を有効に して下さい
Presence  

!--- Enable presence service.

 presence call-list  

!--- Enable BLF monitoring of directory numbers.

 max-subscription 120  

!--- Configure max number watched sessions.

!
sip-ua
 presence enable  

!--- Enable router to accept incoming presence request.

監視されるべきディレクトリ番号を有効に して下さい

Cisco Unified Communications Express ルータに登録されている電話が監察されるディレクトリ番号によって関連付けられる行を使用可能にするためにこれらのステップを完了して下さい。 行は presentity および電話が BLF コール リストおよび BLG speed-dial 機能を通って行ステータスを定期講読できると同時に有効に なります。 監視される行がある場合がある電話の種類に制約事項がありません; あらゆる IP Phone またはサポートされた音声ゲートウェイのアナログ式電話のどの行でも presentity である場合もあります。

1.  enable 
2.  configure terminal 
3.  voice register dn dn-tag 
4.  number number 
5.  allow watch 
6.  end
監視されるべきディレクトリ番号を有効に して下さい
voice register dn  1
 number 101
 allow watch  

!--- Allow this number to be watched.

 name Phone1
 label 4085251001

注: 監視される必要がある各拡張番号のためのこの設定を繰り返し行なって下さい。 このステップは既に時最初構成された音声 レジスタ dns 実行されました。

速度ダイヤルのための BLF ステータスを監視し、リストを呼出すことを SIP Phone が可能にして下さい

監視は BLF speed-dial および BLF コール リスト存在機能を通して内部および外部ディレクトリ番号(presentities)によって関連付けられる行のステータスを監視できます。 SIP Phone の BLF 通知 機能を有効に するためにこれらのステップを完了して下さい:

1.  enable 
2.  configure terminal 
3.  voice register pool pool-tag 
4.  number tag dn dn-tag 
5.  blf-speed-dial tag number label string 
6.  presence call-list 
7.  exit 
8.  voice register global 
9.  mode cme 
10.  create profile 
11.  restart 
12.  end
速度ダイヤルのための BLF ステータスを監視し、リストを呼出すことを SIP Phone が可能にして下さい
voice register pool  1
 id mac 0016.47CD.9BD7
 type 7970
 number 1 dn 1
 presence call-list  

!--- Enable this phone to have presence call list.

 dtmf-relay sip-notify  
 username user1 password cisco
 codec g711ulaw
 blf-speed-dial 2 102 label "Phone2"  

!--- Enable this line to monitor extension 1002.

 blf-speed-dial 3 103 label "3911-1"  

!--- Enable this line to monitor extension 1003.

 blf-speed-dial 4 104 label "3911-2"  

!--- Enable this line to monitor extension 1004.

注:  SIP Phone 設定を変更する度に再始動を行うことを忘れないでいて下さい。

注: SIP 存在サービスのコンフィギュレーションに関する詳細については存在サービスを設定する方法を参照して下さい。

平行ハント グループを設定して下さい

このセクションでは、エクステンション 102、103、および 104 は平行ハント グループに割り当てられます。 平行ハント グループはグループのすべてのメンバーを同時に鳴らすハント グループです。

平行ハント グループ 設定
voice hunt-group 1
pilot 180  

!--- Configure Hunt group pilot number.

list 102, 103, 104  

!--- Specify members in hunt-group.

final 100  

!--- Specify final number as Voicemail Pilot.

CME- SIP 実装: 設定例

このセクションはスタンドアロン Cisco Unified Communications Manager Express の SIP 電話を使用する設定するためにサンプル全体設定を提供します。

CME- SIP 実装: 設定例
CME-SIP#show version
Cisco IOS Software, 2801 Software (C2801-IPVOICE-M), Version 12.4(11)XW2, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Mon 02-Jul-07 19:10 by prod_rel_team

ROM: System Bootstrap, Version 12.3(8r)T6, RELEASE SOFTWARE (fc1)

CME-SIP uptime is 18 hours, 55 minutes
System returned to ROM by reload at 17:01:34 UTC Wed Oct 3 2007
System image file is "flash:c2801-ipvoice-mz.124-11.XW2.bin"

Cisco 2801 (revision 4.1) with 235520K/26624K bytes of memory.
Processor board ID FHK084510HS
11 FastEthernet interfaces
1 terminal line
2 Voice FXO interfaces
3 DSPs, 48 Voice resources
1 cisco service engine(s)
DRAM configuration is 64 bits wide with parity disabled.
191K bytes of NVRAM.
62720K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

CME-SIP#show running-config
Building configuration...

Current configuration : 6227 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-SIP
!
boot-start-marker
boot-end-marker
!
logging buffered 999999
no logging console
enable password cisco
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1 10.10.10.10
ip dhcp excluded-address 192.168.10.1 192.168.10.10
!
ip dhcp pool data
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1 
!
ip dhcp pool voice
   network 192.168.10.0 255.255.255.0
   option 150 ip 192.168.10.1 
   default-router 192.168.10.1 
!
!
no ip domain lookup
multilink bundle-name authenticated
!
!
!
voice service voip 
 allow-connections sip to sip
 sip
  registrar server expires max 1200 min 300
!
!
!
!
!
voice register global
 mode cme
 source-address 192.168.10.1 port 5060
 max-dn 20
 max-pool 10
 load 7970 SIP70.8-2-1S
 load 3911 SIP3951.8-0-2-9
 authenticate register
 authenticate realm cisco.com
 voicemail 100
 tftp-path flash:
 create profile sync 0000589556325309
!
voice register dn  1
 number 101
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone1
 label 4085251001
!
voice register dn  2
 number 102
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone2
 label 4085251002
!
voice register dn  3
 number 103
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone3
 label 4085251003
!
voice register dn  4
 number 104
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone4
 label 4085251004
!
voice register pool  1
 id mac 0016.47CD.9BD7
 type 7970
 number 1 dn 1
 presence call-list
 dtmf-relay sip-notify
 username user1 password cisco
 codec g711ulaw
 blf-speed-dial 2 102 label "Phone2"
 blf-speed-dial 3 103 label "3911-1"
 blf-speed-dial 4 104 label "3911-2"
!
voice register pool  2
 id mac 0014.6948.1D52
 type 7970
 number 1 dn 2
 dtmf-relay sip-notify
 username user2 password cisco
 codec g711ulaw
!
voice register pool  3
 id mac 001A.A11B.4FCE
 type 3911
 number 1 dn 3
 dtmf-relay sip-notify
 username user3 password cisco
 codec g711ulaw
!
voice register pool  4
 id mac 001A.A11B.500E
 type 3911
 number 1 dn 4
 dtmf-relay sip-notify
 username user4 password cisco
 codec g711ulaw
!
voice hunt-group 1 parallel
 final 100
 list 102,103,104
 pilot 180 
!
!
!
!
voice-card 0
!
!
!
archive
 log config
 hidekeys
!
!
!
interface Loopback0
 ip address 10.1.10.2 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Service-Engine0/0
 ip unnumbered Loopback0
 service-module ip address 10.1.10.1 255.255.255.0
 service-module ip default-gateway 10.1.10.2
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/3/0
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/1
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/2
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/3
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/4
 description Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/5
 description Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/6
 description Phone
 switchport access vlan 192
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/7
 description Phone
 switchport access vlan 192
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/8
 switchport access vlan 192
!
interface Vlan1
 no ip address
!
interface Vlan100
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan192
 ip address 192.168.10.1 255.255.255.0
!
ip route 10.1.10.1 255.255.255.255 Service-Engine0/0
!
!
ip http server
!
!
!
tftp-server flash:BOOT3951.0-0-0-9.zz
tftp-server flash:SIP3951.8-0-2-9.zz
tftp-server flash:DSP3951.0-0-0-1.zz
tftp-server flash:SIP3951.8-0-2-9.loads
tftp-server flash:SIP70.8-2-1S.loads
tftp-server flash:term70.default.loads
tftp-server flash:term71.default.loads
tftp-server flash:apps70.8-0-2-55.sbn
tftp-server flash:cnu70.8-2-0-55.sbn 
tftp-server flash:cvm70.sip.8-2-0-55.sbn
tftp-server flash:dsp70.8-2-0-55.sbn
tftp-server flash:jar70.sip.8-0-2-25.sbn
!
control-plane
!
!
!
voice-port 0/1/0
!
voice-port 0/1/1
!
!
!
!
!
dial-peer voice 2 voip
 description ** cue voicemail pilot number **
 translation-profile outgoing PSTN_CallForwarding
 destination-pattern 100
 b2bua
 session protocol sipv2
 session target ipv4:10.1.10.1
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 3 voip
 description ** cue auto attendant number **
 translation-profile outgoing PSTN_CallForwarding
 destination-pattern 110
 b2bua
 session protocol sipv2
 session target ipv4:10.1.10.1
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
!
presence
 presence call-list
 max-subscription 120
!
sip-ua 
 presence enable
!
!
telephony-service
 max-ephones 24
 max-dn 72
 ip source-address 10.100.100.10 port 2000
 system message CME1
 time-zone 5
 voicemail 100
 max-conferences 8 gain -6
 call-forward pattern .T
 web admin system name cisco secret 5 $1$4FC/$CMer08o/KELFlVrhL5QRO0
 dn-webedit 
 time-webedit 
 transfer-system full-blind
 transfer-pattern 9.T
!
!
ephone-dn  11
 number 800
 mwi on
!
!
ephone-dn  12
 number 801
 mwi off
!
!
line con 0
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end

CME-SIP#

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

SIP IP Phone はダイヤルトーンを聞きません

SIP IP 電話のためのコモン コーズはダイヤルトーンを聞けない同じ拡張を用いるもう一つの電話があることです。 Cisco Unified Communications Manager Express な 4.2 現在で、共用 ラインは SIP 電話でサポートされません。 従って、SIP 電話は複数の電話間の同じ拡張を共有できません。 SIP Phone が適切な拡張と提供されることをさらに、確かめて下さい。

これらが発生することをこの問題を解決するために、確かめて下さい:

  • SIP Phone に設定される拡張があり、拡張は SIP Phone で示します。

  • 同じ拡張で設定されるもう一つの SIP または SCCP 電話がありません。

IP Phone は最新版ファームウェアにアップグレードできません

電話をアップグレードできる障害のための可能性が高い原因によっては Cisco Unified Communications Manager Express な フラッシュするか抜けた tftp-server コマンドに置かれるファームウェアファイルが抜けています。

この問題を解決するためにこれらのステップを試して下さい:

  • 必要なファームウェアファイルがフラッシュするで保存されることを確認して下さい。 dir flash を行って下さい: ファイルがあるようにフラッシュするを確認するために命じて下さい。

  • 正しいファームウェアを反映するために OS79XX.TXT ファイルをアップデートしたかどうか確認して下さい。 79XX 電話は適切なファームウェアをロードし、SCCP から SIP に変更するためにこのファイルをチェックします。

  • 正しい tftp-server 文が各ファームウェアファイルのために追加されることを確認して下さい。 設定 TFTP セクションを参照して下さい。

  • グローバル な各タイプの SIP Phone のために音声 レジスタの下の load コマンドが追加されることを確かめて下さい。 設定音声 レジスタ グローバル な パラメータ セクションを参照して下さい。

更に解決するために、電話が Cisco Unified Communications Manager Express な フラッシュするから適切な電話負荷を得られるかどうか見るためにこれらのデバッグを収集して下さい。

Debug tftp events

電話を提供することが不可能

提供できないことのための可能性が高い原因は電話電話に TFTPサーバ オプションの適切な IP アドレスがないことですです。

  • 電話が IP アドレスおよび適切な TFTP サーバ の IP アドレスを受け取ることを確認して下さい。

  • すべての適切な音声 レジスタ グローバルコマンドが追加されることを確かめて下さい。 設定音声 レジスタ グローバル な パラメータ セクションを参照して下さい。

  • 音声 レジスタ プール設定の下の正しい MAC アドレスを使用することを確認して下さい。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 99946