Cisco インターフェイスとモジュール : Cisco ネットワーク モジュール

EtherSwitch ネットワーク モジュール(ESW)の設定例

2007 年 3 月 19 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2007 年 3 月 19 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      関連製品
      表記法
EtherSwitch モジュール:概念
設定
      ネットワーク ダイアグラム
      設定例
      VLAN インターフェイスの設定
      VTP、トランク、ポート チャネル、およびスパニングツリーの設定
      アクセス ポートの設定
      音声ポートの設定
      Quality of Service(QoS)の設定
確認
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、Integrated Service Router(ISR)に取り付けられる EtherSwitch ネットワーク モジュールの設定例を紹介しています。 ただしこのドキュメントでは、EtherSwitch サービス モジュールの設定例については説明しません。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS(R) ソフトウェア リリース 12.4 以降が稼動する Cisco 2800 シリーズ ルータ

  • NM-16ESW-PWR= 16 ポート 10/100 EtherSwitch ネットワーク モジュール(NM)

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

関連製品

この設定は、次のバージョンのハードウェアとソフトウェアにも使用できます。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

EtherSwitch モジュール:概念

Cisco ISR で使用できる EtherSwitch モジュールには次の 2 種類があります。

  • EtherSwitch ネットワーク モジュール(ESW)

  • EtherSwitch サービス モジュール(ES)

ESW モジュールは、ルータの IOS により設定されます。 これらのモジュールでは独立したソフトウェアは実行されません。 ソフトウェアはホスト ルータの IOS に統合されています。 VLAN の作成や、VLAN、スパニングツリー、VLAN Trunking Protocol(VTP; VLAN トランキング プロトコル)などの設定は、ホスト ルータから行えます。 またルータでは、フラッシュへの VLAN データベース ファイル(vlan.dat)の格納も行います。 このドキュメントでは、ESW モジュールの設定例を紹介しています。

ES モジュールには、ホスト ルータのリソースとは独立して動作する、独自のプロセッサ、スイッチング エンジンおよびフラッシュ メモリがあります。 ES モジュールをルータに取り付けると、ホスト ルータから ES モジュールにコンソール接続できます。 ここで、ES モジュールから、VLAN を作成や、VLAN、スパニングツリー、VTP など設定を行えます。 ES モジュールは Catalyst 3750 プラットフォームをベースとしています。

設定

このセクションでは、このドキュメントで説明する機能を設定するための情報を提供します。

注:このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

このドキュメントでは、次のネットワーク構成を使用しています。

ether-switch-nm-config-1.gif

ネットワーク ダイアグラム
※ 画像をクリックすると、大きく表示されます。

設定例

このドキュメントでは、次の設定を使用します。

VLAN インターフェイスの設定

デフォルトでは、すべてのポートが VLAN1 に属します。 VLAN を作成できるのは、VLAN データベース モードからだけです。 VLAN データベース モードから VLAN が作成されると、vlan.dat ファイルが作成され、ルータのフラッシュ ファイル システムに格納されます。 show vlan-switch コマンドを使用すると VLAN を表示できます。 この例では、Dynamic Host Configuration Protocol(DHCP; ダイナミック ホスト コンフィギュレーション プロトコル)サーバ(172.16.10.20)が VLAN 10 に位置しています。 DHCP サーバからこれらの VLAN に位置しているデバイスへ IP アドレスを取得するため、VLAN 10 を除くすべての VLAN 上で ip helper-address コマンドが設定されています。

Router1

Create VLANs


Router1#vlan database
Router1(vlan)#vlan 10
VLAN 10 added:
    Name: VLAN0010
Router1(vlan)#vlan 51
VLAN 51 added:
    Name: VLAN0051
Router1(vlan)#vlan 50
VLAN 50 added:
    Name: VLAN0050
Router1(vlan)#vlan 100
VLAN 100 added:
    Name: VLAN0100
Router1(vlan)#vlan 200
VLAN 200 added:
    Name: VLAN0200
Router1(vlan)#exit
APPLY completed.
Exiting....
Router1#



Configure VLANs


Router1(config)#interface vlan 10
Router1(config-if)#ip address 172.16.10.1 255.255.255.0

Router1(config-if)#interface vlan 50
Router1(config-if)#ip address 172.16.50.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 51
Router1(config-if)#ip address 172.16.51.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 100
Router1(config-if)#ip address 172.16.100.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 200
Router1(config-if)#ip address 172.16.200.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1#show vlan-switch

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/2, Fa1/3, Fa1/4, 
                                                Fa1/5, Fa1/6, Fa1/7, Fa1/8,
                                                Fa1/9, Fa1/10, Fa1/11, Fa1/12
                                                Fa1/13, Fa1/14, Fa1/15
10   VLAN0010                         active    
50   VLAN0050                         active    
51   VLAN0051                         active    
100  VLAN0100                         active    
200  VLAN0200                         active    
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
10   enet  100010     1500  -      -      -        -    -        0      0   
50   enet  100050     1500  -      -      -        -    -        0      0   
51   enet  100051     1500  -      -      -        -    -        0      0   
100  enet  100100     1500  -      -      -        -    -        0      0   

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
200  enet  100200     1500  -      -      -        -    -        0      0   
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0   
1005 trnet 101005     1500  -      -      1        ibm  -        0      0   

VTP、トランク、ポート チャネル、およびスパニングツリーの設定

デフォルトでは、VTP モードはサーバで、ドメイン名は空白です。 VTP を設定できるのは、VLAN データベース モードからだけです。 サポートされている唯一のスパニングツリーのモードは PVST+ です。 デフォルトのトランク カプセル化は dot1q です。 指定の VALN のみを許可するようトランク ポートを設定した場合、Bad VLAN allowed list というエラー メッセージが表示される場合があります。 この場合、カスタム VLAN リストとともに、デフォルトの VLAN 1 〜 2、1002 〜 1005 を許可する必要がある場合があります。 またこのため、トランクの不一致を避けるために、このトランク ポートに接続されている隣接するスイッチ上でデフォルトの VLAN とカスタム VLAN を許可する必要もあります。

Router1

VTP Configuration


Router1#vlan database
Router1(vlan)#vtp transparent
Setting device to VTP TRANSPARENT mode.
Router1(vlan)#vtp domain LAB
Changing VTP domain name from NULL to LAB
Router1(vlan)#exit
APPLY completed.
Exiting....



Spanning-Tree Configuration


Router1(config)#spanning-tree vlan 1 root primary
Router1(config)#spanning-tree vlan 10 root primary
Router1(config)#spanning-tree vlan 50 root primary
Router1(config)#spanning-tree vlan 51 root primary
Router1(config)#spanning-tree vlan 100 root primary
Router1(config)#spanning-tree vlan 200 root primary



Trunk and Port Channel Configuration


Router1(config)#interface port-channel 1
Router1(config-if)#switchport mode trunk

!--- dot1q はデフォルトのカプセル化です。

Router1(config-if)#switchport trunk allowed vlan 100,200
Command rejected: Bad VLAN allowed list. You have to include all default vlans,
e.g. 1-2,1002-1005.
Command rejected: Bad VLAN allowed list. You have to include all default vlans,
e.g. 1-2,1002-1005.
Router1(config-if)#switchport trunk allowed vlan 1,1002-1005,100,200
Router1(config-if)#exit

Router1(config)#interface range fastEthernet 1/0 - 1
Router1(config-if-range)#switchport mode trunk

!--- dot1q はデフォルトのカプセル化です。

Router1(config-if-range)#switchport trunk allowed vlan 1,1002-1005,100,200
Router1(config-if-range)#channel-group 1 mode on
Router1(config-if-range)#exit

Access1

Access1 Switch Configuration


Access1(config)#vlan 100,200
Access1(config-vlan)#exit

Access1(config)#vtp mode transparent
Setting device to VTP TRANSPARENT mode.

Access1(config)#vtp domain LAB
Changing VTP domain name from NULL to LAB

Access1(config)#interface port-channel 1
Access1(config-if)#switchport trunk encapsulation dot1q
Access1(config-if)#switchport mode trunk
Access1(config-if)#switchport trunk allowed vlan 1,1002-1005,100,200
Access1(config-if)#exit

Access1(config)#interface range FastEthernet 0/1 - 2
Access1(config-if-range)#switchport trunk encapsulation dot1q
Access1(config-if-range)#switchport mode trunk
Access1(config-if-range)#switchport trunk allowed vlan 1,1002-1005,100,200
Access1(config-if-range)#channel-group 1 mode on
Access1(config-if-range)#exit

Router1#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 52
Number of existing VLANs        : 10
VTP Operating Mode              : Transparent
VTP Domain Name                 : LAB
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x8D 0x71 0x37 0x29 0x6C 0xB0 0xF2 0x0E
Configuration last modified by 172.22.1.197 at 2-20-07 22:31:06
Router1#
Router1#show interface fastethernet 1/0 trunk

Port      Mode         Encapsulation  Status        Native vlan
Fa1/0     on           802.1q         trunk-inbndl  1
                                      (Po1)

Port      Vlans allowed on trunk
Fa1/0     1,100,200,1002-1005

Port      Vlans allowed and active in management domain
Fa1/0     1,100,200

Port      Vlans in spanning tree forwarding state and not pruned
Fa1/0     1,100,200
Router1#show spanning-tree summary
Root bridge for: VLAN1, VLAN10, VLAN50, VLAN51, VLAN100, VLAN200.
PortFast BPDU Guard is disabled
UplinkFast is disabled
BackboneFast is disabled

Name                 Blocking Listening Learning Forwarding STP Active
-------------------- -------- --------- -------- ---------- ----------
VLAN1                0        0         0        1          1
VLAN10               0        0         0        1          1
VLAN50               0        0         0        1          1
VLAN51               0        0         0        1          1
VLAN100              0        0         0        1          1
VLAN200              0        0         0        1          1
-------------------- -------- --------- -------- ---------- ----------
             6 VLANs 0        0         0        6          6

アクセス ポートの設定

アクセス ポートの設定は、標準的な LAN スイッチ設定に似ています。

Router1

Port for Server Configuration


Router1(config)#interface fastEthernet 1/2
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 10
Router1(config-if)#spanning-tree portfast
Router1(config-if)#speed 100
Router1(config-if)#duplex full
Router1(config-if)#exit



Port for Printer Configuration


Router1(config)#interface fastethernet 1/3
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 51
Router1(config-if)#spanning-tree portfast
Router1(config-if)#exit

音声ポートの設定

音声ポートの設定は、標準的な LAN スイッチ設定に似ています。

Router1

Configure the port for Voice

Router1(config)#interface fastethernet 1/4
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 51
Router1(config-if)#switchport voice vlan 50
Router1(config-if)#spanning-tree portfast
Router1(config-if)#mls qos trust cos

Quality of Service(QoS)の設定

ESW モジュールでの、デフォルトの QoS 設定を次に示します。

Router1#show wrr-queue bandwidth
WRR Queue  :   1   2   3   4

Bandwidth  :   1   2   4   8
wrr-queue bandwidth is disabled

Router1#show wrr-queue cos-map
CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  2  3  3  4  4
wrr-queue cos map is disabled

Router1#show mls qos maps cos-dscp
   Cos-dscp map:
        cos:   0  1  2  3  4  5  6  7
     --------------------------------
       dscp:   0  8 16 26 32 46 48 56

Router1#show mls qos maps dscp-cos

   Dscp-cos map:
       dscp:   0  8 10 16 18 24 26 32 34 40 46 48 56
     -----------------------------------------------
        cos:   0  1  1  2  2  3  3  4  4  5  5  6  7

続くセクションで下記の設定の説明を行います。

wrr キューを設定

レイヤ 2 スイッチ ポートではポートベースの QoS 設定はできません。 キューを設定できるのは、グローバル設定からだけです。 設定例では、4 つの異なるキューに CoS 値をマッピングしています。 パケットがスイッチ ポートから直接レイヤ 2 エンジンに入った場合、そのパケットは動的な 32 MB の共有メモリ バッファにある 4 つのキューのいずれかに配置されます。 音声 VLAN 上の Cisco IP Phone から着信する音声ベアラ パケットは、IP Phone により生成される 802.1p 値(CoS 5)に基づいて、自動的に最高のプライオリティ(Queue 4)に配置されます。 続いてキューには、Weighted Round Robin(WRR; 加重ラウンド ロビン)に基づいてサービスが提供されます。 CoS または Type of Service(ToS; タイプ オブ サービス)3 を使用する制御トラフィックは、Queue 3 に配置されます。

Router1
Router1(config)#wrr-queue cos-map 1 0 1
Router1(config)#wrr-queue cos-map 2 2
Router1(config)#wrr-queue cos-map 3 3 4
Router1(config)#wrr-queue cos-map 4 5 6 7

!--- wrr-queue cos-map <queue-number> <cos values separated by space>

Router(config)#wrr-queue bandwidth 1 16 64 255

!--- wrr-queue bandwidth <Weight of Queue1> <Weight of Queue2> 
!--- <Weight of Queue3> <Weight of Queue4>


Queue のパラメータを確認します。

Router1#show wrr-queue bandwidth
WRR Queue  :   1   2   3   4

Bandwidth  :   1   2   4   8 

!--- デフォルトの値


WRR Queue  :   1   2   3   4

Bandwidth  :   1  16  64 255 

!--- 設定された値


Router1#show wrr-queue cos-map
CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  2  3  3  4  4  

!--- デフォルトの値

CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  3  3  4  4  4  

!--- 設定された値

次の表に、設定後のキューの番号、CoS 値および各キューの重み付けを示します。

キュー番号 CoS 値 重み付け

1

0 1

1

2

2

16

3

3 4

64

4

5 6 7

255


CoS を信頼するようにポートを設定

Router1
Router1(config)#interface fastethernet1/4
Router1(config-if)#mls qos trust cos

!--- IP Phone からのフレームの CoS 値を信頼します。

Router1(config-if)#mls qos cos override

!--- PC からのフレームの CoS 値を 0 にリセットします。

Router1(config-if)#exit

Router1(config)#interface range fastEthernet 1/0 - 1
Router1(config-if-range)#mls qos trust cos

!--- このトランク リンクからのフレームの CoS 値を信頼します。

Router1(config-if-range)#exit

ポリサーを設定

このセクションでは、FTP トラフィックを 5 Mbps に制限するための、インターフェイス fa1/2 上のポリサー設定を示します。

Router1
Router1(config)#ip access-list extended ACTIVE-FTP
Router1(config-ext-nacl)#permit tcp any any eq ftp
Router1(config-ext-nacl)#permit tcp any any eq ftp-data
Router1(config-ext-nacl)#exit
Router1(config)#class-map ACTIVE-FTP-CLASS
Router1(config-cmap)#match class ACTIVE-FTP
Router1(config-cmap)#exit
Router1(config)#policy-map ACTIVE-FTP-POLICY
Router1(config-pmap)#class ACTIVE-FTP-CLASS
Router1(config-pmap-c)#police 5000000 conform-action transmit exceed-action drop
Router1(config-pmap-c)#exit
Router1(config-pmap)#exit
Router1(config)#interface fastethernet1/2
Router1(config-if)#service-policy input ACTIVE-FTP-POLICY
Router1(config-if)#exit

ESW モジュールのポリサー設定にはいくつかの制限があります。 これらは、次のとおりです。

  • 出方向の ACL 分類を持つポリシー マップはサポートされておらず、また service-policy input policy-map-name interface 設定コマンドを使用してインターフェイスに添付することはできません。

  • ポリシー マップでは、class-default という名前のクラスはサポートされていません。 スイッチでは、class class-default policy-map 設定コマンドにより定義されるポリシー マップに基づいたトラフィックのフィルタリングは行われません。

  • ESW インターフェイスの入力に対してのみ、policy-map を作成し、適用することが可能です。 また policy-map ではポリサーだけがサポートされています。

    Router1#show policy-map
      Policy Map FINANCE-POLICY
        Class FINANCE-CLASS
          set cos 4
    Router1(config)#interface fastethernet1/4
    Router1(config-if)#service-policy input FINANCE-POLICY
    %Error: FastEthernet1/4 Service Policy Configuration Failed.Only Police Action S
    upported
    
  • VLAN または Switched Virtual Interface(SVI; スイッチ仮想インターフェイス)レベルでは、ポリシングはサポートされていません。

確認

現在のところ、この設定を確認する手順はありません。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報