サービス品質(QoS) : QoS ポリシング

イーサネット サブインターフェイスへの QoS 機能の適用

2005 年 8 月 10 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
サービス ポリシーの適用
      階層型ポリシーの適用
クラスベースのシェーピングの設定
      設定
確認
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、Class-Based Weighted Fair Queueing(CBWFQ; クラスベース均等化キューイング)および他の Cisco IOS(R) のソフトウェアベースの Quality of Service(QoS)機能をイーサネットのサブインターフェイスに適用する方法について説明しています。 イーサネット サブインターフェイスは、Cisco IOS 内の論理インターフェイスです。 モジュラ QoS コマンドライン インターフェイス(CLI)(MQC)を使用すれば、サービス ポリシーを作成してイーサネット サブインターフェイスに適用できます。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS ソフトウェア 12.2(2)T

  • ファースト イーサネット ネットワーク モジュールを搭載した Cisco 2620 ルータ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

サービス ポリシーの適用

一般に、どこにポリシーを適用するかは、ポリシーでアクティブにする QoS 機能によって異なります。 イーサネット サブインターフェイスでは次の機能がサポートされています。

  • クラスベース ポリシング:police コマンドを使用してインターフェイスとサブインターフェイスの両方にポリシーを適用する場合、クラスに一致するトラフィックに対しては、サブインターフェイスのポリサーだけが有効になります。 詳細については、『トラフィック ポリシング』を参照してください。

  • クラスベース マーキング:詳細については、『分類の概要』を参照してください。

  • クラスベース シェーピング:詳細については、『クラスベースのシェーピングの設定』を参照してください。

  • クラスベース キューイング:イーサネット サブインターフェイスの場合、キューイングは特殊なケースです。 詳細については、次の記述を参照してください。

インターフェイスから送出する必要があるパケットの数がそのインターフェイスの出力レートを超えると、ルータではパケットのキューイングが開始されます。そして超過したパケットがキューイングされます。 送信待機パケットにはキューイング方式を適用できます。

Cisco IOS の論理インターフェイスでは本来、輻輳状態はサポートされておらず、キューイング方式を適用するサービス ポリシーの直接適用はサポートされていません。 そのため、まず、Generic Traffic Shaping(GTS; ジェネリック トラフィック シェーピング)かクラスベース シェーピングを使用してサブインターフェイスにシェーピングを適用する必要があります。 詳細については、『ポリシングとシェーピング』を参照してください。

キューイングを適用するサービス ポリシーをシェーピングを適用せずにイーサネット サブインターフェイスに設定すると、次のログメッセージがルータに表示されます。

router(config)# interface ethernet0/0.1
router(config-subif)# service-policy output test
 CBWFQ : Not supported on subinterfaces

ギガビット イーサネット サブインターフェイスの場合にも同じルールが適用されることに注意してください。

c7400(config)# interface gig0/0.1
c7400(config-subif)# service-policy ou
c7400(config-subif)# service-policy output outFE
  CBWFQ : Not supported on subinterfaces

つまり、親のレベルで shape コマンドを使用して階層型ポリシーを設定する必要があります。 より低位のレベルでは、CBWFQ の場合は bandwidth コマンド、Low Latency Queueing(LLQ; 低遅延キューイング)の場合は priority コマンドを使用します。 クラスベース シェーピングは出力レートを制限するので、論理サブインターフェイスでの輻輳状態を引き起こすと想定できます。 次に、サブインターフェイスで「バックプレッシャ」が適用され、シェイパで保留されている過剰パケットのキューイングが Cisco IOS により開始されます。

階層型ポリシーの適用

階層型ポリシーを適用するには、次の手順を実行します。

  1. キューイング メカニズムを設定する子または下位のポリシーを作成します。 次の例では、priority コマンドを使用して LLQ を設定し、bandwidth コマンドを使用して CBWFQ を設定しています。 詳細については、『輻輳管理の概要』を参照してください。

    policy-map child 
     class voice 
      priority 512
    
  2. クラスベース シェーピングを適用する親またはトップレベルのポリシーを作成します。 子のクラスのアドミッション コントロールは親のクラスのシェーピング レートに基づいて行われるので、親のポリシー下のコマンドとして子のポリシーを適用します。

    policy-map parent
     class class-default 
      shape average 2000000 
      service-policy child 
    
  3. 親のポリシーをサブインターフェイスに適用します。

    interface ethernet0/0.1
     service-policy parent 
    

クラスベースのシェーピングの設定

このセクションでは、このドキュメントで説明する機能を設定するための情報を提供します。

注:このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

設定

ルータ 2620A
hostname 2620A 
! 
ip cef 
! 
class-map match-any dscp46 
 match ip dscp 46 
class-map match-all telnet_ping_snmp 
 match access-group 150 
class-map match-all http 
 match access-group 154 
class-map match-all pop3_smtp 
 match access-group 153 
! 
! 
policy-map voice_traffic 
 class dscp46 
  shape average 30000 10000 
 class telnet_ping_snmp 
  shape average 20000 15440 
 class pop3_smtp 
  shape average 20000 15440 
 class http 
  shape average 20000 15440 
! 
interface FastEthernet0/0 
 ip address 10.10.247.2 255.255.255.0 
 duplex auto 
 speed auto 
! 
interface FastEthernet0/0.1 
 encapsulation dot1Q 1 native 
 ip address 10.1.1.1 255.255.255.0 
 service-policy output voice_traffic

確認

このセクションでは、設定が正しく動作していることを確認するために使用できる情報を提供します。

特定の show コマンドは、アウトプットインタープリタ登録ユーザ専用)でサポートされています。このツールを使用すると、show コマンド出力を分析できます。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

  • show policy-map {policy name}:指定されたサービス ポリシー マップのすべてのクラスの設定を表示します。

    2620A# show policy-map voice_traffic 
    Policy Map voice_traffic 
    Class dscp46 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 30000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 10000 
    Class telnet_ping_snmp 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 20000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 15440 
    Class pop3_smtp 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 20000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 15440 
    Class http 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 20000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 15440 
    
    2620A# show policy-map voice_traffic class dscp46 
    Class dscp46 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 30000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 10000
    
  • show policy-map interface fast:指定されたサービス ポリシー マップのすべてのクラスの一致カウンタを表示します。

    2620A# show policy-map interface fa0/0.1 
    FastEthernet0/0.1 
    Service-policy output: voice_traffic 
    Class-map: dscp46 (match-any) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: ip dscp 46 
    0 packets, 0 bytes 
    5 minute rate 0 bps 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    30000     2500   10000     10000     333       1250      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: telnet_ping_snmp (match-all) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: access-group 150 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    20000     3860   15440     15440     772       1930      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: pop3_smtp (match-all) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: access-group 153 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    20000     3860   15440     15440     772       1930      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: http (match-all) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: access-group 154 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    20000     3860   15440     15440     772       1930      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: class-default (match-any) 
    926 packets, 88695 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: any
    

注:クラスベース シェーピングはインターフェイス レベルとサブインターフェイス レベルで動作します。 Cisco IOS 12.2(2.5) では、メイン インターフェイス上、およびサブインターフェイスの IP アドレスにシェーピングを設定する機能が導入されています。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報