IP : IP アプリケーション サービス

ホットスタンバイ ルータ プロトコルの特長と機能

2006 年 5 月 25 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 5 月 25 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
HSRP の背景と操作
      ダイナミック ルータ検出メカニズム
      HSRP の操作
HSRP アドレッシング
Cisco IOS のリリースと HSRP 機能のマトリクス
Cisco IOS のブート イメージと HSRP 機能のマトリクス
HSRP の機能
      Preemption(優先使用)
      Interface Tracking(インターフェイス トラッキング)
      Use Burned-In Address(焼き込みアドレスの使用)
      Multiple HSRP Groups(複数の HSRP グループ)
      Configurable MAC Address(設定可能 MAC アドレス)
      Syslog Support(syslog のサポート)
      HSRP Debugging(HSRP デバッグ)
      Enhanced HSRP Debugging(拡張 HSRP デバッグ)
      Authentication(認証)
      IP Redundancy(IP 冗長)
      SNMP Management Information Base(SNMP 管理情報ベース)
      HSRP Support for Multiprotocol Label Switching Virtual Private Networks(マルチプロトコル ラベル スイッチング VPN のための HSRP サポート)
      HSRP Support for ICMP Redirects(ICMP リダイレクトのための HSRP サポート)
HSRP のインターフェイスとメディアのサポート
      イーサネット
      トークン リング
      802.1Q
      ISL
      FDDI
      MAC リフレッシュ
      ブリッジ グループ仮想インターフェイス
      サブインターフェイス
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、Hot Standby Router Protocol(HSRP; ホットスタンバイ ルータ プロトコル)の特長と機能について説明します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

HSRP の背景と操作

ネットワークの稼働率のほぼ 100 % を達成するための方法の 1 つに、HSRP の使用があります。HSRP は、ネットワーク エッジ デバイスやアクセス回線における第 1 ホップ障害からユーザ トラフィックが即時かつ透過的に復旧する冗長を IP ネットワークに提供します。

IP アドレスと MAC(レイヤ 2)アドレスを共有することで、複数のルータを単一の「仮想」ルータとして機能させることができます。 仮想ルータ グループのメンバが絶えずステータス メッセージを交換します。 この方法では、1 つのルータが予定した理由、または不測の理由で使用不能になった場合に、別のルータがルーティングを代行することができます。 ホストから同じ IP および MAC アドレスに IP パケットを転送し続けていても、ルーティングを行うデバイスは透過的に切り替えられます。

ダイナミック ルータ検出メカニズム

次に、ホストが使用するダイナミック ルータ検出メカニズムについて説明します。 これらのメカニズムの多くは、ネットワーク管理者が要求するネットワークの復元力を実現しません。 その理由は、プロトコルは初めからネットワークに復元力を提供することを意図されたものではないからです。または、ネットワーク上のすべてのホストがプロトコルを実行することが実現不可能である可能性もあります。 次に挙げる事項の他に、多くのホストで設定可能なのは、デフォルト ゲートウェイだけであることに注意しておくことが重要です。

プロキシ ARP

IP ホストの中には、ルータの選択にプロキシ Address Resolution Protocol(ARP)を使用するものがあります。 プロキシ ARP を実行しているホストは、接続しようとするリモート ホストの IP アドレスに ARP 要求を送信します。 ネットワーク上のあるルータ(ルータ A とします)が、リモート ホストの代理として自身の MAC アドレスを提供します。 プロキシ ARP を使用すると、ホストはリモート ホストがネットワークの同じセグメントに接続されているかのように動作します。 ルータ A に障害が発生した場合、ホストはリモート ホストに宛てたパケットをルータ A の MAC アドレスに送信し続け、それらのパケットは行き先がないために喪失されます。 この場合は、ARP が別の ARP 要求を送信してローカル セグメントにある別のルータ B の MAC アドレスを取得するまで待つか、ホストをリブートして ARP 要求が強制的に送信されるようにします。 どちらの方法でも、ルーティング プロトコルがコンバージされて、ルータ B がルータ A 経由で転送されるパケットを代わりに転送する準備が整ったとしても、ホストはリモート ホストと相当の期間、通信できなくなります。

ダイナミック ルーティング プロトコル

IP ホストの中には、ルータの検出に Routing Information Protocol(RIP; ルーティング情報プロトコル)または Open Shortest Path First(OSPF)などのダイナミック ルーティング プロトコルを実行(スヌーピング)しているものがあります。 RIP の不利点は、トポロジの変更に対応するのに時間がかかることです。 すべてのホストでダイナミック ルーティング プロトコルを実行することは、多くの理由で実現が不可能な場合があります。たとえば、管理上のオーバーヘッド、処理のオーバーヘッド、セキュリティ問題、一部のプラットフォームにプロトコル実装が不足する、などの理由です。

IRDP

最近の IP ホストの中には、ルートが利用できなくなった場合に新しいルータを見つけるのに ICMP Router Discovery Protocol(IRDP)(RFC 1256 leavingcisco.com を参照)を使用しているものがあります。 IRDP を実行するホストは、設定したルータから hello マルチキャスト メッセージを受信します。hello メッセージを受信できなくなると、代替ルータを使用します。 IRDP のデフォルトのタイマー値は、これが第 1 ホップの障害の検出には適さないことを示しています。 デフォルトのアドバタイズメント レートは 7〜10 分に 1 回で、デフォルトのライフタイムは 30 分です。

ダイナミック ホスト コンフィギュレーション プロトコル

Dynamic Host Configuration Protocol(DHCP; ダイナミック ホスト コンフィギュレーション プロトコル)(RFC 1531 leavingcisco.com を参照)は、TCP/IP ネットワーク上のホストに設定情報を渡すメカニズムを提供します。 DHCP クライアントを実行するホストは、ネットワーク上にブートするときに、DHCP サーバに設定情報を要求します。 この設定情報は、通常、IP アドレスとデフォルト ゲートウェイから成ります。 デフォルト ゲートウェイで障害が発生した場合に、代替ルータに切り替わるためのメカニズムはありません。

HSRP の操作

ダイナミック検出をサポートしない、従来のホストの実装では、デフォルト ルータを設定します。 すべてのホストでダイナミックなルータのメカニズムを実行することは、多くの理由で実現が不可能な場合があります。たとえば、管理上のオーバーヘッド、処理のオーバーヘッド、セキュリティ問題、一部のプラットフォームにプロトコル実装が不足している、などの理由です。 HSRP は、ホストにフェールオーバー サービスを提供します。

HSRP を使用すると、一群のルータが連携して動作し、LAN 上のホストに対して単一の仮想ルータであるかのような錯覚を与えます。 この一群のルータのことを、HSRP グループまたはスタンバイ グループと呼びます。 グループから選出された 1 台のルータが、ホストから仮想ルータに送信されたパケットを転送する役割を持ちます。 このルータはアクティブ ルータとして知られます。 別の 1 台のルータがスタンバイ ルータとして選出されます。 アクティブ ルータで障害が発生すると、スタンバイ ルータがアクティブ ルータのパケット転送作業を引き継ぎます。 HSRP は任意の数のルータで実行できますが、仮想ルータに送信されたパケットを転送するのはアクティブ ルータのみです。

ネットワーク トラフィックを最小限に抑えるため、選出プロセスが完了した後は、アクティブ ルータとスタンバイ ルータの間でのみ、定期的に HSRP メッセージが送信されます。 アクティブ ルータで障害が発生すると、スタンバイ ルータがアクティブ ルータの役割を引き継ぎます。 スタンバイ ルータで障害が発生するか、またはスタンバイ ルータがアクティブ ルータになると、別のルータがスタンバイ ルータとして選出されます。

特殊な LAN では、複数のホスト スタンバイ グループが共存し、オーバーラップしています。 スタンバイ グループはそれぞれ 1 台の仮想ルータをエミュレートします。 個々のルータは複数のグループに含まれることがあります。 この場合、ルータはグループごとに異なる状態とタイマーを維持します。

各スタンバイ グループには、IP アドレスと同様に、単一の周知の MAC アドレスがあります。

HSRP アドレッシング

ルータを HSRP グループの一部として設定した場合はほとんど、ルータは自身に焼き付けられた MAC アドレスだけでなく、そのグループ用の HSRP MAC アドレスを listen します。 例外は、ルータのイーサネット コントローラが 1 つの MAC アドレスしか認識しない場合です(たとえば、Cisco 2500 および Cisco 4500 などのルータ上の Lance コントローラなど)。 これらのルータは、自らがアクティブ ルータであるときは HSRP MAC アドレスを使用し、そうでないときは自身に焼き付けられたアドレスを使用します。

HSRP は、トークン リング以外の全メディア上で次の MAC アドレスを使用します。

 0000.0c07.ac**   (where ** is the HSRP group number)
 

トークン リングのインターフェイスは、HSRP MAC アドレスに機能アドレスを使用します。 機能アドレスは、使用可能な唯一の一般的なマルチキャスト メカニズムです。 使用できるトークン リングの機能アドレス数は限られており、その大半は他の機能のために確保されています。 HSRP には次の 3 つのアドレスを使用できます。

 c000.0001.0000   (group 0)
 c000.0002.0000   (group 1)
 c000.0004.0000   (group 2)
 

注:HSRP が複数リングの Source-Route Bridging(SRB; ソースルート ブリッシング)環境で稼働し、HSRP ルータがさまざまなリング上に配置されている場合に、機能アドレスを使用すると Routing Information Field(RIF; ルーティング情報フィールド)に混乱を生じる可能性があります。 たとえば、SRB 環境の場合、HSRP スタンバイ ルータをアクティブ ルータとは異なる別のリングに配置できます。 このスタンバイ ルータがアクティブになると、以前のアクティブ ルータと同じリング上の端末は、新しいアクティブ ルータにパケットを送信するのに新しい RIF が必要です。 しかし、スタンバイ(新しいアクティブ)ルータは以前のアクティブ ルータと同じ機能アドレスを使用しているため、端末は、探索パケットを送信して新しい RIF を入手する必要があることを認識しません。 このような理由で、use-bia コマンドが導入されました。

Cisco IOS のリリースと HSRP 機能のマトリクス

このドキュメントでは、どの Cisco IOS(R) ソフトウェア リリースでどの HSRP 機能がサポートされるかについて示します。 機能をクリックすると詳細の説明が表示されます。 暫定リリース番号は、どのリリースで機能が最初に導入されたか、または機能が変更されたかを示します。

機能

10.0

10.2

10.3

11.0

11.1

11.2

11.3

12.0

12.0T

12.1

12.1T

Preemption(優先使用)

X

X

X

X

X

X

X

X

X

X

X

Multiple Groups (MHSRP)

-

-

X

X

X

X

X

X

X

X

X

Ethernet 802.10 SDE

-

-

-

-

X

X

X

X

X

X

X

Interface Tracking(インターフェイス トラッキング)

-

-

-

-

X

X

X

X

X

X

X

Use BIA

-

-

-

-

8.0

X

X

X

X

X

X

優先使用遅延

-

-

-

-

-

X

X

6.1

X

X

X

Ethernet LANE

-

-

-

-

-

X

X

X

X

X

X

Token Ring LANE

-

-

-

-

-

-

X

X

X

X

X

ISL

-

-

-

-

-

-

X

X

X

X

X

Syslog Support(syslog のサポート)

-

-

-

-

-

-

X

X

X

X

X

MAC Refresh Interval

-

-

-

-

-

-

-

1.0

X

X

X

SNMP MIB

-

-

-

-

-

-

-

-

3.0

X

X

MHSRP and Use BIA

-

-

-

-

-

-

-

-

3.4

X

X

IP Redundancy(IP 冗長)

-

-

-

-

-

-

-

-

3.4

X

X

BVI

-

-

-

-

-

-

-

-

6.2

X

X

802.1Q

-

-

-

-

-

-

-

-

8.1

X

X

Enhanced HSRP Debugging(拡張 HSRP デバッグ)

-

-

-

-

-

-

-

-

-

0.2

X

HSRP ICMP Redirects

-

-

-

-

-

-

-

-

-

-

3

HSRP MPLS VPN

-

-

-

-

-

-

-

-

-

-

3


Cisco IOS のブート イメージと HSRP 機能のマトリクス

HSRP 機能は、Cisco Bug ID CSCec16720登録ユーザ専用)での修正が統合されるまで、Cisco IOS ブート イメージに含まれていました。 Cisco Bug ID CSCec16720 により、次の例外を除き、ブート イメージから HSRP が削除されています。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

  • c7200-boot-mz

  • c7200-kboot-mz

  • c10k-eboot-mz

  • c4500-boot-mz

  • c7200-boot-mz

  • c7200-kboot-mz

  • c7400-kboot-mz

  • ubr7200-boot-mz

  • c6400r-boot-mz

  • rpm-boot-mz

  • rpmxf-boot-mz

  • rsp-boot-mz

  • urm-wboot-mz

  • c5350-boot-mz

  • c5400-boot-mz

  • c7301-boot-mz

  • c5850-boot-mz

  • c4gwy-cboot-mz

  • ubr910-rboot-mz

  • ubr910-rboot-mz

  • ubr925-k8boot-mz

  • c5850tb-boot-mz

HSRP の機能

Preemption(優先使用)

HSRP の優先使用機能によって、ルータが即座にアクティブ ルータになるための最高の優先順位をつけることができます。 優先順位は、設定した優先順位の値で最初に決定され、次に IP アドレスによって決定されます。 いずれの場合も、値が高いほど優先順位が高くなります。

優先順位の高いルータが低い方のルータにとって代わるとき、coup メッセージを送信します。 優先順位の低いアクティブ ルータは、優先順位の高いアクティブ ルータから coup メッセージまたは hello メッセージを受け取ると、speak 状態に移行して resign メッセージを送信します。

優先使用遅延

優先使用遅延機能を使用すると、設定可能な一定の期間、優先使用を遅延させることができます。これによって、ルータはアクティブ ルータになる前にルーティング テーブルを実装できます。

Cisco IOS ソフトウェア リリース 12.0(9) よりも前では、遅延はルータがリロードされた時点で始まっていました。 Cisco IOS リリース 12.0(9) では、遅延は優先使用が最初に試行された時点で開始します。

HSRP の優先順位および優先使用を設定するには、standby [group] [priority number] [preempt [delay [minimum] seconds] [sync seconds]] コマンドを使用します。

HSRP の設定の詳細は、『HSRP のドキュメント』を参照してください。

Interface Tracking(インターフェイス トラッキング)

インターフェイス トラッキングでは、所定のグループの HSRP 優先順位を変更するために、HSRP プロセスでモニタ可能な、ルータ上の別のインターフェイスを指定できます。

指定したインターフェイスの回線プロトコルがダウンした場合は、そのルータの HSRP 優先順位が下がり、優先順位が高い別の HSRP ルータがアクティブになります(優先使用がイネーブルになっている場合)。

HSRP インターフェイス トラッキングを設定するには、standby [group] track interface [priority] コマンドを使用します。

トラッキングしたインターフェイスが複数ダウンした場合は、優先順位は累積分下がります。 優先順位の減少値を明示的に設定した場合、インターフェイスがダウンするとその値分の優先順位が下がり、この減少値は累積されます。 優先順位の減少値を明示的に設定しない場合、インターフェイスがダウンすると 10 ずつ優先順位が下がり、この減少値は累積されます。

次の例では、次のような設定でデフォルトの減少値 10 を使用します。

注:HSRP グループ番号を指定しない場合、デフォルトのグループ番号は 0 になります。

 interface ethernet0
      ip address 10.1.1.1 255.255.255.0
      standby ip  10.1.1.3 
      standby priority 110
      standby track serial0 
      standby track serial1
 

この設定の HSRP は、次のように動作します。

  • 0 インターフェイスのダウン = 減少なし(優先順位は 110)

  • 1 インターフェイスのダウン = 10 減少(優先順位は 100)

  • 2 インターフェイスのダウン = 10 減少(優先順位は 90)

上記のようは HSRP の動作は、次のように減少値を明示的に設定した場合も同じです。

 interface ethernet0
      ip address 10.1.1.1 255.255.255.0
      standby ip  10.1.1.3 
      standby priority 110
      standby track serial0 10
      standby track serial1 10
 

Cisco IOS リリース 12.1 よりも前では、インターフェイスがダウンしているルータを起動すると、HSRP インターフェイス トラッキングでは、そのインターフェイスがアップしていると見なされます。

この不具合は、Cisco Bug ID CSCdp32289登録ユーザ専用)で報告されています。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

Use Burned-In Address(焼き込みアドレスの使用)

Burned-in Address(BIA; 焼き込みアドレス)機能の使用によって、HSRP グループは HSRP MAC アドレスではなくインターフェイスの焼き込み MAC アドレスを使用できます。 BIA の使用は、Cisco IOS リリース 11.1(8) で初めて実装されました。 HSRP で BIA を使用するように設定するには、standby use-bia [scope interface] コマンドを使用します。

use-bia コマンドは、トークン リング インターフェイスで HSRP MAC アドレスに有効アドレスを使用する場合の制限を克服するために実装されたものです。

注:HSRP が複数リングのソースルート ブリッジング環境で稼働し、HSRP ルータがさまざまなリング上に配置されている場合に、有効アドレスを使用すると Routing Information Field(RIF; ルーティング情報フィールド)に混乱が生じる可能性があります。 このような理由で、use-bia コマンドが導入されました。

また、use-bia 機能によって DECnet の MAC アドレス(BIA)を HSRP MAC アドレスとして使用できるため、DECnet、Xerox Network Systems(XNS)および HSRP を同じルータ上で使用することが可能になります。 use-bia コマンドはまた、デバイスの BIA が LAN 上の他のデバイスに設定されているネットワーク環境で便利です。

ただし、use-bia コマンドには不利な点がいくつかあります。

  • ルータがアクティブになると、仮想 IP アドレスが別の MAC アドレスに移動します。 新しいアクティブ ルータは無償の ARP 応答を送信しますが、必ずしもすべてのホスト実装が無償の ARP を正しく処理できるとは限りません。

  • use-bia を設定すると、プロキシ ARP を使用できません。 スタンバイ ルータは、故障したルータのプロキシ ARP データベースが失われた場合、それを補うことができません。

  • Cisco IOS リリース 12.0(3.4)T よりも前では、use-bia が設定されていると、HSRP グループは 1 つしか許可されていませんでした。

サブインターフェイスに use-bia コマンドを設定すると、実際にはメイン インターフェイス上で表示され、すべてのサブインターフェイスに適用されています。 Cisco IOS リリース 12.0(6.2) 以降では、use-bia コマンドはオプションのスコープ インターフェイス キーワードで拡張され、単一のサブインターフェイスに適用できるようになりました。

この不具合は、Cisco Bug ID CSCdm25468登録ユーザ専用)で報告されています。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

Multiple HSRP Groups(複数の HSRP グループ)

複数 HSRP(MHSRP)グループ機能は、Cisco IOS リリース 10.3 で追加されました。 この機能により、ネットワーク内の冗長とロードシェアリングがさらに強化されるため、冗長ルータはさらに十分に活用されます。 ルータは、アクティブ ルータとして 1 つの HSRP グループにトラフィックを転送しながら、別のグループに対してスタンバイまたはリスニング状態でいることができます。

Cisco IOS リリース 12.0(3.4)T では、複数の HSRP グループをイネーブルにしたまま、use-bia コマンドを使用できます。

Configurable MAC Address(設定可能 MAC アドレス)

通常は、端末がIP ルーティングの第 1 ホップ ゲートウェイを探すために HSRP を使用します。 端末はデフォルト ゲートウェイで設定されます。 ただし、HSRP は他のプロトコルに第 1 ホップの冗長を提供できます。 Advanced Peer-to-Peer Networking(APPN; 拡張分散ネットワーク機能)などのプロトコルは、ルーティングのための第 1 ホップを識別するために MAC アドレスを使用します。

このような場合、大概は standby mac-address コマンドを使用して仮想 MAC アドレスを指定できることが必要となります。 これらのプロトコルには、仮想 IP アドレスは重要ではありません。 コマンドの実際の構文は、standby [group] mac-address mac-address です。

注:このコマンドは、トークン リング インターフェイスでは使用できません。

Syslog Support(syslog のサポート)

syslog メッセージによる HSRP 情報のサポートは、Cisco IOS リリース 11.3 で追加されました。 この機能によって、syslog サーバで現在のアクティブ ルータおよびスタンバイ ルータをより効率的にロギングおよびトラッキングできます。

HSRP Debugging(HSRP デバッグ)

Cisco IOS リリース 12.1 よりも前では、HSRP デバッグ コマンドは比較的単純でした。 HSRP のデバッグをイネーブルにするには、debug standby コマンドを使用するだけで可能でした。このコマンドによって、HSRP の状態とすべてのインターフェイス上にあるすべてのスタンバイ グループのパケット情報を出力できました。

Cisco IOS 12.0(2.1) でデバッグ条件が追加されたため、インターフェイスとグループ番号に基づいて、standby debug コマンドの出力にフィルタをかけることができます。 このコマンドは、Cisco IOS リリース 12.0 で導入された debug condition パラダイムを利用するもので、これは debug condition standby interface group のようになります。 interface には、HSRP をサポートする有効なインターフェイスを指定する必要があります。 group には任意のグループ(0〜255)を指定できます。

存在しないグループにデバッグ条件を指定することもできます。これにより、新しいグループの初期化中にデバッグ情報を取得できます。

デバッグ出力を生成するには、standby debug オーダーをイネーブルにする必要があります。 standby debug 条件を設定しない場合は、すべてのインターフェイス上にあるすべてのグループについてデバッグ出力が生成されます。 standby debug 条件を 1 つでも設定した場合、standby debug の出力は standby debug のすべての条件に従ってフィルタに掛けられます。

Enhanced HSRP Debugging(拡張 HSRP デバッグ)

Cisco IOS リリース 12.1(0.2) よりも前では、定期的な hello メッセージのノイズによって情報が失われていたため、HSRP デバッグの使用は制限されていました。 そのため、Cisco IOS 12.1(0.2) でデバッグの拡張機能が追加されました。

次の表で、拡張デバッグのコマンド オプションを説明します。

コマンド 説明

debug standby

HSRP エラー、イベント、パケットをすべて表示します。

debug standby terse

すべての HSRP エラー、イベント、および、パケット(hello パケットとアドバタイズメント パケットを除く)を表示します。

debug standby errors

HSRP エラーを表示します。

debug standby events [[all | terse] | [icmp | protocol | redundancy | track]] [detail]

HSRP イベントを表示します。

debug standby packets [[all | terse] | [advertise | coup | hello | resign]] [detail]

HSRP パケットを表示します。


インターフェイスと HSRP グループによる条件付きデバッグを使用すると、debug の出力にフィルタを掛けることができます。 インターフェイスでの条件付きデバッグをイネーブルするには、debug condition interface interface コマンドを使用します。 HSRP での条件付きデバッグをイネーブルするには、debug condition standby interface group コマンドを使用します。

インターフェイスによるデバッグ条件は、standby debug 条件を設定していない場合のみ適用されます。 Cisco IOS リリース 12.1(1.3) では、HSRP 状態テーブルの改良に伴って、HSRP のデバッグ機能がさらに拡張されます。

この不具合は、Cisco Bug ID CSCdp57811登録ユーザ専用)で報告されています。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

これらの拡張により、HSRP 状態テーブルのイベントが表示されるようになります。 次の出力中の a/b/c/ などは、HSRP 有限状態マシンのイベントを指します。HSRP 有限状態マシンについては、RFC 2281 leavingcisco.com で解説されています。

 SB1: Ethernet0/2 Init: a/HSRP enabled
 SB1: Ethernet0/2 Active: b/HSRP disabled (interface down)
 SB1: Ethernet0/2 Listen: c/Active timer expired (unknown)
 SB1: Ethernet0/2 Active: d/Standby timer expired (20.0.0.3)
 SB1: Ethernet0/2 Speak: f/Hello rcvd from higher pri Speak router
 SB1: Ethernet0/2 Active: g/Hello rcvd from higher pri Active router
 SB1: Ethernet0/2 Speak: h/Hello rcvd from lower pri Active router
 SB1: Ethernet0/2 Standby: i/Resign rcvd
 SB1: Ethernet0/2 Active: j/Coup rcvd from higher pri router
 SB1: Ethernet0/2 Standby: k/Hello rcvd from higher pri Standby router
 SB1: Ethernet0/2 Standby: l/Hello rcvd from lower pri Standby router
 SB1: Ethernet0/2 Active: m/Standby mac address changed
 SB1: Ethernet0/2 Active: n/Standby IP address configured
 

Authentication(認証)

HSRP 認証機能は、HSRP パケットに含まれる共有クリア テキスト キーから成ります。 この機能は、優先順位の低いルータが優先順位の高いルータのスタンバイ IP アドレスおよびスタンバイ タイマー値を学習するのを防ぎます。

HSRP 認証ストリングを設定するには、standby authentication string コマンドを使用します。

IP Redundancy(IP 冗長)

HSRP は、IP ルーティングにステートレスな冗長を提供します。 HSRP そのものの機能は、それ自身の状態を維持するにとどまります。 HSRP は、各ルータが他のルータに依存することなく、専用のルーティング テーブルを構築および維持しているものと想定します。 IP 冗長機能は、HSRP がクライアント アプリケーションにサービスを提供して、ステートフルなフェールオーバーを実装できるメカニズムを提供します。

IP 冗長は、ピア アプリケーションに状態情報を交換するメカニズムを提供しません。 これはアプリケーション自身で用意するものであり、そのアプリケーションがステートフルなフェールオーバーを提供する場合は必須です。

IP 冗長は 2000 年 1 月現在、モバイル IP ホーム エージェント向けにのみ実装されています。 次に、設定例を示します。

 configure terminal
  router mobile
  ip mobile home-agent standby hsrp-group1
 !
 interface e0/2
  no shutdown
  ip address 20.0.0.1 255.0.0.0
  standby 1 ip 20.0.0.11
  standby 1 name hsrp-group1
 

注:Cisco IOS リリース 12.1(3)T では、キーワード standby に加えて、キーワード redundancy が許容されるようになりました。 standby キーワードは、Cisco IOS の今後のリリースでは廃止される予定です。 したがって、正しいコマンドは ip mobile home-agent redundancy hsrp-group1 になります。

今後の IP 冗長の使用法としては、次が考えられます。

  • NAT - 冗長ゲートウェイを提供する必要があります。

  • IPSEC - HSRP 使用時に操作するための状態情報を同期化する必要があります。

  • DHCP サーバ − 各種ルータに実装された DHCP サーバ。

  • NBAR、CBAC - 非対称ルーティングに、ファイアウォール状態をミラーリングする必要があります。

  • GPRS - TCP 状態をトラッキングする方法が必要です。

  • PIX

SNMP Management Information Base(SNMP 管理情報ベース)

Cisco IOS リリース 12.0(3.0)T では、SNMP Management Information Base(MIB; 管理情報ベース)のサポートが追加されています。 HSRP に関連する MIB が 2 つがあります。

  • ciscoMgmt 106: HSRP の管理用 MIB モジュール

  • ciscoMgmt 107: HSRP の管理用拡張 MIB モジュール

Cisco IOS リリース 12.0(6.1)T よりも前では、Bridge Group Virtual Interface(BVI; ブリッジ グループ仮想インターフェイス)が存在する場合に拡張 HSRP MIB がウォークすると、ルータがクラッシュします。

この不具合は、Cisco Bug ID CSCdm61257登録ユーザ専用)で報告されています。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

HSRP Support for Multiprotocol Label Switching Virtual Private Networks(マルチプロトコル ラベル スイッチング VPN のための HSRP サポート)

Cisco IOS リリース 12.1(3)T では、Multiprotocol Label Switching(MLS; マルチプロトコル ラベル スイッチング)Virtual Private Network(VPN; 仮想私設ネットワーク)のための HSRP サポートが追加されました。

MPLS VPN インターフェイス上の HSRP は、2 つの Provider Edge(PE; プロバイダー エッジ)の間がイーサネットで接続されており、次のいずれかにあてはまる場合に便利です。

  • HSRP 仮想 IP アドレスへのデフォルト ルートを持つ Customer Edge(CE; カスタマー エッジ)がある。

  • デフォルト ゲートウェイに HSRP 仮想 IP アドレスが設定されたホストが 1 台以上ある。

次のネットワーク ダイアグラムに、VPN routing/forwarding(VRF; VPN ルーティング/フォワーディング)インターフェイス間で HSRP を実行する 2 つの PE を示します。 CE のデフォルト ルートには、HSRP 仮想 IP アドレスが設定されています。 HSRP は、PE に接続するインターフェイスから残りのプロバイダー ネットワーク全体までをトラッキングするように設定されています。 たとえば、PE1 のインターフェイス E1 に障害が発生すると、HSRP の優先順位が減少し、仮想 IP/MAC アドレスへのパケットの転送は、PE2 が引き継ぎます。

hsrpguide4a.gif

ネットワーク ダイアグラム
※ 画像をクリックすると、大きく表示されます。

設定を次に示します。

ルータ PE1 ルータ PE2
 conf terminal
 !
 ip cef
 !
 ip vrf vrf1
  rd 100:1
  route-target export 100:1
  route-target import 100:1
 !
 interface ethernet0
  no shutdown
  ip vrf forwarding vrf1
  ip address 10.2.0.1 255.255.0.0
  standby 1 ip 10.2.0.20
  standby 1 priority 105
  standby 1 preempt delay minimum 10
  standby 1 timers 3 10
  standby 1 track ethernet1 10
  standby 1 track ethernet2 10
 
 conf terminal
 !
 ip cef
 !
 ip vrf vrf1
  rd 100:1
  route-target export 100:1
  route-target import 100:1
 !
 interface ethernet0
  no shutdown
  ip vrf forwarding vrf1
  ip address 10.2.0.2 255.255.0.0
  standby 1 ip 10.2.0.20
  standby 1 priority 100
  standby 1 preempt delay minimum 10
  standby 1 timers 3 10
  standby 1 track ethernet1 10
  standby 1 track ethernet2 10
 

次のコマンドを使用して、HSRP 仮想 IP アドレスが正しい VRF ARP および Cisco Express Forwarding (CEF)テーブルにあることを確認します。

 ed1-pe1# show ip arp vrf vrf1
 Protocol  Address          Age (min)  Hardware Addr   Type   Interface
 Internet  10.2.0.1                -   00d0.bbd3.bc22  ARPA   Ethernet0/2
 Internet  10.2.0.20               -   0000.0c07.ac01  ARPA   Ethernet0/2   
 
 ed1-pe1# show ip cef vrf vrf1
 Prefix              Next Hop             Interface
 0.0.0.0/0           10.3.0.4             Ethernet0/3
 0.0.0.0/32          receive
 10.1.0.0/16         10.2.0.1             Ethernet0/2
 10.2.0.0/16         attached             Ethernet0/2
 10.2.0.1/32         receive
 10.2.0.20/32        receive                                                
 224.0.0.0/24        receive
 255.255.255.255/32  receive
 

HSRP Support for ICMP Redirects(ICMP リダイレクトのための HSRP サポート)

HSRP は、「サブネットを保護している HSRP ピア ルータは、ネットワークを構成する他のすべてのサブネットへのアクセスを提供できる」という概念に基づいています。 したがって、どのルータがアクティブ HSRP ルータになるかということは関係ありません。なぜなら、すべてのルータがすべてのサブネットに対するルートを持っているからです。

HSRP は、特別な仮想 IP アドレスおよび仮想 MAC アドレスを使用します。これらのアドレスは、HSRP アクティブ ルータに論理的に接続しています。 そのインターフェイス上で HSRP を使用するときには、そのインターフェイス上の ICMP リダイレクトは自動的にディセーブルされます。 IOS 12.1(3)T 以降では、ICMP リダイレクト機能により、HSRP が設定されたインターフェイス上では ICMP リダイレクトがイネーブルにされます。 詳細は、『HSRP の ICMP リダイレクト サポート』を参照してください。 これにより、ホストが HSRP 仮想 IP アドレスからリダイレクトされるのを防ぎます。 サブネット上の 2 つ(またはそれ以上)のルータは、残りのネットワークに対して同一の接続性を持っていない可能性があります。 つまり、特定の宛先 IP アドレスに関しては、どちらかのルータが他方より優れたパスを持っている可能性があります。また、どちらかのルータがそのアドレスに接続する唯一のルータであることもあります。

ICMP プロトコルによって、ルータは、特定の宛先にパケットを送信する端末を、同じサブネット上の別のルータにリダイレクトできるようになります。これは、この別のルータがそのアドレスへのより優れたパスを持っていることを、最初のルータが把握している場合に実行されます。 デフォルト ゲートウェイの場合は、特定の宛先に向けてパケットを送信する端末がリダイレクトされるルータに障害が発生すると、端末から宛先に送信されたパケットは配信されません。 標準的な HSRP では、まさにこの問題が発生します。 このような理由から、HSRP を使用するときは ICMP をディセーブルすることを推奨します。

ICMP リダイレクトと HSRP の関係の拡張が、この問題の解決策となり、ユーザは HSRP と ICMP リダイレクトの両方の優れた機能を利用できるようになります。 2 つ(またはそれ以上)の HSRP グループがそれぞれのサブネットで実行されており、サブネットには、少なくとも参加しているルータと同じ数の HSRP グループが設定されています。 それぞれのルータが少なくとも 1 つの HSRP グループのマスターになるように、優先順位が設定されます。 あるルータが特定の宛先に向けてパケットを送信する端末を別のルータにリダイレクトすることを決定する場合は、端末をその別のルータの IP アドレスにリダイレクトするのではなく、そのルータをマスターにしている HSRP グループを探して、対応する仮想 IP アドレスに端末をリダイレクトします。 そのターゲットとなるルータに障害が発生した場合、HSRP はそのジョブが別のルータに確実に引き継がれるようにします。おそらく、端末はまた別の仮想ルータにリダイレクトされることになります。

HSRP のインターフェイスとメディアのサポート

このセクションでは、HSRP がサポートするインターフェイスとメディアについて説明します。また、それらのメディアで HSRP を実行するときに考えられる注意点についても説明します。

Cisco IOS ソフトウェア リリース 10.0 以降では、HSRP 機能がイーサネット、トークン リングおよび Fiber Distributed Data Interface(FDDI; ファイバ分散データ インターフェイス)で利用できるようになりました。 ファースト イーサネットと ATM インターフェイスも、HSRP によってサポートされます。

Virtual LAN(VLAN; バーチャル LAN)の使用により、論理ネットワーク トポロジを物理スイッチ インフラストラクチャにオーバーレイすることが可能になります。これによって、任意に収集された LAN ポートが、自律したユーザ グループまたは利害を共有する共同体として結合されます。 Cisco IOS リリース 11.1 では、IEEE 802.10 Secure Data Exchange(SDE; セキュア データ交換)用の HSRP VLAN サポートが追加され、Cisco IOS リリース 11.3 では、Cisco Inter-Switch Link(ISL; スイッチ間リンク)用の HSRP VLAN サポートが追加されました。

イーサネット

ローエンド製品に搭載されているイーサネット(Lance および QUICC)コントローラによっては、アドレス フィルタ内にユニキャスト MAC アドレスを 1 つしか設定できないものもあります。 これらのプラットフォームでは、単一の HSRP グループだけが許可され、そのグループがアクティブになると、インターフェイス アドレスが HSRP 仮想 MAC アドレスに変更されます。 この種のインターフェイスを複数持つルータで HSRP を使用している場合は、各インターフェイスに異なる HSRP グループ番号を設定する必要があります。

注:Cisco 7200 ルータでも Lance イーサネット コントローラが使用されますが、その場合、MHSRP はソフトウェアでサポートされます。

HSRP 用にアドレス フィルタを更新するのに時間がかかるため、シスコでは、HSRP Ethernet Interface Processor(EIP; イーサネット インターフェイス プロセッサ)の数を 24 以下にすることを推奨しています。 HSRP EIP の数が 24 を越えると、CPU の負荷が増大し、動作が不安定になります。

この不具合は、Cisco Bug ID CSCdj29595登録ユーザ専用)で報告されています。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

25 以上の EIP がある場合は、EIP を Versatile Interface Processors(VIP)とイーサネット ポート アダプタに置き換えます。 VIP は、最大 80 の HSRP グループにまで許可されています。 また、HSRP グループの数を減らし、HSRP hello と保持時間を増やします。

トークン リング

トークン リング インターフェイスで HSRP を実行するうえでの制約が 1 つあり、イーサネット、FDDI または ATM エミュレーションで行うのと同じ方法で、トークン リング チップセットにアドレス フィルタを再プログラムすることはできません。 トークン リングでは、機能アドレス スペースの中で、他の利用と競合せずに使用できる、ごく少数の機能アドレスが使用されます。

Source-Route Bridging(SRB; ソースルート ブリッジング)環境で HSRP を実行する場合に、機能アドレスを使用すると RIF に混乱を招くことがあります。 詳細は、「HSRP アドレッシング」のセクションを参照してください。 または、use-bia コマンドを設定してみてください。

802.1Q

シスコでは、802.1Q で HSRP を使用する場合は、Cisco IOS リリース 12.0(8.1)T 以降を使用することを推奨しています。

ISL

Cisco IOS リリース 11.2(6)F、11.3、12.X では、HSRP over ISL が使用可能です。 Cisco Bug ID CSCdm68811登録ユーザ専用)で報告されている問題を避けるには、リリース 12.0(7) を推奨します。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

FDDI

FDDI ポート アダプタは、MAC 送信元に自分の MAC アドレスを見つけると、リングからフレームをはずします。 ネットワーク イベントによって両方のルータがアクティブになった場合、両方のルータは、同じ仮想 MAC アドレスを持つ HSRP hello パケットを送信します。 すると、各ルータは誤って他方のルータの hello パケットをネットワークからはずしてしまい、両方がアクティブ状態のままとなります。

この不具合は、Cisco Bug ID CSCdj30049登録ユーザ専用)で報告されています。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

Cisco IOS リリース 11.2(11.1) でのこの問題の解決策は、FDDI 環境にある HSRP ルータがメッセージ交換および HSRP プロトコル実行の際に、自分固有の焼き込み MAC アドレスを使用するというものです。 また、アクティブ ルータも HSRP MAC アドレスを使用して定期的にリフレッシュ メッセージを送信することによって、ラーニング ブリッジとスイッチが仮想 MAC アドレスに正しいポート エントリをキャッシュするようにします。

注:複数の RIP ネットワークと HSRP グループを設定している場合、リロード後に、FDDI インターフェイス上にある Cisco 4500 ルータのハードウェア Content-Addressable Memory(CAM)に書き込みが正しく行われません。 現時点での唯一の回避策は、インターフェイスをクリアして CAM を復元することです。 この不具合は、Cisco Bug ID CSCdm93122登録ユーザ専用)で報告されています。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

MAC リフレッシュ

FDDI 環境にある HSRP ルータは、自分固有の焼き込み MAC アドレスを使用して、メッセージを交換し、HSRP プロトコルを実行しています。 また、アクティブ ルータも HSRP MAC アドレスを使用して定期的にリフレッシュ メッセージを送信することによって、ラーニング ブリッジとスイッチが仮想 MAC アドレスに正しいポート エントリをキャッシュするようにします。 この不具合は、Cisco Bug ID CSCdj30049登録ユーザ専用)で報告されています。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワークにスイッチまたはラーニング ブリッジがない場合は、次に示すとおり、リフレッシュ パケットの送信をディセーブルします。

 interface fddi 1/0/0
  ip address 10.1.1.1 255.255.255.0 
  standby ip 10.1.1.250 
  standby mac-refresh 0
 

ブリッジ グループ仮想インターフェイス

Bridge Group Virtual Interface(BVI; ブリッジ グループ仮想インターフェイス)向けの HSRP サポートは、Cisco IOS リリース 12.0(6.2)T で追加されました。

サブインターフェイス

サブインターフェイス上にある HSRP グループは、同じメイン インターフェイス上のすべてのサブインターフェイスにある、他のすべてのグループ中で固有なグループ番号を持っている必要があります。 サブインターフェイスは、固有の SNMP インターフェイスのインデックスを受信しないためです。 異なるサブインターフェイス上に同じ番号 N を持つ 2 つのグループがある場合、MIB では、サブインターフェイス 1 上にあるグループ N とサブインターフェイス 2 上にあるグループ N が同じグループとして表示されます。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報