IP : IP バージョン 6(IPv6)

IPv4 ネットワークを介した IPv6 のトンネル

2006 年 8 月 10 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 8 月 10 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
設定
      ネットワーク ダイアグラム
      設定例(手動 IPv6 モード)
      設定例(自動 IPv4 互換モード)
確認
      手動 IPv6 モードの確認コマンドの出力
      自動 IPv6 モードの確認コマンドの出力
トラブルシューティング
      トラブルシューティングのためのコマンド
      要約
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、IPv6 Routing Information Protocol(RIP; ルーティング情報プロトコル)および IPv6 Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)ネットワーク、およびトラフィックを既存の IPv4 ネットワークを介して、トンネリングするための設定例を説明します。 この方法では、既存の IPv4 バックボーンを使用して IPv6 のサイトを接続できます。

オーバーレイ トンネリングでは、IPv4 のインフラストラクチャを使用して配信するために、IPv6 パケットが IPv4 パケットにカプセル化されます。 この方法は、Generic Routing Encapsulation(GRE; 総称ルーティング カプセル化)トンネルを作成して、Internetwork Packet Exchange(IPX)トラフィックを IP ネットワーク経由で転送する方法に似ています。 トンネルのヘッド エンドでは、IPv6 パケットが IPv4 パケットにカプセル化されて、トンネルのリモートの宛先に転送されます。 リモートの宛先では IPv4 パケット ヘッダーが取り除かれて、元の IPv6 パケットが IPv6 クラウドに引き続き転送されます。

IPv6 トラフィックをトンネリングする方法には、次の 5 種類があります。

  • 手動 IPv6 トンネル

  • 自動 IPv4 互換トンネル

  • GRE

  • 自動 6to4 トンネル

  • Intra-Site Automatic Tunnel Addressing Protocol(ISATAP)トンネル

これらのトンネリング方法の主な違いは、トンネルの送信元と宛先の決定方法です。 このドキュメントでは、手動タイプと自動タイプの IPv4 互換トンネルについて説明します。 他のトンネリング方法とそれらの特長の詳細については、『IPv6 用のトンネリングの実装』を参照してください。

: オーバーレイ トンネルを使用すると、インターフェイスの最大伝送ユニット(maximum transmission unit; MTU)が 20 オクテット少なくなります。 これは IPv4 の基本パケット ヘッダーにオプション フィールドが含まれていないと仮定した場合の値です。 オーバーレイ トンネルを使用するとネットワークのトラブルシューティングが難しくなります。 そのため、孤立した IPv6 ネットワークを接続するオーバーレイ トンネルを IPv6 の最終的なネットワーク アーキテクチャとは考えないでください。 オーバーレイ トンネルの使用は、IPv4 と IPv6 の両方のプロトコル スタックまたは IPv6 のプロトコル スタックだけをサポートするネットワークへの移行方法と考えてください。

前提条件

要件

この設定を行うには、IPv6 の知識があることが推奨されます。 IPv6 の詳細については、『IPv6 によるアドレッシングと基本的な接続の実装』を参照してください。

使用するコンポーネント

このドキュメントの情報は、Cisco IOS(R) ソフトウェア リリース 12.3(13) が稼働する Cisco 36xx シリーズ ルータに基づくものです。

注:Cisco IOS ソフトウェア リリース 12.2(2)T または 12.0(21)ST 以降がサポートされているハードウェア プラットフォームでは、IPv6 もサポートされています。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションでは、このドキュメントで説明する機能を設定するための情報を提供します。

注:このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

このドキュメントでは、次のネットワーク構成を使用しています。

ipv6tunnel.jpg

ネットワーク構成
※ 画像をクリックすると、大きく表示されます。

設定例(手動 IPv6 モード)

手動で設定した IPv6 トンネルの設定については、特に説明の必要はないと思われます。 この場合は、IPv4 トンネルの発信元と IPv4 トンネルの宛先を明確に指定する必要があります。 この方法を使用する場合の唯一の欠点は、トンネルの数が増えたときに管理作業が増加することです。

このドキュメントでは、次に示す手動 IPv6 モードの設定を使用します。

R1-IPv6(Cisco 3640 ルータ)
 R1-ipv6#show run
 Building configuration...
  
 Current configuration : 916 bytes
 !
 version 12.3
 hostname R1-ipv6
 !
 boot system flash 
 logging buffered 4096 debugging
 !
 ip subnet-zero
 ip cef
 !
 !
 no ip domain-lookup
 !
 ipv6 unicast-routing
 !
 !
 !
 !
 interface Ethernet0/0
  no ip address
  shutdown
 !
 interface Ethernet0/1
  no ip address
  ipv6 address 2000:1:1:1:1:1:1:1112/112
  ipv6 rip 6bone enable
 !
 !
 ip classless
 !
 ipv6 router rip 6bone 
 !
 line con 0
  exec-timeout 0 0
 line aux 0
 line vty 0 4
  login
 !
 !
 !
 end
 
R2-IPv6-IPv4(Cisco 3640 ルータ)
 R2-ipv6-ipv4#show run
 Building configuration...
  
 Current configuration : 1079 bytes
 !
 version 12.3
 !
 hostname R2-ipv6-ipv4
 !
 ip subnet-zero
 !
 !
 ipv6 unicast-routing
 !
 !
 interface Tunnel0
  no ip address
  ipv6 address 3000::1/112
  ipv6 rip 6bone enable
  tunnel source Serial0/0
 tunnel destination 192.34.1.4
 tunnel mode ipv6ip
 
 !--- 手動トンネルを設定します。
 
 
 !
 !
 interface Serial0/0
  ip address 192.23.1.2 255.255.255.0
  clockrate 64000
 !
 interface FastEthernet0/1
  no ip address
  duplex auto
  speed auto
  ipv6 address 2000:1:1:1:1:1:1:1111/112
  ipv6 rip 6bone enable
 !
 router ospf 1
  log-adjacency-changes
  network 192.23.1.0 0.0.0.255 area 0
 !
 ip classless
 !
 ipv6 router rip 6bone
 !
 !
 line con 0
 line aux 0
 line vty 0 4
  login
 line vty 5 15
  login
 !
 !
 end
 
R3-IPv4(Cisco 2621 ルータ)
 R3-ipv4#show run
 Building configuration...
  
 Current configuration : 865 bytes
 !
 version 12.3
 !
 hostname R3-ipv4
 !
 !
 memory-size iomem 15
 ip subnet-zero
 !
 !
 interface Serial0/0
  ip address 192.23.1.3 255.255.255.0
 !
 interface Serial0/1
  ip address 192.34.1.3 255.255.255.0
 !
 router ospf 1
  log-adjacency-changes
  network 192.23.1.0 0.0.0.255 area 0
  network 192.34.1.0 0.0.0.255 area 0
 !
 ip classless
 !
 line con 0
 line aux 0
 line vty 0 4
 !
 !
 end
 
R4-IPv4-IPv6(Cisco 3640 ルータ)
 R4-ipv4-ipv6#show run
 Building configuration...
  
 Current configuration : 1413 bytes
 !
 version 12.3
 !
 hostname R4-ipv4-ipv6
 !
 !
 ip subnet-zero
 !
 !
 no ip domain-lookup
 !
 ipv6 unicast-routing
 !
 !
 !
 interface Tunnel0
  no ip address
  ipv6 address 3000::2/112
  ipv6 rip 6bone enable
  tunnel source Serial1/5
 tunnel destination 192.23.1.2
 tunnel mode ipv6ip
 
 !--- 手動トンネルを設定します。
 
 
 !
 !
 interface Serial1/5
  ip address 192.34.1.4 255.255.255.0
  clockrate 64000
 !
 !
 interface Ethernet3/0
  no ip address
  half-duplex
  ipv6 address 4000:1:1:1:1:1:1:1111/112
  ipv6 rip 6bone enable
 !
 router ospf 1
  log-adjacency-changes
  network 192.34.1.0 0.0.0.255 area 0
 !
 ip classless
 !
 ipv6 router rip 6bone
 !         
 !
 line con 0
 line aux 0
 line vty 0 4
  login
 !
 !
 end
 
R5-IPv6(Cisco 7500 ルータ)
 R5-ipv6#show run
 Building configuration...
  
 Current configuration : 1001 bytes
 !
 version 12.3
 !
 hostname R5-ipv6
 !
 ip subnet-zero
 ip cef distributed
 !
 !
 no ip domain-lookup
 !
 ipv6 unicast-routing
 !
 !
 !
 interface Ethernet1/2
  no ip address
  ipv6 address 4000:1:1:1:1:1:1:1112/112
  ipv6 rip 6bone enable
 !
 !
 ip classless
 !
 ipv6 router rip 6bone
 !
 !
 !
 line con 0
  exec-timeout 0 0
 line aux 0
 line vty 0 4
  login
 !
 !
 end
 

設定例(自動 IPv4 互換モード)

R1、R3、および R5 の設定は、手動 IPv6 モードの例と同じです。 変更点があるのは、R2R4 の設定だけです。 IPv4 互換トンネルを設定するときには、トンネルの宛先の IPv4 アドレスを明示的に指定しないでください。 トンネルの宛先は、IPv6 ルートの IPv6 ネクストホップ アドレスから自動的に計算されます。 そのようなトンネル上にルートを設定するには、BGP やスタティック ルートなどのように明示的に近隣アドレスが定義されたルーティング プロトコルが必要です。 この場合、BGP ネイバーの IPv6 アドレスまたはスタティック ルートのネクストホップ アドレスとして、IPv4 互換の IPv6 アドレスを使用する必要があります。

次の例では、IPv4 互換 IPv6 アドレスとして、R2 および R4 上のシリアル インターフェイスを使用します。 同じシリアル インターフェイスがトンネルの発信元になっています。 たとえば、R2 S0/0 の IPv4 アドレス 192.23.1.2 は、IPv6 表記では「::192.23.1.2」に変換されています。 このアドレスは、BGP ピアの IPv6 アドレスおよび BGP のネクストホップとして使用されています。 最終的には、IPv6 BGP ルートが IPv6 RIP に再配布されて、ネットワークのリモート エンドが情報を取得できるようになります。

このトンネリング方法は、現在では廃止されています。 IPv6 ISATAP のトンネリング方法を使用することをお勧めします。 この方法の詳細については、『ISATAP トンネル』を参照してください。

注:自動 IPv6 モードでは、トンネルの宛先を設定する必要はありません。

R2-IPv6-IPv4(Cisco 3640 ルータ)
 R2-ipv6-ipv4#show run
 Building configuration...
 Current configuration : 1394 bytes
 !
 version 12.3
 !
 hostname R2-ipv6-ipv4
 !
 !
 ip subnet-zero
 !
 !
 !
 ipv6 unicast-routing
 !
 !
 interface Tunnel0
  no ip address
  no ip redirects
  ipv6 rip 6bone enable
  tunnel source Serial0/0
 tunnel mode ipv6ip auto-tunnel
 
 !--- 自動 IPv4 互換トンネルを設定します。
 
 
 !
 !
 interface Serial0/0
  ip address 192.23.1.2 255.255.255.0
  clockrate 64000
 !
 interface FastEthernet0/1
  no ip address
  duplex auto
  speed auto
  ipv6 address 2000:1:1:1:1:1:1:1111/112
  ipv6 rip 6bone enable
 !
 !
 router ospf 1
  log-adjacency-changes
  network 192.23.1.0 0.0.0.255 area 0
 !
 router bgp 100
  no synchronization
  no bgp default ipv4-unicast
  bgp log-neighbor-changes
  neighbor ::192.34.1.4 remote-as 100
  no auto-summary
  !
  address-family ipv6
  neighbor ::192.34.1.4 activate
  neighbor ::192.34.1.4 next-hop-self
  network 2000:1:1:1:1:1:1:0/112
 bgp redistribute-internal
 
 !--- show run コマンドを redistribute bgp コマンドとともに
 !--- 使用すると、別のサイトからトンネルを経由して学習した IPv6 ルートを
 !--- BGP で再配布できます。
 
 
  exit-address-family
 !         
 ip classless
 !
 ipv6 router rip 6bone
 redistribute bgp 100 metric 2
 !
 !
 line con 0
 line aux 0
 line vty 0 4
  login
 line vty 5 15
  login
 !
 !
 end
 
R4-IPv4-IPv6(Cisco 3640 ルータ)
 R4-ipv4-ipv6#show run
 Building configuration...
  
 Current configuration : 1697 bytes
 !
 version 12.3
 !
 hostname R4-ipv4-ipv6
 !
 ip subnet-zero
 !
 !
 no ip domain-lookup
 !
 ipv6 unicast-routing
 !
 !
 !
 interface Tunnel0
  no ip address
  no ip redirects
  ipv6 rip 6bone enable
  tunnel source Serial1/5
 tunnel mode ipv6ip auto-tunnel
 
 !--- 自動 IPv4 互換トンネルを設定します。
 
 
 !
 !
 interface Serial1/5
  ip address 192.34.1.4 255.255.255.0
  clockrate 64000
 !
 !
 interface Ethernet3/0
  no ip address
  half-duplex
  ipv6 address 4000:1:1:1:1:1:1:1111/112
  ipv6 rip 6bone enable
 !
 router ospf 1
  log-adjacency-changes
  network 192.34.1.0 0.0.0.255 area 0
 !
 router bgp 100
  no synchronization
  no bgp default ipv4-unicast
  bgp log-neighbor-changes
  neighbor ::192.23.1.2 remote-as 100
  no auto-summary
  !
  address-family ipv6
  neighbor ::192.23.1.2 activate
  neighbor ::192.23.1.2 next-hop-self
  network 4000:1:1:1:1:1:1:0/112
 bgp redistribute-internal
 
 !--- show run コマンドを redistribute bgp コマンドとともに
 !--- 使用すると、別のサイトからトンネルを経由して学習した IPv6 ルートを
 !--- BGP で再配布できます。
 
 
  exit-address-family
 !
 ip classless
 !
 ipv6 router rip 6bone
 redistribute bgp 100 metric 2
 !
 !
 !         
 line con 0
 line aux 0
 line vty 0 4
  login
 !
 !
 end
 

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を示します。

特定の show コマンドが、アウトプットインタープリタ登録ユーザ専用)(OIT)でサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

  • ping — リモート ホストがアクティブまたは非アクティブのどちらであるか、およびホストとの通信における往復遅延を判別できます。

  • show ipv6 route — IPv6 でルートが存在するかどうかを確認できます。

  • show bgp ipv6 — BGP が稼働中であるかどうかを確認できます。

  • show bgp ipv6 summary — IPv6 で稼働する BGP の要約情報を表示できます。

  • show ipv6 int tunnel 0 — IPv6 でトンネルがアップ状態であるかどうかを確認できます。

手動 IPv6 モードの確認コマンドの出力

R5 の IPv6 アドレスに対する ping を R1 から実行して、IPv4 ネットワーク経由のトンネル上を IPv6 が転送されているかどうかを確認します。

 R1-ipv6#ping ipv6 4000:1:1:1:1:1:1:1112 
 Type escape sequence to abort. 
 Sending 5, 100-byte ICMP Echos to 4000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
 !!!!! 
 Success rate is 100 percent (5/5), round-trip min/avg/max = 72/72/72 ms 
 R1-ipv6#ping 4000:1:1:1:1:1:1:1112 
 Type escape sequence to abort. 
 Sending 5, 100-byte ICMP Echos to 4000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
 !!!!! 
 Success rate is 100 percent (5/5), round-trip min/avg/max = 72/72/72 ms 
 R1-ipv6#
 

R5 から、R1 の IPv6 アドレスに ping を実行します。

 R5-ipv6#ping  2000:1:1:1:1:1:1112 
 Type escape sequence to abort. 
 Sending 5, 100-byte ICMP Echos to 2000:1:1:1:1:1:1112, timeout is 2 seconds: 
 !!!!! 
 Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms 
 R5-ipv6#ping ipv6 2000:1:1:1:1:1:1112 
 Type escape sequence to abort. 
 Sending 5, 100-byte ICMP Echos to 2000:1:1:1:1:1:1112, timeout is 2 seconds: 
 !!!!! 
 Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms 
 R5-ipv6#
 

自動 IPv6 モードの確認コマンドの出力

リモート IPv6 ネットワークに対して ping を実行して、トンネル経由の接続を確認します。

 R1-ipv6#ping 4000:1:1:1:1:1:1:1112 
 Type escape sequence to abort. 
 Sending 5, 100-byte ICMP Echos to 4000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
 !!!!! 
 Success rate is 100 percent (5/5), round-trip min/avg/max = 68/69/72 ms 
 R1-ipv6# 
 R5-ipv6#ping ipv6 2000:1:1:1:1:1:1:1112 
 Type escape sequence to abort. 
 Sending 5, 100-byte ICMP Echos to 2000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
 !!!!! 
 Success rate is 100 percent (5/5), round-trip min/avg/max = 68/70/72 ms 
 R5-ipv6#
 

ping が失敗する場合、IPv6 ルーティング テーブルを調べて、ルートが存在するかどうかを確認します。 また、相手側のルーティング テーブルもチェックします。 R5 や R1 などのエンド ルータでのルートは、RIP ルートとして学習されます。 このルートは、R2 および R4 において、BGP から RIP に再配布されています。 R2 と R4 は、トンネルが終了し、BGP ピアリングが設定されている場所です。

 R5-ipv6#show ipv6 route 
 IPv6 Routing Table - 6 entries 
 Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
        I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
 Timers: Uptime/Expires 
 R   ::/96 [120/2] 
      via FE80::230:80FF:FEF3:4731, Ethernet1/2
 R   2000:1:1:1:1:1:1:0/112 [120/3]
      via FE80::230:80FF:FEF3:4731, Ethernet1/2
 L   4000:1:1:1:1:1:1:1112/128 [0/0] 
      via ::, Ethernet1/2
 C   4000:1:1:1:1:1:1:0/112 [0/0] 
      via ::, Ethernet1/2
 L   FE80::/10 [0/0] 
      via ::, Null0
 L   FF00::/8 [0/0] 
      via ::, Null0
 R5-ipv6#
 

エンド ルータ上にリモート IPv6 ネットワークがない場合、トンネルを終端するルータをチェックします。

 R4-ipv4-ipv6#show ipv6 route 
 IPv6 Routing Table - 7 entries 
 Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
        I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
 Timers: Uptime/Expires 
 L   ::192.34.1.4/128 [0/0] 
      via ::, Tunnel0
 C   ::/96 [0/0] 
      via ::, Tunnel0
 B   2000:1:1:1:1:1:1:0/112 [200/0]
      via ::192.23.1.2, Null
 L   4000:1:1:1:1:1:1:1111/128 [0/0] 
      via ::, Ethernet3/0
 C   4000:1:1:1:1:1:1:0/112 [0/0] 
      via ::, Ethernet3/0
 L   FE80::/10 [0/0] 
      via ::, Null0
 L   FF00::/8 [0/0] 
      via ::, Null0
 R4-ipv4-ipv6#
 

IPv6 BGP を使用して 2 つの異なる IPv6 ネットワーク間で情報を共有しているため、BGP がアップ状態で実行中であることを確認します。

 R4-ipv4-ipv6#show bgp ipv6 
 BGP table version is 3, local router ID is 192.34.1.4 
 Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
               r RIB-failure 
 Origin codes: i - IGP, e - EGP, ? - incomplete 
    Network          Next Hop            Metric LocPrf Weight Path 
 *>i2000:1:1:1:1:1:1:0/112 
                     ::192.23.1.2                  100      0 i 
 *> 4000:1:1:1:1:1:1:0/112 
                     ::                                 32768 i 
 R4-ipv4-ipv6#show bgp ipv6 summary 
 BGP router identifier 192.34.1.4, local AS number 100 
 BGP table version is 3, main routing table version 3 
 2 network entries and 2 paths using 394 bytes of memory 
 2 BGP path attribute entries using 120 bytes of memory 
 0 BGP route-map cache entries using 0 bytes of memory 
 0 BGP filter-list cache entries using 0 bytes of memory 
 BGP activity 2/8 prefixes, 2/0 paths, scan interval 60 secs 
 Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd 
 ::192.23.1.2    4   100      24      24        3    0    0 00:19:00        1 
 R4-ipv4-ipv6# 
 R4-ipv4-ipv6#show ipv6 int tunnel 0 
 Tunnel0 is up, line protocol is up 
   IPv6 is enabled, link-local address is FE80::C022:104 
   Global unicast address(es): 
     ::192.34.1.4, subnet is ::/96 
   Joined group address(es): 
     FF02::1 
     FF02::2 
     FF02::9 
     FF02::1:FF22:104 
   MTU is 1480 bytes 
   ICMP error messages limited to one every 100 milliseconds 
   ICMP redirects are enabled 
   ND DAD is not supported 
   ND reachable time is 30000 milliseconds 
   Hosts use stateless autoconfig for addresses. 
 R4-ipv4-ipv6#
 

トラブルシューティング

このセクションでは、設定のトラブルシューティングに役立つ情報を説明します。

トラブルシューティングのためのコマンド

特定の show コマンドが、アウトプットインタープリタ登録ユーザ専用)(OIT)でサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

注:debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

  • show ipv6 route — IPv6 でルートが存在するかどうかを確認できます。

  • show ip ospf neighbor — 隣接ルータのルータ ID、優先度、および状態を表示できます。 このコマンドでは、隣接デバイスのダウンを宣言する前に、隣接デバイスからの Open Shortest Path First(OSPF)hello パケットの受信をルータが待機する残り時間も表示されます。 また、この隣接デバイスが直接接続されているインターフェイス、および OSPF 隣接デバイスが隣接関係を形成するインターフェイスの IP アドレスも表示されます。

  • show ipv6 interface brief — トンネル インターフェイスがアップ状態であることを確認できます。

  • show interfaces tunnel 0 — 設定されたトンネルの宛先が、ルーティング テーブルに反映されていることを確認できます。

  • show ipv6 rip — IPv6 RIP 情報を表示できます。

  • show ipv6 protocols — IPv6 ルーティング プロトコルのステータスを表示できます。

リモート IPv6 ネットワークへの ping が失敗した場合、IPv6 ルートが IPv6 RIP を介して学習されることを確認します。

 R1-ipv6#show ipv6 route 
 IPv6 Routing Table - 6 entries 
 Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
        I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
 Timers: Uptime/Expires 
 L   2000:1:1:1:1:1:1:1112/128 [0/0] 
      via ::, Ethernet0/1
 C   2000:1:1:1:1:1:1:0/112 [0/0] 
      via ::, Ethernet0/1
 R   3000::/112 [120/2]
      via FE80::202:B9FF:FECB:D281, Ethernet0/1
 R   4000:1:1:1:1:1:1:0/112 [120/3] 
      via FE80::202:B9FF:FECB:D281, Ethernet0/1
 L   FE80::/10 [0/0] 
      via ::, Null0
 L   FF00::/8 [0/0] 
      via ::, Null0
 R1-ipv6#
 

R2 では、IPv6 RIP ルートが Tunnel0 インターフェイスから学習されていることを確認します。

 R2-ipv6-ipv4#show ipv6 route 
 IPv6 Routing Table - 7 entries 
 Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
        I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
 Timers: Uptime/Expires 
 L   2000:1:1:1:1:1:1:1111/128 [0/0] 
      via ::, FastEthernet0/1
 C   2000:1:1:1:1:1:1:0/112 [0/0] 
      via ::, FastEthernet0/1
 L   3000::1/128 [0/0] 
      via ::, Tunnel0
 C   3000::/112 [0/0] 
      via ::, Tunnel0
 R   4000:1:1:1:1:1:1:0/112 [120/2]
      via FE80::230:80FF:FEF3:4701, Tunnel0
 L   FE80::/10 [0/0] 
      via ::, Null0
 L   FF00::/8 [0/0] 
      via ::, Null0
 R2-ipv6-ipv4#
 

接続に関する問題が存在する場合、まず IPv4 ネットワークに問題がないことを確認します。 また、リモート トンネル インターフェイスのトンネルの発信元であり、IPv4 アドレスへのルートがある OSPF 隣接デバイスの隣接関係も確認します。 次に、IPv4 の ping を使用して、トンネルの発信元の間で ping を実行できることを確認します。

 R2-ipv6-ipv4#show ip ospf neighbor 
 Neighbor ID     Pri   State           Dead Time   Address         Interface 
 192.23.1.3        1   FULL/  -        00:00:36    192.23.1.3      Serial0/0 
 R2-ipv6-ipv4# 
 R3-ipv4#show ip ospf neighbor 
 Neighbor ID     Pri   State           Dead Time   Address         Interface 
 1.1.1.1           1   FULL/  -        00:00:30    192.34.1.4      Serial0/1 
 192.23.1.2        1   FULL/  -        00:00:35    192.23.1.2      Serial0/0 
 R3-ipv4# 
 R4-ipv4-ipv6#show ip ospf neighbor 
 Neighbor ID     Pri   State           Dead Time   Address         Interface 
 192.23.1.3        1   FULL/  -        00:00:35    192.34.1.3      Serial1/5 
 R4-ipv4-ipv6#
 

R2 で、IPv6 トンネル インターフェイスがアップ状態になっていることと、IPv4 互換 IPv6 アドレスを指定して、リモート トンネルの発信元に IPv6 の ping を実行できることを確認します。 トンネル インターフェイスがダウンしている場合、設定されたトンネルの宛先が、ルーティング テーブルに反映されていることを確認します。 トンネルの宛先がルーティング テーブルに存在しないので、これはネットワークの IPv4 部分の問題になります。

 R2-ipv6-ipv4#show ipv6 interface brief 
 FastEthernet0/0            [up/up] 
     unassigned 
 Serial0/0                  [up/up] 
     unassigned 
 FastEthernet0/1            [up/up] 
     2000:1:1:1:1:1:1:1111 
 Tunnel0                    [up/up] 
     3000::1 
 R2-ipv6-ipv4# 
 R2-ipv6-ipv4#show interfaces tunnel 0 
 Tunnel0 is up, line protocol is up 
   Hardware is Tunnel 
   MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec, 
      reliability 255/255, txload 1/255, rxload 1/255 
   Encapsulation TUNNEL, loopback not set 
   Keepalive not set 
   Tunnel source 192.23.1.2 (Serial0/0), destination 192.34.1.4 
   Tunnel protocol/transport IPv6/IP, key disabled, sequencing disabled 
   Tunnel TTL 255 
   Checksumming of packets disabled 
   Last input 00:00:09, output 00:00:19, output hang never 
   Last clearing of "show interface" counters never 
   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
   Queueing strategy: fifo 
   Output queue :0/0 (size/max) 
   5 minute input rate 0 bits/sec, 0 packets/sec 
   5 minute output rate 0 bits/sec, 0 packets/sec 
      3119 packets input, 361832 bytes, 0 no buffer 
      Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
      0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
      3117 packets output, 361560 bytes, 0 underruns 
      0 output errors, 0 collisions, 0 interface resets 
      0 output buffer failures, 0 output buffers swapped out 
 R2-ipv6-ipv4#
 

この時点でも IPv6 ルートに問題が存在し、IPv4 ネットワークが確認済みの場合は、IPv6 RIP 設定を確認する必要があります。

 R2-ipv6-ipv4#show ipv6 rip 
 RIP process "6bone", port 521, multicast-group FF02::9, pid 111 
      Administrative distance is 120.  Routing table is 0 
      Updates every 30 seconds, expire after 180 
      Holddown lasts 180 seconds, garbage collect after 120 
      Split horizon is on; poison reverse is off 
      Default routes are not generated 
      Periodic updates 176, trigger updates 1 
 R2-ipv6-ipv4# 
 R2-ipv6-ipv4#show ipv6 protocols 
 IPv6 Routing Protocol is "connected" 
 IPv6 Routing Protocol is "static" 
 IPv6 Routing Protocol is "rip 6bone" 
   Interfaces: 
     FastEthernet0/1 
     Tunnel0 
   Redistribution: 
     Redistributing protocol rip 6bone
 

デフォルト設定が使用されていない場合は、タイマーが同一であることを確認します。 この例では、すべての IPv6 RIP ルータでデフォルトが使用されています。 設定を確認して、すべての RIP 対応インターフェイスを正しく設定します。 また、ネットワーク全体で一貫して同じ RIP プロセス名が使用されていることも確認します。 必要に応じて、debug ipv6 rip の出力を調べます。 すべてのデバッグに言えることですが、CPU とコンソール ロギング バッファに過負荷をかけないよう、注意が必要です。

要約

このドキュメントでは、IPv6 と IPv4 を同一のネットワークで共存させるための、トンネルの使用法について説明しています。 これは、移行期間中に必要になる可能性があります。 IPv6 の設定に関する注意点としては、IPv6 RIP では network 文を使用しないことがあります。 IPv6 RIP がグローバルに有効であれば、各インターフェイスが RIP に参加し、IPv6 RIP に対して有効になります。 IPv6 BGP の例では、「自動トンネル」のセクションに address-family ipv6 コマンド セットを使用して BGP ステートメントを入力する必要があります。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報