スイッチ : Cisco Catalyst 3750 シリーズ スイッチ

Catalyst 3750 シリーズ スイッチでの一般的な問題のトラブルシューティング

2009 年 6 月 16 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2007 年 7 月 6 日) | フィードバック

目次


概要

このドキュメントでは、Cisco Catalyst 3750 シリーズ スイッチでの一般的な問題と、問題を解決するための方法について説明しています。



前提条件

要件

このドキュメントに関する特別な要件はありません。



使用するコンポーネント

このドキュメントの情報は、Cisco Catalyst 3750 シリーズ スイッチに基づくものです。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。



表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。



接続性の問題

イーサネット速度とデュプレックスの自動ネゴシエーションのミスマッチ

IEEE 802.3ab 自動ネゴシエーション プロトコルでは、速度(10 Mbps、100 Mbps、および SFP モジュール ポートを除外する 1000 Mbps)とデュプレックス(半二重または全二重)のスイッチ設定が管理されます。このプロトコルによりこれらの設定が誤って調整され、パフォーマンスが下がる場合があります。

ミスマッチが発生するのは、次の状況です。

  • 手動で設定したポートの速度とデュプレックスのパラメータが、接続先のポート上で手動で設定された速度とデュプレックスのパラメータと異なっている。

  • ポートが自動ネゴシエートに設定されており、接続先のポートは自動ネゴシエーションなしで全二重で設定されている。

デュプレックスと速度の設定を変更する際に、スイッチのパフォーマンスを最大にしてリンクを確立するには、次のガイドラインに従ってください。

  • 両方のポートで、速度とデュプレックスの両方を自動ネゴシエートに設定する。

または

  • 接続されている両端のポートで、速度とデュプレックスのパラメータを手動で設定する。

注:リモート デバイスで自動ネゴシエートが行われない場合は、2 つのポートで一致するようにデュプレックスの設定を行ってください。接続ポートで自動ネゴシエートが行われなくても、速度パラメータ自体の調整が可能です。



SFP 速度とデュプレックスの自動ネゴシエーションのミスマッチ

SFP モジュール ポートでは速度は設定できませんが、自動ネゴシエーションがサポートされていないデバイスに接続されている場合に速度をネゴシエートしないように(nonegotiate)は設定できます。ところが、SFP モジュール ポートに 1000BASE-T SFP モジュールがある場合は、速度を 10 Mbps、100 Mbps、または 1000 Mbps、あるいは自動に設定できます。

1000BASE-T SFP モジュールまたは 100BASE-FX MMF SFP モジュールがポートにない場合、SFP モジュール ポートでデュプレックス モードの設定はできません。他のすべての SFP モジュールは、全二重モードでのみ動作します。

  • 1000 BASE-T SFP モジュールが SFP モジュール ポートにある場合は、デュプレックス モードを自動または全二重に設定できます。

  • 100 BASE-FX SFP モジュールが SFP モジュール ポートにある場合は、デュプレックス モードを半二重または全二重に設定できます。

注:ギガビット イーサネット インタフェースでは半二重モードがサポートされています。ところが、これらのインタフェースを半二重モードで動作するようには設定できません。



IP ルーティングがイネーブルになってからの接続喪失

ユーザが直面する普遍的な問題の 1 つは、スイッチで IP ルーティングがイネーブルになってからの接続の喪失です。通常、この問題の原因はデバイスに対してデフォルト ゲートウェイの設定に使用されたコマンドです。

デバイスで IP ルーティングがイネーブルになっていない場合、このコマンドは ip default-gateway です。

3750-1#ip default-gateway A.B.C.D


!--- A.B.C.D はデフォルト ルータの IP アドレスです。

IP ルーティングがイネーブルになっている場合は、そのデバイスに対してデフォルト ルータを指定するのに、ip route コマンドを使用します。

3750-1#ip route 0.0.0.0 0.0.0.0 A.B.C.D


!--- A.B.C.D はデフォルト ルータの IP アドレスです。



単一の VLAN に割り当てられた場合に、アクセス ポートとして設定されていないポートにより接続が断続的になる問題

特定の VLAN にポートが割り当てられている場合、インターフェイスをパーマネント非トランキング モードに設定するため、さらに、インターフェイス ネゴシエーションでリンクが非トランク リンクに変換されるのを確認するために、ポートに対して switchport mode access コマンドが適用されている必要があります。隣接インターフェイスが変更されなかった場合でも、インターフェイスは非トランク インターフェイスになります。

switchport mode access コマンドが適用されていないと、ポートでフラッピングが発生する可能性があります。このコマンドにより、ポートは非トランク リンクとして機能するようになります。

インターフェイスをアクセス モードに設定するには、次の手順を実行します。

  1. 次のように、アクセス ポートとして設定するインターフェイスにアクセスします。

    Switch(config)#interface fastEthernet 0/25
    Switch(config-if)#switchport mode access
    
    !--- このコマンドにより、インターフェイスがパーマネント非トランキング モードにされます。
    
    Switch(config-if)#switchport access vlan 3
    
    !--- このコマンドにより、インターフェイス fastethernet 0/25 が VLAN 3 に割り当てられます。
    
    Switch(config-if)#no shut
    
  2. スイッチでポート フラッピングが発生している場合は、フラッピングが発生しているインターフェイスに switchport mode access が適用されているかどうかを調べてください。show run コマンドの出力を調べます。

    Switch# show run
    Building configuration...
    
    Current configuration : 3183 bytes
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log datetime
    service password-encryption
    !
    
    !--- 出力を省略。
    
    !
    interface FastEthernet0/25
     switchport access vlan 3
     switchport mode access
    !
    interface FastEthernet0/26
     switchport access vlan 3
    !
    
    !--- 出力を省略。
    
    

    注:FastEthernet0/26 は VLAN 3 に所属すると設定されているだけですが、インターフェイス FastEthernet0/25 はアクセス ポートとして設定されています。

    注:ポート フラッピングが発生するのは、物理インターフェイスにデバイスやホストが接続されている場合だけです。



Catalyst 3750 スイッチで TCN パケットが大量に受信される

ネットワークにホストが多数存在する場合、スイッチでは複数の Topology Change Notification(TCN)パケットを受信する可能性があります。たとえば、直接に接続されたサーバで電源再投入(電源のオフ/オン)が行われた際に、スイッチではトポロジ変更のスパニング ツリー ルート(root)を通知する必要があります。

これによりブリッジは、トポロジ変更を知らせる必要が生じると、そのルート(root)ポートに TCN パケットの送信を開始します。代表ブリッジでは、TCN が受信されると受信確認が返送され、自身のルート(root)ポート用に別の TCN が生成されます。このプロセスは、TCN がルート(root)ブリッジに到達するまで続けられます。

ここで考慮する必要のある重要な点は、TCN では STP 再計算は開始されないということです。通常、TCN は不安定な STP 環境に関連するものであるという事実から、この懸念が派生しますが、TCN は不安定な環境の結果であり、原因ではありません。TCN による影響があるのは、エージング タイムだけです。これにより、トポロジが変更されたり、ループが発生することはありません。

スイッチがポートで大量の TCN を受信する場合は、それらのポートに接続されているのがエンド デバイスだけであることを確認してください。TCN を回避するために、エンド デバイスが接続されている各ポートで PortFast をイネーブルにできます。PortFast に設定されたポートがアップやダウンしても、スイッチでは TCN が生成されません。

注:ハブや他のブリッジに接続されているポートでは、STP PortFast は絶対に使用しないでください。

スパニング ツリーでのトポロジ変更についての詳細は、『スパニングツリー プロトコル トポロジの変更』を参照してください。



ポートにホストとデバイスが何も接続されていない場合、インターフェイス VLAN が UP/DOWN 状態になる

新しい VLAN をレイヤ 3 インターフェイスとして作成する際に、それにポートが割り当てられておらず、ポートの状態が Not Connected になっていると、この VLAN の状態は UP/DOWN と表示されます。この VLAN の状態が UP/UP と表示されるようにするには、このインターフェイス VLAN に少なくとも 1 つのポートが割り当てられている必要があり、さらに、この新しいインターフェイス VLAN に割り当てられているポートにデバイスかホストが接続されている必要があります。

次の例では、新しいレイヤ 3 インターフェイス VLAN が作成されます。この新しい VLAN にポートが 1 つ割り当てられ、そのポートにデバイスが接続されると、インターフェイス VLAN の状態が UP/UP になります。

  1. 新しい VLAN をデータベースに作成します。VLAN データベース モードを終了すると、設定変更が適用されます。

    Switch# vlan database
    Switch(vlan)# vlan 40
    VLAN 40 added:
        Name: VLAN0040
    Switch(vlan)# exit
    APPLY completed.
    Exiting....
    
  2. VLAN データベースに VLAN が作成されていることを確認します。show vlan コマンドの出力を調べます。

    Switch# show vlan
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa1/0/2, Fa1/0/3, Fa1/0/4
                                                    Fa1/0/5, Fa1/0/6, Fa1/0/7
                                                    Fa1/0/8, Fa1/0/9, Fa1/0/10
                                                    Fa1/0/11, Fa1/0/13, Fa1/0/14
                                                    Fa1/0/15, Fa1/0/16, Fa1/0/17
                                                    Fa1/0/18, Fa1/0/19, Fa1/0/20
                                                    Fa1/0/21, Fa1/0/22, Fa1/0/23
                                                    Fa1/0/24, Gi1/0/1, Gi1/0/2
    2    VLAN0002                         active    
    10   data                             active    
    21   VLAN0021                         active    
    35   VLAN0035                         active    
    36   VLAN0036                         active    Fa1/0/12
    40   VLAN0040                   active    
    99   VLAN0099                         active    
    100  VLAN0100                         active    
    198  VLAN0198                         active 
    

    注:VLAN 40 にはポートが割り当てられていません。

  3. 新しく作成された VLAN に IP アドレスを設定します。

    Switch(config)# int vlan 40
    Switch(config-if)# ip address 10.4.4.1 255.255.255.0
    Switch(config-if)# no shut
    Switch(config-if)# exit
    
  4. 対応する VLAN にクライアントを接続する物理インターフェイスを設定します。

    Switch(config)# int fa 1/0/2
    Switch(config-if)# switchport mode access
    Switch(config-if)# switchport access vlan 40
    Switch(config-if)# no shut
    
  5. VLAN にその物理インターフェイスが割り当てられていることを確認します。

    Switch# show vlan
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa1/0/3, Fa1/0/4, Fa1/0/5
                                                    Fa1/0/6, Fa1/0/7, Fa1/0/8
                                                    Fa1/0/9, Fa1/0/10, Fa1/0/11
                                                    Fa1/0/13, Fa1/0/14, Fa1/0/15
                                                    Fa1/0/16, Fa1/0/17, Fa1/0/18
                                                    Fa1/0/19, Fa1/0/20, Fa1/0/21
                                                    Fa1/0/22, Fa1/0/23, Fa1/0/24
                                                    Gi1/0/1, Gi1/0/2
    2    VLAN0002                         active    
    10   data                             active    
    21   VLAN0021                         active    
    35   VLAN0035                         active    
    36   VLAN0036                         active    Fa1/0/12
    40   VLAN0040                   active    Fa1/0/2
    
  6. この段階では、ポート Fa1/0/2 にはホストやデバイスが接続されていないため、VLAN の状態は UP/DOWN と表示されます。

    Switch# show interface vlan 40
    Vlan40 is up, line protocol is down 
    
    !--- 出力を省略。
    
    

    注:ポート Fa1/0/2 にホストやデバイスが物理的に接続されていないため、VLAN にポートが割り当てられていても、VLAN の状態は UP/DOWN と表示されます。

  7. VLAN 40 に所属するポート Fa1/0/2 にホストかデバイスを接続します。

  8. ポート Fa1/0/2 の状態が UP/UP になっていることを確認します。

    Switch# show interface fa1/0/2
    FastEthernet1/0/2 is up, line protocol is up
    
    !--- 出力を省略。
    
    
  9. この段階では、新しい VLAN にポートが割り当てられていて、そのポートの状態が UP/UP なので、VLAN の状態は UP/UP と表示されます。

    Switch# show interface vlan 40
    Vlan40 is up, line protocol is up
    
    !--- 出力を省略。
    
    

    注:レイヤ 3 VLAN の状態が UP/UP と表示されるのは、その VLAN のポートが割り当てられていて、そのポートの状態が UP/UP の場合だけです。



IP 電話への接続

IP 電話で IP アドレスの取得と設定が行われるためには、DHCP が重要な役割を果たします。IP 電話と DHCP サーバ間での通信は、さまざまな理由により妨げられる場合があります。一般的な原因と解決法のリストを次に示します。



HTTP アクセスの問題

デバイスのリブート時に自己署名証明書が失われている

スイッチがホスト名とドメイン名で設定されていない場合は、一時的な自己署名証明書が生成されます。スイッチがリブートすると、一時的な自己署名証明書がすべて失われて、新しい一時的な自己署名証明書が割り当てられます。

スイッチがホスト名とドメイン名で設定されている場合は、永続的な自己署名証明書が生成されます。スイッチをリブートしたり、セキュア HTTP サーバをディセーブルにする場合も、この証明書はアクティブなままで残り、再度セキュア HTTP 接続をイネーブルにする際にも存在しています。

セキュア HTTP 接続をイネーブルにして、Client Authentication(CA; クライアント認証)トラストポイントを設定しない場合には、一時的または永続的な自己署名証明書が自動的に生成されます。

注:セキュア HTTP 接続では、CA トラストポイントを設定することを強く推奨します。HTTPS サーバが稼働するデバイスに CA トラストポイントが設定されていない場合は、サーバは自身を証明して、必要な Rivest, Shamir, Adelman(RSA)鍵ペアを生成します。自己証明された(自己署名された)証明書では十分なセキュリティが提供されないため、接続するクライアントでは証明書が自己証明であることの通知が生成されます。これにより、ユーザには接続を許可するか、拒否する機会が与えられます。



HTTP アクセスには使用されないローカル ユーザ名

Catalyst 3750 スイッチのデバイス マネージャに接続する際には、スイッチではデバイスに設定されたローカル ユーザ名が使用されず、シークレット パスワードだけが使用されるか、シークレット パスワードが設定されていない場合に限りイネーブル パスワードが使用されます。

接続をセキュアにするには、デバイスで SSL をイネーブルにできます。詳細は、『Secure Socket Layer(SSL)HTTP 用のスイッチの設定』を参照してください。



Cisco IOS ソフトウェアがアップグレードされる際にセキュア HTTP アクセスが失われる

Cisco Catalyst 3750 シリーズ スイッチで Cisco IOS(R) ソフトウェアをアップグレードすると、デバイスへのセキュアなアクセスが失われる場合があります。アクセスをいったんディセーブルにしてから、再度、イネーブルにしても、アクセスは回復されません。この問題に対処するには、次の手順を実行してください。

  1. セキュア HTTP サーバをディセーブルにします。

    no ip http secure-server
    
  2. CA トラストポイントか PKI トラストポイントの設定を削除します。

    no crypto ca trustpoint name
    
    

    または

    no crypto pki trustpoint name
    
    
  3. セキュア HTTP サーバを再設定するには、『SSL 設定のガイドライン』で説明されている手順を使用してください。



Power Over Ethernet の問題

電力の過剰設定

Cisco Catalyst 3560 および 3750 シリーズ Power over Ethernet(PoE)製品の Power Inline Consumption 機能により、ネットワーク管理者はインライン電力供給先デバイスの実際の所要電力を設定できます。この機能により管理者は、インライン電力供給先デバイスの分類設定を変更できます。この機能は多くの大規模な企業のお客様で必要とされたもので、リリース 12.2(25)SEC 以降でサポートされています。

次の 2 つのシナリオでは、Consumption Command Line Interface(CLI)を使用して、自動アルゴリズムよりも効率的に PoE 割り当てを手動設定できます。

  • 現在、Cisco Catalyst 3750 シリーズ スイッチでは、クラス 0 のインライン電力供給先デバイスには 15.4 W が割り当てられます。ところが、これらのインライン電力供給先デバイスの一部では、必要な最大電力は 15.4 W 未満です(たとえば、Siemens IP Phone に必要なのは 5 W です)。Power Inline Consumption 機能がないと、これらのデバイスは 24 台しか導入できないところでした。スイッチポートの所要電力の設定に power inline consumption コマンドを使用すると、これらのデバイスを 48 台まで導入できます。

  • クラス 3 のインライン電力供給先デバイスには、通常 15.4 W が割り当てられます。一部の IEEE クラス 3 のインライン電力供給先デバイス(8 〜 15 W の範囲)が使用する電力は、15.4 W の最大電力よりも大幅に少ないものです。例としては、最悪のシナリオでも 8 W しか使用しない Avaya 2620SW があります。この電話をサポートするポートを Consumption CLI で 8 W に設定した場合には、3750-48PS では 24 台ではなく 46 台の電話に安全に電力を供給できます。

注:スイッチの誤設定(電源モジュールの過剰設定)は、信頼性の低下、またはスイッチの損傷につながる可能性があります。電源モジュールが約 20 % まで過剰設定されている場合、スイッチは動作し続けますが、信頼性が低下する可能性があります。約 20 % を超えると、短絡保護回路が起動して、スイッチがシャットダウンされます。



停電のためポートが使用不可になる

PoE スイッチ ポートに接続されながら、AC 電源から電力を供給されているインライン電力供給先デバイス(たとえば、Cisco IP Phone 7910 など)で AC 電源からの電力供給が失われると、デバイスがエラー ディセーブル状態に入る可能性があります。エラー ディセーブル状態から回復するためには、shutdown インターフェイス設定コマンドを入力し、次に no shutdown インターフェイス コマンドを入力してください。



偽のリンク アップによりポートが使用不可になる

Cisco 製品からインライン電力供給を受けるデバイスがポートに接続されていて、ポートを power inline never インターフェイス設定コマンドで設定すると、偽のリンク アップによりポートがエラー ディセーブル状態に置かれることがあります。ポートをエラー ディセーブル状態から元に戻すには、power inline で PoE モードを変更し、shutdown および no shutdown インターフェイス設定コマンドを入力してください。Cisco 製品からインライン電力供給を受けるデバイスは、power inline never コマンドで設定されたポートには接続しないでください。3750 では、キャリア遅延はサポートされていません。さらに、キャリア遅延はリンク デバウンスの代替にはなりませんが、ラインカード ハードウェアの機能であり、レイヤ 3 Cisco IOS メカニズムです。このように、Cat3750 ではどちらもサポートされていません。



既存スタックに新しいスイッチが追加されると電話機の電源をオンにできない

既存スタックに新しいスイッチが追加されると、この問題が発生します。この新しいスイッチにはワークステーションが接続され、ポートがアップ状態になって、スイッチとワークステーション間の接続が確立されます。新しいスイッチに IP 電話が接続されても、電話機の電源がオンになれず、ポートがアップ状態になりません。

この問題が発生する場合は、IP 電話の電源をオンにするための PoE が新しいスイッチでサポートされていることを確認してください。新しいスイッチで PoE がサポートされていない場合は、スイッチで PoE のサポートが許可されるように設定を変更してください。

3750 のどのモデルで PoE がサポートされているかについての詳細は、『Cisco Catalyst 3750 Q&A』を参照してください。



スタックの問題

%STACKMGR-6-SWITCH_ADDED_VM

スタック メンバ間のソフトウェア互換性は、スタック プロトコル バージョン番号によって判別されます。スイッチ スタックのスタック プロトコル バージョンを表示するためには、show platform stack-manager all コマンドを発行できます。

3750-Stk# show platform stack-manager all
                                               Current
Switch#  Role      Mac Address     Priority     State
--------------------------------------------------------
 1       Slave     0016.4748.dc80     5         Ready
*2       Master    0016.9d59.db00     1         Ready


!--- 出力を省略。


                 Stack State Machine View
==============================================================

Switch   Master/   Mac Address          Version    Uptime   Current
Number   Slave                          (maj.min)            State
---------------------------------------------------------------------
1        Slave     0016.4748.dc80          1.11        8724    Ready
2        Master    0016.9d59.db00          1.11        8803    Ready


!--- 出力を省略。

同じバージョンの Cisco IOS ソフトウェアを使用しているスイッチ間では、スタック プロトコル バージョンも同じになります。そのようなスイッチには完全に互換性があり、すべての機能はスイッチ スタック全体で適切に機能します。スタック マスターと同じ Cisco IOS ソフトウェア バージョンを持つスイッチは、即座にスイッチ スタックに加わります。

非互換性が存在する場合、完全に機能するスタック メンバではシステム メッセージを生成して特定のスタック メンバの非互換性の原因を説明します。スタック マスターは、このメッセージをすべてのスタック メンバに送信します。

異なる Cisco IOS ソフトウェア バージョンのスイッチには、おそらく異なるスタック プロトコル バージョンが備わっています。異なるメジャー バージョン番号を持つスイッチは互換性がないため、同じスイッチ スタックの内には存在できません。

3750-Stk# show switch
                                               Current
Switch#  Role      Mac Address     Priority     State
--------------------------------------------------------
 1       Member    0015.c6f5.6000     1         Version Mismatch
*2       Master    0015.63f6.b700     15        Ready
 3       Member    0015.c6c1.3000     5         Ready

同じメジャー バージョン番号のスイッチでマイナー バージョン番号がスタック マスターと異なる場合は、部分的に互換性があると考えられます。スイッチ スタックに接続されている場合、部分的に互換性のあるスイッチは Version-Mismatch(VM; バージョン-ミスマッチ)モードに入り、完全に機能するメンバとしてスタックに加わることができません。ソフトウェアはミスマッチのソフトウェアを検出すると、スイッチ スタック フラッシュ メモリからの tar ファイル イメージまたはスイッチ スタック イメージを使用して、VM モードになっているスイッチのアップグレード(またはダウングレード)を試みます。ソフトウェアは自動アップグレード(auto-upgrade)機能、および、自動アドバイス(auto-advise)機能を使用します。

自動アップグレードは、スタック マスターで稼働しているソフトウェア リリースが VM モードになっているスイッチと互換性があり、さらに現在のイメージの tar ファイルがどのスタック メンバでも利用できる場合に行われます。現在のイメージの tar ファイルが利用できない場合、auto-advise 機能が、必要なコマンドを使用して互換性のあるイメージがダウンロードされることを推奨します。スイッチ マスターと VM モードになっているスイッチで異なるフィーチャ セット(IP サービスおよび IP ベース)や異なる暗号機能(暗号および非暗号)が稼働している場合、auto-upgrade 機能と auto-advise 機能は動作しません。

詳細は、『スタック内のスイッチが新しいイメージでブートされない(バージョンのミスマッチ)』を参照してください。



%IDBs can not be removed when switch is active

スタックからスイッチが排除される際に、次のエラー メッセージが返されます。

  • %IDBs can not be removed when switch is active
  • %Switch can not be un-provisioned when it is physically present

これらのエラー メッセージが表示されるのは、スタックからスイッチが排除されて、さらに、メンバ値がデフォルトの 1 に変更されない場合です。この問題を解決するには、次の手順を実行します。

  1. スタックから排除するスイッチの接続を解除する。

  2. 次のコマンドで、そのスイッチの番号付けをやり直す。

    switch current-stack-member-number renumber new-stack-member-number
    
    
  3. プロビジョニング済みのスイッチをスイッチ スタックから排除するためには、削除済みのスタック メンバに関連付けられたコンフィギュレーションが、プロビジョニング対象情報として実行コンフィギュレーションに残っています。このコンフィギュレーションを完全に削除するには、no switch stack-member-number provision グローバル設定コマンドを使用します。

メンバの番号付けについての詳細は、『スタック メンバ番号』を参照してください。



設定の問題

DHCP サービスが VLAN 経由で使用できない

Cisco Catalyst 3750 が DHCP リレー エージェントとして機能する場合には、DHCP サーバの VLAN とは異なる VLAN のクライアントへのサービスが行われない可能性があります。この問題を解決するには、次の手順を実行します。

  1. スイッチで IP ルーティングがイネーブルになっているかどうかを確認します。

  2. ネットワークで VTP バージョン 2 が稼働しているかどうかを確認します。

    3750-Stk#show vtp status
    VTP Version                     : 2
    
    !--- 出力を省略。
    
    
  3. ルーテッド インターフェイス上で DHCP サーバの IP ヘルパー アドレスを設定します。

    3750-Stk(config-if)# ip helper-address <IP Address of DHCP Server>
    
    
  4. グローバル コンフィギュレーション モードで、転送要求のための DHCP/BOOTP ポートを開きます。

    3750-Stk(config)#ip forward-protocol udp bootpc
    3750-Stk(config)#ip forward-protocol udp bootps
    


サポート対象外のコマンド

Catalyst 3750 シリーズ スイッチでは、CLI のヘルプに表示される CLI コマンドの一部に、テストされていないか、あるいは Catalyst 3750 スイッチのハードウェアの制限によりサポートされていないものがあります。

Cisco IOS ソフトウェア リリース 12.2(35)SE でのサポート対象外コマンドのリストについては、『Cisco IOS リリース 12.2(35)SE でサポートされないコマンド』を参照してください。

その他の Cisco IOS ソフトウェア リリースについては、『Catalyst 3750 スイッチ ソフトウェア コンフィギュレーション ガイド』を参照してください。



同じ VLAN 内でマルチキャストが機能しない

Catalyst スイッチでは、一般的な誤設定が原因で、マルチキャスト トラフィックがスイッチ間を流れないことがあります。この問題と利用可能なソリューションについての詳細は、『Catalyst スイッチで同一 VLAN 内でのマルチキャストが機能しない』を参照してください。



ポートのセキュリティ違反のためにポートがエラーディセーブル状態に移行する

ポートのセキュリティ違反は、1 つのセキュア インターフェイスで学習または設定されるアドレスが、同じ VLAN 内にある別のセキュア インターフェイスにある場合に発生します。

SW1-3750#
1d01h: %PM-4-ERR_DISABLE: psecure-violation error detected on Gi2/0/22, 
   putting Gi2/0/22 in err-disable state
1d01h: %PORT_SECURITY-2-PSECURE_VIOLATION: Security violation occurred, 
   caused by MAC address 0009.434b.c48c on port GigabitEthernet2/0/22.
1d01h: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/22, 
   changed state to down
1d01h: %LINK-3-UPDOWN: Interface GigabitEthernet2/0/22, 
   changed state to down SW1-3750#

1 つのセキュア インターフェイスから別のインターフェイスに移動する必要がある場合は、次の手順を実行します。

  1. ポートのセキュリティにダイナミック学習を使用して、静的な MAC アドレス リストやスティッキ学習設定を削除します。

    SW1-3750(config-if)#no switchport port-security mac-address sticky
    SW1-3750(config-if)#no switchport port-security mac-address H.H.H
    
    
    !--- H.H.H は設定されている 48 ビットの MAC アドレスです。
    
    
  2. ポート セキュリティ エージングを設定します。

    このエージング タイムにより、MAC アドレスが別のポートに現れる前に必要な最小の時間間隔が指定されます。

    SW1-3750(config-if)#switchport port-security aging time 1
    
    SW1-3750(config-if)#switchport port-security aging type inactivity
    

    aging type inactivity の指定により、指定された時間内にセキュアな送信元アドレスからデータトラフィックが送信されない場合に限り、このポートのセキュア アドレスがエージング アウトされます。

  3. ポートのセキュリティ違反からのエラーディセーブル状態の回復を設定します。

    SW1-3750(config)#errdisable recovery cause psecure-violation
    

詳細は、『ポートベース トラフィック制御の設定』の「ポート セキュリティの設定」セクションを参照してください。



FIB-2-FIBDOWN

FIB-2-FIBDOWN : CEF has been disabled due to a low memory condition.
It can be re-enabled by configuring "ip cef [distributed]"

CEF を再度イネーブルにする前に、原因を特定し、問題を解決してください。このエラーは、次の問題のうちの 1 つに起因する可能性があります。

  • デスクトップのデフォルト テンプレートで許可される非直接接続のルートの数が超過している。

    このテンプレートが使用されている場合は、最大数の 2000 を超過する可能性が高くなります。

    回避策としては、sdm prefer routing コマンドを発行してから、スイッチをリロードします。原理的には、この回避策で問題が解決されるはずです。詳細は、『SDM テンプレートの設定』を参照してください。

  • スイッチで学習された MAC アドレスの数が、MAC アドレスの保存用にハードウェアで割り当てられている容量を超過している。

    この場合、show mac-address-table count の出力では、空きエントリが 0 を示しています。

    回避策として、Switch Database Management(SDM)テンプレートを変更して、ユニキャストの MAC アドレス領域でより多くのスペースを使用できるようにするか、または不要な VLAN をプルーニングして、スイッチで学習される MAC アドレスの数を減らします。この問題は、Cisco Bug ID CSCef89559登録ユーザ専用)に記述されています。
    一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。



リロードのたびにシステム クロックがリセットされる

Catalyst 3750 スイッチやさらにローエンドのほとんどのスイッチ(2900 XL、3500 XL、2950、3550、3560)には、電池でバックアップされたシステム クロックが備わっていません。これにより、手動で設定した日時はリロードにより失われます。そのため、これらのスイッチでは、外部 NTP サーバを使用してシステムの日時を管理することが推奨されます。システム クロックについての詳細は、『スイッチの管理』の「システムの日時の管理」セクションを参照してください。

注:Cisco では、スイッチが同期できる外部ソースがない場合のみ、手動での日時設定を使用することを推奨いたします。



リロードするとスイッチのスタティック ルート設定が失われる

スイッチがリロードされるか、電源オフにしてから電源オンにされると、スタティック ルート設定が失われる場合があります。リロード後にルート設定が存在していることを確認するには、show run コマンドの出力を調べます。

スイッチで、リロード後にも確実にスタティック ルートが失われないようにするには、次の手順を実行します。

  1. スイッチ上で IP ルーティングをイネーブルにするために、グローバル コンフィギュレーション モードで ip routing コマンドを使用する。

    3750_Switch(config)#ip routing
    
    !--- インター VLAN ルーティングを行うために IP ルーティングをイネーブルにします。
    
    
  2. スタティック ルートを追加する。

  3. write memory コマンドを発行する。

    3750_Switch#write memory
    
  4. スイッチをリロードする。

  5. スイッチのリロードが完了したら、スタティック ルートが失われていないことを確認するために、show run コマンドを発行する。



セキュア シェルと Telnet を介してログインできない

セキュア シェルや Telnet を介して 3750 スイッチに接続しようとした際のログイン試行の失敗です。どちらの接続でもパスワードが要求されますが、ログインされません。ハイパーターミナル HTTP では、ユーザ名とパスワードでスイッチに接続できます。

SSH や Telnet を介してスイッチにアクセスするには、次の設定を使用します。

3750_Switch(config)#line vty 0 4
3750_Switch(config-line)#no password <removed>
3750_Switch(config-line)#login local
3750_Switch(config-line)#transport input ssh
3750_Switch(config)#line vty 5 15
3750_Switch(config-line)#no password <removed>
3750_Switch(config-line)#login local
3750_Switch(config-line)#transport input ssh

次のように、ユーザ名とパスワードでログインします。

username swadmin password 0 <removed>



Catalyst 3750 で default route コマンドが機能しない

Express Setup により、3750 スイッチで最初にデフォルト ルートを設定すると、デフォルト ゲートウェイが無効になっています。

3750 でデフォルト ゲートウェイ設定が有効になるには、ip routing コマンドがイネーブルにされている必要があります。Express Setup で 3750 スイッチを設定するのが初回である場合は、ip routing コマンドがデフォルトではイネーブルになっていないので、これがイネーブルになっていることを確認してください。

このコマンドは CNA を使用してイネーブルにできます。

  1. ip routing コマンドを適用する。

  2. デフォルト ゲートウェイを設定する。

注:ip route コマンドが有効なのは、IP ルーティングがイネーブルになっている場合だけです。デフォルトでは、IP ルーティングはディセーブルになっています。



実行コンフィギュレーション(Running-Config)にルーティングに関係するコマンドが表示されない

スイッチでルート マップを設定してあると、コマンドがデバイスでは受け付けられますが、実行コンフィギュレーション(running-config)には表示されない可能性があります。これは、現在スイッチで使用されているのが実行テンプレートではなく、VLAN SDM テンプレートであるためです。

ルーティング テンプレートにより、ユニキャスト ルーティング用のシステム リソースが最大にされ、通常これは、ネットワークの中心にあるルータまたはアグリゲータに必要です。この場合、VLAN テンプレートによりルーティングがディセーブルにされ、最大数のユニキャスト MAC アドレスがサポートされます。通常、レイヤ 2 スイッチのために、これが選択されます。

SDM テンプレートとその使用法についての詳細は、『SDM テンプレートの設定』を参照してください。



アップグレードの問題

ソフトウェアのアップグレード後にスタックが新しいイメージでブートしない

スタック内の Catalyst 3750 シリーズ スイッチが、ソフトウェアのアップグレード後に新しいイメージでブートしない場合があります。この問題は、ダウンロード オプションで archive download-sw /leave-old-sw を使用したことが原因である可能性があります。

/leave-old-sw オプションでは、ダウンロード後に古いソフトウェア バージョンが残されます。リロードに入る際に、スタック マスターだけがリロードされます。スタックとしてのスイッチでは、スタック内のすべてのモデルに同じバージョンのイメージが入っていることが前提となっているため、これは失敗します。その結果、スタック マスター スイッチはディセーブル ステートになり、別のメンバ スイッチがマスターとして選出されます。

この状態から回復するためには、スタック マスターで archive copy-sw コマンドを使用して、1 つのスタック メンバのフラッシュ メモリから 1 つ以上の他のスタック メンバのフラッシュ メモリへ実行イメージをコピーします。そうすると、既存のスタック メンバから非互換のソフトウェアがある他のスタック メンバへソフトウェア イメージがコピーされます。そのスイッチでは自動的にリロードが行われ、完全に機能するメンバとしてスタックに加入します。

Cisco Catalyst 3750 スイッチでの Cisco IOS ソフトウェアのアップグレードに関する他の問題については、『コマンドライン インターフェイスを使用した、スタック構成の Catalyst 3750 のソフトウェア アップグレード』の「トラブルシューティング」セクションを参照してください。



「flash:update」という一時ディレクトリを作成できない

Cisco IOS ソフトウェアをアップグレードする際に、次のエラー メッセージが表示されることがあります。

Unable to create temp dir "flash:update"

このエラー メッセージは、一時ディレクトリ「update」がファイル システムの flash: にすでに存在していることを示しています。現在のアップグレード プロセスでは、このディレクトリを使用できません。このディレクトリは、以前にアップグレードが試行された際の結果として、ファイル システムの flash: に残っていた可能性があります。

この問題を解決するには、次の手順を実行します。

  1. rmdir flash:update コマンドを使用して、この一時ディレクトリを削除します。

  2. delete flash:update コマンドを発行します。

  3. rmdir flash:update コマンドが機能しない場合は、delete /force /recursive flash:update コマンドを発行してください。

  4. Cisco IOS ソフトウェアのアップグレード手順を続行します。



パフォーマンスの問題

CPU 高使用率の問題

CPU のパケット処理アーキテクチャと CPU の使用率が高くなる問題のトラブルシューティングについて考える前に、ハードウェア ベースの転送を行うスイッチと Cisco IOS ソフトウェア ベースのルータでは CPU の使用方法が異なっていることを理解しておく必要があります。CPU の使用率が高くなる現象は、デバイス上のリソースの枯渇や、クラッシュの危険を示すものと誤解されていることが多いようです。容量の問題は、Cisco IOS ルータで CPU 使用率が高くなった場合に発生する症状の 1 つです。ところが、ハードウェアベースの転送を行うスイッチでは、容量の問題が CPU 高使用率の症状となることはほとんどありません。

CPU 高使用率のトラブルシューティングを行うための最初のステップは、使用している Catalyst 3750 スイッチの Cisco IOS バージョンのリリース ノートを調べて、可能性のある既知の IOS の不具合を探すことです。この方法で、トラブルシューティングのステップから IOS の不具合を排除できます。使用している Cisco IOS ソフトウェア リリースのリリース ノートについては、『Cisco Catalyst 3750 シリーズ スイッチのリリース ノート』を参照してください。

一般的な CPU 高使用率の問題と解決方法については、『Catalyst 3750 シリーズ スイッチでの CPU 高使用率のトラブルシューティング』を参照してください。



スループットの問題

スイッチポートでの入出力トラフィック レートは、さまざまな理由により変動する可能性があります。次のような一般的な原因が考えられます。

  • スイッチ、特にインターフェイスに QoS 機能が設定されている。デフォルトのままになっている場合、標準の QoS 設定では、最適のパフォーマンスが得られない可能性があります。QoS に詳しくない場合は、Cisco Catalyst 3750 スイッチで使用可能な自動 QoS 機能を使用することを推奨いたします。QoS 設定を手動で調整する場合、詳細は、『標準 QoS の設定』と『Cisco Catalyst 3750 の QoS 設定例』を参照してください。

  • 速度/デュプレックス設定:ネットワークで自動ネゴシエーションが使用されている場合、異なるベンダー間でのネゴシエーションが予想どおりには機能しない可能性があります。動作の速度/デュプレックス値を確認して、望ましい値になっていない場合は、接続の両端で値を固定的に設定することを推奨いたします。自動ネゴシエーションについての詳細は、『Cisco Catalyst スイッチと NIC との互換性に関する問題のトラブルシューティング』を参照してください。



%SIGNATURE-3-NOT_ABLE_TO_PROCESS: %ERROR:

このエラー メッセージが表示されるのは 3750/3560 でのリブート中で、file verify auto コマンドが設定されている場合です。デフォルトでは、file verify auto はイネーブルになっていませんが、これが使用されると、このエラーが発生します。結果的に、これら 2 つのプラットフォームの後のイメージからは、このコマンドは削除されています。

リロード中には、他のエラー メッセージも表示されます。

 %SIGNATURE-3-NOT_ABLE_TO_PROCESS: %ERROR: Not able to process Signature in flash:.
%SIGNATURE-3-ABORT_OPER: %ERROR: Aborting reload

これらのエラー メッセージは 3560 スイッチと 3750 スイッチに特有のものです。この問題は、Cisco Bug ID CSCsb65707登録ユーザ専用)に記載されています。この問題を解決するには、コンフィギュレーションから file verify auto コマンドを削除します。このコマンドを削除すると、スイッチはエラー メッセージが表示されずにリロードされるようになります。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。



メモリの問題

メモリの枯渇

Cisco Catalyst 3750 スイッチでの作業の際、メモリ リークまたはフラグメンテーションの問題により、%SYS-2-MALLOCFAIL メッセージが返される場合があります。このメッセージは、プロセスで連続するメモリの十分に大きなブロックを見つけられないことを示しています。この例に示すように、IP 入力プロセスは、メモリのプロセッサ プールから 1028 バイトを取得するように試みます。

%SYS-2-MALLOCFAIL: Memory allocation of 1028 bytes failed from 0x601617A4, 
pool Processor, alignment 0 -Process= "IP Input", ipl= 2, pid= 21

これらのエラー メッセージには、次のような原因が考えられます。

  • 通常のメモリ利用

  • メモリ リーク

  • メモリのフラグメンテーション

一般に、MALLOCFAIL エラーは、ネットワーク内で活動するワームやウイルスなどのセキュリティ問題によって発生します。たとえば、スイッチの IOS のアップグレードなど、最近ネットワークに対する変更を行っていない場合は、これが原因になっている可能性が高くなります。通常は、アクセス リストに行を追加するといった設定の変更によって、この問題の影響を軽減できます。『Cisco セキュリティ アドバイザリおよび注意』ページには、一番可能性が高い原因の検出方法と、具体的な回避策に関する情報が掲載されています。

%SYS-2-MALLOCFAIL メッセージがログに記録される場合、次の手順を実行してください。

  1. show version コマンドを使用して、スイッチに Cisco IOS ソフトウェアをサポートするための十分な DRAM があることを確認します。

    3750-Stk#show version
    Cisco IOS Software, C3750 Software (C3750-IPBASE-M), Version 12.2(25)SEC2, 
      RELEASE SOFTWARE (fc1)
    Copyright (c) 1986-2005 by Cisco Systems, Inc.
    Compiled Wed 31-Aug-05 08:45 by antonino
    
    ROM: Bootstrap program is C3750 boot loader
    BOOTLDR: C3750 Boot Loader (C3750-HBOOT-M) Version 12.2(25r)SEC, 
       RELEASE SOFTWARE (fc4)
    
     SW1-3750 uptime is 6 hours, 32 minutes
    System returned to ROM by power-on
    System image file is "flash:/c3750-ipbase-mz.122-25.SEC2.bin"
    
    cisco WS-C3750G-24T (PowerPC405) processor (revision L0) with 118784K/12280K 
       bytes of memory.
    
    !--- 出力を省略。
    
    

    スイッチは、128 MB(118784K/12280K バイト)の DRAM で動作します。残念ながら、Catalyst 3750 シリーズ スイッチでは DRAM のアップグレードはサポートされていません。Cisco IOS ソフトウェアの最小メモリ要件を確認するには、show version コマンドの出力をアウトプットインタープリタ登録ユーザ専用)ツールにカット アンド ペーストしてください。分析出力の「Cisco IOS Image Software Advisor - IOS Image Name」セクションで提供されるリンクに従います。
    一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

  2. 一部のアプリケーションでは Cisco Works の User Tracking(UT)ディスカバリのような機能があり、ip cef コマンドが発行されないと、これによりメモリの枯渇状態が起こる可能性があります。

  3. メモリ割り当ての失敗は、メモリ リークの不具合かメモリのフラグメンテーションによって引き起こされる場合があります。この場合は、アウトプットインタープリタ登録ユーザ専用)ツールを使用して、show memory コマンドの出力を分析します。
    一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

  4. フラグメンテーションが発生しているかどうかを判別するには、show memory summary コマンドを発行して、Largest フィールドと Free フィールドを比較します。

    Largest フィールドの数値が Free フィールドの数値より非常に小さい場合、フラグメンテーションが発生しています。この理由は、Largest フィールドには最大の連続する空きメモリ ブロックが示されているためです。次の例で示すように、それは通常、空きメモリに近い必要があります。

    SW1-3750#show memory summary
               Head     Total(b)  Used(b)   Free(b)   Lowest(b) Largest(b)
    Processor  18AA068  95772568  24384312  71388256  68313048  69338560
          I/O  7400000  12574720  9031656   3543064   3499232   3535816
    
    !--- 出力を省略。
    
    

    フィールドについて簡単に説明します。

    • Total は、プロセッサや I/O メモリに割り当てられるメモリの合計です。この値には、Cisco IOS ソフトウェアに占有されるメモリの量は含まれません。

    • Used は、このコマンドが発行された時点で使用されているメモリの量です。

    • Free は、このコマンドが発行された時点で利用可能な空きメモリの量です。

    • Lowest は、最後のリロード以降で利用可能であったメモリ量の最小値です。

    • Largest は、このコマンドが発行された時点での連続する空きメモリ量の最大値です。これは通常は、空きメモリ値に近いはずです。空きメモリと比較して数値が小さいと、フラグメンテーションを表しています。

  5. メモリ リークが発生しているかどうか判別するためには、show memory summary コマンドの出力を何度か、一定間隔でキャプチャしてください。この間隔は、メモリ割り当て失敗が現れる時間の長さによって決まります。スイッチで 4 日後にエラーの表示が始まる場合は、1 日に 1 回か 2 回キャプチャすれば、パターンを確認するのには十分です。

    空きメモリが着実に減少している場合は、メモリ リークが起こっていた可能性があります。

    プロセスがメモリを取得して使用しながら、システムへメモリを解放しない場合、メモリ リークが発生します。問題の原因となるプロセスを判別するには、show processes memory コマンドを発行し、次のステップを実行します。

    1. メモリをシステムへ解放していないプロセスを判別するには、show processes memory コマンドの出力を何度か、一定間隔でキャプチャしてください。

    2. このキャプチャに使用される 2 つのカウンタは、Freed と Holding です。プロセスの Holding カウンタが増加しながら Freed カウンタが増加しない場合、そのプロセスがメモリ リークの原因である可能性があります。

    3. プロセスが特定されたら、Bug Toolkit登録ユーザ専用)を参照して、メモリ リークの問題を検索します。この問題が関連するのは、スイッチに現在インストールされている Cisco IOS ソフトウェアに影響を及ぼすプロセスです。
      一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

メモリの問題を解決する方法についての詳細は、『メモリ問題のトラブルシューティング』を参照してください。



CEF IPC バックグラウンド プロセスでの予期しないメモリ消費

Catalyst 3750 スイッチがスタックされていて、そのスイッチで IP ルーティングがディセーブルにされており、さらにスタック マスターが変更されると、Cisco Express Forwarding(CEF)IPC バックグラウンド プロセスで、緩慢で恒常的なメモリ リークが発生します。この問題は、Cisco Bug ID CSCsc59027登録ユーザ専用)に記述されています。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

この問題を解決するには、IP ルーティングをイネーブルにするか、またはスイッチ ソフトウェアをこの不具合に該当しない Cisco IOS リリースにアップグレードしてください。



%Error opening flash:/ (Device or resource busy)

Cisco IOS リリース 12.2(25)SED にアップグレードした後、フラッシュまたは NVRAM で問題が起こり、次のエラー メッセージを受け取る場合があります。

%Error opening flash:/ (Device or resource busy)

これらのシナリオで観察される症状は、次のとおりです。

  • switch renumber コマンドを使用してスイッチの再番号付けが行われると、予想外のリロードが発生する場合があります。

  • ファイル システムが正常に機能していないように見え、次のエラー メッセージの 1 つが表示されます。

    Switch#dir
    Directory of flash:/
    %Error opening flash:/ (Device or resource busy)
    

    または

    Switch#copy flash:config.text flash:config.also.text
    Destination filename [config.also.text]? 
    i28f128j3_16x_write_bytes: command sequence error
    flashfs[1]: writing to flash handle 0x2411CD8, device 0, offset 0x520000, 
       length 0x208: Operation Failed
    flashfs[1]: sector ptr: {0x29, 0xA3}
    %Error opening flash:config.also.text (I/O error)
    

    または

    Switch(config)#boot system flash:
         /c3750-ipservices-mz.122-25.SEC/c3750-ipservices-mz.122-25.SEC.bin
    i28f128j3_16x_erase_sector: timeout after 593 polling loops, 
         and 0x393AC7D usecs
    bs_open[2]: Unable to erase boot_block 0
    vb:: I/O error
    

この問題は、Cisco Bug ID CSCsc41813登録ユーザ専用)に記述されています。この問題を解決するには、スイッチ ソフトウェアをこの不具合に該当しない Cisco IOS リリースにアップグレードできます。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。



Debug Exception (Could be NULL pointer dereference)

Cisco IOS システム ソフトウェアが稼働する Catalyst 3750 シリーズ スイッチでリロードが発生して、ログには Debug Exception (Could be NULL pointer dereference) エラー メッセージが記録されます。

このエラー メッセージには、次のような原因が考えられます。

  • CEF バックグラウンド プロセスでのメモリ リーク。この問題を解決する方法についての詳細は、「CEF IPC バックグラウンド プロセスでの予期しないメモリ消費」セクションを参照してください。

  • インライン電力供給先デバイスの検出。

    この問題は、インライン電力供給先デバイスが overcurrent class として検出されるか、分類される場合に発生します。この問題は、Cisco Bug ID CSCsa72400登録ユーザ専用)に記述されています。
    一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

    この問題を解決するには、スイッチに IEEE 802.3af 非標準クラスのインライン電力供給先デバイス(もしくは、不良ケーブルまたはループバック ケーブル)を接続しないでください。スイッチで誤ってこのクラスが検出される場合があります。スイッチ ソフトウェアを、この不具合に該当しない Cisco IOS ソフトウェア リリースにアップグレードすることもできます。




関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報




Document ID: 77805