LAN スイッチング : レイヤ 3 スイッチングとフォワーディング

外部ルータを使用した Catalyst 2900XL/3500XL/2940/2950/2970 シリーズ スイッチでのインター VLAN ルーティングと ISL/802.1Q トランキングの設定

2005 年 11 月 22 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 11 月 22 日) | フィードバック

目次

概要
始める前に
      表記法
      前提条件
      使用するコンポーネント
      特記事項
設定
      ネットワーク ダイアグラム
      設定例
debug コマンドと show コマンド
show コマンドの出力例
      Catalyst 3500XL スイッチ
      Cisco 2600 ルータ
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、Catalyst 3512-XL スイッチと Cisco 2600 ルータ間での InterSwitch Link(ISL; スイッチ間リンク)と 802.1Q トランキングの設定例について説明します。各コマンドの実行結果は、そのコマンドを実行する場所で示されます。 Cisco 3600 および 4500/4700 シリーズ ルータ、またはこの他の Cisco 2600 シリーズ ルータで FastEthernet インターフェイスを備えたもの、そして Catalyst 2900XL、3500XL、2940、2950 または 2970 のどれをこのドキュメントで説明するシナリオで使用しても、同じ結果を得ることができます。

トランキングとは、複数の VLAN からのトラフィックを、2 台のデバイス間のポイントツーポイント リンク上で伝送する方法です。 イーサネット トランキングの実装方法には、次の 2 種類があります。

  • ISL(Cisco 独自のプロトコルで、2940 または 2950 シリーズ スイッチではサポート対象外)

  • 802.1Q(Institute of Electrical and Electronics Engineers(IEEE; 電気電子学会)規格)

ここでは、2 つの VLAN(VLAN1 と VLAN2)からのトラフィックを、Catalyst 3500 と Cisco 2600 ルータ間の 1 本のリンク上で搬送するトランクを構築します。

VLAN1 と VLAN2 の間のインター VLAN ルーティングを行うには、Cisco 2600 ルータを使用します。 Catalyst 2900XL/3500XL/2940/2950/2970 シリーズのスイッチはレイヤ 2(L2)スイッチで、VLAN 間のルーティングや通信を行う機能はありません。 インター VLAN ルーティングの詳細は、『Cisco IOS (R) スイッチング サービス設定ガイド、リリース 12.1』の「バーチャル LAN 間でのルーティングの概要」の章を参照してください。

この例を作成するにあたっては、ラボ環境で次のスイッチをクリアーな設定で使用しています。

  • Cisco IOS 12.0(5.x)XU が動作している Catalyst 3512XL スイッチ

  • Cisco IOS 12.1(3)T が動作する Cisco 2621 ルータ

  • Cisco IOS 12.1(1)T が動作する Cisco 2621 ルータ

このドキュメントに記載されている設定は、隔離されたラボ環境で実装されたものです。 実際の使用環境では、ネットワーク上の設定やコマンドの影響を受ける可能性があります。 全デバイスの設定は、write erase コマンドによって初期化され、デフォルト設定になっていることが確認されています。

始める前に

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

前提条件

このドキュメントに適用される特定の前提条件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

特記事項

Catalyst 2900XL/3500XL/2940/2950/2970 スイッチの場合:

Catalyst 2940 および 2950 シリーズ スイッチでは 802.1q トランキングだけがサポートされており、ISL トランキングはサポートされていません。

4 MB の DRAM を持つ Catalyst 2900XL スイッチでは、トランキングは次のトランキング対応モジュールでのみサポートされています。

  • WS-X2914-XL-V: 4 ポート 10/100 ISL/802.1Q スイッチ モジュール

  • WS-X2922-XL-V: 2 ポート 100BaseFX ISL/802.1Q スイッチ モジュール

  • WS-X2924-XL-V: 4 ポート 100BaseFX ISL/802.1Q スイッチ モジュール

  • WS-X2931-XL: Catalyst 2900 XL 用 1000BaseX アップリンク

  • WS-X2932-XL: Catalyst 2900 XL 用 1000BaseT アップリンク

トランキングをサポートしているスイッチのモデルに関する現時点のリストについては、次の表 1 を参照してください。

表 1

スイッチのモデル ISL トランキングに必要な最低限のリリース IEEE 802.1Q トランキングに必要な最低限のリリース トランキング(ISL/802.1Q)に必要な現在のリリース

WS-C2916M-XL(4 -Meg スイッチ)

11.2(8)SA4(Enterprise Edition)

11.2(8)SA5(Enterprise Edition)

11.2(8.6)SA6(Original Edition)

C2912-XL

11.2(8)SA4(Enterprise Edition)

11.2(8)SA5(Enterprise Edition)

12.0(5)WC(1) 以降

C2924-XL

11.2(8)SA4(Enterprise Edition)

11.2(8)SA5(Enterprise Edition)

12.0(5)WC(1) 以降

WS-C2924C-XL

11.2(8)SA4(Enterprise Edition)

11.2(8)SA5(Enterprise Edition)

12.0(5)WC(1) 以降

WS-C2924M-XL

11.2(8)SA4(Enterprise Edition)

11.2(8)SA5(Enterprise Edition)

12.0(5)WC(1) 以降

WS-C2912MF-XL

11.2(8)SA4(Enterprise Edition)

11.2(8)SA5(Enterprise Edition)

12.0(5)WC(1) 以降

WS-C2924M-XL-DC

12.0(5)XU

12.0(5)XU

12.0(5)WC(1) 以降

WS-C3508G-XL

11.2(8)SA4(Enterprise Edition)

11.2(8)SA5(Enterprise Edition)

12.0(5)WC(1) 以降

WS-C3512-XL

11.2(8)SA4(Enterprise Edition)

11.2(8)SA5(Original Edition)

12.0(5)WC(1) 以降

WS-C3524-XL

11.2(8)SA4(Enterprise Edition)

11.2(8)SA5(Enterprise Edition)

12.0(5)WC(1) 以降

WS-C3548-XL

12.0(5)XP(Enterprise Edition)

12.0(5)XP(Enterprise Edition)

12.0(5)WC(1) 以降

WS-C3524-PWR-XL

12.0(5)XU

12.0(5)XU

12.0(5)WC(1) 以降

WS-C2940-8TF

ISL は非サポート

12.1(13)AY

802.1Q 用には 12.1(13)AY 以降。ISL は非サポート。

WS-C2940-8TT

ISL は非サポート

12.1(13)AY

802.1Q 用には 12.1(13)AY 以降。ISL は非サポート。

WS-C2950-12

ISL は非サポート

12.0(5)WC(1)

802.1Q 用には 12.0(5)WC(1) 以降。ISL は非サポート。

WS-C2950-24

ISL は非サポート

12.0(5)WC(1)

802.1Q 用には 12.0(5)WC(1) 以降。ISL は非サポート。

WS-C2950C-24

ISL は非サポート

12.0(5)WC(1)

802.1Q 用には 12.0(5)WC(1) 以降。ISL は非サポート。

WS-C2950T-24

ISL は非サポート

12.0(5)WC(1)

802.1Q 用には 12.0(5)WC(1) 以降。ISL は非サポート。

WS-C2950G-12-EI

ISL は非サポート

12.0(5)WC(1)

802.1Q 用には 12.0(5)WC(1) 以降。ISL は非サポート。

WS-C2950G-24-EI

ISL は非サポート

12.0(5)WC(1)

802.1Q 用には 12.0(5)WC(1) 以降。ISL は非サポート。

WS-C2950G-48-EI

ISL は非サポート

12.0(5)WC(1)

802.1Q 用には 12.0(5)WC(1) 以降。ISL は非サポート。

WS-C2950SX-24

ISL は非サポート

12.0(5)WC(1)

802.1Q 用には 12.0(5)WC(1) 以降。ISL は非サポート。

WS-C2950-24-EI-DC

ISL は非サポート

12.0(5)WC(1)

802.1Q 用には 12.0(5)WC(1) 以降。ISL は非サポート。

WS-C2955T-12

ISL は非サポート

12.1(13)EA1

802.1Q 用には 12.1(13)EA1 以降。ISL は非サポート。

WS-C2955S-12

ISL は非サポート

12.1(13)EA1

802.1Q 用には 12.1(13)EA1 以降。ISL は非サポート。

WS-C2955C-12

ISL は非サポート

12.1(13)EA1

802.1Q 用には 12.1(13)EA1 以降。ISL は非サポート。

WS-C2970G-24T

12.1(11)AX

12.1(11)AX

12.1(11)AX 以降

WS-C2970G-24TS

12.1(14)EA1

12.1(14)EA1

12.1(14)EA1 以降


注:上記の表では、WS-C2916M-XL だけが 4 MB の DRAM を備えたスイッチです。 記載されているその他のスイッチは、すべて 8 MB の DRAM を備えたスイッチです。 使用しているスイッチの DRAM が 4 MB か 8 MB を調べるには、ユーザレベルで show version コマンドを実行します。 詳細は、『コマンドライン インターフェイスを使用した Catalyst 2900XL および 3500XL スイッチでのソフトウェアのアップグレード』の「コマンドライン インターフェイスを使用してスイッチのメモリ キャパシティを判別する方法」のセクションを参照してください。

注:Catalyst 2900XL/3500XL/2940/2950/2970 スイッチでは、int vlan 1、int vlan 2、int vlan x などの VLAN インターフェイスは、スイッチ上で設定されている各 VLAN すべてに対して作成できます。 ただし、管理用 VLAN として同時に使用できるのは 1 つの VLAN だけです。 IP アドレスは、管理用 VLAN の VLAN インターフェイスにのみ割り当てられます。 IP アドレスが管理用 VLAN ではない VLAN の VLAN インターフェイスに割り当てられていると、そのインターフェイスは起動しなくなります。 このため、管理用 VLAN 専用の VLAN インターフェイスを作成する方が安全です。

Cisco 2600 ルータの場合:

802.1Q トランキングの場合、タグ付けされない VLAN が 1 つあります。 この VLAN をネイティブ VLAN と呼びます。 ネイティブ VLAN は、このポートが 802.1Q トランキング モードの場合に、タグなしのトラフィック用に使用されます。 802.1Q トランキングを設定する際には、ネイティブ VLAN はトランク リンクの両端で同じ設定でなければならないことに注意してください。 ルータとスイッチ間に 802.1Q トランキングを設定する際のネイティブ VLAN の不一致は、よく見られる誤りです。 ネイティブ VLAN の詳細は、『リリース 12.1(3)T の新機能』の『IEEE 802.1Q VLAN 間でのブリッジング」にある、「IEEE 802.1Q」のセクションを参照してください。

この設定例では、ネイティブ VLAN は Cisco 2621 ルータと Catalyst 3512XL スイッチの両方で、デフォルトで VLAN1 になります。 使用しているネットワークでの必要性によっては、デフォルトの VLAN である VLAN1 以外のネイティブ VLAN を使用しなくてはならない場合もあります。 このドキュメントの「設定」のセクションでは、Cisco 2600 ルータおよび Catalyst 3500XL スイッチでのネイティブ VLAN を変更するコマンドについて説明しています。

このドキュメントで説明している設定例は、Fast Ethernet インターフェイスまたは Fast Ethernet ネットワーク モジュールを備えた Cisco 2600/3600/4500/4700 シリーズ ルータで使用できます。 また、ISL/802.1Q VLAN トランキングをサポートする Cisco IOS バージョンを使用していることも確認してください。 ISL/802.1Q VLAN トランキングをサポートする Cisco 2600/3600/4500/4700 ルータと、サポートされている Cisco IOS バージョンについては、次の表 2 を参照してください。

表 2

ルータのモデル ISL トランキングに必要な最低限のリリース IEEE 802.1Q トランキングに必要な最低限のリリース 最低限必要なフィーチャ セット(ISL/802.1Q)

Cisco 2620

11.3(3a)T

12.0(1)T

IP PLUS / IP PLUS

Cisco 2621

11.3(3a)T

12.0(1)T

IP PLUS / IP PLUS

Cisco 2620

12.1(3a)T

12.1(3a)T

IP PLUS / IP PLUS

Cisco 2650

12.1(3a)T

12.1(3a)T

IP PLUS / IP PLUS

Cisco 3620

11.3(1)T

12.0(1)T

IP PLUS / IP PLUS

Cisco 3640

11.3(1)T

12.0(1)T

IP PLUS / IP PLUS

Cisco 3661

12.0(5)T

12.0(5)T

IP PLUS / IP PLUS

Cisco 3662

12.0(5)T

12.0(5)T

IP PLUS / IP PLUS

Cisco 4500-M

11.3(1)T

12.0(1)T

IP PLUS / IP PLUS

Cisco 4700-M

11.3(1)T

12.0(1)T

IP PLUS / IP PLUS


注:表 2 では、この設定例をサポートしている最低限のリリース、または現在のメンテナンス リリースおよびメイン リリースについてのみ一覧しています。 特定のネットワーク モジュールを備えたルータ モデルには、それぞれ最低限の Cisco IOS バージョンがあります。 各ルータ ファミリでサポートされている最低限のソフトウェアの完全なリストについては、Software Advisor登録ユーザ専用)を使用してください。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

注:サポートされている最低限のリリースは、必ずしも推奨されているリリースであるとは限りません。 使用している Cisco 製品に対する最善のメンテナンス リリースを判別するには、Bug Toolkit登録ユーザ専用)にある製品コンポーネントごとにリストされている不具合を調べてください。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

注:表 2 では、この設定例をサポートするための IP インター VLAN ルーティングとトランキングの実行に必要な最低限のフィーチャ セットを一覧しています。 Cisco IOS の各バージョンや、各プラットフォームでサポートされている他のフィーチャ セットの完全な一覧については、Download Software Area登録ユーザ専用)を使用してください。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

設定

このセクションでは、このドキュメントで説明する機能を設定するための情報を提供します。

注:このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

このドキュメントでは、次のダイアグラムに示すネットワーク設定を使用しています。

50a.jpg

ネットワーク ダイアグラム
※ 画像をクリックすると、大きく表示されます。

設定例

このドキュメントでは、次に示す設定を使用しています。

注:ある種類のネットワーク モジュールを搭載したルータ モデルには、それぞれ ISL トランキングをサポートする最低限の Cisco IOS バージョンがあります。

  • Catalyst 3512-XL

  • Cisco 2600 ルータ

  • バージョン 12.1(3)T よりも前の Cisco IOS がインストールされたルータでの 802.1Q の設定

Catalyst 3512-XL

注:次の画面キャプチャには、3512XL スイッチ上で入力されたコマンドが示されています。 行の先頭にある感嘆符(!)は、コメント行であることを示します。

 
 !-- スイッチで特権モードと
 
 
 !-- Telnet のパスワードを設定します。
 
 switch#configure terminal
 Enter configuration commands, one per line. End with CNTL/Z.
 switch(config)#hostname 3512xl
 3512xl(config)#enable password mysecret
 3512xl(config)#line vty 0 4
 3512xl(config-line)#login
 3512xl(config-line)#password mysecret
 3512xl(config-line)#exit
 3512xl(config)#no logging console
 3512xl(config)#^Z
 
 
 !-- 管理用として、VLAN 1 の IP アドレスおよびデフォルト ゲートウェイを設定します。
 
 3512xl#configure terminal
 Enter configuration commands, one per line. End with CNTL/Z.
 3512xl(config)#int vlan 1
 3512xl(config-if)#ip address 10.10.10.2 255.255.255.0
 3512xl(config-if)#exit
 3512xl(config)#ip default-gateway 10.10.10.1
 3512xl(config)#end
 
 !-- VTP モードを設定します。
 !-- この例では、モードを transparent に設定しました。
 !-- VTP モードはネットワークに応じて設定します。
 !-- VTP の詳細は、
 !-- 次を参照してください。
 !-- 『Catalyst 2900XL および 3500XL スイッチでの VLAN の作成と維持
 
 3512xl#vlan database
 3512xl(vlan)#vtp transparent
 Setting device to VTP TRANSPARENT mode.
 
 
 !-- VLAN2 を追加します。 VLAN1 はデフォルトですでに作成されています。
 
 3512xl(vlan)#vlan 2
 VLAN 2 added:
 Name: VLAN0002
 3512xl(vlan)#exit
 APPLY completed.
 Exiting....
 
 
 !-- インターフェイス fastEthernet 0/1 でトランキングを有効にします。
 
 3512xl#configure terminal
 Enter configuration commands, one per line. End with CNTL/Z.
 3512xl(config)#int fastEthernet 0/1
 3512xl(config-if)#switchport mode trunk
 
 
 !-- トランキング カプセル化を isl または
 
 3512xl(config-if)#switchport trunk encapsulation isl
 
 !-- dot1q のいずれかで入力します。
 
 
 3512xl(config-if)#switchport trunk encapsulation dot1q
 
 !-- 2940/2950 シリーズ スイッチの場合、上記の 2 つのコマンドはどちらも使用しません。
 !-- 2940/2950 シリーズ スイッチでは 802.1q カプセル化だけがサポートされ、switchport mode trunk コマンドを
 !-- 使用してインターフェイス上でトランキングが有効になると、自動的に設定されます。
 
 !-- dot1q の場合は、リンク全体でネイティブ VLAN が
 !-- 一致していることを確認する必要があります。
 !-- 3512XL では、デフォルトでネイティブ VLAN が 1 になっています。
 !-- 使用しているネットワークの必要性に応じて、ネイティブ VLAN を
 !-- VLAN1 以外に変更する場合がありますが、
 !-- ルータでのネイティブ VLAN の変更は正しく行うことが
 !-- 非常に重要です。
 !-- 必要な場合は、次のコマンドを使用してネイティブ VLAN を変更します。
 !-- 3512xl(config-if)#switchport trunk native vlan <vlan ID>
 
 !-- トランク上のすべての VLAN を許可します。
 
 3512xl(config-if)#switchport trunk allowed vlan all
 3512xl(config-if)#exit
 
 
 !-- 次の一連のコマンドにより、FastEthernet 0/2 が VLAN2 に
 !-- 割り当てられ、このインターフェイスで PortFast が有効になります。
 
 3512xl(config)#int fastEthernet 0/2
 3512xl(config-if)#switchport access vlan 2
 3512xl(config-if)#spanning-tree portfast
 3512xl(config-if)#exit
 
 
 !-- FastEthernet 0/3 は、すでに VLAN1 にデフォルトで設定されています。
 !-- このインターフェイス上で PortFast を有効にします。
 
 3512xl(config)#int fastEthernet 0/3
 3512xl(config-if)#spanning-tree portfast
 3512xl(config-if)#^Z
 
 !-- Portfast を有効にする理由の説明は
 !-- 次を参照してください。
 !-- 『PortFast と他のコマンドを使用したワークステーションの接続始動遅延の修復』
 !-- 設定を忘れずに保存します。
 
 3512xl#write memory
 Building configuration...
 
 3512xl#
 
 --------------------------------------------------------------------------------
 
 3512xl#show running-config
 Building configuration...
 
 Current configuration:
 
 !
 version 12.0
 no service pad
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname 3512xl
 !
 no logging console
 enable password mysecret
 !
 !
 !
 !
 !
 ip subnet-zero
 !
 !
 !
 interface FastEthernet0/1
   switchport mode trunk
 !
 
 !-- 802.1Q が設定されている場合は、
 !-- 代わりに次の出力が
 !-- インターフェイス FastEthernet0/1 の下に表示されます。
 !-- interface FastEthernet0/1
 !-- switchport trunk encapsulation dot1q
 !-- switchport mode trunk
 
 !
 interface FastEthernet0/2
  switchport access vlan 2
  spanning-tree portfast
 !
 interface FastEthernet0/3
  spanning-tree portfast
 !
 interface FastEthernet0/4
 !
 interface FastEthernet0/5
 !
 interface FastEthernet0/6
 !
 interface FastEthernet0/7
 !
 interface FastEthernet0/8
 !
 interface FastEthernet0/9
 !
 interface FastEthernet0/10
 !
 interface FastEthernet0/11
 !
 interface FastEthernet0/12
 !
 interface GigabitEthernet0/1
 !
 interface GigabitEthernet0/2
 !
 interface VLAN1
  ip address 10.10.10.2 255.255.255.0
  no ip directed-broadcast
  no ip route-cache
 !
 ip default-gateway 10.10.10.1
 !
 line con 0
  transport input none
  stopbits 1
 line vty 0 4
  password mysecret
  login
 line vty 5 15
  login
 !
 end
 
2600 ルータ

注:次の画面キャプチャには、Cisco 2600 ルータ上で入力されたコマンドが示されています。 行の先頭にある感嘆符(!)は、コメント行であることを示します。

 
 !-- ルータで特権モードと
 !-- Telnet のパスワードを設定します。
 
 Router#configure terminal
 Enter configuration commands, one per line. End with CNTL/Z.
 Router(config)#hostname c2600
 
 c2600(config)#enable password mysecret
 c2600(config)#line vty 0 4
 c2600(config-line)#login
 c2600(config-line)#password mysecret
 c2600(config-line)#exit
 c2600(config)#no logging console
 c2600(config)#^Z
 
 c2600#configure terminal
 Enter configuration commands, one per line. End with CNTL/Z.
 
 
 !-- トランクの設定に FastEthernet 0/0 を選択します。
 !-- ここではレイヤ 2(L2)またはレイヤ 3(L3)の設定は行いません。
 
 c2600(config)#int fastEthernet 0/0
 c2600(config-if)#no shut
 c2600(config-if)#exit
 
 
 !-- サブインターフェイス FastEthernet 0/0.1 でトランキングを有効にします。
 !-- 実際のトランクはサブインターフェイスで設定されることに注意してください。
 
 c2600(config)#int fastEthernet 0/0.1
 
 
 !-- トランキング カプセル化を isl または
 
 c2600(config-subif)#encapsulation isl 1
 
 
 !-- dot1q のいずれかで入力します。
 !-- dot1q の場合は、リンク全体でネイティブ VLAN が
 !-- 一致していることを確認する必要があります。
 !-- 3512XL では、デフォルトでネイティブ VLAN が 1 になっています。
 !-- ルータで、VLAN1 をネイティブ VLAN として設定します。
 
 c2600(config-subif)#encapsulation dot1Q 1 ?
   native  Make this is native vlan
   <cr>
 c2600(config-subif)#encapsulation dot1Q 1 native
 
 !-- スイッチ上で、VLAN1 以外のネイティブ VLAN を設定している場合、
 !-- ルータでも同じ VLAN を設定してネイティブ VLAN とします。
 !-- その際には、上記のコマンドを使用します。
 
 

注:encapsulation dot1Q 1 native コマンドは、Cisco IOS バージョン 12.1(3)T で追加されました。これより前のバージョンの Cisco IOS を使用している場合は、このドキュメントの「Cisco IOS のバージョンが 12.1(3)T より前のルータでの 802.1Q の設定」のセクションを参照し、そのルータで 802.1Q トランキングを設定してください。

 
 !-- サブインターフェイス 0/0.1 で L3 情報を設定します。
 
 c2600(config-subif)#ip address 10.10.10.1 255.255.255.0
 c2600(config-subif)#exit
 
 
 !-- サブインターフェイス FastEthernet 0/0.2 でトランキングを有効にします。
 !-- 実際のトランクはサブインターフェイスで設定されることに注意してください。
 
 c2600(config)#int fastEthernet 0/0.2
 
 
 !-- トランキング カプセル化を isl または
 
 c2600(config-subif)#encapsulation isl 2
 
 
 !-- dot1q のいずれかで入力します。
 
 c2600(config-subif)#encapsulation dot1Q 2
 
 
 !-- サブインターフェイス 0/0.2 で L3 情報を設定します。
 
 c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
 c2600(config-subif)#exit
 c2600(config)#^Z
 
 
 !-- 設定を忘れずに保存します。
 
 c2600#write memory
 Building configuration...
 [OK]
 c2600#
 

注:この設定が機能し、workstation 1 と workstation 2 の間で正常に ping を実行できるようにするには、ワークステーション上でのデフォルト ゲートウェイの設定が正しいことを確認する必要があります。 workstation1 のデフォルト ゲートウェイは 10.10.11.1 であり、workstation2 のデフォルト ゲートウェイは 10.10.10.1 であることが必要です。 ワークステーションでのデフォルト ゲートウェイの設定方法の詳細は、このドキュメントのそれぞれのセクションを参照してください。

注:次の段落の説明は、802.1Q トランキングをルータとスイッチの間で設定している場合にのみ該当します。

注:上記のセクションで示された設定手順に従っていても、まだ VLAN 間(workstation1 と workstation2 の間)で ping が実行できない場合は、警告 CSCds42715 の状況に該当している可能性があります。これは、ファースト スイッチングが有効になっている場合に、802.1Q ネイティブ VLAN のキーワードが正しく機能しないというものです。 この不具合の修正は、コード バージョン 12.2(0.5)、12.2(0.5)T、12.1(5)DC、12.1(5)YB、12.2(0.18)S、12.1(5)YD02、12.2(2)B、12.2(15)ZN に統合されています。 Bug Toolkit登録ユーザ専用)を使用して、Bug ID CSCds42715 を入力すると、この不具合のステータスと簡潔な説明を調べることができます。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

 
 --------------------------------------------------------------------------------
 
 c2600#show running-config
 Building configuration...
  
 Current configuration:
 !
 version 12.1
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname c2600
 !
 no logging console
 enable password mysecret
 !
 !
 !
 !
 !
 ip subnet-zero
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 interface FastEthernet0/0
  no ip address
  duplex auto
  speed auto
 !
 interface FastEthernet0/0.1
  encapsulation isl 1
  ip address 10.10.10.1 255.255.255.0
  no ip redirects
 !
 
 !-- 802.1Q が設定されている場合は、
 !-- 代わりに次の出力が
 !-- インターフェイス FastEthernet0/0.1 の下に表示されます。
 !-- interface FastEthernet0/0.1
 !-- encapsulation dot1Q 1 native
 !-- ip address 10.10.10.1 255.255.255.0
 
 !
 !
 interface FastEthernet0/0.2
  encapsulation isl 2
  ip address 10.10.11.1 255.255.255.0
  no ip redirects
 !
 
 !-- 802.1Q が設定されている場合は、
 !-- 代わりに次の出力が
 !-- インターフェイス FastEthernet0/0.2 の下に表示されます。
 !-- interface FastEthernet0/0.2
 !-- encapsulation dot1Q 2
 !-- ip address 10.10.11.1 255.255.255.0
 
 !
 interface FastEthernet0/1
  no ip address
  shutdown
  duplex auto
  speed auto
 !
 ip classless
 no ip http server
 !
 !
 !
 line con 0
  transport input none
 line aux 0
 line vty 0 4
  password mysecret
  login
 !
 no scheduler allocate
 end
 
バージョン 12.1(3)T よりも前の Cisco IOS がインストールされたルータでの 802.1Q の設定

このドキュメントで先に説明したように、802.1Q トランキングの設定では、リンク全体でネイティブ VLAN が一致していることが非常に重要です。 Cisco IOS ソフトウェアの 12.1(3)T よりも前のバージョンでは、サブインターフェイスでの encapsulation dot1Q 1 native コマンドがないため、ネイティブ VLAN を明示的に定義できません。 Cisco IOS の以前のバージョンでは、このドキュメントの例の VLAN1 にあるように、VLAN インターフェイスをサブインターフェイスとしてではなく設定することが重要です。 設定が正しくない場合、ルータではタグ付きの dot1q フレームが VLAN1 上にあると想定される一方、スイッチ側では VLAN1 上でタグが想定されていません。 その結果、このスイッチとルータの VLAN1 の間では、トラフィックが通過しません。 こういった場合、必ずネイティブ VLAN の設定をメイン インターフェイスの下に配置し、その他すべての VLAN に対してはトランク上でサブインターフェイスを作成します。

現在のラボの設定では、次の手順を使用して、Cisco 2600 ルータを設定しています。

 
 !-- ルータで特権モードと
 !-- Telnet のパスワードを設定します。
 
 Router#configure terminal
 Enter configuration commands, one per line. End with CNTL/Z.
 Router(config)#hostname c2600
 c2600(config)#enable password mysecret
 c2600(config)#line vty 0 4
 c2600(config-line)#login;
 c2600(config-line)#password mysecret
 c2600(config-line)#exit
 c2600(config)#no logging console
 c2600(config)#^Z
 
 c2600#configure terminal
 Enter configuration commands, one per line. End with CNTL/Z.
 
 
 !-- トランクの設定に FastEthernet 0/0 を選択します。
 
 c2600(config)#int fastEthernet 0/0
 c2600(config-if)#no shut
 
 
 !-- VLAN1 の IP アドレスは主インターフェイスに設定され、
 !-- サブインターフェイスでは VLAN1 に対するカプセル化は行われないことに注意してください。
 
 c2600(config-if)#ip address 10.10.10.1 255.255.255.0
 c2600(config-if)#exit
 
 
 !-- VLAN 2 に対する dot1q カプセル化を
 !-- サブインターフェイス fastEthernet 0/0.2 に設定します。
 
 c2600(config)#int fastEthernet 0/0.2
 c2600(config-subif)#encapsulation dot1Q 2
 c2600(config-subif)#
 
 
 !-- サブインターフェイス 0/0.2 で L3 情報を設定します。
 
 c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
 c2600(config-subif)#exit
 c2600(config)#^Z
 
 
 !-- 設定を忘れずに保存します。
 
 c2600#write memory
 Building configuration...
 [OK]
 c2600#
 
 

注:この設定が機能し、workstation 1 と workstation 2 の間で正常に ping を実行できるようにするには、ワークステーション上でのデフォルト ゲートウェイの設定が正しいことを確認する必要があります。 workstation1 のデフォルト ゲートウェイは 10.10.11.1 であり、workstation2 のデフォルト ゲートウェイは 10.10.10.1 である必要があります。 ワークステーションでのデフォルト ゲートウェイの設定方法の詳細は、このドキュメントのそれぞれのセクションを参照してください。

 c2600#show running-config
 Building configuration...
 
 Current configuration:
 !
 version 12.1
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname c2600
 !
 no logging console
 enable password mysecret
 !
 !
 !
 !
 !
 memory-size iomem 7
 ip subnet-zero
 !
 !
 !
 !
 !
 !
 !
 interface FastEthernet0/0
  ip address 10.10.10.1 255.255.255.0
  duplex auto
  speed auto
 !
 interface FastEthernet0/0.2
  encapsulation dot1Q 2
  ip address 10.10.11.1 255.255.255.0
 !
 interface FastEthernet0/1
  no ip address
  shutdown
  duplex auto
  speed auto
 !
 ip classless
 no ip http server
 !
 !
 line con 0
  transport input none
 line aux 0
 line vty 0 4
  password mysecret
  login
 !
 no scheduler allocate
 end
 
 c2600#
 
 

debug コマンドと show コマンド

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を示します。

特定の show コマンドは、アウトプットインタープリタ登録ユーザ専用)でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

Catalyst 2900XL/3500XL/2940/2950/2970 スイッチでは、次のコマンドを使用します。

  • show int {FastEthernet | GigabitEthernet} <module/port> switchport

  • show vlan

  • show vtp status

Cisco 2600 ルータでは、次のコマンドを使用します。

  • show vlan

  • show interface

show コマンドの出力例

Catalyst 3500XL スイッチ

show int {FastEthernet | GigabitEthernet} <module/port> switchport

このコマンドはポートの管理ステータスや動作ステータスを確かめるために使用します。 また、トランクの両側でネイティブ VLAN が一致していることを確認するためにも使用します。 ネイティブ VLAN は、このポートが 802.1Q トランキング モードの場合に、タグなしのトラフィック用に使用されます。 ネイティブ VLAN の詳細は、『Catalyst 2900XL および 3500XL スイッチでの VLAN の作成と維持』を参照してください。

 3512xl#show int fastEthernet 0/1 switchport
 Name: Fa0/1
 Switchport: Enabled
 Administrative mode: trunk
 Operational Mode: trunk
 Administrative Trunking Encapsulation: isl
 Operational Trunking Encapsulation: isl
 Negotiation of Trunking: Disabled
 Access Mode VLAN: 0 ((Inactive))
 Trunking Native Mode VLAN: 1 (default)
 Trunking VLANs Enabled: ALL
 Trunking VLANs Active: 1,2
 Pruning VLANs Enabled: 2-1001
 
 Priority for untagged frames: 0
 Override vlan tag priority: FALSE
 Voice VLAN: none
 Appliance trust: none
 

注:802.1Q トランキングでは、上記コマンドの出力が次のように変化します。

 3512xl#show int fastEthernet 0/1 switchport
 Name: Fa0/1
 Switchport: Enabled
 Administrative mode: trunk
 Operational Mode: trunk
 Administrative Trunking Encapsulation: dot1q
 Operational Trunking Encapsulation: dot1q
 Negotiation of Trunking: Disabled
 Access Mode VLAN: 0 ((Inactive))
 Trunking Native Mode VLAN: 1 (default)
 Trunking VLANs Enabled: ALL
 Trunking VLANs Active: 1,2
 Pruning VLANs Enabled: 2-1001
 
 Priority for untagged frames: 0
 Override vlan tag priority: FALSE
 Voice VLAN: none
 

show vlan

このコマンドは、インターフェイス(ポート)が正しい VLAN に属していることを確認するために使用します。 この例では、インターフェイス Fa0/2 だけが VLAN2 に属しています。 その他は VLAN1 のメンバです。

 3512xl#show vlan
 VLAN Name                             Status    Ports
 ---- -------------------------------- --------- -------------------------------
 1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6,
                                                 Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                 Fa0/11, Fa0/12, Gi0/1, Gi0/2
 2    VLAN0002                         active    Fa0/2
 1002 fddi-default                     active    
 1003 token-ring-default               active    
 1004 fddinet-default                  active    
 1005 trnet-default                    active    
 
 ...(output suppressed)
 

show vtp status

このコマンドは、スイッチでの VLAN trunking protocol(VTP; VLAN トランキング プロトコル)設定を確かめるために使用します。 この例では、透過モードを使用しています。 正しい VTP モードは、使用しているネットワークのトポロジによって異なります。 VTP の詳細は、『Catalyst 2900XL および 3500XL スイッチでの VLAN の作成と維持』を参照してください。

 3512xl#show vtp status
 VTP Version                     : 2
 Configuration Revision          : 0
 Maximum VLANs supported locally : 254
 Number of existing VLANs        : 6
 VTP Operating Mode              : Transparent
 VTP Domain Name                 : 
 VTP Pruning Mode                : Disabled
 VTP V2 Mode                     : Disabled
 VTP Traps Generation            : Disabled
 MD5 digest                      : 0xC3 0x71 0xF9 0x77 0x2B 0xAC 0x5C 0x97
 Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
 

Cisco 2600 ルータ

show vlan

このコマンドでは、各 VLAN で設定されている L2 情報または L3 情報が分かります。

 c2600#show vlan
  
 Virtual LAN ID:  1 (Inter Switch Link Encapsulation)
  
    vLAN Trunk Interface:   FastEthernet0/0.1
  
    Protocols Configured:   Address:              Received:        Transmitted:
            IP              10.10.10.1                  40                  38
  
 Virtual LAN ID:  2 (Inter Switch Link Encapsulation)
  
    vLAN Trunk Interface:   FastEthernet0/0.2
  
    Protocols Configured:   Address:              Received:        Transmitted:
            IP              10.10.11.1                   9                   9
 

注:802.1Q トランキングでは、上記コマンドの出力が次のように変化します。

 c2600#show vlan
  
 Virtual LAN ID:  1 (IEEE 802.1Q Encapsulation)
  
    vLAN Trunk Interface:   FastEthernet0/0.1
  
  This is configured as native Vlan for the following interface(s): FastEthernet0/0
  
    Protocols Configured:   Address:              Received:        Transmitted:
            IP              10.10.10.1                   0                   2
  
 Virtual LAN ID:  2 (IEEE 802.1Q Encapsulation)
  
    vLAN Trunk Interface:   FastEthernet0/0.2
  
    Protocols Configured:   Address:              Received:        Transmitted:
            IP              10.10.11.1                  42                  19
 

注:Cisco IOS の 12.1(3)T よりも前のバージョンを使用している 802.1Q トランキングでは、コマンドの出力が次のように変わります。

 c2600#show vlan
 
 Virtual LAN ID:  2 (IEEE 802.1Q Encapsulation)
 
    vLAN Trunk Interface:   FastEthernet0/0.2
 
    Protocols Configured:   Address:              Received:        Transmitted:
            IP              10.10.11.1                   6                   4
 

注:どのサブインターフェイスの VLAN1 についても、IEEE 802.1Q カプセル化は表示されません。

show interface

このコマンドは、インターフェイスの管理ステータスや動作ステータスを確かめるために使用します。

 c2600#show interfaces fastEthernet 0/0
 FastEthernet0/0 is up, line protocol is up
   Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
   MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
      reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation ARPA, loopback not set
   Keepalive set (10 sec)
   Full-duplex, 100Mb/s, 100BaseTX/FX
   ARP type: ARPA, ARP Timeout 04:00:00
   Last input 00:00:00, output 00:00:07, output hang never
   Last clearing of "show interface" counters never
   Queueing strategy: fifo
   Output queue 0/40, 0 drops; input queue 0/75, 0 drops
   5 minute input rate 0 bits/sec, 1 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
      217 packets input, 12884 bytes
      Received 217 broadcasts, 0 runts, 0 giants, 0 throttles
      0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
      0 watchdog
      0 input packets with dribble condition detected
      45 packets output, 6211 bytes, 0 underruns(0/0/0)
      0 output errors, 0 collisions, 4 interface resets
      0 babbles, 0 late collision, 0 deferred
      0 lost carrier, 0 no carrier
      0 output buffer failures, 0 output buffers swapped out
 
 c2600#show interfaces fastEthernet 0/0.1
 FastEthernet0/0.1 is up, line protocol is up
   Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
   Internet address is 10.10.10.1/24
   MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
      reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation ISL Virtual LAN, Color 1.
   ARP type: ARPA, ARP Timeout 04:00:00
 
 c2600#show interfaces fastEthernet 0/0.2
 FastEthernet0/0.2 is up, line protocol is up
   Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
   Internet address is 10.10.11.1/24
   MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
      reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation ISL Virtual LAN, Color 2.
   ARP type: ARPA, ARP Timeout 04:00:00
 

注:802.1Q トランキングでは、上記コマンドの出力が次のように変化します。

 c2600#show interfaces fastEthernet 0/0.1
 FastEthernet0/0.1 is up, line protocol is up
   Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
   Internet address is 10.10.10.1/24
   MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
      reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation 802.1Q Virtual LAN, Vlan ID  1.
   ARP type: ARPA, ARP Timeout 04:00:00
 
 c2600#show interfaces fastEthernet 0/0.2
 FastEthernet0/0.2 is up, line protocol is up
   Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
   Internet address is 10.10.11.1/24
   MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
      reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation 802.1Q Virtual LAN, Vlan ID  2.
   ARP type: ARPA, ARP Timeout 04:00:00
 

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報