スイッチ : Cisco Catalyst 6500 シリーズ スイッチ

PVST+ から rapid-PVST へのスパニング ツリー移行の設定例

2007 年 1 月 12 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2007 年 1 月 12 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
背景説明
設定
      ネットワーク ダイアグラム
      設定例
      PVST+ の設定
      UplinkFast と BackboneFast
      rapid-PVST+ への移行
      デバッグ出力 - Mixed モード
      デバッグ出力 - rapid-PVST+ モード
確認
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、キャンパス ネットワークでスパニング ツリーのモードを PVST+ から rapid-PVST+へ移行するための設定例を説明します。また、PVST+ の設定、スパニング ツリーのロード バランシング、および UplinkFast と BackboneFast 機能についても説明します。

前提条件

要件

rapid-PVST+ を設定する前には『Rapid Spanning Tree Protocol(802.1w)の概要』を読んでおくことをお勧めします。

次の表に、Catalyst スイッチでの Rapid Spanning Tree Protocol(RSTP)のサポートと、サポートに必要な最低限のソフトウェアを示します。

Catalyst プラットフォーム rapid-PVST+

Catalyst 2900 XL/3500 XL

該当なし

Catalyst 2940

12.1(20)EA2

Catalyst 2950/2955/3550

12.1(13)EA1

Catalyst 2970/3750

12.1(14)EA1

Catalyst 3560

12.1(19)EA1

Catalyst 3750 Metro

12.1(14)AX

Catalyst 2948G-L3/4908G-L3

該当なし

Catalyst 4000/2948G/2980G(CatOS)

7.5

Catalyst 4000/4500(IOS)

12.1(19)EW

Catalyst 5000/5500

該当なし

Catalyst 6000/6500

7.5

Catalyst 6000/6500(IOS)

12.1(13)E

Catalyst 8500

該当なし


使用するコンポーネント

このドキュメントの情報は、Cisco IOS(R) ソフトウェア リリース 12.2(25) および CatOS 8.5(8) に基づくものです。ただし、設定は表に示されている最低限の Cisco IOS のバージョンに適用できます。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

802.1D Spanning Tree Protocol(STP; スパニング ツリー プロトコル)にはコンバージェンスが遅いという欠点があります。Cisco Catalyst スイッチでは、PVST+、rapid-PVST+ および MST という 3 種類の STP がサポートされています。PVST+ は IEEE802.1D 標準に基づくもので、BackboneFast、UplinkFast、PortFast などの Cisco 独自の拡張機能も含まれています。rapid-PVST+ は IEEE 802.1w 標準に基づくもので、802.1D よりもコンバージェンスが速くなっています。RSTP(IEEE 802.1w)には、Cisco が独自に 802.1D スパニング ツリーに加えた、BackboneFast、UplinkFast などの強化機能のほとんどがデフォルトで備わっています。rapid-PVST+ には次のような独自の機能があります。

  • Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)バージョン 2 を使用し、これは BPDU バージョン 0 を使用する 802.1D STP と下位互換性がある。

  • すべてのスイッチでは BPDU を生成して 2 秒ごとにすべてのポートで送出するのに対し、802.1D STP ではルート ブリッジのみが設定 BPDU を送信する。

  • ポートの役割 — ルート ポート、代表ポート、代替ポート、およびバックアップ ポート。

  • ポートの状態 — Discarding、Learning、および Forwarding。

  • ポートのタイプ — エッジ ポート(PortFast)、ポイントツーポイントおよび共有ポート。

rapid-PVST は RSTP を使用してより高速なコンバージェンスを実現します。RSTP ポートではレガシー 802.1D BPDU を受信すると、レガシー STP に「フォール バック」するので、802.1w に固有のファースト コンバージェンスの利点は、レガシー ブリッジと相互対話すると失われます。

設定

次の例には 2 つのセクションが含まれています。第 1 のセクションには現在の PVST+ の設定が示されています。第 2 のセクションには PVST+ から rapid-PVST+ への移行を行う設定が示されています。

注: このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

このドキュメントでは、次のネットワーク構成を使用しています。

この図には次のスイッチが含まれています。

  • ディストリビューション レイヤ内にある Distribution1 および Distribution2

  • Access1(IOS)および Access2(CatOS)と呼ばれる 2 台のアクセスレイヤ スイッチ

  • Services1 および Services2 と呼ばれる 2 台のサーバ集約スイッチ

VLAN 10、30、および 100 がデータ トラフィックを伝送します。VLAN 20、40、および 200 が音声トラフィックを伝送します。

rapidpvst-mig-config1.gif

ネットワーク ダイアグラム
※ 画像をクリックすると、大きく表示されます。

設定例

このドキュメントでは、次の設定を使用します。

PVST+ の設定

スイッチは、ネットワーク ダイアグラムにあるように、PVST+ でデータおよび音声トラフィックを伝送するように設定されています。次に設定の簡潔な要約を示します。

  • Distribution1 スイッチは Distribution1(config)# spanning-tree vlan 10,30,100 root primary コマンドを使用してデータ VLAN 10、30、および 100 のプライマリ ルート ブリッジになるよう設定されていて、また音声 VLAN 20、40、および 200 のセカンダリ ルート ブリッジには Distribution1(config)# spanning-tree vlan 20,40,200 root secondary コマンドが使用されています。

  • Distribution2 スイッチは Distribution2(config)# spanning-tree vlan 20,40,200 root primary コマンドを使用して音声 VLAN 20、40、および 200 のプライマリ ルート ブリッジになるよう設定されていて、またデータ VLAN 10、30、および 100 のセカンダリ ルート ブリッジには Distribution2(config)# spanning-tree vlan 10,30,100 root secondary コマンドが使用されています。

  • ネットワークで間接的なリンク障害が発生した場合に、より高速に STP をコンバージするため、すべてのスイッチ上で spanning-tree backbonefast コマンドが設定されています。

  • 直接的なアップリンク障害が発生した場合に、より高速に STP をコンバージするため、アクセスレイヤ スイッチ上で spanning-tree uplinkfast コマンドが設定されています。

Distribution1
  Distribution1#show running-config 
   Building configuration...
  spanning-tree mode pvst
  spanning-tree extend system-id
  spanning-tree backbonefast
  spanning-tree vlan 10,30,100 priority 24576
  spanning-tree vlan 20,40,200 priority 28672
  !
  vlan 10,20,30,40,100,200
  !
  interface FastEthernet1/0/1
   switchport trunk encapsulation dot1q
   switchport mode trunk
   switchport trunk allowed vlan 10,20
  !
  interface FastEthernet1/0/3
   switchport trunk encapsulation dot1q
   switchport mode trunk
   switchport trunk allowed vlan 30,40
  !
  interface FastEthernet1/0/5
   switchport trunk encapsulation dot1q
   switchport mode trunk
   switchport trunk allowed vlan 100,200
  !
  interface FastEthernet1/0/23
   switchport trunk encapsulation dot1q
   switchport mode trunk
   switchport trunk allowed vlan 10,20,30,40,100,200
  !
  interface FastEthernet1/0/24
   switchport trunk encapsulation dot1q
   switchport mode trunk
   switchport trunk allowed vlan 10,20,30,40,100,200
  !
   !
   end
  

ポート Fa1/0/24 が spanning-tree vlan 20,40,200 port-priority 64 コマンドを使用して設定されていることが確認できます。Distribution2 は VLAN 20、40、および 200 の設定済みルート(root)です。Distribution2 には Distribution1 へのリンクが 2 つ(Fa1/0/23 と Fa1/0/24)あります。Distribution2 は VLAN 20、40、および 200 のルート(root)なので、両方のポートはこれらの VLAN の代表ポートです。両方のポートのプライオリティは 128(デフォルト)で同じです。また、これら 2 つのリンク(fa1/0/23 と fa1/0/24)は、Distribution1 からのコストが同じです。Distribution1 は、ポートをフォワーディング ステートに設定するため、2 つのポートから最も低いポート番号を選択します。最も低いポート番号は Fa1/0/23 ですが、ネットワーク ダイアグラムにあるように、音声 VLAN 20、40、および 200 は Fa1/0/24 を通過するはずです。これは次の方法で実現できます。

  1. Distribution1 の Fa1/0/24 でポート コストを小さくする

  2. Distribution2 の Fa1/0/24 でポート プライオリティを小さくする

次の例では、fa1/0/24 を経由して VLAN 20、40、200 を転送するため、ポート プライオリティが小さくなっています。

Distribution2
  Distribution2#show running-config 
   Building configuration...
  !
  spanning-tree mode pvst
  spanning-tree extend system-id
  spanning-tree backbonefast
  spanning-tree vlan 10,30,100 priority 28672
  spanning-tree vlan 20,40,200 priority 24576
  !
  vlan 10,20,30,40,100,200
  !
  interface FastEthernet1/0/2
   switchport trunk encapsulation dot1q
   switchport mode trunk
   switchport trunk allowed vlan 10,20
  !
  interface FastEthernet1/0/4
   switchport trunk encapsulation dot1q
   switchport mode trunk
   switchport trunk allowed vlan 30,40
  !
  interface FastEthernet1/0/6
   switchport trunk encapsulation dot1q
   switchport mode trunk
   switchport trunk allowed vlan 100,200
  !
  interface FastEthernet1/0/23
   switchport trunk encapsulation dot1q
   switchport mode trunk
   switchport trunk allowed vlan 10,20,30,40,100,200
  !
  interface FastEthernet1/0/24
   switchport trunk encapsulation dot1q
   switchport mode trunk
   spanning-tree vlan 20,40,200 port-priority 64
   switchport trunk allowed vlan 10,20,30,40,100,200
  
  end
  

Services1 のポート Fa0/5、および Services2 の Fa0/6 と Fa0/48 の両方にスパニング ツリーのポート コストおよびポート プライオリティの設定があることが確認できます。この場合、Services1 と Services2 の VLAN 100 および 200 が、それらの間のトランク リンクを通過できるよう STP が調整されています。この設定が適用されていない場合、Services1 および 2 は、それらの間のトランク リンク経由でトラフィックを受け渡しません。その代わりに、Distribution1 と Distribution2 を経由するパスが選択されます。

Services2 では、VLAN 100 のルート(Distribution1)への 2 つの等価のコスト パスが確認できます。1 つは Services1 を経由するパスで、もう 1 つは Distribution2 を経由するパスです。STP は最適パス(ルート パス)を次の順序で選択します。

  1. パス コスト

  2. フォワーディング スイッチのブリッジ ID

  3. 最も低いポート プライオリティ

  4. 最も低い内部ポート番号

この例では、両方のパスのコストは同じです。ただし、VLAN 100 に関して、Distribution2(24576)は Services1(32768)よりもプライオリティが低くなっています。そのため、Services2 は Distribution2 を選択します。この例では、Services2 に Services1 を選択させるため、Services1 上の fa0/5 でポート コストがより低く設定されています。パス コストは、フォワーディング スイッチのプライオリティ番号よりも優先されます。

Services1
  Services1#show running-config 
   Building configuration...
  spanning-tree mode pvst
  spanning-tree portfast bpduguard default
  spanning-tree extend system-id
  spanning-tree backbonefast
  !
  vlan 100,200
  !
  interface FastEthernet0/5
   switchport trunk encapsulation dot1q
   switchport mode trunk
   spanning-tree vlan 100 cost 18
   switchport trunk allowed vlan 100,200
  !
  interface FastEthernet0/47
   switchport trunk encapsulation dot1q
   switchport mode trunk
   switchport trunk allowed vlan 100,200
  !
  interface FastEthernet0/48
   switchport trunk encapsulation dot1q
   switchport mode trunk
   switchport trunk allowed vlan 100,200
  !
  !
   end
  

同じ概念は Services1 にも当てはまり、VLAN 200 の転送に Services2 が選択されます。Services2 の fa0/6 で VLAN 200 のコストを小さくすると、Services1 は VLAN 200 の転送に fa0/47 を選択します。ただし、ここでの必要条件は、fa0/48 を経由して VLAN 200 を転送することです。これは次の 2 つの方法で実現できます。

  1. Services1 の Fa0/48 でポート コストを小さくする

  2. Services2 の Fa0/48 でポート プライオリティを小さくする

この例では、fa0/48 経由で VLAN 200 を転送するために、Services2 のポート プライオリティが小さくなっています。

Services2
  Services2#show running-config 
   Building configuration...
  spanning-tree mode pvst
  spanning-tree portfast bpduguard default
  spanning-tree extend system-id
  spanning-tree backbonefast
  !
  vlan 100,200
  !
  interface FastEthernet0/6
   switchport trunk encapsulation dot1q
   switchport mode trunk
   spanning-tree vlan 200 cost 18
   switchport trunk allowed vlan 100,200
  !
  interface FastEthernet0/47
   switchport trunk encapsulation dot1q
   switchport mode trunk
   switchport trunk allowed vlan 100,200
  !
  interface FastEthernet0/48
   switchport trunk encapsulation dot1q
   switchport mode trunk
   spanning-tree vlan 200 port-priority 64
   switchport trunk allowed vlan 100,200
  !
   !
   end
  

Access1
  Access1#show running-config 
   Building configuration...
  !
  spanning-tree mode pvst
  spanning-tree portfast bpduguard default
  spanning-tree extend system-id
  spanning-tree uplinkfast
  spanning-tree backbonefast
  !
  vlan 10,20
  !
  interface FastEthernet0/1
   switchport trunk encapsulation dot1q
   switchport mode trunk
   switchport trunk allowed vlan 10,20
  !
  interface FastEthernet0/2
   switchport trunk encapsulation dot1q
   switchport mode trunk
   switchport trunk allowed vlan 10,20
  !
   end
  

Access2
  Access2> (enable)show config all 
  
  #mac address reduction
  set spantree macreduction enable
  !
  #stp mode
  set spantree mode pvst+
  !
  #uplinkfast groups
  set spantree uplinkfast enable rate 15 all-protocols off
  !
  #backbonefast
  set spantree backbonefast enable
  !
  #vlan parameters
  set spantree priority 49152  1
  set spantree priority 49152  30
  set spantree priority 49152  40
  !
  #vlan(defaults)
  set spantree enable  1,30,40
  set spantree fwddelay 15     1,30,40
  set spantree hello    2      1,30,40
  set spantree maxage   20     1,30,40
  !
  #vtp
  set vlan 1,30,40
  !
  #module 3 : 48-port 10/100BaseTX Ethernet
  set trunk 3/3  on dot1q 30,40
  set trunk 3/4  on dot1q 30,40
  !
   end
  

UplinkFast と BackboneFast

移行プロセスを開始する前に、UplinkFast と BackboneFast の動作を知っておくことが推奨されます。「ネットワーク ダイアグラム」では、Access1 スイッチで Cisco IOS が稼働しています。次の出力は、rapid-PVST+ モードへの移行前に取得したものです。

  Access1#show spanning-tree vlan 10
  
  VLAN0010
    Spanning tree enabled protocol ieee
    Root ID    Priority    24586
               Address     0015.63f6.b700
               Cost        3019
               Port        107 (FastEthernet3/0/1)
               Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
  
    Bridge ID  Priority    49162  (priority 49152 sys-id-ext 10)
               Address     000f.f794.3d00
               Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
               Aging Time 300
    Uplinkfast enabled
  
  Interface        Role Sts Cost      Prio.Nbr Type
  ---------------- ---- --- --------- -------- --------------------------------
  Fa3/0/1          Root FWD 3019      128.107  P2p
  Fa3/0/2          Altn BLK 3019      128.108  P2p
  
  
  Access1#show spanning-tree summary
  Switch is in pvst mode
  Root bridge for: none
  Extended system ID           is enabled
  Portfast Default             is disabled
  PortFast BPDU Guard Default  is enabled
  Portfast BPDU Filter Default is disabled
  Loopguard Default            is disabled
  EtherChannel misconfig guard is enabled
  UplinkFast                   is enabled
  BackboneFast                 is enabled
  Configured Pathcost method used is short
  
  Name                   Blocking Listening Learning Forwarding STP Active
  ---------------------- -------- --------- -------- ---------- ----------
  
  VLAN0010                     1         0        0          1          2
  VLAN0020                     1         0        0          1          2
  ---------------------- -------- --------- -------- ---------- ----------
  2 vlans                      2         0        0          2          4
  

次の出力は、rapid-PVST+ へモードを変更した後に取得したものです。

  Access1#show spanning-tree vlan 10
  
  VLAN0010
    Spanning tree enabled protocol rstp
    Root ID    Priority    24586
               Address     0015.63f6.b700
               Cost        3019
               Port        107 (FastEthernet3/0/1)
               Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
  
    Bridge ID  Priority    49162  (priority 49152 sys-id-ext 10)
               Address     000f.f794.3d00
               Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
               Aging Time 300
    UplinkFast enabled but inactive in rapid-pvst mode
  
  Interface        Role Sts Cost      Prio.Nbr Type
  ---------------- ---- --- --------- -------- --------------------------------
  Fa3/0/1          Root FWD 3019      128.107  P2p
  Fa3/0/2          Altn BLK 3019      128.108  P2p
  
  Access1#show spanning-tree summary
  Switch is in rapid-pvst mode
  Root bridge for: none
  Extended system ID           is enabled
  Portfast Default             is disabled
  PortFast BPDU Guard Default  is enabled
  Portfast BPDU Filter Default is disabled
  Loopguard Default            is disabled
  EtherChannel misconfig guard is enabled
  UplinkFast                   is enabled but inactive in rapid-pvst mode
  BackboneFast                 is enabled but inactive in rapid-pvst mode
  Configured Pathcost method used is short
  
  Name                   Blocking Listening Learning Forwarding STP Active
  ---------------------- -------- --------- -------- ---------- ----------
  
  VLAN0010                     1         0        0          1          2
  VLAN0020                     1         0        0          1          2
  ---------------------- -------- --------- -------- ---------- ----------
  2 vlans                      2         0        0          2          4
  

show spanning-tree summary コマンドの出力では、UplinkFast および BackboneFast は有効ですが、rapid-PVST モードでは非アクティブであることが確認できます。オプションで、両方のコマンドを削除できます。これらのコマンドを削除しない場合、rapid-PVST の動作には影響しません。no spanning-tree uplinkfast 設定モード コマンドを使用して UplinkFast を無効にすると、ブリッジ プライオリティとポート コストはデフォルトに戻ります。非ルート スイッチのブリッジ プライオリティをより大きな数にすることをお勧めします。次の出力は、rapid-PVST モードで UplinkFast 機能を無効にした後の状態を示しています。

  Access1#show spanning-tree vlan 10
  
  VLAN0010
    Spanning tree enabled protocol rstp
    Root ID    Priority    24586
               Address     0015.63f6.b700
               Cost        19
               Port        107 (FastEthernet3/0/1)
               Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
  
    Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
               Address     000f.f794.3d00
               Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
               Aging Time 300
  
  Interface        Role Sts Cost      Prio.Nbr Type
  ---------------- ---- --- --------- -------- --------------------------------
  Fa3/0/1          Root FWD 19        128.107  P2p
  Fa3/0/2          Altn BLK 19        128.108  P2p
  
  Access1#show spanning-tree summary
  Switch is in rapid-pvst mode
  Root bridge for: none
  Extended system ID           is enabled
  Portfast Default             is disabled
  PortFast BPDU Guard Default  is enabled
  Portfast BPDU Filter Default is disabled
  Loopguard Default            is disabled
  EtherChannel misconfig guard is enabled
  UplinkFast                   is disabled
  BackboneFast                 is enabled but inactive in rapid-pvst mode
  Configured Pathcost method used is short
  
  Name                   Blocking Listening Learning Forwarding STP Active
  ---------------------- -------- --------- -------- ---------- ----------
  
  VLAN0010                     1         0        0          1          2
  VLAN0020                     1         0        0          1          2
  ---------------------- -------- --------- -------- ---------- ----------
  2 vlans                      2         0        0          2          4
  

CatOS では、BackboneFast 機能が有効である場合、モードを rapid-PVST に変更することはできません。移行の前に BackboneFast を無効にする必要があります。UplinkFast は、IOS での動作と同じように動作します。

  Access2> (enable) set spantree mode rapid-pvst+
  Cannot change the spantree mode to RAPID-PVST+ when backbonefast is enabled.
  

rapid-PVST+ への移行

rapid-PVST+ は 802.1D と同じ BPDU 形式を使用し、また下位互換性があります。企業ネットワークのすべてのスイッチを同時に rapid-PVST+ に変更することは困難です。ただし、下位互換性があるため、変更を段階的に行うことができます。スパニング ツリーの再設定はトラフィック フローを中断させるため、スケジュールされたメンテナンス時間帯に変更を実施することをお勧めします。スパニング ツリーの UplinkFast および BackboneFast 機能は、PVST+ の機能です。これらの機能は rapid-PVST+ の内部に組み込まれているため、rapid-PVST+ を有効にするとこれらは無効になります。そのため、移行中にこれらのコマンドを削除できます。PortFast、BPDUguard、BPDUfilter、ルート ガード、およびループ ガードなどの機能の設定は、rapid-PVST+ モードでも適用されます。これらの機能の使用法は、PVST+ モードと同じです。PVST+ モードですでにこれらの機能を有効にしている場合、rapid-PVST+ モードへの移行の後もこれらの機能はアクティブなままになります。この例では、移行は次の順序で行われます。

  1. Access1

  2. Access2

  3. Services1 と Services2

  4. Distribution1 と Distribution2


  1. Access1 の移行:

      Access1(config)#spanning-tree mode rapid-pvst
      Access1(config)#no spanning-tree uplinkfast
      Access1(config)#no spanning-tree backbonefast
      
      
      Access1#show spanning-tree vlan 10
      
      VLAN0010
        Spanning tree enabled protocol rstp
        Root ID    Priority    24586
                   Address     0015.63f6.b700
                   Cost        19
                   Port        107 (FastEthernet3/0/1)
                   Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
      
        Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
                   Address     000f.f794.3d00
                   Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
                   Aging Time 300
      
      Interface        Role Sts Cost      Prio.Nbr Type
      ---------------- ---- --- --------- -------- --------------------------------
      Fa3/0/1          Root FWD 19        128.107  P2p Peer(STP)
      Fa3/0/2          Altn BLK 19        128.108  P2p Peer(STP)
      
      
      !--- タイプ P2p ピア(STP)は、隣接スイッチで PVST が稼働していることを表しています。
      
      
  2. Access2 の移行:

      Access2> (enable) set spantree backbonefast disable
      Backbonefast disabled for all VLANs.
      
      Access2> (enable) set spantree mode rapid-pvst+
      PVST+ database cleaned up.
      Spantree mode set to RAPID-PVST+.
      
      
      Access2> (enable) clear spantree uplinkfast
      This command will cause all portcosts, portvlancosts, and the
      bridge priority on all vlans to be set to default.
      Do you want to continue (y/n) [n]? y
      VLANs 1-4094 bridge priority set to 32768.
      The port cost of all bridge ports set to default value.
      The portvlancost of all bridge ports set to default value.
      uplinkfast all-protocols field set to off.
      uplinkfast disabled for bridge.
      
  3. Services1 と Services2 の移行:

      Services1(config)#spanning-tree mode rapid-pvst
      Services1(config)#no spanning-tree backbonefast
      
      Services2(config)#spanning-tree mode rapid-pvst
      Services2(config)#no spanning-tree backbonefast
      
  4. Distribution1 と Distribution2 の移行:

      Distribution1(config)#spanning-tree mode rapid-pvst
      2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to
      up
      2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to
      up
      2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
      up
      2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
      up
      2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to
       up
      2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan200, changed state to
       up
      2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
      down
      2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
      down
      2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
      up
      2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
      up
      
      !--- Distribution1 スイッチにはレイヤ 3 VLAN インターフェイスがあり、
      !--- 変換中にダウンになり、アップに戻ります。
      
      
      Distribution1(config)#no spanning-tree backbonefast
      
      
      Distribution2(config)#spanning-tree mode rapid-pvst
      
      2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to
      own
      2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to
      p
      2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to
      up
      2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to
      up
      2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
      up
      2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
      up
      2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state t
       up
      2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan200, changed state t
       up
      2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
      down
      2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
      up
      
      !--- Distribution2 スイッチにはレイヤ 3 VLAN インターフェイスがあり、
      !--- 変換中にダウンになり、アップに戻ります。
      
      
      Distribution2(config)#no spanning-tree backbonefast
      

デバッグ出力 - Mixed モード

大規模な企業ネットワークでは、移行プロセスには数日を要する可能性があります。移行プロセス中は、一部のスイッチを PVST+ モード、また一部のスイッチを rapid-PVST+ モードのように、混合モードで LAN を稼働させることができます。混合モードでは、rapid-PVST+ の利点を完全に享受することはできません。全般的なコンバージェンス時間は、PVST+ モードのコンバージェンス時間と同じです。rapid-PVST+ を完全に活用するには、スパニング ツリー トポロジのすべてのスイッチが rapid-PVST+ で稼働する必要があります。混合モードでスパニング ツリーがどのように動作するかを示すために、debug コマンドの出力例を次に示します。Distribution1 と Distribution2 が PVST+ で、Access1 が rapid-PVST+ モードです。

debug spanning-tree コマンドの出力は、Access1 と Distribution1 の間のリンクに障害が発生した場合の STP の動作を示しています。

  Access1
  
  00:55:13: RSTP(10): updt roles, root port Fa0/1 going down
  00:55:13: RSTP(10): Fa0/2 is now root port
  00:55:13: RSTP(10): Fa0/2 received a tc ack
  00:55:15: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to adminis
  tratively down
  00:55:16: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, cha
  nged state to down
  
  Distribution1
  
  00:55:20: STP: VLAN0010 Topology Change rcvd on Fa1/0/23
  00:55:20: STP: VLAN0020 sent Topology Change Notice on Fa1/0/24
  00:55:21: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1,
  changed state to down
  00:55:22: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to down
  
  Distribution2
  
  00:55:06: STP: VLAN0010 Topology Change rcvd on Fa1/0/2
  00:55:06: STP: VLAN0010 sent Topology Change Notice on Fa1/0/23
  

debug spanning-tree コマンドの出力は、Access1 と Distribution1 の間のリンクがアップである場合の STP の動作を示しています。

  Access1
  
  00:55:40: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
  00:55:43:  STP: PVST vlan 10 port Fa0/1 created, ext id 2E42430, vp 3389640
  00:55:43: RSTP(10): initializing port Fa0/1
  00:55:43: RSTP(10): Fa3/0/1 is now designated
  00:55:43:  STP: PVST vlan 20 port Fa0/1 created, ext id 2E42430, vp 300EC20
  00:55:43: RSTP(20): initializing port Fa0/1
  00:55:43: RSTP(20): Fa0/1 is now designated
  00:55:43: RSTP(10): transmitting a proposal on Fa0/1
  00:55:43: RSTP(20): transmitting a proposal on Fa0/1
  00:55:43: RSTP(10): transmitting a proposal on Fa0/1
  00:55:43: RSTP(20): transmitting a proposal on Fa0/1
  00:55:43: RSTP(10): updt roles, received superior bpdu on Fa0/1
  00:55:43: RSTP(10): Fa0/1 is now root port
  00:55:43: RSTP(10): Fa0/2 blocked by re-root
  00:55:43: RSTP(10): Fa0/2 is now alternate
  00:55:44: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, cha
  nged state to up
  00:55:44: RSTP(20): updt roles, received superior bpdu on Fa0/1
  00:55:44: RSTP(20): Fa0/1 is now alternate
  
  Distribution1
  
  00:55:49: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to up
  00:55:50: set portid: VLAN0010 Fa1/0/1: new port id 8001
  00:55:50:  STP: PVST vlan 10 port Fa1/0/1 created, ext id 2DA13A8, vp 3BDB708
  00:55:50: STP: VLAN0010 Fa1/0/1 -> listening
  00:55:50: set portid: VLAN0020 Fa1/0/1: new port id 8001
  00:55:50:  STP: PVST vlan 20 port Fa1/0/1 created, ext id 2DA13A8, vp 3C06F20
  00:55:50: STP: VLAN0020 Fa1/0/1 -> listening
  00:55:51: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1,
  changed state to up
  00:56:05: STP: VLAN0010 Fa1/0/1 -> learning
  00:56:05: STP: VLAN0020 Fa1/0/1 -> learning
  00:56:20: STP: VLAN0010 Fa1/0/1 -> forwarding
  00:56:20: STP: VLAN0020 sent Topology Change Notice on Fa1/0/24
  00:56:20: STP: VLAN0020 Fa1/0/1 -> forwarding
  
  
  !--- この出力は、Access1 スイッチが、リスニング、ラーニング、フォワーディングの
  !--- 標準 802.1D のスパニング ツリーのプロセスが Distribution1 で完了するのを
  !--- 待機することを明らかにしています。
  
  
  
  
  Distribution2
  
  00:55:06: STP: VLAN0020 Topology Change rcvd on Fa1/0/24
  00:56:06: STP: VLAN0020 Topology Change rcvd on Fa1/0/24
  
  
  !--- この出力は、TCN BPDU により Distribution2 に
  !--- 間接リンク停止が通知されることを示しています。
  
  

デバッグ出力 - rapid-PVST+ モード

Distribution1、Distribution2 および Access1 スイッチが rapid-PVST+ モードです。debug spanning-tree コマンドの出力は、Access1 と Distribution1 の間のリンクに障害が発生した場合の STP の動作を示しています。

  Access1
  
  01:31:04: RSTP(10): updt roles, root port Fa0/1 going down
  01:31:04: RSTP(10): Fa0/2 is now root port
  01:31:06: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to adminis
  tratively down
  01:31:07: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, cha
  nged state to down
  
  Distribution1
  
  01:31:13: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1,
  changed state to down
  01:31:14: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to down
  

debug spanning-tree コマンドの出力は、Access1 と Distribution1 の間のリンクがアップである場合の STP の動作を示しています。

  Access1
  
  01:35:46: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
  01:35:48:  STP: PVST vlan 10 port Fa3/0/1 created, ext id 2E42430, vp 3C8E360
  01:35:48: RSTP(10): initializing port Fa3/0/1
  01:35:48: RSTP(10): Fa3/0/1 is now designated
  01:35:48:  STP: PVST vlan 20 port Fa3/0/1 created, ext id 2E42430, vp 3C8E3E0
  01:35:48: RSTP(20): initializing port Fa3/0/1
  01:35:48: RSTP(20): Fa3/0/1 is now designated
  01:35:48: RSTP(10): updt roles, received superior bpdu on Fa3/0/1
  01:35:48: RSTP(10): Fa3/0/1 is now root port
  01:35:48: RSTP(10): Fa3/0/2 blocked by re-root
  01:35:48: RSTP(10): synced Fa3/0/1
  01:35:48: RSTP(10): Fa3/0/2 is now alternate
  01:35:48: RSTP(20): updt roles, received superior bpdu on Fa3/0/1
  01:35:48: RSTP(20): Fa3/0/1 is now alternate
  01:35:48: RSTP(10): transmitting an agreement on Fa3/0/1 as a response to a prop
  osal
  
  Distribution1
  
  01:35:55: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to up
  01:35:56:  STP: PVST vlan 10 port Fa1/0/1 created, ext id 2DA13A8, vp 3BDCCD8
  01:35:56: RSTP(10): initializing port Fa1/0/1
  01:35:56: RSTP(10): Fa1/0/1 is now designated
  01:35:56:  STP: PVST vlan 20 port Fa1/0/1 created, ext id 2DA13A8, vp 2D21C60
  01:35:56: RSTP(20): initializing port Fa1/0/1
  01:35:56: RSTP(20): Fa1/0/1 is now designated
  01:35:56: RSTP(10): transmitting a proposal on Fa1/0/1
  01:35:56: RSTP(20): transmitting a proposal on Fa1/0/1
  01:35:56: RSTP(10): received an agreement on Fa1/0/1
  01:35:57: RSTP(20): transmitting a proposal on Fa1/0/1
  01:35:59: RSTP(20): transmitting a proposal on Fa1/0/1
  01:36:01: RSTP(20): transmitting a proposal on Fa1/0/1
  01:36:03: RSTP(20): transmitting a proposal on Fa1/0/1
  01:36:06: RSTP(20): transmitting a proposal on Fa1/0/1
  01:36:08: RSTP(20): transmitting a proposal on Fa1/0/1
  01:36:10: RSTP(20): transmitting a proposal on Fa1/0/1
  01:36:11: RSTP(20): Fa1/0/1 fdwhile Expired
  01:36:12: RSTP(20): transmitting a proposal on Fa1/0/1
  01:36:14: RSTP(20): transmitting a proposal on Fa1/0/1
  01:36:16: RSTP(20): transmitting a proposal on Fa1/0/1
  01:36:18: RSTP(20): transmitting a proposal on Fa1/0/1
  01:36:20: RSTP(20): transmitting a proposal on Fa1/0/1
  01:36:22: RSTP(20): transmitting a proposal on Fa1/0/1
  01:36:24: RSTP(20): transmitting a proposal on Fa1/0/1
  01:36:26: RSTP(20): transmitting a proposal on Fa1/0/1
  01:36:26: RSTP(20): Fa1/0/1 fdwhile Expired
  
  
  !--- Distribution1 は、ポート Fa1/0/1 を VLAN 10 および 20 の代表ポートにしています。
  !--- まだ、Fa1/0/1 を VLAN 10、20 の代表ポートにすることも提案しています。
  !--- Access1 は VLAN10 の提案に同意しています。
  !--- ただし、VLAN20 に関する提案には同意していません。これは、
  !--- Distribution2 からの VLAN20 に関する上位の BPDU があるためです。
  
  

確認

このセクションを使用して、設定が正しく動作していることを確認します。

特定の show コマンドが、アウトプットインタープリタ登録ユーザ専用)(OIT)でサポートされています。OIT を使用して、show コマンド出力の解析を表示できます。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

設定が変更されるたびにスパニング ツリー トポロジを確認することをお勧めします。

Distribution1 スイッチがデータ VLAN 10、30、および 100 のルート ブリッジであり、スパニング ツリーの転送パスが「ネットワーク ダイアグラム」のパスに一致することを確認してください。

  Distribution1#show spanning-tree vlan 10
  
  VLAN0010
    Spanning tree enabled protocol rstp
    Root ID    Priority    24586
               Address     0015.63f6.b700
               This bridge is the root
               Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
  
    Bridge ID  Priority    24586  (priority 24576 sys-id-ext 10)
               Address     0015.63f6.b700
               Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
               Aging Time 300
  
  Interface        Role Sts Cost      Prio.Nbr Type
  ---------------- ---- --- --------- -------- --------------------------------
  Fa1/0/1          Desg FWD 19        128.1    P2p
  Fa1/0/3          Desg FWD 19        128.3    P2p
  Fa1/0/5          Desg FWD 19        128.5    P2p
  Fa1/0/23         Desg FWD 19        128.23   P2p
  Fa1/0/24         Desg FWD 19        128.24   P2p
  
  
  Access1#show spanning-tree summary
  Switch is in rapid-pvst mode
  Root bridge for: none
  Extended system ID           is enabled
  Portfast Default             is disabled
  PortFast BPDU Guard Default  is enabled
  Portfast BPDU Filter Default is disabled
  Loopguard Default            is disabled
  EtherChannel misconfig guard is enabled
  UplinkFast                   is disabled
  BackboneFast                 is disabled
  Configured Pathcost method used is short
  
  Name                   Blocking Listening Learning Forwarding STP Active
  ---------------------- -------- --------- -------- ---------- ----------
  
  VLAN0010                     1         0        0          1          2
  VLAN0020                     1         0        0          1          2
  ---------------------- -------- --------- -------- ---------- ----------
  2 vlans                      2         0        0          2          4
  
  Access2> (enable) show spantree 30
  VLAN 30
  Spanning tree mode          RAPID-PVST+
  Spanning tree type          ieee
  Spanning tree enabled
  
  Designated Root             00-15-63-f6-b7-00
  Designated Root Priority    24606
  Designated Root Cost        19
  Designated Root Port        3/3
  Root Max Age   20 sec   Hello Time 2  sec   Forward Delay 15 sec
  
  Bridge ID MAC ADDR          00-d0-00-50-30-1d
  Bridge ID Priority          32768
  Bridge Max Age 20 sec   Hello Time 2  sec   Forward Delay 15 sec
  
  Port                     State         Role Cost      Prio Type
  ------------------------ ------------- ---- --------- ---- --------------------
   3/3                     forwarding    ROOT        19   32 P2P
   3/4                     blocking      ALTR        19   32 P2P
  
  Access2> (enable) show spantree 40
  VLAN 40
  Spanning tree mode          RAPID-PVST+
  Spanning tree type          ieee
  Spanning tree enabled
  
  Designated Root             00-15-c6-c1-30-00
  Designated Root Priority    24616
  Designated Root Cost        19
  Designated Root Port        3/4
  Root Max Age   20 sec   Hello Time 2  sec   Forward Delay 15 sec
  
  Bridge ID MAC ADDR          00-d0-00-50-30-27
  Bridge ID Priority          32768
  Bridge Max Age 20 sec   Hello Time 2  sec   Forward Delay 15 sec
  
  Port                     State         Role Cost      Prio Type
  ------------------------ ------------- ---- --------- ---- --------------------
   3/3                     blocking      ALTR        19   32 P2P
   3/4                     forwarding    ROOT        19   32 P2P
  
  
  Services1#show spanning-tree vlan 100
  
  VLAN0100
    Spanning tree enabled protocol rstp
    Root ID    Priority    24676
               Address     0015.63f6.b700
               Cost        18
               Port        7 (FastEthernet0/5)
               Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
  
    Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
               Address     0003.fd63.bb80
               Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
               Aging Time 300
  
  Interface        Role Sts Cost      Prio.Nbr Type
  ---------------- ---- --- --------- -------- --------------------------------
  Fa0/5            Root FWD 18        128.7    P2p
  Fa0/46           Desg FWD 19        128.50   P2p
  Fa0/47           Desg FWD 19        128.51   P2p
  
  Services1#show spanning-tree vlan 200
  
  VLAN0200
    Spanning tree enabled protocol rstp
    Root ID    Priority    24776
               Address     0015.c6c1.3000
               Cost        37
               Port        51 (FastEthernet0/47)
               Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
  
    Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
               Address     0003.fd63.bb80
               Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
               Aging Time 300
  
  Interface        Role Sts Cost      Prio.Nbr Type
  ---------------- ---- --- --------- -------- --------------------------------
  Fa0/5            Altn BLK 19        128.7    P2p
  Fa0/46           Altn BLK 19        128.50   P2p
  Fa0/47           Root FWD 19        128.51   P2p
  
  Services2#show spanning-tree vlan 100
  
  VLAN0100
    Spanning tree enabled protocol rstp
    Root ID    Priority    24676
               Address     0015.63f6.b700
               Cost        37
               Port        42 (GigabitEthernet0/42)
               Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
  
    Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
               Address     00d0.2bfc.7d80
               Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
               Aging Time 300
  
  Interface        Role Sts Cost      Prio.Nbr Type
  ---------------- ---- --- --------- -------- --------------------------------
  Fa0/6            Altn BLK 19        128.6    P2p
  Fa0/42           Root FWD 19        128.42   P2p
  Fa0/43           Altn BLK 19        128.43   P2p
  
  Services2#show spanning-tree vlan 200
  
  VLAN0200
    Spanning tree enabled protocol rstp
    Root ID    Priority    24776
               Address     0015.c6c1.3000
               Cost        18
               Port        6 (GigabitEthernet0/6)
               Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
  
    Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
               Address     00d0.2bfc.7d80
               Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
               Aging Time 300
  
  Interface        Role Sts Cost      Prio.Nbr Type
  ---------------- ---- --- --------- -------- --------------------------------
  Fa0/6            Root FWD 18        128.6    P2p
  Fa0/42           Desg FWD 19        128.42   P2p
  Fa0/43           Desg FWD 19         64.43   P2p
  

トラブルシューティング

現在、この設定に関する特定のトラブルシューティング情報はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報