音声 : ゲートウェイ プロトコル

Unity ボイスメール統合による CallManager と Avaya S8700/G650 間の Q.SIG PRI トランク設定

2006 年 8 月 20 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 8 月 20 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
テスト環境のトポロジ
Cisco と Avaya の IP-PBX システムの相互運用性
      Avaya S8700/G650 IP-PBX システムでの手順
      Cisco CallManager での手順
Cisco 3745 の設定
Cisco と Avaya の IP-PBX システムの相互運用性のためのテスト済機能
Cisco と Avaya の IP 電話をサポートするための Cisco Unity ボイスメールの統合
      Cisco CallManager への Cisco Unity の付加
テスト済の Cisco Unity ボイスメール機能
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

Cisco CallManager と Avaya S8700/G650 間に Q.SIG PRI トランクを設定する手順をシスコのお客様とビジネス パートナーに提供することが、このドキュメントの目的です。 さらに、このドキュメントでは、Cisco と Avaya の両方の IP 電話にボイス メール サポートを提供するために、Cisco CallManager のプラットフォームに Cisco Unity を付加する方法の詳細な手順を説明しています。 IP-PBX の相互運用性とボイス メールの統合が必要とされる状況では、これは特に重要です。 Avaya の設定画面キャプチャは、標準エミュレーション ツールで作成されたものです。 それに代えて、Avaya S8700/G650 での設定作業には Avaya Site Administration(ASA)ツールも使用できます。 どちらの場合でも、出力表示は同じです。 IP-PBX の相互運用性とボイス メール統合に関する本ドキュメントでは、外部での使用が想定されています。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • 使用されている Avaya IP-PBX システムは、Avaya Communication Manager 2.0 が稼働する Avaya S8700/G650 です。 Q.SIG 機能は、このソフトウェア バージョンで標準装備になっています。

  • このドキュメントで使用される Avaya の IP 電話は、Phone Firmware Version 2.01 が稼働する 4610SW と 4620 です。

  • Cisco IOS(R) バージョン 12.2.15ZJ3 が稼働している、NM-HDV モジュール搭載の 3745 Media Gateway Control Protocol(MGCP)ゲートウェイを制御するために、Cisco CallManager 4.1.(2) が使用されています。 Cisco IOS(R) バージョン 12.3.8.T5 でも、テストが繰り返されています。

  • ボイス メール統合テストでは、バージョン 4.0(4) SR1 が稼働する Cisco Unity が使用されています。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメント内で使用されているデバイスは、すべてクリアな(デフォルト)設定で作業が開始されています。対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

テスト環境のトポロジ

top.gif

テスト環境のトポロジ
※ 画像をクリックすると、大きく表示されます。

Cisco と Avaya の IP-PBX システムの相互運用性

次のセクションでは、Avaya Communication Manager 2.0 が稼働する Avaya S8700/G650 と CallManager バージョン 4.1(2) が稼働する Cisco CallManager プラットフォーム間に Q.SIG トランクを設定するのに役立つ手順と画面キャプチャを提供しています。なお、Avaya S8700/G650 に物理的な ISDN PRI 接続を提供するために、Cisco 3745 MGCP デバイスが使用されています。

Avaya S8700/G650 IP-PBX システムでの手順

次の手順を実行します。

  1. S8700 サーバにログインします。 必要な Q.SIG 機能が S8700 サーバで有効になっていることを確認するために display system-parameters customer コマンドを実行します。

    proced1.gif

    display system-parameters customer コマンドを実行
    ※ 画像をクリックすると、大きく表示されます。

  2. DS-1 カードを Q.SIG PRI 用に設定します。

    config_q-2.gif

    DS-1 カードを設定
    ※ 画像をクリックすると、大きく表示されます。

  3. トランク グループを設定します。 add trunk-group # と入力します。# には対象のトランクを指定します。

    次の 3 つの画面キャプチャはトランク設定に関するものです。 トランク グループが作成されたら、グループに DS0 チャネルを 23 付加します。 これはポート割り当ての例で、01A0901 は Gateway# 1、Cabinet A、Slot# 9、DS0 channel# group1 を意味しています。

    config_q-3.gif

    トランク グループの設定
    ※ 画像をクリックすると、大きく表示されます。

    config_q-4.gif

    トランク グループの設定
    ※ 画像をクリックすると、大きく表示されます。

    config_q-5.gif

    トランク グループの設定
    ※ 画像をクリックすると、大きく表示されます。

  4. シグナリング グループを追加して、作成済のトランク グループをポイントします。

    config_q-6.gif

    シグナリング グループを追加
    ※ 画像をクリックすると、大きく表示されます。

  5. ルート パターンを追加して、シグナリング グループをポイントします。 この例では、ルート パターン 4 が、手順 4 で作成されたシグナリング グループ 1 をポイントしています。

    config_q-7.gif

    ルート パターンを追加
    ※ 画像をクリックすると、大きく表示されます。

  6. コールのルーティングに作成したルート パターンを使用するために、AAR テーブルにエントリを追加します。 この例では、Cisco IP Phone の内線 4XXX へのコールに 4 で始まる AAR エントリが使用されており、これがルート パターン # 4 を示すことになります。

    config_q-8.gif

    AAR テーブルにエントリを追加
    ※ 画像をクリックすると、大きく表示されます。

  7. 発信者名を送信するために、各 IP Phone で発信者番号(Caller ID)が有効になっていることを確認します。

    config_q-9.gif

    Caller ID が有効になっていることを確認
    ※ 画像をクリックすると、大きく表示されます。

Cisco CallManager での手順

次の手順を実行します。

  1. ヘアピニングなどの問題を防止するために、サービス パラメータで、Start Path Replacement の Minimum と Maximum の値が適切に設定されていることを確認します。

    次の 2 つの画面キャプチャは、Q.SIG のサービス パラメータ設定に関するものです。

    config_q-10.gif

    Q.SIG のサービス パラメータ設定
    ※ 画像をクリックすると、大きく表示されます。

    config_q-11.gif

    Q.SIG のサービス パラメータ設定
    ※ 画像をクリックすると、大きく表示されます。

  2. MGCP ゲートウェイとして Cisco 3745 を追加し、NM-HDV T1 モジュールを Q.SIG PRI 用に設定します。

    次の 5 つの画面キャプチャは、この設定に関するものです。

    config_q-12.gif

    MGCP ゲートウェイとして Cisco 3745 を追加して NM-HDV T1 モジュールを Q.SIG PRI 用に設定
    ※ 画像をクリックすると、大きく表示されます。

    config_q-13.gif

    MGCP ゲートウェイとして Cisco 3745 を追加して NM-HDV T1 モジュールを Q.SIG PRI 用に設定
    ※ 画像をクリックすると、大きく表示されます。

    config_q-15.gif

    MGCP ゲートウェイとして Cisco 3745 を追加して NM-HDV T1 モジュールを Q.SIG PRI 用に設定
    ※ 画像をクリックすると、大きく表示されます。

    config_q-16.gif

    MGCP ゲートウェイとして Cisco 3745 を追加て NM-HDV T1 モジュールを Q.SIG PRI 用に設定
    ※ 画像をクリックすると、大きく表示されます。

    config_q-17.gif

    MGCP ゲートウェイとして Cisco 3745 を追加して NM-HDV T1 モジュールを Q.SIG PRI 用に設定
    ※ 画像をクリックすると、大きく表示されます。

  3. 最後の手順として、PBX に経路切替要求のための番号を提供するために Cisco CallManager ピックアップ グループを作成します。 コール ピックアップ番号が Path PINX Replacement ID Service パラメータにも入力されていることを確認してください(手順 1 参照)。 さらに、Avaya のシステムでは、ピックアップ グループへのルーティングのためにルート パターンが必要です。

    config_q-18.gif

    Cisco CallManager ピックアップ グループを作成
    ※ 画像をクリックすると、大きく表示されます。

    注:Cisco CallManager Service ParametersAdvanced)の中の(Device - PRI and MGCP Gateway)にある次の 2 つのクラスタワイド パラメータが PBX の Q.SIG 設定と一致していることを確認してください。 PBX トランクは、すべて、これらの CallManager パラメータどおりに設定する必要があります。

    • ASN.1 ROSE OID Encoding: このパラメータでは、Remote Operations Service Element(ROSE)のための Invoke Object ID(OID)のエンコード方法が指定されます。 別途、シスコのサポート エンジニアからの指示がない限り、このパラメータはデフォルトのままにしておきます。 これは必須フィールドで、デフォルトは Use Local Value です。

      このパラメータで有効な値を次に示します。

      • Use Local Value:これはほとんどのテレフォニー システムでサポートされており、Q.SIG Variant サービス パラメータが ISO(Protocol Profile 0x9F)にセットされている場合に使用する必要があります。

      • Use Global Value (ISO):これを使用するのは、接続された PBX で Use Local Value がサポートされていない場合だけです。

      • Use Global Value (ECMA):これを使用する必要があるのは、Q.SIG Variant サービス パラメータが ECMA(Protocol Profile 0x91)にセットされている場合です。

    • Q.SIG Variant: このパラメータでは、トランクが Q.SIG に設定されている場合に、アウトバウンド Q.SIG ファシリティ情報で送信されるプロトコル プロファイルが指定されます。別途、シスコのサポート エンジニアからの指示がない限り、このパラメータはデフォルトのままにしておきます。 これは必須フィールドで、デフォルトは ISO (Protocol Profile 0x9F) です。

      このパラメータに使用可能な値を次に示します。

      • ECMA (Protocol Profile 0x91):通常、これは ECMA PBX で使用され、Protocol Profile 0x91 だけを使用できます。 このサービス パラメータが ECMA(Protocol Profile 0x91)にセットされていると、ASN.1 Rose OID Encoding サービス パラメータを Use Global Value(ECMA)にセットする必要があります。

      • ISO (Protocol Profile 0x9F):これが現在の ISO 推奨値です。 このサービス パラメータが ISO(Protocol Profile 0x9F)にセットされていると、ASN.1 Rose OID Encoding サービス パラメータを Use Local Value にセットする必要があります。

        警告:CallManager Administration の Trunk Configuration ウィンドウで Tunneled Protocol フィールドが Q.SIG にセットされた状態でクラスタ間トランクを使用する場合、Cisco CallManager では ECMA はサポートされません。 このサービス パラメータを ECMA(Protocol Profile 0x91)にセットしていると、すべてのクラスタ間トランクで Tunneled Protocol フィールドを None にセットする必要があります。

        qsig.gif

        パラメータの確認
        ※ 画像をクリックすると、大きく表示されます。

Cisco 3745 の設定

次に示すのは、Cisco 3745 MGCP デバイスでの show versionshow running-configuration コマンドの出力です。 Cisco 3745 上の Controller T1 1/0 が Avaya S8700/G650 DS1 PRI カードに接続されています。 Cisco 3745 と Avaya S8700/G650 間の PRI リンクに Q.SIG シグナリングが設定されています。

  CCME_CUE_3745# sh vers
  Cisco Internetwork Operating System Software 
  IOS (tm) 3700 Software (C3745-IS-M), Version 12.2(15)ZJ3, EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)
  TAC Support: http://www.cisco.com/tac
  Copyright (c) 1986-2003 by cisco Systems, Inc.
  Compiled Thu 25-Sep-03 22:25 by eaarmas
  Image text-base: 0x60008954, data-base: 0x61C2C000
  
  ROM: System Bootstrap, Version 12.2(8r)T2, RELEASE SOFTWARE (fc1)
  ROM: 3700 Software (C3745-IS-M), Version 12.2(15)ZJ3, EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)
  
  CCME_CUE_3745 uptime is 39 minutes
  System returned to ROM by reload
  System image file is "flash:c3745-is-mz.122-15.ZJ3.bin"
  
  cisco 3745 (R7000) processor (revision 2.0) with 246784K/15360K bytes of memory.
  Processor board ID JMX0814L3E2
  R7000 CPU at 350Mhz, Implementation 39, Rev 3.3, 256KB L2, 2048KB L3 Cache
  Bridging software.
  X.25 software, Version 3.0.0.
  SuperLAT software (copyright 1990 by Meridian Technology Corp).
  Primary Rate ISDN software, Version 1.1.
  2 FastEthernet/IEEE 802.3 interface(s)
  25 Serial network interface(s)
  1 terminal line(s)
  2 Channelized T1/PRI port(s)
  1 ATM AIM(s)
  2 Voice FXS interface(s)
  2 Voice E & M interface(s)
  1 cisco service engine(s)
  DRAM configuration is 64 bits wide with parity disabled.
  151K bytes of non-volatile configuration memory.
  125184K bytes of ATA System CompactFlash (Read/Write)
  Configuration register is 0x2102
  
  CCME_CUE_3745# sh run
  Building configuration...
  
  Current configuration : 3291 bytes
  !
  version 12.2
  service timestamps debug datetime msec
  service timestamps log datetime msec
  no service password-encryption
  !
  hostname CCME_CUE_3745
  !
  logging queue-limit 100
  !
  voice-card 1
   dspfarm
  !
  voice-card 5
   dspfarm
  !
  ip subnet-zero
  !
  !
  no ip domain lookup
  !
  isdn switch-type primary-qsig
  !
  no voice hpi capture buffer
  no voice hpi capture destination 
  !
  !
  ccm-manager mgcp
  ccm-manager music-on-hold
  ccm-manager config server 172.28.221.18  
  ccm-manager config
  mta receive maximum-recipients 0
  !
  !
  controller T1 1/0
   framing esf
   linecode b8zs
   pri-group timeslots 1-24 service mgcp
  !
  controller T1 1/1
   framing sf
   linecode ami
  !
  !
  !
  interface FastEthernet0/0
   description CCME-CUE-3745_to_cat3550
   no ip address
   duplex auto
   speed auto
  !
  interface FastEthernet0/0.1
   encapsulation dot1Q 99
  !
  interface FastEthernet0/0.2
   description NEW_S8700_G650
   encapsulation dot1Q 300
   ip address 172.28.221.49 255.255.255.240
   ip helper-address 172.28.221.19
   h323-gateway voip bind srcaddr 172.28.221.49
  !
  interface FastEthernet0/0.3
   description MODULAR_MESSAGING_SOLUTION
   encapsulation dot1Q 900
   ip address 172.28.221.129 255.255.255.240
   ip helper-address 172.28.221.19
  !
  interface FastEthernet0/0.4
   encapsulation dot1Q 301
   ip address 10.1.3.1 255.255.255.128
   ip helper-address 172.28.221.19
  !
  interface FastEthernet0/0.5
   encapsulation dot1Q 302
   ip address 10.1.3.129 255.255.255.128
   ip helper-address 172.28.221.19
  !
  interface FastEthernet0/0.6
   encapsulation dot1Q 90
   ip address 90.1.1.254 255.255.255.0
   ip helper-address 172.28.221.19
  !
  interface Serial0/0
   description CCME-CUE-3745_to_3600
   ip address 25.0.0.1 255.0.0.0
   clockrate 256000
   no fair-queue
  !
  interface Serial1/0:23
   no ip address
   no logging event link-status
   isdn switch-type primary-qsig
   isdn incoming-voice voice
   isdn bind-l3 ccm-manager
   isdn bchan-number-order ascending
   no cdp enable
  !
  interface Service-Engine2/0
   no ip address
   shutdown
  !
  router eigrp 100
   network 10.0.0.0
   network 25.0.0.0
   network 90.0.0.0
   network 172.28.0.0
   auto-summary
  !
  ip http server
  ip classless
  !
  call rsvp-sync
  !
  voice-port 1/0:23
  !
  voice-port 4/0/0
  !
  voice-port 4/0/1
  !
  voice-port 4/1/0
  !
  voice-port 4/1/1
  !
  mgcp
  mgcp call-agent 172.28.221.18 2427 service-type mgcp version 0.1
  mgcp dtmf-relay voip codec all mode out-of-band
  mgcp rtp unreachable timeout 1000 action notify
  mgcp package-capability rtp-package
  no mgcp package-capability res-package
  mgcp package-capability sst-package
  no mgcp timer receive-rtcp
  mgcp sdp simple
  mgcp fax t38 inhibit
  mgcp rtp payload-type g726r16 static
  !
  mgcp profile default
  !
  !
  !
  dial-peer cor custom
  !
  dial-peer voice 1 pots
   application mgcpapp
   port 1/0:23
  !
  dial-peer voice 999410 pots
   application mgcpapp
   port 4/1/0
  !
  !
  line con 0
   password cisco
   login
  line 65
   flush-at-activation
   no activation-character
   no exec
   transport preferred none
   transport input all
  line aux 0
  line vty 0 4
   password cisco
   login
  !
  end
  

Cisco と Avaya の IP-PBX システムの相互運用性のためのテスト済機能

このセクションでは、Cisco CallManager 4.1(2) プラットフォームと Communication Manager 2.0 が稼働する Avaya S8700/G650 間の Q.SIG PRI トランクでテストされた機能を一覧表示しています。

  • 名前と番号の表示(双方向)

  • コール転送

  • 2 つのシステム間の会議コール

Cisco と Avaya の IP 電話をサポートするための Cisco Unity ボイスメールの統合

ここでは、Avaya Communication Manager 2.0 が稼働する Avaya S8700/G650 と CallManager バージョン 4.1(2) が稼働する Cisco CallManager プラットフォーム間でのコールのために Q.SIG トランクが使用できます。なお、Avaya S8700/G650 に物理的な ISDN PRI 接続を提供するためには、Cisco 3745 MGCP デバイスが使用されます。 Cisco と Avaya の両方の IP 電話にボイス メール サポートを提供するために、Cisco CallManager プラットフォームに Cisco Unity サーバを追加できます。 これを有効にするには、管理者が Cisco CallManager プラットフォームで Cisco Unity を設定する必要があります。 このセクションでは、Cisco CallManager Administration 管理ページで Cisco Unity を設定する方法を示した画面キャプチャ付きの手順が紹介されています。

注:ほとんどの設定は、Cisco Voice Mail Port Wizard で実行されます。

Cisco CallManager への Cisco Unity の付加

次の手順を実行します。

  1. Feature メニューで、Voice Mail > Voice Mail Port Wizard の順に選択します。 Create a new Cisco Voice Mail Server and add ports to it を選択して、Next をクリックします。

    config_q-19.gif

    Create a new Cisco Voice Mail Server and add ports to it を選択
    ※ 画像をクリックすると、大きく表示されます。

  2. AvayaUM3 のように、Cisco Voice Mail Server の名前を入力して、Next をクリックします。

    config_q-20.gif

    Cisco Voice Mail Server の名前を入力
    ※ 画像をクリックすると、大きく表示されます。

  3. 必要な Voice Mail Port の数を選択して、Next をクリックします。

    config_q-21.gif

    Voice Mail Port 数を選択
    ※ 画像をクリックすると、大きく表示されます。

  4. Voice Mail Port のための Description と Device Pool に入力します。 設定例では、Description として Avaya VMailPorts と入力されており、Device Pool には Default が選択されています。

    39_step4.gif

    Description と Device Pool 入力
    ※ 画像をクリックすると、大きく表示されます。

  5. Beginning Directory Number には 4406 のように入力し、Display には Voicemail のように入力して、Next をクリックします。

    config_q-22.gif

    Beginning Directory Number と Display 入力
    ※ 画像をクリックすると、大きく表示されます。

  6. 次の画面では、「Do you want to add these directory numbers to a Line Group?」との質問が表示されます。 Yes. Add directory numbers to a new Line Group を選択して、Next をクリックします。

    config_q-23.gif

    Yes. Add directory numbers to a new Line Group を選択
    ※ 画像をクリックすると、大きく表示されます。

  7. AvayaUM3 のような、前に入力した Voice Mail Server に一致する Line Group Name を入力します。

    config_q-24.gif

    Line Group Name を入力
    ※ 画像をクリックすると、大きく表示されます。

  8. 次の画面では、これまでに入力した設定が表示されます。 設定に変更がなければ、Finish をクリックします。

    config_q-25.gif

    入力した設定の確認
    ※ 画像をクリックすると、大きく表示されます。

  9. Hunt List Administration の Web ページで、Add a New Hunt List をクリックします。

    config_q-26.gif

    Add a New Hunt List をクリック
    ※ 画像をクリックすると、大きく表示されます。

  10. Hunt List Name と Description に、Avaya VMailHL のように入力します。 さらに、Cisco CallManager Group には、Default を選択します。

    config_q-27.gif

    Hunt List の設定
    ※ 画像をクリックすると、大きく表示されます。

  11. Hunt List の追加が成功すると、次の画面キャプチャのようになります。 Add Line Group をクリックします。

    config_q-28.gif

    Add Line Group をクリック
    ※ 画像をクリックすると、大きく表示されます。

  12. 設定済の Line Group を選択します。 この場合は、AvayaUM3 です。

    config_q-29.gif

    設定済の Line Group を選択
    ※ 画像をクリックすると、大きく表示されます。

  13. 次の画面キャプチャには、ライン グループの挿入が成功したことが示されています。

    config_q-30.gif

    ライン グループの挿入が成功した場合
    ※ 画像をクリックすると、大きく表示されます。

  14. Route Plan > Route/Hunt > Hunt Pilot の順に進みます。 表示された Hunt Pilot 画面で、Add a New Hunt Pilot をクリックします。

    config_q-31.gif

    Add a New Hunt Pilot をクリック
    ※ 画像をクリックすると、大きく表示されます。

  15. Hunt Pilot に 4408 のように入力して、さらに、Avaya VMail HL のように Hunt List を選択し、Insert をクリックします。

    config_q-32.gif

    Hunt List の設定
    ※ 画像をクリックすると、大きく表示されます。

  16. Feature > Voice Mail > Voice Mail Pilot の順に進み、表示された画面で、Add a New Voice Mail Pilot をクリックします。

    config_q-33.gif

    Add a New Voice Mail Pilot をクリック
    ※ 画像をクリックすると、大きく表示されます。

  17. 設定済の Hunt Pilot 番号に一致する Voice Mail Pilot 番号を入力します。 この場合は、Hunt Pilot と Voice Mail Pilot の番号はどちらも 4408 です。

    config_q-34.gif

    Voice Mail Pilot 番号を入力
    ※ 画像をクリックすると、大きく表示されます。

  18. Feature > Voice Mail > Voice Mail Profile の順に進み、Add a New Voice Mail Profile をクリックします。

    config_q-35.gif

    Add a New Voice Mail Profile をクリック
    ※ 画像をクリックすると、大きく表示されます。

  19. Voice Mail Profile Name と Description に AvayaVMailProfile のように入力して、手順 17 の Voice Mail Pilot 番号を選択します。この場合は、Voice Mail Pilot 番号は 4408 です。

    config_q-36.gif

    手順 17 の Voice Mail Pilot 番号を選択
    ※ 画像をクリックすると、大きく表示されます。

  20. Features > Voice Mail > Message Waiting Indicator > Add a New Message Waiting Number の順にクリックして、Message Waiting Indicator(MWI)On/Off 番号を追加します。 Message Waiting Indicator On/Off 番号に関する画面キャプチャを 2 枚示します。

    config_q-37.gif

    Message Waiting Indicator On/Off 番号を追加
    ※ 画像をクリックすると、大きく表示されます。

    config_q-38.gif

    Message Waiting Indicator On/Off 番号を追加
    ※ 画像をクリックすると、大きく表示されます。

テスト済の Cisco Unity ボイスメール機能

次に、Cisco CallManager 4.1(2) プラットフォームと Communication Manager 2.0 が稼働する Avaya S8700/G650 間での Q.SIG PRI トランクで、Cisco Unity Voice Mail のアクセスに使用される Avaya IP 電話でテストされた Cisco Unity ボイスメール機能を一覧表示します。

  • Internal greeting

  • Busy greeting

  • MWI

  • Easy message access


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報