オプティカル : 同期光ネットワーク(SONET)

POS/APS の冗長性の設定

2006 年 1 月 10 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 1 月 10 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
自動保護スイッチング
APS および関連コマンド
切り替えモード
      双方向モード(推奨)
      単方向モード
基本的なシナリオ
      現用インターフェイスから ADM へのファイバ障害
      ADM から現用インターフェイスへのファイバ障害(双方向モード)
      ADM から現用インターフェイスへのファイバ障害(単方向モード)
      現用インターフェイスと ADM 間の Tx ファイバおよび Rx ファイバの両方のリンク障害
K1/K2 バイト
APS の設定
APS の監視とメンテナンス
APS のトラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、Automatic Protection Switching(APS; 自動保護スイッチング)機能について説明し、Packet Over SONET(POS)冗長性のための APS の設定例を示します。

このドキュメントには APS のしくみを理解するための情報と Cisco ルータで APS の設定および管理をする際に役立つ情報が記載されています。 このドキュメントは、図 1 のネットワーク トポロジに基づくものです。

pos-aps_14680-a.gif

図 1 - ネットワーク トポロジ
※ 画像をクリックすると、大きく表示されます。

前提条件

要件

次の項目に関する知識があることを推奨しています。

  • Synchronous Optical Network(SONET)および POS テクノロジー

  • Cisco ルータの設定の基礎

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS(R) ソフトウェア リリース 12.0(10)S

  • Cisco 12000 シリーズ ハードウェア プラットフォーム

APS 機能は、Cisco 7500 および 12000 シリーズ ハードウェア プラットフォームと Cisco IOS ソフトウェア リリース 12.2(5) 以降でサポートされています。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼働中である場合には、すべてのコマンドによる潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

自動保護スイッチング

APS 機能は冗長性を実現し、回線障害時の POS 回線の切り替えを可能にします。 APS の実装により、回線冗長性のために 1 対の SONET 回線を設定できます。 Working(W; 現用)インターフェイスに障害が発生した場合、Protect(P; 保護)インターフェイスが瞬時にトラフィック ロードを引き継ぎます。 ファイバ切断の際は、アクティブ回線が 60 ミリ秒以内に自動的に予備回線に切り替わります(開始動作に 10 ミリ秒、切り替えに 50 ミリ秒)。 SONET APS では、レイヤ 1(L1)での切り替えが実行されます。 そのため、レイヤ 2(L2)やレイヤ 3(L3)の切り替えよりも高速な切り替えが実現されます。

この機能が使用する保護メカニズムには 1+1 アーキテクチャが含まれています。このアーキテクチャについては Bellcore のドキュメント『TR-TSY-000253, SONET Transport Systems, Common Generic Criteria』のセクション 5.3 に記載されています。 SONET APS は GR-253 および ITU-T G.783 に準拠しています。 そのため SONET APS では、Cisco ルータを SONET Add/Drop Multiplexer(ADM; add/drop マルチプレクサ)とシームレスに統合できます。 この機能では双方向または単方向の切り替えを設定できますが、双方向の非リバーティブ切り替えがデフォルトです。

APS 1+1 アーキテクチャでは、各冗長回線ペアが W インターフェイスと P インターフェイスで構成されます。 W インターフェイスと P インターフェイスは SONET ADM に接続されます。SONET ADM は W インターフェイスと P インターフェイスに同一の信号ペイロードを送信します。 W 回線と P 回線は同一のアダプタ、ラインカード、または 2 台の異なるルータ内の 2 つのポートで終端できます。 Signal Fail(SF; 信号障害)条件または Signal Degrade(SD; 信号劣化)条件の発生時には、ハードウェアが W 回線から P 回線への切り替えを行います。 リバーティブ オプションを使用できます。 SF 条件が検出された場合は、W 回線の修復後、設定された時間が経過すると、ハードウェアが自動的に W 回線への切り替えを実施します。 W 回線と P 回線の調整はインバンド Protect Group Protocol(PGP)により行われます。 非リバーティブのオプションでは、SF 条件の発生時にハードウェアが P 回線への切り替えを行った後、W 回線への自動切り替えが行われません。

P 回線では、SONET フレームの Line OverHead(LOH; ライン オーバーヘッド)の K1/K2 バイトが APS 接続の現在の状態を示し、処理要求を伝達します。 接続の両端では、このシグナリング チャネルを使用して同期を維持しています。 終端地点での 1 つあるいは複数のルータ内の W 回線と P 回線自体は、W 回線と P 回線とは別に、独立した通信チャネル(APS PGP を使用)で同期を取っています。 この独立チャネルには、異なる SONET 接続、イーサネット、または狭帯域幅の接続を使用できます。 APS の設定を行うルータでは、P インターフェイスの設定に W インターフェイスを持つルータの IP アドレス(通常はループバック アドレスで、これを推奨)を含めます。

User Datagram Protocol(UDP; ユーザ データグラム プロトコル)の上で動作する APS PGP により、W インターフェイスを制御するプロセスと P インターフェイスを制御するプロセス間の通信が可能になります。 P 回線を制御するプロセスはこのプロトコルを使用して、回線劣化時、チャネル信号の消失時、またはユーザ介入時に W 回線をアクティブにするか非アクティブ化にするかについて、W 回線を含むプロセスに指示します。 これら 2 つのプロセス間の通信が失われた場合、W ルータは P 回線が存在しないものとして W 回線の完全制御を引き受けます。

APS および関連コマンド

次に APS のトリガーを階層的(優先順位の低い順)に分類したものを示します。

  • 手動切り替え要求

  • SD 条件(Bit Error Rate(BER; ビット誤り率)が SD しきい値を超える)

  • SF 条件(Loss of Frame(LOF; フレーム損失)、Loss of Signal(LOS; 信号消失)、Alarm Indication Signal-Line(AIS-L; アラーム表示信号(回線))、10-3 またはユーザによるプロビジョニングの値を超える回線 BER)

  • 強制切り替え要求

APS を設定するための IOS オプションを示します。

 GSR(config-if)# aps ?
 authentication  Authentication string 
 force           Force channel 
 group           Group association 
 lockout         Lockout protection channel 
 manual          Manually switch channel 
 protect         Protect specified circuit 
 reflector       Configure for reflector mode APS 
 revert          Specify revert operation and interval 
 signaling      Specify SONET/SDH K1K2 signaling 
 timers          APS timers 
 unidirectional  Configure for unidirectional mode 
 working         Working channel number 
 

APS 機能のための新しい IOS コマンドに加え、POS インターフェイス設定コマンド POS threshold および POS report が追加されました。これらのコマンドは BER しきい値や SONET アラームのレポーティングに関するユーザ設定をサポートするものです。 次に出力例を示します。

 GSR(config-if)# POS threshold ? 
   b1-tca  B1 BER threshold crossing alarm 
   b2-tca  B2 BER threshold crossing alarm 
   b3-tca  B3 BER threshold crossing alarm 
   sd-ber  set Signal Degrade BER threshold 
   sf-ber  set Signal Fail BER threshold 
 
 GSR(config-if)# POS report ?
   all     all Alarms/Signals 
   b1-tca  B1 BER threshold crossing alarm 
   b2-tca  B2 BER threshold crossing alarm 
   b3-tca  B3 BER threshold crossing alarm 
   lais    Line Alarm Indication Signal 
   lrdi    Line Remote Defect Indication 
   pais    Path Alarm Indication Signal 
   plop    Path Loss of Pointer 
   prdi    Path Remote Defect Indication 
   rdool   Receive Data Out Of Lock 
   sd-ber  LBIP BER in excess of SD threshold 
   sf-ber  LBIP BER in excess of SF threshold 
   slof    Section Loss of Frame 
   slos    Section Loss of Signal 
 
 

切り替えモード

双方向モードでは、Receive(Rx; 受信)チャネルと Transmit(Tx; 送信)チャネルがペアとして切り替えられます。 単方向モードでは、Tx チャネルと Rx チャネルがそれぞれ別々に切り替えられます。 たとえば双方向モードでは、W インターフェイスの Rx チャネルにチャネル信号消失が発生した場合、Rx と Tx の両方のチャネルが切り替えられます。

双方向モード(推奨)

W ルータが障害を認識し、P ルータに通知します(ローカル相互接続 PGP を介して)。 P ルータは W ルータに、W インターフェイスを選択解除するように指示します(ローカル相互接続 PGP を介して)。 P ルータは ADM に、Tx と Rx の P への切り替えを要求します(ADM に向かう P インターフェイス上の K1/K2 バイトを介して)。 P ルータが P インターフェイスを選択し、ADM が切り替え要求と信号準拠に従います(P インターフェイス ファイバに向かう ADM 上の K1/K2 バイトを介して)。

単方向モード

W の Rx に LOS/LOF アラーム(障害)が発生すると、W ルータが障害を認識し、P ルータに通知します(ローカル相互接続 PGP を介して)。 P ルータは W ルータに、W インターフェイスを選択解除するように指示します(ローカル相互接続 PGP を介して)。 W ルータは、W インターフェイスが選択解除されている間 Line Alarm Indication Signal(LAIS; ラインのアラーム表示信号)をアサートし、ADM に Rx の P インターフェイスへの切り替えを強制させます。 P ルータは ADM に、P インターフェイスへの切り替えを要求します(ADM ファイバに向かう P インターフェイスの K1/K2 を介して)。 P ルータが P インターフェイスを選択し、ADM が切り替え要求に従います。

単方向モードでは、ルータが ADM に切り替えを強制します。 切り替えを実行するため、ルータは LAIS(W の場合は継続的に、P の場合は一時的に)をアサートします。 そのため、GR-253 に準拠するという点で実質的な単方向切り替えが行われます。しかし単方向モードでは、2 つ目の単方向切り替えを強制するため、切り替えが双方向のように見えます。 これはルーティング メカニズム(IP)の根底にある制約の結果です。この制約により、すべてのレベルにおいて、トラフィックに同一インターフェイス上の Rx と Tx が必要になります。 つまりルータは、GR-253 の単方向プロトコルに準拠しますが、IP をサポートするモデルへの切り替えを強制します。 そのためルータでは、異なるファイバ ペアの Tx および Rx はサポートされません。

注:Cisco 12000 シリーズに存在する GR-253 からの主な逸脱点は、Cisco 12000 シリーズは W および P への送信のブリッジを行わず、一度に 1 つのインターフェイスだけをアクティブにするという点です。

基本的なシナリオ

現用インターフェイスから ADM へのファイバ障害

ADM がファイバ障害を確認し、P ルータに SF SWITCH REQUEST を送信して(P インターフェイス ファイバ上の K1/ K2 バイトを介して)、P インターフェイスへの切り替えを要求します。 P ルータは W ルータに、W インターフェイスを選択解除(無効化)するように指示します(ローカル相互接続を介して)。 P ルータが P インターフェイスを選択(アクティブ化)します。 P ルータが ADM に、切り替え要求への追従を連絡します(P インターフェイス ADM ファイバ上の K1/K2 バイトを介して)。

ADM から現用インターフェイスへのファイバ障害(双方向モード)

W ルータが障害を認識し、P ルータに通知します(ローカル相互接続を介して)。 P ルータは W ルータに、W インターフェイスを選択解除するように指示します(ローカル相互接続を介して)。 P ルータは ADM に、Tx と Rx の P への切り替えを要求します(ADM ファイバに向かう P インターフェイス上の K1/K2 バイトを介して)。 P ルータが P インターフェイスを選択し、ADM が切り替え要求と信号準拠に従います(P インターフェイス ファイバに向かう ADM 上の K1/K2 バイトを介して)。

ADM から現用インターフェイスへのファイバ障害(単方向モード)

W ルータが障害を認識し、P ルータに通知します(ローカル相互接続を介して)。 P ルータは W ルータに、W インターフェイスを選択解除するように指示します(ローカル相互接続を介して)。 W ルータは 100 ミリ秒の間 LAIS をアサートし、Rx の P インターフェイスへの切り替えを ADM に強制させます。 P ルータは ADM に、P インターフェイスへの切り替えを要求します(ADM ファイバに向かう P インターフェイスの K1/K2 を介して)。 P ルータが P インターフェイスを選択し、ADM が切り替え要求に従います。

現用インターフェイスと ADM 間の Tx ファイバおよび Rx ファイバの両方のリンク障害

両方のシーケンスが開始されます。 P ルータが P への切り替えを先に開始するか、ADM が先に切り替えを開始するかは関係ありません。得られる結果は同じです。

POS を実装する Cisco ルータは、SONET/Synchronous Digital Hierarchy(SDH)のセクション、回線、およびリンクのパス セグメントに対して Terminal Equipment(TE; 端末機器)として機能し、次の SONET/SDH エラーおよびアラームを検出およびレポートできます。

  • セクション:LOS、LOF、および Threshold Crossing Alarms(TCA; しきい値超過アラーム)(B1)

  • 回線:AIS(回線およびパス)、Remote Defect Indication(RDI; リモート障害表示)(回線およびパス)、および Remote Error Indication(REI; リモート エラー表示)、および TCA(B2)

  • パス:AIS、RDI、REI、(B3)、New Pointer Events(NEWPTR)、POSitive Stuffing Event(PSE)、および Negative Stuffing Event(NSE)

そのほか、次のような情報がレポートされます。

  • SF-ber

  • SD-ber

  • C2 - 信号ラベル(ペイロード構築)

  • J1 - パス トレース バイト

B1、B2、および B3 はパフォーマンス モニタリング パラメータに分類されます。それ以外の LOS、LOF、LAIS などはアラームに分類されます。 パフォーマンス モニタリングは早期警告に該当し、アラームは障害を表すものです。 K1/K2 バイトのステータスは、SONET APS または SDH Multiservice Switching Path(MSP; マルチサービス スイッチング パス)についてもレポートされます。

K1/K2 バイト

APS について検討する場合は、SONET で LOH の K1/K2 バイトがどのように使用されるのかを理解しておく必要があります。

Synchronous Transport Signal-1(STS-1)(STS; 同期転送信号)は、27 バイトの Transport Overhead(TOH; 転送オーバーヘッド)と 783 バイトの Synchronous Payload Envelope(SPE; 同期ペイロード エンベロープ)を含む、810 バイトで構成されています。 表 1 は、STS-1 フレームの形式およびその 9 行 x 90 列を示したものです。

表 1 - STS-1 フレームの形式
パス オーバーヘッド

セクション オーバーヘッド

A1 フレーミング

A2 フレーミング

A3 フレーミング

J1 トレース

B1 BIP-8

E1 オーダーワイヤ

E1 ユーザ

B3 BIP-8

D1 データ コム

D2 データ コム

D3 データ コム

C2 信号ラベル

回線オーバーヘッド

H1 ポインタ

H2 ポインタ

H3 ポインタ アクション

G1 パス ステータス

B2 BIP-8

K1

K2

F2 ユーザ チャネル

D4 データ コム

D5 データ コム

D6 データ コム

H4 インジケータ

D7 データ コム

D8 データ コム

D9 データ コム

Z3 グロース

D10 データ コム

D11 データ コム

D12 データ コム

Z4 グロース

S1/Z1 同期ステータス/グロース

M0 または M1/Z2 REI-L グロース

E2 オーダーワイヤ

Z5 タンデム接続

K1/K2 バイトは 16 ビットのフィールドを形成します。 表 2 に各ビットの用途を示します。

表 2 - K1 ビットの説明
ビット(16 進数) 説明

K1 ビット 12345678

ビット 5 〜 8

nnnn

コマンド コードに関連付けられたチャネル番号

ビット 1 〜 4

1111(0xF)

保護要求のロックアウト

1110(0xE)

強制切り替え要求

1101(0xD)

SF - 高優先順位要求

1100(0xC)

SF - 低優先順位要求

1011(0xB)

SD - 高優先順位要求

1010(0xA)

SD - 低優先順位要求

1001(0x9)

未使用

1000(0x8)

手動切り替え要求

0111(0x7)

未使用

0110(0x6)

復元待ち要求

0101(0x5)

未使用

0100(0x4)

試験要求

0011(0x3)

未使用

0010(0x2)

リバース要求

0001(0x1)

切り替え戻しなし要求

0000(0x0)

要求なし

注:ビット 1 が低位ビットです。

表 3 - K2 ビットの説明
ビット 説明

K2 ビット 12345678

 

ビット 1 〜 4

 

nnnn

コマンド コードに関連付けられたチャネル番号

ビット 5

 

1

1 対 n(1:n)アーキテクチャ

0

1 プラス 1(1+1)アーキテクチャ

ビット 6 〜 8

 

111

ライン AIS

110

ライン RDI

101

双方向動作モード

100

単方向動作モード

その他

予約済み

注:K2(12345678)

  • K2[1-4] - 現在ブリッジされているチャネル番号

  • K2[5] - アーキテクチャ(1+1 の場合は常に 0)

  • K2[6-8] - プロビジョニングされた動作モード(4 = unidir、5 = bidir)

  • K2[6-8] - アラーム コード 6=LRDI および 7=LAIS も転送

注:SDH の場合、K2[6-8] ではアラーム コードだけが転送されます。 動作モードは送信されません。

注:たとえば、ルータが SF を受信したときの、W 側の K1 および対応する K2 の値はいくつですか。また P 側の値はいくつですか。

注:  答え: K1/K2 を転送し、読み取るのは P だけです。W では転送も読み取りも行われません。双方向モードでは、W が SF を受け取り、それよりも高い要求がなければ、P から ADM へのコードは次のようになります。

 K1= 0xC1 (switch request, SF on 1=working, low priority) 
 K2 = 0x05 (protect bridged [working bridge is incomplete];bidirectional)
 

注:ADM の応答後は、次のようになります。

 K1 = 0x21 (Reverse request, channel 1) 
 K2 = 0x15 (Working bridged; bidirectional)
 

注:保護ルータの txk1k2 は次のようになります。

 K1=0xC1 (switch request, SF on 1=working, low priority) 
 K2 = 0x15 (working bridged; bidirectional) 
 

注:この時点で切り替えが完了します。

APS の設定

図 2 は、非リバーティブ、双方向モード(Cisco 12000 シリーズのデフォルト)の GSR から ADM(ONS 15454)への基本的な APS 1+1 の構成を示しています。 APS はリニア切り替えで、回線レベルで実行されます(パスやエンドツーエンドよりも Cisco 12000 シリーズと ADM 間で)。

注:この例では、W および P インターフェイスが同じルータ上にあるため、PGP 用の独立チャネルはありません。

pos-aps_14680-a.gif

図 2 - 基本的な APS 1+1 の構成
※ 画像をクリックすると、大きく表示されます。

 gsrA# show running-config
 ! 
 interface Loopback0 
 ip address 100.1.1.1 255.255.255.0 
 no ip directed-broadcast 
 ! 
 interface POS1/0 
 ip address 10.1.1.1 255.255.255.0 
 no ip directed-broadcast 
 crc 16 
 aps group 10 
 aps working 1 
 ! 
 interface POS1/1 
 ip address 10.1.1.3 255.255.255.0 
 no ip directed-broadcast 
 no keepalive 
 crc 16 
 aps group 10 
 aps revert 1 
 aps protect 1 100.1.1.1
 ! 
 router ospf 100 
 network 10.1.1.0 0.0.0.255 area 0 
 network 100.1.1.0 0.0.0.255 area 0 
 
 gsrB#show running-config 
 ! 
 interface Loopback0 
 ip address 200.1.1.1 255.255.255.0 
 ! 
 interface POS3/0
 ip address 10.1.1.2 255.255.255.0 
 no ip directed-broadcast 
 crc 16 
 aps group 10 
 aps working 1 
 ! 
 interface POS3/1 
 ip address 10.1.1.4 255.255.255.0 
 no ip directed-broadcast 
 no keepalive 
 crc 16 
 aps group 10 
 aps revert 1 
 aps protect 1 200.1.1.1 
 ! 
 router ospf 100 
 network 10.1.1.0 0.0.0.255 area 0 
 network 200.1.1.0 0.0.0.255 area 0 
 ! 
 

APS の監視とメンテナンス

システム プロセス情報を提供するため、IOS ソフトウェアには show で始まる EXEC コマンドの広範なリストが含まれています。 これらの show コマンドを実行すると、システム情報に関する詳細なテーブルが表示されます。 次に、APS 機能用の一般的な show コマンドのいくつかと、それらの出力例を示します。

  • show aps

  • show controllers POS

  • show interface POS

 ! 
 gsrA# show aps
 POS1/1 APS Group 10: protect channel 0 (inactive) 
 bidirectional, revertive (1 min) 
 SONET framing; SONET APS signaling by default 
 Received K1K2: 0x20 0x05 
 Reverse Request (protect) 
 Transmitted K1K2: 0xE0 0x05 
 Forced Switch (protect) 
 Working channel 1 at 100.1.1.1 (Enabled) 
 Pending local request(s): 
 0x0E (No Request, channel(s) 0 1) 
 Remote APS configuration: working 
 POS1/0 APS Group 10: working channel 1 (active) 
 
 !--- 現用チャネルがアクティブであるかどうかを確認します。
 
 SONET framing; SONET APS signaling by default 
 Protect at 100.1.1.1 
 Remote APS configuration: working 
 
 gsrA# show controllers POS 1/0
 POS1/0 
 SECTION 
 LOF = 0          LOS    = 0                            BIP(B1) = 0 
 LINE 
 AIS = 0          RDI    = 0          FEBE = 0          BIP(B2) = 0 
 PATH 
 AIS = 0          RDI    = 0          FEBE = 0          BIP(B3) = 0 
 LOP = 0          NEWPTR = 0          PSE  = 0          NSE     = 0 
 Active Defects: None 
 Active Alarms:  None 
 Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
 Framing: SONET 
 APS 
 working (active) 
 
 !--- 現用チャネルがアクティブであるかどうかを確認します。
 
 COAPS = 0          PSBF = 0 
 State: PSBF_state = False 
 ais_shut = FALSE 
 Rx(K1/K2): 00/00  S1S0 = 00, C2 = CF 
 Remote aps status working; Reflected local aps status working 
 CLOCK RECOVERY 
 RDOOL = 0 
 State: RDOOL_state = False 
 PATH TRACE BUFFER : STABLE 
 Remote hostname : 12012 
 Remote interface: POS3/0 
 Remote IP addr  : 10.1.1.2 
 Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00    
 BER thresholds:  SF = 10e-3  SD = 10e-6 
 TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
 ! 
 gsrA# show controllers POS 1/1 
 POS1/1 
 SECTION 
 LOF = 0          LOS    = 0                            BIP(B1) = 0 
 LINE 
 AIS = 0          RDI    = 0          FEBE = 0          BIP(B2) = 0 
 PATH 
 AIS = 0          RDI    = 0          FEBE = 0          BIP(B3) = 0 
 LOP = 0          NEWPTR = 0          PSE  = 0          NSE     = 0 
 Active Defects: None 
 Active Alarms:  None 
 Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
 Framing: SONET 
 APS 
 protect (inactive) 
 COAPS = 0          PSBF = 0 
 State: PSBF_state = False 
 ais_shut = FALSE 
 Rx(K1/K2): 20/05 Tx(K1/K2): E0/05    
 Signalling protocol: SONET APS by default 
 S1S0 = 00, C2 = CF 
 Remote aps status working; Reflected local aps status working 
 CLOCK RECOVERY 
 RDOOL = 0 
 State: RDOOL_state = False 
 PATH TRACE BUFFER : STABLE 
 Remote hostname : 12012 
 Remote interface: POS3/0 
 Remote IP addr  : 10.1.1.2 
 Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00 
 BER thresholds:  SF = 10e-3  SD = 10e-6 
 TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
 ! 
 gsrA# show interface p1/0 
 POS1/0 is up, line protocol is up  (APS working - active) 
 
 !--- 現用チャネルがアクティブであるかどうかを確認します。
 
 gsrA# show interface p1/1 
 POS1/1 is up, line protocol is down  (APS protect - inactive) 
 
 ! 
 gsrB# show aps
 POS3/1 APS Group 10: protect channel 0 (inactive) 
 bidirectional, revertive (1 min) 
 SONET framing; SONET APS signaling by default 
 Received K1K2: 0x00 0x05 
 No Request (Null) 
 Transmitted K1K2: 0x00 0x05 
 No Request (Null) 
 Working channel 1 at 200.1.1.1 (Enabled) 
 Remote APS configuration: working 
 POS3/0 APS Group 10: working channel 1 (active) 
 
 !--- 現用チャネルがアクティブであるかどうかを確認します。
 
 SONET framing; SONET APS signaling by default 
 Protect at 200.1.1.1 
 Remote APS configuration: working 
 ! 
 gsrB# show controllers p 3/0
 POS3/0 
 SECTION 
 LOF = 11         LOS    = 11                           BIP(B1) = 
 46701837 
 LINE 
 AIS = 10         RDI    = 11         FEBE = 1873       BIP(B2) = 8662 
 PATH 
 AIS = 14         RDI    = 27         FEBE = 460909     BIP(B3) = 
 516875 
 LOP = 0          NEWPTR = 11637      PSE  = 2          NSE     = 16818 
 Active Defects: None 
 Active Alarms:  None 
 Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
 Framing: SONET 
 APS 
 working (active)
 
 !--- 現用チャネルがアクティブであるかどうかを確認します。
 
 COAPS = 103        PSBF = 0 
 State: PSBF_state = False 
 ais_shut = FALSE 
 Rx(K1/K2): 00/00  S1S0 = 00, C2 = CF 
 Remote aps status working; Reflected local aps status working 
 CLOCK RECOVERY 
 RDOOL = 11 
 State: RDOOL_state = False 
 PATH TRACE BUFFER : STABLE 
 Remote hostname : hswan-gsr12008-2b 
 Remote interface: POS1/0 
 Remote IP addr  : 10.1.1.1 
 Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00 
 BER thresholds:  SF = 10e-3  SD = 10e-6 
 TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
 ! 
 gsrB# show controllers p 3/1 
 POS3/1 
 SECTION 
 LOF = 10         LOS    = 10                           BIP(B1) = 
 250005115 
 LINE 
 AIS = 11         RDI    = 8          FEBE = 517        BIP(B2) = 5016 
 PATH 
 AIS = 14         RDI    = 25         FEBE = 3663       BIP(B3) = 7164 
 LOP = 0          NEWPTR = 184        PSE  = 1          NSE     = 247 
 Active Defects: None 
 Active Alarms:  None 
 Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
 Framing: SONET 
 APS 
 protect (inactive) 
 COAPS = 538        PSBF = 0 
 State: PSBF_state = False 
 ais_shut = FALSE 
 Rx(K1/K2): 00/05 Tx(K1/K2): 00/05 
 Signalling protocol: SONET APS by default 
 S1S0 = 00, C2 = CF 
 Remote aps status working; Reflected local aps status working 
 CLOCK RECOVERY 
 RDOOL = 10 
 State: RDOOL_state = False 
 PATH TRACE BUFFER : STABLE 
 Remote hostname : hswan-gsr12008-2b 
 Remote interface: POS1/0 
 Remote IP addr  : 10.1.1.1 
 Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00 
 BER thresholds:  SF = 10e-3  SD = 10e-6 
 TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
 ! 
 gsrB#show interface p3/0 
 POS3/0 is up, line protocol is up  (APS working - active) 
 
 !--- 現用チャネルがアクティブであるかどうかを確認します。
 
 gsrB#show interface p3/1 
 POS3/1 is up, line protocol is down  (APS protect - inactive) 
 ! 
 

APS のトラブルシューティング

APS 関連の問題を解決するには、show コマンドと debug コマンドの出力を収集します。

  • show ver

  • show run

  • show ip int b

  • show contr POS

  • debug aps

  • show aps

必要な操作を実行し、問題を再現します。 次のコマンドを発行して、最終的な出力を収集してから、デバッグを無効にします。

  • show aps

  • no debug aps

注:正常な場合は、debug aps コマンドを実行しても何も出力されません。 異常な状況が存在する場合は、このコマンドによりその状況がレポートされます。

注:W ファイバと P ファイバが異なるルータに収容されている場合(通常の状態)、両方のルータでコマンド出力を収集する必要があります。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報