オプティカル ネットワーキング : Cisco ONS 15454 Series Multiservice Provisioning Platforms

CTC がファイアウォールの内側にある場合に、CTC と ONS 15454 間のセッションの確立に PAT を使用

2006 年 1 月 11 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 1 月 11 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
背景説明
      トポロジ
設定
      ネットワーク ダイアグラム
      設定例
      Cisco ONS 15454 の設定
      PC の設定
      ルータの設定
確認
      確認手順
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、Cisco Transport Controller(CTC; シスコ トランスポート コントローラ)がファイアウォールの内側にある環境で、CTC と ONS 15454 間でセッションを確立するための Port Address Translation(PAT; ポート アドレス変換)の設定例を示します。

前提条件

要件

この設定を開始する前に、次の要件が満たされていることを確認してください。

  • Cisco ONS 15454 についての基本的な知識がある。

  • どの Cisco ルータで PAT がサポートされているかを把握している。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco ONS 15454 バージョン 4.6.X 以降

  • Cisco IOS(R) ソフトウェア リリース 12.1(11) 以降

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼働中である場合には、すべてのコマンドによる潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

トポロジ

トポロジは次の要素で構成されています。

  • Cisco ONS 15454:1 台

  • PC:1 台

  • Cisco 2600 シリーズ ルータ:1 台

ONS 15454 は外部ネットワーク上にあり、サーバとして機能します。 PC は内部ネットワーク上にあり、CTC クライアントとして機能します。 Cisco 2600 シリーズ ルータは PAT をサポートをします。

設定

このセクションでは、このドキュメントに記載されている機能を設定するための情報を示します。

注:このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

このドキュメントでは、次のネットワーク構成を使用しています。

ctc_ons_pat_01.gif

図 1 - トポロジ
※ 画像をクリックすると、大きく表示されます。

設定例

このドキュメントでは、次の構成を使用しています。

  • Cisco ONS 15454

  • PC

  • Cisco 2600 シリーズ ルータ

Cisco ONS 15454 の設定

10.89.238.192 は ONS 15454 の IP アドレスです(図 2 の矢印 A を参照)。10.89.238.1 はデフォルト ルータを表しています(図 2 の矢印 B を参照)。

ctc_ons_pat_02.gif

図 2 - ONS 15454 の設定
※ 画像をクリックすると、大きく表示されます。

CTC が PAT をとおして ONS 15454 と通信できるようにするには、次の手順を実行します。

  1. Gateway Settings のセクションで Enable proxy server on port チェックボックスにチェックマークを付けます(図 2 の矢印 C を参照)。

  2. Proxy-only オプション(図 2 の矢印 D を参照)を選択します。

  3. Apply をクリックします。

プロキシ サーバを有効にしないと、CTC に障害が発生し、次のエラー メッセージが表示されます。

  • EID-2199(図 3 を参照)

  • IOR レポジトリ初期化中の障害(図 4 を参照)。

ctc_ons_pat_03.gif

図 3 - EID-2199 エラー
※ 画像をクリックすると、大きく表示されます。

ctc_ons_pat_04.gif

図 4 - CTC 初期化エラー
※ 画像をクリックすると、大きく表示されます。

PC の設定

172.16.1.254 は PC の IP アドレスです(図 5 の矢印 A を参照)。172.16.1.1 はデフォルト ゲートウェイを表しています(図 5 の矢印 B を参照)。


ctc_ons_pat_05.gif

図 5 - PC の設定


ルータの設定

このセクションでは、ルータの設定手順について説明します。

次の手順を実行します。

  1. ONS 15454 が存在する外部インターフェイスを設定します。

      !
      interface Ethernet1/0
       ip address 10.89.238.1 255.255.255.0
       ip nat outside
      !
      
  2. CTC クライアントが存在する内部インターフェイスを設定します。

      interface Ethernet1/1
       ip address 172.16.1.1 255.255.255.0
       ip nat inside
      !
      
  3. ルータで PAT サポートの設定を行います。 この設定では、access list 1 で許可される内部インターフェイスに到着するすべてのパケットで、1 つの外部 IP アドレスが共有されます。 この設定では外部 IP アドレスは 10.89.238.1 です。

      !
      
      !--- access list 1 で許可される内部インターフェイスに到着するすべてのパケットで、
      !--- 1 つの外部 IP アドレス(ethernet1/0 のアドレス)が
      !--- 共有されます。
      
      
      ip nat inside source list 1 int ethernet1/0 overload
      access-list 1 permit 172.16.1.0 0.0.0.255
      !
      

確認

このセクションを使用して、設定が正しく動作していることを確認します。

確認手順

次の手順を実行します。

  1. Microsoft Internet Explorer を起動します。

  2. ブラウザ ウィンドウのアドレス バーに http://10.89.238.192 と入力し、Enter キーを押します。

    CTC ログイン ウィンドウが表示されます。

  3. 正しいユーザ名とパスワードを入力します。

    CTC クライアントが ONS 15454 との接続に成功します。

トラブルシューティング

このセクションでは、設定のトラブルシューティングに役立つ情報を示します。

debug ip nat detailed コマンドを発行して、IP NAT 詳細トレースを有効にします。 172.16.1.254 から 10.89.238.1 へのアドレス変換(図 6 の矢印 A を参照)および 10.89.238.1 から 172.16.1.254 へのアドレス変換が表示されます(図 6 の矢印 B を参照)。

ctc_ons_pat_06.gif

図 6 - debug ip nat detailed
※ 画像をクリックすると、大きく表示されます。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 63775