サービス品質(QoS) : QoS ポリシング

Cisco 7500 シリーズでの分散型 QoS を使用したフレームリレーのトラフィック シェーピング

2005 年 8 月 10 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
背景説明
設定手順
FRF.12 および DTS
既知の問題
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、トラフィック シェーピングを、Versatile Interface Processor(VIP)を搭載した Cisco 7500 シリーズ ルータのフレームリレー インターフェイスに適用する場合と、それ以外のプラットフォームに適用する場合との違いを具体的に示しています。 それ以外のプラットフォームには、Cisco 7200、3600、および 2600 シリーズのルータがあります。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

Cisco IOS(R) ソフトウェアのリリース 12.1(5)T では、Route Switch Processor(RSP; ルート スイッチ プロセッサ)ベースの Quality of Service(QoS)がサポートされていないため、QoS ポリシーは VIP 上で分散モードで実行する必要があります。 したがって、7500 シリーズでは、VIP のフレームリレー インターフェイスに Distributed Traffic Shaping(DTS; 分散型トラフィックシェーピング)を実装するには、shape コマンドと Modular QoS Command Line Interface(MQC; モジュラ QoS コマンドライン インターフェイス)のその他のコマンドを使用する必要があります。 DTS では、Generic Traffic Shaping(GTS)とフレームリレー トラフィック シェーピング(フレームリレー TS)が統合されます。 設定例は、『Distributed Traffic Shaping(DTS; 分散トラフィック シェーピング)の設定』を参照してください。

次の表に、フレームリレー TS の設定方法をプラットフォーム別に示します。

7500 シリーズ 7200、3600、2600、およびその他の非 VIP プラットフォーム

サポートされるシェーピング メカニズム

DTS

フレームリレー TS

設定コマンド

ポリシーマップでの shape コマンド

メイン インターフェイスでの frame-relay traffic-shaping、シェーピング パラメータを指定する map-class 設定コマンド

dCEF1 の必要性

必要(show cef linecard コマンドにより確認)

不要

1 dCEF = distributed Cisco Express Forwarding

注:フレームリレー TS は、非分散モードの RSP でしか実行できないため、Cisco 7500 シリーズでは frame-relay traffic-shaping コマンドによるフレームリレー TS の設定はブロックされています。 dCEF およびフレームリレー TS を使用すると、CEF の「パント」隣接関係により、全パケットが RSP によってファーストスイッチングされます。この場合、最大転送パフォーマンスが最善とはなりません。

設定手順

次の手順に従って、VIP ベースのフレームリレー インターフェイスに DTS を設定します。

  1. 次のコマンドで dCEF をイネーブルにします。

     router(config)# ip cef distributed
     
  2. 分散スイッチングでフレームリレー インターフェイスがイネーブルにされていることを確認します。

     router(config-if)# interface serial 8/0/0 
     router(config-if)# ip route-cache distributed
    router# show ip interface serial 8/0/0 Serial8/0/0 is up, line protocol is up Internet address is 24.0.0.2/24 Broadcast address is 255.255.255.255 !--- 出力を省略。 ICMP redirects are always sent ICMP unreachables are always sent ICMP mask replies are never sent IP fast switching is enabled IP fast switching on the same interface is disabled IP Flow switching is disabled IP CEF switching is enabled IP Distributed switching is enabled IP Fast switching turbo vector IP CEF switching with tag imposition turbo vector IP multicast fast switching is enabled IP multicast distributed fast switching is disabled IP route-cache flags are Fast, Distributed, CEF Router Discovery is disabled IP output packet accounting is disabled
  3. サービス ポリシーを作成して、マップ クラスに適用します。

    次のいずれか 1 つのポリシーを実装できます。

    注:Cisco IOS ソフトウェア リリース 12.1(2)T では、Cisco 7500 シリーズ以外のプラットフォームでの Low Latency Queueing(LLQ)がサポートされていますが、VIP 上での distributed LLQ(dLLQ; 分散型 LLQ)は Cisco IOS ソフトウェア リリース 12.1(5)T で導入されています。 分散型のバージョンでは、この機能のパフォーマンスが向上しています。 Data-Link Connection Identifier(DLCI; データリンク接続識別子)ごとに、一意のサービス ポリシーを設定できます。 マップ クラスを使用する必要はありません。 service-policy コマンドは、サブインターフェイスあるいは DLCI に直接適用できます。 この場合は、マップ クラス内に dLLQ を設定します。

  4. 次のコマンドを使用して、サービス ポリシーが正常に動作していることを確認します。

    • show policy-map interface

    • show interface shape

    • show vip full-qos

    階層型ポリシーによる DTS の設定例
    ip cef distributed 
    ! 
    class-map 1 
      match <> 
      
    !--- 一致基準を定義します。
     
    class-map 2 
      match <> 
      
    !--- 一致基準を定義します。
     
    ! 
    policy-map CBWFQ 
      class 1 
        bandwidth <>  
        
    !--- kbps または % で値を定義します。
     
      class 2 
        priority <>  
        
    !--- kbps または % で値を定義します。
     
    ! 
    policy-map SHAPE 
       class class-default 
        shape average   
        service-policy CBWFQ 
    ! 
    int s0/0 
      encapsulation frame-relay 
      ip route-cache distributed 
    
    !--- frame-relay traffic-shaping を設定しないでください。
    
    ! 
    int s0/0.1 point-to-point 
      ip address a.b.c.d 
      frame-relay interface-dlci xxx 
       class cisco 
    ! 
    map-class frame-relay cisco 
      service-policy output SHAPE
    

FRF.12 および DTS

Cisco IOS ソフトウェア リリース 12.1(5)T では、フレームリレー フラグメンテーションの分散型バージョンの FRF.12 が導入されています。 フレームリレー インターフェイスに分散型 FRF.12 を適用する場合は、マップ クラスを定義して、そのマップ クラスにサービス ポリシーを適用する必要があります。 インターフェイスに直接適用されるサービス ポリシーを付けてマップ クラスを設定しようとすると、logging console がイネーブルにされているルータでは、次のメッセージが報告されます。

 Frame Relay fragmentation works with dTS only. 
 Please remove traffic-shaping from the interface serial 1/0/0
 

このセクションでの設定コマンドおよび設定検証コマンドは、RSP 8 で Cisco IOS ソフトウェア リリース 12.2(5)T が稼働する Cisco 7500 シリーズ ルータでテスト済みです。

注:フラグメンテーション値の選択に関する詳細情報は、『QOS(フラグメンテーション、トラフィック シェーピング、LLQ/IP RTP プライオリティ)を使用した VoIP over Frame Relay』を参照してください。

DTS および FRF.12 の設定例
interface Ethernet4/1/3 
 ip address 10.122.3.206 255.255.255.0 
! 
interface Serial5/0/0:0 
 no ip address 
 encapsulation frame-relay 
 load-interval 30 
 no fair-queue 

!--- frame-relay traffic-shaping を設定しないでください。

! 
interface Serial5/0/0:0.1 point-to-point 
 ip address 10.1.1.2 255.255.255.0 
 frame-relay interface-dlci 16  
 class test 
 frame-relay ip rtp header-compression 
! 
map-class frame-relay test 
 no frame-relay adaptive-shaping 
 service-policy output llq-shape 
 frame-relay fragment 120 

!--- フレームリレーのマップ クラスに、
!--- frame-relay fragment コマンドを適用します。

 access-list 101 permit udp any range 16384 32767 any  range 16384 32767
MS-7507-8A# show ip rtp head 
RTP/UDP/IP header compression statistics: 
DLCI 16 Link/Destination info: point-to-point dlci 
Interface Serial5/0/0:0: 
Distributed fast switched: 
4 seconds since line card sent last stats update 
Rcvd: 105475 total, 105472 compressed, 0 errors 
0 dropped, 0 buffer copies, 0 buffer failures 
Sent: 99451 total, 99447 compressed,  
3776208 bytes saved, 2187963 bytes sent 
2.72 efficiency improvement factor 
Connect: 256 rx slots, 256 tx slots,  
0 long searches, 3 misses 0 collisions, 0 negative cache hits 
99% hit ratio, five minute miss rate 0 misses/sec, 0 max 
MS-7507-8A# show policy-map Policy Map llq-shape Class class-default shape peak 256000 1024 1024 service-policy llq Policy Map llq Class voip priority percent 50
MS-7507-8A# show policy-map interface s 5/0/0:0.1 Serial5/0/0:0.1: DLCI 16 - Service-policy output: llq-shape queue stats for all priority classes: queue size 0, queue limit 32 packets output 147008, packet drops 0 tail/random drops 0, no buffer drops 0, other drops 0 Class-map: class-default (match-any) 148237 packets, 10393582 bytes 30 second offered rate 24000 bps, drop rate 0 bps Match: any queue size 0, queue limit 64 packets output 149563, packet drops 0 tail/random drops 0, no buffer drops 0, other drops 0 Shape: cir 256000, Bc 1024, Be 1024 lower bound cir 0, adapt to fecn 0 output bytes 6972057, shape rate 10000 bps Service-policy : llq Class-map: voip (match-all) 146701 packets, 10325334 bytes 30 second offered rate 24000 bps, drop rate 0 bps Match: access-group 101 Priority: 50% (128 kbps), burst bytes 3200, b/w exceed drops: 0 Class-map: class-default (match-any) 1536 packets, 68248 bytes 30 second offered rate 0 bps, drop rate 0 bps Match: any queue size 0, queue limit 32 packets output 2555, packet drops 0 tail/random drops 0, no buffer drops 0, other drops 0
MS-7507-8A# show frame pvc 16 PVC Statistics for interface Serial5/0/0:0 (Frame Relay DTE) LCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial5/0/0:0.1 input pkts 3036327 output pkts 199453 in bytes 198958363 out bytes 17271661 dropped pkts 0 in FECN pkts 0 in BECN pkts 0 out FECN pkts 0 out BECN pkts 0 in DE pkts 0 out DE pkts 0 out bcast pkts 1071 out bcast bytes 371448 5 minute input rate 0 bits/sec, 0 packets/sec 5 minute output rate 35000 bits/sec, 50 packets/sec pvc create time 17:51:42, last time pvc status changed 17:50:53 fragment type end-to-end fragment size 120
MS-7507-8A# show interface shape Serial5/0/0:0 nobuffer drop 0 Serial5/0/0:0.1(class 0): cir 256000, Bc 1024, Be 1024 lower bound cir 0, adapt to fecn 0 packets output 152104, bytes output 6985505 queue limit 64, queue size 0, drops 0 last clear = 16:58:59 ago, shape rate = 10000 bps
MS-7507-8A# show ip rtp head RTP/UDP/IP header compression statistics: DLCI 16 Link/Destination info: point-to-point dlci Interface Serial5/0/0:0: Distributed fast switched: 4 seconds since line card sent last stats update Rcvd: 105475 total, 105472 compressed, 0 errors 0 dropped, 0 buffer copies, 0 buffer failures Sent: 99451 total, 99447 compressed, 3776208 bytes saved, 2187963 bytes sent 2.72 efficiency improvement factor Connect: 256 rx slots, 256 tx slots, 0 long searches, 3 misses 0 collisions, 0 negative cache hits 99% hit ratio, five minute miss rate 0 misses/sec, 0 max
MS-7507-8A# show policy-map Policy Map llq-shape Class class-default shape peak 256000 1024 1024 service-policy llq Policy Map llq Class voip priority percent 50
MS-7507-8A# show policy-map interface s 5/0/0:0.1 Serial5/0/0:0.1: DLCI 16 - Service-policy output: llq-shape queue stats for all priority classes: queue size 0, queue limit 32 packets output 147008, packet drops 0 tail/random drops 0, no buffer drops 0, other drops 0 Class-map: class-default (match-any) 148237 packets, 10393582 bytes 30 second offered rate 24000 bps, drop rate 0 bps Match: any queue size 0, queue limit 64 packets output 149563, packet drops 0 tail/random drops 0, no buffer drops 0, other drops 0 Shape: cir 256000, Bc 1024, Be 1024 lower bound cir 0, adapt to fecn 0 output bytes 6972057, shape rate 10000 bps Service-policy : llq Class-map: voip (match-all) 146701 packets, 10325334 bytes 30 second offered rate 24000 bps, drop rate 0 bps Match: access-group 101 Priority: 50% (128 kbps), burst bytes 3200, b/w exceed drops: 0 Class-map: class-default (match-any) 1536 packets, 68248 bytes 30 second offered rate 0 bps, drop rate 0 bps Match: any queue size 0, queue limit 32 packets output 2555, packet drops 0 tail/random drops 0, no buffer drops 0, other drops 0
MS-7507-8A# show frame pvc 16 PVC Statistics for interface Serial5/0/0:0 (Frame Relay DTE) DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial5/0/0:0.1 input pkts 3036327 output pkts 199453 in bytes 198958363 out bytes 17271661 dropped pkts 0 in FECN pkts 0 in BECN pkts 0 out FECN pkts 0 out BECN pkts 0 in DE pkts 0 out DE pkts 0 out bcast pkts 1071 out bcast bytes 371448 5 minute input rate 0 bits/sec, 0 packets/sec 5 minute output rate 35000 bits/sec, 50 packets/sec pvc create time 17:51:42, last time pvc status changed 17:50:53 fragment type end-to-end fragment size 120
MS-7507-8A# show interface shape Serial5/0/0:0 nobuffer drop 0 Serial5/0/0:0.1(class 0): cir 256000, Bc 1024, Be 1024 lower bound cir 0, adapt to fecn 0 packets output 152104, bytes output 6985505 queue limit 64, queue size 0, drops 0 last clear = 16:58:59 ago, shape rate = 10000 bps

既知の問題

Cisco IOS ソフトウェア リリース 12.1E を使用している場合、フレームリレー カプセル化が設定されている VIP インターフェイスが、バス エラーでクラッシュする可能性があります。 このクラッシュは、サービス ポリシーを適用している場合に、インターフェイスをトラフィックが通過する際に発生します。 回避策としては、サービス ポリシーをアップデートする前に、バックグラウンドのトラフィックをすべて停止する方法があります。 あるいは、Cisco IOS ソフトウェア リリース 12.2 以降にアップデートすることもできます。

詳細情報は、『e-Support ツール』のページを参照してください。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報