ロング リーチ イーサネット(LRE)とデジタル加入者線(xDSL) : 非対称デジタル加入者線(ADSL)

Cisco 7200 Broadband Aggregation のコンフィギュレーション例

2005 年 6 月 1 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 8 月 9 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
設定
      PPPoA セッションの終了: xDSL から 7200 への接続
      RFC 1483 ブリッジング: xDSL から 7200 への接続
      RBE: xDSL から 7200 への接続
      PPPoE: xDSL から 7200 への接続
      L2TP: L2TP による xDSL から 7200 への接続
確認
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントには、Digital Subscriber Line(DSL; デジタル加入者線)のコンポーネントに関する一般的な説明、および DSL コンポーネントを基本的な DSL の実装に構成する方法についての説明があります。 このドキュメントの設定例では、現在使用されている最も一般的な DSL ネットワークが示されています。 これらの設定は、ブロードバンド集約の実装を設計する際の一般的なリファレンスとして使用できます。 ただし、この設定を定型のソリューションとして捉えないでください。 お客様ごとに要求事項も異なるため、同じ設計目標を実現するにも数多くの方法があります。

このドキュメントに示した設定はできるだけ完全な状態になっていますが、表示されているのは必須の行だけです。 このドキュメントでは、Cisco デバイスの設定に関してユーザが基本的な知識を持っていることを前提としています。そのため、基本的なコマンドラインはほとんど省略されています。 下記の設定は、単に実装設計の出発点として使用してください。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細については、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションでは、このドキュメントに記載されている機能を設定するための情報を示します。

注:このドキュメントで使用されているコマンドに関する詳細情報を見つけるには、Command Lookup Tool登録ユーザ専用)を使用してください。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

PPPoA セッションの終了: xDSL から 7200 への接続

ネットワーク ダイアグラム

このセクションでは、次のネットワーク設定を使用します。

7200_bdaggreg1.gif

設定例

この例では、PPP over ATM(PPPoA)によって、Cisco 677 またはその他の DSL Customer Premises Equipment(CPE; 顧客宅内機器)を Cisco 7200 に接続する方法を説明します。 設定には、Cisco Lightstream 1010(LS1010)ATM スイッチが含まれていますが、このコンポーネントはオプションです。 DSL Access Multiplier(DSLAM)が直接 Cisco 7200 に接続されていても、結果は同じになります。

この例では、PPP セッションはまず Cisco 677 で確立され、Cisco 7200 で終了されています。セッションが終了すると、従来の IP で、Network Service Provider(NSP; ネットワーク サービス プロバイダー)やインターネットにトラフィックが伝送されます。

CPE は、Network Address Translation(NAT; ネットワーク アドレス変換)や Port Address Translation(PAT; ポート アドレス変換)を行うように設定されています。 CPE には DHCP サーバも実装されており、イーサネット ステーションに IP アドレスを割り当てています。

このセクションでは、次の設定を使用します。

PPPoA に対する PC の設定
  1. 自動的に IP アドレスを取得するように、IP アドレッシングを設定します。

  2. WINS を設定して、WINS の解決に DHCP を使用するようにします。

  3. デフォルトのゲートウェイが設定されていないことを確認します。

注:DHCP がこの情報を渡せられない場合は、ドメイン名を設定する必要があります。


PPPoA に対する Cisco CPE の設定
 cbos> enable
 Password:
cbos# set nat enable NAT is now enabled You must use "write" then reboot for changes to take effect.
cbos# set ppp wan0-0 login User name for wan0-0 has been set to testcpe.
cbos# set ppp wan0-0 password Password for wan0-0 has been set to cisco.
cbos# set ppp wan0-0 ipcp 0.0.0.0 PPP wan0-0 IPCP Address set to 0.0.0.0
cbos# set int wan0-0 close cbos# set int wan0-0 vpi 1
cbos# set int wan0-0 vci 32
cbos# set int wan0-0 open
cbos# set int eth0 address 172.22.10.254 eth0 ip address changed from 10.0.0.1 to 172.22.10.254
cbos# set int eth0 netmask 255.255.255.0 eth0 netmask changed from 255.255.255.0 to 255.255.255.0
cbos# set dhcp server enable DHCP Server enabled
cbos# set dhcp server pool 0 ip 172.22.10.0 Pool 0 IP parameter is now 172.22.10.0
cbos# set dhcp server pool 0 netmask 255.255.255.0 Pool 0 netmask parameter is now 255.255.255.0
cbos# set dhcp server pool 0 gateway 172.22.10.254 Pool 0 gateway parameter is now 172.22.10.254
cbos# set password exec Exec Password Change Successful!
cbos# set password enable Enable Password Change Successful!
cbos# write NVRAM written.

PPPoA に対する Cisco DSLAM の設定
 hostname 6260
 ! Subtending Port - Will set as shutdown
 interface atm0/2
  shutdown
 slot 1 atuc-1-4dmt
 !
 dsl-profile fast
  dmt codeword-size downstream 16 upstream 16
  dmt bitrate maximum interleaved downstream 8032 upstream 832
 !
 interface atm1/1
  dsl profile fast
  atm pvc 1 32 interface atm0/1 1 35
 

PPPoA に対する Cisco LS1010 の設定
 interface ATM 0/1/2
  no ip address
  no ip directed-broadcast
  no ATM ilmi-keepalive
  ATM pvp 1 interface ATM 0/0/2 1
 

PPPoA に対する Cisco 7200 の設定
 aaa new-model
 AAA authentication ppp default local
 !
 !
 username password
 !
 !
 interface ATM 2/0.1 multipoint
  no ip directed-broadcast
  PVC 1/35
   encapsulation aal5mux ppp Virtual-Template 2
 !
 !
 interface FastEthernet 4/0
  ip address 172.22.32.1 255.255.255.0
  no ip directed-broadcast
 !
 !
 interface Virtual-Template 2
  ip unnumbered FastEthernet 4/0
  no ip directed-broadcast
  peer default ip address pool <pool name>
  ppp authentication pap
 !
 !
 ip local pool <pool name> 172.22.40.10 172.22.40.25
 

RFC 1483 ブリッジング: xDSL から 7200 への接続

ネットワーク ダイアグラム

このセクションでは、次のネットワーク設定を使用します。

7200_bdaggreg2.gif

設定例

この例では、RFC1483 Bridged Encapsulation によって、Cisco 677 またはその他の DSL CPE を Cisco 7200 に接続する方法を説明します。 設定には、Cisco LS1010 ATM スイッチが含まれていますが、このコンポーネントはオプションです。 DSLAM が直接、Cisco 7200 に接続されていても、結果は同じになります。

この例では、ブリッジされたセッションが Cisco 677 にまず確立され、Cisco 7200 で終了しています。セッションが Cisco 7200 にブリッジされると、従来の IP で NSP やインターネットにトラフィックが伝送されます。 Cisco 7200 で設定された DHCP サーバによって、IP アドレスがクライアント ワークステーションに割り当てられます。

この設定では、Integrated Routing and Bridging(IRB; 統合ルーティングおよびブリッジング)を使用しています。 IRB に関するスケーラビリティとセキュリティの問題を緩和するには、Routed Bridged Encapsulation(RBE)を考慮する必要があります。

このセクションでは、次の設定を使用します。

RFC 1483 に対する PC の設定
  1. 自動的に IP アドレスを取得するように、IP アドレッシングを設定します。

  2. WINS を設定して、WINS の解決に DHCP を使用するようにします。

  3. デフォルトのゲートウェイが設定されていないことを確認します。

注:DHCP がこの情報を渡せられない場合は、ドメイン名を設定する必要があります。


RFC 1483 に対する Cisco 677 CPE の設定
 cbos# set bridging rfc1483 enabled

 !--- write を使用し、変更が有効になるように再起動します。

 cbos# set bridging management enable
cbos# set int eth0 address 172.22.40.25 !--- この IP アドレスは、管理目的だけに使用します。 cbos# set int wan0-0 close cbos# set int wan0-0 vpi 1
cbos# set int wan0-0 vci 32
cbos# set int wan0-0 open
cbos# write NVRAM written.
cbos# reboot

RFC 1483 に対する Cisco DSLAM の設定
 hostname 6260
 ! Subtending Port - Will set as shutdown
 interface atm0/2
  shutdown
 slot 1 atuc-1-4dmt
 !
 dsl-profile fast
  dmt codeword-size downstream 16 upstream 16
  dmt bitrate maximum interleaved downstream 8032 upstream 832
 !
 interface atm1/1
  dsl profile fast
  ATM PVC 1 32 interface atm0/1 1 35
 

RFC 1483 に対する Cisco LS1010 の設定
 interface ATM 0/1/2
  no ip address
  no ip directed-broadcast
  no ATM ilmi-keepalive
  ATM pvp 1 interface ATM 0/0/2 1
 

RFC 1483 に対する Cisco 7200 の設定
 ip dhcp excluded-address 172.22.40.1 172.22.40.25
 !
 !
 ip dhcp pool 0
    network 172.22.40.0 255.255.255.0
    default-router 172.22.40.9
    dns-server
    netbios-name-server
 !
 !
 bridge irb
 !
 !
 interface ATM 2/0
  no ip address
  no ip directed-broadcast
  no ATM ilmi-keepalive
 !
 !
 interface ATM 2/0.1 point-to-point
  no ip directed-broadcast
  PVC 1/35
   encapsulation aal5snap
  bridge-group 1
 !
 !
 interface ATM 2/0.2 point-to-point
  no ip directed-broadcast
  PVC 1/36
   encapsulation aal5snap
  bridge-group 1!
 !
 interface FastEthernet 4/0
  ip address 172.22.32.1 255.255.255.0
  no ip directed-broadcast
 !
 !
 interface BVI 1
  ip address 172.22.40.9 255.255.255.0
  no ip directed-broadcast
 !
 !
 bridge 1 protocol ieee
  bridge 1 route ip
 

RBE: xDSL から 7200 への接続

ネットワーク ダイアグラム

このセクションでは、次のネットワーク設定を使用します。

7200_bdaggreg2.gif

設定例

新しい DSL を設置する場合、現在では通常、RBE が設定の対象として選択されます。 RBE が、ブロードバンドの加入者環境において、ブリッジングのセキュリティやスケーラビリティの問題に対応しているためです。

Cisco 7200 で設定された DHCP サーバによって、IP アドレスがクライアント ワークステーションに割り当てられます。

重要: Cisco IOS(R) ソフトウェア リリース 12.1(2)T 以降が使用されている場合以外、非番号 ATM では、ルータで DHCP は動作できません。

このセクションでは、次の設定を使用します。

RBE に対する PC の設定
  1. 自動的に IP アドレスを取得するように、IP アドレッシングを設定します。

  2. WINS を設定して、WINS の解決に DHCP を使用します。

  3. デフォルトのゲートウェイが設定されていないことを確認します。

注:DHCP がこの情報を渡せられない場合は、ドメイン名を設定する必要があります。


RBE に対する Cisco CPE の設定
 cbos# set bridging rfc1483 enabled

 !--- write を使用し、変更が有効になるように再起動します。
 

 cbos# set bridging management enable
 
 cbos# set int eth0 address 172.22.40.25

 !--- この IP アドレスは、管理目的だけに使用します。

 cbos# set int wan0-0 close
 cbos# set int wan0-0 vpi 1
cbos# set int wan0-0 vci 32
cbos# set int wan0-0 open
cbos# write NVRAM written.
cbos# reboot

RBE に対する Cisco DSLAM の設定
 hostname 6260
 ! Subtending Port - Will set as shutdown
 interface atm0/2
  shutdown
 slot 1 atuc-1-4dmt
 !
 dsl-profile fast
  dmt codeword-size downstream 16 upstream 16
  dmt bitrate maximum interleaved downstream 8032 upstream 832
 !
 interface atm1/1
  dsl profile fast
  ATM PVC 1 32 interface atm0/1 1 35
 

RBE に対する Cisco LS1010 の設定
 interface ATM 0/1/2
  no ip address
  no ip directed-broadcast
  no ATM ilmi-keepalive
  ATM pvp 1 interface ATM 0/0/2 1
 

RBE に対する Cisco 7200 の設定
 ip dhcp excluded-address 172.22.40.1 172.22.40.25
 !
 !
 ip dhcp pool 0
    network 172.22.40.0 255.255.255.0
    default-router 172.22.40.9
    dns-server
    netbios-name-server
 !
 !
 interface Loopback0
  ip address 172.22.40.9 255.255.255.0
 !
 !
 interface ATM 2/0
  no ip address
  no ip directed-broadcast
  no ATM ilmi-keepalive
 !
 !
 interface ATM 2/0.1 point-to-point
  ip unnumbered Loopback0
  no ip directed-broadcast
  ATM route-bridged ip
  PVC 1/35
   encapsulation aal5snap
 !
 !
 interface ATM 2/0.2 point-to-point
  ip unnumbered Loopback0
  no ip directed-broadcast
  ATM route-bridged ip
  PVC 1/36
   encapsulation aal5snap
 !
 !
 interface FastEthernet 4/0
  ip address 172.22.32.1 255.255.255.0
  no ip directed-broadcast
 !
 !
 

PPPoE: xDSL から 7200 への接続

ネットワーク ダイアグラム

このセクションでは、次のネットワーク設定を使用します。

7200_bdaggreg3.gif

設定例

PPP over Ethernet(PPPoE)によって、PPP セッションはルータからエンド クライアントまで延長されます。 PPP と認証ソフトウェアは、通常、クライアントのオペレーティング システムまたはスタンドアロン アプリケーションで動作します。 ブリッジ モードの場合、CPE は DSL 接続上で PPP セッションにブリッジするように動作しますが、このシナリオでは DHCP サーバとして動作できません。

CPE、DSLAM、および ATM スイッチの設定は、RFC1483 ブリッジングの設定と同じです。 この例で示すとおり、Cisco 7200 集約ルータはローカル認証用に設定できます。 または、Cisco 7200 を Authentication, Authorization, and Accounting(AAA; 認証、認可、アカウンティング)RADIUS 認証用に設定することも可能です。

このセクションでは、次の設定を使用します。

PPPoE に対する PC の設定
  1. 自動的に IP アドレスを取得するように、IP アドレッシングを設定します。

  2. WINS を設定して、WINS の解決に DHCP を使用します。

  3. デフォルトのゲートウェイが設定されていないことを確認します。

注:DHCP がこの情報を渡せられない場合は、ドメイン名を設定する必要があります。

注:端末では、ルータへの PPP 接続を確立できる必要があります。 そのためには、認証およびアクセス用に特別のクライアント ソフトウェアが必要になる場合があります。


PPPoE に対する Cisco 677 CPE の設定
 cbos# set bridging rfc1483 enabled

 !--- write を使用し、変更が有効になるように再起動します。

 cbos# set bridging management enable
cbos# set int eth0 address 172.22.40.25 !--- この IP アドレスは、管理目的だけに使用します。 cbos# set int wan0-0 close cbos# set int wan0-0 vpi 1
cbos# set int wan0-0 vci 32
cbos# set int wan0-0 open
cbos# write NVRAM written.
cbos# reboot

PPPoE に対する Cisco DSLAM の設定
 hostname 6260
 ! Subtending Port - Will set as shutdown
 interface atm0/2
  shutdown
 slot 1 atuc-1-4dmt
 !
 dsl-profile fast
  dmt codeword-size downstream 16 upstream 16
  dmt bitrate maximum interleaved downstream 8032 upstream 832
 !
 interface atm1/1
  dsl profile fast
  ATM PVC 1 32 interface atm0/1 1 35
 

PPPoE に対する Cisco LS1010 の設定
 interface ATM 0/1/2
  no ip address
  no ip directed-broadcast
  no ATM ilmi-keepalive
  ATM pvp 1 interface ATM 0/0/2 1
 

PPPoE に対する Cisco 7200 の設定
 !
 username <username> password <password>
 !
 vpdn enable
 !
 vpdn-group 1
  accept-dialin
   protocol pppoe
   virtual-template 1
   pppoe limit per-mac 100
   pppoe limit per-vc 100
 !
 ip cef
 !
 interface atm2/0
  no ip address
  no ip directed-broadcast
  no ATM ilmi-keepalive
 !
 !
 interface ATM 2/0.1 point-to-point
  no ip directed-broadcast
  PVC 1/35
   encapsulation aal5snap
   protocol pppoe
 !
 !
 interface ATM 2/0.2 point-to-point
  no ip directed-broadcast
  PVC 1/36
   encapsulation aal5snap
   protocol pppoe
 !
 interface Virtual-Template1
  ip unnumbered FastEthernet 4/0
  no ip directed-broadcast
  peer default ip address pool <pool name>
  ppp authentication pap
 !
 interface FastEthernet 4/0
  ip address 172.22.32.1 255.255.255.0
  no ip directed-broadcast
 !
 ip local pool <pool name> 172.22.32.20 172.22.32.100
 

L2TP: L2TP による xDSL から 7200 への接続

ネットワーク ダイアグラム

このセクションでは、次のネットワーク設定を使用します。

7200_bdaggreg4.gif

設定例

Layer Two Tunneling Protocol(L2TP)を使用すると、ある場所でエンド ユーザからの PPP 接続を終端し、L2 のデータ パケットを別の場所に転送できます。 L2TP によって集約デバイスの IP 機能が大幅に軽減され、より中央集中型のネットワーク設計が可能になります。 RADIUS サーバは AAA を提供します。

Cisco 7200 以外のすべてのデバイスの設定は、RFC1483 の例での設定と同じです。

このセクションでは、次の設定を使用します。

L2TP に対する PC の設定
  1. 自動的に IP アドレスを取得するように、IP アドレッシングを設定します。

  2. WINS を設定して、WINS の解決に DHCP を使用します。

  3. デフォルトのゲートウェイが設定されていないことを確認します。

注:DHCP がこの情報を渡せられない場合は、ドメイン名を設定する必要があります。


L2TP に対する Cisco 677 CPE の設定
 cbos> enable
 Password:
cbos# set nat enable NAT is now enabled You must use "write" then reboot for changes to take effect.
cbos# set ppp wan0-0 login User name for wan0-0 has been set to testcpe.
cbos# set ppp wan0-0 password Password for wan0-0 has been set to cisco.
cbos# set ppp wan0-0 ipcp 0.0.0.0 PPP wan0-0 IPCP Address set to 0.0.0.0
cbos# set int wan0-0 close cbos# set int wan0-0 vpi 1
cbos# set int wan0-0 vci 32
cbos# set int wan0-0 open
cbos# set int eth0 address 172.22.10.254 eth0 ip address changed from 10.0.0.1 to 172.22.10.254
cbos# set int eth0 netmask 255.255.255.0 eth0 netmask changed from 255.255.255.0 to 255.255.255.0
cbos# set dhcp server enable DHCP Server enabled
cbos# set dhcp server pool 0 ip 172.22.10.0 Pool 0 IP parameter is now 172.22.10.0
cbos# set dhcp server pool 0 netmask 255.255.255.0 Pool 0 netmask parameter is now 255.255.255.0
cbos# set dhcp server pool 0 gateway 172.22.10.254 Pool 0 gateway parameter is now 172.22.10.254
cbos# set password exec Exec Password Change Successful!
cbos# set password enable Enable Password Change Successful!
cbos# write NVRAM written.

L2TP に対する Cisco DSLAM の設定
 hostname 6260
 ! Subtending Port - Will set as shutdown
 interface atm0/2
  shutdown
 slot 1 atuc-1-4dmt
 !
 dsl-profile fast
  dmt codeword-size downstream 16 upstream 16
  dmt bitrate maximum interleaved downstream 8032 upstream 832
 !
 interface atm1/1
  dsl profile fast
  ATM PVC 1 32 interface atm0/1 1 35
 
L2TP に対する Cisco LS1010 の設定
 interface ATM 0/1/2
  no ip address
  no ip directed-broadcast
  no ATM ilmi-keepalive
  ATM pvp 1 interface ATM 0/0/2 1
 

L2TP に対する Cisco 7200 LAC の設定
 !
 AAA new-model
 AAA authentication login default none
 AAA authentication ppp default local group radius
 AAA authorization network default local group radius none
 AAA accounting network default wait-start group radius
 !
 vpdn-group 4
  request-dialin
   protocol l2tp
   domain cisco.com
  initiate-to ip 172.22.32.27 priority 1
  local name cisco-tunnel
 !
 interface ATM 2/0
  no ip address
  no ip directed-broadcast
  no ATM ilmi-keepalive
 !
 !
 interface ATM 2/0.1 point-to-point
  no ip directed-broadcast
  PVC 1/35
   encapsulation aal5mux ppp Virtual-Template1
 !
 !
 interface ATM 2/0.2 point-to-point
  no ip directed-broadcast
  PVC 1/36
   encapsulation aal5mux ppp Virtual-Template1
 !
 !
 interface FastEthernet 4/0
  ip address 172.22.32.1 255.255.255.0
  no ip directed-broadcast
 !
 !
 interface Virtual-Template1
  ip unnumbered FastEthernet4/0
  no ip directed-broadcast
  ppp authentication pap
 !
 !
 radius-server host 172.22.32.20 auth-port 1645 acct-port 1646
 radius-server key cisco
 

L2TP に対する Cisco 7200 LNS の設定
 !
 AAA new-model
 AAA authentication login default none
 AAA authentication ppp default local group radius
 AAA authorization network default local group radius none
 AAA accounting network default wait-start group radius
 !
 vpdn-group 1
  accept-dialin
   protocol any
   virtual-template 1
  terminate-from hostname cisco-tunnel
  local name tunnel-gate
 !
 radius-server host 172.22.32.20 auth-port 1645 acct-port 1646
 radius-server key cisco
 

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

現在、この設定に関する特定のトラブルシューティング情報はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報