アプリケーション ネットワーキング サービス : Cisco 500 シリーズ キャッシュ エンジン

WCCP を使用した透過キャッシングのための Cache Engine の設定方法

2004 年 8 月 18 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 7 月 26 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
設定
      ネットワーク ダイアグラム
      設定例
確認
      Cache Engine の debug コマンドと show コマンド
      ルータの debug コマンドと show コマンド
      コマンドの概要
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、Web Cache Coordination Protocol(WCCP)を使用して透過キャッシングを行う際の Cisco Cache Engine の設定方法について説明します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco Cache Engine 560

  • Cisco Application and Content Networking System ソフトウェア(ACNS)リリース 5.1

  • Cisco IOS(R) ソフトウェア リリース 12.2(17) が稼働している Cisco 3600 ルータ

このドキュメントの情報は、特定のラボ環境にあるデバイスを使用して作成されたものです。このドキュメント内で使用されているデバイスではすべて、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼動中である場合には、すべてのコマンドによる潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションでは、このドキュメントで説明する機能を設定するために必要な情報を提供します。

注:このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

このドキュメントでは、次のネットワーク構成を使用しています。

transparentconfig.jpg

設定例

このドキュメントでは、次の設定を使用します。

  • Cache / Content Engine

  • ルータ

Cache / Content Engine
 ce-560# wr t
 ! ACNS version 5.1.9
 !
 hostname ce560
 !
 ip domain-name cisco.com
 !
 interface FastEthernet 0/0
  ip address 10.0.0.2 255.255.255.0
  exit
 interface FastEthernet 0/1
  shutdown
  exit
 !
 ip default-gateway 10.0.0.1
 !
 primary-interface FastEthernet 0/0
 !
 ip name-server 10.66.86.18
 !
 wccp router-list 1 10.0.0.1
 wccp web-cache router-list-num 1
 wccp version 2
 !
 transaction-logs enable
 !
 username admin password 1 bVmDmMMmZAPjY
 username admin privilege 15
 !
 authentication login local enable primary
 authentication configuration local enable primary
 !
 ! End of ACNS configuration
 

ルータ
 c3640#wr t
 Building configuration...
 Current configuration : 1905 bytes
 !
 ! NVRAM config last updated at 11:30:04 AEST Wed Aug 4 2004
 !
 version 12.2
 no service password-encryption
 !
 hostname c3640
 !
 enable password cisco
 !
 clock timezone AEST 10
 ip subnet-zero
 ip wccp web-cache
 ip cef
 !
 interface Ethernet0/0
  ip address 10.1.0.1 255.255.255.0
  ip wccp web-cache redirect in
  full-duplex
 !
 interface Ethernet0/1
  ip address 10.0.0.1 255.255.255.0
 full-duplex
 !
 ip classless
 ip route 0.0.0.0 0.0.0.0 10.0.0.254
 !
 line con 0
 line aux 0
 line vty 0 4
  password cisco
  login
 !
 end
 

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を示します。

注:debug コマンドを使用する前に、『デバッグ コマンドの重要な情報』を参照してください。

Cache Engine の debug コマンドと show コマンド

  • show wccp cache— WCCP キャッシュ エンジンの情報を表示します。

  • show wccp flows— WCCP パケット フローを表示します。

  • show wccp routers — WCCP ルータ リストを表示します。

  • show wccp services — 設定されている WCCP サービスを表示します。

  • show wccp slowstart — WCCP スロースタートを表示します。

  • show wccp status — WCCP 動作ステータスを表示します。

  • show statistics http savings — HTTP の節約率の統計情報を表示します。

  • debug wccp all — WCCP に対するすべてのデバッグを有効にします。

  • debug wccp events — WCCP イベントをデバッグします。

  • debug wccp packets — WCCP パケットに関連する情報をデバッグします。

ルータの debug コマンドと show コマンド

  • show ip wccp web-cache detail — 特定のサービス グループに対するキャッシュ エンジンと WCCP ルータの統計情報を表示します。

  • show ip wccp web-cache view — サービス グループのビュー情報を表示します。

  • debug ip wccp events — WCCP イベントをデバッグします。

  • debug ip wccp packets — WCCP パケットに関連する情報をデバッグします。

コマンドの概要

この設定では、次のキャッシュ エンジンのコマンドが使用されています。

  • wccp version {1 | 2}

  • wccp router-list number ip-address

  • wccp web-cache router-list-num number

この設定では、次のルータのコマンドが使用されています。

  • ip wccp {web-cache | service-number}

  • ip wccp {web-cache | service-number} redirect out

トラブルシューティング

現時点では、この設定に対して使用可能な特定のトラブルシューティング情報はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報