IP : IP ルーティング

OSPF エリア間ルーティング

2005 年 3 月 28 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 3 月 28 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
設定
      ネットワーク ダイアグラム
      設定
確認
      OSPF データベースの検査
      最短パスの計算
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、Open Shortest Path First(OSPF)が 2 つのエリアにまたがって動作している場合の、OSPF データベースとルーティング テーブルについて説明します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションでは、このドキュメントで説明する機能を設定するために必要な情報を提供します。

注:このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

このドキュメントでは次の図に示すネットワーク設定を使用しています。

ospfdb5a.gif

設定

このドキュメントでは、次の設定を使用します。

ルータ 1.1.1.1
 Current configuration:
hostname r1.1.1.1
interface Loopback0 ip address 1.1.1.1 255.0.0.0
interface Ethernet2/0/0 ip address 4.0.0.1 255.0.0.0
interface Serial2/1/0 ip unnumbered Ethernet2/0/0
router ospf 1 network 4.0.0.0 0.255.255.255 area 0
end
ルータ 2.2.2.2
 Current configuration:
hostname r2.2.2.2
interface Loopback0 ip address 2.2.2.2 255.0.0.0
interface Ethernet0/0/4 ip address 6.0.0.2 255.0.0.0
interface Serial0/1/0 ip unnumbered Ethernet0/0/4
interface ATM1/0.20 point-to-point ip address 200.0.0.2 255.255.255.0
router ospf 2 network 6.0.0.0 0.255.255.255 area 0 network 200.0.0.0 0.255.255.255 area 1
end
ルータ 3.3.3.3
 Current configuration:
hostname r3.3.3.3
interface Loopback0 ip address 3.3.3.3 255.0.0.0
interface ATM2/0.20 point-to-point ip address 200.0.0.3 255.255.255.0
router ospf 2 network 200.0.0.0 0.255.255.255 area 1
end

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を示します。

特定の show コマンドは、アウトプットインタープリタ登録ユーザ専用)でサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

  • show ip ospf database — リンク ステート データベース内にある Link State Advertisement(LSA; リンクステート アドバタイズメント)のリストを表示します。 このリストでは、LSA ヘッダーの情報だけが表示されます。

  • show ip ospf database [router] [link-state-id] — データベース内のルータ LSA(タイプ 1 LSA)の内容を表示します。 ルータの LSA は各ルータで作成され、これらの基本となる LSA には、全ルータのリンクまたはインターフェイスと、そのリンクの状態や発信コストが一覧されています。 これらは、生成されたエリア内でだけフラッディングされます。

  • show ip ospf database summary <link-state id> — Area Border Router(ABR; エリア境界ルータ)の集約リンクを表示します。

OSPF データベースの検査

ルータ 2.2.2.2 は ABR であるため、接続されている両方のエリアに対するデータベースを保持しています。 したがって、show ip ospf database コマンドを使用して OSPF データベースを確認するために最適な場所がこのルータです。

 r2.2.2.2#show ip ospf database
OSPF Router with ID (2.2.2.2) (Process ID 2)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count 1.1.1.1 1.1.1.1 697 0x80000040 0x5A21 2 2.2.2.2 2.2.2.2 696 0x80000045 0xEE82 2
Summary Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum 200.0.0.0 2.2.2.2 352 0x80000001 0x2546
Router Link States (Area 1)
Link ID ADV Router Age Seq# Checksum Link count 2.2.2.2 2.2.2.2 351 0x8000000B 0xCA9D 2 3.3.3.3 3.3.3.3 354 0x80000006 0x71F7 2
Summary Net Link States (Area 1)
Link ID ADV Router Age Seq# Checksum 4.0.0.0 2.2.2.2 689 0x80000001 0xFFE6 6.0.0.0 2.2.2.2 700 0x80000001 0x63C1
r2.2.2.2#show ip ospf database router 1.1.1.1
OSPF Router with ID (2.2.2.2) (Process ID 2)
Router Link States (Area 0)
LS age: 773 Options: (No TOS-capability, DC) LS Type: Router Links Link State ID: 1.1.1.1 !--- ルータ リンクの Link State ID は常に !--- Advertising Router(次の行)と同じです。 Advertising Router: 1.1.1.1 !--- これは、この LSA を作成したルータのルータ ID です。 LS Seq Number: 80000040 Checksum: 0x5A21 Length: 48 Number of Links: 2
Link connected to: another Router (point-to-point) !--- この行は、ルータ 1.1.1.1 がルータ 2.2.2.2 の !--- ネイバーであることを示しています。 (Link ID) Neighboring Router ID: 2.2.2.2 (Link Data) Router Interface address: 0.0.0.12 !--- リンクが番号なしであるため、アドレスはゼロから !--- 始まります。 番号なしリンクの場合、インターフェイス アドレスには !--- MIB II IfIndex の値が表示されます。通常、この値は 0 で始まります。 Number of TOS metrics: 0 TOS 0 Metrics: 64 !--- これは 2 台のルータを接続するリンクの !--- OSPF コストです。 Link connected to: a Stub Network !--- この回線はイーサネット セグメント 4.0.0.0/8 を表しています。 (Link ID) Network/subnet number: 4.0.0.0 (Link Data) Network Mask: 255.0.0.0 Number of TOS metrics: 0 TOS 0 Metrics: 10
r2.2.2.2#show ip ospf database router 2.2.2.2
OSPF Router with ID (2.2.2.2) (Process ID 2)
Router Link States (Area 0) !--- これはエリア 0 での 2.2.2.2 に対するルータ LSA です。 LS age: 789 Options: (No TOS-capability, DC) LS Type: Router Links Link State ID: 2.2.2.2 Advertising Router: 2.2.2.2 LS Seq Number: 80000045 Checksum: 0xEE82 Length: 48 Area Border Router !--- ビット B はルータ LSA で設定されます。 !--- このビットは、このルータが ABR であることを示します。 Number of Links: 2 !--- エリア 0 には 2 つのリンクがあります。 Link connected to: another Router (point-to-point) (Link ID) Neighboring Router ID: 1.1.1.1 (Link Data) Router Interface address: 0.0.0.10 Number of TOS metrics: 0 TOS 0 Metrics: 64
Link connected to: a Stub Network (Link ID) Network/subnet number: 6.0.0.0 (Link Data) Network Mask: 255.0.0.0 Number of TOS metrics: 0 TOS 0 Metrics: 10 Router Link States (Area 1) !--- エリア 1 でのルータ 2.2.2.2 に対する !--- ルータ LSA です。 LS age: 445 Options: (No TOS-capability, DC) LS Type: Router Links Link State ID: 2.2.2.2 Advertising Router: 2.2.2.2 LS Seq Number: 8000000B Checksum: 0xCA9D Length: 48 Area Border Router Number of Links: 2
Link connected to: another Router (point-to-point) (Link ID) Neighboring Router ID: 3.3.3.3 (Link Data) Router Interface address: 200.0.0.2 Number of TOS metrics: 0 TOS 0 Metrics: 1
Link connected to: a Stub Network (Link ID) Network/subnet number: 200.0.0.0 (Link Data) Network Mask: 255.255.255.0 Number of TOS metrics: 0 TOS 0 Metrics: 1
r2.2.2.2#show ip ospf database router 3.3.3.3
OSPF Router with ID (2.2.2.2) (Process ID 2)
Router Link States (Area 1)
LS age: 465 Options: (No TOS-capability, DC) LS Type: Router Links Link State ID: 3.3.3.3 Advertising Router: 3.3.3.3 LS Seq Number: 80000006 Checksum: 0x71F7 Length: 48 Number of Links: 2
Link connected to: another Router (point-to-point) (Link ID) Neighboring Router ID: 2.2.2.2 (Link Data) Router Interface address: 200.0.0.3 Number of TOS metrics: 0 TOS 0 Metrics: 1
Link connected to: a Stub Network (Link ID) Network/subnet number: 200.0.0.0 (Link Data) Network Mask: 255.255.255.0 Number of TOS metrics: 0 TOS 0 Metrics: 1

あるエリアから他のエリアへのルートをアドバタイズする場合、ABR が集約リンクを生成します。この集約リンクは show ip ospf database summary <link-state id> コマンドで参照できます。

 r2.2.2.2#show ip ospf database summary 200.0.0.0 
OSPF Router with ID (2.2.2.2) (Process ID 2)
Summary Net Link States (Area 0)
LS age: 487 Options: (No TOS-capability, DC, Upward) !--- キーワード Upward は、これが VPN バックボーンから(PE から CE へ) !--- インポートされた LSA ではないことを示しています。 LS Type: Summary Links(Network) Link State ID: 200.0.0.0 (summary Network Number) !--- 200.0.0.0/24 は、ABR(ルータ 2.2.2.2)によって !--- エリア 0 にアドバタイズされます。 Advertising Router: 2.2.2.2 LS Seq Number: 80000001 Checksum: 0x2546 Length: 28 Network Mask: /24 TOS: 0 Metric: 1
r2.2.2.2#show ip ospf database summary 4.0.0.0
OSPF Router with ID (2.2.2.2) (Process ID 2)
Summary Net Link States (Area 1)
LS age: 840 Options: (No TOS-capability, DC, Upward) LS Type: Summary Links(Network) Link State ID: 4.0.0.0 (summary Network Number) !--- 4.0.0.0/8 は、ABR(ルータ 2.2.2.2)によって !--- エリア 1 にアドバタイズされます。 Advertising Router: 2.2.2.2 LS Seq Number: 80000001 Checksum: 0xFFE6 Length: 28 Network Mask: /8 TOS: 0 Metric: 74
r2.2.2.2#show ip ospf database summary 6.0.0.0
OSPF Router with ID (2.2.2.2) (Process ID 2)
Summary Net Link States (Area 1)
LS age: 861 Options: (No TOS-capability, DC, Upward) LS Type: Summary Links(Network) Link State ID: 6.0.0.0 (summary Network Number) !--- 6.0.0.0/8 は、ABR(ルータ 2.2.2.2)によって !--- エリア 1 にアドバタイズされます。 Advertising Router: 2.2.2.2 LS Seq Number: 80000001 Checksum: 0x63C1 Length: 28 Network Mask: /8 TOS: 0 Metric: 10

最短パスの計算

このセクションでは、ルータ 3.3.3.3 から見た最短パスを計算します。

ルータ 3.3.3.3 は自身の LSA を参照し、ルータ 2.2.2.2 がネイバーであることを認識します。 続いてルータ 3.3.3.3 はルータ 2.2.2.2 の LSA を参照し、ルータ 2.2.2.2 がルータ 3.3.3.3 をネイバーとして認識していることを確認します。 両方のルータが互いにネイバーとして認識しあっている場合、両ルータは到達可能と見なされます。

さらに各ルータはローカルのネイバーテーブル(show ip ospf neighbor コマンドで表示できる)をチェックし、自身のインターフェイスとネイバーのインターフェイスが共通の IP サブネット上にあることを確認します。

注:このチェックは番号なしインターフェイスでは行われません。

インターフェイスが共通のサブセットにある場合、ルータはネイバーの LSA にリストされているすべてのスタブ ネットワークに対するルートを設定します。 この例では、ルータ 2.2.2.2 の LSA にリストされているスタブ ネットワークは 200.0.0.0/24 だけで、ルータ 3.3.3.3 はルータ 2.2.2.2 にすでに直接接続されています。

エリア 1 内の到達可能なルータ LSA すべてについて検査した後、ルータ 3.3.3.3 はデータベースの集約 LSA を参照します。 4.0.0.0/8 と 6.0.0.0/8 に対する集約 LSA が見つかります。ルータ 3.3.3.3 でこの集約 LSA を作成したアドバタイジング ルータへの到達方法が分かっている場合は、そのルートを自身のルーティング テーブルに設定します。 この例では、アドバタイジング ルータはルータ 2.2.2.2 です。 ルータ 3.3.3.3 ではルータ 2.2.2.2 への到達方法が分かっているため、4.0.0.0/8 と 6.0.0.0/8 へのルートがルーティング テーブルに設定されます。 これらのルートへのメトリックは、アドバタイジング ルータへ到達するまでのメトリックに、集約 LSA のメトリックを足したものになります。 集約 LSA のメトリックは、集約 LSA を作成するときの対象となるエリア内ルートまたはエリア間ルートに到達するコストから計算されます。

注:ルータでは、タイプ 1 LSA を使用して、エリア内で直接接続されているネットワークと他のルータへのアドバタイズを行います。これは同じエリア内でフラッディングされます。 そのため、同じエリア内のすべてのルータが、自身のエリアについての完全なトポロジ情報を持ちます。 結果として、ABR が、直接接続されているすべてのエリアについての完全なトポロジ情報を維持します。 しかし、ABR があるエリアに属しているネットワークを 2 番目のエリアにアドバタイズするときには、タイプ 3 LSA を使用してネットワークのプレフィクスとマスクだけをアドバタイズします。 2 番目のエリアにあるルータは、他のエリアのトポロジ情報を知りませんが、他のエリア内のネットワークへの到達可能性情報は持っています。

次の出力は、上記の各ルータのルーティング テーブルに格納された OSPF ルートを示しています。

 r1.1.1.1# show ip route ospf 
 O IA 200.0.0.0/24 [110/65] via 6.0.0.2, 00:09:00, Serial2/1/0 
 O    6.0.0.0/8 [110/74] via 6.0.0.2, 00:14:41, Serial2/1/0
r2.2.2.2#show ip route ospf O 4.0.0.0/8 [110/74] via 4.0.0.1, 00:09:16, Serial0/1/0
r3.3.3.3#show ip route ospf O IA 4.0.0.0/8 [110/75] via 200.0.0.2, 00:09:27, ATM2/0.20 O IA 6.0.0.0/8 [110/11] via 200.0.0.2, 00:09:27, ATM2/0.20

トラブルシューティング

データベース内の情報がルーティング テーブルから失われた場合の OSPF のトラブルシューティングについての情報は、『一部の OSPF ルートがデータベースにはあるがルーティングテーブルにはない理由』を参照してください。 一般的な OSPF のトラブルシューティング情報については、『OSPF のトラブルシューティング』を参照してください。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報