ロング リーチ イーサネット(LRE)とデジタル加入者線(xDSL) : 非対称デジタル加入者線(ADSL)

CHAP および PAP を実行する PPPoA を使用した Cisco 1700/2600/3600 ADSL WIC の設定

2005 年 6 月 10 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2008 年 2 月 26 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
設定
      ネットワーク ダイアグラム
      設定例
確認
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

Cisco 1700、2600、および 3600 シリーズのルータでは、Asymmetric Digital Subscriber Line(ADSL; 非対称デジタル加入者線)対応の WAN Interface Card(WIC; WAN インターフェイス カード)がサポートされています。 これら 3 つのタイプのプラットフォームは、基本的には同じように設定されますが、各プラットフォームに必要なハードウェアおよび Cisco IOS(R) ソフトウェア リリースには差があります。 このドキュメントでは、Cisco 1700/2600/3600 を Cisco ADSL WIC と呼びます。

このドキュメントでは、Cisco 6400 Universal Access Concentrator(UAC; ユニバーサル アクセス コンセントレータ)で終端する Cisco 6130 DSL access multiplexer(DSLAM)に接続された Cisco ADSL WIC について説明します。 各設定は、PPP over ATM(PPPoA)を使用します。 ATM インターフェイスは、AALMUX PPP カプセル化用に設定されています。

1 つ目の設定では、Challenge Handshake Authentication Protocol(CHAP; チャレンジ ハンドシェーク認証プロトコル)を使用する PPPoA を示します。 2 つ目の設定では、Password Authentication Protocol(PAP; パスワード認証プロトコル)を使用する PPPoA を示します。

前提条件

要件

この設定を開始する前に、次の要件が満たされていることを確認してください。

  • Cisco 6400 UAC-NRP IOS ソフトウェア リリース 12.1(3)DC1

  • Cisco 6400 UAC-NSP IOS ソフトウェア リリース 12.1(3)DB

  • Cisco 6130 DSLAM-NI2 IOS ソフトウェア リリース 12.1(5)DA

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

Cisco 2600/3600 で ADSL WIC をサポートするには、次のハードウェア製品が必要です。

  • 2600: シャーシ WIC スロット、NM-2W

  • 3600: NM-1FE1R2W、NM-1FE2W、NM-2FE2W、NM-2W

注:Cisco 3600 の場合、ADSL は WIC NM-1E1R2W、NM-1E2W、または NM-2E2W ではサポートされません。

ADSL WIC をサポートするには、最低限、次の Cisco IOS ソフトウェア リリースが必要です。

  • Cisco 2600/3600 では、Cisco IOS ソフトウェア リリース 12.1(5)YB(Plus バージョンのみ)。

  • Cisco 1700 では、Cisco IOS ソフトウェア リリース IOS 12.1(3)XJ 以降(Plus バージョンまたは ADSL 機能セットのみ)。 ADSL 機能セットは、イメージ名に「y7」を付けて示されます(c1700-sy7-mz.121-3.XJ.bin など)。

注:Cisco 1700 用のイメージをダウンロードするときは、1700 のイメージ名を必ず選択してください。 1720 または 1750 のイメージはダウンロードしないでください。これらの機能は ADSL WIC をサポートしていません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されています。このドキュメント内で使用されているデバイスはすべて、クリアな設定(デフォルト)から作業を始めています。対象のネットワークが実稼動中である場合には、すべてのコマンドによる潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメントの表記法の詳細については、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションでは、このドキュメントで説明する機能を設定するための情報を提供します。

注:このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク ダイアグラム

このドキュメントでは次の図に示すネットワーク構成が使用されています。

wicadsl_pppoa_chap_12961a.gif

設定例

このドキュメントでは、次に示す設定を使用しています。

  • CHAP を使用する PPPoA

  • PAP を使用する PPPoA

CHAP を使用する PPPoA に対して interface virtual-template コマンドを使用するときは、ppp chap sent-username username password password だけを設定してください。 ppp authentication chap callin コマンドはサポートされていません。 CHAP を使用する PPPoA のこの例では、これには該当しない interface dialer コマンドを使用しています。

Cisco ADSL WIC
 Current configuration: 
 ! 
 version 12.1 
 !
 service timestamps debug datetime msec 
 service timestamps log datetime msec 
 ! 
 hostname R1 
 ! 
 ip subnet-zero 
 ! 
 interface FastEthernet0 
  ip address 10.0.0.1 255.0.0.0 
  no ip directed-broadcast 
  no ip mroute-cache 
 ! 
 interface ATM0 
  no ip address 
  no ip directed-broadcast 
  no ip mroute-cache 
  no atm ilmi-keepalive 
  pvc 1/150 
   encapsulation aal5mux ppp dialer 
   dialer pool-member 1 
  ! 
  hold-queue 224 in 
 ! 
 interface Dialer0 
  ip address 172.18.0.1 255.255.0.0 
  no ip directed-broadcast 
  encapsulation ppp 
  dialer pool 1 
  dialer-group 1 
  ppp authentication chap callin 
  ppp chap hostname username
 
  ppp chap password password
 
 ! 
 ip classless
 ip route 0.0.0.0.0.0.0.0 dialer0 
 ! 
 dialer-list 1 protocol ip permit 
 !
 end
 
Access 6400 NRP1
 username username password password
 
 
  !--- ユーザ名とパスワードの値は、リモート デバイスの
 
 
  !--- ユーザ名とパスワードの値に一致する必要がある。
 !
 interface ATM0/0/0.200 point-to-point
  no ip directed-broadcast
  no ip route-cache 
  pvc 1/301 
   encapsulation aal5mux ppp Virtual-Template11
  !
  interface Virtual-Template11 
   ip address 172.18.0.2 255.255.0.0 
   no ip directed-broadcast 
   ppp authentication chap
 ! 
 ip route 10.0.0.1 255.255.255.255 172.18.0.1
 

PAP を使用する PPPoA に対して interface virtual-template コマンドを使用するときは、ppp pap sent-username username password password コマンドだけを設定してください。 ppp authentication pap callin コマンドはサポートされていません。 PAP を使用する PPPoA のこの例では、これには該当しない interface dialer コマンドを使用しています。

Cisco ADSL WIC
 version 12.1 
 !
 service timestamps debug datetime msec 
 service timestamps log datetime msec 
 ! 
 hostname R1 
 ! 
 ip subnet-zero 
 ! 
 interface FastEthernet0 
  ip address 10.0.0.1 255.0.0.0 
  no ip directed-broadcast 
  no ip mroute-cache 
 ! 
 interface ATM0 
  no ip address 
  no ip directed-broadcast 
  no ip mroute-cache 
  no atm ilmi-keepalive 
  pvc 1/150 
   encapsulation aal5mux ppp dialer 
   dialer pool-member 1 
  ! 
  hold-queue 224 in 
 ! 
 interface Dialer0 
  ip address 172.18.0.1 255.255.0.0 
  no ip directed-broadcast 
  encapsulation ppp 
  dialer pool 1 
  dialer-group 1 
  ppp authentication pap callin
 ppp pap sent-username username password password
 
  ! 
 ip classless
 ip route 0.0.0.0.0.0.0.0 dialer0 
 no ip http server 
 ! 
 dialer-list 1 protocol ip permit 
 
Access 6400 NRP1
 username <username> password <password>
 
  !--- ユーザ名とパスワードの値は、リモート デバイスの

 
 !--- ユーザ名とパスワードの値に一致する必要がある。 
!
 interface ATM0/0/0.200 point-to-point
  no ip directed-broadcast
  no ip route-cache 
  pvc 1/301 
   encapsulation aal5mux ppp Virtual-Template11
  !
  interface Virtual-Template11 
   ip address 172.18.0.2 255.255.0.0 
   no ip directed-broadcast 
   ppp authentication pap
 ! 
 ip route 10.0.0.1 255.255.255.255 172.18.0.1
 

確認

現在のところ、この設定を確認する手順はありません。

トラブルシューティング

現時点では、この設定に対して使用可能な特定のトラブルシューティング情報はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報