ロング リーチ イーサネット(LRE)とデジタル加入者線(xDSL) : Symmetrical High-Data-Rate DSL(G.SHDSL)

G.SHDSL ポートを使用する CPE のバックツーバック接続の設定

2005 年 6 月 10 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 4 月 23 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
設定
      ネットワーク ダイアグラム
      設定例
コマンド リファレンス
      DSL 装置のタイプ
      DSL のラインレート
      DSL の動作モード(G.SHDSL)
確認
トラブルシューティング
      トラブルシューティングのためのコマンド
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、Multirate Symmetric High-Speed Digital Subscriber Line(G.SHDSL)ポートを使用して、2 台のルータをバックツーバック接続で設定する例について説明します。 また、G.SHDSL 対応のシスコ ルータを、リモートの G.SHDSL CPE デバイスからの接続を終端する Central Office(CO; セントラル オフィス)の DSL デバイスとして設定する方法についても説明します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づいています。

  • Cisco IOS(R) ソフトウェア リリース 12.2(8)T1 が稼働する 828 Customer Premises Equipment(CPE; 顧客宅内機器)

  • Cisco IOS ソフトウェア リリース 12.2(8)T が稼働する 2612 ルータ

  • WAN インターフェイス カード(WIC)-1SHDSL を使用している 2612 ルータ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されています。このドキュメント内で使用されているデバイスはすべて、クリアな設定(デフォルト)から作業を始めています。対象のネットワークが実稼動中である場合には、すべてのコマンドによる潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションでは、このドキュメントで説明する機能を設定するための情報を提供します。

注:このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

このドキュメントでは次の図に示すネットワーク構成が使用されています。

dsl_cpe_config1.gif

設定例

このドキュメントでは、次に示す設定を使用しています。

注:次の設定では、828A は装置タイプを「CO」として設定しています。これは CO からの信号をシミュレートするものです。また、G.SHDSL WIC を装着している 2612 は、装置タイプを「CPE」として設定しています。

DSL5-828A(CO として動作する Cisco 828 CPE)
 DSL5-828A#show run
 Building configuration...
 
 Current configuration : 769 bytes
 !
 version 12.2
 no service pad
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname DSL5-828A
 !
 !
 ip subnet-zero
 !
 !
 !
 !
 !
 interface Ethernet0
  ip address 192.168.1.1 255.255.255.0
  hold-queue 100 out
 !
 interface ATM0
  no ip address
  no atm ilmi-keepalive
  pvc 0/35 
   encapsulation aal5snap
  !
  pvc 8/35 
   encapsulation aal5mux ppp dialer
   dialer pool-member 1
  !
  dsl equipment-type CO
  dsl operating-mode GSHDSL symmetric annex A
  dsl linerate AUTO
 !
 interface Dialer0
  ip address 1.1.1.1 255.255.255.0
  encapsulation ppp
  dialer pool 1
  dialer-group 1
 !
 ip classless
 ip http server
 ip pim bidir-enable
 !
 !         
 dialer-list 1 protocol ip permit
 !
 line con 0
  stopbits 1
 line vty 0 4
 !
 scheduler max-task-time 5000
 end
 
DSL4-2612A(CPE として動作する Cisco 2612 ルータ)
 dsl4-2612a#show run
 Building configuration...
 
 Current configuration : 927 bytes
 !
 version 12.2
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname dsl4-2612a
 !
 !
 ip subnet-zero
 !
 !
 !
 !
 !
 !
 !
 !
 !
 !
 fax interface-type fax-mail
 mta receive maximum-recipients 0
 !
 !
 !
 !
 interface ATM0/0
  no ip address
  no atm ilmi-keepalive
  pvc 0/35 
   encapsulation aal5snap
  !
  pvc 8/35 
   encapsulation aal5mux ppp dialer
   dialer pool-member 1
  !
  dsl equipment-type CPE
  dsl operating-mode GSHDSL symmetric annex A
  dsl linerate AUTO
 !
 interface Ethernet0/0
  ip address 172.16.1.2 255.255.255.0
  shutdown
  half-duplex
 !         
 interface TokenRing0/0
  no ip address
  shutdown
  ring-speed 16
 !
 interface Dialer0
  ip address 1.1.1.2 255.255.255.0
  encapsulation ppp
  dialer pool 1
  dialer-group 1
 !
 ip classless
 ip http server
 ip pim bidir-enable
 !
 !
 dialer-list 1 protocol ip permit
 !
 call rsvp-sync
 !
 !
 mgcp profile default
 !         
 dial-peer cor custom
 !
 !
 !
 !
 line con 0
 line aux 0
 line vty 0 4
 !
 !
 end
 

コマンド リファレンス

このセクションでは、変更されたコマンドについて説明します。 この機能で使用するその他すべてのコマンドは、Cisco IOS リリース 12.2 のコマンド リファレンスに記載されています。

変更されたコマンド

  • DSL 装置のタイプ

  • DSL のラインレート

  • DSL の動作モード(G.SHDSL)

DSL 装置のタイプ

DSL ATM インターフェイスが CO 装置または CPE として動作するよう設定するには、ATM インターフェイス モードで dsl equipment-type コマンドを発行します。 デフォルトの装置タイプに戻すには、このコマンドの no 形式を使用します。

  • dsl equipment-type {co | cpe}

  • no dsl equipment-type

上記のコマンド構文について説明します。

  • co - DSL ATM インターフェイスが CO 装置として動作するよう設定します。

  • cpe - DSL ATM インターフェイスが CPE として動作するよう設定します。

デフォルト設定

DSL ATM インターフェイスは CPE として動作します。

インターフェイス コマンド モード

G.SHDSL WIC 用の ATM インターフェイスは、次の Cisco IOS リリースに組み込まれています。

  • 12.2(4)XL - Cisco 2600 シリーズ ルータ

  • 12.2(8)T - Cisco 2600 シリーズ ルータおよび Cisco 3600 シリーズ ルータ

使用上のガイドライン

この設定コマンドは、特定の ATM インターフェイスに適用されます。 このコマンドを発行する前に、ATM インターフェイスを指定する必要があります。 また、コマンドを発行する前に、ATM インターフェイスを shutdown 状態にしておく必要があります。 次の例では、DSL ATM インターフェイス 1/1 を CO 装置として動作するように設定する方法を示しています。

 Router# configure terminal 
   
 Enter configuration commands, one per line. End with CNTL/Z. 
 Router(config)# interface atm 1/1 
 Router(config-if)# dsl equipment-type co 
 
 Router(config-if)# end 
 Router# clear interface atm 0/1 
 
 Router#
 

関連するコマンド

  • dsl linerate - DSL ATM インターフェイスのライン レートを指定します。

  • dsl operating-mode (g.shdsl) - DSL ATM インターフェイスの動作モードを指定します。

DSL のラインレート

DSL ATM インターフェイスのライン レートを指定するには、ATM インターフェイス モードで dsl linerate コマンドを発行します。 デフォルトのライン レートに戻すには、このコマンドの no 形式を使用します。

  • dsl linerate {kbps | auto}

  • no dsl linerate

上記のコマンドの構文について説明します。

  • kbps - DSL ATM インターフェイスのライン レートを、1 秒あたりのキロビット数で指定します。 指定できる値は、72、136、200、264、392、520、776、1032、1160、1544、2056、および 2312 です。

  • auto - 遠端の DSL Access Multiplier(DSLAM)または WIC とネゴシエーションを行って、最適なライン レートを自動的にトレインするように DSL ATM インターフェイスを設定します。

デフォルト設定

DSL ATM インターフェイスは、自動的に遠端の DSLAM または WIC とライン レートを同期します。

インターフェイス コマンド モード

G.SHDSL WIC 用の ATM インターフェイスは、次の Cisco IOS リリースに組み込まれています。

  • 12.2(4)XL - Cisco 2600 シリーズ ルータ

  • 12.2(8)T - Cisco 2600 シリーズ ルータおよび Cisco 3600 シリーズ ルータ

使用上のガイドライン

この設定コマンドは、特定の ATM インターフェイスに適用されます。 このコマンドを発行する前に、ATM インターフェイスを指定する必要があります。 また、コマンドを発行する前に、ATM インターフェイスを shutdown 状態にしておく必要があります。 次の例では、DSL ATM インターフェイス 0/1 を 1040 kbps のライン レートで動作するように設定する方法を示しています。

 Router# configure terminal 
   
 Enter configuration commands, one per line. End with CNTL/Z. 
 Router(config)# interface atm 0/1 
 Router(config-if)# dsl linerate 1040 
 
 Router(config-if)# end 
 Router# clear interface atm 0/1 
 
 Router# 
 

関連するコマンド

  • dsl equipment-type - DSL ATM インターフェイスが、CO 装置または CPE として動作するよう設定します。

  • dsl operating-mode (g.shdsl) - DSL ATM インターフェイスの動作モードを指定します。 デフォルトの動作モードに戻すには、このコマンドの no 形式を使用します。

DSL の動作モード(G.SHDSL)

ATM インターフェイスでの DSL の動作モードを指定するには、ATM インターフェイス コマンドの dsl operating-mode を発行します。 デフォルトの動作モードに戻すには、このコマンドの no 形式を使用します。

  • dsl operating-mode gshdsl symmetric annex {A | B}

  • no dsl operating-mode

上記のコマンドの構文について説明します。

  • gshdsl - DSL ATM インターフェイスが、ITU G.991.2 に準拠したマルチレート高速モードで動作するよう設定します。

  • symmetric - DSL ATM インターフェイスが、ITU G.991.2 に準拠した対称モードで動作するよう設定します。

  • annex {A | B} - 地域ごとの動作パラメータを指定します。 北米の場合は A、ヨーロッパの場合は B を入力します。 デフォルトは A です。

デフォルト設定

デフォルトの動作モードは、gshdsl symmetric annex A です。

インターフェイス コマンド モード

G.SHDSL WIC 用の ATM インターフェイスは、Cisco IOS リリース 12.1(3)X で導入され、下記の Cisco IOS リリースに組み込まれています。

  • 12.2(2)T - Cisco 1700 シリーズ ルータ

  • 12.2(4)XL - Cisco 2600 シリーズ ルータ

  • 12.2(8)T - Cisco 2600 シリーズ ルータおよび Cisco 3600 シリーズ ルータ

使用上のガイドライン

この設定コマンドは、特定の ATM インターフェイスに適用されます。 このコマンドを発行する前に、ATM インターフェイスを指定する必要があります。 また、コマンドを入力する前に、ATM インターフェイスを shutdown 状態にしておく必要があります。 次の例では、DSL ATM インターフェイス 0/0 が G.SHDSL モードで動作するように設定する方法について説明します。

 Router# configure terminal 
   
 Enter configuration commands, one per line. End with CNTL/Z. 
 Router(config)# interface atm 0/0 
 Router(config-if)# dsl operating-mode gshdsl symmetric annex A 
 
 Router(config-if)# end 
 Router# clear interface atm 0/1 
 
 Router#
 

関連するコマンド

  • dsl equipment-type - DSL ATM インターフェイスが、CO 装置または CPE として動作するよう設定します。

  • dsl linerate - DSL ATM インターフェイスのライン レートを指定します。

確認

コンソール セッションに表示される次の項目を確認する必要があります。 ルータに Telnet 接続している場合は、コンソール メッセージを表示するために term mon コマンドを発行する必要があります。

 00:51:25: %GSI-6-RESET: Interface ATM0/0, bringing up the line. It may take several seconds for the line to be active. 
 00:52:09: %ATM-5-UPDOWN: Changing VC 0/35 VC-state to PVC activated. 
 00:52:09: %ATM-5-UPDOWN: Changing VC 8/35 VC-state to PVC activated. 
 00:52:10: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
 00:52:10: %DIALER-6-BIND: Interface Vi1 bound to profile Di0 
 00:52:11: %LINK-3-UPDOWN: Interface ATM0/0, changed state to up 
 00:52:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0, changed state to up 
 00:52:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up 
 

このセクションでは、設定が正しく動作していることを確認するために使用できる情報を提供します。

特定の show コマンドは、アウトプットインタープリタ登録ユーザ専用)でサポートされています。このツールを使用すると、show コマンドの出力の解析を表示できます。

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

  • show running-config - 現在の設定を確認し、すべてのコントローラのステータスを表示します。

  • show controllers atm slot/port - ATM コントローラの統計情報を表示します。

  • show atm vc - Permanent Virtual Circuit(PVC; 相手先固定接続)のステータスを確認します。

  • show dsl interface atm - G.SHDSL モデムのステータスを表示します。

  • show interface atm - ATM インターフェイスのステータスを表示します。

show atm vc コマンドの出力例を次に示します。 アクティブな PVC がアップしていることを確認します。

 dsl4-2612a#show atm vc 
            VCD /                                        Peak  Avg/Min Burst 
 Interface  Name         VPI   VCI  Type   Encaps   SC   Kbps   Kbps   Cells  Sts 
 0/0        1              0    35  PVC    SNAP     UBR    2304                UP 
 0/0        2              8    35  PVC    MUX      UBR    2304                UP
 

show dsl interface atm コマンドの出力例を次に示します。 回線がダウンしている場合、次のメッセージが表示されます。Line is not active. Some of the values may not be accurate. 装置タイプや動作モードの設定が、ご使用のアプリケーションに対して適切かどうかを調べることもできます。

 dsl4-2612a#show dsl interface atm 0/0 
 Globespan G.SHDSL/SDSL Chipset Information 
 
  Equipment Type:         Customer Premise 
  Operating Mode:         G.SHDSL Annex A 
  Clock Rate Mode:        Auto rate selection Mode 
  Reset Count:            1 
  Actual rate:            2312 Kbps 
  Modem Status:           Data (0x1) 
  Received SNR:           39 dB 
  SNR Threshold:          23 dB 
  Loop Attenuation:      -0.3400 dB 
  Transmit Power:         7.5 dBm 
  Receiver Gain:          4.3900 dB 
  Last Activation Status: No Failure (0x0) 
  CRC Errors:             33372 
  Chipset Version:        1 
  Firmware Version:       R1.5 
 
 dsl4-2612a#show dsl interface atm 0/0 
 Globespan G.SHDSL/SDSL Chipset Information 
 
 Line is not active. Some of the values printed may not be accurate. 
  Equipment Type:         Customer Premise 
  Operating Mode:         G.SHDSL Annex A 
  Clock Rate Mode:        Auto rate selection Mode 
  Reset Count:            1 
  Actual rate:            2312 Kbps 
  Modem Status:           Idle (0x0) 
  Received SNR:           38 dB 
  SNR Threshold:          23 dB 
  Loop Attenuation:      -0.3400 dB 
  Transmit Power:         7.5 dBm 
  Receiver Gain:          4.3900 dB 
  Last Activation Status: No Failure (0x0) 
  CRC Errors:             33372 
  Chipset Version:        1 
  Firmware Version:       R1.5
 

ATM 回線上で ping を実行できない場合は、両方のルータの ATM インターフェイスに対して show interface コマンドを発行して、ATM インターフェイスが UP/UP 状態であることを確認します。 ATM インターフェイスのステータスを表示するには、show interface atm コマンドを発行します。 次の例で示すように、ATM スロット、ポート、および回線プロトコルがアップされていることを確認してください。

 DSL5-828A#show interfaces atm0 
 ATM0 is up, line protocol is up 
   Hardware is PQUICC_SAR (with Globespan G.SHDSL module) 
   MTU 1500 bytes, sub MTU 1500, BW 2312 Kbit, DLY 80 usec, 
      reliability 255/255, txload 1/255, rxload 1/255 
   Encapsulation ATM, loopback not set 
   Encapsulation(s): AAL5, PVC mode 
   10 maximum active VCs, 2 current VCCs 
   VC idle disconnect time: 300 seconds 
   Last input never, output 00:00:08, output hang never 
   Last clearing of "show interface" counters never 
   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
   Queueing strategy: None 
   5 minute input rate 0 bits/sec, 0 packets/sec 
   5 minute output rate 0 bits/sec, 0 packets/sec 
      261 packets input, 11170 bytes, 0 no buffer 
      Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
      0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
      264 packets output, 11388 bytes, 0 underruns 
      0 output errors, 0 collisions, 2 interface resets 
      0 output buffer failures, 0 output buffers swapped out
 

トラブルシューティング

このセクションでは、設定のトラブルシューティングに役立つ情報を説明します。

トラブルシューティングのためのコマンド

注:debug コマンドを使用する前に、『デバッグ コマンドの重要な情報』を参照してください。

  • debug atm events - ATM 関連のイベントが生成されたときに、そのイベントを識別します。

  • debug atm errors - トラブルが発生しているインターフェイスを示します。

次のデバッグ例は、上記のデバッグを実行して、オンラインになった ATM インターフェイスから得られたものです(回線がアップ状態になるには、30 秒以上の時間がかかる場合があります)。

 01:07:15: ATM0/0 dslsar_1a_reset: PLIM type is 19, Rate is 2304Mbps 
 01:07:15: ATM0/0 dslsar_1a_shutdown: state=4 
 01:07:15: dslsar disable ATM0/0 
 
 01:07:15: %GSI-6-RESET: Interface ATM0/0, 
bringing up the line. It may take several seconds for the line to be active.
01:07:15: Resetting ATM0/0 01:07:15: dslsar_1a_config(ATM0/0) 01:07:15: dslsar_1a_enable(ATM0/0) 01:07:15: ATM0/0: dslsar_init(825AD084,FALSE) 01:07:15: dslsar disable ATM0/0 01:07:16: ATM0/0 dslsar_init: DSLSAR TXRX disabled 01:07:16: ATM0/0 dslsar_1a_enable: restarting VCs: 0 01:07:16: (ATM0/0)1a_enable,calling atm_activate_pvc, vcd = 1, vc = 0x82A17BE0adb->flags = 0x4800C 01:07:16: (ATM0/0)1a_enable,calling atm_activate_pvc, vcd = 2, vc = 0x82A1863Cadb->flags = 0x4800C dsl4-2612a# dsl4-2612a# 01:07:16: %SYS-5-CONFIG_I: Configured from console by console 01:07:19: dslsar disable ATM0/0 01:08:03: ATM0/0 dslsar_MatchSARTxToLineSpeed(): usbw 2304, clkPerCell 6360 prev_clkPerCell 9702 01:08:03: ATM0/0 dslsar_update_us_bandwidth(): upstream bw =2304 Kbps 01:08:09: dslsar_periodic: ENABLING DSLSAR 01:08:09: dslsar enable ATM0/0 01:08:09: dslsar_1a_setup_vc(ATM0/0): vc:1 vpi:0 vci:35 state 2 01:08:09: ATM0/0 dslsar_vc_setup: vcd 1, vpi 0, vci 35, avgrate 0 01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 0 01:08:09: Forcing Peakrate and Avgrate to: 2304 01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 01:08:09: Configuring VC 1: slot 0 in TST 5 01:08:09: SUCCESSFUL CONFIGURATION OF VC 1 (0/35), QOS Type 4 01:08:09: ATM0/0: vcd = 1, bw = 2304, tbds_per_tsi = 15,
max_pkt_len = 4470, max_tx_time = 1862ATM0/0 last_address 0x12E14 01:08:09: %ATM-5-UPDOWN: Changing VC 0/35 VC-state to PVC activated. 01:08:09: dslsar_1a_setup_vc(ATM0/0): vc:2 vpi:8 vci:35 state 2 01:08:09: ATM0/0 dslsar_vc_setup: vcd 2, vpi 8, vci 35, avgrate 0 01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 1 01:08:09: Forcing Peakrate and Avgrate to: 2304 01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 01:08:09: Configuring VC 1: slot 0 in TST 5 01:08:09: SUCCESSFUL CONFIGURATION OF VC 1 (0/35), QOS Type 4 01:08:09: ATM0/0: vcd = 1, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 01:08:09: CONFIGURING VC 2 (8/35) IN TX SCHEDULE TABLE SET 1 01:08:09: Forcing Peakrate and Avgrate to: 2304 01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 01:08:09: Configuring VC 2: slot 1 in TST 5 01:08:09: SUCCESSFUL CONFIGURATION OF VC 2 (8/35), QOS Type 4 01:08:09: ATM0/0: vcd = 2, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 01:08:09: %ATM-5-UPDOWN: Changing VC 8/35 VC-state to PVC activated. 01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 0 01:08:09: Forcing Peakrate and Avgrate to: 2304 01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 01:08:09: Configuring VC 1: slot 0 in TST 5 01:08:09: SUCCESSFUL CONFIGURATION OF VC 1 (0/35), QOS Type 4 01:08:09: ATM0/0: vcd = 1, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 01:08:09: CONFIGURING VC 2 (8/35) IN TX SCHEDULE TABLE SET 0 01:08:09: Forcing Peakrate and Avgrate to: 2304 01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 01:08:09: Configuring VC 2: slot 1 in TST 5 01:08:09: SUCCESSFUL CONFIGURATION OF VC 2 (8/35), QOS Type 4 01:08:09: ATM0/0: vcd = 2, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 01:08:10: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 01:08:10: %DIALER-6-BIND: Interface Vi1 bound to profile Di0 01:08:11: %LINK-3-UPDOWN: Interface ATM0/0, changed state to up 01:08:11: dslsar_atm_lineaction(ATM0/0): state=4 01:08:12: %LINEPROTO-5-UPDOWN:
Line protocol on Interface ATM0/0, changed state to up 01:08:13: %LINEPROTO-5-UPDOWN:
Line protocol on Interface Virtual-Access1, changed state to up

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報