ワイヤレス / モビリティ : ワイヤレス LAN(WLAN)

無線 LAN コントローラでの VLAN の設定例

2010 年 11 月 10 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2011 年 8 月 26 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
WLC でのダイナミック インターフェイス
設定
      Catalyst スイッチの設定
      WLAN コントローラ VLAN の設定
確認
      Catalyst スイッチの確認
      WLAN コントローラ VLAN の確認
トラブルシューティング
      トラブルシューティング手順
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、無線 LAN(WLAN)コントローラと、それに関連付けられた Cisco Catalyst スイッチでの VLAN の設定例について説明します。



前提条件

要件

このドキュメントに関する特別な要件はありません。ただし、このドキュメントではコントローラに登録されているアクセス ポイント(AP)に IP アドレスを提供するための DHCP サーバが稼働していることを前提とします。



使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • 設定 A:

    • Cisco IOS® ソフトウェアと WLAN コントローラが稼働する Catalyst スイッチ

    • ソフトウェア バージョン 5.1 が稼働する Cisco 4404 WLAN コントローラ

  • 設定 B:

    • Catalyst OS (CatOS)ソフトウェアと WLAN コントローラが稼働する Catalyst スイッチ

    • ソフトウェア バージョン 5.1 が稼働する Cisco 4404 WLAN コントローラ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。



表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。



WLC でのダイナミック インターフェイス

ダイナミック インターフェイスは、VLAN インターフェイスとしても知られており、ユーザによって作成され、無線 LAN クライアントに VLAN に類似する機能を提供します。コントローラでは、最大 512 のダイナミック インターフェイス(VLAN)がサポートされます。各ダイナミック インターフェイスは個別に設定されるため、任意のまたはすべてのコントローラのディストリビューション システム ポートに、別々の通信ストリームを割り当てることができます。各ダイナミック インターフェイスでは、VLAN およびコントローラとその他のすべてのネットワーク デバイスとの間の通信が制御されます。また、インターフェイスにマップされた WLAN に接続するワイヤレス クライアントに対して、それぞれが DHCP リレーとして機能します。ユーザは、ダイナミック インターフェイスを、ディストリビューション システム ポート、WLAN、レイヤ 2 管理インターフェイス、およびレイヤ 3 AP マネージャ インターフェイスに割り当てることができます。また、バックアップ ポートにもマッピングできます。

ワイヤレス LAN コントローラのさまざまなポートの設定方法についての詳細は、『管理インターフェイス、AP マネージャ インターフェイス、仮想インターフェイス、およびサービスポート インターフェイスの設定』を参照してください。

WLAN コントローラを使用する VLAN は、次のようなモデルになります。

/image/gif/paws/68100/wlan_controllers_vlans1.gif



設定

このセクションでは、このドキュメントで説明する機能の設定に必要な情報を提供します。

注:このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。



Catalyst スイッチの設定

このセクションでは、次の設定例を使用しています。

Cisco IOS ソフトウェアが稼働する Catalyst スイッチ

lab1sup720ip1#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
lab1sup720ip1(config)#interface gigabitethernet 1/6
lab1sup720ip1(config-if)#
lab1sup720ip1(config-if)#switchport
lab1sup720ip1(config-if)#switchport trunk encapsulation dot1q
lab1sup720ip1(config-if)#switchport trunk allowed vlan 1,5,15,20,25,30,35,40,45,50,55,100
lab1sup720ip1(config-if)#switchport mode trunk
lab1sup720ip1(config-if)#end
lab1sup720ip1#

CatOS ソフトウェアが稼働する Catalyst スイッチ

controller-catos> (enable) set trunk 2/1 on dot1q
Port(s)  2/1 trunk mode set to on.
Port(s)  2/1 trunk type set to dot1q.
!
!clearing out/pruning unwanted vlans
!
controller-catos> (enable) clear trunk 2/1 21-24,26-30,31-34,36-39,41-44,46-49,51-54,
56-99,101-999

!--- このコマンドは 1 行に収める必要があります。

Removing Vlan(s) 21-24,26-34,36-39,41-44,46-49,51-54,56-99,101-999 from allowed list.
Port  2/1 allowed vlans modified to 1,5,15,20,25,35,40,45,50,55,100,1000-1005,1025-4094.




WLAN コントローラ VLAN の設定

GUI による設定

WLAN コントローラで次の手順を実行してください。

  1. WLC の GUI で、[Controller] > [Interfaces] を選択します。[Interfaces] ページに、WLC に設定されているすべてのインターフェイスの一覧が表示されます。新しいダイナミック インターフェイスを作成するには、[New] をクリックします。

    wlan_controllers_vlans2.gif

  2. Interface Name と VLAN Id を入力して、[Apply] をクリックします。

    wlan_controllers_vlans3.gif

  3. この VLAN 固有のパラメータを入力します。たとえば、IP アドレス、ネットマスク、ゲートウェイ、および DHCP サーバの IP アドレスなどがあります。入力したら、[Apply] をクリックします。下図には、このページで設定可能なすべてのパラメータの一覧が示されています。

    wlan_controllers_vlans4.gif

    次に例を示します。

    wlan_controllers_vlans5.gif

    注:このインターフェイスに割り当てられた IP アドレスは、クライアントが DHCP サーバから IP アドレスを取得するのに使用される DHCP リレーとして機能します。たとえば、あるクライアントが、このダイナミック インターフェイスにマップされた WLAN/SSID(この設定のステップ 5 を参照)との関連付けを実行しようとするときには、DHCP サーバを特定するために、ローカル サブネット ブロードキャストを実行します。コントローラは DHCP サーバ(または、そのコントローラがセグメントの DHCP サーバである場合には、自分自身)に要求を送信します。その場合に、このダイナミック インターフェイスの IP アドレスが、このインターフェイスに設定された DHCP サーバに対するリレー IP として使用されます。DHCP サーバは、設定された DHCP スコープから取得した IP アドレスをクライアントに割り当てます。

  4. インターフェイスの設定を確認します。

    ウィンドウの一番上のメニューで [Controller] タブをクリックし、左側のメニューから [Interfaces] を選択します。

    wlan_controllers_vlans6.gif

  5. ウィンドウの一番上のメニューで [WLANs] タブをクリックし、[New] をクリックします。

  6. サービス セット ID(SSID)を入力し、[Apply] をクリックします。

    次の例では、わかりやすくするため vlan15 を使用しています。

    wlan_controllers_vlans7.gif

  7. ウィンドウの一番下の [Interface Name] ドロップダウン メニューから vlan15 を選択し、[Apply] をクリックします。

    ここでは、SSID vlan15 がインターフェイス名 vlan15 に結びつけられています。

    wlan_controllers_vlans8.gif

CLI による設定

このセクションでは、コマンドライン インターフェイス(CLI)から VLAN を設定する方法について説明します。

  1. インターフェイスとそれに関連付ける VLAN タグを作成します。

    使用するコマンドは、config interface create interface_name vlan_id です。

    (lab5wlc4404ip15) >config interface create vlan15 15
    
  2. IP アドレスとデフォルト ゲートウェイを定義します。

    使用するコマンドは、config interface interface_name IP_address netmask gateway です。

    (lab5wlc4404ip15) >config interface address vlan15 192.168.15.10  
    255.255.255.0 192.168.15.1
    
    !--- このコマンドは 1 行に収める必要があります。
    
    
  3. DHCP サーバを定義します。

    使用するコマンドは、config interface dhcp interface_name dhcp_server 1 dhcp_server 2 dhcp_server 3 dhcp_server 4 です。

    (lab5wlc4404ip15) >config interface dhcp vlan15 192.168.5.15
    
  4. インターフェイスの設定を確認します。

    使用するコマンドは、show interface summary です。

    (lab5wlc4404ip15) >show interface summary  
    
    Interface Name           Port     Vlan Id      IP Address          Type      Ap Mgr
    -----------------------  ----     --------     ---------------     -------   ------
    ap-manager               1        untagged     192.168.5.215       Static    Yes
    management               1        untagged     192.168.5.15        Static    No
    service-port             N/A      N/A          100.100.100.100     Static    No
    virtual                  N/A      N/A          1.1.1.1             Static    No
    vlan15                   1        15           192.168.15.10       Dynamic   No
    
    
    (lab5wlc4404ip15) >
  5. WLAN を定義します。

    使用するコマンドは、config wlan create wlan_id name です。

    (lab5wlc4404ip15) >config wlan create 2 vlan15
    
  6. WLAN のインターフェイスを定義します。

    使用するコマンドは、config wlan interface wlan_id interface_name です。

    (lab5wlc4404ip15) >config wlan interface 2 vlan15
    
  7. VWLAN とそれに関連付けられたインターフェイスを確認します。

    使用するコマンドは、show wlan summary です。

    (lab5wlc4404ip15) >show wlan summary 
    
    Number of WLANs.................................. 2
    
    WLAN ID   WLAN Name               Status        Interface Name                  
    -------   --------------------    ---------     --------------------------------
    1         lab5wlc4404ip15         Enabled       management                      
    2         vlan15                  Disabled      vlan15                          
    
    (lab5wlc4404ip15) >


確認

このセクションでは、設定が正常に動作していることを確認します。

特定の show コマンドが、アウトプットインタープリタ ツール登録ユーザ専用)(OIT)でサポートされています。OIT を使用して、show コマンド出力の解析を表示できます。



Catalyst スイッチの確認

  • Cisco IOS ソフトウェアが稼働する Catalyst スイッチ: show running-config interface interface_type interface_number

    controller-ios#show running-config interface gigabitethernet 2/1
    
     Building configuration...
     
    Current configuration : 190 bytes
    !
    interface GigabitEthernet2/1
     no ip address
     switchport
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 1,5,15,20,25,30,35,40,45,50,55,100
     switchport mode trunk
    end
  • CatOS ソフトウェアが稼働する Catalyst スイッチ:show config mod

    controller-catos> (enable) show config 2
    
    !--- このコマンドで表示されるのは、デフォルトではない設定だけです。
    !--- デフォルトとデフォルト以外の設定を両方とも表示するには、  
    !--- show config mod all コマンドを発行します。
    
    ............................
    begin
    !
    # ***** NON-DEFAULT CONFIGURATION *****
    !
    !
    #time: Sat Jan 7 2006, 08:03:04 
    !
    # default port status is enable
    !
    !
    #module 2 : 2-port 1000BaseX Supervisor
    clear trunk 2/1  2-4,6-14,16-19,21-24,26-34,36-39,41-44,46-49,51-54,56-99,101-999
    set trunk 2/1  on dot1q 1,5,15,20,25,35,40,45,50,55,100,1000-1005,1025-4094
    end
    Console> (enable)


WLAN コントローラ VLAN の確認

このドキュメントの「WLAN コントローラの VLAN 設定」セクションに、確認の手順が説明されています。



トラブルシューティング

このセクションは、設定のトラブルシューティングを行う際に参照してください。



トラブルシューティング手順

次の手順に従って、設定のトラブルシューティングを行います。

  1. WLAN コントローラから、VLAN でルーティングされるインターフェイス上に設定されたデフォルト ゲートウェイに向かって ping を実行し、次に反対方向に ping を実行します。

    • WLAN コントローラ:

      (lab5wlc4404ip15) >ping 192.168.15.1
      
      Send count=3, Receive count=3 from 192.168.15.1
    • VLAN でルーティングされるインターフェイス:

      lab1sup720ip1#ping 192.168.15.10
      
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 192.168.15.10, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = ½/4 ms
      lab1sup720ip1#
  2. ping が成功しない場合には、スイッチにパケット キャプチャまたはスニファを配備して、VLAN のタギングが適切であるかを確認します。

    注:コントローラからレイヤ 3 ゲートウェイに ping を開始するときに、それがダイナミック インターフェイスと同じサブネットに存在する場合は、コントローラがダイナミック インターフェイスからの ping の送信元であるように見えます。




関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 68100