IP : IP ルーティング

IS-IS の擬似ノード LSP について

2005 年 8 月 10 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
DIS と擬似ノード
      DIS とは何か
      DIS の選択
      擬似ノード(PSN)とは何か
      擬似ノード LSP

      ネットワーク ダイアグラム
      設定例
      IS-IS データベース
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、link-state packet (LSP; リンクステート パケット)擬似ノードについて説明します。擬似ノードとは、LAN セグメントの Designated Intermediate System(DIS; 指定中間システム)によって生成される、LAN の論理的な表現です。このドキュメントでは、ルータへの情報の伝播についても説明します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のリリースに関連するソフトウェアとハードウェアのバージョンに基づいています。

  • Cisco IOS(R) ソフトウェア リリース 12.1(5)T9

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されています。このドキュメントで使用するすべてのデバイスは、クリアな状態(デフォルト)から設定作業を始めています。対象のネットワークが実稼動中である場合には、すべてのコマンドによる潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

DIS と擬似ノード

このセクションでは、DIS と擬似ノードについて説明します。

DIS とは何か

ブロードキャスト マルチアクセス ネットワークでは、1 つのルータが DIS として選択されます。バックアップ DIS は選択されません。DIS は擬似ノードを作成し、擬似ノード の代わりに機能するルータです。

DIS は、2 つの主要なタスクを行います。

  • ブロードキャスト サブネットワーク上のすべてのシステムにリンクの報告を行うため、擬似ノード LSP を作成し、更新します。詳細については、「擬似ノード LSP」のセクションを参照してください。

  • LAN 上で LSP をフラッディングする。

LAN 上でフラッディングするということは、DIS は次に情報をまとめた Complete Sequence Number PDU(CSNP)を定期的に(デフォルト設定は 10 秒)送信することになります。

  • シーケンス番号

  • Checksum

  • 残りのライフタイム

DIS はフラッディングに使用されます。DIS は、自分が接続されている各 LAN の、自分が参加する各ルーティング レベル(レベル 1 またはレベル 2)ごとに、新しい擬似ノード LSP を 1 つ作成し、フラッディングします。IS-IS の優先順位またはレイヤ 2 アドレスによって、ルータは接続されているすべての LAN の DIS にもなり得るし、接続されている LAN のサブセットの DIS にもなり得ます。DIS は、隣接ルータとの隣接関係が確立、切断、またはリフレッシュ インターバル タイマーが時間切れになったときにも新しい擬似ノード LSP を作成し、フラッディングします。DIS のメカニズムは、LAN のフラッディング量を削減します。

DIS の選択

LAN では、インターフェイスの優先順位(デフォルトは 64)に基づいて、ルータの 1 つが自分自身を DIS に選択します。インターフェイスの優先順位がすべて同じ場合は、Subnetwork Point of Attachment (SNPA)の最も大きいルータが選ばれます。SNPA は LAN 上では MAC アドレスであり、フレーム リレー ネットワークではローカルな Data-Link Connection Identifier(DLCI; データリンク接続識別子)です。SNPA が DLCI で、リンクの両側の DLCI が同じ場合には、システム ID が大きい方のルータが DIS になります。各 IS-IS ルータのインターフェイスは、L1 と L2 両方の優先順位が 0 から 127 の範囲で割り当てられています。

DIS の選択は、(OSPF と異なり)プリエンプティブです。LAN で新しいルータが起動した場合に、そのルータのインターフェイスの優先順位がより高ければ、そのルータが DIS になります。このルータは古い擬似ノード LSP を削除し、新しい LSP セットをフラッディングします。

擬似ノード(PSN)とは何か

マルチアクセス リンクのノード間で、フル メッシュ構造の隣接関係を減らすために、マルチアクセス リンクそのものを擬似ノードとしてモデル化します。これは名前のとおり、仮想的なノードです。DIS は擬似ノードを作成します。DIS を含め、ブロードキャスト リンクにあるすべてのルータは擬似ノードとの隣接関係を形成します。

擬似ノードの表示:

pseodonode.gif

IS-IS では、DIS は隣接ルータと同期しません。DIS は LAN の擬似ノードを作成した後、各レベル(1 および 2)の hello パケットを 3 秒おきに送信し、また CSNP を 10 秒おきに送信します。hello パケットはこの DIS が LAN のそのレベルの DIS であることを示し、CSNP は LSP ID、シーケンス番号、チェックサム、および残りのライフタイムを含む、すべての LSP の要約を記述しています。LSP は常にマルチキャスト アドレスにフラッディングされますが、CSNP のメカニズムは失われた Protocol Data Unit(PDU)を補正するだけです。たとえば、 あるルータが Partial Sequence Number Packet(PSNP)を使用して消失した LSP を DIS に要求したり、反対に新しい LSP を DIS に提供する場合もあります。

CSNP は、1 つのルータのデータベースにあるすべての LSP の情報を他のルータに伝えるために使用されます。PSNP は、OSPF の Database Descriptor(DBD)パケットと同様、LSP を要求し、LSP の受信を通知をするために使用されます。

擬似ノード LSP

擬似ノード LSP は、DIS によって生成されます。DIS はメトリック 0 で、すべての LAN 隣接ルータ(DIS を含む)を擬似ノード LSP内にレポートします。DIS を含む LAN のすべてのルータは、自分の LSP 内に擬似ノードへの接続性をレポートします。これは OSPF における、ネットワーク LSA の概念と似ています。

次のネットワーク ダイアグラムを使用して、すべての LAN 隣接ルータを報告する際に DIS の生成した擬似ノード LSP がどのように使用されるかを説明します。

注: 下の例では、ダイナミック ホスト名の機能がイネーブルになっています。そのため、下の show コマンドの出力では、ルータのホスト名にシステム ID が自動的にマップされています。

ネットワーク ダイアグラム

isis-pnode.jpg

設定例

ネットワーク ダイアグラム のルータには、次の設定が使用されました。

ルータ ISIS

Router 6
        interface e0
        ip address 172.16.126.6 255.255.255.0 
        ip router isis
        Isis priority 127
        router isis
        net 49.0001.0000.0c4a.4598.00
        is-type level-1
   Router 2
        interface e0
        ip address 172.16.126.2 255.255.255.0
        ip router isis
        router isis
        net 49.0001.0000.0c8d.e6b4.00
        is-type level-1
   Router 1
        interface e0
        ip address 172.16.126.1 255.255.255.0
        ip router isis
        interface s1
        ip address 172.16.1.1 255.255.255.0
        ip router isis
        router isis
        net 49.0001.0000.5c75.d0e9.00
        is-type level-1
   Router 8
        interface s1
        ip address 172.16.1.8 255.255.255.0
        ip router isis
        router isis
        net 49.0001.0000.0c31.c2fd.00
        is-type level-1c

次の表は、上に設定されているルータごとに、領域、MAC アドレス、およびネットワークを分類したものです。すべてのルータが同じ領域に属していることに注意してください。

ルータ

領域

MAC アドレス

NET(Network Entity Title)

6

49.0001

0000.0c4a.4598

49.0001.0000.0c4a.4598.00

2

0000.0c8d.e6b4

49.0001.0000.0c8d.e6b4.00

1

0000.5c75.d0e9

49.0001.0000.5c75.d0e9.00

8

0000.0c31.c2fd

49.0001.0000.0c31.c2fd.00

このセクションで設定されているルータでは、show clns is-neighbor コマンドを使用して IS-IS 隣接ルータを表示できます。

router-6# show clns is-neighbor
 System Id      Interface   State  Type Priority  Circuit Id         Format
 router-2       Et0         Up     L1   64        router-6.01        Phase V
 router-1       Et0         Up     L1   64        router-6.01        Phase V
 router-6#
 router-2# show clns is-neighbor
 System Id      Interface   State  Type Priority  Circuit Id         Format
 router-6       Et0         Up     L1   127       router-6.01        Phase V
 router-1       Et0         Up     L1   64        router-6.01        Phase V
 router-2#
 router-1# show clns is-neighbor
 System Id      Interface   State  Type Priority  Circuit Id         Format
 router-6       Et0         Up     L1   127       router-6.01        Phase V
 router-2       Et0         Up     L1   64        router-6.01        Phase V
 router-8       Se1         Up     L1   0         00                 Phase V
 router-1#
 router-8# show clns is-neighbor
 System Id      Interface   State  Type Priority  Circuit Id         Format
 Router-1       Se1         Up     L1   0         00                 Phase V
 router-8#

上記の隣接ルータのリストで、マルチアクセス ネットワーク(イーサネット)に接続されているルータは、すべて回線 ID が同じであることに注意してください。回線 ID は、ルータが IS-IS インターフェイスを一意に識別するための 1 オクテットの数字です。インターフェイスがマルチアクセス ネットワークに接続されている場合、DIS のシステム ID に回線 ID が連結されます。これを擬似ノード ID と呼びます。イーサネット インターフェイスの下に設定されている IS-IS の優先順位により、DIS が Router 6 であることにも注意してください。

IS-IS データベース

次の出力は、前のセクションで説明した各ルータから IS-IS データベースを表示したものです。

Router-6# show isis database
 IS-IS Level-1 Link State Database:
 LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
 router-8.00-00        0x0000006E   0xFF1A        960               0/0/0
 router-6.00-00      * 0x0000006D   0xDD58        648               0/0/0
 router-6.01-00      * 0x00000069   0x6DCB        1188              0/0/0
 router-2.00-00        0x0000006D   0x59DE        589               0/0/0
 router-1.00-00        0x00000074   0xC4B0        759               0/0/0
 router-6#
 router-2# show isis database
 IS-IS Level-1 Link State Database:
 LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
 router-8.00-00        0x0000006E   0xFF1A        947               0/0/0
 router-6.00-00        0x0000006D   0xDD58        633               0/0/0
 router-6.01-00        0x00000069   0x6DCB        1172              0/0/0
 router-2.00-00      * 0x0000006D   0x59DE        577               0/0/0
 router-1.00-00        0x00000074   0xC4B0        746               0/0/0
 router-2#
 router-1# show isis database
 IS-IS Level-1 Link State Database:
 LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
 router-8.00-00        0x0000006E   0xFF1A        934               0/0/0
 router-6.00-00        0x0000006D   0xDD58        619               0/0/0
 router-6.01-00        0x00000069   0x6DCB        1158              0/0/0
 router-2.00-00        0x0000006D   0x59DE        561               0/0/0
 router-1.00-00      * 0x00000074   0xC4B0        734               0/0/0
 router-1#
 router-8# show isis database
 IS-IS Level-1 Link State Database
 LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
 router-8.00-00*       0x0000006E   0xFF1A        927           0/0/0
 router-6.00-00        0x0000006D   0xDD58        607           0/0/0
 router-6.01-00        0x00000069   0x6DCB        1147          0/0/0
 router-2.00-00        0x0000006D   0x59DE        550           0/0/0
 router-1.00-00        0x00000074   0xC4B0        723           0/0/0
 router-8#

上記の出力が示すとおり、show isis database コマンドは、データベース内の LSP のリストを表示します。この場合、すべてのルータが同じ領域の Level 1 ルータであるため、IS-IS データベースにはすべて同じ LSP が含まれています。各ルータが 1 つの LSP を生成することに注意してください。DIS は自分の LSP を生成するとともに、擬似ノードに代わって LSP も生成します。この例では、擬似ノード LSP は 0000.0C4A.4598.01-00 です。

LAN 上のルータは、その LAN の擬似ノードにだけアドバタイズメントを送信すると説明しました。次のshow isis database lsp detail コマンドの出力例が示すように、擬似ノードはメトリック 0 で、擬似ノード LSP 内にすべての LAN 隣接ルータをレポートします。

  • (Router 8 から見た)Router 6 LSP

    Router 6 は、自分が直接接続しているネットワークと擬似ノードにだけ到達できることをアドバタイズしていることに注意してください。この場合、擬似ノードのメトリックは 10 です。すでに説明したとおり、LAN 上のルータは、LAN の擬似ノードにだけ到達が可能であることをアドバタイズします。

    router-8# show isis database router-6.00-00 detail
     IS-IS Level-1 LSP router-6.00-00
     LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
     router-6.00-00        0x00000071   0xD55C        456           0/0/0
       Area Address: 49.0001
       NLPID:       0xCC 
       Code:   137 Length: 8
       IP Address:  172.16.126.6
       Metric: 10 IP 172.16.126.0 255.255.255.0
       Metric: 10 IS router-6.01
     router-8#
  • (Router 8 から見た)擬似ノード LSP

    擬似ノード LSP は、メトリック 0 での LAN 隣接ルータをすべてアドバタイズします。擬似ノードに代わり、この場合は Router 6 で、DISによって擬似ノード LSP が生成されます。

    Router-8# show isis database router-6.01-00 detail
     IS-IS Level-1 LSP router-6.01-00
     LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
     router-6.01-00        0x0000006D   0x65CF        759           0/0/0
       Metric: 0  IS router-6.00
       Metric: 0  IS router-2.00
       Metric: 0  IS router-1.00
     router-8#
  • (Router 8 から見た)Router 2 LSP

    再度、Router 2 LSP には、直接接続しているネットワークと擬似ノードのみへ、到達が可能かどうかの情報が含まれています。

    Router-8# show isis database router-2.00-00 detail
     IS-IS Level-1 LSP router-2.00-00
     LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
     router-2.00-00        0x00000072   0x4FE3        791           0/0/0
       Area Address: 49.0001
       NLPID:       0xCC 
       Code:   137 Length: 8
       IP Address:  172.16.126.2
       Metric: 10 IP 172.16.126.0 255.255.255.0
       Metric: 10 IS router-6.01
     router-8#
  • (Router 8 から見た)Router 1 LSP

    Router 1 LSP に含まれている LAN ネットワークの情報は、ネットワークそのものと擬似ノードへの到達が可能かどうかの情報です。Router 1 は別のネットワークであるシリアル ネットワークにも接続されているため、直接接続されているネットワークもアドバタイズされます。

    Router-8# show isis database router-1.00-00 detail
     IS-IS Level-1 LSP router-1.00-00
     LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
     router-1.00-00        0x00000079   0xBAB5        822           0/0/0
       Area Address: 49.0001
       NLPID:       0xCC 
       Code:   137 Length: 8
       IP Address:  172.16.1.1
       Metric: 10 IP 172.16.126.0 255.255.255.0
       Metric: 10 IP 172.16.1.0 255.255.255.0
       Metric: 10 IS router-6.01
       Metric: 10 IS router-8.00
     router-8#
  • Router 8 LSP

    この場合、Router 8 は LAN に接続されていないため、自分への到達が可能であることを擬似ノードにアドバタイズしません。ただし、(自分への到達が可能であることを)自分自身、Router 1、および直接接続されているネットワークにアドバタイズします。

    Router-8# show isis database router-8.00-00 detail
     IS-IS Level-1 LSP router-8.00-00
     LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
     router-8.00-00*       0x00000072   0xF71E        554           0/0/0
       Area Address: 49.0001
       NLPID:       0xCC 
       IP Address:  172.16.1.8
       Metric: 10 IP 172.16.1.0 255.255.255.0
       Metric: 10 IS router-1.00
       Metric: 0  ES router-8
     router-8#

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 49627