LAN スイッチング : バーチャル LAN/VLAN トランキング プロトコル(VLAN/VTP)

CatOS と Cisco IOS システム ソフトウェアが稼働している Catalyst スイッチ間での 802.1Q トランキング

2008 年 11 月 5 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2007 年 11 月 17 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
      背景理論
設定
      ネットワーク ダイアグラム
      設定例
確認
      show コマンド
      show コマンドの出力例
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、Catalyst OS(CatOS)システム ソフトウェアが稼働している Catalyst スイッチと、Cisco IOS(R) システム ソフトウェアが稼働しているモジュラ型レイヤ 3(L3)スイッチとの間での IEEE 802.1Q トランキングの設定例を紹介しています。CatOS が稼働するスイッチには、Catalyst 4500/4000、5500/5000、および 6500/6000 シリーズ スイッチが含まれます。Cisco IOS ソフトウェアが稼働するモジュラ型 L3 スイッチには、Catalyst 4500/4000 および Catalyst 6500/6000 シリーズ スイッチが含まれます。設定例では、Catalyst 4000(CatOS)と Catalyst 6500(Cisco IOS ソフトウェア)を使用していますが、上記のスイッチのいずれもを使用しても同じ結果が得られます。

トランキングとは、複数の VLAN からのトラフィックを、2 台のデバイス間のポイントツーポイント リンクを経由して搬送する方法です。イーサネット トランキングの実装には次の 2 つの方法があります。

  • スイッチ間リンク プロトコル(ISL)(Cisco 独自のプロトコル)

  • 802.1Q(IEEE 標準)

前提条件

要件

Catalyst スイッチでの 802.1Q および ISL に関連するシステム要件、ガイドライン、および制限事項については、『トランキングを実装するためのシステム要件』を参照してください。

使用するコンポーネント

このドキュメントに記述されている例の作成には、次のスイッチが使用されています。

  • スーパーバイザ エンジン II(WS-X4013)を搭載し、CatOS ソフトウェア バージョン 8.1.3 が稼働している Catalyst 4000

  • Supervisor Engine 2/マルチレイヤ スイッチ フィーチャ カード 2(MSFC2)を搭載し、Supervisor Engine と MSFC2 上で Cisco IOS ソフトウェア リリース 12.1(20)E2 が稼働している Catalyst 6509

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景理論

このドキュメントで紹介しているのは、スイッチの設定ファイルと、それに関連する show コマンド使用例の出力だけです。Catalyst スイッチ間で 802.1Q トランクを設定する方法についての詳細は、『LAN 製品に関するサポート ページ』を参照してください。

802.1Q トランキングでは、トランク リンク上でネイティブ VLAN を除くすべての VLAN パケットにタグが付けられます。ネイティブ VLAN パケットは、タグ付けされずにトランク リンク上に送信されます。したがって、ネイティブ VLAN は、トランク用に設定された両スイッチ上で同じになります。このようにして、タグのないフレームを受信したときに、そのフレームが属する VLAN を推測することができます。デフォルトでは、VLAN 1 はすべてのスイッチ上でネイティブ VLAN になります。

  • CatOS の場合、ネイティブ VLAN は、set vlan vlan-id mod/port コマンドを発行して変更できます。mod/port には、トランク ポートを指定します。

  • Cisco IOS ソフトウェアの場合、ネイティブ VLAN は、トランク ポートで switchport trunk native vlan vlan-id interface コマンドを発行して変更できます。

設定

このセクションでは、このドキュメントで説明する機能を設定するための情報を提供しています。

このドキュメントの設定は、隔離されたラボ環境で実装されたものです。設定やコマンドは、ネットワークで使用する前に、それが与える可能性のある影響を必ず理解しておいてください。各デバイスがデフォルト設定になっていることを保証するため、すべてのデバイスで clear config all コマンドと write erase コマンドを発行して設定をクリアしてあります。

注:このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

このドキュメントでは、次のネットワーク構成を使用しています。

67-a.gif

設定例

このドキュメントでは、次の設定を使用しています。

注:コメントと説明は、青い斜体で示されています。

Catalyst 4000 スイッチ
#version 8.1(3)
!
!
#system web interface version(s)
!
#system
set system name  cat4000
!
#frame distribution method
set port channel all distribution mac both
!
#vtp
set vtp domain cisco

!--- この例では、VLAN Trunk Protocol(VTP)ドメイン名が両側で
!--- 同じになっています。これはダイナミック トランキング プロトコル(DTP)
!--- によるトランクの自動ネゴシエーションのために必要です。


set vtp mode client vlan

!--- この例では、VTP モードが client に設定されています。
!--- VTP モードは、使用しているネットワークの要件に従って設定します。

!--- 詳細については、
!--- 『VLAN Trunk Protocol(VTP)の説明と設定』を参照してください。


!
#ip
set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255

!--- これは管理用の IP アドレスです。

!--- 出力を省略。

!
#module 1 : 2-port 1000BaseX Supervisor
!
#module 2 empty
!
#module 3 empty
!
#module 4 empty
!
#module 5 : 48-port Inline Power Module
set vlan 2    5/13-24

!--- ポート 5/13-24 は VLAN 2 に割り当てられています。



set trunk 5/1  desirable dot1q 1-1005,1025-4094

!--- トランキング モードは desirable モードに設定されています。これは、
!--- desirableauto、または on モードに設定されている隣接ポートと
!--- このポートが動的にトランクの構成を試みることを意味しています。

!--- 推奨されるトランク モードの設定については、
!--- 『CatOS が稼働する Catalyst 4500/4000、5500/5000 および 6500/6000 シリーズ 
スイッチの設定と管理のベスト プラクティス』の「ダイナミック トランキング プロトコル」
セクションを参照してください。

!--- 出力を省略。


set spantree portfast    5/2-24 enable
set port channel 5/2-24 mode off

!--- マクロ コマンドの set port host 5/2-24 は、トランキングの無効化、
!--- ポート チャネリングの無効化、スパンツリー PortFast の有効化という
!--- 3 つのことを行うために使用されています。

!--- set port host コマンドの使用方法についての詳細は、
!--- 『PortFast と他のコマンドを使用したワークステーションの接続始動遅延の修復』
!--- を参照してください。

!
#module 6 empty
end

Catalyst 6500 スイッチ
Current configuration : 4408 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6500
!
boot system flash sup-bootflash:c6sup22-jsv-mz.121-20.E2
enable password mysecret

!--- これはこの例で使用している特権モードのパスワードです。


!
ip subnet-zero
!
!
!
mls flow ip destination
mls flow ipx destination
!
redundancy
 mode rpr-plus
 main-cpu
  auto-sync running-config
  auto-sync standard
!
!
!
interface GigabitEthernet2/1
 no ip address
 shutdown
!
interface GigabitEthernet2/2
 no ip address
 shutdown
!
interface fastethernet3/1
 switchport

!--- インターフェイスをレイヤ 2 ポートとして設定するには、switchport コマンドを
!--- 1 回、キーワードなしで入力します。
!--- ここでは、このインターフェイスは、デフォルト コマンドの
!--- switchport mode dynamic desirable で自動的に設定されます。

!--- これは、このインターフェイスで、desirableauto、または on モードの
!--- 隣接ポートと、トランキングのカプセル化の自動ネゴシエーションとトランク リンクの構築
!---(DTP を使用)を行う準備ができていることを意味しています。

!--- 推奨されるトランク モードの設定については、
!--- 『Cisco IOS が動作している Catalyst 6500/6000 シリーズおよび 4500/4000 シリーズ
!--- スイッチのベスト プラクティス』の「ダイナミック トランキング プロトコル」
セクションを参照してください。




!
interface FastEthernet3/2
 switchport
 switchport mode access
 spanning-tree portfast


!--- interface range fastethernet mod/beginport - endport コマンドは、
!--- インターフェイス 3/2 - 24 を同時に設定するために使用しています。

!--- 次に、switchport コマンドを発行します(まだ発行されていない場合)。


switchport mode access
 spanning-tree portfast

!--- 次に、マクロ コマンドの switchport host 3/2 - 24 を発行して、
!--- 自動的にこれらのポートをアクセス ポートとして設定し、
!--- スパンツリー PortFast を有効にします。

!--- switchport host コマンドの使用方法についての詳細は、
!--- 『PortFast と他のコマンドを使用したワークステーションの接続始動遅延の修復』
!--- を参照してください。


!
interface FastEthernet3/13
 switchport
 switchport access vlan 2

!--- インターフェイス 3/13 - 24 は、
!--- switchport access vlan 2 コマンドを使用して VLAN 2 上に配置されます。


 switchport mode access
 spanning-tree portfast


!--- 出力を省略。


!
interface FastEthernet3/24
 shutdown
 switchport
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast


!--- 出力を省略。

!
interface FastEthernet3/48
 no ip address
 shutdown
!
interface vlan 1
 ip address 10.10.10.3 255.255.255.0

!--- これは管理用の IP アドレスです。

!
ip classless
no ip http server
!
!
!
line con 0
line vty 0 4
 password mysecret


!--- これはこの例で使用している Telnet のパスワードです。


 login
 transport input lat pad mop telnet rlogin udptn nasi
!
!
end

cat6500#

確認

このセクションでは、設定が適切に機能していることの確認に利用できる情報を提供しています。

show コマンド

特定の show コマンドは、アウトプットインタープリタ登録ユーザ専用)によってサポートされています。これにより、show コマンド出力の分析を表示できます。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

CatOS が稼働している Catalyst スイッチでは、次のコマンドを使用します。

  • show port capabilities module/port

  • show port module/port

  • show trunk module/port

  • show vtp domain

Cisco IOS ソフトウェアが稼働している Catalyst 6000 スイッチでは、次のコマンドを使用します。

  • show interfaces interface-type module/port trunk

  • show vlan

show コマンドの出力例

Catalyst 4000 スイッチ

show port capabilities module/port コマンドは、このポートでトランキングが可能かどうかを確認するために使用します。

cat4000> (enable) show port capabilities 5/1
Model                    WS-X4148-RJ45V
Port                     5/1
Type                     10/100BaseTX
Speed                    auto,10,100
Duplex                   half,full
Trunk encap type         802.1Q
Trunk mode               on,off,desirable,auto,nonegotiate
Channel                  5/1-48
Flow control             no
Security                 yes
Dot1x                    yes
Membership               static,dynamic
Fast start               yes
QOS scheduling           rx-(none),tx-(2q1t)
CoS rewrite              no
ToS rewrite              no
Rewrite                  no
UDLD                     yes
Inline power             auto,off,static
AuxiliaryVlan            1..1000,1025..4094,untagged,none
SPAN                     source,destination,reflector
Link debounce timer      yes
IGMPFilter               yes
Dot1q-all-tagged         no
cat4000> (enable)

show port module/port コマンドは、あるポートの状態と、これがトランキングを行っているかどうかを表示します。

cat4000> (enable) show port status 5/1
Port  Name               Status     Vlan       Level  Duplex Speed Type
----- ------------------ ---------- ---------- ------ ------ ----- ------------
 5/1                     connected  trunk      normal a-full a-100 10/100BaseTX
cat4000> (enable)

show trunk コマンドは、トランキングの状態と設定を確認するために使用します。

cat4000> (enable) show trunk
* - indicates vtp domain mismatch
# - indicates dot1q-all-tagged enabled on the port
Port      Mode         Encapsulation  Status        Native vlan
--------  -----------  -------------  ------------  -----------
 5/1      desirable    dot1q          trunking      1

Port      Vlans allowed on trunk
--------  ---------------------------------------------------------------------
 5/1      1-1005,1025-4094

Port      Vlans allowed and active in management domain
--------  ---------------------------------------------------------------------
 5/1      1-2

Port      Vlans in spanning tree forwarding state and not pruned
--------  ---------------------------------------------------------------------
 5/1      1-2
cat4000> (enable)

show vtp domain コマンドは、VTP 情報を確認するために使用します。

cat4000> (enable) show vtp domain 
Version      : running VTP1 (VTP3 capable)
Domain Name  : cisco                            Password  : not configured
Notifications: disabled                         Updater ID: 10.10.10.3

Feature        Mode           Revision
-------------- -------------- -----------
VLAN           Client         21

Pruning             : disabled
VLANs prune eligible: 2-1000

Catalyst 6500 スイッチ

show interfaces interface-type module/port trunk コマンドは、このポートがトランキングを行っているかどうかを示します。

cat6500# show interfaces fastethernet 3/1 trunk

Port      Mode         Encapsulation  Status        Native vlan
Fa3/1     desirable    n-802.1q       trunking      1

Port      Vlans allowed on trunk
Fa3/1     1-4094

Port      Vlans allowed and active in management domain
Fa3/1     1-2

Port      Vlans in spanning tree forwarding state and not pruned
Fa3/1     1-2
cat6500#

show vlan コマンドでは、VLAN と特定の VLAN に属しているポートに関する情報が表示されます。

cat6500# show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa3/2, Fa3/3, Fa3/4, Fa3/5
                                          Fa3/6, Fa3/7, Fa3/8, Fa3/9
                                          Fa3/10, Fa3/11, Fa3/12
2    VLAN0002                         active    Fa3/13, Fa3/14, Fa3/15, Fa3/16
                                          Fa3/17, Fa3/18, Fa3/19, Fa3/20
                                          Fa3/21, Fa3/22, Fa3/23, Fa3/24
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup


!--- 出力を省略。
    
cat6500#

注:レイヤ 2 の非トランク ポートとして設定されているポートだけが表示されます。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 8760