ストレージ ネットワーキング : 他のストレージ ネットワーキング

FCIP を使用して MDS を MDS 802.1Q に設定する

2005 年 10 月 28 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 10 月 28 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
背景説明
設定
      ネットワーク ダイアグラム
      設定例
確認
トラブルシューティング
      ネイティブ VLAN のミスマッチについて
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、MDS に 802.1Q Multilayer Director Switch(MDS)を使用した Fibre Channel Over TCP/IP(FCIP)の設定例を紹介します。

FCIP は、単一の Fibre Channel(FC; ファイバ チャネル)ファブリック内に統合された SAN を形成するために、IP ベースのネットワーク上で Fibre Channel(FC; ファイバ チャネル)ストレージ エリア ネットワーク(SAN)のアイランド間での相互接続を可能にするメカニズムです。 ローカル エリア ネットワーク、メトロポリタン エリア ネットワーク、あるいはワイド エリア ネットワーク上の SAN アイランド間での FCIP による接続は、IP ベースのネットワーク サービスにより成立しています。

FCIP で接続されるファイバ チャネル SAN

ips8_dot1q_1.gif

FCIP では、ネットワーク層の転送にポート 3225 の Transmission Control Protocol(TCP; 伝送制御プロトコル)が使用されます。

前提条件

要件

IP バックボーンが動作中で、これにより FCIP リンク上で稼動しているアプリケーションをサポートするために必要な帯域幅が提供されている必要があります。これは、レイヤ 2(L2)またはレイヤ 3(L3)トポロジです。 これが L3 トポロジの場合、中継ルータまたはマルチレイヤ スイッチの設定により、FCIP トンネルの送信元と宛先の IP アドレス間で IP トラフィックが適切に送信されるように設定する必要があります。 FCIP ピア間のパスにあるネットワーク デバイスで、Quality of Service(QoS)またはトラフィック シェーピングが必要となった場合は、TCP 関連のパラメータや Multilayer Director Switch(MDS)FCIP プロファイルの機能を設定する前に、IP インフラストラクチャを管理しているネットワーク管理者に連絡して必要な情報を入手する必要があります。 MDS の IP Storage(IPS; IP ストレージ)サービス モジュールでサブインターフェイスが設定されている場合は、MDS と隣接関係にあるイーサネットのスイッチでは 802.1Q トランキングがサポートされており、さらに、802.1Q トランキングに設定されている必要があります。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • バージョン 1.2.(2a) が稼動する IPS サービス モジュール(DS-X9308-SMIP)が搭載された MDS 9509

  • バージョン 1.2.(2a) が稼動する IPS サービス モジュール(DS-X9308-SMIP)が搭載された MDS 9216

  • Catalyst OS(CatOS)7.4(3) が稼動する Catalyst 6509

  • Emulex LP9K HBA が搭載された Win2003 Server(HPQ Pro-Liant-P4)

  • IBM Storage Array(ESS-2105-F20)

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメント内で使用されているデバイスはすべて、クリアな状態(デフォルト)から設定作業を始めています。対象のネットワークが実稼動中である場合には、すべてのコマンドによる潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

FCIP の仕様は次のとおりです。

ANSI T11

  1. FC-SW-2 は、E_Port とファブリック動作を含む FC スイッチの動作とインタラクションに関する規定です。

  2. FC-BB-2 は、TCP ネットワーク バックボーン上での FC スイッチによるネットワークの拡張に適したマッピングで、E_Port と B_Port をサポートする参照モデルが定義されています。

IETF IPS ワーキング グループ

  1. FC over TCP では、IP ネットワーク上で FC フレームを転送する場合の TCP/IP 要件が規定されています。

  2. FC フレームのカプセル化では、共通のファイバ カプセル化フォーマットが定義されています。

IEEE 802 標準

ISO/IEC 15802-3 で定義されているように、MAC ブリッジを介してあらゆるタイプの IEEE 802 LAN が接続できます。ブリッジングされた LAN インフラストラクチャ内での VLAN トポロジの定義、動作、管理を許可する VLAN ブリッジの動作が、この標準で定義されています。

FCIP での 2 つの SAN スイッチ間、またはファブリック間の相互接続は FCIP リンクと呼ばれ、1 つまたは複数の TCP 接続が可能です。 FCIP リンクの両端は、Virtual E port(VE_port)か B_port に関連付けられます。これは実装によって異なります。 FC-BB と FC-BB-2 では、両方のアプローチの違いについて説明されています。 IP サービス モジュール(DS-X9308-SMIP)では両方のモードがサポートされていますが、デフォルトでは VE_Port となっています。これは、すべての関連ピアが DS-X9308-SMIP モジュールの場合に推奨されるモードでもあります。 MDS プラットフォームでの VE_Port の機能では、TE ポート機能もサポートされています。これによって、1 つの FCIP インスタンス上の複数の仮想 SAN(VSAN)からのトラフィックのトランキングが可能になります。 Cisco X9308-SMIP モジュールに装備されている Gigabit Ethernet(GE; ギガビット イーサネット)インターフェイスでは、FCIP トンネルごとに低帯域幅が必要とされるような状況で、複数の FCIP トンネル間で 1 Gbps の帯域幅の利用するために、802.1Q がサポートされています。 FCIP プロファイルの TCP パラメータがデフォルトの状態のままである場合は、dot1q を使用して帯域幅を共有しても、FCIP トンネルごとの確定的な帯域幅は割り当てられないことを理解しておく必要があります。

設定

MDS については、両方のプラットフォームの IPS 設定ガイドを熟知している必要があります。 これらのマニュアルの最新バージョンは、Cisco.com の『IP ストレージの設定』にあります。イーサネット スイッチ側については、dot1q トランキング設定の仕様について熟知している必要があります。 ここに示す例では、Hybrid CatOS が稼動している Catalyst が配備されています。他の Cisco スイッチや他のベンダーのスイッチでは適用する設定が異なる場合があります。

ハイブリッド モードで稼動している Catalyst 6000 シリーズの詳細は、『イーサネット VLAN トランクの設定』を参照してください。 Native IOS の詳細は、『VLAN の設定』を参照してください。 Native IOS が稼動している Catalyst XL タイプのスイッチの詳細は、『VLAN の設定』を参照してください。

注:このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool を使用してください(登録ユーザ専用)。

ネットワーク ダイアグラム

このドキュメントでは次の図に示すネットワーク構成が使用されています。

トポロジ 2

ips8_dot1q_2.gif

トポロジ 2 は、IP クラウドのどちらか一方の側で、802.1Q トランクで稼動している 1 つの FCIP トンネルを表しています。 VLAN 1000 から VLAN 500、および VLAN 500 から VLAN 1000 へのトラフィックをルーティングしている 1 台のマルチレイヤ スイッチ(Catalyst 6500)が IP クラウドと見なされます。概念的には、VLAN 1000 は IP サブネット 100.100.100.0/30 にマップし、VLAN500 は IP サブネット 100.100.100.4/30 にマップします。MDS でマッピングを行って dot1q フレームを取得する方法は、後述の「設定」のセクションで説明します。 例を簡単にするために、両方の MDS 上で 1 つの物理インターフェイスに 1 つの FCIP トンネルが定義されています。複数の FCIP トンネル間で 1 ギガビット インターフェイスの帯域幅を共有するには、dot1q トランキングだけが使用されます。

設定例

IPS-8 モジュールを搭載した MDS 9509(Bison)

bison# sh ver
 Cisco Storage Area Networking Operating System (SAN-OS) Software
 TAC support: http://www.cisco.com/tac
 Copyright (c) 2002-2003 by Cisco Systems, Inc. All rights reserved.
 The copyright for certain works contained herein are owned by
 Andiamo Systems, Inc. and/or other third parties and are used and
 distributed under license.
 Software
 BIOS: version 1.0.8
 loader: version 1.2(2)
 kickstart: version 1.2(2a)
 system: version 1.2(2a)
 BIOS compile time: 08/07/03
 kickstart image file is: bootflash:/k122a
 kickstart compile time: 9/23/2003 11:00:00
 system image file is: bootflash:/s122a
 system compile time: 10/8/2003 18:00:00
 Hardware
 RAM 1024584 kB
 bootflash: 500736 blocks (block size 512b)
 slot0: 0 blocks (block size 512b)
 bison uptime is 1 days 15 hours 45 minute(s) 44 second(s)
 Last reset 
 Reason: Unknown
 System version: 1.2(2a)
 Service: 
 bison# sh run
 Building Configuration ...
 fcip profile 1
 ip address 100.100.100.1
 
 !--- FCIP プロファイル 1 がローカルの関連 IPS インターフェイスにバインドされます。 
 !---  この例では、インターフェイス Gig4/1 の IP アドレスです。
 
 vsan database
 vsan 200 name test 
 vsan 600 
 vsan 601 
 fcdomain priority 1 vsan 1
 fcdomain domain 1 preferred vsan 1
 fcdomain domain 1 preferred vsan 600
 fcdomain domain 1 preferred vsan 601
 interface fcip1
 no shutdown
 switchport trunk allowed vsan 600-601
 use-profile 1
 peer-info ipaddr 100.100.100.6
 
 <!--- ピア IP アドレスはリモート MDS Canterbury のアドレスで、
 <!--- インターフェイス Gig4/1.500 で設定されます。
 
 vsan database
 vsan 600 interface fc3/1
 vsan 601 interface fc3/8
 boot system bootflash:/s122a sup-1
 boot kickstart bootflash:/k122a sup-1
 boot system bootflash:/s122a sup-2
 boot kickstart bootflash:/k122a sup-2
 boot asm-sfn bootflash:/ilc1.bin module 4
 ip domain-name cisco.com
 ip name-server 144.254.10.123
 ip default-gateway 10.48.69.129
 ip route 100.100.100.4 255.255.255.252 100.100.100.2 distance 2
 
 !--- ネクストホップ IP アドレスは 100.100.100.2 で、
 !--- 中継イーサネット マルチレイヤ スイッチ
 !---  Aspendos のものです。
 
 zone name z-fcip2 vsan 600
 member pwwn 50:05:07:63:00:d0:94:4c
 member pwwn 10:00:00:00:c9:32:a6:e3
 zone name Zone_a1 vsan 601
 member pwwn 10:00:00:00:00:01:00:00
 member pwwn 10:00:00:00:00:05:00:00
 zone default-zone permit vsan 1
 zone default-zone permit vsan 603
 zoneset distribute full vsan 600
 zoneset name zs-fcip2 vsan 600
 member z-fcip2
 zoneset name Agilent_1 vsan 601
 member Zone_a1
 zoneset activate name zs-fcip2 vsan 600
 zoneset activate name Agilent_1 vsan 601
 interface fc3/1
 no shutdown
 
 !--- 出力を省略
 
 interface fc3/8
 no shutdown
 interface mgmt0
 ip address 10.48.69.151 255.255.255.192
 interface GigabitEthernet4/1
 no shutdown
 interface GigabitEthernet4/1.1000
 ip address 100.100.100.1 255.255.255.252
 switchport mtu 3000
 no shutdown
 
 !--- サブインターフェイス 1000 が設定されました。
 !--- イーサネット スイッチの dot1q VLAN 1000 に結合されます。 
 !--- 中継スイッチが L2 および L3 で
 !--- ジャンボ フレームをサポートするため、MTU サイズが
 !--- デフォルトの 1500 バイトから 3000 バイトに変更されました。
 
 

IPS-8 モジュールを搭載した MDS 9216(Canterbury)

canterbury# sh run
 Building Configuration ...
 fcip profile 1
 ip address 100.100.100.6
 vsan database
 vsan 600 
 vsan 601 
 fcdomain domain 2 preferred vsan 600
 fcdomain domain 2 preferred vsan 601
 interface fcip1
 use-profile 1
 peer-info ipaddr 100.100.100.1
 vsan database
 vsan 600 interface fc1/1
 vsan 601 interface fc1/8
 boot system bootflash:/s122a 
 boot kickstart bootflash:/k122a 
 fcalias name test vsan 1
 ip domain-name cisco.com
 ip name-server 144.254.10.123
 ip default-gateway 10.48.69.129
 ip route 10.61.0.0 255.255.0.0
 ip route 10.61.0.0 255.255.0.0 10.48.69.200
 ip route 100.100.100.0 255.255.255.252 100.100.100.5 distance 2
 
 !--- FCIP ピア アドレスに到達するために必要なスタティック IPS ルート。
  
 line vty
 exec-timeout 0
 switchname canterbury
 system default switchport trunk mode auto
 zone name z-fcip2 vsan 600
 member pwwn 50:05:07:63:00:d0:94:4c
 member pwwn 10:00:00:00:c9:32:a6:e3
 zone default-zone permit vsan 777
 zoneset distribute full vsan 600
 zoneset name zs-fcip2 vsan 600
 member z-fcip2
 zoneset activate name zs-fcip2 vsan 600
 zoneset activate name Agilent_1 vsan 601
 interface GigabitEthernet2/1
 no shutdown
 interface GigabitEthernet2/1.500
 ip address 100.100.100.6 255.255.255.252
 switchport mtu 3000
 no shutdown
 interface fc1/1
 no shutdown
 interface fc1/8
 no shutdown
 interface mgmt0
 ip address 10.48.69.156 255.255.255.128

IPS-8 モジュールを搭載した Catalyst 6000(Aspendos)

Aspendos> (enable) sh vlan 500
 VLAN Name                             Status    IfIndex Mod/Ports, Vlans
 ---- -------------------------------- --------- ------- -------------------
 500  VLAN0500                         active    191     1/1
                                                         3/3
                                                         15/1
 VLAN Type SAID MTU  Parent RingNo BrdgNo Stp    Brdg   Mode   Trans1 Trans2
 ---- ---- ---- ---- ------ ------ ------ ------ ------ ------ ------ ------
 500  enet 100  500  1500   -      -      -      -      -      0      0
 VLAN MISTP-Inst DynCreated RSPAN
 ---- ---------- ---------- --------
 500  -          static     disabled
 Aspendos> (enable) sh vlan 1000
 VLAN Name                             Status    IfIndex Mod/Ports, Vlans
 ---- -------------------------------- --------- ------- -------------------
 1000 fcip-extra-hop                   active    131     3/7
                                                         15/1
 VLAN Type SAID MTU  Parent RingNo BrdgNo Stp    Brdg   Mode   Trans1 Trans2
 ---- ---- ---- ---- ------ ------ ------ ------ ------ ------ ------ ------
 1000 enet 101  000  1500   -      -      -      -      -      0      0
 VLAN MISTP-Inst DynCreated RSPAN
 ---- ---------- ---------- --------
 1000 -          static     disabled
 Aspendos> (enable) sh trunk 3/3
 * - indicates vtp domain mismatch
 Port Mode Encapsulation Status        Native vlan
 ---- ---- ------------- ------------- -----------
 3/3  on   dot1q         trunking      1
 Port Vlans allowed on trunk
 ---- ----------------------------------------------------------------------
 3/3  1,500
 Port Vlans allowed and active in management domain 
 ---- ----------------------------------------------------------------------
 3/3  1,500
 Port Vlans in spanning tree forwarding state and not pruned
 ---- ----------------------------------------------------------------------
 3/3  1,500
 Aspendos> (enable) sh trunk 3/7
 * - indicates vtp domain mismatch
 Port Mode Encapsulation Status       Native vlan
 ---- ---- ------------- ------------ -----------
 3/7  on   dot1q         trunking     1
 Port Vlans allowed on trunk
 ---- ----------------------------------------------------------------------
 3/7  1,1000
 Port Vlans allowed and active in management domain 
 ---- ----------------------------------------------------------------------
 3/7  1,1000
 Port Vlans in spanning tree forwarding state and not pruned
 ---- ----------------------------------------------------------------------
 3/7  1,1000
 
 !--- VLAN 500 は、ポート 3/3 でトランクされることに注意してください。
 !--- これは、物理的には MDS Canterbury に接続されています。
 !--- ポート 3/7 の VLAN 1000 トランクは MDS Bison に接続されています  ポート 15/1 は内部ポートで、
 !--- スイッチ内のマルチレイヤ エンティティにダイレクトされています。
 
 Aspendos> (enable) sh port jumbo 
 Jumbo frames MTU size is 9216 bytes.
 Jumbo frames enabled on port(s) 1/2,3/1-16.
 
 !---  関係するすべてのポートで L2 のジャンボ サポートを有効にします。
  
 Aspendos> (enable) sh spantree 3/3 
 Port Vlan Port-State Cost Prio Portfast Channel_id
 ---- ---- ---------- ---- ---- -------- ----------
 3/3  1    forwarding 4    32   disabled 0 
 3/3  500  forwarding 4    32   disabled 0 
 Aspendos> (enable) sh spantree 3/7
 Port Vlan Port-State Cost Prio Portfast Channel_id
 ---- ---- ---------- ---- ---- -------- ----------
 3/7  1    forwarding 4    32   disabled 0 
 3/7  1000 forwarding 4    32   disabled 0 
 Aspendos> (enable) sh spantree 15/1
 Port Vlan Port-State Cost Prio Portfast Channel_id
 ---- ---- ---------- ---- ---- -------- ----------
 15/1 192  forwarding 4    32   enabled  0 
 15/1 500  forwarding 4    32   enabled  0 
 15/1 691  forwarding 4    32   enabled  0 
 15/1 1000 forwarding 4    32   enabled  0
 
 !--- Catalyst 上の関係するすべてのポートで、
 !--- 対応する VLAN への転送が行われています。
 
 Aspendos> (enable) ses 15
 Trying Router-15...
 Connected to Router-15.
 Escape character is '^]'.
 User Access Verification
 Password: 
 Aspendos_MSFC2> en
 Password: 
 Aspendos_MSFC2#
 !
 interface Vlan500
 mtu 3000
 ip address 100.100.100.5 255.255.255.252
 end
 Aspendos_MSFC2# sh run int vlan 1000
 Building configuration...
 Current configuration : 113 bytes
 !
 interface Vlan1000
 description "test-vlan-fcip-1000"
 mtu 3000
 ip address 100.100.100.2 255.255.255.252
 end
 
 !--- VLAN 500 と 1000 が Catalyst 6000 の MSFC で
 !--- 適切に設定されます。
 !--- 両方のサブネットが同一のイーサネット スイッチに
 !--- 直接接続されているので、ルートを追加する必要はありません。 また、
 !--- MTU サイズが MDS ギガビット インターフェイスに基づいて
 !--- 3000 バイトに変更されていることに注意してください。 これは、
 !--- ジャンボ マルチレイヤ スイッチングをサポートするための変更です。
 
 

確認

このセクションでは、設定が正しく動作していることを確認するための情報が提供されています。

特定の show コマンドは、アウトプットインタープリタ登録ユーザ専用)でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

  • show interface gig x/y - FCIP プロファイルにバインドされた、関連するギガビット インターフェイスのステータスを表示します。

  • show ips stats tcp int gig x/y - TCP 統計情報と関連ギガビット インターフェイスのアクティブな接続を表示します。

  • show ips arp int gig x/y - 関連ギガビット インターフェイスのすべての Address Resolution Protocol(ARP)エントリを表示します。このリストにはネクスト ホップやピアが表示されます。

  • show ips ip route int gig x/y - 関連ギガビット インターフェイスを通過する個々のルートを表示します。

  • show interface fcip x - FCIP インターフェイスのステータスと、その FCIP トンネルに関連するすべての詳細情報を表示します。

  • show profile fcip x - プロファイルがバインドされる IP アドレスと、設定されたすべての TCP パラメータを表示します。

  • show int fcip x counters - FCIP トンネルを通るフレームのチェックに使用します。

  • show fcdomain vsan x - ドメイン関連の詳細情報を一覧表示します。FCIP トンネルにファブリックが形成されているか確認するために使用します。

  • show fcns da vsan x - 関連する VSAN の pwwn、FC4-Type、および FCID すべてを表示します。FCIP トンネルで予測されたエントリすべてが配信されているか確認するために使用します。

注:dot1q インターフェイスは、FCIP の通常の物理インターフェイスとして機能します。 正常な処理を確認するのに必要なのは、show interface gig x/y.z コマンドだけです。z はサブインターフェイスを意味します。 ローカル MDS ギガビット インターフェイスに接続しているインターフェイスやポートが適切に設定されていることを確認するには、それぞれのデバイスの関連するドキュメントを参照してください。

トラブルシューティング

カウンタ履歴を構築するには、必ず show コマンドを複数回発行してください。 一度だけ収集された、適切な時点とは無関係なカウンタは、ほとんど役に立ちません。

さらに詳細なトラブルシューティングには、次に示す設定を使用してください。

MDS 9509(Bison)

bison# sh int gig 4/1.1000
 GigabitEthernet4/1.1000 is up
     Hardware is GigabitEthernet, address is 0005.3000.a85a
     Internet address is 100.100.100.1/30
     MTU 3000 bytes
 
 !--- 3000 バイトに設定します。
 
     5 minutes input rate 488 bits/sec, 61 bytes/sec, 0 frames/sec
     5 minutes output rate 488 bits/sec, 61 bytes/sec, 0 frames/sec
     1785 packets input, 996030 bytes
       0 multicast frames, 0 compressed
       0 input errors, 0 frame, 0 overrun 0 fifo
     1812 packets output, 354152 bytes, 0 underruns
       0 output errors, 0 collisions, 0 fifo
       0 carrier errors
 
 !--- 不要な TCP セグメント化を回避し、オーバーヘッドを制限するため、
 !--- MTU を 3000 バイトに設定します。
 
 bison# sh ips stats tcp int gig 4/1 de
 TCP Statistics for port GigabitEthernet4/1
     TCP send stats
       337202017 segments, 222637392068 bytes
       130562402 data, 205533417 ack only packets
       503 control (SYN/FIN/RST), 0 probes, 1105737 window updates
       7 segments retransmitted, 2208 bytes
       4 retransmitted while on ethernet send queue, 40061909 packets split
       250922624 delayed acks sent
     TCP receive stats
       932985742 segments, 921498012 data packets in sequence, 
         936715052100 bytes in sequence
       770241 predicted ack, 856752348 predicted data
       0 bad checksum, 0 multi/broadcast, 0 bad offset
       0 no memory drops, 0 short segments
       0 duplicate bytes, 16 duplicate packets
       0 partial duplicate bytes, 0 partial duplicate packets
       53128 out-of-order bytes, 165 out-of-order packets
       0 packet after window, 0 bytes after window
       5 packets after close
       76225562 acks, 192030009160 ack bytes, 0 ack toomuch,
         5851 duplicate acks
       0 ack packets left of snd_una, 0 non-4 byte aligned packets
       9124012 window updates, 0 window probe
       1381 pcb hash miss, 984 no port, 103 bad SYN, 0 paws drops
     TCP Connection Stats
       272 attempts, 107 accepts, 163 established
       511 closed, 3 drops, 206 conn drops
       3 drop in retransmit timeout, 20 drop in keepalive timeout
       0 drop in persist drops, 0 connections drained
     TCP Miscellaneous Stats
       61792500 segments timed, 76225541 rtt updated
       124 retransmit timeout, 0 persist timeout
       5760 keepalive timeout, 5740 keepalive probes
     TCP SACK Stats
       0 recovery episodes, 0 data packets, 0 data bytes
       0 data packets retransmitted, 0 data bytes retransmitted
       0 connections closed, 0 retransmit timeouts
     TCP SYN Cache Stats
       107 entries, 107 connections completed, 0 entries timed out
       0 dropped due to overflow, 0 dropped due to RST
       0 dropped due to ICMP unreach, 0 dropped due to bucket overflow
       0 abort due to no memory, 0 duplicate SYN, 0 no-route SYN drop
       0 hash collisions, 0 retransmitted
 100.100.100.1:64860 100.100.100.6:3225 ESTABLISH 0 0
 100.100.100.1:64862 100.100.100.6:3225 ESTABLISH 0 0
 100.100.100.1:3225 0.0.0.0:0 LISTEN 0 0
 
 !--- サブインターフェイスごとに管理されているカウンタはありません。
 !--- Gig 4/1 のすべてのサブインターフェイスの統計情報がここに示されます。
 
 bison# sh ips arp interface gig 4/1
 Protocol Address Age (min) Hardware Addr Type Interface
 Internet 100.100.100.2 13 0008.e21e.c7bc ARPA GigabitEthernet4/1.1000 
 
 !--- サブインターフェイスごとに管理されている ARP テーブルはありません。
 !--- Gig 1/4 のすべてのサブインターフェイスのエントリがここにすべて示されます。
 
 bison# sh ips ip route int gig 4/1
 Codes: C - connected, S - static
 No default gateway
 S 100.100.100.4/30 via 100.100.100.2, GigabitEthernet4/1.1000
 C 100.100.100.0/30 is directly connected, GigabitEthernet4/1.1000
 
 !--- IPS ルートは、サブインターフェイスごとにではなく、
 !--- メインインターフェイスで決定されます。 ここでネクストホップが確認されます。
 
 bison# sh cdp ne int gig 4/1
 Capability Codes: R - Router, T - Trans-Bridge, B - Source-Route-Bridge
 S - Switch, H - Host, I - IGMP, r - Repeater
 Device ID   Local Intrfce Hldtme Capability Platform Port ID
 ----------- ----- ------- ------ ---------- -------- -------
 TBM06033144 (Aspe Gig4/1  136    T S        WS-C6506 3/7 
 
 !!--- ネイバーでサポートされている場合は、
 !--- 物理接続の確認に、このコマンドを使用します。
 
 bison# sh fcip profile 1
 FCIP Profile 1
 Internet Address is 100.100.100.1 (interface GigabitEthernet4/1.1000)
 Listen Port is 3225
 TCP parameters
 SACK is enabled
 PMTU discovery is enabled, reset timeout is 3600 sec
 Keep alive is 60 sec
 Minimum retransmission timeout is 200 ms
 Maximum number of re-transmissions is 4
 Send buffer size is 0 KB
 Maximum allowed bandwidth is 1000000 kbps
 Minimum available bandwidth is 15000 kbps
 Estimated round trip time is 1000 usec
 Congestion window monitoring is enabled, burst size is 10 KB 
 
 !--- FCIP インスタンスごとに設定された TCP/IP パラメータは、
 !--- プロファイル パラメータで直接確認できます。
  
 bison# sh int fcip 1
 fcip1 is trunking
 Hardware is GigabitEthernet
 Port WWN is 20:c2:00:05:30:00:7a:de
 Peer port WWN is 20:42:00:0c:30:6c:24:40
 Admin port mode is auto, trunk mode is on
 Port mode is TE
 vsan is 1
 Trunk vsans (allowed active) (1,600-601)
 Trunk vsans (operational) (1,600-601)
 Trunk vsans (up) (1,600-601)
 Trunk vsans (isolated) ()
 Trunk vsans (initializing) ()
 Using Profile id 1 (interface GigabitEthernet4/1.1000)
 Peer Information
 Peer Internet address is 100.100.100.6 and port is 3225
 Special Frame is disabled
 Maximum number of TCP connections is 2
 Time Stamp is disabled
 QOS control code point is 0
 QOS data code point is 0
 B-port mode disabled
 TCP Connection Information
 2 Active TCP connections
 Control connection: Local 100.100.100.1:64860, Remote 100.100.100.6:3225
 Data connection: Local 100.100.100.1:64862, Remote 100.100.100.6:3225
 2 Attempts for active connections, 0 close of connections
 TCP Parameters
 Path MTU 3000 bytes
 Current retransmission timeout is 200 ms
 Round trip time: Smoothed 2 ms, Variance: 1
 Advertized window: Current: 118 KB, Maximum: 118 KB, Scale: 1
 Peer receive window: Current: 118 KB, Maximum: 118 KB, Scale: 1
 Congestion window: Current: 10 KB, Slow start threshold: 112 KB
 5 minutes input rate 200 bits/sec, 25 bytes/sec, 0 frames/sec
 5 minutes output rate 200 bits/sec, 25 bytes/sec, 0 frames/sec
 1306 frames input, 891212 bytes
 472 Class F frames input, 46972 bytes
 834 Class 2/3 frames input, 844240 bytes
 0 Error frames timestamp error 0
 867 frames output, 252424 bytes
 470 Class F frames output, 48860 bytes
 397 Class 2/3 frames output, 203564 bytes
 0 Error frames 0 reass frames
 
 !--- これは、FCIP インスタンスを実行することで表示される
 !--- FCIP インターフェイスごとの詳細です。 この出力を使用して、
 !--- ピアの TCP パラメータを導出することも可能です。
 
 bison# sh fcdomain vsan 600
 The local switch is the Principal Switch.
 Local switch run time information:
 State: Stable
 Local switch WWN: 22:58:00:05:30:00:7a:df
 Running fabric name: 22:58:00:05:30:00:7a:df
 Running priority: 2
 Current domain ID: 0x01(1) 
 Local switch configuration information:
 State: Enabled
 FCID persistence: Disabled
 Auto-reconfiguration: Disabled
 Contiguous-allocation: Disabled
 Configured fabric name: 20:01:00:05:30:00:28:df
 Configured priority: 128
 Configured domain ID: 0x01(1) (preferred)
 Principal switch run time information:
 Running priority: 2
 Interface        Role          RCF-reject
 ---------------- ------------- ------------
 fcip1            Downstream    Disabled
 ---------------- ------------- ------------
 bison# sh fcdomain vsan 601
 The local switch is the Principal Switch.
 Local switch run time information:
 State: Stable
 Local switch WWN: 22:59:00:05:30:00:7a:df
 Running fabric name: 22:59:00:05:30:00:7a:df
 Running priority: 2
 Current domain ID: 0x01(1) 
 Local switch configuration information:
 State: Enabled
 FCID persistence: Disabled
 Auto-reconfiguration: Disabled
 Contiguous-allocation: Disabled
 Configured fabric name: 20:01:00:05:30:00:28:df
 Configured priority: 128
 Configured domain ID: 0x01(1) (preferred)
 Principal switch run time information:
 Running priority: 2
 Interface        Role          RCF-reject
 ---------------- ------------- ------------
 fcip1            Downstream    Disabled
 ---------------- ------------- ------------
 
 !---(E)ISL の通常のトラブルシューティングと同様に、 
 !--- ファブリックが予測どおりに形成されていることを確認します。
 
 bison# sh fcns da vsan 600-601
 VSAN 600:
 -------- ---- ----------------------- -------- ---------------------------
 FCID     TYPE PWWN                    (VENDOR) FC4-TYPE:FEATURE
 -------- ---- ----------------------- -------- ---------------------------
 0x010001 N    10:00:00:00:c9:32:a6:e3 (Emulex) scsi-fcp:init 
 0x020001 N    50:05:07:63:00:d0:94:4c (IBM)    scsi-fcp:target fc..
 Total number of entries = 2
 VSAN 601:
 -------- ---- ----------------------- -------- ---------------------------
 FCID     TYPE PWWN                    (VENDOR) FC4-TYPE:FEATURE
 -------- ---- ----------------------- -------- ---------------------------
 0x010001 N    10:00:00:00:c9:32:a6:e2 (Emulex) scsi-fcp:init 
 0x010100 N    10:00:00:00:00:05:00:00 
 0x020100 N    10:00:00:00:00:01:00:00 
 Total number of entries = 3

MDS 9216(Canterbury)

canterbury# sh int gig 2/1.500
 GigabitEthernet2/1.500 is up
     Hardware is GigabitEthernet, address is 0005.3000.ade6
     Internet address is 100.100.100.6/30
     MTU 3000 bytes
     5 minutes input rate 2248 bits/sec, 281 bytes/sec, 0 frames/sec
     5 minutes output rate 696 bits/sec, 87 bytes/sec, 0 frames/sec
     2263 packets input, 482038 bytes
       0 multicast frames, 0 compressed
       0 input errors, 0 frame, 0 overrun 0 fifo
     2479 packets output, 1077822 bytes, 0 underruns
       0 output errors, 0 collisions, 0 fifo
       0 carrier errors
 canterbury# sh cdp ne int gig 2/1
 Capability Codes: R - Router, T - Trans-Bridge, B - Source-Route-Bridge
                   S - Switch, H - Host, I - IGMP, r - Repeater
 Device ID   Local Intrfce Hldtme Capability Platform Port ID
 ----------- ----- ------- ------ ---------- -------- -------
 TBM06033144 (Aspe Gig2/1  165    T S        WS-C6506 3/3
 
 !--- ネイバーで CDP がサポートされている場合は、
 !--- このコマンドを使用して物理接続を確認します。
 
 canterbury# sh fcip profile 1
 FCIP Profile 1
 Internet Address is 100.100.100.6 (interface GigabitEthernet2/1.500)
 Listen Port is 3225
 TCP parameters
 SACK is enabled
 PMTU discovery is enabled, reset timeout is 3600 sec
 Keep alive is 60 sec
 Minimum retransmission timeout is 200 ms
 Maximum number of re-transmissions is 4
 Send buffer size is 0 KB
 Maximum allowed bandwidth is 1000000 kbps
 Minimum available bandwidth is 15000 kbps
 Estimated round trip time is 1000 usec
 Congestion window monitoring is enabled, burst size is 10 KB
 canterbury# sh int fcip 1
 fcip1 is trunking
 Hardware is GigabitEthernet
 Port WWN is 20:42:00:0c:30:6c:24:40
 Peer port WWN is 20:c2:00:05:30:00:7a:de
 Admin port mode is auto, trunk mode is auto
 Port mode is TE
 vsan is 1
 Trunk vsans (allowed active) (1,600-601)
 Trunk vsans (operational) (1,600-601)
 Trunk vsans (up) (1,600-601)
 Trunk vsans (isolated) ()
 Trunk vsans (initializing) ()
 Using Profile id 1 (interface GigabitEthernet2/1.500)
 Peer Information
 Peer Internet address is 100.100.100.1 and port is 3225
 Special Frame is disabled
 Maximum number of TCP connections is 2
 Time Stamp is disabled
 QOS control code point is 0
 QOS data code point is 0
 B-port mode disabled
 TCP Connection Information
 2 Active TCP connections
 Control connection: Local 100.100.100.6:3225, Remote 100.100.100.1:64860
 Data connection: Local 100.100.100.6:3225, Remote 100.100.100.1:64862
 0 Attempts for active connections, 0 close of connections
 TCP Parameters
 Path MTU 3000 bytes
 Current retransmission timeout is 200 ms
 Round trip time: Smoothed 2 ms, Variance: 1
 Advertized window: Current: 118 KB, Maximum: 118 KB, Scale: 1
 Peer receive window: Current: 118 KB, Maximum: 118 KB, Scale: 1
 Congestion window: Current: 10 KB, Slow start threshold: 112 KB
 5 minutes input rate 184 bits/sec, 23 bytes/sec, 0 frames/sec
 5 minutes output rate 184 bits/sec, 23 bytes/sec, 0 frames/sec
 1163 frames input, 336700 bytes
 722 Class F frames input, 72176 bytes
 441 Class 2/3 frames input, 264524 bytes
 0 Error frames timestamp error 0
 1588 frames output, 917216 bytes
 724 Class F frames output, 70288 bytes
 864 Class 2/3 frames output, 846928 bytes
 0 Error frames 0 reass frames

ネイティブ VLAN のミスマッチについて

条件によっては、隣接関係にある(Catalyst)イーサネット スイッチのシステム ログに、native vlan mismatch というエラーメッセージが表示される場合があります。 これは、それらのスイッチのトランクポートでの設定が誤っていることを示しています。 .1000 のサブインターフェイスが、MDS IP サービス モジュールのメイン インターフェイスの 1 つで設定されている場合は、その Catalyst スイッチで隣接関係にあるスイッチポートを同じ VLAN ID 1000 にトランキングする必要があります。 Catalyst で、何らかの理由で、VLAN 1000ポート VLAN またはネイティブ VLAN として実行されている場合は、エラー メッセージが生成され、接続が切断されます。これは、MDS 側からの dot1q カプセル化フレームがスイッチで識別されず、廃棄されるためです。 native vlan mismatch エラーの例を示します。

2003 Nov 13 02:36:39 %CDP-4-NVLANMISMATCH:Native vlan mismatch detected on port 3/7
 2003 Nov 13 02:37:26 %CDP-4-NVLANMISMATCH:Native vlan mismatch detected on port 3/3

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 47101