IP : IP アドレッシング サービス

NAT プールとサブネット ゼロ

2005 年 8 月 10 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2008 年 1 月 28 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      背景理論
      表記法
設定
      ネットワーク ダイアグラム
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書では、Network Address Translation(NAT; ネットワーク アドレス変換)プールが、他の IP アドレスと同様に、サブネット ゼロの影響を受けることについて説明します。

前提条件

要件

この文書に関する特別な要件はありません。

使用するコンポーネント

この文書は、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

この文書の情報は、特定のラボ環境にあるデバイスに基づいて作成されています。この文書内で使用されているデバイスはすべて、クリアな状態(デフォルト)から設定作業を始めています。コマンドを実行する前に、実稼動中のネットワークに与える影響について理解しておいてください。

背景理論

プール内のアドレスがサブネット ゼロに該当するような NAT プールを設定すると、NAT 変換が正しく行われません。

表記法

文書表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションでは、この文書で説明する機能を設定するための情報を提供します。

注:この文書で使用されているコマンドの詳細を調べるには、Command Lookup Tool を使用してください(登録ユーザ専用)。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

この文書では、次のネットワーク構成を使用しています。

7a.gif

この設定例では、内側のデバイスには NAT ルータのデフォルト ルートが設定されています。 外側のデバイスには、内側のデバイスの変換先アドレスへのスタティック ルートが設定されています。 NAT ルータには、次の NAT 設定が行われています。

 ip nat pool test 171.68.1.1 171.68.1.10 netmask  255.255.240.0
  ip nat inside source list 7 pool test
 
  interface s 0
  ip address 171.16.4.6 255.255.255.0
  ip nat inside
  
  interface s 1
  ip address 171.16.6.6 255.255.255.0
  ip nat outside
  
  access-list 7 permit host 171.16.4.4
  

NAT プール test の中のアドレスは、サブネット ゼロのアドレスであることに注意してください。 内側のデバイスから外側のデバイスへ ping を送ると、変換が行われず、失敗します。 NAT ルータで debug ip nat コマンドを実行すると、次のメッセージが表示されます。

 NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
  NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
  NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
  NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
  NAT: translation failed (A), dropping packet s=171.16.4.4 d=171.16.6.5
  

注:デバッグ出力の中にある「(A)」は、ルーティングの後で変換が失敗したことを示しています。 

注:この問題を回避するには、NAT ルータ上で ip subnet-zero コマンドを設定します。  このコマンドは、Cisco IOS(R) ソフトウェア リリース 12.0 ではデフォルトでイネーブルになっています。 これより前の Cisco IOS ソフトウェア リリースでは、デフォルトではイネーブルになっていません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13777