WAN : ポイントツーポイント プロトコル(PPP)

PPP バックツーバック接続

2004 年 4 月 14 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 6 月 1 日) | フィードバック

目次

概要
前提条件
     要件
     使用するコンポーネント
     表記法
設定
     設定の要約
     ネットワーク ダイアグラム
     設定例
確認
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書では、PPP のバックツーバック接続のための設定例について説明しています。 この設定を使用すると、接続とハードウェアが適切に動作していることを確認できます。また、テスト用に IP ルーティングを使用することもできます。

前提条件

要件

この文書に関する特別な要件はありません。

使用するコンポーネント

この文書の情報は、次のソフトウェアとハードウェアのバージョンに基づいています。

  • この設定は、すべての Cisco IOS(R) ソフトウェア リリースに適用できます。

  • DCE 側は WAN DCE ケーブルに接続されます。

  • DTE 側は WAN DTE ケーブルに接続されます。

WAN DCE ケーブルまたは DTE ケーブルの詳細については、『シリアル ケーブル』の文書を参照してください。

この文書の情報は、特定のラボ環境にあるデバイスに基づいて作成されています。この文書内で使用されているデバイスはすべて、クリアな状態(デフォルト)から設定作業を始めています。対象のネットワークが実稼動中である場合には、すべてのコマンドによる潜在的な影響について確実に理解しておく必要があります。

表記法

文書表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションでは、この文書で説明する機能を設定するための情報を提供します。

設定の要約

この設定では、Router1 では V35-MT ケーブル(シスコの部品番号は CAB-V35MT)を使用し、Router2 では V35-FC ケーブル(シスコの部品番号は CAB-V35FC)を使用します。 これは、クロックは Router2 から提供されていることを意味します。 シリアル 0 インターフェイスで clock rate 64000 コマンドを発行して、64000 bps のクロック レートを使用しています。

注:このコマンドを設定すると、設定には clock rate 64000 と表示されます。  ここでは、2 本のケーブルが互いに接続されています。

イーサネット インターフェイスは、no keepalive コマンドを発行して設定します。 この方法では、イーサネット インターフェイスを起動して稼働状態にするためには、LAN ネットワークへの接続は不要です。 各ルータでのスタティック ルートを使用すると、Router1 のイーサネット インターフェイスの IP アドレスを使用して、Router2 のイーサネット インターフェイスの IP アドレスに ping を送ることができます(その逆も可能)。 これはテスト環境で便利です。

ネットワーク ダイアグラム

この文書は、次の設定に基づいています。

ppp_backtoback.gif

設定例

この文書では、次の設定を使用します。

Router1

 service timestamps debug uptime
  service timestamps log uptime
  no service password-encryption
  !
  hostname Router1
  !
  enable password cisco
  !
  ip subnet-zero
  !
  !
  !
  !
  interface Ethernet0
   ip address 10.1.0.1 255.255.255.0
   no keepalive
  !
  interface Serial0
   ip address 10.0.0.1 255.255.255.0
   encapsulation ppp
  !
  ip classless
  ip route 10.2.0.0 255.255.255.0 10.0.0.2
  ip http server
  !
  !
  line con 0
  line aux 0
  line vty 0 4
   no login
  !
  end


Router2

 service timestamps debug uptime
  service timestamps log uptime
  no service password-encryption
  !
  hostname Router2
  !
  enable password cisco
  !
  ip subnet-zero
  !
  !
  !
  !
  interface Ethernet0
   ip address 10.2.0.1 255.255.255.0
   no keepalive
  !
  interface Serial0
   ip address 10.0.0.2 255.255.255.0
   encapsulation ppp
   no fair-queue
   clock rate 64000
  !
  ip classless
  ip route 10.1.0.0 255.255.255.0 10.0.0.1
  ip http server
  !
  !
  line con 0
  line aux 0
  line vty 0 4
   no login
  !
  end

確認

このセクションでは、設定が正しく動作していることを確認するために使用できる情報を提供します。

特定の show コマンドは、アウトプットインタープリタ登録ユーザ専用)でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

  • show controllers コマンドを発行して、ケーブルとクロック レートを確認します。

    show controllers コマンドの出力を次に示します。

     Router1#show controllers serial 0 | i V.35
      buffer size 1524  HD unit 0, V.35 DTE cable
      Router1#
      
  • show interfaces serial 0 コマンドを発行して、パケットの送受信が行われていることを確認します(packets inputpackets output5 minute input rate、および 5 minute output rate を参照してください)。 使用しているカプセル化に関する情報は、Encapsulation PPP を参照してください。

    show interfaces serial 0 コマンドの出力を次に示します。

     Router1#show interfaces serial 0
      Serial0 is up, line protocol is up
        Hardware is HD64570
        Internet address is 10.0.0.1/24
        MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
           reliability 255/255, txload 1/255, rxload 1/255
        Encapsulation PPP, loopback not set
        Keepalive set (10 sec)
        LCP Open
        Open: IPCP, CDPCP
        Last input 00:00:00, output 00:00:00, output hang never
        Last clearing of "show interface" counters 00:07:53
        Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
        Queueing strategy: weighted fair
        Output queue: 0/1000/64/0 (size/max total/threshold/drops)
           Conversations  0/5/256 (active/max active/max total)
           Reserved Conversations 0/0 (allocated/max allocated)
           Available Bandwidth 1158 kilobits/sec
        5 minute input rate 2000 bits/sec, 2 packets/sec
        5 minute output rate 2000 bits/sec, 2 packets/sec
           155 packets input, 55066 bytes, 0 no buffer
           Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
           0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
           168 packets output, 60037 bytes, 0 underruns
           0 output errors, 0 collisions, 0 interface resets
           0 output buffer failures, 0 output buffers swapped out
           0 carrier transitions
           DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
      Router1#
      
  • IP アドレス 10.2.0.1 を使用して 10.2.0.2 に ping を送るには、次のように ping コマンドを発行します。

    ping コマンドの出力を次に示します。

     Router1#ping
      Protocol [ip]:
      Target IP address: 10.2.0.1
      Repeat count [5]:
      Datagram size [100]:
      Timeout in seconds [2]:
      Extended commands [n]: y
      Source address or interface: 10.1.0.1
      Type of service [0]:
      Set DF bit in IP header? [no]:
      Validate reply data? [no]:
      Data pattern [0xABCD]:
      Loose, Strict, Record, Timestamp, Verbose[none]:
      Sweep range of sizes [n]:
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.2.0.1, timeout is 2 seconds: Packet sent with 
     a source address of 10.1.0.1 !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms Router1#
      

特定の show コマンドは、アウトプットインタープリタ登録ユーザ専用)でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

  • show controllers:ケーブルとクロック レートを表示します。

  • show interfaces serial 0:パケットが送受信されていることを確認します。

  • ping:デバイスの接続をテストするために使用します。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 7923