マルチプロトコル ラベル スイッチング(MPLS) : MPLS

OSPF を使用した基本的な MPLS の設定

2005 年 8 月 10 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
メカニズム
設定
      ネットワーク ダイアグラム
      クイック コンフィギュレーション ガイド
      設定例
確認
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書では、基本的な Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)ネットワークの設定方法について説明します。 VPN や Traffic Engineering(TE; トラフィック エンジニアリング)などの高度な機能を設定する方法の詳細については、MPLS のサポート ページの『設定例およびテクニカル ノーツ』を参照してください。

前提条件

要件

ユーザが MPLS の基本的な操作に精通していることを前提としています。 MPLS の概要については、『MPLS の概要』を参照してください。

使用するコンポーネント

この文書の情報は、次のソフトウェアとハードウェアのバージョンに基づいています。

  • Cisco IOS(R) ソフトウェア リリース 12.2(28)

  • Cisco 3600 ルータ

この文書の情報は、特定のラボ環境にあるデバイスに基づいて作成されています。この文書内で使用されているデバイスはすべて、クリアな状態(デフォルト)から設定作業を始めています。対象のネットワークが実稼動中である場合には、すべてのコマンドによる潜在的な影響について確実に理解しておく必要があります。

表記法

文書表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

メカニズム

多くの場合、MPLS ネットワークは Label Switch Router(LSR; ラベル スイッチ ルータ)と呼ばれる MPLS 対応ルータで構成されるバックボーン ネットワークとして使用されます。 通常、このネットワークは、パケットにラベルを適用するエッジ LSR を装備したコア LSR で構成されています。

MPLS ネットワークのセットアップ メカニズムは次のとおりです。

  1. さまざまな LSR のルーティング テーブルは、Interior Gateway Protocol(IGP)を使用して作成されます。 MPLS TE を導入する場合は、Open Shortest Path First(OSPF)や Intermediate System-to-Intermediate System(IS-IS)などのリンクステート プロトコルが必要です。

  2. Label Distribution Protocol (LDP; ラベル配布プロトコル)は、ルートとラベルのバインディングをアドバタイズします。 これらのバインディングは、ルーティング テーブルと照合してチェックされます。 LDP を介して学習されたルート(プレフィクス/マスクおよびネクストホップ)がルーティング テーブル内の IGP を介して学習されたルートと一致する場合は、LSR 上の Label Forwarding Information Bases(LFIB; ラベル転送情報ベース)にエントリが作成されます。

LSR では、次の転送メカニズムが使用されます。

  1. ラベルがないパケットがエッジ LSR で受信されると、Cisco Express Forwarding テーブルがチェックされて、必要に応じてパケットにラベルが付けられます。 この LSR は、入力 LSR と呼ばれています。

  2. ラベルの付いたパケットがコア LSR の着信インターフェイスに到達すると、発信パケット用に使用される発信インターフェイスと新しいラベルが LFIB に従って決定されます。

  3. 最後の LSR の前のルータ(最後から 2 番目のホップ)がラベルを外してレベルなしのパケットを送信します。 最後のホップは、出力 LSR と呼ばれています。

次の図は、このネットワークのセットアップを示しています。

1b.gif

設定

このセクションでは、この文書で説明する機能を設定するための情報を提供します。

注:この文書で使用されているコマンドの詳細を調べるには、Command Lookup Tool を使用してください(登録ユーザ専用)。一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

この文書では、次のネットワーク構成を使用しています。

1a.gif

クイック コンフィギュレーション ガイド

この手順をクイック コンフィギュレーション ガイドとして使用してください。

  1. ネットワークを通常の方法でセットアップします(MPLS が転送ベースを確立するためには標準の IP 接続が必要です)。

  2. ルーティング プロトコル(OSPF または IS-IS)が正常に動作していることを確認します。 これらのコマンドは、次の設定では、強調して表示されています。

  3. 一般的な設定モードで、ip cef を有効にします(次の設定では太字で表示されています。使用可能な場合は ip cef distributed を使用するほうがパフォーマンスが良くなります)。

  4. 一般的な設定モードで、インターフェイスごとに mpls ip(IOS の古いバージョンでは tag-switching ip)を有効にします(次の設定では太字で表示されています)。 次の例からわかるように、IOS の一部のバージョンの「show running」の出力では、「mpls ip」コマンドを使用した場合でも、まだコマンドが「tag-switching ip」と表示される場合があります。

    注:LSR には、32 ビットのアドレス マスクが設定された(アップ状態の)ループバック インターフェイスが必要です。これらのインターフェイスには、グローバル IP ルーティング テーブルを介して到達できる必要があります。

設定例

この文書では、次の設定を使用します。

Pomerol

  !
  version 12.2
  !
  hostname Pomerol
  !
  ip subnet-zero
  !
  ip cef
  !
  interface Loopback0
   ip address 10.10.10.3 255.255.255.255
  !
  interface Serial2/0
   ip address 10.1.1.21 255.255.255.252
   tag-switching ip
  !
  interface Serial3/0
   ip address 10.1.1.6 255.255.255.252
   tag-switching ip
  !
  interface Serial4/0
   ip address 10.1.1.9 255.255.255.252
   tag-switching ip
  !
  router ospf 10
   log-adjacency-changes
   network 10.0.0.0 0.255.255.255 area 9
  ! 
  ip classless
  !
  end
  

Pulligny

  !
  version 12.2
  !
  hostname Pulligny
  !
  !
  ip subnet-zero
  !
  ip cef
  !
  interface Loopback0
   ip address 10.10.10.2 255.255.255.255
  !
  interface Serial2/0
   ip address 10.1.1.2 255.255.255.252
   tag-switching ip
  !
  interface Serial3/0
   ip address 10.1.1.10 255.255.255.252
   tag-switching ip
  !
  router ospf 10
   log-adjacency-changes
   network 10.0.0.0 0.255.255.255 area 9
  !
  ip classless
  !
  end
  

Pauillac

  !
  version 12.2
  !
  hostname Pauillac
  !
  ip subnet-zero
  !
  ip cef
  !
  interface Loopback0
   ip address 10.10.10.1 255.255.255.255
  !
  interface Serial2/0
   ip address 10.1.1.13 255.255.255.252
   tag-switching ip
  !
  interface Serial3/0
   ip address 10.1.1.17 255.255.255.252
   tag-switching ip
  !
  interface Serial4/0
   ip address 10.1.1.1 255.255.255.252
   tag-switching ip
  !
  interface Serial5/0
   ip address 10.1.1.5 255.255.255.252
   tag-switching ip
  !
  router ospf 10
   log-adjacency-changes
   network 10.0.0.0 0.255.255.255 area 9
  !
  ip classless
  !
  end
  

Pescara

!
  version 12.2
  !
  hostname Pescara
  !
  ip subnet-zero
  !
  ip cef
  !
  interface Loopback0
   ip address 10.10.10.4 255.255.255.255
  !
  interface Serial2/0
   ip address 10.1.1.14 255.255.255.252
   tag-switching ip
  !
  router ospf 10
   log-adjacency-changes
   network 10.0.0.0 0.255.255.255 area 9
  !
  ip classless
  !
  end

Pesaro

!
  version 12.2
  !
  hostname Pesaro
  !
  ip subnet-zero
  !
  ip cef
  !
  interface Loopback0
   ip address 10.10.10.6 255.255.255.255
  !
  interface Serial2/0
   ip address 10.1.1.22 255.255.255.252
   tag-switching ip
  !
  router ospf 10
   log-adjacency-changes
   network 10.0.0.0 0.255.255.255 area 9
  !
  ip classless
  !
  end
  

Perugia

!
  version 12.2
  !
  hostname Perugia
  !
  ip subnet-zero
  !
  ip cef
  !
  interface Loopback0
   ip address 10.10.10.5 255.255.255.255
  !
  interface Serial2/0
   ip address 10.1.1.18 255.255.255.252
   tag-switching ip
  !
  router ospf 10
   log-adjacency-changes
   network 10.0.0.0 0.255.255.255 area 9
  !
  ip classless
  !
  end

確認

このセクションでは、設定が正しく動作していることを確認するために使用できる情報を提供します。

IS-IS を使用した MPLS の基本設定』の設定例で使用したコマンドも適用できます。

この設定例を説明するために、Pomerol LSR の 10.10.10.4 などの特定の宛先を取り上げます。

特定の show コマンドは、アウトプットインタープリタ登録ユーザ専用)でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

  • show ip route:この宛先で使用する IP ルートを IP ルーティング テーブル内でチェックするために使用します。

      Pomerol#show ip route 10.10.10.4
      Routing entry for 10.10.10.4/32
        Known via "ospf 10", distance 110, metric 129, type intra area
        Last update from 10.1.1.5 on Serial3/0, 17:29:23 ago
        Routing Descriptor Blocks:
        * 10.1.1.5, from 10.10.10.4, 17:29:23 ago, via Serial3/0
            Route metric is 129, traffic share count is 1
      
  • show mpls forwarding-table:ラベル スイッチングで、標準 IP ルーティングの IP ルーティング テーブルに相当する MPLS 転送テーブルをチェックするために使用します。 このテーブルには、入ラベルと出ラベルおよびパケットの説明が格納されています。

      Pomerol#show mpls forwarding-table 
      Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
      tag    tag or VC   or Tunnel Id      switched   interface
      16     Pop tag     10.1.1.12/30      636        Se3/0      point2point
      17     Pop tag     10.10.10.1/32     0          Se3/0      point2point
      18     21          10.10.10.4/32     0          Se3/0      point2point
      19     Pop tag     10.1.1.0/30       0          Se4/0      point2point
             Pop tag     10.1.1.0/30       0          Se3/0      point2point
      20     Pop tag     10.10.10.6/32     612        Se2/0      point2point
      21     Pop tag     10.1.1.16/30      0          Se3/0      point2point
      22     16          10.10.10.5/32     0          Se3/0      point2point
      23     Pop tag     10.10.10.2/32     0          Se4/0      point2point
  • show mpls forwarding-table detail:MPLS 転送テーブルの詳細を表示するために使用します。

      Pomerol#show mpls forwarding-table 10.10.10.4 32 detail
      Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
      tag    tag or VC   or Tunnel Id      switched   interface
      18     21          10.10.10.4/32     0          Se3/0      point2point
              MAC/Encaps=4/8, MRU=1500, Tag Stack{21}
              0F008847 00015000
              No output feature configured
          Per-packet load-sharing
  • show mpls ldp bindings または show tag-switching tdp bindings(ご使用の IOS バージョンによって異なります) :特定の宛先に関連付けられたラベル バインディングを表示するために使用します。ローカル バインディングとリモート バインディングの両方が表示できます。

      Pomerol#show tag-switching tdp bindings 10.10.10.4 32
        tib entry: 10.10.10.4/32, rev 14
              local binding:  tag: 18
              remote binding: tsr: 10.10.10.1:0, tag: 21
              remote binding: tsr: 10.10.10.2:0, tag: 23
              remote binding: tsr: 10.1.1.22:0, tag: 24 (Srikanth - should this be 10.10.10.6:0 ? )
      
      

    各転送クラスのラベルは、たとえそれらのラベルが優先(最短)パス上にない場合でも、LSR ごとに確立されていることに注意してください。 この場合、10.10.10.4/32 を宛先とするパケットは、10.10.10.1(ラベル 21 を使用)または 10.10.10.2(ラベル 23 を使用)を経由して転送できます。 最初の方法が最短なので、LSR では最初の方法が選択されます。 この決定は、標準の IP ルーティング テーブル(この場合は、OSPF を使用して作成)を使用して行われます。

  • show ip cef detail:Cisco Express Forwarding が正常に動作しており、タグが正しく交換されていることをチェックするために使用します。

      Pomerol#show ip cef 10.10.10.4 detail
      10.10.10.4/32, version 37, cached adjacency to Serial3/0
      0 packets, 0 bytes
        tag information set
          local tag: 18
          fast tag rewrite with Se3/0, point2point, tags imposed: {21}
        via 10.1.1.5, Serial3/0, 0 dependencies
          next hop 10.1.1.5, Serial3/0
          valid cached adjacency
          tag rewrite with Se3/0, point2point, tags imposed: {21}
      

トラブルシューティング

トラブルシューティングの詳細については、『MPLS のトラブルシューティング』を参照してください。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13736