マルチプロトコル ラベル スイッチング(MPLS) : MPLS

MPLS VPN のマルチキャストのサポートの設定例

2005 年 8 月 10 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
背景説明
設定
      ネットワーク ダイアグラム
      設定
設計に関するヒント
確認
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書では、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)VPN に対するマルチキャストのサポートの設定について、設定例と一般的なガイドラインを説明します。この機能は、Cisco IOS(R) ソフトウェア リリース 12.0(23)S および 12.2(13)T で導入されました。

前提条件

要件

この設定を開始する前に、次の要件が満たされていることを確認してください。

  • サービス プロバイダーでは、Cisco Multicast VPN 機能を使用するために、マルチキャストが可能なコアを用意する必要があります。

使用するコンポーネント

この文書の情報は、Cisco IOS ソフトウェア リリース 12.2(13)T に基づいています。

注:この機能をサポートしているプラットフォームに関する最新情報を得るには、Software Advisor登録ユーザのみ)を使用してください。この機能をサポートする新しいプラットフォームが追加されると、Software Advisor ではサポートされているプラットフォームのリストが動的に更新されます。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

この文書の情報は、特定のラボ環境にあるデバイスに基づいて作成されています。この文書内で使用されているデバイスはすべて、クリアな状態(デフォルト)から設定作業を始めています。対象のネットワークが実稼動中である場合には、すべてのコマンドによる潜在的な影響について確実に理解しておく必要があります。

表記法

文書表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

背景説明については、MPLS VPN に対する IP マルチキャストのサポートに関する Cisco IOS ソフトウェア リリース 12.2(13)T の新機能についての文書を参照してください。

設定

このセクションでは、この文書で説明する機能を設定するための情報を提供します。

注:この文書で使用されているコマンドの詳細を調べるには、Command Lookup Tool を使用してください(登録ユーザのみ)。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

この文書では、次の図に示すネットワーク設定を使用します。

config_mpls_vpn1.gif

設定

このネットワーク ダイアグラムは、サービス プロバイダーのバックボーンを表しています。このネットワークは、ルータ R2、R3、および R4 で構成されています。このバックボーンは、MPLS VPN をサポートするように設定されています。R2 と R4 は Provider Edge(PE; プロバイダー エッジ)ルータであり、一方 R3 は Provider(P; プロバイダー)ルータです。R1 と R5 は、Customer Edge(CE; カスタマー エッジ)ルータを表しており、これは同じ VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)のインスタンス(yellow)に属します。

マルチキャスト サービスを提供するには、バックボーンがマルチキャスト ルーティングを実行できるように設定されている必要があります。この目的のために選択するマルチキャスト プロトコルは、Protocol Independent Multicast(PIM)になります。そして、R3 は Rendezvous Point(RP; ランデブー ポイント)として設定する必要があります。R2 と R4 も、VRF yellow に対してマルチキャスト ルーティングを実行するよう設定します。PIM 希薄/稠密モードは、PE と CE との間のマルチキャスト ルーティング プロトコルとして設定します。R2 は、VRF yellow に対する RP になるよう設定されています。

マルチキャスト接続をテストするために、R5 の s0/0 インターフェイスがマルチキャスト グループ 224.2.2.2 に参加するよう設定します。R1 のループバック アドレスから 224.2.2.2 に ping を送信します。Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)のエコーはマルチキャスト パケットです。これに対して、ICMP 応答はユニキャスト パケットです。これはこのパケットの IP 宛先アドレスが R1 のループバック アドレスであるためです。

この文書で紹介する設定には、次のものが含まれます。

R1-(CE)

version 12.2
 service timestamps debug datetime msec
 service timestamps log datetime msec
 no service password-encryption
 !
 hostname R1
 !
 !
 clock timezone CET 1
 ip subnet-zero
 no ip domain lookup
 !
 ip multicast-routing 
 
 !--- マルチキャスト ルーティングを有効にします。
 
 !
 !
 interface Loopback0
  ip address 100.0.0.1 255.255.255.255
 !
 interface Serial0/0
  ip address 10.1.0.1 255.255.255.0
  ip pim sparse-dense-mode
 
 !--- PIM 希薄/稠密モードを PE と CE との間に使用します。
 !--- PIM 希薄/稠密モードはマルチキャスト ルーティング プロトコルです。
 
 !
 router rip
  version 2
  network 10.0.0.0
  network 100.0.0.0
  no auto-summary
 !
 ip classless
 no ip http server
 ip pim bidir-enable
 !
 !
 !
 !
 line con 0
  exec-timeout 0 0
 line aux 0
 line vty 0 4
  login
 !         
 end

R2-(PE)

version 12.2
 service timestamps debug datetime msec
 service timestamps log datetime msec
 no service password-encryption
 !
 hostname R2
 !
 !
 clock timezone CET 1
 ip subnet-zero
 no ip domain lookup
 !
 ip vrf yellow
  rd 2:200
  route-target export 2:200
  route-target import 2:200
  mdt default 239.1.1.1
 
 !--- VRF yellow のデフォルトのマルチキャスト配信ツリー(MDT)
 !--- を設定します。
 
  mdt data 239.2.2.0 0.0.0.255 threshold 1
 
 !--- データ MDT に対するグローバル アドレスの範囲と
 !--- しきい値を設定します。
 
 ip multicast-routing 
 
 !--- グローバル マルチキャスト ルーティングを有効にします。
 
 ip multicast-routing vrf yellow 
 
 !--- VRF yellow でマルチキャスト ルーティングを有効にします。
 
 ip cef
 mpls label protocol ldp
 tag-switching tdp router-id Loopback0
 !
 !
 !
 interface Loopback0
  ip address 50.0.0.2 255.255.255.255
  ip pim sparse-dense-mode
 
 !--- ループバック インターフェイスでマルチキャストを有効にする
 !-- 必要があります。これは MVPN に参加する PE ルータ間での MPBGP セッションの
 !--- ソースとして使用されます。
 
 !
 interface Loopback100
  ip vrf forwarding yellow
  ip address 100.0.0.2 255.255.255.255
  ip pim sparse-dense-mode
 !
 
 !--- このルータは、VRF yellow でのマルチキャストのための
 !--- RP になる必要があります。したがって、マルチキャストを
 !--- RP として使用するインターフェイスで有効にする必要があります。
 
 !
 interface Serial1/0
  ip vrf forwarding yellow
  ip address 10.1.0.2 255.255.255.0
  ip pim sparse-dense-mode
 
 !--- マルチキャストは、VRF の PE-CE インターフェイスで有効になっています。
 
 !         
 interface Serial2/0
  ip address 10.2.0.2 255.255.255.0
  ip pim sparse-dense-mode
 
 !--- サービス プロバイダーのコアでは、MVPN サービスをサポートするために
 !--- マルチキャストを実行する必要があります。
 !--- そのため、PE-P リンクではマルチキャストを有効にします。
 
  tag-switching ip        
 !         
 router ospf 1
  router-id 50.0.0.2
  log-adjacency-changes
  network 10.0.0.0 0.255.255.255 area 0
  network 50.0.0.0 0.0.0.255 area 0
 !
 router rip
  version 2
  no auto-summary
  !
  address-family ipv4 vrf yellow
  version 2
  redistribute bgp 1
  network 10.0.0.0
  network 100.0.0.0
  default-metric 5
  no auto-summary
  exit-address-family
 !
 router bgp 1
  no synchronization
  no bgp default ipv4-unicast
  bgp log-neighbor-changes
  redistribute rip
  neighbor 50.0.0.4 remote-as 1
  neighbor 50.0.0.4 update-source Loopback0
  neighbor 50.0.0.4 activate
  neighbor 50.0.0.6 remote-as 1
  neighbor 50.0.0.6 update-source Loopback0
  neighbor 50.0.0.6 activate
  no auto-summary
  !
  address-family ipv4 vrf yellow
  redistribute connected
  redistribute rip
  no auto-summary
  no synchronization
  exit-address-family
  !
  address-family vpnv4
  neighbor 50.0.0.4 activate
  neighbor 50.0.0.4 send-community extended
  neighbor 50.0.0.6 activate
  neighbor 50.0.0.6 send-community extended
  no auto-summary
  exit-address-family
 !         
 ip classless
 no ip http server
 ip pim bidir-enable
 ip pim vrf yellow send-rp-announce Loopback100 scope 100
 ip pim vrf yellow send-rp-discovery Loopback100 scope 100
 
 !--- auto-RP を設定します。R2 の loopback 
 !--- 100 は VRF yellow の RP です。
 
 !
 !
 !
 line con 0
  exec-timeout 0 0
 line aux 0
 line vty 0 4
  login
 !
 end

R3-(P)

version 12.2 
 service timestamps debug datetime msec 
 service timestamps log datetime msec 
 no service password-encryption 
 ! 
 hostname R3 
 ! 
 ! 
 clock timezone CET 1 
 ip subnet-zero 
 ! 
 ip multicast-routing  
 
 !--- グローバル マルチキャスト ルーティングを有効にします。
  
 ip cef 
 mpls label protocol ldp 
 tag-switching tdp router-id Loopback0 
 ! 
 ! 
 ! 
 interface Loopback0 
  ip address 50.0.0.3 255.255.255.255 
  ip pim sparse-dense-mode 
 ! 
 ! 
 interface Serial1/0 
  ip address 10.2.0.3 255.255.255.0 
  ip pim sparse-dense-mode
 
 !--- MVPN が設定されている PE ルータに繋がるリンクで
 !--- マルチキャストを有効にします。
 
  tag-switching ip 
 ! 
 interface Serial2/0 
  ip address 10.3.0.3 255.255.255.0 
  ip pim sparse-dense-mode 
  tag-switching ip 
 ! 
 router ospf 1 
  router-id 50.0.0.3 
  log-adjacency-changes 
  network 10.0.0.0 0.255.255.255 area 0 
  network 50.0.0.0 0.0.0.255 area 0 
 ! 
 ip classless 
 no ip http server 
 ip pim bidir-enable 
 ip pim send-rp-announce Loopback0 scope 100 
 ip pim send-rp-discovery Loopback0 scope 100 
 
 !--- R3 は auto-RP を経由して自身が RP であることを
 !--- アナウンスするよう設定します。
  
 ! 
 ! 
 ! 
 ! 
 line con 0 
  exec-timeout 0 0 
 line aux 0 
 line vty 0 4 
  login  
 ! 
 end

R4-(PE)

version 12.2 
 service timestamps debug datetime msec 
 service timestamps log datetime msec 
 no service password-encryption 
 ! 
 hostname R4 
 ! 
 ! 
 clock timezone CET 1 
 ip subnet-zero 
 no ip domain lookup 
 ! 
 ip vrf yellow 
  rd 2:200 
  route-target export 2:200 
  route-target import 2:200 
  mdt default 239.1.1.1 
 
 !--- デフォルトの MDT アドレスを設定します。
  
  mdt data 238.2.2.0 0.0.0.255 threshold 1 
 
 !--- データ MDT の範囲としきい値を設定します。
  
 ! 
 ip multicast-routing  
 
 !--- グローバル マルチキャスト ルーティングを有効にします。
  
 ip multicast-routing vrf yellow  
 
 !--- VRF yellow でマルチキャスト ルーティングを有効にします。
  
 ip cef 
 mpls label protocol ldp 
 tag-switching tdp router-id Loopback0 
 ! 
 ! 
 ! 
 interface Loopback0 
  ip address 50.0.0.4 255.255.255.255 
  ip pim sparse-dense-mode 
 ! 
 interface Loopback100 
  ip vrf forwarding yellow 
  ip address 100.0.0.4 255.255.255.255 
  ip pim sparse-dense-mode 
 ! 
 interface Serial1/0 
  ip address 10.3.0.4 255.255.255.0 
  ip pim sparse-dense-mode 
  tag-switching ip 
 ! 
 interface Serial2/0 
  ip vrf forwarding yellow 
  ip address 10.4.0.4 255.255.255.0 
  ip pim sparse-dense-mode 
 
 !--- CE に対する PIM を有効にします。
  
 ! 
 router ospf 1 
  router-id 50.0.0.4 
  log-adjacency-changes 
  network 10.0.0.0 0.255.255.255 area 0 
  network 50.0.0.0 0.0.0.255 area 0 
 ! 
 router rip 
  version 2 
  no auto-summary 
  ! 
  address-family ipv4 vrf yellow 
  version 2 
  redistribute bgp 1 
  network 10.0.0.0 
  network 100.0.0.0 
  default-metric 5 
  no auto-summary 
  exit-address-family 
 ! 
 router bgp 1 
  no synchronization 
  no bgp default ipv4-unicast 
  bgp log-neighbor-changes 
  redistribute rip 
  neighbor 50.0.0.2 remote-as 1 
  neighbor 50.0.0.2 update-source Loopback0 
  neighbor 50.0.0.2 activate 
  no auto-summary 
  ! 
  address-family ipv4 vrf yellow 
  redistribute connected 
  redistribute rip 
  no auto-summary 
  no synchronization 
  exit-address-family 
  ! 
  address-family vpnv4 
  neighbor 50.0.0.2 activate 
  neighbor 50.0.0.2 send-community extended 
  no auto-summary 
  exit-address-family 
 ! 
 ip classless 
 no ip http server 
 ip pim bidir-enable 
 ! 
 ! 
 ! 
 ! 
 ! 
 line con 0 
  exec-timeout 0 0 
 line aux 0 
 line vty 0 4 
  login 
 ! 
 end

R5-(CE)

version 12.2 
 service timestamps debug datetime msec 
 service timestamps log datetime msec 
 no service password-encryption 
 ! 
 hostname R5 
 ! 
 ! 
 clock timezone CET 1 
 ip subnet-zero 
 no ip domain lookup 
 ! 
 ip multicast-routing  
 
 !--- CE でグローバル マルチキャスト ルーティングを有効にします。
  
 ! 
 ! 
 interface Loopback0 
  ip address 100.0.0.5 255.255.255.255 
 ! 
 interface Serial0/0 
  ip address 10.4.0.5 255.255.255.0 
  ip pim sparse-dense-mode 
  ip igmp join-group 224.2.2.2 
 ! 
 router rip 
  version 2 
  network 10.0.0.0 
  network 100.0.0.0 
  no auto-summary 
 ! 
 ip classless 
 no ip http server 
 ip pim bidir-enable 
 ! 
 ! 
 ! 
 ! 
 ! 
 line con 0 
  exec-timeout 0 0 
 line aux 0 
 line vty 0 4 
  login 
 !          
 end

設計に関するヒント

  • MPLS VPN(MVPN)に対するマルチキャストは、VPN 設定の先頭で設定します。MPLS VPN ネットワークは慎重に設計する必要があります。MPLS VPN ネットワークの推奨事項が最初に守られる必要があります。

  • サービス プロバイダーのコアは、ネイティブなマルチキャスト サービス用に設定する必要があります。コアは、PIM Sparse mode(PIM-SM; PIM 希薄モード)、Source specific multicast(PIM-SSM)、または Bidirectional PIM(PIM-BIDIR; 双方向 PIM)用に設定する必要があります。Dense mode PIM(PIM-DM; 稠密モード PIM)は、MVPN 設定のコア プロトコルとしてはサポートされていません。プロバイダーのコアで、サポートされるプロトコルを混在させて設定することも可能です。これは、ある PIM モードによって一部のマルチキャスト グループが処理され、さらに他の PIM モードによって他のグループが処理されている場合に設定できます。

  • マルチキャスト VRF 内ではすべてのマルチキャスト プロトコルがサポートされます。つまり、マルチキャスト VRF 内では、PIM-SM、PIM-SSM、PIM-BIDIR の他に、MSDP および PIM-DM も使用できます。

  • MVPN サービスは、VRF ごとに別個に追加できます。つまり、1 つの PE ルータに、マルチキャストが有効な VRF と、ユニキャストだけの VRF の両方を設定できます。

  • 単独のユニキャスト VRF のすべてのサイトをマルチキャスト用に設定する必要はありません。一部のサイトで(あるいは MVPN PE ルータの一部のインターフェイスでも)マルチキャストを有効にしないことが可能です。ルータで、マルチキャスト以外が有効になっているインターフェイスを指すような計算が行われないようにする必要があります。このような計算が行われると、マルチキャスト転送が失敗します。

  • 同じ MVPN マルチキャスト ドメインに複数の VRF が属することができます。1 つのマルチキャスト ドメイン内で IP アドレッシングは一意である必要があります。マルチキャスト ドメインの間で、あるいはグローバル マルチキャスト ルーティング テーブルに、ルートやパケットをリークすることは、現在では不可能です。

  • MVPN が動作するには、MDT のデフォルト設定が必須です。データ MDT の設定はオプションです。設定する場合は、データ MDT にしきい値を設定することを強く推奨します。

  • デフォルトの MDT の IP アドレスによって、VRF が属するマルチキャスト ドメインが決まります。したがって、複数の VRF に同じデフォルト MDT アドレスを割り当てることが可能です。しかし、これらの VRF 間ではマルチキャスト パケットが共有されるため、マルチキャスト ドメインに関する推奨事項(一意の IP アドレッシング方式など)に準拠する必要があります。

  • データ MDT は、異なる PE ルータに対して同じ範囲の IP アドレスを指定して設定できる場合と、できない場合があります。これは、プロバイダーのコアで使用されている PIM モードによって変わります。サービス プロバイダーのコアで希薄モード PIM が使用されている場合、各 PE ルータではデータ MDT グループに対して一意の IP アドレス範囲を使用する必要があります。サービス プロバイダーのコアでソース固有のマルチキャストが使用されている場合は、各マルチキャスト ドメインのデータ MDT に対して、全 PE ルータで同じ範囲の IP アドレスを使用できます。

確認

この項では、設定が正しく動作することを確認するために使用できる情報を提供します。

一部の show コマンドは、show コマンド出力の分析を表示するアウトプットインタープリタ登録ユーザのみ)でサポートされています。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

  • show ip igmp groups — ルータに直接接続され、Internet Group Management Protocol(IGMP; インターネット グループ管理プロトコル)によって学習されたマルチキャスト グループと受信装置の情報を表示します。

  • show ip pim mdt bgp — MDT デフォルト グループの Route Distinguisher(RD; ルート識別子)の Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)によるアドバタイズメントの詳細を表示します。

  • show ip pim vrf <vrf-name> mdt send — 指定した VRF でルータが作成したデータ MDT アドバタイズメントを表示します。

  • show ip pim vrf <vrf-name> mdt receive — 指定した VRF でルータが受信したデータ MDT アドバタイズメントを表示します。

  • show ip mroute — プロバイダーのコアにある IP マルチキャスト ルーティング テーブルの内容を表示します。

  • show ip mroute vrf <vrf-name> — クライアントの VRF にあるマルチキャスト ルーティング テーブルを表示します。

設定が正しく動作していることを確認するには、次の手順を実行します。

  1. PE がデフォルトの MDT トンネルの IGMP グループに参加していることをチェックします。

    これが VRF 設定で default-mdt コマンドを発行した後に設定されていると、PE がデフォルトの MDT グループに参加できなくなることがあります。ループバックを設定したら、この問題を解決するために、VRF から mdt コマンドをいったん削除して元に戻します。

    • PE-R2 に対して、show ip igmp groups コマンドを実行します。

      IGMP Connected Group Membership
       Group Address  Interface   Uptime     Expires   Last Reporter
       224.0.1.40     Serial2/0   02:21:23   stopped   10.2.0.2
       239.1.1.1      Loopback0   02:36:59   stopped   0.0.0.0
    • PE-R4 に対して、show ip igmp groups コマンドを実行します。

      IGMP Connected Group Membership 
       Group Address  Interface    Uptime    Expires   Last Reporter
       224.0.1.40     Loopback0    02:51:48  00:02:39  50.0.0.4
       239.1.1.2      Loopback0    02:51:45  stopped   0.0.0.0
       239.1.1.1      Loopback0    02:51:45  stopped   0.0.0.0
       239.2.2.0      Loopback0    01:40:03  stopped   0.0.0.0 
  2. 各 PE について、受信した BGP アドバタイズメントをチェックします。

    注: たとえば、ピア PE である PE-R2 および PE-R4 を発信元とする MDT をチェックします。

    • PE-R2 に対して、show ip pim mdt bgp コマンドを実行します。

      MDT-default group 239.1.1.1 
       rid: 50.0.0.4 next_hop: 50.0.0.4 
       WAVL tree nodes
       MDT-default: 239.1.1.1  Tunnel0     source-interface: Loopback0
    • PE-R4 に対して、show ip pim mdt bgp コマンドを実行します。

      MDT-default group 239.1.1.1 
       rid: 50.0.0.2 next_hop: 50.0.0.2 
       WAVL tree nodes
       MDT-default: 239.1.1.1  Tunnel0     source-interface: Loopback0 
       MDT-data   : 239.2.2.0  Tunnel0     source-interface: Loopback0 
  3. データ MDT をチェックします。

    注: たとえば、PE-R2 および PE-R4 を発信元とする、あるいは参加しているデータ MDT をチェックします。

    • PE-R2 に対して、show ip pim vrf yellow mdt send コマンドを実行します。

      MDT-data send list for VRF: yellow 
         (source, group)                     MDT-data group      ref_count 
         (100.0.0.1, 224.2.2.2)              239.2.2.0           1 
    • PE-R2 に対して、show ip pim vrf yellow mdt receive コマンドを実行します。

      Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
              L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
              T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
              X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
              U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
              Y - Joined MDT-data group, y - Sending to MDT-data group
       Joined MDT-data groups for VRF: yellow 
         group: 239.2.2.0 source: 0.0.0.0 ref_count: 1 
    • デフォルト MDT のグローバル マルチキャスト ルーティング テーブルをチェックします。

      注: 次の情報に注意してください。

      1. この発信インターフェイスのリストは PE の MVRF yellow のものです。

      2. P ルータはこのグループを通常のマルチキャスト グループと見なしています。

      3. 各 PE はデフォルト MDT の発信元であり、PE ルータにだけあります。

      4. 新しいフラグ Z は、これがマルチキャスト トンネルであることを示します。

    • PE-R2 に対して、show ip mroute 239.1.1.1 コマンドを実行します。

      IP Multicast Routing Table 
       Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
              L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
              T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
              X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
              U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
              Y - Joined MDT-data group, y - Sending to MDT-data group 
       Outgoing interface flags: H - Hardware switched 
        Timers: Uptime/Expires 
        Interface state: Interface, Next-Hop or VCD, State/Mode 
       (*, 239.1.1.1), 02:37:16/stopped, RP 50.0.0.3, flags: SJCFZ 
         Incoming interface: Serial2/0, RPF nbr 10.2.0.3 
         Outgoing interface list: 
           MVRF yellow, Forward/Sparse-Dense, 02:21:26/00:00:28 
       (50.0.0.2, 239.1.1.1), 02:37:12/00:03:29, flags: FTZ 
         Incoming interface: Loopback0, RPF nbr 0.0.0.0 
         Outgoing interface list: 
           Serial2/0, Forward/Sparse-Dense, 02:36:09/00:02:33 
       (
       50.0.0.4, 239.1.1.1), 02:36:02/00:02:59, flags: JTZ 
         Incoming interface: Serial2/0, RPF nbr 10.2.0.3 
         Outgoing interface list: 
           MVRF yellow, Forward/Sparse-Dense, 02:21:26/00:00:28
    • PE-R3 に対して、show ip mroute 239.1.1.1 コマンドを実行します。

       
       IP Multicast Routing Table 
       Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
              L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
              T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
              X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
              U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
              Y - Joined MDT-data group, y - Sending to MDT-data group 
       Outgoing interface flags: H - Hardware switched 
        Timers: Uptime/Expires 
        Interface state: Interface, Next-Hop or VCD, State/Mode 
       (*, 239.1.1.1), 02:50:24/stopped, RP 50.0.0.3, flags: S 
         Incoming interface: Null, RPF nbr 0.0.0.0 
         Outgoing interface list: 
           Serial1/0, Forward/Sparse-Dense, 02:34:41/00:03:16 
           Serial2/0, Forward/Sparse-Dense, 02:49:24/00:02:37 
       (50.0.0.2, 239.1.1.1), 02:49:56/00:03:23, flags: T 
         Incoming interface: Serial1/0, RPF nbr 10.2.0.2 
         Outgoing interface list: 
           Serial2/0, Forward/Sparse-Dense, 02:49:24/00:02:37 
       (50.0.0.4, 239.1.1.1), 02:49:47/00:03:23, flags: T 
         Incoming interface: Serial2/0, RPF nbr 10.3.0.4 
         Outgoing interface list: 
           Serial1/0, Forward/Sparse-Dense, 02:34:41/00:03:16 
    • PE-R4 に対して、show ip mroute 239.1.1.1 コマンドを実行します。

      IP Multicast Routing Table 
       Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
              L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
              T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
              X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
              U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
              Y - Joined MDT-data group, y - Sending to MDT-data group 
       Outgoing interface flags: H - Hardware switched 
        Timers: Uptime/Expires 
        Interface state: Interface, Next-Hop or VCD, State/Mode 
       (*, 239.1.1.1), 02:51:06/stopped, RP 50.0.0.3, flags: SJCFZ 
         Incoming interface: Serial1/0, RPF nbr 10.3.0.3 
         Outgoing interface list: 
           MVRF yellow, Forward/Sparse-Dense, 02:51:06/00:00:48 
       (50.0.0.2, 239.1.1.1), 02:50:06/00:02:58, flags: JTZ 
         Incoming interface: Serial1/0, RPF nbr 10.3.0.3 
         Outgoing interface list: 
           MVRF yellow, Forward/Sparse-Dense, 02:50:06/00:00:48 
       (50.0.0.4, 239.1.1.1), 02:51:00/00:03:10, flags: FTZ 
         Incoming interface: Loopback0, RPF nbr 0.0.0.0 
         Outgoing interface list: 
           Serial1/0, Forward/Sparse-Dense, 02:35:24/00:03:00 
  4. データ MDT のグローバル マルチキャスト ルーティング テーブルをチェックします。

    注: PE-R2 の場合は、発信インターフェイスが tunnel0 であることに注意してください。

    • PE-R2 の場合はここに発信元が存在するため(VRF 側)、show ip mroute vrf yellow 224.2.2.2 コマンドを実行します。

      IP Multicast Routing Table 
       Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
              L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
              T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
              X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
              U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
              Y - Joined MDT-data group, y - Sending to MDT-data group 
       Outgoing interface flags: H - Hardware switched 
        Timers: Uptime/Expires 
        Interface state: Interface, Next-Hop or VCD, State/Mode 
       (*, 224.2.2.2), 2d01h/stopped, RP 100.0.0.2, flags: S 
         Incoming interface: Null, RPF nbr 0.0.0.0 
         Outgoing interface list: 
           Tunnel0, Forward/Sparse-Dense, 2d01h/00:02:34 
       (100.0.0.1, 224.2.2.2), 00:05:32/00:03:26, flags: Ty 
         Incoming interface: Serial1/0, RPF nbr 10.1.0.1 
         Outgoing interface list: 
           Tunnel0, Forward/Sparse-Dense, 00:05:37/00:02:34
    • PE-R2 の場合はここに発信元が存在するため(グローバル マルチキャスト ルート)、show ip mroute 239.2.2.0 コマンドを実行します。

      IP Multicast Routing Table 
       Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected, 
              L - Local, P - Pruned, R - RP-bit set, F - Register flag, 
              T - SPT-bit set, J - Join SPT, M - MSDP created entry, 
              X - Proxy Join Timer Running, A - Candidate MSDP Advertisement, 
              U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel 
              Y - Joined MDT-data group, y - Sending to MDT-data group 
       Outgoing interface flags: H - Hardware switched 
        Timers: Uptime/Expires 
        Interface state: Interface, Next-Hop or VCD, State/Mode 
       (*, 239.2.2.0), 02:13:27/stopped, RP 50.0.0.3, flags: SJPFZ 
         Incoming interface: Serial2/0, RPF nbr 10.2.0.3 
         Outgoing interface list: Null 
       (50.0.0.2, 239.2.2.0), 02:13:27/00:03:22, flags: FTZ 
         Incoming interface: Loopback0, RPF nbr 0.0.0.0 
         Outgoing interface list: 
           Serial2/0, Forward/Sparse-Dense, 02:13:27/00:03:26

    注: マルチキャストの送信元が接続されている PE ルータだけが、データ MDT グループ アドレスのマルチキャスト トラフィックの発信元として表示されます。

トラブルシューティング

  • PE ルータでダイナミック トンネル インターフェイスによる PIM 隣接関係が構築されていることを確認するには、show ip pim vrf neighbor コマンドを実行します。これが構築されていれば、デフォルト MDT は正しく動作します。

  • デフォルト MDT が機能しない場合は、show ip pim mdt bgp コマンドを実行して、MVPN に参加しているリモート PE ルータのループバックが、ローカル ルータに認識されているかどうかをチェックします。認識されていない場合は、MP BGP セッションの発信元として使用されているループバック インターフェイスで PIM が有効になっていることを確認します。

  • SP のコアが正しく設定され、PE ルータ間でマルチキャストが搬送されていることをチェックします。テストのために、ある PE ルータのループバック インターフェイスに ip igmp join-group を設定し、別の PE ルータのループバックからマルチキャスト ping を送信できます。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 29220