マルチプロトコル ラベル スイッチング(MPLS) : MPLS

カスタマー側の RIP を使用した MPLS ベースの VPN の設定

2005 年 8 月 10 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2007 年 11 月 16 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      ネットワークの説明
      表記法
設定手順
      ネットワーク ダイアグラム
      パート I
      パート II
      設定例
debug コマンドと show コマンド
      MPLS ラベル
      アドレス オーバーラッピング
デバッグの出力例
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この設定例は、Routing Information Protocol(RIP; ルーティング情報プロトコル)がカスタマー側で使用されている場合の、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Virtual Private Network(VPN; バーチャル プライベート ネットワーク)を示しています。

VPN 機能を MPLS と併用すると、サービス プロバイダーのネットワークを介して、複数のサイトを透過的に相互接続できます。サービス プロバイダーのネットワーク 1 つで、複数の異なる IP VPN をサポートできます。 各 IP VPN は、他のすべてのネットワークから切り離されたプライベート ネットワークとして認識されます。 VPN 内の各サイトは、同じ VPN 内の他のサイトに IP パケットを送信します。

各 VPN は、1 つまたは複数の VPN ルーティングまたはフォワーディング インスタンス(VRF)に関連付けられています。 VRF は、IP ルーティング テーブル、取得された Cisco Express Forwarding(CEF)テーブル、およびフォワーディング テーブルを使用する一連のインターフェイスから構成されます。

ルータでは、VRF ごとに個別のルーティング テーブルおよび CEF テーブルが維持されます。 このため、VPN の外へ情報が送信されるのを防ぐことができ、IP アドレスの重複問題を起こさずに、複数の VPN で同じサブネットを使用できます。

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)を使用しているルータは、BGP 拡張コミュニティを使って、VPN ルーティング情報を配信します。

VPN を介したアップデートの伝搬の詳細については、『MPLS バーチャル プライベート ネットワーク』の「VPN ルート ターゲット コミュニティ」、「BGP による VPN ルーティング情報の配布」、「MPLS 転送」のセクションを参照してください。

前提条件

要件

この文書に適用される特定の前提条件はありません。

使用するコンポーネント

次のバージョンのソフトウェアとバードウェアを使って、この設定の開発とテストを行いました。

  • PE ルータ: MPLS VPN の機能は、PE ルータで提供されています。 使用可能なハードウェアとソフトウェアの組み合せを判断するには、Feature Navigator II登録ユーザ専用)を使用してください。

  • CE ルータ: PE ルータとの情報交換が可能な任意のルータを使用します。

  • IP ルータとスイッチ: この文書では、MSR、BPX、および MGX などの ATM スイッチが使用されています。 ただし、この文書では MPLS VPN 機能を中心に説明しているので、Cisco 12000 などのルータでコアのフレーム ベースの MPLS を使用することも可能でした。


一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

この文書の情報は、特定のラボ環境にあるデバイスに基づいて作成されています。 この文書で使用するすべてのデバイスは、クリアな状態(デフォルト)から設定作業を始めています。 実稼動中のネットワークで作業する場合は、コマンドの実行によって生じる影響について、事前に理解しておいてください。

ネットワークの説明

Open Shortest Path First(OSPF)エリア 0 を Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)として使用して、標準 MPLS ATM バックボーンをセットアップしています。 このバックボーンを使って、2 つの異なる VPN を設定しました。 最初の VPN では、カスタマー エッジからプロバイダー エッジ(CE-PE)へのルーティングプロトコルとして RIP を使用し、もう 1 つの VPN では PE-CE ルーティング プロトコルとして BGP を使用します。 他のルータやネットワークの存在をシミュレートするために、CE ルータ上にさまざまなループバック ルートとスタティック ルートを設定しています。

注:BGP 拡張コミュニティを使用する方法が、PE ルータ間で VPN のルーティング情報を転送する唯一の方法なので、PE ルータ間の VPN IGP には BGP を使用する必要があります。

注:この設定では、ATM ネットワークをバックボーン ネットワークとして使用しています。 この設定は、ATM(および他の)プロトコルに適用できます。 VPN の設定が正しく動作するためには、PE ルータが MPLS ネットワークを使用して相互に到達可能である必要があります。

表記法

次の文字は、使用されるさまざまなタイプのルータとスイッチを表しています。

  • P:プロバイダーのコア ルータ

  • PE:プロバイダーのエッジ ルータ

  • CE:カスタマーのエッジ ルータ

  • C: カスタマーのルータ

次の図は、一般的な構成でこれらの表記法を例示しています。

mpls_vpn_rip_mplsvpn.gif

文書表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定手順

このセクションでは、この文書で説明する機能を設定するための情報を提供します。 『MPLS バーチャル プライベート ネットワーク』にある Cisco IOS の文書でも、この設定手順を説明しています。

注:この文書で使用されているコマンドの詳細を調べるには、IOS の Command Lookup Tool登録ユーザ専用)を使用してください。 


一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

この文書では次の図に示すネットワーク構成を使用しています。

mpls_vpn_rip_mv_rip.gif

パート I

正しい設定には、次の手順が役に立ちます。

ip cef コマンドを有効にします。 Cisco 7500 ルータを使用している場合、MPLS が設定されたら、PE の性能が強化されるように、使用可能なところでは ip cef distributed コマンドが有効になっていることを確認します。

  1. ip vrf [VPN routing | forwarding instance name] コマンドを使用して、VPN ごとに、VRF を 1 つ作成します。 VRF を作成する際には、次のことを必ず行います。

    • 次のコマンドを使用して、対象となる VPN に対して使用する適切なルート区分を指定します。 この区分は、IP アドレスの拡張に使用されて、IP アドレスが所属する VPN を識別できるようになります。

       rd [VPN route distinguisher]
       
    • 次のコマンドを使用して、BGP 拡張コミュニティに対し、インポート プロパティとエクスポート プロパティをセットアップします。 これらのプロパティは、インポートおよびエクスポートのプロセスのフィルタリングに使用されます。

       route-target {export | import | both} [target VPN extended community] 
       
  2. ip vrf forwarding [table name] コマンドを使用して、各インターフェイスに対してフォワーディングの詳細を設定します。その後、IP アドレスを必ずセットアップしてください。

  3. 使用する PE-CE ルーティング プロトコルに応じて、次の作業を 1 つ以上行います。

    • 次のようにスタティック ルートを設定します。

       ip route vrf vrf-name prefix mask [next-hop-address] [interface {interface-number}] 
       
    • 次のコマンドを使って、RIP を設定します。

       address-family ipv4 vrf [VPN routing | forwarding instance name] 
       

      上のステップの 1 つまたは両方を完了したら、通常の RIP 設定コマンドを入力します。

      注:これらのコマンドは、現在の VRF のフォワーディング インターフェイスだけに適用されます。 適切な BGP を RIP に再配布します。この際、使用するメトリックを必ず指定してください。

    • BGP 隣接情報を宣言します。

    • 新しい IOS コマンドを使って、OSPF を設定します。

       router ospf process-id vrf [VPN routing | forwarding instance name] 
       

    注:このコマンドは、現在の VRF のフォワーディング インターフェイスだけに適用されます。 適切な BGP ルーティング情報を OSPF に再配布して、使用するメトリックを指定します。 VRF に対する OSPF プロセスが完了したら、コマンドラインに OSPF プロセスが指定されていない場合でも、この VRF にはこのプロセス ID が常に使用されます。

パート II

PE ルータ間で BGP を設定します。 ルート リフレクタの使用やコンフェデレーション方式など、BGP の設定には、いくつかの方法があります。 ここで示す方法は、直接隣接ルータを設定する方法です。 この方法は最も簡単ですが、きわめてスケーラビリティに欠けています。

  1. 異なる隣接ルータを宣言します。

  2. 対象の PE ルータに存在する VPN ごとに、address-family ipv4 vrf [VPN routing | forwarding instance name] コマンドを入力します。必要に応じて、次のステップを 1 つまたは複数実行します。

    • スタティック ルーティング情報を再配信します。

    • RIP ルーティング情報を再配信します。

    • OSPF ルーティング情報を再配信します。

    • CE ルータとの BGP 隣接関係をアクティブ化します。

  3. address-family vpnv4 モードに移行し、

    • 隣接ルータをアクティブ化します。

    • 拡張コミュニティを使用する必要があることを指定します。この手順は必ず実行してください。

設定例

Alcalzaba の設定では、VPN 設定に固有の行が太字で示されています。

Alcazaba

!
 ip vrf vrf101
  rd 1:101
  route-target export 1:101
  route-target import 1:101
 !
 ip cef
 !
 interface Loopback0
  ip address 223.0.0.3 255.255.255.255
 !
 interface Ethernet1/1
  ip vrf forwarding vrf101
  ip address 150.150.0.1 255.255.255.0
 !
 interface ATM3/0
  no ip address
  no ip mroute-cache
  no ATM ilmi-keepalive
  PVC qsaal 0/5 qsaal
  PVC ilmi 0/16 ilmi
  !
 !
 interface ATM3/0.1 tag-switching
  ip address 10.0.0.17 255.255.255.252
  tag-switching ATM vpi 2-4
  tag-switching ip
 !
 interface ATM4/0
  no ip address
  no ATM ilmi-keepalive
 !
 interface ATM4/0.1 tag-switching
  ip address 10.0.0.13 255.255.255.252
  tag-switching ATM vpi 2-4
  tag-switching ip 
 !
 router ospf 1
  network 10.0.0.0 0.0.0.255 area 0
  network 223.0.0.3 0.0.0.0 area 0
 !
 router rip
  version 2
  !
  address-family ipv4 vrf vrf101
  version 2
  redistribute bgp 1 metric 0
  network 150.150.0.0
  no auto-summary
  exit-address-family
 !
 router bgp 1
  no synchronization
  neighbor 125.2.2.2 remote-as 1
  neighbor 125.2.2.2 update-source Loopback0
  neighbor 223.0.0.21 remote-as 1
  neighbor 223.0.0.21 update-source Loopback0
  no auto-summary
  !
  address-family ipv4 vrf vrf101
  redistribute rip
  no auto-summary
  no synchronization
  exit-address-family
  !
  address-family vpnv4
  neighbor 125.2.2.2 activate
  neighbor 125.2.2.2 send-community extended
  neighbor 223.0.0.21 activate
  neighbor 223.0.0.21 send-community extended
  no auto-summary
  exit-address-family
 !

Kozel

!
 ip vrf vrf101
  rd 1:101
  route-target export 1:101
  route-target import 1:101
 !
 ip cef
 !
 interface Loopback0
  ip address 223.0.0.21 255.255.255.255
 !
 interface Ethernet1/1
  ip vrf forwarding vrf101
  ip address 200.200.0.1 255.255.255.0
 !
 interface ATM4/0
  no ip address
  no ATM scrambling cell-payload
  no ATM ilmi-keepalive
  PVC qsaal 0/5 qsaal     
  PVC ilmi 0/16 ilmi
 !
 interface ATM4/0.1 tag-switching
  ip address 10.0.0.6 255.255.255.252
  tag-switching ATM vpi 2-4
  tag-switching ip
 !
 router ospf 1
  log-adjacency-changes
  network 10.0.0.0 0.0.0.255 area 0
  network 223.0.0.21 0.0.0.0 area 0
 !
 router rip
  version 2
  !
  address-family ipv4 vrf vrf101
  version 2
  redistribute bgp 1 metric 1
  network 200.200.0.0
  no auto-summary
  exit-address-family
 !
 router bgp 1
  no synchronization
  neighbor 125.2.2.2 remote-as 1
  neighbor 125.2.2.2 update-source Loopback0
  neighbor 223.0.0.3 remote-as 1
  neighbor 223.0.0.3 update-source Loopback0
  no auto-summary
  !
  address-family ipv4 vrf vrf101
  redistribute rip
  no auto-summary
  no synchronization
  exit-address-family
  !
  address-family vpnv4
  neighbor 125.2.2.2 activate
  neighbor 125.2.2.2 send-community extended
  neighbor 223.0.0.3 activate
  neighbor 223.0.0.3 send-community extended
  no auto-summary
  exit-address-family
 !

Medina

Current configuration:
 !
 ip vrf vrf101
  rd 1:101
  route-target export 1:101
  route-target import 1:101
 ip cef
 !
 interface Loopback1
  ip vrf forwarding vrf101
  ip address 11.2.2.2 255.255.255.252
 !
 interface ATM2/0
  no ip address
  no ATM ilmi-keepalive
 !
 interface ATM2/0.66 tag-switching
  ip address 125.1.4.2 255.255.255.252
  tag-switching ip
 !
 interface Ethernet1/1
  ip vrf forwarding vrf101
  ip address 11.3.3.1 255.255.255.252
 !
 router ospf 1
  network 125.1.4.0 0.0.0.3 area 0
  network 125.2.2.2 0.0.0.0 area 0
 !
 router rip
  version 2
  network 11.0.0.0
  !
  address-family ipv4 vrf vrf101
  version 2
  redistribute bgp 1 metric 1
  network 11.0.0.0
  no auto-summary
  exit-address-family
 !
 router bgp 1
  no synchronization
  neighbor 223.0.0.3 remote-as 1
  neighbor 223.0.0.3 update-source Loopback0
  neighbor 223.0.0.21 remote-as 1
  neighbor 223.0.0.21 update-source Loopback0
  !
  address-family ipv4 vrf vrf101
  redistribute connected
  redistribute static
  redistribute rip
  default-information originate
  no auto-summary
  no synchronization
  exit-address-family
  !
  address-family vpnv4
  neighbor 223.0.0.3 activate
  neighbor 223.0.0.3 send-community extended
  neighbor 223.0.0.21 activate
  neighbor 223.0.0.21 send-community extended
  exit-address-family
 !

Rapid

Current configuration:
 !
 interface Loopback0
  ip address 223.0.0.12 255.255.255.255
 !         
 interface Loopback2
  ip address 7.7.7.7 255.255.255.0
 !
 interface FastEthernet0/1
  ip address 150.150.0.2 255.255.255.0
  duplex auto
  speed auto
 !
 router rip
  version 2
  redistribute static
  network 7.0.0.0
  network 10.0.0.0
  network 150.150.0.0
  no auto-summary
 !
 ip route 158.0.0.0 255.0.0.0 Null0
 !

Damme

!
 interface Loopback1
  ip address 6.6.6.6 255.0.0.0
 !
 interface FastEthernet0/0
  ip address 10.200.10.14 255.255.252.0
  duplex auto
  speed autoa
 !
 router bgp 158
  no synchronization
  network 6.0.0.0
  network 10.200.0.0 mask 255.255.252.0
  neighbor 10.200.10.3 remote-as 1
  no auto-summary
 !

Pivrnec

Current configuration:
 !
 interface Loopback0
  ip address 223.0.0.22 255.255.255.255
 !
 interface Loopback1
  ip address 6.6.6.6 255.255.255.255
 !
 interface FastEthernet0/1
  ip address 200.200.0.2 255.255.255.0
  duplex auto
  speed auto
 !
 router rip
  version 2
  redistribute static
  network 6.0.0.0
  network 200.200.0.0
  no auto-summary
 !
 ip route 69.0.0.0 255.0.0.0 Null0
 !

Guilder

!
 interface Loopback2
  ip address 150.150.0.1 255.255.0.0
 !
 interface Ethernet0/2
  ip address 201.201.201.2 255.255.255.252
 !
 router bgp 69
  no synchronization
  network 7.7.7.0 mask 255.255.0.0
  network 150.150.0.0
  network 201.201.201.0 mask 255.255.255.252
  redistribute connected
  neighbor 201.201.201.1 remote-as 1
  no auto-summary
 !

Purkmister

Current configuration:
 !
 interface Loopback0
  ip address 11.5.5.5 255.255.255.252
 !
 interface FastEthernet0/1
  ip address 11.3.3.2 255.255.255.252
  duplex auto
  speed auto
 !
 router rip
  version 2
  network 11.0.0.0
 !

debug コマンドと show コマンド

debug コマンドを使用する前に、『デバッグ コマンドに関する重要な情報』を参照してください。 ルーティング固有のコマンドを次に示します。

  • show ip rip database vrf - 特定の VRF 用の RIP データベースに格納されている情報を表示します。

  • show ip bgp vpnv4 vrf - BGP テーブルの VPN アドレス情報を表示します。

  • show ip route vrf - VRF に関連付けられている IP ルーティング テーブルを表示します。

  • show ip route - すべてのスタティック IP ルート、または Authentication, Authorization, and Accounting(AAA; 認証、許可、アカウンティング)ルート ダウンロード機能を使用してインストールされたスタティック IP ルートを表示します。

一部の show コマンドは、show コマンド出力の分析を表示するアウトプットインタープリタ登録ユーザ専用)でサポートされています。


一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

PE ルータでは、PE-CE ルーティング方式(RIP、BGP、スタティックなど)と、PE-PE BGP アップデートによって、特定の VRF に対して使用されるルーティング テーブルが示されます。次の操作によって、特定の VRF に対する RIP 情報を表示できます。

Alcazaba# show ip rip database vrf vrf101
  0.0.0.0/0 auto-summary  
  0.0.0.0/0
  [2] via 150.150.0.2, 00:00:12, Ethernet1/1
  6.0.0.0/8 auto-summary
  6.6.6.6/32 redistributed
  [1] via 223.0.0.21,
  7.0.0.0/8 auto-summary
  7.7.7.0/24
  [1] via 150.150.0.2, 00:00:12, Ethernet1/1 
  10.0.0.0/8 auto-summary
  10.0.0.0/8 redistributed
  [1] via 125.2.2.2,
  10.0.0.0/16
  [1] via 150.150.0.2, 00:00:12, Ethernet1/1 
  10.200.8.0/22
  [1] via 150.150.0.2, 00:00:12, Ethernet1/1 
  11.0.0.0/8 auto-summary
  11.0.0.4/30 redistributed
  [1] via 125.2.2.2,
  11.1.1.0/30 redistributed
  [1] via 125.2.2.2,
  11.3.3.0/30 redistributed
  [1] via 125.2.2.2,
  11.5.5.4/30 redistributed
  [1] via 125.2.2.2,
  69.0.0.0/8 auto-summary
  69.0.0.0/8 redistributed
  [1] via 223.0.0.21,
  150.150.0.0/16 auto-summary
  150.150.0.0/24 directly connected, Ethernet1/1
  158.0.0.0/8
  [1] via 150.150.0.2, 00:00:17, Ethernet1/1
  200.200.0.0/24 auto-summary 
  200.200.0.0/24 redistributed 
  [1] via 223.0.0.21,

show ip bgp vpnv4 vrf コマンドを使えば、特定の VRF に対する BGP 情報を表示できます。 次の出力で i が付いているものは、内部 BGP(iBGP)に起因する PE-PE の出力を示しています。

Alcazaba# show ip bgp vpnv4 vrf vrf101 
    BGP table version is 46, local router ID is 223.0.0.3 
    Status codes: s suppressed, d damped, h history, * valid, best, i - internal    
    Origin codes: i - IGP, e - EGP, ? - incomplete  
  Network Next Hop Metric LocPrf Weight Path 
    Route Distinguisher: 1:101 (default for vrf vrf101) 
    *i6.6.6.6/32 223.0.0.21 1 100 0 ? 
    * 7.7.7.0/24 150.150.0.2 1 32768 ? 
    * 10.0.0.0/16 150.150.0.2 1 32768 ? 
    * 10.200.8.0/22 150.150.0.2 1 32768 ? 
    *i11.2.2.0/30 125.2.2.2 0 100 0 ? 
    *i11.3.3.0/30 125.2.2.2 0 100 0 ? 
    *i11.5.5.4/30 125.2.2.2 1 100 0 ? 
    *i69.0.0.0 223.0.0.21 1 100 0 ? 
    * 150.150.0.0/24 0.0.0.0 0 32768 ? 
    * 158.0.0.0/8 150.150.0.2 1 32768 ? 
    *i200.200.0.0 223.0.0.21 0 100 0 ?

PE ルータと CE ルータの両方の VRF 用のグローバル ルーティング テーブルを調べます。 これらの VRF は一致する必要があります。PE ルータの場合、show ip route vrf コマンドを使って、VRF を指定する必要があります。

Alcazaba# show ip route vrf vrf101
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP   
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
    i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, IA - ISIS inter area    
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route
     Gateway of last resort is not set
    B 69.0.0.0/8 [200/1] via 223.0.0.21, 00:11:03
    B 200.200.0.0/24 [200/0] via 223.0.0.21, 00:11:03
     6.0.0.0/32 is subnetted, 1 subnets
    B 6.6.6.6 [200/1] via 223.0.0.21, 00:11:03 
     7.0.0.0/24 is subnetted, 1 subnets
    R 7.7.7.0 [120/1] via 150.150.0.2, 00:00:05, Ethernet1/1 
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    R 10.0.0.0/16 [120/1] via 150.150.0.2, 00:00:05, Ethernet1/1 
    R 10.200.8.0/22 [120/1] via 150.150.0.2, 00:00:05, Ethernet1/1 
     11.0.0.0/30 is subnetted, 3 subnets
    B 11.3.3.0 [200/0] via 125.2.2.2, 00:07:05
    B 11.2.2.0 [200/0] via 125.2.2.2, 00:07:05
    B 11.5.5.4 [200/1] via 125.2.2.2, 00:07:05
     150.150.0.0/24 is subnetted, 1 subnets
    C 150.150.0.0 is directly connected, Ethernet1/1
    R 158.0.0.0/8 [120/1] via 150.150.0.2, 00:00:06, Ethernet1/1

Pivrnec でこれに相当するコマンドは、show ip route コマンドです。すべてのカスタマー(およびカスタマー エッジ)ルータにとっては、これが標準ルーティング テーブルになるためです。

Pivrnec# show ip route 
 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP  
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
   i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, IA - ISIS inter area  
   * - candidate default, U - per-user static route, o - ODR 
   P - periodic downloaded static route Gateway of last resort is not 
   set S 69.0.0.0/8 is directly connected, Null0 
   223.0.0.0/32 is subnetted, 1 subnets 
  C 223.0.0.22 is directly connected, Loopback0 
  C 200.200.0.0/24 is directly connected, FastEthernet0/1 
   6.0.0.0/32 is subnetted, 1 subnets 
  C 6.6.6.6 is directly connected, Loopback1 
   7.0.0.0/24 is subnetted, 1 subnets 
  R 7.7.7.0 [120/1] via 200.200.0.1, 00:00:23, FastEthernet0/1 
   10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks 
  R 10.0.0.0/16 [120/1] via 200.200.0.1, 00:00:23, FastEthernet0/1 
  R 10.200.8.0/22 [120/1] via 200.200.0.1, 00:00:24, FastEthernet0/1 
   11.0.0.0/30 is subnetted, 3 subnets 
  R 11.3.3.0 [120/1] via 200.200.0.1, 00:00:24, FastEthernet0/1 
  R 11.2.2.0 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1 
  R 11.5.5.4 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1 
   150.150.0.0/24 is subnetted, 1 subnets 
  R 150.150.0.0 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1 
  R 158.0.0.0/8 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1

MPLS ラベル

いずれかのルートに使用されているラベル スタックは、次のようにチェックします。

Alcazaba# show tag-switching forwarding-table vrf vrf101 11.5.5.5 detail    
    Local Outgoing Prefix Bytes tag Outgoing Next Hop
    tag tag or VC or Tunnel Id switched interface
    None 2/91 11.5.5.4/30 0 AT4/0.1 point2point
     MAC/Encaps=4/12, MTU=4466, Tag Stack{2/91(vcd=69) 37} 
     00458847 0004500000025000

Virtual Path Identifier と Virtual Channel Identifier(VPI; 仮想パス識別子/VCI; 仮想チャネル識別子)の関係とともにタグの割り当てを表示するには、『MPLS VPN のトラブルシューティング方法』に示されている通常のコマンドを使用できます。

アドレス オーバーラッピング

他の VPN に干渉を起こさずに、複数の VPN で同じアドレスを使用できます。 この例では、アドレス 6.6.6.6 が VPN 101 の Pivrnec と VPN 102 の Damme に 2 回接続されています。一方のサイトで ping コマンドを使用して、他方のサイトで debug ip icmp コマンドを使用すれば、この状態をチェックできます。

Guilder# ping 6.6.6.6
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
 Damme# debug ip icmp
    ICMP packet debugging is on
    6d22h: ICMP: echo reply sent, src 6.6.6.6, DST 201.201.201.2
    6d22h: ICMP: echo reply sent, src 6.6.6.6, DST 201.201.201.2
    6d22h: ICMP: echo reply sent, src 6.6.6.6, DST 201.201.201.2
    6d22h: ICMP: echo reply sent, src 6.6.6.6, DST 201.201.201.2
    6d22h: ICMP: echo reply sent, src 6.6.6.6, DST 201.201.201.2

デバッグの出力例

同じ設定を使用した出力例については、『MPLS VPN 環境のパケット フロー』を参照してください。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13732