LAN スイッチング : EtherChannel

Cisco IOS システム ソフトウェアが稼動する Catalyst スイッチと Cisco ルータ間での EtherChannel の設定

2005 年 3 月 29 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 12 月 15 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
      特記事項
設定
      ネットワーク ダイアグラム
      設定例
確認
      show コマンド
      show コマンドの出力例
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この設定例では、VLAN トランキングを使用せずに、Cisco ルータと Cisco IOS(R) システム ソフトウェアが稼動する Cisco Catalyst 6500 スイッチの間に、レイヤ 3(L3)の EtherChannel を設定する方法を紹介します。 EtherChannel は、その構成に使用したインターフェイスやポートの速度によって、Fast EtherChannel(FEC)または Gigabit EtherChannel(GEC)と呼ばれます。 この例では、Cisco ルータと Catalyst 6500 スイッチの 2 つのファースト イーサネット ポートが、FEC に組み込まれています。 この文書中では、FEC、GEC、ポート チャネル、チャネル、およびポート グループという用語は、すべて EtherChannel に関して使用されています。

この文書で紹介されているのは、スイッチとルータの設定ファイルと、それに関連する show コマンド使用例の出力だけです。

前提条件

要件

この設定を開始する前に、次の要件が満たされていることを確認してください。

  • Cisco IOS ソフトウェアが稼動する Catalyst 6500/6000 および 4500/4000 シリーズ スイッチ

    • Cisco IOS ソフトウェアが稼動する Catalyst 6000/6500 および 4500/4000 シリーズ スイッチは、任意のモジュール上の互換構成されたイーサネット インターフェイスを最大 8 個使用して、レイヤ 2(L2)および L3 EtherChannel 両方をサポートします。 各 EtherChannel でのすべてのインターフェイスは、同じ速度であることが必要です。 これらすべてを L2 または L3 インターフェイスのいずれかに設定する必要があります。

    • EtherChannel のロード バランシングでは、MAC アドレス、IP アドレス、または TCP ポート番号のいずれも使用できます。

      注:選択したモードは、そのスイッチで設定されているすべての EtherChannel に適用されることに注意してください。

    • Catalyst 6500/6000 では Cisco IOS ソフトウェア リリース 12.0 XE 以降、Catalyst 4500/4000 では Cisco IOS ソフトウェア リリース 12.1(8a)EW 以降。

  • Cisco ルータ

    • IP トラフィックは、ポート チャネルのインターフェイス経由で配信されますが、他のルーティング プロトコルでのトラフィックは単一リンクで送信されます。 ブリッジ トラフィックは、パケットの L3 情報に基づいて配信されます。 パケット内に L3 情報がない場合、そのトラフィックは最初のリンクで送信されます。

  • Etherchannel はさまざまなタイプの Cisco ルータでサポートされています。 Cisco ルータで、Etherchannel をサポートするプラットフォームやコードのバージョンを調べるには、Cisco Feature Navigator II を使用します。 EtherChannel をサポートするルータおよび Cisco IOS ソフトウェア リリースのリストは、FEC 項目の下にあります。

他の Cisco 製品での Etherchannel のためのハードウェアとソフトウェアの要件については、次の文書を参照してください。

使用するコンポーネント

この文書の情報は、次のソフトウェアとハードウェアのバージョンに基づいています。

  • Cisco IOS ソフトウェア リリース 12.1(8b)E10 が稼動している Catalyst 6500 スイッチ

  • Cisco IOS ソフトウェア リリース 12.1(21) が稼動している Cisco 7500 ルータ

この文書の Catalyst スイッチの設定は、Cisco IOS ソフトウェアが稼動する Catalyst 6500/6000 および Catalyst 4500/4000 シリーズの全スイッチに適用されます。

この文書の情報は、特定のラボ環境にあるデバイスに基づいて作成されています。 この文書内で使用されているデバイスはすべて、クリアな状態(デフォルト)から設定作業を始めています。 コマンドが実稼動中のネットワークに与える影響について理解しておいてください。

注:確実にデフォルト設定にするには、write erase コマンドを使用してすべてのデバイスの設定をクリアします。 write erase コマンドを発行してデフォルト外設定をすべて消去したら、必ずデバイスのリロードを行ってください。

表記法

文書表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

特記事項

物理インターフェイスで最初に channel-group コマンドを発行すると、自動的にポートチャネル インターフェイスが作成されます。 物理インターフェイスをチャネリングする前に、ポートチャネル インターフェイスを設定した場合は、まずポートチャネル インターフェイスを削除します。 これが該当するのは Catalyst スイッチだけです。 7500 ルータでは、設定の順序が変わります。 ポートチャネル インターフェイスを設定してから、物理インターフェイスのチャネル グループを設定する必要があります。

Cisco IOS ソフトウェアが稼動する Catalyst 6500/6000 と 4500/4000 では、ポートチャネルの設定順序が重要です。 物理インターフェイスで、まず switchport コマンドを発行してから、channel-group コマンドを発行することをお勧めします。

物理インターフェイス(インターフェイス ギガビット イーサネット 1/1)で、switchport コマンドより先に channel-group コマンドを発行すると、自動的にポートチャネル インターフェイスが作成され、L3 インターフェイスになります。 ここで、物理インターフェイスに switchport コマンドを発行すると、物理インターフェイスは L2 インターフェイスになります。 また、以前に作成したポートチャネル インターフェイスには、関連付けられている物理インターフェイスはありません。 物理インターフェイスには、channel-group コマンドを使用できないことに注意してください。 この場合、まず新しく設定したポートチャネル インターフェイスで switchport コマンドを発行します。 これにより、物理ポートは、再度、channel-group コマンドを受け付けます。 この場合、ポートチャネルは L3 インターフェイスから L2 インターフェイスに変わります。

これに対して、まず物理インターフェイスで switchport コマンドを発行し、次に channel-group コマンドを発行した場合のことを考えてみます。 この場合、ポートチャネル インターフェイスが自動的に作成され、設定済みのすべての switchport コマンドが継承されます。

Cisco IOS ソフトウェアが稼動している Catalyst 6500/6000 スイッチでは、デフォルトでは、すべてのポートが L3 ポートです。 Cisco IOS ソフトウェアが稼動している Catalyst 4500/4000 スイッチでは、デフォルトでは、すべてのポートが L2 ポートです。

設定

このセクションでは、この文書で説明する機能を設定するための情報を提供します。

注:この文書で使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザのみ)を使用してください。

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。


ネットワーク ダイアグラム

この文書では、次のネットワーク構成を使用しています。

135-a.gif

設定例

この文書では、次の構成を使用しています。

注:コメントおよび説明は、青い斜体で示されています。

Catalyst 6500 スイッチ(VLAN トランキングなし)

Building configuration...
   
  Current configuration : 5869 bytes
  !
  version 12.1
  service timestamps debug uptime
  service timestamps log uptime
  no service password-encryption
  !
  hostname cat6500
  !
  boot buffersize 126968
  boot system flash slot0:c6sup11-jsv-mz.121-8b.E15.bin
  boot bootldr bootflash:c6msfc-boot-mz.121-8b.E15
  enable password ww
  !
  redundancy
   main-cpu
    auto-sync standard
  ip subnet-zero
  !
  !
  no ip finger
  !
  !
  !
  !
  
  !--- この例では、L3 EtherChannel を設定します。
  !--- 詳細は、
  !--- EtherChannel の設定を参照してください。
  !--- ポートがチャネル グループに分類されると、
  !--- 論理ポートチャネル インターフェイスが自動的に作成されます。
  
  
  interface Port-channel 1
   ip address 11.1.1.2 255.255.255.0
   duplex full
   speed 100
  
  !--- ポートチャネル レベルで速度およびデュプレックスを指定すると、
  !--- これらの設定が物理ポートに渡されます。
  !--- つまり、物理ポートはポートチャネル インターフェイスと同じ速度と
  !--- デュプレックス設定を継承します。
  
   hold-queue 300 in
  !
  interface GigabitEthernet1/1
   no ip address
   shutdown
  !
  interface GigabitEthernet1/2
   no ip address
   shutdown
  !
  interface FastEthernet3/1
   no ip address
   duplex full
   speed 100
  
  !--- ポートは、チャネル グループ 1 のメンバです。ルータでは、EtherChannel ネゴシエーション
  !--- (ポート集約プロトコル(PAgP))がサポートされていないため、
  !--- PAgP は無効にする必要があります。 Catalyst 4500/4000 スイッチでは、
  !--- 全ポートがデフォルトで L2 ポートになります。 このポートを物理 L2 ポートから物理 L3 ポートに
  !--- no switchport コマンドを使用して変換します。
  
  channel-group 1 mode on
  interface FastEthernet3/2
   no ip address
   duplex full
   speed 100
  
  !--- ポートは、チャネル グループ 1 のメンバです。ルータでは、EtherChannel ネゴシエーション(PAgP)が
  !--- サポートされていないので、PAgP を無効にする必要があります。
  !--- Catalyst 4500/4000 スイッチでは、全ポートがデフォルトでレイヤ 2 ポートとなります。 
  !--- このポートを物理 L2 ポートから物理 L3 ポートに
  !--- no switchport コマンドを使用して変換します。
  
  
  channel-group 1 mode on
  interface FastEthernet3/3
   no ip address
   switchport
   switchport mode access
  !
  
  !--- 出力を省略
  
  !
  ip classless
  no ip http server
  !
  !
  !
  line con 0
   transport input none
  line vty 0 4
  !
  end

Cisco 7500 ルータ(VLAN トランキングなし)

  
  !--- 出力を省略
  
  !
  interface Port-channel1
   ip address 11.1.1.1 255.255.255.0
   full-duplex
   hold-queue 300 in
  !
  interface FastEthernet0/0
   no ip address
   full-duplex
   speed 100
   channel-group 1
  !
  interface FastEthernet0/1
   no ip address   
   full-duplex
   speed 100                              
   channel-group 1
  
  !--- 出力を省略
  
  

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を示します。

show コマンド

特定の show コマンドは、アウトプットインタープリタ登録ユーザのみ)によってサポートされています。これにより、show コマンド出力の分析を表示できます。

    一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。


  • show etherchannel channel-id port-channel - Cisco IOS スイッチのポート チャネルをチェックします。

  • show interfaces port-channel channel-id - Cisco IOS ルータのポート チャネルをチェックします。

show コマンドの出力例

Catalyst 6500/6000 スイッチ

  • show etherchannel channel-id port-channel

Router# show etherchannel 1 port-channel
  Port-channels in the group:
  ----------------------
  Port-channel: Po1
  ------------
  Age of the Port-channel = 01h:56m:20s
  Logical slot/port = 10/1 Number of ports in agport = 2
  GC = 0x00010001 HotStandBy port = null
  Passive port list = Fa3/1 Fa3/2
  Port state = Port-channel L3-Ag Ag-Inuse
  Ports in the Port-channel:
  Index Load Port
  -------------------
  0 55 Fa3/1
  1 AA Fa3/2
  Time since last port bundled: 01h:55m:44s Fa3/2
  Router#

Cisco 7500 ルータ

  • show interfaces port-channel channel-id

Router# show interfaces port-channel 1
  Port-channel1 is up, line protocol is up
  Hardware is FastEtherChannel, address is 00e0.1476.7600 (bia 0000.0000.0000)
  Internet address is 11.1.1.1/24
  MTU 1500 bytes, BW 400000 Kbit, DLY 100 usec, rely 255/255, load 62/255
  Encapsulation ARPA, loopback not set, keepalive set (10 sec), hdx
  ARP type: ARPA, ARP Timeout 04:00:00
  No. of members in this fechannel: 2
  Member 0 : FastEthernet0/0
  Member 1 : FastEthernet0/1
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 10:51:55
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/300, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 98281000 bits/sec, 8762 packets/sec
  4545 packets input, 539950 bytes, 0 no buffer
  Received 0 broadcasts, 0 runts, 0 giants
  0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
  0 watchdog, 0 multicast
  0 input packets with dribble condition detected
  342251216 packets output, 3093422680 bytes, 0 underruns
  0 output errors, 0 collisions, 0 interface resets
  0 babbles, 0 late collision, 0 deferred
  0 lost carrier, 0 no carrier
  0 output buffer failures, 0 output buffers swapped out

トラブルシューティング

現時点では、この設定に対して使用可能な特定のトラブルシューティング情報はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 21066