WAN : ポイントツーポイント プロトコル(PPP)

ルータ間の複数のマルチリンク バンドル

2005 年 1 月 5 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2010 年 2 月 4 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
背景説明
設定
      ネットワーク ダイアグラム
      設定
確認
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書では、ルータ間でマルチリンク バンドルを作成する場合の設定例を紹介します。 2 台のルータ間に複数のマルチリンクを作成するには、各バンドルごとに別々の認証されたユーザ名を設定する必要があります。

前提条件

要件

この文書に関する特別な要件はありません。

使用するコンポーネント

この文書の情報は、Cisco IOS(R) ソフトウェア リリース 12.0(7)T に基づいています。

この文書の情報は、特定のラボ環境にあるデバイスに基づいて作成されています。この文書内で使用されているデバイスはすべて、クリアな状態(デフォルト)から設定作業を始めています。対象のネットワークが実稼動中である場合には、すべてのコマンドによる潜在的な影響について確実に理解しておく必要があります。

表記法

文書表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

ここで設定されている例には、次の特徴があります。

  • 物理メンバ インターフェイス 1 つを持つマルチリンク インターフェイスを使用。

  • マルチリンク インターフェイスのバックアップとして BRI インターフェイスを使用。 この BRI インターフェイスにはマルチリンク機能があり、メインのマルチリンク インターフェイスの他の特性すべてを備えています。

  • バックアップ インターフェイスからメイン インターフェイスへ切り替える際には、互いに独立した 2 つのマルチリンク バンドルを使用します。 一方はマルチリンク インターフェイスからのもので、もう一方は BRI からのものです。 デフォルトでは、マルチリンク バンドルは認証されたユーザ名で識別されます。 ところが、これによりバックアップ(BRI)インターフェイスからメイン(マルチリンク)インターフェイスへの切り替えの際には、問題が生じます。 この設定例では、この問題を回避する方法を説明します。

設定

この項では、この文書で説明する機能を設定するための情報を提供します。

注:この文書で使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザのみ)を使用してください。 


一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

この文書では、次のネットワーク設定を使用します。

multilink_bundles.gif

設定

この文書では、次の設定を使用します。

  • Router3

  • Router2

Router3

Router3#show running-config 
 !
 version 12.0 
 !
 hostname Router3
 !
 !
 username MultilinkRouter2 password 0 cisco
 username Router2BRI password 0 cisco
 
 !--- ユーザ名は、リモート ルータでの ppp chap hostname コマンドで指定されているユーザ名と同じである必要があります。
 
 ! 
 !
 isdn switch-type basic-net3 
 ! 
 multilink bundle-name authenticated 
 
 !--- 認証されたユーザ名に基づいてバンドルを区別します
 
 !
 interface Multilink1
 ip address 192.168.19.6 255.255.255.0 
 no cdp enable
 ppp authentication chap
 ppp chap hostname MultilinkRouter3 
 
 !--- 別の CHAP ホスト名
 
 ppp chap password 7 121A0C041104
 ppp multilink
 multilink-group 1
 ! 
 interface Serial1
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 no fair-queue
 ppp multilink
 multilink-group 1
 !
 interface BRI0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 dialer rotary-group 1
 isdn switch-type basic-net3
 ppp authentication chap
 ppp multilink
 !
 interface Dialer1
 ip address 192.168.20.1 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 30
 dialer map ip 10.0.0.0 name Router2 broadcast 6084
 dialer map ip 192.168.20.2 name Router2 broadcast 6084
 dialer load-threshold 1 either
 dialer watch-group 1
 dialer-group 1
 ppp authentication chap
 ppp chap hostname Router3BRI 
 
 !--- 別の CHAP ホスト名
 
 ppp chap password 7 094F471A1A0A
 ppp multilink
 !
 router eigrp 1
 network 10.0.0.0
 network 192.168.19.0
 network 192.168.20.0
 no auto-summary
 eigrp log-neighbor-changes
 !
 ip classless
 no ip http server
 ! 
 access-list 150 deny eigrp any any
 access-list 150 deny udp any any
 access-list 150 permit ip any any
 dialer watch-list 1 ip 10.0.0.0 255.0.0.0
 dialer-list 1 protocol ip list 150
 !
 line con 0
 exec-timeout 0 0
 transport input none
 line aux 0
 line vty 0 4
 login
 !
 end

Router2

Router2#show running-config 
 !
 version 12.0 
 !
 hostname Router2
 !
 !
 username MultilinkRouter3 password 0 cisco
 username Router3BRI password 0 cisco
 
 !--- ユーザ名は、リモート ルータでの ppp chap hostname コマンドで指定されているユーザ名と同じである必要があります。
 
 !
 isdn switch-type basic-net3 
 !
 multilink bundle-name authenticated
 !
 interface Multilink1
 ip address 192.168.19.5 255.255.255.0 
 no cdp enable
 ppp authentication chap
 ppp chap hostname MultilinkRouter2
 ppp chap password 7 104D000A0618 
 
 !--- 別の CHAP ホスト名
 
 ppp multilink
 multilink-group 1
 ! 
 interface Serial1
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 no fair-queue
 clockrate 2000000
 ppp multilink
 multilink-group 1
 !
 interface BRI0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 dialer pool-member 1
 isdn switch-type basic-net3
 ppp authentication chap
 ppp multilink
 !
 interface Dialer1
 ip address 192.168.20.2 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 dialer remote-name Router3
 dialer pool 1
 dialer string 6082
 dialer-group 1
 ppp authentication chap
 ppp chap hostname Router2BRI 
 
 !--- 別の CHAP ホスト名
 
 ppp chap password 7 00071A150754
 ppp multilink
 !
 router eigrp 1
 network 10.0.0.0
 network 192.168.19.0
 network 192.168.20.0
 no auto-summary
 eigrp log-neighbor-changes
 ! 
 access-list 150 deny eigrp any any
 access-list 150 deny udp any any
 access-list 150 permit ip any any
 dialer-list 1 protocol ip list 150
 !
 !
 line con 0
 exec-timeout 0 0
 transport input none
 line aux 0
 line vty 0 4
 !
 end

確認

このセクションでは、設定が正しく動作していることを確認するために使用できる情報を提供します。

一部の show コマンドは、show コマンド出力の分析を表示するアウトプットインタープリタ登録ユーザのみ)でサポートされています。

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

  • show ppp multilink - ネットワークが正常に動作しているかどうかをテストします。

次に示す出力は、上記のネットワーク ダイアグラムにあるデバイス上で、これらのコマンドを入力した結果です。

Router3#show ppp multilink
 Multilink1, bundle name is MultilinkRouter2
 0 lost fragments, 0 reordered, 0 unassigned, sequence 0x0/0x0 rcvd/sent
 0 discarded, 0 lost received, 1/255 load
 Member links: 1 active, 0 inactive (max not set, min not set)
 Serial1
 Virtual-Access1, bundle name is Router2BRI
 Dialer interface is Dialer1
 0 lost fragments, 0 reordered, 0 unassigned, sequence 0x18/0x3F rcvd/sent
 0 discarded, 0 lost received, 1/255 load
 Member links: 2 (max not set, min not set)
 BRI0:1
 BRI0:2
 Router2#show ppp multilink
 Multilink1, bundle name is MultilinkRouter3
 0 lost fragments, 0 reordered, 0 unassigned, sequence 0x0/0x0 rcvd/sent
 0 discarded, 0 lost received, 1/255 load
 Member links: 1 active, 0 inactive (max not set, min not set)
 Serial1
 Virtual-Access1, bundle name is Router3BRI
 Dialer interface is Dialer1
 0 lost fragments, 0 reordered, 0 unassigned, sequence 0x18/0x3F rcvd/sent
 0 discarded, 0 lost received, 1/255 load
 Member links: 2 (max not set, min not set)
 BRI0:1
 BRI0:2

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 9500