スイッチ : Cisco Catalyst 6500 シリーズ スイッチ

PortFast と他のコマンドを使用したワークステーションの接続始動遅延の修復

2005 年 4 月 26 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2008 年 12 月 19 日) | フィードバック

内容

概要
はじめに
      表記法
      前提条件
      使用するコンポーネント
背景説明
      スパニング ツリー
      EtherChannel
      トランキング
      速度とデュプレックスのネゴシエーション
CatOS が稼動する Catalyst 4500/4000、5500/5000、および 6500/6000 スイッチ
      設定
      検証
      Catalyst 5500 で DTP、PAgP、および PortFast を使用する場合と使用しない場合のタイミング テスト
Cisco IOS システム ソフトウェアが稼動する Catalyst 6500/6000 スイッチ
      設定
      検証
      Cisco IOS システム ソフトウェアが稼動する Catalyst 6000 でのタイミング テスト
Cisco IOS システム ソフトウェアが稼動する Catalyst 4500/4000 スイッチ
      設定
      検証
      Cisco IOS システム ソフトウェアが稼動する Catalyst 4500/4000 でのタイミング テスト
Catalyst 2948G-L3/4908G-L3/4840G スイッチ
Catalyst 2900XL/3500XL/2950/3550 スイッチ
      設定
      検証
      Catalyst 2900XL のタイミング テスト
Catalyst 1900/2800 スイッチ
      設定
      検証
      Catalyst 1900 でのタイミング テスト
PortFast へのその他のメリット
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この資料は、ワークステーション(スイッチに接続)がネットワーク ドメイン(Windows NT または Novell)にログインできない、または Dynamic Host Configuration Protocol(DHCP; ダイナミック ホスト コンフィギュレーション プロトコル)アドレスを取得できない場合に発生する初期接続遅延について述べます。 この資料の手順の実装は容易で、ワークステーションの初期化/起動段階で生じるワークステーション接続遅延の最も一般的な原因に対処しています。

はじめに

表記法

文書表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

ワークステーション、端末、サーバという用語は、この文書では特に区別なく使用されています。 これらの用語は、1 枚の Network Interface Card(NIC; ネットワーク インターフェイス カード)によってスイッチに直接接続されているあらゆるデバイスを指しています。 また、NIC が冗長性の目的だけに使用されている複数の NIC が装備されたデバイスを指すこともあります。言い換えると、ワークステーションやサーバはブリッジとして機能するようには設定されていませんが、冗長性のために複数の NIC が装備されています。

注:サーバ NIC の中には、トランキングと EtherChannel の両方、あるいはそのどちらかをサポートするものがあります。 サーバが複数の VLAN 上で同時に稼働することが必要な状況(トランキング)、またはスイッチに接続するリンク(EtherChannel)上において、サーバ用に帯域幅がさらに必要になる状況があります。 これらの場合、Port Aggregation Protocol(PAgP; ポート集約プロトコル)を off にしたり、トランキングを off にすることはありません。 通常、これらのデバイスをオフやリセットにすることもありません。 この資料の手順は、これらのタイプのデバイスには適用されません。

前提条件

多くのユーザでデスクトップにスイッチングが配備され、共有ハブがスイッチに置き換えられることにより、クライアント/サーバ環境で初期接続遅延が頻繁に発生するようになっています。 最も一般的なケースとして、Windows 95/98/NT、Novell、VINES、IBM NetworkStation/IBM シンクライアント、および AppleTalk クライアントはそれぞれのサーバに接続できません。 これらのクライアント上のソフトウェアが起動処理中に持続しない場合は、トラフィックがスイッチをパススルーしてクライアントに到達するのをスイッチが許可する前に、クライアントはサーバへの接続をあきらめます。

注:この初期接続遅延は、多くの場合、ワークステーションの最初の起動時に出現するエラーとして発生します。 表示される可能性のあるエラー メッセージとエラーの例は、次のとおりです。

  • Microsoft ネットワーキング クライアントに No Domain Controllers Available. が表示される。

  • DHCP が No DHCP Servers Available. をレポートする。

  • Novell IPX ネットワーキング ワークステーションで起動時に Novell ログイン画面が表示されない。

  • AppleTalk ネットワーキング クライアントに Access to your AppleTalk network has been interrupted. To re-establish your connection, open and close the AppleTalk control panel. が表示される。 AppleTalk クライアントのセレクタ アプリケーションでゾーン リストが表示されないか、不完全なゾーン リストが表示される可能性もあります。

  • IBM ネットワーク ステーションに次のいずれかのメッセージが表示されます。

     NSB83619--Address resolution failed
     NSB83589--Failed to boot after 1 attempt
     NSB70519--Failed to connect to a server

    IBM はこの問題に対処するための修正プログラムを作成しており、これらは V2R1 コードの PTF 7 の中にあります。 この資料にリストされたスイッチに対して接続を試みる前に、ユーザのシステムの Network Station Firmware のレベルが B3052500(2000 年 5 月 25 日)であることを確認してください。

初期接続遅延は、ネットワーク管理者がソフトウェアやドライバをアップデートするスイッチ環境においても頻繁に見られます。 この場合、ベンダーはドライバを最適化してネットワーク初期化手順がクライアントの起動プロセスの早い段階で(スイッチがパケットを処理可能になる前に)行われるようにできます。

現在一部のスイッチに搭載されているいくつかの機能を使用すれば、スイッチが新たに接続されたワークステーションに対して作動するのに 1 分近くかかることがあります。 ワークステーションは、起動や再起動のたびに、この遅延による影響を受けます。 この遅延の原因となる主な 4 つ機能は、次のとおりです。

  • Spanning Tree Protocol(STP; スパニング ツリー プロトコル)

  • EtherChannel ネゴシエーション

  • トランキング ネゴシエーション

  • スイッチとワークステーション間のリンク速度/デュプレックス ネゴシエーション

上記の 4 つの機能は、最大の遅延の原因となる機能(STP)から最小の遅延の原因となる機能(速度とデュプレックスのネゴシエーション)の順に示されています。 通常、スイッチに接続されているワークステーションが原因でスパニング ツリー ループが発生することはなく、EtherChannel を必要とはせず、トランキング方式のネゴシエーションを行う必要がありません 始動時間を可能な限り最適化する必要がある場合は、リンク速度および検出のネゴシエーションをディセーブルにして、ポートの遅延を低減することもできます。

この資料では、3 つの Catalyst スイッチ プラットフォームで始動速度最適化コマンドを実装する方法について説明します。 タイミングのセクションでは、スイッチ ポート遅延がどのように、またどれだけ削減されるかが示されます。

この文書の例を作成するにあたり、次の装置を使用しました。

  • スイッチのスーパーバイザ エンジンに適したコンソール ケーブル

  • 設定をクリアした実験環境での Catalyst 5505 スイッチを 1 台。

    注:この文書は、他のネットワークに接続されていないラボ環境に基づいて作成されました。 コマンドは、必ず使用しているネットワークへの影響の可能性を把握してから、使用してください。

    注:スイッチがデフォルト設定になっていることを確認するために、clear config all コマンドが発行されています。

  • PagP とトランキング機能を持つ FastEthernet モジュール。

  • スイッチに接続する RJ-45 イーサネット クロスオーバー ケーブル 1 本。

  • スイッチに接続する PC。

使用するコンポーネント

この文書は特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

背景説明

ここでは、一部のスイッチに装備され、デバイスがスイッチに接続されている場合に初期遅延の原因となる 4 つの機能について説明します。 通常、ワークステーションはスパニング ツリー問題(ループ)を生じないか、一般的に PAgP と Dynamic Trunking Protocol(DTP; ダイナミック トランキング プロトコル)の両方、またはその一方の機能を必要としないかのどちらかであり、遅延はありません。

スパニング ツリー

ハブ環境からスイッチ環境へ移行したばかりの場合、スイッチの動作はハブと大きく異なるため、接続始動遅延が発生する場合があります。 スイッチは、物理層ではなくデータリンク層で接続を提供します。 スイッチはブリッジング アルゴリズムを使用して、ポートで受信されたパケットを別のポートに送り出す必要があるかどうかを判断します。 ブリッジング アルゴリズムは、ネットワーク トポロジ内の物理ループの影響を受けやすくなっています。 このループの影響の受け易さのため、スイッチは、ループをトポロジ内で除去させるプロトコル STP を実行します。 STP を実行すると、ループの検出とブロックが行われるため、スパニング ツリー プロセスに関与するすべてのポートがアクティブになるまでの時間が、そうでない場合よりも長くかかります。 物理ループを持つブリッジ ネットワークが STP を持たない場合は中断します。 時間はかかりますが、STP は有益です。 Catalyst スイッチで稼動する STP は業界標準の仕様です(IEEE 802.1d)。

スイッチ上のポートがリンクされブリッジ グループに加わると、STP をそのポートで実行します。 STP を実行するポートは、blockinglisteninglearningforwardingdisabled の 5 つのステートの内、いずれか 1 つのステートになります。 STP は、ポートに対して、blocking を開始して、すぐに listeninglearning のフェーズに進むよう指示を出します。 デフォルトでは、listening におよそ 15 秒、learning におよそ 15 秒が費やされます。 listening ステートの間、スイッチはポートがスパニング ツリー トポロジのどこに適合するかを探そうとします。 スイッチは特に、このポートが物理ループの一部かどうかを調べようとします。 ループの一部の場合、このポートは blocking モードに進むよう選択されます。 Blocking 中は、ループを除去するために、ポートでユーザ データの送受信は行われません。 ポートがループの一部ではない場合は learning ステートに進み、そこでこのポートで有効になっている MAC アドレスを取得します。 この STP 初期化プロセス全体では、約 30 秒かかります。

NIC カードを 1 枚だけ装備したワークステーションやサーバをスイッチ ポートに接続している場合、この接続では物理ループを生成できません。 これらの接続は、リーフノードと見なされます。 ワークステーションがループを生じない場合、スイッチがループをチェックする間ワークステーションを 30 秒間待機させる必要はありません。 シスコでは PortFast または Fast-Start 機能を追加しました。これは、このポートの STP が、このポートをループの一部ではないと見なしてただちに forwarding ステートへ進み、blockinglistening、または learning ステートを経由しないことを意味します。 このコマンドは、STP をオフにはしません。 このコマンドを使用すると、STP では、選択したポートで、最初のいくつかの(この状況では不要な)ステップがスキップされます。

注:別のスイッチ、ハブ、またはルータに接続されたスイッチ ポートでは、PortFast 機能を使用しないでください。 これらの接続は物理ループを生じる可能性があり、これらの状況においてスパニング ツリーが初期化手順をすべて経由することはきわめて重要です。 スパニング ツリー ループにより、ネットワークがダウンする可能性があります。 物理ループの一部になっているポートで PortFast をオンにすると、パケットを連続的に転送する時間枠が発生して(さらに数倍にもなって)、ネットワークが復旧できない場合があります。

EtherChannel

スイッチで利用できるその他の機能には、EtherChannel、Fast EtherChannel(FEC)、または Gigabit EtherChannel(GEC)があります。 これらの機能により、2 台の同一デバイス間の複数のリンクが 1 つの高速リンクのように機能し、リンク間でトラフィックのロード バランシングが行われるようになります。 スイッチは PAgP を使用して、近隣ルータとこれらのバンドルをつくることができます。 PAgP を実行できるスイッチ ポートは、通常、auto モードと呼ばれる受動モードにデフォルト設定されます。これは、リンク上の隣接デバイスの要求に応じてバンドルを形成することを意味します。 このプロトコルを auto モードで実行すると、制御が Spanning Tree Algorithm(STA; スパニング ツリー アルゴリズム)に渡される前に、ポートで最大 15 秒間の遅延が発生する可能性があります(PAgP は STP が実行する前にポートで実行します)。 ポートで作動する PAgP をワークステーションに接続させる必要はありません。 スイッチ ポートの PAgP モードを off に設定すると、この遅延が解消されます。

トランキング

スイッチの機能には、トランクを作成するポートの機能が含まれています。 トランクは 2 つのデバイス間で設定され、これは複数の VLAN からのトラフィックを伝えなければならない場合に行われます。 VLAN とは、スイッチによって作成されるもので、ワークステーションのグループがそれぞれのセグメントやブロードキャスト ドメインにあるように見せることができます。 トランク ポートはこうした VLAN の拡張を複数のスイッチ上に展開して、1 つの VLAN がキャンパス全体をカバーできるようにします。 これを実行するために、トランク ポートではパケットにタグを付けて、そのパケットがどの VLAN に属するかを示します。

トランキング プロトコルにはさまざまなタイプがあります。 ポートがトランクになることができると、自動的にトランキングする機能を持ったり、ときにはポートでどのタイプのトランキングを使用するかをネゴシエートしたりすることもできます。 DTP は、トランキング方式を別のデバイスとネゴシエートするためにこの機能を備えています。 DTP の原型は、Dynamic ISL(DISL; ダイナミック ISL)というプロトコルです。 これらのプロトコルを実行していると、スイッチ上のポートがアクティブになるのに遅延する可能性があります。

通常、ワークステーションに接続されているポートは 1 つの VLAN に属しているため、トランクは必要ありません。 ポートにトランクの形成をネゴシエートする機能がある場合、このポートは通常、デフォルトで auto モードになっています。 ポートのトランキング モードを off に変更すると、スイッチ ポートがアクティブになるための遅延はさらに減少します。

速度とデュプレックスのネゴシエーション

初期接続遅延を解決するには、通常は PortFast をオンにし、PAgP をオフ(存在する場合)にするだけで足ります。 少しでも秒数を減らしたい場合は、そのスイッチがマルチスピード ポート(10/100)であれば、スイッチのポート速度とデュプレックスを手動で設定することもできます。 オートネゴシエーションは優れた機能ですが、この機能をオフにすると Catalyst 5000 では 2 秒節約されます。 Catalyst 2800 や Catalyst 2900XL では、オートネゴシエーションはそれほど役には立ちません。

注:スイッチのオートネゴシエーションをオフにしながら、ワークステーションではこれをアクティブなままにしておくと、スイッチはクライアントとネゴシエートしません。 場合によっては、スイッチが使用しているデュプレックスの設定と同じ設定をクライアントが選択していないこともあります。 オートネゴシエーションの注意の詳細については、『イーサネット 10/100/1000Mb 半二重/全二重オートネゴシエーションの設定およびトラブルシューティング』を参照してください。

CatOS が稼動する Catalyst 4500/4000、5500/5000、および 6500/6000 スイッチ

次のコマンドは、PortFast をオン、PAgP ネゴシエーションをオフ、およびトランキング ネゴシエーション(DISL、DTP)をオフにする方法を示しています。 set spantree portfast コマンドは、ある範囲のポートに対して同時に実行できます(たとえば、set spantree portfast 2/1-12 enable)。 通常、set port channel コマンドは、チャネル対応ポートの有効なグループを使ってオフにする必要があります。 次の例では、モジュール 2 にはポート 2/1-2 やポート 2/1-4 とのチャネル機能があります。 これらのポートのグループは、いずれも使用できます。

注:Catalyst 4500/4000 および 5500/5000 用スイッチ ソフトウェアのバージョン 5.2 には、新しいコマンドが用意されています。 set port host は、次に掲載したコマンドを 1 つの使いやすいコマンドに結合するマクロです。

設定

 Switch -A> (enable) set spantree portfast 2/1 enable
 Warning: Spantree port fast start should only be enabled on ports connected to
 a single host. Connecting hubs, concentrators, switches, bridges, etc. to a
 fast start port can cause temporary spanning tree loops. Use with caution.
 		Spantree port 2/1 fast start enabled.
 Switch-A> (enable) set port channel 2/1-2 off
 Port(s) 2/1-2 channel mode set to off.
 Switch-A> (enable) set trunk 2/1 off
 Port(s) 2/1 trunk mode set to off.

設定の変更は、自動的に NVRAM に保存されます。

検証

この資料で使われているスイッチ ソフトウェアのバージョンは 4.5(1) です。 show version コマンドと show module コマンドの全出力結果については、この文書の「タイミング テスト」セクションを参照してください。

 Switch-A> (enable) show version
 WS-C5505 Software, Version McpSW: 4.5(1) NmpSW: 4.5(1)
 

次のコマンドは、STP に関するポートの現在のステートを表示する方法を示しています。 現在、ポートは STP forwarding ステート(パケットを送受信中)にあり、Fast-Start カラムは PortFast が現在ディセーブルであることを表示します。 ポートの初期化時は、常に、forwarding ステートへ進むのに少なくとも 30 秒はかかります。

 Switch-A> (enable) show port spantree 2/1
 Port      Vlan  Port-State     Cost   Priority  Fast-Start  Group-Method
 --------  ----  -------------  -----  --------  ----------  ------------
  2/1      1     forwarding        19        32  disabled
 

このスイッチ ポートで PortFast をイネーブルにします。 このコマンドを単一のホスト(ワークステーション、サーバなど)に接続されているポートだけで使用し、他のハブやスイッチに接続されているポートでは使用しないように、スイッチから警告が発せられます。 単一のホストでは、PortFast がイネーブルである場合、ポートが転送をただちに開始します。ワークステーションやサーバではネットワーク ループは生じません。

 Switch-A> (enable) set spantree PortFast 2/1 enable
 Warning: Spantree port fast start should only be enabled on ports connected
 to a single host.  Connecting hubs, concentrators, switches, bridges, etc. to
 a fast start port can cause temporary spanning tree loops.  Use with caution.
 Spantree port 2/1 fast start enabled.

PortFast がこのポートでイネーブルになっていることを検証するには、次のコマンドを発行します。

 Switch-A> (enable) show port spantree 2/1
 Port      Vlan  Port-State     Cost   Priority  Fast-Start  Group-Method
 --------  ----  -------------  -----  --------  ----------  ------------
  2/1      1     forwarding        19        32  enabled
 

1 つ以上のポートの PortFast 設定を表示する別の方法は、特定の VLAN の STP 情報を表示することです。 この文書の「タイミングのセクション」では、リアル タイムで進む STP の各段階を、スイッチにレポートさせる方法を示します。 次の出力では、転送遅延時間(15 秒)も表示されます。これは、VLAN の各ポートでは STP がどのくらいの時間 listening ステートであり、どのくらいの時間 learning ステートであるのかを表します。

 Switch-A> (enable) show spantree 1
 VLAN 1
 Spanning tree enabled
 Spanning tree type          ieee
 Designated Root             00-e0-4f-94-b5-00
 Designated Root Priority    8189
 Designated Root Cost        19
 Designated Root Port        2/24
 Root Max Age   20 sec    Hello Time 2  sec   Forward Delay 15 sec
 Bridge ID MAC ADDR          00-90-92-b0-84-00
 Bridge ID Priority          32768
 Bridge Max Age 20 sec    Hello Time 2  sec   Forward Delay 15 sec
 Port      Vlan  Port-State     Cost   Priority  Fast-Start  Group-Method
 --------- ----  -------------  -----  --------  ----------  ------------
  2/1      1     forwarding        19        32   enabled              
 ...

PAgP が off であることを検証するには、show port channel コマンド(下記)を実行します。 必ずモジュール番号(ここでは 2)を指定して、チャネルが形成されていない場合でもコマンドがチャネル モードを表示するようにします。 チャネルを形成しないで show port channel を発行すると、ポートのチャネリングがないことが表示されます。 さらに進み、現在のチャネル モードを表示する必要があります。

 Switch-A> (enable) show port channel
 No ports channeling
 Switch-A> (enable) show port channel 2
 Port  Status     Channel   Channel     Neighbor                  Neighbor
                  mode      status      device                    port
 ----- ---------- --------- ----------- ------------------------- ----------
  2/1  notconnect auto      not channel
  2/2  notconnect auto      not channel
 ...
 Switch-A> (enable) set port channel 2/1-2 off
 Port(s) 2/1-2 channel mode set to off.
 Switch-A> (enable) show port channel 2
 Port  Status     Channel   Channel     Neighbor                  Neighbor
                  mode      status      device                    port
 ----- ---------- --------- ----------- ------------------------- ----------
  2/1  connected  off       not channel
  2/2  connected  off       not channel
 ...

トランキング ネゴシエーションが off であることを検証するには、set trunk off コマンドを発行します。 次の例では、デフォルト状態を表示し、トランキングが off であることと結果の状態を表示します。 モジュール番号 2 を指定して、このモジュールにあるポートの現在のチャネル モードを表示できるようにします。

 Switch-A> (enable) show trunk 2
 Port      Mode         Encapsulation  Status        Native vlan
 --------  -----------  -------------  ------------  -----------
  2/1      auto         negotiate      not-trunking  1
  2/2      auto         negotiate      not-trunking  1
 ...
 Switch-A> (enable) set trunk 2/1-2 off
 Port(s) 2/1-2 trunk mode set to off.
 Switch-A> (enable) show trunk 2
 Port      Mode         Encapsulation  Status        Native vlan
 --------  -----------  -------------  ------------  -----------
  2/1      off          negotiate      not-trunking  1
  2/2      off          negotiate      not-trunking  1 
 ...

スイッチの速度とデュプレックスを手動で設定して速度/デュプレックス オートネゴシエーションをオフにする例は、まれな場合を除いて必要ないため、ここには示しません。

Catalyst 5500 で DTP、PAgP、および PortFast を使用する場合と使用しない場合のタイミング テスト

次のテストは、各種のコマンドを適用した場合、スイッチ ポートの初期化タイミングがどのようになるかを示しています。 最初に、ポートのデフォルト設定を使用して、ベンチマークを取得します。 PortFast はディセーブルに、PAgP(EtherChannel)モードは auto に設定(要求された場合はチャネリングを実行)、トランキング モード(DTP)は auto(要求された場合はトランクを実行)に設定されています。

テストを進め、PortFast を on にして時間を測定した後、PAgP を off にして時間を測定し、さらにトランキングをオフにして時間を測定します。 オートネゴシエーションが off になり、時間が測定されます。 これらのテストすべてを、DTP と PAgP をサポートする 10/100 Fast Ethernet カードが搭載された Catalyst 5500 上で行います。

注:PortFast を on にすることは、STP を off にすることと同じではありません(この文書で説明済み)。 PortFast が on 状態であっても、STP はポートで稼動しています。blockinglisteninglearning がスキップされ、ポートは直接に forwarding ステートに進みます。 STP を off にすることは推奨されません。これを行うと VLAN 全体に影響があり、ネットワークが物理的なトポロジ ループに対して脆弱になる可能性があります。 これは重大なネットワークの問題を引き起こす可能性があります。

  1. show version コマンドと show module コマンドを発行して、スイッチのソフトウェア バージョンと設定を表示します。

     Switch-A> (enable) show version
     WS-C5505 Software, Version McpSW: 4.5(1) NmpSW: 4.5(1)
     Copyright (c) 1995-1999 by Cisco Systems
     NMP S/W compiled on Mar 29 1999, 16:09:01
     MCP S/W compiled on Mar 29 1999, 16:06:50
     System Bootstrap Version: 3.1.2
     Hardware Version: 1.0  Model: WS-C5505  Serial #: 066507453
     Mod Port Model      Serial #  Versions
     --- ---- ---------- --------- ----------------------------------------
     1   0    WS-X5530   006841805 Hw : 1.3
                                   Fw : 3.1.2
                                   Fw1: 3.1(2)
                                   Sw : 4.5(1)
     2   24   WS-X5225R  012785227 Hw : 3.2
                                   Fw : 4.3(1)
                                   Sw : 4.5(1)
            DRAM                    FLASH                   NVRAM
     Module Total   Used    Free    Total   Used    Free    Total Used  Free
     ------ ------- ------- ------- ------- ------- ------- ----- ----- -----
     1       32640K  13648K  18992K   8192K   4118K   4074K  512K  119K  393K
     Uptime is 28 days, 18 hours, 54 minutes
     Switch-A> (enable) show module
     Mod Module-Name         Ports Module-Type           Model    Serial-Num Status
     --- ------------------- ----- --------------------- --------- --------- -------
     1                       0     Supervisor III        WS-X5530  006841805 ok
     2                       24    10/100BaseTX Ethernet WS-X5225R 012785227 ok
     Mod MAC-Address(es)                        Hw     Fw         Sw
     --- -------------------------------------- ------ ---------- -----------------
     1   00-90-92-b0-84-00 to 00-90-92-b0-87-ff 1.3    3.1.2      4.5(1)
     2   00-50-0f-b2-e2-60 to 00-50-0f-b2-e2-77 3.2    4.3(1)     4.5(1)
     Mod Sub-Type Sub-Model Sub-Serial Sub-Hw
     --- -------- --------- ---------- ------
     1   NFFC     WS-F5521  0008728786 1.0
  2. set logging level spantree 7 コマンドを発行して、STP のロギングを最も詳細な水準に設定します。 STP のデフォルトのログレベル(2)を次に示します。これは、重大な状況だけがレポートされることを意味します。

     Switch-A> (enable) show logging
     Logging buffer size:          500
             timestamp option:     enabled
     Logging history size:         1
     Logging console:              enabled
     Logging server:               disabled
             server facility:      LOCAL7
             server severity:      warnings(4)
     Facility            Default Severity         Current Session Severity
     -------------       -----------------------  ------------------------
     ...
     spantree            2                        2                    
     ...
     0(emergencies)        1(alerts)             2(critical)           
     3(errors)             4(warnings)           5(notifications)      
     6(information)        7(debugging)

    ポート上での STP のステートの変化を表示するには、STP のレベルを 7(デバッグ)に変更します。 この設定変更は、現在のターミナル セッションだけ継続します。

     Switch-A> (enable) set logging level spantree 7
     System logging facility <spantree> for this session set to severity 7(debugging)
     Switch-A> (enable) show logging
     ...
     Facility            Default Severity         Current Session Severity
     -------------       -----------------------  ------------------------
     ...
     spantree            2                        7                    
     ...
  3. 次のコマンドによって、ポートがシャットダウンされます。

     Switch-A> (enable) set port disable 2/1
     Port 2/1 disabled.
     
  4. 時間をチェックし、ポートをイネーブルにします。 スイッチが各ステートにある時間を判断します。 最も正確なタイミング情報を得るには、次のコマンドをできるだけ速く入力することが大切です。 1 つの方法として、各コマンド(この例では show timeset port enable 2/1)をテキスト ファイルの別々の行に入力します。これで、コマンドをクリップボードにコピーしてからスイッチにペーストできます。

     Switch-A> (enable) show time
     Fri Feb 25 2000, 12:20:17
     Switch-A> (enable) set port enable 2/1
     Port 2/1 enabled.
     Switch-A> (enable)
     2000 Feb 25 12:20:39 %PAGP-5-PORTTOSTP:
        Port 2/1 joined bridge port 2/1
     2000 Feb 25 12:20:39 %SPANTREE-6-PORTBLK: 
        port 2/1 state in vlan 1 changed to blocking.
     2000 Feb 25 12:20:39 %SPANTREE-6-PORTLISTEN: 
        port 2/1 state in vlane 1 changed to Listening.
     2000 Feb 25 12:20:53 %SPANTREE-6-PORTLEARN: 
        port 2/1 state in vlan 1 changed to Learning.
     2000 Feb 25 12:21:08 %SPANTREE-6-PORTFWD: 
        port 2/1 state in vlan 1 changed to forwarding.

    上の出力結果から、ポートが STP blocking ステージを開始するのに約 22 秒(20:17 〜 20:39)かかっていることがわかります。 この時間は、ブリッジ グループに加わり DTP と PAgP ネゴシエーションを完了するのに費やされています。 ブロッキングが開始されると、STP 領域にいることになります。 ブロッキング後、STP はただちに listening へ進みました(20:39 〜 20:39)。 Listening ステートでは約 14 秒(20:39 〜 20:53)かかっています。 learning ステート(forwarding ステートの開始まで)では 15 秒(20:53 〜 21:08)かかっています。 ポートがトラフィックに対して実際に動作可能になるまでの合計時間は、約 51 秒(20:17〜21:08)です。

    注:listeninglearning ステージは両方共 15 秒になり、技術的にはこれが、この VLAN 用に設定された自動転送遅延パラメータを示しています。 より正確に測定すれば、learning ステージは 15 秒です(14 秒と比較して、より近い値)。 ここで扱う測定法はいずれも完全に正確であるとはいえません。

  5. 上の出力結果と show spantree コマンド出力から、このポートでは STP が active であることがわかります。 ポートが forwarding ステートに達するのを遅らせる要因は他にもあります。 show port capabilities コマンドを発行すると、このポートがトランクを実行して EtherChannel を作成する機能があることが表示されます。 show trunk コマンドでは、このポートが auto モードであり、使用するトランキングのタイプをネゴシエートするように設定されていることが示されます(DTP でネゴシエートされる ISL または 802.1q)。

     Switch-A> (enable) show port capabilities 2/1
     Model                    WS-X5225R
     Port                     2/1
     Type                     10/100BaseTX
     Speed                    auto,10,100
     Duplex                   half,full
     Trunk encap type         802.1Q,ISL
     Trunk mode   on,off,desirable,auto,nonegotiate
     Channel      2/1-2,2/1-4
     Broadcast suppression    percentage(0-100)
     Flow control             receive-(off,on),send-(off,on)
     Security                 yes
     Membership               static,dynamic
     Fast start               yes
     Rewrite                  yes
     Switch-A> (enable) show trunk 2/1
     Port      Mode         Encapsulation  Status        Native vlan
     --------  -----------  -------------  ------------  -----------
      2/1      auto         negotiate      not-trunking  1
     ...
  6. このポートで PortFast をイネーブルにします。 トランキング ネゴシエーション(DTP)および EtherChannel(PAgP)は、auto モードのままになっています。

     Switch-A> (enable) set port disable 2/1
     Port 2/1 disabled.
     Switch-A> (enable) set spantree PortFast 2/1 enable
     Warning: Port fast start should only be enabled on ports connected to a
     single host. Connecting hubs, concentrators, switches, bridges, etc. to a fast
     start port can cause temporary spanning tree loops. Use with caution. 
     Spantree port 2/1 fast start enabled.
     Switch-A> (enable) show time
     Fri Feb 25 2000, 13:45:23
     Switch-A> (enable) set port enable 2/1
     Port 2/1 enabled.
     Switch-A> (enable) 
     Switch-A> (enable)
     2000 Feb 25 13:45:43 %PAGP-5-PORTTOSTP:
        Port 2/1 joined bridgeport 2/1
     2000 Feb 25 13:45:44 %SPANTREE-6-PORTFWD: 
        port 2/1 state in vlan 1 change to forwarding.

    合計時間は 21 秒です。 ブリッジ グループに加入するまで 20 秒かかります(45:23 〜 45:43)。 PortFast がイネーブルにされているため、STP が forwarding を開始するまで(30 秒ではなく)1 秒しかかかりません。 PortFast をイネーブルにすることにより、29 秒が節約されました。 遅延をさらに縮小できるか試します。

  7. PAgP モードを off にします。 show port channel コマンドにより PAgP モードが auto に設定されていることがわかります。つまり、PAgP が稼動している隣接ルータから要求された場合、チャネルが実行されます。 最小でも 2 ポートのグループに対して、チャネリングを off にする必要があります。 個々のポートに対して、チャネリングを off にすることはできません。

     Switch-A> (enable) show port channel 2/1
     Port  Status     Channel   Channel     Neighbor                  Neighbor
                      mode      status      device                    port
     ----- ---------- --------- ----------- ------------------------- ---------- 
      2/1  connected  auto      not channel
     Switch-A> (enable) set port channel 2/1-2 off
     Port(s) 2/1-2 channel mode set to off.
  8. ポートをシャットダウンして、テストを繰り返します。

     Switch-A> (enable) set port disable 2/1
     Port 2/1 disabled.
     Switch-A> (enable) show time
     Fri Feb 25 2000, 13:56:23
     Switch-A> (enable) set port enable 2/1
     Port 2/1 enabled.
     Switch-A> (enable)
     2000 Feb 25 13:56:32 %PAGP-5-PORTTOSTP:
        Port 2/1 joined bridgeport 2/1
     2000 Feb 25 13:56:32 %SPANTREE-6-PORTFWD: 
        port 2/1 state in vlan 1 changed to forwarding.

    forwarding ステートに達するのに、前のテストでは 21 秒でしたが、今回は 9 秒(56:23 〜 56:32)しかかからないことが分かります。 このテストでは PAgP を auto から off に変更することにより、およそ 12 秒が節約されました。

  9. トランキングを(auto ではなく)off にして、ポートが forwarding ステートに達するのにかかる時間に、どのような影響があるかを確認します。 ポートを off してから on にして、時間を記録します。

     Switch-A> (enable) set trunk 2/1 off
     Port(s) 2/1 trunk mode set to off.
     Switch-A> (enable) set port disable 2/1
     Port 2/1 disabled.

    トランキングを(auto ではなく)off に設定してテストを開始します。

     Switch-A> (enable) show time
     Fri Feb 25 2000, 14:00:19
     Switch-A> (enable) set port enable 2/1
     Port 2/1 enabled.
     Switch-A> (enable)
     2000 Feb 25 14:00:22 %PAGP-5-PORTTOSTP:
        Port 2/1 joined bridge port 2/1
     2000 Feb 25 14:00:23 %SPANTREE-6-PORTFWD: 
        port 2/1 state in vlan 1 change for forwarding.

    STP forwarding ステートに達するまでに 4 秒しかかからなかったため(00:19 〜 00:22)、開始時点で数秒間節約されました。 トランキング モードを auto から off に変更することにより、およそ 5 秒が節約されました。

  10. (オプション) スイッチ ポート初期化時間が問題の場合、すぐに解決する必要があります。 時間をさらに数秒削減する必要がある場合は、オートネゴシエーションを使用する代わりに、ポート速度とデュプレックスを手動で設定できます。

    この手順は、通常始動遅延問題の解決では必要ではありません。

    一方の側において手動で速度とデュプレックスを設定すると、速度とデュプレックスを別の側でも同じように設定する必要があります。 これは、ポート速度とデュプレックスを設定すると、ポートのオートネゴシエーションがディセーブルにされ、接続デバイスからオートネゴシエーション パラメータを参照できなくなるためです。 接続デバイスは半二重でだけ接続を行うため、その結果デュプレックスの不一致によりパフォーマンスが低下してポート エラーが発生します。 一方の側で速度とデュプレックスを設定する場合は、接続デバイスでも同じように速度とデュプレックスを設定してこれらの問題を回避する必要があることを忘れないでください。

    速度とデュプレックスを設定した後でポートのステータスを表示するには、show port コマンドを発行します。

     Switch-A> (enable) set port speed 2/1 100
     Port(s) 2/1 speed set to 100Mbps.
     Switch-A> (enable) set port duplex 2/1 full
     Port(s) 2/1 set to full-duplex.
     Switch-A> (enable) show port
     Port  Name               Status     Vlan       Level  Duplex Speed Type
     ----- ------------------ ---------- ---------- ------ ------ ----- ------------
      2/1                     connected  1          normal   full   100 10/100BaseTX
     ...

    タイミング結果は、次のとおりです。

     Switch-A> (enable) show time
     Fri Feb 25 2000, 140528 Eastern
     Switch-A> (enable) set port enable 2/1
     Port 2/1 enabled.
     Switch-A> (enable)
     2000 Feb 25 140529 Eastern -0500 %PAGP-5-PORTTOSTP:
        Port 2/1 joined bridgeport 2/1
     2000 Feb 25 140530 Eastern -0500 %SPANTREE-6-PORTFWD: 
        port 2/1 state in vlan 1 changed to forwarding.

    最終結果で 2 秒の時間(0528 〜 0530)が示されます。

  11. スイッチに接続された PC で、スイッチに向けて連続的な PING(ping -t)を使用した、目視による別の時間のテスト(時計を使用)を開始しました。 ケーブルをスイッチから取りはずすと、PING が失敗し始めました。 ケーブルをスイッチに再度接続して、時計を調べてスイッチが PC からの PING への応答にどれだけ時間がかかったかを調べます。

    速度とデュプレックスを on にしたオートネゴシエーションでは約 5 〜 6 秒かかり、速度とデュプレックスを off にしたオートネゴシエーションでは約 4 秒かかっています。 このテストには変動要素が多数ありますが(PC 初期化、PC ソフトウェア、要求に応答するスイッチ コンソール ポートなど)、PC 側から見た応答を得るのにかかる時間の認識がこのテストの最も重要な部分でした。 上のすべてのテストは、スイッチの内部デバッグ メッセージから見たものです。

Cisco IOS システム ソフトウェアが稼動する Catalyst 6500/6000 スイッチ

次のコマンドは、スパニング ツリー PortFast を on にして、トランキング ネゴシエーション(DISL、DTP)を off にする方法を示しています。 このオペレーティング システムでは、ポートを EtherChannel に追加するまで PAgP はアクティブになりません。 PAgP を off にする必要はありません。 これらのコマンドは interface range コマンドを発行することにより、ポートのグループに一度に適用できます。 次のコマンドを使用すると、コマンドをポート 3/2 から 3/4 へ同時に適用できます。(コマンド interface range fastEthernet 3/2 -4 の中で 2 と - の間には、構文エラーを防ぐためにスペースが必須です)。

 Native_IOS# conf t
 Enter configuration commands, one per line.  End with CNTL/Z.
 Native_IOS(config)# interface range fastEthernet 3/2 -4
 Native_IOS(config-if-range)#

これらの例では、1 つのポートだけが使用されます。 Cisco IOS ソフトウェアのポートは、ルータ上の場合と同様、ルーティングされたポート(レイヤ 3(L3))になるようデフォルト設定されます。 ここでは、これらのコマンドをスイッチ ポート(レイヤ 2(L2))として設定されたポートに追加するだけです。これらは L2 プロトコル(スパニング ツリーと DTP)を実行するポートであるために、始動遅延が発生しやすいことがその理由です。 ルーティングされたポートをスイッチド ポートにするには、switchport コマンド(後ろにパラメータを付けない)をインターフェイス モードで使用します。

設定

ここではまずデフォルト(L3)ステートのポートを使用し、それをスイッチポートに設定し(その回線上で switchport コマンドを使用)、それをアクセス ポート(専用)に設定して DTP を off にし、スパニング ツリー PortFast 機能を on にして、それから、設定を保存します。 次の最初のコマンド show run interface fastEthernet 3/13 は、このポートの現在の設定を表示します。

 Native_IOS# show run interface fastEthernet 3/13
 Building configuration...
 Current configuration : 61 bytes
 !
 interface FastEthernet3/13
  no ip address
  shutdown
 end
 Native_IOS# conf t
 Enter configuration commands, one per line.  End with CNTL/Z.
 Native_IOS(config)# interface fastEthernet 3/13
 Native_IOS(config-if)# switchport
 Native_IOS(config-if)# switchport mode access
 Native_IOS(config-if)# spanning-tree portfast 
 %Warning: PortFast should only be enabled on ports connected to a single host.
  Connecting hubs, concentrators, switches,  bridges, etc.to this interface
  when PortFast is enabled, can cause temporary Spanning Tree loops.
  Use with CAUTION
 %PortFast has been configured on FastEthernet3/13 but will only
  have effect when the interface is in a non-trunking mode.
 Native_IOS(config-if)# no shutdown
 Native_IOS(config-if)# ^Z
 Native_IOS# copy run start
 

検証

この文書で使用されているスイッチ ソフトウェアのバージョンは、Cisco IOS ソフトウェア リリース 12.1(6)E です。 show version コマンドと show module コマンドの全出力結果については、この文書の「タイミング テスト」セクションを参照してください。

 Native_IOS# show version
 Cisco Internetwork Operating System Software 
 IOS (tm) c6sup1_rp Software (c6sup1_rp-JSV-M), Version 12.1(6)E, EARLY DEPLOYME)
 

次に、前述の変更後、設定がどのようになるかを示します。

 Native_IOS# show run interface fastEthernet 3/13
 Building configuration...
 Current configuration : 109 bytes
 !
 interface FastEthernet3/13
  no ip address
  switchport
  switchport mode access
  spanning-tree portfast
 end
 Native_IOS# show interfaces fastEthernet 3/13 switchport 
 Name: Fa3/13
 Switchport: Enabled
 Administrative Mode: static access
 Operational Mode: static access
 Administrative Trunking Encapsulation: negotiate
 Operational Trunking Encapsulation: native
 Negotiation of Trunking: Off
 Access Mode VLAN: 1 (default)
 Trunking Native Mode VLAN: 1 (default)
 Trunking VLANs Enabled: ALL
 Pruning VLANs Enabled: 2-1001
 Native_IOS# show spanning-tree interface fastEthernet 3/13
  Port 141 (FastEthernet3/13) of VLAN1 is forwarding
    Port path cost 19, Port priority 128, Port Identifier 128.141.
    Designated root has priority 32768, address 00d0.024f.6001
    Designated bridge has priority 32768, address 00d0.024f.6001
    Designated port id is 128.141, designated path cost 0
    Timers: message age 0, forward delay 0, hold 0
    Number of transitions to forwarding state: 1
    BPDU: sent 8984, received 0
    The port is in the PortFast mode
 Native_IOS#

Cisco IOS システム ソフトウェアが稼動する Catalyst 6000 でのタイミング テスト

次のテストは、各種のコマンドを適用した場合、スイッチ ポートの初期化タイミングがどのようになるかを示しています。 最初に、ポートのデフォルト設定を使用して、ベンチマークを取得します。 PortFast はディセーブルにされ、トランキング モード(DTP)は auto に設定されます(トランキングの要求があった場合にトランキングを行います)。 このオペレーティング システムでは、PAgP はデフォルトではアクティブではありません。 この後、テストは PortFast を on にして時間を測定し、トランキングを off にして時間を測定します。 最後に、オートネゴシエーションを off にして時間を測定します。

注:PortFast を on にすることは、STP を off にすることと同じではありません(この文書で説明済み)。 PortFast が on 状態であっても、STP はポートで稼動しています。blockinglisteninglearning がスキップされ、ポートは直接に forwarding ステートに進みます。 STP を off にすることは推奨されません。これを行うと VLAN 全体に影響があり、ネットワークが物理的なトポロジ ループに対して脆弱になる可能性があります。 これは重大なネットワークの問題を引き起こす可能性があります。

  1. show version コマンドと show module コマンドを発行して、スイッチのソフトウェア バージョンと設定を表示します。

     Native_IOS# show version
     Cisco Internetwork Operating System Software 
     IOS (tm) c6sup1_rp Software (c6sup1_rp-JSV-M), Version 12.1(6)E, EARLY DEPLOYME)
     TAC Support: http://www.cisco.com/pcgi-bin/ibld/view.pl?i=support
     Copyright (c) 1986-2001 by cisco Systems, Inc.
     Compiled Sat 17-Mar-01 00:14 by eaarmas
     Image text-base: 0x60020950, data-base: 0x6165E000
     ROM: System Bootstrap, Version 12.0(3)XE, RELEASE SOFTWARE 
     BOOTFLASH: MSFC Software (C6MSFC-BOOT-M), Version 12.1(6)E, EARLY DEPLOYMENT RE)
     Native_IOS uptime is 12 hours, 36 minutes
     System returned to ROM by reload (SP by reload)
     System image file is "sup-bootflash:c6sup11-jsv-mz.121-6.E"
     cisco Catalyst 6000 (R5000) processor with 114688K/16384K bytes of memory.
     Processor board ID SAD04281AF6
     R5000 CPU at 200Mhz, Implementation 35, Rev 2.1, 512KB L2 Cache
     Last reset from power-on
     Bridging software.
     X.25 software, Version 3.0.0.
     SuperLAT software (copyright 1990 by Meridian Technology Corp).
     TN3270 Emulation software.
     24 Ethernet/IEEE 802.3 interface(s)
     1 Virtual Ethernet/IEEE 802.3  interface(s)
     48 FastEthernet/IEEE 802.3 interface(s)
     4 Gigabit Ethernet/IEEE 802.3 interface(s)
     381K bytes of non-volatile configuration memory.
     4096K bytes of packet SRAM memory.
     16384K bytes of Flash internal SIMM (Sector size 256K).
     Configuration register is 0x2102
     Native_IOS# show module
     Slot Ports Card Type                                 Model                 Serir
     ---- ----- ----------------------------------------- --------------------- -----
      1     2   Cat 6000 sup 1 Enhanced QoS (active)      WS-X6K-SUP1A-2GE      SAD0 
      2     2   Cat 6000 sup 1 Enhanced QoS (other)       WSSUP1A-2GE           SAD0 
      3    48   48 port 10/100 mb RJ45                    WS-X6348-RJ-45        SAD0 
      6    24   24 port 10baseFL                          WS-X6024-10FL-MT      SAD0 
     Slot MAC addresses                      Hw    Fw           Sw
     ---- ---------------------------------- ----- ------------ ----------
      1   00d0.c0d2.5540 to 00d0.c0d2.5541   3.2   unknown      6.1(0.105)OR
      2   00d0.bceb.8bb4 to 00d0.bceb.8bb5   5.0   unknown      unknown     
      3   0002.7ef1.36e0 to 0002.7ef1.370f   1.1   5.3(1) 1999- 6.1(0.105)OR
      6   00d0.9738.5338 to 00d0.9738.534f   0.206 5.3(1) 1999- 6.1(0.105)OR
  2. さまざまなスパニング ツリーのステートを表示し、いつポートでデータの送受信が可能になるかを判断するには、デバッグをオンにします。 表示されているメッセージ内のタイミング情報を表示するには、タイムスタンプをオンにします。 Cisco IOS ソフトウェアでは、スイッチ プロセッサ(SP)とルータ プロセッサ(RP)が連携し、CLI を管理する RP とともに 1 つの Command Line Interface(CLI; コマンドライン インターフェイス)をユーザに表示します。 各モジュールは、さまざまな機能に対しての責任を陰で負っています。 スイッチ ポート(L2)に設定されたポートで作動するスパニング ツリーのデバッグを表示するには、デバッグを SP 上でオンにする必要があります。 これを実行するには、remote login コマンドを発行して SP にアクセスします。 プロンプトが変わり、SP にアクセスしたことがわかります。 RP に戻るには、(下のメッセージで示されている「^C^C^C」ではなく)exit コマンドを発行します。 デバッグ情報を対象にしているポート(debug interface fastEthernet 3/13)だけに限定して、SP のスパニング ツリー デバッグをオンします。 この実行後、RP に戻り、テストを続行します。 スイッチは、デバッグ出力をコンソールに送信するようデフォルト設定されます。

     Native_IOS# conf t
     Native_IOS(config)# service timestamps debug datetime msec
     Native_IOS(config)# service timestamps log datetime msec
     
     
     !--- タイムスタンプをオンにすると、デバッグやログ メッセージの両方または片方が
     !--- 作成されるたびに、時間が出力されます。 これにより、さまざまなメッセージ間の
     !--- 時間を測定できるようになります。
     
     Native_IOS(config)# exit
     Native_IOS# remote login
     Trying Switch ...
     Entering CONSOLE for Switch
     Type "^C^C^C" to end this session
     Switch-sp# debug interface fastEthernet 3/13
     Condition 1 set
     Switch-sp# debug spanning-tree events
     spanning tree event debugging is on
     Switch-sp# exit
     [Connection to Switch closed by foreign host]
     Native_IOS#
  3. 次のコマンドによって、ポートがシャットダウンされます。

     Native_IOS# conf t
     Enter configuration commands, one per line.  End with CNTL/Z.
     Native_IOS(config)# Int f3/13
     Native_IOS(config-if)# shutdown
     Native_IOS(config-if)# ^Z                 
     Native_IOS#
  4. 時間をチェックしてポートをイネーブルにし、スイッチの各ステートでの時間を判断します。 最も正確なタイミング情報を得るには、次のコマンドをできるだけ速く入力することが大切です。 1 つの方法として、各コマンド(この例では show clockconf tInt f3/13 No shut)をテキスト ファイルの別々の行に入力します。これで、コマンドをクリップボードにコピーしてからスイッチにペーストできます。

     Native_IOS# show run int f3/13 
     Building configuration...
     Current configuration : 71 bytes
     !
     interface FastEthernet3/13
      no ip address
      shutdown
      switchport
     end
     Native_IOS# show clock
     *08:35:55.059 UTC Sun Jan 2 2000
     Native_IOS# conf t
     Enter configuration commands, one per line.  End with CNTL/Z.
     Native_IOS(config)#Int f3/13
     Native_IOS(config-if)#No shut
     *Jan  2 08:36:00.847: SP: STP: VLAN1 Fa3/13 -> listening
     *Jan  2 08:36:15.847: SP: STP: VLAN1 Fa3/13 -> learning
     *Jan  2 08:36:30.847: SP: STP: VLAN1 Fa3/13 -> forwarding

    上の出力結果から、ポートが STP listening ステージを開始するのに約 5.8 秒(35:55 〜 36:00)かかっていることがわかります。 この時間は、ブリッジ グループに加入して DTP ネゴシエーションを完了するのに要した時間です。 listening ステートに 15 秒(36:00 〜 36:15)かかっています。 learning ステート(forwarding ステートの開始まで)は 15 秒(36:15 〜 36:30)かかっています。 ポートがトラフィックに対して実際に動作可能になるまでの合計時間は、約 35 秒(35:55 〜 36:30)です。

  5. 上の出力結果が示すように、STP はこのポートでアクティブです。 ポートが forwarding ステートに達するのを遅らせる要因は他にもあります。 show int f3/13 switchport コマンドでは、リンクの相手側がトランク状態になる場合、このポートがダイナミックにトランク状態になることを示します(管理モードは dynamic desirable)。ただし、現在のオペレーション モードは、スタティック アクセスです(相手側ではトランクを望まない場合)。 トランキングのネゴシエーションが on であり、テストの間、継続してオンであることに注意します。

     Native_IOS# show int f3/13 switchport 
     Name: Fa3/13
     Switchport: Enabled
     Administrative Mode: dynamic desirable
     Operational Mode: static access
     Administrative Trunking Encapsulation: negotiate
     Operational Trunking Encapsulation: native
     Negotiation of Trunking: On
     Access Mode VLAN: 1 (default)
     Trunking Native Mode VLAN: 1 (default)
     Trunking VLANs Enabled: ALL
     Pruning VLANs Enabled: 2-1001
  6. このポートの PortFast をイネーブルにします。 トランキング ネゴシエーション(DTP)は auto モードのままになっています。

     Native_IOS# conf t
     Enter configuration commands, one per line.  End with CNTL/Z.
     Native_IOS(config)# int f3/13
     Native_IOS(config-if)# spanning-tree portfast 
     %Warning: PortFast should only be enabled on ports connected to a single host.
      Connecting hubs, concentrators, switches,  bridges, etc.to this interface
      when PortFast is enabled, can cause temporary spanning tree loops.
      Use with CAUTION
     %PortFast has been configured on FastEthernet3/13 but will only
      have effect when the interface is in a non-trunking mode.
     Native_IOS(config-if)# shutdown
     Native_IOS(config-if)# ^Z
     Native_IOS#

    テストを実行します。

     Native_IOS# show clock
     *08:41:09.531 UTC Sun Jan 2 2000
     Native_IOS# conf t
     Enter configuration commands, one per line.  End with CNTL/Z.
     Native_IOS(config)# Int f3/13
     Native_IOS(config-if)# No shut
     *Jan  2 08:41:15.175: SP: STP: VLAN1 Fa3/13 ->jump to forwarding from blocking

    合計時間は、約 5.7 秒(41:09 〜 41:15)です。 PortFast をイネーブルにすることにより約 30 秒が節約されました。 遅延をさらに縮小できるか試します。

  7. トランキングを(オートではなく)off にして、ポートが forwarding ステートに達するのにかかる時間に、どのような影響があるかを確認します。 再度、ポートを off してから on にして、時間を記録します。 Cisco IOS ソフトウェアでトランキングを off にするには、switchport mode access コマンドを発行します。

     Native_IOS# conf t
     Enter configuration commands, one per line.  End with CNTL/Z.
     Native_IOS(config)# Int f3/13
     Native_IOS(config-if)# switchport mode access
     Native_IOS(config-if)# shutdown
     Native_IOS(config-if)# ^Z
     Native_IOS#

    トランキングを(auto ではなく)off に設定した状態でテストを開始します。

     Native_IOS# show clock
     *08:42:01.767 UTC Sun Jan 2 2000
     Native_IOS# conf t
     Enter configuration commands, one per line.  End with CNTL/Z.
     Native_IOS(config)# Int f3/13
     Native_IOS(config-if)# No shut
     *Jan  2 08:42:04.363: SP: STP: 
        VLAN1 Fa3/13 ->jump to forwarding from blocking

    STP forwarding ステートに達するまでに約 3 秒かかっているので(00:19 〜 00:22)、開始時点で数秒間節約されました。 トランキング モードを auto から off に変更することにより、およそ 2 秒が節約されました。

  8. (オプション) スイッチ ポート初期化時間が問題の場合、すぐに解決する必要があります。 時間をさらに数秒削減する必要がある場合は、オートネゴシエーションを使用する代わりに、ポート速度とデュプレックスを手動で設定できます。

    このステップは、通常、始動遅延問題の解決には必要ではなく、リンクの相手側がオートネゴシエーションではなく、同じ設定で手動設定されていると、実際はパフォーマンス問題につながる可能性があることに注意してください。

    手動で速度とデュプレックスを設定すると、速度とデュプレックスを別の側でも同じように設定する必要があります。 これは、ポート速度とデュプレックスを設定すると、ポートのオートネゴシエーションがディセーブルにされ、接続デバイスからオートネゴシエーション パラメータを参照できなくなるためです。 接続デバイスは半二重でだけ接続を行うため、その結果デュプレックスの不一致によりパフォーマンスが低下してポート エラーが発生します。 一方の側で速度とデュプレックスを設定する場合は、接続デバイスでも同じように速度とデュプレックスを設定してこれらの問題を回避する必要があることを忘れないでください。

     Native_IOS# conf t
     Enter configuration commands, one per line.  End with CNTL/Z.
     Native_IOS(config)# Int f3/13
     Native_IOS(config-if)# speed 100  
     Native_IOS(config-if)# duplex full
     Native_IOS(config-if)# shutdown
     Native_IOS(config-if)# ^Z
     Native_IOS#

    タイミング結果は、次のとおりです。

     Native_IOS# show clock
     *08:43:47.367 UTC Sun Jan 2 2000
     Native_IOS# conf t
     Enter configuration commands, one per line.  End with CNTL/Z.
     Native_IOS(config)# Int f3/13
     Native_IOS(config-if)# No shut
     *Jan  2 08:43:49.079: SP: STP: VLAN1 Fa3/13 ->jump to forwarding from blocking

    最終結果で、およそ 2 秒(43:47 〜 43:49)の時間が示されます。

  9. SP でデバッグをオフにするには、次の一連のコマンドを発行します。

     Native_IOS# remote login
     Trying Switch ...
     Entering CONSOLE for Switch
     Type "^C^C^C" to end this session
     Switch-sp# undebug all
     All possible debugging has been turned off
     Switch-sp# exit
     [Connection to Switch closed by foreign host]
     Native_IOS#

Cisco IOS システム ソフトウェアが稼動する Catalyst 4500/4000 スイッチ

次のコマンドは、スパニング ツリー PortFast をオンにして、トランキング ネゴシエーション(DISL、DTP)をオフにする方法を示しています。 このオペレーティング システムでは、ポートを EtherChannel に追加するまで PAgP はアクティブにはならないため、PAgP をオフにする必要はありません。 これらのコマンドは interface range コマンドを発行することにより、ポートのグループに一度に適用できます。 次のコマンドを使用すると、コマンドをポート 3/2 〜 3/4 に同時に適用できます。

注:interface range fastEthernet 3/2 -4 コマンドで、2 と - の間には、構文エラーを防ぐためにスペースが必須です。

 Switch#conf t
 Enter configuration commands, one per line.  End with CNTL/Z.
 Switch(config)#interface range fastEthernet 3/2 -4
 Switch(config-if-range)#

これらの例では、1 つのポートだけに焦点を当てます。 Cisco IOS システム ソフトウェアが稼動している Catalyst 4000 スイッチ内のポートを、スイッチ ポート(L2)にデフォルト設定します。 これらは L2 プロトコル(スパニング ツリーと DTP)が稼動しているポートであり、始動遅延が発生することがあります。

設定

まずデフォルト(L2)ステートのポートを使用し、DTP をアクセス ポート(専用)に設定してオフにし、スパニング ツリー PortFast 機能をオンにして、設定を保存します 次の最初のコマンドは、このポートの現在の設定を表示しています。

 SwitchB# show run interface fas 5/4
 Building configuration...
 Current configuration : 59 bytes
 !
 interface FastEthernet5/4
  no snmp trap link-status
 end
 SwitchB# conf t
 Enter configuration commands, one per line.  End with CNTL/Z.
 SwitchB(config)# interface fastethernet 5/4
 SwitchB(config-if)# switchport mode access
 SwitchB(config-if)# spanning-tree portfast
 %Warning: PortFast should only be enabled on ports connected to a single hos
 t.
  Connecting hubs, concentrators, switches,  bridges, etc.to this interface
  when PortFast is enabled, can cause temporary spanning tree loops.
  Use with CAUTION
 %PortFast has been configured on FastEthernet5/4 but will only
  have effect when the interface is in a non-trunking mode.
 SwitchB(config-if)#^Z
 SwitchB#
 SwitchB# copy run start
 

検証

次の例で示すように、この文書で使用されているスイッチ ソフトウェアのバージョンは、Cisco IOS ソフトウェア リリース 12.1(11b)EW です。 show version コマンドと show module コマンドの全出力結果については、この文書の「タイミング テスト」セクションを参照してください。

 Switch#show version
 Cisco Internetwork Operating System Software 
 IOS (tm) Catalyst 4000 L3 Switch Software (cat4000-IS-M), Version 12.1(11b)EW,

次に、上記の変更後、設定がどのように見えるかを示します。

 SwitchB# show run interface fas 5/4
 Building configuration...
 Current configuration : 107 bytes
 !
 interface FastEthernet5/4
  switchport mode access
  no snmp trap link-status
  spanning-tree portfast
 end
 SwitchB# show interfaces fastEthernet 5/4 switchport 
 Name: Fa5/4
 Switchport: Enabled
 Administrative Mode: static access
 Operational Mode: static access
 Administrative Trunking Encapsulation: negotiate
 Operational Trunking Encapsulation: native
 Negotiation of Trunking: Off
 Access Mode VLAN: 1 (default)
 Trunking Native Mode VLAN: 1 (default)
 Voice VLAN: none
 Appliance trust: none
 Administrative private-vlan host-association: none 
 Administrative private-vlan mapping: none 
 Operational private-vlan: none 
 Trunking VLANs Enabled: ALL
 Pruning VLANs Enabled: 2-1001
 SwitchB# show spanning-tree interface fastEthernet 5/4
  Port 260 (FastEthernet5/4) of VLAN1 is forwarding
    Port path cost 19, Port priority 128, Port Identifier 129.4.
    Designated root has priority 1, address 0060.8355.7b00
    Designated bridge has priority 32768, address 0001.96d9.f300
    Designated port id is 129.4, designated path cost 38
    Timers: message age 0, forward delay 0, hold 0
    Number of transitions to forwarding state: 109
    BPDU: sent 148, received 0
    The port is in the PortFast mode
 

Cisco IOS システム ソフトウェアが稼動する Catalyst 4500/4000 でのタイミング テスト

次のテストは、各種のコマンドを適用した場合、スイッチ ポートの初期化タイミングがどのようになるかを示しています。 最初に、ポートのデフォルト設定を使用して、ベンチマークを取得します。 PortFast はディセーブルにされ、トランキング モード(DTP)は auto に設定されます(トランキングの要求があった場合にトランキングを行います)。 このオペレーティング システムでは、PAgP はデフォルトではアクティブではありません。 この後、PortFast をオンにして時間が測定された後、トランキングをオフにして時間を測定します。 オートネゴシエーションがオフになり、時間が測定されます。

注:PortFast を on にすることは、STP を off にすることと同じではありません(この文書で説明済み)。 PortFast が on 状態であっても、STP はポートで稼動しています。blockinglisteninglearning がスキップされ、ポートは直接に forwarding ステートに進みます。 STP を off にすることは推奨されません。これを行うと VLAN 全体に影響があり、ネットワークが物理的なトポロジ ループに対して脆弱になる可能性があります。 これは重大なネットワークの問題を引き起こす可能性があります。

  1. 次の例で示すように、show version コマンドと show module コマンドを発行して、スイッチのソフトウェア バージョンと設定を表示します。

     SwitchB# show version
     Cisco Internetwork Operating System Software 
     IOS (tm) Catalyst 4000 L3 Switch Software (cat4000-IS-M), Version 12.1(11b)EW,
        EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)
     TAC Support: http://www.cisco.com/tac
     Copyright (c) 1986-2002 by cisco Systems, Inc.
     Compiled Tue 14-May-02 13:31 by hqluong
     Image text-base: 0x00000000, data-base: 0x00B1C1F8
     ROM: 12.1(11br)EW
     SwitchB uptime is 4 minutes
     System returned to ROM by reload
     System image file is "bootflash:cat4000-is-mz.121-11b.EW"
     cisco WS-C4006 (MPC8245) processor (revision 5) with 262144K bytes of memory.
     Processor board ID FOX04169082
     Last reset from Reload
     32 FastEthernet/IEEE 802.3 interface(s)
     4 Gigabit Ethernet/IEEE 802.3 interface(s)
     467K bytes of non-volatile configuration memory.
     Configuration register is 0x2102
     SwitchB# show module
     Mod  Ports Card Type                              Model             Serial No.
     ----+-----+--------------------------------------+-----------------+-----------
      1      2  1000BaseX (GBIC) Supervisor Module WS-X4014 JAB054109FE 
      5     34  10/100BaseTX (RJ45), 1000BaseX (GBIC)  WS-X4232          JAB0253010D 
      M MAC addresses                    Hw  Fw           Sw               Status
     --+--------------------------------+---+------------+----------------+---------
      1 0001.96d9.f300 to 0001.96d9.f6ff 0.5 12.1(11br)EW 12.1(11b)EW, EAR Ok       
      5 0050.730a.da18 to 0050.730a.da39 1.0                               Ok
  2. 次の例で示すように、デバッグをオンにすることによって、さまざまなスパニングツリーのステートを表示して、いつポートでデータの送受信が可能になるかを判断できるようにします。 タイムスタンプをオンにして、表示されているメッセージ内のタイミング情報を見れるようにします。 (debug interface fastEthernet 5/4 コマンドの発行によって)対象にしているポートだけにデバッグ情報を限定します。 スイッチは、デバッグ出力をコンソールに送信するようデフォルト設定されます。

     SwitchB# conf t
     Enter configuration commands, one per line.  End with CNTL/Z.
     SwitchB(config)# service timestamps debug datetime msec
     SwitchB(config)# service timestamps log datetime msec
     SwitchB(config)# end
     
     !--- タイムスタンプをオンにすると、デバッグやログ メッセージの両方または片方が
     !--- 作成されるたびに、時間が出力されます。 これにより、さまざまなメッセージ間の
     !--- 時間を測定できるようになります。
     
     SwitchB# debug interface fastEthernet 5/4
     Condition 1 set
     SwitchB# debug spanning-tree events 
     Spanning Tree event debugging is on
  3. 次のコマンドによって、ポートがシャットダウンされます。

     SwitchB# conf t            
     Enter configuration commands, one per line.  End with CNTL/Z.
     SwitchB(config)# interface fastEthernet 5/4
     SwitchB(config-if)# shutdown 
     SwitchB(config-if)# end
     SwitchB#
  4. 次の例に示すように、時間をチェックしてポートをイネーブルにし、スイッチの各ステートでの時間を判断します。 最も正確なタイミング情報を得るには、次のコマンドをできるだけ速く入力することが大切です。 1 つの方法として、各コマンド(この例では show clock、conf t、int f5/4 no shut)をテキスト ファイルの別々の行に入力します。これで、コマンドをクリップボードにコピーしてからスイッチにペーストできます。

     SwitchB# show running-config interface fastEthernet 5/4
     Building configuration...
     Current configuration : 69 bytes
     !
     interface FastEthernet5/4
      shutdown
      no snmp trap link-status
     end
     SwitchB# show clock
     21:31:34.027 UTC Thu Jul 25 2002
     SwitchB# conf t
     Enter configuration commands, one per line.  End with CNTL/Z.
     SwitchB(config)# int f5/4
     SwitchB(config-if)# no shut
     Jul 25 21:31:38.187: set portid: VLAN1 Fa5/4: new port id 8104
     Jul 25 21:31:38.187: STP: VLAN1 Fa5/4 -> listening
     Jul 25 21:31:53.187: STP: VLAN1 Fa5/4 -> learning
     Jul 25 21:32:08.187: STP: VLAN1 sent Topology Change Notice on Fa5/34
     Jul 25 21:32:08.187: STP: VLAN1 Fa5/4 -> forwarding

    上の出力結果から、ポートが STP listening ステージを開始するのに約 4.2 秒(34.02 〜 38.18)かかっていることがわかります。 この時間は、ブリッジ グループに加入して DTP ネゴシエーションを完了するのに要した時間です。 listening ステートに 15 秒(38.18 〜 53.18)かかっています。 learning ステート(forwarding ステートの開始まで)では 15 秒(53.18 〜 08:18)かかっています。 ポートがトラフィックに対して実際に動作可能になるまでの合計時間は約 34 秒(34:02 〜 08.18)です。

  5. このポートでは STP はアクティブです。 ポートが forwarding ステートに達するのを遅らせる要因は他にもあります。 show int f5/4 switchport コマンドを発行すると、このポートが受動ネゴシエート ステートであることが示されます。リンクのもう一方の側によってネゴシエーションが開始されると、このポートはトランク状態になります(管理モードは dynamic auto)。 現在、オペレーション モードはスタティック アクセスです(相手側でトランクが望まれない場合)。

    トランキングのネゴシエーションが on であり、次のテストの間、継続して on であることに注意します。

     SwitchB# show interfaces fastEthernet 5/4 switchport
     Name: Fa5/4
     Switchport: Enabled
     Administrative Mode: dynamic auto
     Operational Mode: static access
     Administrative Trunking Encapsulation: negotiate
     Operational Trunking Encapsulation: native
     Negotiation of Trunking: On
     Access Mode VLAN: 1 (default)
     Trunking Native Mode VLAN: 1 (default)
     Voice VLAN: none
     Appliance trust: none
     Administrative private-vlan host-association: none 
     Administrative private-vlan mapping: none 
     Operational private-vlan: none 
     Trunking VLANs Enabled: ALL
     Pruning VLANs Enabled: 2-1001
  6. 次の例に示すように、このポートの PortFast をイネーブルにします。 トランキング ネゴシエーション(DTP)は auto モードのままになっています。

     SwitchB# conf t
     Enter configuration commands, one per line.  End with CNTL/Z.
     SwitchB(config)# interface fastethernet 5/4
     SwitchB(config-if)# spanning-tree portfast
     %Warning: PortFast should only be enabled on ports connected to a single host
      Connecting hubs, concentrators, switches,  bridges, etc.to this interface
      when PortFast is enabled, can cause temporary spanning tree loops.
      Use with CAUTION
     %PortFast has been configured on FastEthernet5/4 but will only
      have effect when the interface is in a non-trunking mode.
     SwitchB(config-if)# shutdown 
     SwitchB(config-if)# ^Z
     SwitchB#

    合計時間は、約 4.7 秒でした(16.41 〜 21:15)。 PortFast をイネーブルにすることにより約 30 秒が節約されました。 遅延をさらに縮小できるか試します。

  7. トランキングを(オートではなく)off にして、ポートが forwarding ステートに達するのにかかる時間に、どのような影響があるかを確認します。 再度、ポートを off してから on にして、時間を記録します。 次の例で示すように、Cisco IOS システム ソフトウェアでトランキングを off にするには、switchport mode access コマンドを発行します。

     SwitchB# conf t
     Enter configuration commands, one per line.  End with CNTL/Z.
     SwitchB(config)# interface fastethernet 5/4
     SwitchB(config-if)# switchport mode access
     SwitchB(config-if)# shutdown
     SwitchB(config-if)# ^Z
     SwitchB#

    次の例で示すように、トランキングを(auto ではなく)off に設定してテストを開始します。

     SwitchB# show clock
     22:06:11.947 UTC Thu Jul 25 2002
     SwitchB#conf t
     Enter configuration commands, one per line.  End with CNTL/Z.
     SwitchB(config)# int f5/4
     SwitchB(config-if)# no shut
     Jul 25 22:06:16.143: set portid: VLAN1 Fa5/4: new port id 8104
     Jul 25 22:06:16.143: STP: VLAN1 Fa5/4 ->jump to forwarding from blocking

    STP forwarding ステートに達するまでに約 4 秒かかったため(12.00 〜 16.10)、開始時点でわずかに時間が節約されました。 トランキング モードをオートからオフに変更することにより、およそ 0.5 秒が節約されました。

  8. (オプション) スイッチ ポート初期化時間が問題の場合、すぐに解決する必要があります。 時間をさらに数秒削減する必要がある場合は、オートネゴシエーションを使用する代わりに、ポート速度とデュプレックスを手動で設定できます。

    注:この手順は、通常始動遅延問題の解決には必要ありません。 この手順では、リンクの相手側がオートネゴシエーションではなく、同じ設定で手動設定されていると、パフォーマンス問題につながる可能性があります。

    こちらの側において手動で速度とデュプレックスを設定すると、速度とデュプレックスを別の側でも同じように設定する必要があります。 これは、ポート速度とデュプレックスを設定すると、ポートのオートネゴシエーションがディセーブルにされ、接続デバイスからオートネゴシエーション パラメータを参照できなくなるためです。 接続デバイスは半二重でだけ接続を行うため、その結果デュプレックスのミスマッチによりパフォーマンスが低下して、ポート エラーが発生します。 一方の側で速度とデュプレックスを設定する場合は、接続デバイスでも同じように速度とデュプレックスを設定して、これらの問題を回避する必要があることを忘れないでください。

     SwitchB# conf t
     Enter configuration commands, one per line.  End with CNTL/Z.
     SwitchB(config)# interface fastethernet 5/4       
     SwitchB(config-if)# speed 100
     SwitchB(config-if)# duplex full
     SwitchB(config-if)# shutdown
     SwitchB(config-if)# ^Z
     SwitchB#

    タイミング結果は、次のとおりです。

     SwitchB# show clock
     22:14:49.219 UTC Thu Jul 25 2002
     SwitchB# conf t
     Enter configuration commands, one per line.  End with CNTL/Z.
     SwitchB(config)# int f5/4
     SwitchB(config-if)# no shut
     Jul 25 22:14:53.135: set portid: VLAN1 Fa5/4: new port id 8104
     Jul 25 22:14:53.135: STP: VLAN1 Fa5/4 ->jump to forwarding from blocking

    最終結果で約 3.9 秒の時間(49.21 〜 53.13)が示されます。

  9. 先にオンにしてあった SP でデバッグをオフにするには、次の一連のコマンドを発行します。

     SwitchB# undebug all
     All possible debugging has been turned off
     SwitchB# exit
     

Catalyst 2948G-L3/4908G-L3/4840G スイッチ

2948G-L3/4908G-L3/4840G ファミリのスイッチは、Cisco IOS ソフトウェアが稼動するスイッチのもう 1 つのグループです。 これらのスイッチでは、Catalyst 6000 の Cisco IOS ソフトウェアのように、ポートをスイッチポートにする機能はありません。 これらのスイッチに関しては次の事柄を理解する必要があります。

  • 設定の観点では、Catalyst 2948G-L3 はルータになります。 このスイッチでは、Cisco IOS 設定インターフェイスが使用されており、すべてのインターフェイスはデフォルトでルーテッド インターフェイスとなっています。

  • Catalyst 2948G-L3 は VLAN を拡張するものではありません。 このスイッチでは、ルーテッド インターフェイスで VLAN を終了させます(ブリッジ コマンドを使用すると VLAN の機能をある程度シミュレートできます)。

  • Catalyst 2948G-L3 では、他の Catalyst スイッチに見られる VTP、DTP、PAgP などの L2 指向プロトコルはサポートされていません。

これらのデバイス上でポートをブリッジング用に設定すると、スパニング ツリーがこれらのポート上でアクティブになり、ポートが blockinglisteninglearning ステージを進むため、通常 30 秒の始動遅延が生じます。 これらのポートに接続されているのが端末だけなのがわかっている場合ば、これらのポートでスパニング ツリーを off にすることで始動遅延を小さくできます。 この方法では、PortFast を使用するよりもリスクが増大します(次の項で説明しています)。 ただし、PortFast はこれらのデバイスでは使用できません。

注:ブリッジ ルータ インターフェイスのスパニング ツリーをディセーブルにすることは、スイッチ ポートのスパニング ツリー PortFast をイネーブルにすることとは異なります。 BPDU がスイッチから受信されたりブリッジがインターフェイスに誤って接続されたりしている場合、ルータはポートをブロックしません。 スパニングツリーをディセーブルにしたまま、ワークステーションやその他のエンドホストだけをインターフェイスに接続するよう配慮してください。 ハブやスイッチをポートに接続している場合は、ポートのスパニング ツリーをディセーブルにしないでください。

次の出力は、Catalyst 2948G-L3 をブリッジング用に設定する方法を示しています。 すべてのファースト イーサネット インターフェイスは 1 つのブリッジ グループに割り当てられており、さまざまな端末の起動問題を回避するためスパニング ツリーはディセーブルにされています。

 2948G-L3# configure terminal
 Enter configuration commands, one per line.  End with CNTL/Z.
 2948G-L3(config)# bridge irb
 2948G-L3(config)# bridge 1 protocol ieee
 2948G-L3(config)# bridge 1 route ip
 2948G-L3(config)# interface bvi 1 
 2948G-L3(config-if)# ip add 10.1.1.1 255.255.255.0
 2948G-L3(config-if)# exit
 2948G-L3(config)# interface fast 1
 2948G-L3(config-if)# no shutdown
 2948G-L3(config-if)# bridge-group 1
 2948G-L3(config-if)# bridge-group 1 spanning-disabled
 2948G-L3(config-if)# exit
 2948G-L3(config)# interface fast 2
 2948G-L3(config-if)# no shutdown
 2948G-L3(config-if)# bridge-group 1
 2948G-L3(config-if)# bridge-group 1 spanning-disabled
 . . .

2948G-L3 スイッチの設定の詳細については、『Catalyst 2948G-L3 設定例:単一 VLAN、複数 VLAN、およびネットワーク コアに接続する複数 VLAN ディストリビューション レイヤ』を参照してください。

Catalyst 2900XL/3500XL/2950/3550 スイッチ

Catalyst 2900XL/3500XL および Catalyst 2950/3550 モデルは、Web ブラウザから、Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)、 または Command Line Interface(CLI; コマンドライン インターフェイス)を使用して設定できます。 CLI の使用が推奨されます。 次に、ポートの STP のステートを表示し、PortFast をオンにして、PortFast がオンになっていることを検証している例を示します。 2900XL/3500XL では、EtherChannel とトランキングはサポートされますが、ダイナミック EtherChannel 作成(PAgP)や DTP はサポートされません。 このテスト中、これらをオフにする必要はありません。 また、PortFast をオンにした後は、ポートが立ち上がるための経過時間はすでに 1 秒未満になっているので、速度とデュプレックスのネゴシエーション設定を変更しても速度を速める効果はありません。 デフォルトでは、スイッチ ポートで PortFast はオフになっています。 2950/3550 では、PAgP と DTP 両方のプロトコルがサポートされています。 これらのスイッチでは、PAgP はデフォルトではアクティブではありませんが、DTP はアクティブです。 2950 では、Cisco IOS 12.0 が稼動している場合、DTP や PAgP はサポートされていません。 PortFast をオンにするコマンドの一覧を次に掲載します。

設定

 2900XL# conf t
 2900XL(config)# interface fastEthernet 0/1
 2900XL(config-if)# spanning-tree portfast
 2900XL(config-if)# exit
 2900XL(config)# exit
 2900XL# copy run start
 

注:Catalyst 2950 および 3550 では、DTP プロトコルがサポートされています。 DTP をオフにするには switchport mode access コマンドを発行します。

このプラットフォームは、Cisco ルータの IOS と似ています。 永続的な保存が必要な場合は、copy run start コマンドを発行して設定を保存する必要があります。

検証

PortFast がイネーブルになっていることを確認するには、次のコマンドを発行します。

 2900XL# show spanning-tree interface fastEthernet 0/1
 Interface Fa0/1 (port 13) in Spanning tree 1 is FORWARDING
    Port path cost 19, Port priority 128
    Designated root has priority 8192, address 0010.0db1.7800
    Designated bridge has priority 32768, address 0050.8039.ec40
    Designated port is 13, path cost 19
    Timers: message age 0, forward delay 0, hold 0
    BPDU: sent 2105, received 1
    The port is in the PortFast mode
 

次のコマンドを使用すると、スイッチの設定を表示することもできます。

 2900XL# show running-config
 Building configuration...
 Current configuration:
 !
 version 11.2
 ...
 !
 interface VLAN1
  ip address 172.16.84.5 255.255.255.0
  no ip route-cache
 !
 interface FastEthernet0/1
  spanning-tree portfast
 !
 interface FastEthernet0/2
 !
 ...

Catalyst 2900XL のタイミング テスト

Catalyst 2900XL 上でタイミング テストを実行するには、次の手順を実行します。

  1. ソフトウェアのバージョンを表示します。 次の例では、バージョン 11.2(8.2)SA6 のソフトウェアが 2900XL で使用されています。

     Switch# show version
     Cisco Internetwork Operating System Software
     IOS (tm) C2900XL Software (C2900XL-C3H2S-M), Version 11.2(8.2)SA6, MAINTENANCE INTERIM SOFTWARE
     Copyright (c) 1986-1999 by cisco Systems, Inc.
     Compiled Wed 23-Jun-99 16:25 by boba
     Image text-base: 0x00003000, data-base: 0x00259AEC
     ROM: Bootstrap program is C2900XL boot loader
     Switch uptime is 1 week, 4 days, 22 hours, 5 minutes
     System restarted by power-on
     System image file is "flash:c2900XL-c3h2s-mz-112.8.2-SA6.bin", booted via console
     cisco WS-C2924-XL (PowerPC403GA) processor (revision 0x11) with 8192K/1024K bytes of memory.
     Processor board ID 0x0E, with hardware revision 0x01
     Last reset from power-on
     Processor is running Enterprise Edition Software
     Cluster command switch capable
     Cluster member switch capable
     24 Ethernet/IEEE 802.3 interface(s)
     32K bytes of flash-simulated non-volatile configuration memory.
     Base ethernet MAC Address: 00:50:80:39:EC:40
     Motherboard assembly number: 73-3382-04
     Power supply part number: 34-0834-01
     Motherboard serial number: FAA02499G7X
     Model number: WS-C2924-XL-EN
     System serial number: FAA0250U03P
     Configuration register is 0xF
  2. 次のコマンドを発行して、スイッチの状況を判別します。

     2900XL(config)# service timestamps debug uptime
     2900XL(config)# service timestamps log uptime
     2900XL# debug spantree events
     Spanning Tree event debugging is on
     2900XL# show debug
     General spanning tree:
       Spanning Tree event debugging is on
  3. 該当のポートをシャット ダウンします。

     2900XL# conf t
     Enter configuration commands, one per line.  End with CNTL/Z.
     2900XL(config)# interface fastEthernet 0/1
     2900XL(config-if)# shut
     2900XL(config-if)#
     00:31:28: ST: sent Topology Change Notice on FastEthernet0/6
     00:31:28: ST: FastEthernet0/1 -> blocking
     00:31:28: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
     00:31:28: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
     2900XL(config-if)# exit
     2900XL(config)# exit
     2900XL#
  4. 時間をチェックし、ポートをオンに戻して、スイッチの各ステートでの滞在時間を判別します。

    最も正確なタイミング情報を得るには、次のコマンドをできるだけ速く入力することが大切です。 1 つの方法として、次の各コマンドをテキスト ファイルの別々の行に入力します。これでコマンドをクリップボードにコピーしてからスイッチにペーストできます。

     
     show clock
     conf t
     int f0/1
     no shut
     
  5. デフォルトでは PortFast はオフになっています。 これは 2 つの方法で確認できます。 1 番目の方法では、show spanning-tree interface コマンドで PortFast に関する記述がないことを確認します。 2 番目の方法は、実行設定を確認することで、インターフェイスに spanning-tree portfast コマンドが表示されていないことを確認します。

     2900XL# show spanning-tree interface fastEthernet 0/1
     Interface Fa0/1 (port 13) in Spanning tree 1 is FORWARDING
        Port path cost 19, Port priority 128
        Designated root has priority 8192, address 0010.0db1.7800
        Designated bridge has priority 32768, address 0050.8039.ec40
        Designated port is 13, path cost 19
        Timers: message age 0, forward delay 0, hold 0
        BPDU: sent 887, received 1

    注: このスポットには PortFast モードであることを示すメッセージはありません。

     2900XL# show running-config
     Building configuration...
     ...
     !
     interface FastEthernet0/1
     
     
     !--- このインターフェイスにはスパンニング ツリー PortFast コマンドはありません。
     
     !
     ...
  6. この出力には、PortFast をオフにした最初のタイミング テストが示されています。

     2900XL# show clock
     *00:27:27.632 UTC Mon Mar 1 1993
     2900XL# conf t
     Enter configuration commands, one per line.  End with CNTL/Z.
     2900XL(config)# int f0/1
     2900XL(config-if)# no shut
     2900XL(config-if)#
     00:27:27: ST: FastEthernet0/1 -> listening
     00:27:27: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
     00:27:28: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
     00:27:42: ST: FastEthernet0/1 -> learning
     00:27:57: ST: sent Topology Change Notice on FastEthernet0/6
     00:27:57: ST: FastEthernet0/1 -> forwarding
     

    シャットダウンからポートが転送を開始するまでの合計時間は 30 秒(27:27 〜 27:57)でした。

  7. PortFast をオンにするには、次のコマンドを発行します。

     2900XL# conf t
     Enter configuration commands, one per line.  End with CNTL/Z.
     2900XL(config)# interface fastEthernet 0/1
     2900XL(config-if)# spanning-tree portfast
     2900XL(config-if)# exit
     2900XL(config)# exit
     2900XL#

    PortFast がイネーブルであることを確認するには、show spanning-tree interface コマンドを発行します。 コマンド出力の最後に、PortFast がイネーブルであることが表示されることに注意します。

    2900XL# show spanning tree interface fastEthernet 0/1
     Interface Fa0/1 (port 13) in Spanning tree 1 is FORWARDING
        Port path cost 19, Port priority 128
        Designated root has priority 8192, address 0010.0db1.7800
        Designated bridge has priority 32768, address 0050.8039.ec40
        Designated port is 13, path cost 19
        Timers: message age 0, forward delay 0, hold 0
        BPDU: sent 1001, received 1
        The port is in the PortFast mode.
     

    PortFast がイネーブルであることは、次に示す設定出力でも確認できます。

     2900XL# sh run
     Building configuration...
     ...
     interface FastEthernet0/1
      spanning-tree portfast
     ...
  8. PortFast がイネーブルの状態で、タイミング テストを実行します。

     2900XL# show clock
     *00:23:45.139 UTC Mon Mar 1 1993
     2900XL# conf t
     Enter configuration commands, one per line.  End with CNTL/Z.
     2900XL(config)# int f0/1
     2900XL(config-if)# no shut
     2900XL(config-if)#
     00:23:45: ST: FastEthernet0/1 ->jump to forwarding from blocking
     00:23:45: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
     00:23:45: %LINEPROTO-5-UPDOWN: 
        Line protocol on Interface FastEthernet0/1, changed state to up

    この場合は、合計時間は 1 秒未満です。 スイッチのポート初期化遅延が問題であれば、PortFast を使用して解決します。 スイッチは現在トランク ネゴシエーションや PAgP をサポートしていないため、これらをオフにする必要はありません。 スイッチは、速度やデュプレックスのオートネゴシエーションをサポートしていますが、遅延が小さいのでオフにするほどではありません。

  9. ワークステーションからスイッチに対して、PING テスト(上記「Catalyst 5500 で DTP、PAgP、および PortFast を使用する場合と使用しない場合のタイミング テスト」セクションのステップ 11)を実行します。 速度とデュプレックスのオートネゴシエーションが on なのか、または off なのかの応答がスイッチから届くのに、約 5 〜 6 秒かかります。

Catalyst 1900/2800 スイッチ

Catalyst 1900 と Catalyst 2820 では、PortFast はスパンツリー始動転送と呼ばれます。 バージョン 8.01.05 のソフトウェアでは、スイッチのデフォルト設定は、イーサネット(10Mbps)ポートでは PortFast がイネーブルに、ファーストイーサネット(アップリンク)ポートでは PortFast がディセーブルになっています。 show run コマンドを発行して設定を表示したときに、イーサネット ポートに PortFast についての情報がない場合、PortFast はイネーブルです。 ポートによって設定の中に no spantree start-forwarding がレポートされる場合、PortFast はディセーブルです。 FastEthernet(100Mbps)ポートの場合は逆になります。FastEthernet ポートでは、ポートによって設定内に spantree start-forwarding が示される場合にだけ、PortFast はオンです。

次に、FastEthernet ポートで PortFast を設定する例を示します。 次の例では、Enterprise 版ソフトウェアのバージョン 8 を使用しています。 Catalyst 1900 では、設定が変更されると自動的に NVRAM に保存されます。 別のスイッチやハブに接続したポートで PortFast をイネーブルにする必要はなく、端末に接続したポートでだけ PortFast をイネーブルにする必要があることに注意してください。

設定

 1900# show version
 Cisco Catalyst 1900/2820 Enterprise Edition Software
 Version V8.01.05    
 Copyright (c) Cisco Systems, Inc.  1993-1998
 1900 uptime is 0day(s) 01hour(s) 10minute(s) 42second(s) 
 cisco Catalyst 1900 (486sxl) processor with 2048K/1024K bytes of memory
 Hardware board revision is 5
 Upgrade Status: No upgrade currently in progress. 
 Config File Status: No configuration upload/download is in progress 
 27 Fixed Ethernet/IEEE 802.3 interface(s)
 Base Ethernet Address: 00-50-50-E1-A4-80
 1900# conf t
 Enter configuration commands, one per line.  End with CNTL/Z
 1900(config)# interface FastEthernet 0/26
 1900(config-if)# spantree start-forwarding 
 1900(config-if)# exit
 1900(config)# exit
 1900#

検証

PortFast がオンであることを検証する 1 つの方法は、設定を調べることです。 ファーストイーサネット ポートは必ずオンであると表示することを忘れないでください。 イーサネット ポートは、設定がオフであると示さない限りオンにします。 次の設定では、インターフェイス Ethernet 0/1 の PortFast はオフ(オフにするコマンドが表示されます)に、インターフェイス Ethernet 0/2 の PortFast はオン(オンであることを示すものは何も表示されません)に、インターフェイス FastEthernet 0/26(メニュー システムのポート A)の PortFast はオン(オンにするコマンドが表示されます)になっています。

 1900# show running-config 
 Building configuration...
 ...
 !
 interface Ethernet 0/1
   no spantree start-forwarding
 !
 interface Ethernet 0/2
 !
 ...
 !
 interface FastEthernet 0/26
   spantree start-forwarding
 !

PortFast のステータスを表示する最も簡単な方法は、メニュー システムの使用です。 メイン メニューから Port Configuration(P)を選択して次にポートを選択すると、出力に PortFast モードが enabled になっているかどうかが表示されます。 次の出力は、ポート FastEthernet 0/26(このスイッチではポート A)の場合です。

        
         Catalyst 1900 - Port A Configuration
         Built-in 100Base-FX
         802.1d STP State:  Blocking     Forward Transitions:  0
     ----------------------- Settings ---------------------------------------
      [D] Description/name of port                                        
      [S] Status of port                              Suspended-no-linkbeat
      [I] Port priority (spanning tree)               128 (80 hex)
      [C] Path cost (spanning tree)                   10
      [H] Port fast mode (spanning tree)              Enabled 
      [E] Enhanced congestion control                 Disabled             
      [F] Full duplex / Flow control                  Half duplex             
     ----------------------- Related Menus ----------------------------------
      [A] Port addressing           [V] View port statistics
      [N] Next port                 [G] Goto port
      [P] Previous port             [X] Exit to Main Menu
 Enter Selection:

Catalyst 1900 でのタイミング テスト

デバッグ ツールがないため、Catalyst 1900/2820 でタイミングの値を検証するのはもっと困難です。 スイッチに接続された PC から、スイッチ自身に向けて PING を開始します。 ケーブルの接続をはずしてから再度接続して、PortFast をオンにした状態とオフにした状態で、スイッチが PING に応答するのにどれだけ時間がかかったかを記録します。 PortFast をオンにした(デフォルト ステート)イーサネット ポートでは、PC は 5 〜 6 秒以内に応答を受け取っています。 PortFast をオフにすると、PC は 34 〜 35 秒で応答を受信しました。

PortFast へのその他のメリット

ネットワークで PortFast を使用すると、その他にも STP 関連のメリットがあります。 リンクがアクティブになり STP のフォワーディング ステートに進むたびに、スイッチは、Topology Change Notification(TCN; トポロジ変更通知)という名の特殊な STP パケットを送信します。 TCN 通知はスパニング ツリーのルートに渡され、そこで VLAN 内のすべてのスイッチに伝搬されます。 これによりすべてのスイッチは、転送遅延パラメータを使用して MAC アドレスのテーブルをエージング アウトします。このパラメータは通常 15 秒に設定されます。 そのためワークステーションがブリッジ グループに加入するたびに、すべてのスイッチの MAC アドレスは通常の 300 秒ではなく 15 秒後にエージング アウトされます。

ワークステーションがアクティブになったとき、トポロジが大きく変更されることはありません。 VLAN 内のすべてのスイッチに関する限り、高速エージング TCN 期間を経る必要はありません。 PortFast をオンにすると、ポートがアクティブのときスイッチでは TCN パケットは送信されません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 10553