ルータ : Cisco SOHO 70 シリーズ ルータ

NAT による Cisco SOHO77 ルータの PPPoE クライアントとしての設定

2004 年 12 月 6 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2007 年 11 月 23 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
設定
      ネットワーク ダイアグラム
      設定
確認
トラブルシューティング
      DSL 物理層
      ATM 層
      イーサネット層
      PPP 層
デバッグ
      DSL 物理層
      ATM 層
      イーサネット層
      PPP 層
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

Cisco IOS(R) ソフトウェア リリース 12.1(3)XG では、Cisco Small Office/Home Office(SOHO)77 向けの Point-to-Point Protocol over Ethernet(PPPoE)クライアント機能が導入されています。 この機能を使用すると、PPPoE の機能をルータに追加できます。 Cisco SOHO77 の背後には複数の PC を設置でき、PC のトラフィックが PPPoE セッションに送信される前にデータを暗号化およびフィルタリングすることが可能で、また Network Address Translation(NAT; ネットワーク アドレス変換)を実行できます。

この文書では、Cisco SOHO77 の Asynchronous Transfer Mode(ATM; 非同期転送モード)インターフェイス(DSL インターフェイス)上での PPPoE クライアントの設定について説明します。 この設定は、Asymmetric Digital Subscriber Line(ADSL; 非対称デジタル加入者線)対応の WAN Interface Card(WIC; WAN インターフェイス カード)を搭載した Cisco 1700 にも使用可能です。

Cisco 6400 Node Route Processor(NRP; ノード ルート プロセッサ)の設定は、アグリゲータとして動作しているルータや ATM インターフェイスを搭載しているルータにも使用可能です。

前提条件

要件

この文書に関する特別な要件はありません。

使用するコンポーネント

この文書の情報は、次のソフトウェアとハードウェアのバージョンに基づいています。

  • Cisco SOHO77 Customer Premises Equipment(CPE; 顧客宅内機器) IOS ソフトウェア リリース 12.1(3)XP2

  • Cisco 6400 UAC-NRP IOS ソフトウェア リリース 12.1(3)DC1

  • Cisco 6400 UAC-NSP IOS ソフトウェア リリース 12.1(3)DB

  • Cisco 6130 DSLAM-NI2 IOS ソフトウェア リリース 12.1(5)DA

この文書の情報は、特定のラボ環境にあるデバイスに基づいて作成されています。 また、この文書で使用するデバイスは、すべて初期(デフォルト)の設定で起動しています。 実稼動中のネットワークで作業する場合は、コマンドの実行によって生じる影響について、事前に理解しておいてください。

表記法

文書表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションでは、この文書で説明する機能を設定するための情報を提供します。

注:この文書で使用されているコマンドの詳細を調べるには、Command Lookup Toolを使用してください(登録のユーザ専用)。


一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

この文書では、次のネットワーク設定を使用します。

soho77pppoe_client.gif

設定

この文書では、次の設定を使用します。

  • Cisco SOHO77

  • Cisco 6400

Cisco SOHO77 に PPPoE を設定するには、Virtual Private Dial-up Network(VPDN; 仮想プライベート ダイヤルアップ ネットワーク)コマンドを使用します。 まず最初に、VPDN コマンドを設定します。

Cisco SOHO77

! 
  vpdn enable 
  no vpdn logging
  
  !--- デフォルト。
  
  ! 
  vpdn-group pppoe 
   request-dialin     
   
  !--- PPPoE クライアントは、集約ユニット(6400 NRP)とのセッションを要求します。
  
    protocol pppoe 
  ! 
  
  !--- 内部のイーサネット ネットワーク。 
  
  ! 
  interface Ethernet0 
   ip address 10.92.1.182 255.255.255.0 
   ip nat inside 
  
  !--- DSL インターフェイス。 
  
  ! 
  interface ATM0 
   no ip address 
   no atm ilmi-keepalive
   bundle-enable
   dsl operating-mode auto
   hold-queue 224 in
   !--- all defaults
  
  !--- PPPoE は、AAL5SNAP の最上位層で動作しますが、encap aal5snap コマンドは使用されません。  
  
  ! 
  interface ATM0.1 point-to-point 
   pvc 1/1 
    pppoe-client dial-pool-number 1 
    
  !--- pvc 1/1 はサンプル値で、Internet Service Provider(ISP)により使用される値に
    !--- 一致するよう変更する必要があります。
  
   ! 
  
  !--- PPPoE クライアント コードは、バーチャルアクセス インターフェイスが複製される、
  !--- ダイヤラ インターフェイスに接続します。
  
  ! 
  interface Dialer1 
   ip address negotiated 
   ip mtu 1492
   
  !--- Ethernet MTU のデフォルトは 1500 です。 つまり、1492 + PPPoE ヘッダー = 1500 です。
  
   ip nat outside 
   encapsulation ppp 
   dialer pool 1
   
  !--- ATM インターフェイスに接続します。  
  
   ppp authentication chap callin 
   ppp chap hostname <hostname>
   ppp chap password <password>
  ! 
  
  !--- 使用する認証タイプについては、ISP から指示されます。 
  !--- PPP CHAP から PPP PAP の認証タイプに変えるには、次の 3 行を入れ替えます。             
  !--- ppp authentication chap callin 
  !--- ppp chap hostname <hostname>
  !--- ppp chap password <password>
  !--- を次の 2 行に置き換えます。
  !--- ppp authentication pap callin
  !--- ppp pap sent-username <username> password <password>
  !--- NAT のために、Dialer1 インターフェイスに overload を実行します
  !--- 続いて、ダイヤラの IP アドレスは変わることがあるので、デフォルトの送信ルートを追加します。  
   
  ip nat inside source list 1 interface Dialer1 overload 
  ip classless 
  ip route 0.0.0.0 0.0.0.0 dialer1 
  no ip http server 
 
  ! 
  access-list 1 permit 10.92.1.0 0.0.0.255
  
  !--- NAT 用。
  
  ! 
  

Cisco 6400

*** local ppp user 
  
  !--- AAA を使用することもできます。
  
  username <username> password <password>
  
  !--- VPDN コマンドから始めます。
  !--- ATM インターフェイス上ではなく、バーチャルテンプレートに PPPoE がバインドされていることに注意してください。 
  !--- この時点では、VPDN コマンドによって開始した PPPoE には、
  !--- 複数のバーチャルテンプレート(または VPDN グループ)を使用できません。
  
  vpdn enable 
  no vpdn logging 
  ! 
  vpdn-group pppoe 
   accept-dialin
   
  !--- PPPoE サーバ モード。 
  
    protocol pppoe 
    virtual-template 1 
  ! 
  ! 
  interface ATM0/0/0 
   no ip address 
   no atm ilmi-keepalive 
   hold-queue 500 in 
  
  !--- バーチャルテンプレート インターフェイスへのバインディングが、VPDN グループで設定されています。     
  
  ! 
  interface ATM0/0/0.182 point-to-point 
   pvc 1/82 
    encapsulation aal5snap
    
  !--- サーバ側でコマンドが必要です。 
  
    protocol pppoe 
   ! 
  ! 
  
  !--- ダイヤラ インターフェイスの代わりに、バーチャルテンプレートが使用されます。 
  
  ! 
  interface Virtual-Template1 
   ip unnumbered Loopback10 
   ip mtu 1492 
   peer default ip address pool ippool 
   ppp authentication chap 
  ! 
  ! 
  interface Loopback10 
   ip address 8.8.8.1 255.255.255.0 
  ! 
  ip local pool ippool 9.9.9.1 9.9.9.5 
  

確認

現在のところ、この設定を確認する手順はありません。

トラブルシューティング

このセクションでは、設定のトラブルシューティングおよびデバッグに役立つ情報を説明します。

Cisco SOHO77 または Cisco 6400 上で PPPoE をデバッグする場合は、プロトコル スタックを考慮する必要があります。 トラブルシューティングは最下層のプロトコル層から始めます。

  1. DSL 物理層

  2. ATM 層

  3. イーサネット層

  4. PPP 層

DSL 物理層

回線がアップおよび確立されていることを確認します。

この例で説明したように show コマンドを入力します。 結果の出力は回線の状態を示しています。

  show int atm0 
  ATM0 is up, line protocol is up 
    Hardware is PQUICC_SAR (with Alcatel ADSL Module) 
  show dsl interface atm0 
  
  !--- 最初の数行で "Showtime" を探します。
  
                  ATU-R (DS)                      ATU-C (US) 
  Modem Status:   Showtime (DMTDSL_SHOWTIME) 
  

ATM 層

ATM インターフェイスがアップ状態になったら、debug atm packets コマンドを使用して、ISP からの受信の有無を確認します。

注:パケットの処理方法が異なるので、発信パケットにはこのコマンドは使用できません。

この文書の例で示したように debug atm packets コマンドを入力します。

  debug atm packet 
  03:21:32: ATM0(I): 
  VCD:0x2 VPI:0x1 VCI:0x1 Type:0x0 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 
  Length:0x30 
  03:21:32: 0000 0050 7359 35B7 0001 96A4 84AC 8864 1100 0001 000E C021 09AB 
  000C 0235 
  03:21:32: 279F 0000 0000 
  03:21:32:

上記の出力には同じ Type、SAP、CTL、および OUI のフィールドが含まれ、着信した ATM パケットが AAL5SNAP であることが示されます。

イーサネット層

完全なイーサネット フレームは、AAL5SNAP パケットに含まれます。 debug ethernet packet というコマンドはありませんが、VPDN デバッグ操作を実行して PPPoE フレームを確認する必要があります。

PPPoE フレームであるイーサネット フレームには、次の 2 つの ethertype のどちらかが含まれることを参考にしてください。

  • 0x8863 Ethertype = PPPoE 制御パケット(PPPoE セッションを処理する)。

  • 0x8864 Ethertype = PPPoE データ パケット(PPP パケットを含む)。

PPPoE には 2 つのセッションが存在することに注意することが重要です。 PPPoE セッションは、VPDN L2TP タイプのセッションであり、PPP セッションでもあります。 そのため、PPPoE を確立できるように、PPPoE セッション確立フェーズと PPP セッション確立フェーズを用意しています。

終端には、通常、PPP 終端フェーズと PPPoE 終端フェーズの両方が関係しています。

PPPoE 確立フェーズは、次の 2 つのステップから構成されています。

  • ステップ 1: PPPoE クライアントおよびサーバを識別する(MAC アドレス)。

  • ステップ 2: セッション ID を割り当てる。

この処理が終了すると、他の PPP 接続と同じように通常の PPP が確立されます。

デバッグするには、VPDN PPPoE デバッグを使用すると、PPPoE 接続フェーズの成功または失敗を確認できます。

  1. この文書の例で示したように debug コマンドを入力します。

      #debug vpdn pppoe-events
      06:17:58: Sending PADI: vc=1/1
      
      !--- ブロードキャスト イーサネット フレーム(この例では ATM にカプセル化されている)が
      !--- 「Is there a PPPoE server out there?」というメッセージを使用して PPPoE サーバを要求します。
      
      06:18:00:  PPPOE: we have got our pado, and the pado timer went off 
      
      !--- PPPoE サーバからのユニキャスト応答で、DHCP の提供と似ています。
      
      
      06:18:00: OUT PADR from PPPoE tunnel
      
      !--- 提供を受け入れるユニキャスト応答です。
      
      
      06:18:00: IN PADS from PPPoE tunnel
      
      !--- 確認で、確立が完了されます。
      
      
  2. PPP 接続を開始します。 PPP の確立は、通常の PPP の開始どおりに実行されます。 PPPoE セッションが確立されたら、次に示すように、show vpdn コマンドを使用すると状況を取得できます。

      #show vpdn
      %No active L2TP tunnels 
      %No active L2F tunnels 
      PPPoE Tunnel and Session Information Total tunnels 1 sessions 1
      PPPoE Tunnel Information
      Session count: 1
      PPPoE Session Information
      SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC 
      1       0050.7359.35b7  0001.96a4.84ac  Vi1     UP     AT0     1       1
  3. パケット カウント情報を得るには、次に示すように、show vpdn session all コマンドを使用します。

      show vpdn session all
      %No active L2TP tunnels
      %No active L2F tunnels
      PPPoE Session Information Total tunnels 1 sessions 1
      session id: 1
      local MAC address: 0001.96a4.84ac, remote MAC address: 0050.7359.35b7 
      virtual access interface: Vi1, outgoing interface: AT0, vc: 1/1 
          1656 packets sent, 1655 received, 24516 bytes sent, 24486 received

    役に立つ場合があるその他の debug コマンドには debug vpdn pppoe-datadebug pppoe-errors、および debug pppoe-packets があります。

PPP 層

PPPoE セッションが確立されたら、PPP デバッグは、その他の PPP 設定の場合と同じです。 同じ debug ppp negotiation および debug ppp authentication コマンドを使用します。

注:次の例では、ホスト名は「client1」で、リモートの Cisco 6400 名は「nrp-b」です。

コマンドラインから PPP ネゴシエーションまたは PPP 認証を有効にします。 結果の出力は次のようになります。

06:36:03: Vi1 PPP: Treating connection as a callout
  06:36:03: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
  06:36:03: Vi1 PPP: No remote authentication for call-out
  06:36:03: Vi1 LCP: O CONFREQ [Closed] id 1 len 10
  06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43) 
  06:36:03: Vi1 LCP: I CONFACK [REQsent] id 1 len 10
  06:36:03: Vi1 LCP:    MagicNumber 0x03013D43 (0x050603013D43) 
  06:36:05: Vi1 LCP: I CONFREQ [ACKrcvd] id 2 len 15
  06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
  06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5) 
  06:36:05: Vi1 LCP: O CONFACK [ACKrcvd] id 2 len 15
  06:36:05: Vi1 LCP:    AuthProto CHAP (0x0305C22305)
  06:36:05: Vi1 LCP:    MagicNumber 0x65E315E5 (0x050665E315E5) 
  06:36:05: Vi1 LCP: State is Open
  06:36:05: Vi1 PPP: Phase is AUTHENTICATING, by the peer [0 sess, 1 load]
  06:36:05: Vi1 CHAP: I CHALLENGE id 9 len 26 from "nrp-b" 
  06:36:05: Vi1 CHAP: Using alternate hostname client1
  06:36:05: Vi1 CHAP: Username nrp-b not found
  06:36:05: Vi1 CHAP: Using default password
  06:36:05: Vi1 CHAP: O RESPONSE id 9 len 28 from "client1"
  06:36:05: Vi1 CHAP: I SUCCESS id 9 len 4
  06:36:05: Vi1 PPP: Phase is FORWARDING [0 sess, 1 load]
  06:36:05: Vi1 PPP: Phase is AUTHENTICATING [0 sess, 1 load]
  06:36:05: Vi1 PPP: Phase is UP [0 sess, 1 load]
  06:36:05: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10
  06:36:05: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)
  06:36:05: Vi1 CDPCP: O CONFREQ [Closed] id 1 len 4
  06:36:05: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10
  06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)
  06:36:05: Vi1 IPCP:    Address 8.8.8.1 (0x030608080801)
  06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
  06:36:05: Vi1 IPCP: O CONFREQ [ACKsent] id 2 len 10
  06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
  06:36:05: Vi1 LCP: I PROTREJ [Open] id 3 len 10 protocol 
  CDPCP (0x820701010004) 
  06:36:05: Vi1 CDPCP: State is Closed
  06:36:05: Vi1 IPCP: I CONFACK [ACKsent] id 2 len 10
  06:36:05: Vi1 IPCP:    Address 9.9.9.2 (0x030609090902)
  06:36:05: Vi1 IPCP: State is Open
  06:36:05: Di1 IPCP: Install negotiated IP interface address 9.9.9.2
  06:36:05: Di1 IPCP: Install route to 8.8.8.1
  06:36:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, 
  changed state to up
  

デバッグ

Cisco 6400(PPPoE サーバ)をデバッグする場合は、Cisco SOHO77(クライアント)に使用したものと同じ上位へ向かう手順を使用します。 ただし、今回は、DSL 物理層で DSLAM をチェックする必要がある点が異なります。

  1. DSL 物理層

  2. ATM 層

  3. イーサネット層

  4. PPP 層

DSL 物理層

DSL 物理層をチェックするときは、DSLAM の DSL 統計情報を確認する必要があります。 Cisco DSLAM の場合は、show dsl interface コマンドを使用します。

ATM 層

Cisco 6400 側でも、debug atm packet コマンドを使用できます。また、特定の PVC に Cisco 6400 を使用可能にします。

次のように、コマンドラインから適切なパラメータを使用して debug atm packet を入力します。

  debug atm packet interface atm 0/0/0.182 vc 1/82
  

結果の出力は次のようになります。

4d04h: ATM0/0/0.182(I):
  VCD:0x3 VPI:0x1 VCI:0x52 Type:0x900 SAP:AAAA CTL:03 OUI:0080C2 TYPE:0007 Length:0x30
  4d04h: 0000 0001 96A4 84AC 0050 7359 35B7 8864 1100 0001 000E C021 0A2E 000C 65E3
  4d04h: 15E5 0000 0000

注:パケットの処理方法が異なるので、このコマンドでは発信パケットが表示されません。

イーサネット層

Cisco SOHO77 と同様に、Cisco 6400 でも、PPPoE 確立の確認に同じ VPDN show コマンドとデバッグが使用できます。

次の例に、出力とともにコンテキスト内の show コマンドと debug コマンドを示します。 必要に応じてこれらのコマンドを使用します。

  #debug vpdn pppoe-events
  4d04h: IN PADI from PPPoE tunnel
  4d04h: OUT PADO from PPPoE tunnel
  4d04h: IN PADR from PPPoE tunnel
  4d04h: PPPoE: Create session
  4d04h: PPPoE: VPN session created.
  4d04h: OUT PADS from PPPoE tunnel
  #show vpdn
  %No active L2TP tunnels
  %No active L2F tunnels
  PPPoE Tunnel and Session Information Total tunnels 1 sessions 1
  PPPoE Tunnel Information
  Session count: 1
  PPPoE Session Information
  SID        RemMAC          LocMAC       Intf    VASt   OIntf    VC
  1       0001.96a4.84ac  0050.7359.35b7  Vi4     UP     AT0/0/0 1    82
  #show vpdn session all
  nrp-b#show vpdn session all
  %No active L2TP tunnels
  %No active L2F tunnels
  PPPoE Session Information Total tunnels 1 sessions 1
  session id: 1
  local MAC address: 0050.7359.35b7, remote MAC address: 0001.96a4.84ac
  virtual access interface: Vi4, outgoing interface: AT0/0/0, vc: 1/82
      30 packets sent, 28 received, 422 bytes sent, 395 received

その他の debug コマンドには debug vpdn pppoe-datadebug pppoe-errors、および debug pppoe-packets があります。

PPP 層

次に、Cisco 6400 からの PPP デバッグの出力例を示します。これらのデバックは、前述した Cisco SOHO77 からのデバッグに対応しています。

コマンドライン インターフェイスから次のコマンドを入力します。

  debug ppp negotiation and debug ppp authentication
  

結果の出力は次のようになります。

4d04h: Vi2 PPP: Treating connection as a dedicated line 
  4d04h: Vi2 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load] 
  4d04h: Vi2 LCP: O CONFREQ [Closed] id 1 len 15 
  4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
  4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
  4d04h: Vi2 LCP: I CONFREQ [REQsent] id 1 len 10 
  4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9) 
  4d04h: Vi2 LCP: O CONFACK [REQsent] id 1 len 10 
  4d04h: Vi2 LCP:    MagicNumber 0x03144FF9 (0x050603144FF9) 
  4d04h: Vi3 LCP: I ECHOREQ [Open] id 60 len 8 magic 0xA60C0000 
  4d04h: Vi3 LCP: O ECHOREP [Open] id 60 len 8 magic 0x51A0BEF6 
  4d04h: Vi2 LCP: TIMEout: State ACKsent 
  4d04h: Vi2 LCP: O CONFREQ [ACKsent] id 2 len 15 
  4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
  4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
  4d04h: Vi2 LCP: I CONFACK [ACKsent] id 2 len 15 
  4d04h: Vi2 LCP:    AuthProto CHAP (0x0305C22305) 
  4d04h: Vi2 LCP:    MagicNumber 0x65F62814 (0x050665F62814) 
  4d04h: Vi2 LCP: State is Open 
  4d04h: Vi2 PPP: Phase is AUTHENTICATING, by this end [0 sess, 1 load] 
  4d04h: Vi2 CHAP: O CHALLENGE id 10 len 26 from "nrp-b" 
  4d04h: Vi2 CHAP: I RESPONSE id 10 len 28 from "client1" 
  4d04h: Vi2 PPP: Phase is FORWARDING [0 sess, 1 load] 
  4d04h: Vi2 PPP: Phase is AUTHENTICATING [0 sess, 1 load] 
  4d04h: Vi2 CHAP: O SUCCESS id 10 len 4 
  4d04h: Vi2 PPP: Phase is UP [0 sess, 1 load] 
  4d04h: Vi2 IPCP: O CONFREQ [Closed] id 1 len 10 
  4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801) 
  4d04h: Vi2 IPCP: I CONFREQ [REQsent] id 1 len 10 
  4d04h: Vi2 IPCP:    Address 0.0.0.0 (0x030600000000) 
  4d04h: Vi2 IPCP: Pool returned 9.9.9.2 
  4d04h: Vi2 IPCP: O CONFNAK [REQsent] id 1 len 10 
  4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
  4d04h: Vi2 CDPCP: I CONFREQ [Not negotiated] id 1 len 4 
  4d04h: Vi2 LCP: O PROTREJ [Open] id 3 len 10 protocol CDPCP (0x820701010004) 
  4d04h: Vi2 IPCP: I CONFACK [REQsent] id 1 len 10 
  4d04h: Vi2 IPCP:    Address 8.8.8.1 (0x030608080801) 
  4d04h: Vi2 IPCP: I CONFREQ [ACKrcvd] id 2 len 10 
  4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
  4d04h: Vi2 IPCP: O CONFACK [ACKrcvd] id 2 len 10 
  4d04h: Vi2 IPCP:    Address 9.9.9.2 (0x030609090902) 
  4d04h: Vi2 IPCP: State is Open 
  4d04h: Vi2 IPCP: Install route to 9.9.9.2 
  4d04h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2,
  changed state to up 

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 12925