IP : IP ルーテッド プロトコル

複数のトラッキング オプション機能を使用したポリシー ベース ルーティングの設定例

2009 年 1 月 14 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
設定
      ネットワーク ダイアグラム
      設定例
確認
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

このドキュメントでは、複数のトラッキング オプション機能を使用したポリシー ベース ルーティングの設定例を紹介しています。この機能は、Cisco IOS(R) ソフトウェア リリース 12.3(4)T で導入されました。詳細は、『複数のトラッキング オプションの PBR サポート』を参照してください。

この機能は、トラフィックをネクストホップに転送する前にネクストホップ IP アドレスを検証するための目標トラッキング機能を拡張するものです。検証方式は、Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)PING、User Datagram Protocol(UDP; ユーザ データグラム プロトコル)PING、または Hypertext Transfer Protocol(HTTP; ハイパーテキスト転送プロトコル)GET 要求です。ICMP は、インターネット上で最も一般的に使用される検証方式です。複数のトラッキング オプション機能は、複数のイーサネット接続をネクストホップとして持つルータに最適です。通常、イーサネット インターフェイスは、Digital Subscriber Line(DSL; デジタル加入者線)またはケーブル モデムに接続します。現在、ISP ブロードバンド ネットワークにおける障害アップストリームを検出する方法はありません。イーサネット インターフェイスはアップ状態のままになり、あらゆる形式のスタティック ルーティングがそのインターフェイスをポイントします。この強力な機能を利用すると、2 つのイーサネット インターフェイスをバックアップし、ICMP PING を送信して到達可能性を検証することで利用可能なインターフェイスを選択し、そのインターフェイスにトラフィックをルーティングできるようになります。

前提条件

要件

この設定を試行する前に、次の要件が満たされていることを確認してください。

  • エンタープライズ ベースの IOS 機能セットをルータにロードします(まだロードしていない場合)。この機能セットをご購入済みのお客様は、Download Software Area登録ユーザ専用)からダウンロードできます。
    一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションでは、このドキュメントで説明する機能を設定するために必要な情報を提供しています。

注:このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

このドキュメントでは、次のネットワーク構成を使用しています。このシナリオでは、R1 は 2 つの異なる ISP(ISP-1、ISP-2)に接続されています。R1 は、両方の ISP ルータへの到達可能性を追跡します。

pbrtracking_01.gif

設定例

このドキュメントでは、次の設定を使用しています。

R1

R1# show running-config 
Building configuration...

Current configuration : 1203 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
clock timezone EST 0
no aaa new-model
ip subnet-zero
no ip domain lookup
!
!
!
!
track 123 rtr 1 reachability

!--- ルータ 1 の到達可能性を追跡します。

!         
track 124 rtr 2 reachability

!--- ルータ 2 の到達可能性を追跡します。

!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.0.1 255.255.255.0
!
interface Ethernet1/0
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet2/0
 ip address 10.10.10.1 255.255.255.0
 ip policy route-map alpha

!--- 発信インターフェイスでポリシー ルーティングをイネーブルにします。

!
ip classless
no ip http server
!
!
!
!
route-map alpha permit 10

!--- 追跡ルータの状態に応じて 
!--- ネクストホップを設定するルートマップを定義します。

 set ip next-hop verify-availability 192.168.0.10 10 track 123
 set ip next-hop verify-availability 192.168.1.20 20 track 124
!
!
control-plane
!
rtr 1

!--- ルータ 1 を定義および起動します。

 type echo protocol ipIcmpEcho 192.168.0.10
rtr schedule 1 life forever start-time now
rtr 2

!--- ルータ 2 を定義および起動します。


 type echo protocol ipIcmpEcho 192.168.1.20
rtr schedule 2 life forever start-time now
!
line con 0
 transport preferred all
 transport output all
line aux 0
 transport preferred all
 transport output all
line vty 0 4
 login
 transport preferred all
 transport input all
 transport output all
!
!
end

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を示しています。

特定の show コマンドは、アウトプットインタープリタ登録ユーザ専用)でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。
一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

  • show track:トラッキング情報を表示します。

  • show track brief:制限付きのトラッキング情報を表示します。

R1# show track           
Track 123
  Response Time Reporter 1 reachability
  Reachability is Up
    3 changes, last change 00:06:43
  Latest operation return code: OK
  Latest RTT (millisecs) 8
  Tracked by:
    ROUTE-MAP  0
Track 124
  Response Time Reporter 2 reachability
  Reachability is Up
    3 changes, last change 00:06:43
  Latest operation return code: OK
  Latest RTT (millisecs) 12
  Tracked by:
    ROUTE-MAP  0

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Up
124     rtr       2                    reachability     Up

show track brief コマンドの出力から、両方の ISP が到達可能であることがわかります。ISP-1 に接続されているインターフェイスをシャットダウンすると、追跡時には、そのインターフェイスはダウンと表示されます。

R1# conf t
R1(config)# int ethernet 0/0
R1(config-if)# shutdown
R1(config-if)# end
R1#

*Jan 21 06:06:50.167: %SYS-5-CONFIG_I: Configured from console by console
*Jan 21 06:06:50.807: %LINK-5-CHANGED: Interface Ethernet0/0, changed state to administratively down
*Jan 21 06:06:51.827: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to down

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Up
124     rtr       2                    reachability     Up

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Down
124     rtr       2                    reachability     Up
R1# 

注:PBR では、インターフェイスまたはルートがアクティブであるかどうかを判断するためにトラッキングが必要になります。ルート トラッキングのステータスを表示するときにも、show route-map コマンドを使用できます。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 48003