IP : IP ルーティング

BGP ローカル AS 機能の設定

2004 年 3 月 16 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

目次

概要
前提条件
     要件
     使用するコンポーネント
     背景理論
     コマンド構文
     表記法
設定
     ネットワーク ダイアグラム
     設定
確認
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書では、Cisco IOS(R) ソフトウェア リリース 12.0(5)S で最初に使用可能になった Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)のローカル AS 機能について説明します。

前提条件

要件

本書の読者は、BGP ルーティング プロトコルおよびその操作方法を理解している必要があります。

使用するコンポーネント

この文書の情報は、次のソフトウェアとハードウェアのバージョンに基づいています。

  • Cisco IOS ソフトウェア リリース 12.2(10b)

  • Cisco 2500 シリーズ ルータ

この文書で紹介する情報は、特定のラボ環境にあるデバイスを使用して作成されました。この文書内で使用されているデバイスはすべて、クリアな状態(デフォルト)から設定作業を始めています。実稼動中のネットワークで作業する場合は、コマンドの実行によって生じる影響について、事前に理解しておいてください。

背景理論

ローカル AS 機能を使用すれば、実際の自立システム(AS)に加えて、2 番目の AS のメンバーのように見せることができます。 この機能を使用できるのは、本当の eBGP ピアの場合だけです。 異なるコンフェデレーション サブ AS のメンバである 2 つのピアには使用できません。

この機能は、ISP-A が ISP-B を買収したが、ISP-B の顧客がピアの設定または構成の変更に同意しない場合に便利です。 ローカル AS 機能を使用すれば、ISP-B の顧客には ISP-B の AS 番号をそのまま保持したように見せながら、ISP-B のルータを ISP-A のメンバにできます。

次の図 1 では、ISP-A はまだ ISP-B を買収していません。図 2 では、ISP-A が ISP-B を買収して、ISP-B でローカル AS 機能を使用しています。

図 2 では、ISP-B は AS 100 に、ISP-C は AS 300 にそれぞれ属しています。ISP-B は、ISP-C とピアになるときには、neighbor ISP-C local-as 200 コマンドを使用して AS 200 を自分の AS 番号として使用します。 ISP-B から ISP-C へ送信されるアップデートには、AS_PATH アトリビュートの AS_SEQUENCE に「200 100」が格納されます。 ISP-B で「200」が前に付加(プリペンド)されるのは、local-as 200 コマンドが ISP-C 用に設定されているためです。

通常は、ISP-A と B を結合すれば、ISP-B のルータが AS 100 の一部になるように番号が付け替えられます。しかし、ISP-C が ISP-B との eBGP の設定を変更できない場合はどうなるでしょうか。 ローカル AS 機能が実現される前は、結合された ISP-A/B で 2 つの AS 番号を保持する必要がありました。 local-as コマンドを使用すれば、ISP-C には ISP-A/B を 2 つの AS のように見せながら、物理的には 1 つの AS にできます。

コマンド構文

この文書で説明する設定に使用したコマンドの構文を次に示します。

  • neighbor x.x.x.x local-as local-AS-number

  • neighbor peer-group local-as local-AS-number

ローカル AS では、ピア グループ内の個々のピアに対するカスタマイズはできません。

ローカル AS には、ローカル BGP プロトコルの AS 番号またはリモート ピアの AS 番号は設定できません。

local-as コマンドは、ピアが本当の eBGP ピアの場合にだけ有効です。 コンフェデレーション内の異なるサブ AS にある 2 つのピアには使用できません。

BGP コマンドの詳細については、「BGP コマンド リファレンス ガイド」を参照してください。

表記法

文書の表記法の詳細は、「シスコ テクニカル ティップスの表記法」を参照してください。

設定

このセクションでは、この文書で説明する機能を設定するための情報を提供します。

注:この文書で使用されているコマンドの詳細を調べるには、Command Lookup Tool を使用してください(登録ユーザのみ)。


一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

この文書では次の図に示すネットワーク設定を使用しています。

図 1

39a.gif

図 2

39b.gif

設定

この文書では、次に示す設定を使用しています。

ISP-B(AS 100、local-as 200)

hostname ISP-B
  ! 
  interface serial 0 
  ip address 192.168.1.1 255.255.255.252 
  ! 
  interface ethernet 0 
  ip address 192.168.4.1 255.255.255.0 
  ! 
  router bgp 100 
   neighbor 192.168.1.2 remote-as 300 
   neighbor 192.168.1.2 local-as 200 
   network 192.168.4.0 
  ! 
  !

ISP-C(AS 300)

hostname ISP-C
  ! 
  interface serial 1 
  ip address 192.168.1.2 255.255.255.252 
  ! 
  interface ethernet 0 
  ip address 192.168.9.1 255.255.255.0 
  ! 
  router bgp 300 
   neighbor 192.168.1.1 remote-as 200
  
  !--- AS が 200 で AS 100 ではないことに注意してください
   
   network 192.168.9.0 
  ! 
  !

確認

この項では、設定が正しく動作することを確認するために使用できる情報を提供します。

特定の show コマンドは、アウトプットインタープリタ登録ユーザのみ)でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。


一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

次に使用されている show コマンドの詳細については、「BGP コマンド リファレンス ガイド」を参照してください。

BGP ルーティング テーブルを見て、local-as コマンドによって AS_PATH がどのように変更されたかを確認しましょう。 ISP-B では、ISP-C との間で送受信されるアップデートに AS 200 がプリペンドされていることがわかります。さらに、ISP-B が AS 番号 100 に所属していることにも注意してください。

ISP-B# show ip bgp summary
    BGP router identifier 192.168.4.1, local AS number 100 
    BGP table version is 3, main routing table version 3 
    2 network entries and 2 paths using 266 bytes of memory 
    2 BGP path attribute entries using 104 bytes of memory 
    1 BGP AS-PATH entries using 24 bytes of memory 
    0 BGP route-map cache entries using 0 bytes of memory 
    0 BGP filter-list cache entries using 0 bytes of memory 
    BGP activity 2/6 prefixes, 2/0 paths, scan interval 15  secs 
    Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd 
    192.168.1.2     4   300      29      29        3    0    0 00:25:19       1
  

次の出力の ISP-C では、ISP-B が AS 200 の一部として表示されていることに注意してください。

ISP-C# show ip bgp summary 
    BGP table version is 3, main routing table version 3 
    2 network entries (2/6 paths) using 480 bytes of memory 
    2 BGP path attribute entries using 192 bytes of memory 
    0 BGP route-map cache entries using 0 bytes of memory 
    0 BGP filter-list cache entries using 0 bytes of memory 
    Neighbor        V    AS MsgRcvd MsgSent  TblVer InQ OutQ   Up/Down  State/PfxRcd 
    192.168.1.1     4   200      34      34       3   0    0  00:30:19   1

次の出力の ISP-B では、ISP-C から学習したルートに「200」がプリペンドされていることに注意してください。

ISP-B# show ip bgp 
    BGP table version is 3, local router ID is 192.168.4.1 
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal 
    Origin codes: i - IGP, e - EGP, ? - incomplete 
    Network          Next Hop            Metric LocPrf  Weight   Path 
    *> 192.168.4.0      0.0.0.0               0          32768   i 
    *> 192.168.9.0      192.168.1.2           0              0   200 300 i

次の出力の ISP-C では、ISP-B からのルートに「200 100」という AS_PATH 指定が表示されていることに注意してください。

ISP-C# show ip bgp 
    BGP table version is 3, local router ID is 192.168.1.2 
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal 
    Origin codes: i - IGP, e - EGP, ? - incomplete 
    Network          Next Hop          Metric LocPrf  Weight Path 
    *> 192.168.4.0      192.168.1.1         0              0 200 100 i 
    *> 192.168.9.0      0.0.0.0             0          32768 i

次のコマンドの出力には、設定されている local-as 値が表示されます。

  • show ip bgp neighbor x.x.x.x

  • show ip bgp peer-group peer group name

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13761