ダイヤルとアクセス : 非同期接続

アクセス サーバでの WINS、DNS、および DHCP の設定

2004 年 9 月 6 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2008 年 1 月 29 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      関連製品
      表記法
背景理論
設定
      ネットワーク ダイアグラム
      設定
      コマンドの概要
確認
トラブルシューティング
      トラブルシューティングのためのコマンド
      デバッグの出力例
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

ダイヤルイン クライアントの中には、ネットワークに正しく接続するために、Windows Internet Naming Service(WINS)サーバまたは Domain Naming System(DNS; ドメイン ネーム システム)サーバの情報を必要とするものがあります。 さらに、アクセス サーバでのダイヤルイン クライアントへの IP アドレスの割り当てには、いくつかの異なる方法があります。

前提条件

要件

設定を開始する前に、次の前提条件を満たしていることを確認してください。

ルータが非同期コールおよび ISDN コールの着信を受け入れらるように設定を行い、これを確認します。 詳細については、『着信の非同期コールおよび ISDN コールについて、PRI(一次群速度インターフェイス)の備わったアクセス サーバの設定』で説明されている設定手順を参照してください。

DHCP、DNS、および WINS サーバが正しく設定されていることを確認します。 詳細については、システム管理者にお問い合せください。

注:この設定では、WINS、DNS、および DHCP サーバが、別々のサーバであると仮定しています。  実際には、これらを 1 台のサーバ上で実行することもできます。また、1 台のサーバ上で WINS と DNS を実行して、DHCP は他のサーバ上で実行するなど、3 つの機能をさまざまな組み合わせで実行できます。

使用するコンポーネント

この設定は、次の装置やデバイスを使用して作成およびテストされています。

  • Cisco AS5200、T1 PRI 回路 2 基搭載

  • DNS サーバ

  • WINS サーバ

  • クライアントに IP アドレスを割り当てる DHCP サーバ

この文書で紹介する情報は、特定のラボ環境にあるデバイスを使用して作成されました。この文書内で使用されているデバイスはすべて、クリアな状態(デフォルト)から設定作業を始めています。実稼動中のネットワークで作業する場合は、コマンドの実行によって生じる影響について、事前に理解しておいてください。

関連製品

DNS、DHCP、および WINS の設定コマンドは、PPP コールの着信をサポートするあらゆるルータで使用できます。

表記法

文書表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景理論

クライアントに IP アドレスを割り当てるには、次のようないくつかの方法があります。

  • アクセス サーバ上のローカル IP プールからアドレスを割り当てる。

  • 外部のダイナミック ホスト制御プロトコル(DHCP)サーバを使用する。

  • Remote Authentication Dial-in User Service(RADIUS)または Terminal Access Controller Access Control System(TACACS+)を使用する。

この文書では、WINS および DNS サーバの情報を、アクセス サーバ経由でダイヤルイン クライアントに渡すための手順について説明します。 アクセス サーバは、外部 DHCP サーバから返された IP アドレスを、さらにダイヤルイン クライアントに渡すことになります。

詳細については、この文書の「関連文書」のセクションに記載されている文書を参照してください。

設定

このセクションでは、この文書で説明する機能を設定するための情報を提供します。

ネットワーク ダイアグラム

この文書では次の図に示すネットワーク構成を使用しています。

winsdhcp.gif

設定

AS5200 アクセス サーバには、2 基の Primary Rate Interface(PRI; 一次群速度インターフェイス)が搭載されており、非同期および ISDN ユーザの着信を許可しています。 ISDN ユーザ向けに、ダイナミック ダイヤラ マップが作成されます。 ダイヤルイン アクセスを必要とする各ユーザには、TACACS+ または RADIUS 設定を行わずに、ユーザ名とパスワードを割り当てる必要があります。 IP アドレスは、すべて、DHCP サーバによりクライアントに渡されます。 アクセス サーバでは、PPP IP Control Protocol(IPCP)ネゴシエーションの際に、DNS サーバと WINS サーバの IP アドレスをクライアントに渡します。

AS5200 アクセス サーバ

version 11.1
  !
  service timestamps debug datetime msec localtime show-timezone
  service timestamps log datetime msec localtime show-timezone
  no service udp-small-servers
  no service tcp-small-servers
  !
  hostname as5200
  !
  enable password letmein
  !
  username Jason password foo
  username Laura password bar
  username Russ password fake
  username Syed password pseudo
  username Tito password knockknock
  !
  controller T1 0
   framing esf
   clock source line primary
   linecode b8zs
   pri-group timeslots 1-24
  !
  controller T1 1
   framing esf
   clock source line secondary
   linecode b8zs
   pri-group timeslots 1-24
  !
  interface Loopback0
   ip address 172.16.209.65 255.255.255.192
  !
  interface Loopback1
   ip address 172.16.209.129 255.255.255.192
  !
  interface Ethernet0
   ip address 172.16.162.4 255.255.255.0
  !
  interface Serial0
   no ip address 
  !
  interface Serial1
   no ip address
  !
  interface Serial0:23
   no ip address
   isdn incoming-voice modem
   dialer rotary-group 1
   encapsulation ppp
   no fair-queue
  !
  interface Serial1:23
   no ip address
   encapsulation ppp
   dialer rotary-group 1
   isdn incoming-voice modem
   no fair-queue
  !
  interface Group-Async1
   ip unnumbered Ethernet0
   encapsulation ppp
   async mode interactive
   peer default ip address dhcp
  
  ! -- 非同期ダイヤルアップ ユーザには、DHCP サーバから IP アドレスが 
  ! -- 割り当てられます。 dhcp サーバは、次の
  ! -- ip dhcp-server コマンドで指定します。
  ! -- 詳細については、「コマンドの概要」のセクションを参照してください。
  
   ip helper-address 172.16.162.10
  
  ! -- ip helper address コマンドは、一連のクライアントに対する BOOTP ブロードキャストの
  ! -- 転送を有効にします。 このヘルパー アドレスには、
  ! -- 以下で設定する DHCP サーバのアドレスを指定します。
  ! -- 詳細については、「コマンドの概要」のセクションを参照してください。
  
   ppp authentication chap
   group-range 1 48
  !
  interface Dialer1
   ip unnumbered Ethernet0
   encapsulation ppp
   peer default ip address dhcp
  
  ! -- ISDN ダイヤルアップ ユーザには、DHCP サーバから IP アドレスが割り当てられます。
  ! -- dhcp サーバは、次に示す ip dhcp-server コマンドで 
  ! -- 指定されます。 詳細については、「コマンドの概要」のセクションを参照してください。
  
   ip helper-address 172.16.162.10
  
  ! -- ip helper address コマンドは、一連のクライアントに対する BOOTP ブロードキャストの
  ! -- 転送を有効にします。 このヘルパー アドレスは、
  ! -- 以下で設定する DHCP サーバのアドレスを指定します。 
  ! -- 詳細については、「コマンドの概要」のセクションを参照してください。
  
   dialer in-band
   dialer idle-timeout 300
   dialer-group 1
   no fair-queue
   ppp multilink
   ppp authentication chap
  !
  router eigrp 222
   redistribute connected
   network 172.16.0.0
  !
  dialer-list 1 protocol ip permit
  !
  async-bootp dns-server 172.16.224.100 172.16.154.101
  
  ! -- プライマリおよびセカンダリ DNS サーバを設定します。
  ! -- 最初の IP アドレスは、プライマリ DNS サーバに属します。
  ! -- DNS サーバが 1 台しかない場合は、セカンダリ DNS サーバを設定する
  ! -- 必要はありません。
  ! -- 詳細については、「コマンドの概要」のセクションを参照してください。
  
  async-bootp nbns-server 172.16.224.10 172.16.4.2 
  
  ! -- プライマリおよびセカンダリ WINS サーバを設定します。
  ! -- 最初の IP アドレスは、プライマリ WINS サーバに属します。
  ! -- WINS サーバが 1 台しかない場合は、セカンダリ WINS サーバを設定する
  ! -- 必要はありません。
  ! -- 詳細については、「コマンドの概要」のセクションを参照してください。
  
  ip dhcp-server 172.16.162.10
  
  !--- dhcp サーバの IP アドレスを設定します。 このコマンドは、
  ! -- ダイヤルイン クライアントの IP アドレスをこのサーバから取得する場合に必要です。
  ! -- 注:dhcp サーバは、イーサネット インターフェイスと同じサブネット上にある
  ! -- 必要はありません。 
  ! -- 到達が可能であれば、1 ホップ以上離れた場所に配置することもできます。
  
  !
  line con 0
   login 
  line 1 48
  modem InOut
  transport input telnet
   autoselect during-login
   autoselect ppp
   flowcontrol hardware
  line aux 0
  line vty 0 4
   password secret
   login 
  !
  end
  

コマンドの概要

アクセス サーバの DHCP、DNS、および WINS に関するコマンドについて、以下で説明します。

  • ip helper-address address - DHCP プロトコルの情報は、BOOTP パケットによって搬送されます。 ip helper address コマンドは、一連のクライアントに対して BOOTP ブロードキャスト転送を有効にします。 ヘルパー アドレスには、DHCP サーバのアドレスを指定します。また、クライアントに最も近いインターフェイス(この場合は、group-async および dialer インターフェイス)に対して設定する必要があります。 複数のサーバがある場合は、各サーバにヘルパー アドレスを 1 つずつ設定できます。 ヘルパー アドレスは、RFC 1531 leavingcisco.com で定義されています。

  • peer default ip address dhcp - このインターフェイスに接続するリモート ピアに、DHCP 方式によるアドレスを返すよう指定します。 このことは、このインターフェイスに接続するクライアントには、DHCP サーバから取得した IP アドレスが割り当てられることを意味します。 また、ip dhcp server コマンドを使用して、クライアントの IP アドレスを取得する DHCP サーバの IP アドレスを指定することもできます。

  • async-bootp dns-server address - RFC1877 leavingcisco.com を実装する PPP クライアントをあつかう際に、NAS 応答で使用される DNS サーバのアドレスを設定します。 この DNS サーバの IP アドレスは、IPCP ネゴシエーションの際にダイヤルイン クライアントに渡されます。

  • async-bootp nbns-server address - Windows Name Service(WINS)サーバの IP アドレスを指定します。 この WINS サーバの IP アドレスは、IPCP ネゴシエーションの際にダイヤルイン クライアントに渡されます。

確認

クライアントがアクセス サーバから適切なパラメータを正しく受け取っているかどうかを確認するには、クライアントからテストを行う必要があります。

たとえば、www.cisco.com のような DNS によって解決できるアドレスに対して、クライアントから ping を実行します。DNS サーバがこのアドレスを解決できる場合は、設定が正しく動作していることになります。 WINS サーバの割り当てをテストするには、Windows ネットワークを使用してネットワークを参照します。

ダイナミック ダイヤラ マップが作成されているかどうかを調べるには、ISDN 接続が構築された後で、show dialer map コマンドを実行します。 これがないと、ルーティングを行うことができません。 ピアに割り当てられたアドレスを確認してください(このアドレスは、DHCP サーバから得られたものです)。 これによって、DHCP アドレスの割り当てが正しく行われたことを検証できます。

特定の show コマンドは、Output Interpreter ツールでサポートされています。このツールを使用すると、show コマンドの出力を分析できます。

トラブルシューティング

このセクションでは、設定のトラブルシューティングに役立つ情報を説明します。

トラブルシューティングのためのコマンド

この文書では、ISDN のレイヤ 1、2、3 が正しく機能していると仮定します。 ISDN の低いレイヤに問題が生じる場合は、 詳細について、『show isdn status コマンドを使用しての BRI のトラブルシューティング』を参照してください。

注:debug コマンドを使用する前に、『デバッグ コマンドの重要な情報』を参照してください。

  • debug ppp authentication - クライアントが認証を渡しているかどうかを確認します。 Cisco IOS(R) ソフトウェア リリース 11.2 より前のバージョンを使用している場合は、代わりに debug ppp chap コマンドを使用してください。

  • debug ppp negotiation - クライアントが PPP ネゴシエーション情報を渡しているかどうかを確認します。これは、アドレス ネゴシエーションをチェックする際に使用します。 IPCP ネゴシエーションは、クライアントに渡されている DNS サーバと WINS サーバの情報を示します。

  • debug ppp error - PPP 接続のネゴシエーションと運用に関するプロトコル エラーと、エラーの統計情報を表示します。

DNS サーバと WINS サーバの割り当ては、PPP ネゴシエーションの IPCP フェーズで行われています。 次に出力例を示します。

デバッグの出力例

以下の debug ppp negotiation の出力(非同期ダイヤルイン コールに対するもの)では、クライアントに対する IPCP ネゴシエーションを表しています。 この例では、プライマリ DNS サーバだけが指定されています。 WINS サーバはクライアントに渡されていません。

Sep 26 12:50:47.227: As97 CHAP: O CHALLENGE id 1 len 32 
  from "maui-nas-02"
  Sep 26 12:50:47.355: As97 CHAP: I RESPONSE id 1 len 31 
  from "async_user"
  Sep 26 12:50:47.355: As97 AUTH: Started process 0 pid 56
  Sep 26 12:50:47.355: As97 CHAP: O SUCCESS id 1 len 4
  Sep 26 12:50:47.359: As97 PPP: Phase is UP [0 sess, 0 load]
  
  !--- IPCP ネゴシエーションが開始されます。
  
  Sep 26 12:50:47.359: As97 IPCP: O CONFREQ [Closed] id 1 len 10
  Sep 26 12:50:47.359: As97 IPCP:    Address 172.22.53.140 
  (0x0306AC16358C)
  Sep 26 12:50:47.467: As97 IPCP: I CONFREQ [REQsent] id 1 len 40
  Sep 26 12:50:47.467: As97 IPCP:    CompressType VJ 15 slots 
  CompressSlotID 
  (0x0206002D0F01)
  Sep 26 12:50:47.467: As97 IPCP:    Address 0.0.0.0 
  (0x030600000000)
  Sep 26 12:50:47.467: As97 IPCP:    PrimaryDNS 172.22.53.210 
  (0x8106AC1635D2)
  Sep 26 12:50:47.467: As97 IPCP:    PrimaryWINS 0.0.0.0 
  (0x820600000000)
  Sep 26 12:50:47.467: As97 IPCP:    SecondaryDNS 0.0.0.0 
  (0x830600000000)
  Sep 26 12:50:47.467: As97 IPCP:    SecondaryWINS 0.0.0.0 
  (0x840600000000)
  Sep 26 12:50:47.467: As97 AAA/AUTHOR/IPCP: Start.  
  Her address 0.0.0.0, we want 172.22.60.2
  Sep 26 12:50:47.467: As97 AAA/AUTHOR/IPCP: Done.  
  Her address 0.0.0.0, we want 172.22.60.2
  
  ! -- クライアントの IP アドレスが割り当てられます。
  
  Sep 26 12:50:47.467: As97 IPCP: O CONFREJ [REQsent] id 1 len 28
  Sep 26 12:50:47.467: As97 IPCP:    CompressType VJ 15 slots 
  CompressSlotID 
  (0x0206002D0F01)
  Sep 26 12:50:47.467: As97 IPCP:    PrimaryWINS 0.0.0.0 
  (0x820600000000)
  Sep 26 12:50:47.467: As97 IPCP:    SecondaryDNS 0.0.0.0 
  (0x830600000000)
  Sep 26 12:50:47.467: As97 IPCP:    SecondaryWINS 0.0.0.0 
  (0x840600000000)
  Sep 26 12:50:47.483: As97 CCP: I CONFREQ [Not negotiated] 
  id 1 len 15
  Sep 26 12:50:47.483: As97 CCP:    MS-PPC supported bits 
  0x00000001 
  (0x120600000001)
  Sep 26 12:50:47.483: As97 CCP:    Stacker history 1 check mode 
  EXTENDED 
  (0x1105000104)
  Sep 26 12:50:47.483: As97 LCP: O PROTREJ [Open] id 4 len 21 
  protocol CCP
  Sep 26 12:50:47.483: As97 LCP:  (0x80FD0101000F12060000000111050001)
  Sep 26 12:50:47.483: As97 LCP:  (0x04)
  Sep 26 12:50:47.499: As97 IPCP: I CONFACK [REQsent] id 1 len 10
  Sep 26 12:50:47.499: As97 IPCP:    Address 172.22.53.140 
  (0x0306AC16358C)
  Sep 26 12:50:49.359: As97 IPCP: TIMEout: State ACKrcvd
  Sep 26 12:50:49.359: As97 IPCP: O CONFREQ [ACKrcvd] id 2 len 10
  Sep 26 12:50:49.359: As97 IPCP:    Address 172.22.53.140 
  (0x0306AC16358C)
  Sep 26 12:50:49.467: As97 IPCP: I CONFACK [REQsent] id 2 len 10
  Sep 26 12:50:49.467: As97 IPCP:    Address 172.22.53.140 
  (0x0306AC16358C)
  Sep 26 12:50:50.459: As97 IPCP: I CONFREQ [ACKrcvd] id 2 len 34
  Sep 26 12:50:50.459: As97 IPCP:    Address 0.0.0.0 (0x030600000000)
  Sep 26 12:50:50.459: As97 IPCP:    PrimaryDNS 172.22.53.210 
  (0x8106AC1635D2)
  Sep 26 12:50:50.459: As97 IPCP:    PrimaryWINS 0.0.0.0 
  (0x820600000000)
  Sep 26 12:50:50.459: As97 IPCP:    SecondaryDNS 0.0.0.0 
  (0x830600000000)
  Sep 26 12:50:50.459: As97 IPCP:    SecondaryWINS 0.0.0.0 
  (0x840600000000)
  Sep 26 12:50:50.459: As97 AAA/AUTHOR/IPCP: Start.  
  Her address 0.0.0.0, we want 172.22.60.2
  Sep 26 12:50:50.463: As97 AAA/AUTHOR/IPCP: Done.  
  Her address 0.0.0.0, we want 172.22.60.2
  Sep 26 12:50:50.463: As97 IPCP: O CONFREJ [ACKrcvd] id 2 len 22
  Sep 26 12:50:50.463: As97 IPCP:    PrimaryWINS 0.0.0.0 
  (0x820600000000)
  Sep 26 12:50:50.463: As97 IPCP:    SecondaryDNS 0.0.0.0 
  (0x830600000000)
  Sep 26 12:50:50.463: As97 IPCP:    SecondaryWINS 0.0.0.0 
  (0x840600000000)
  Sep 26 12:50:50.571: As97 IPCP: I CONFREQ [ACKrcvd] id 3 len 16
  Sep 26 12:50:50.571: As97 IPCP:    Address 0.0.0.0 
  (0x030600000000)
  Sep 26 12:50:50.571: As97 IPCP:    PrimaryDNS 172.22.53.210 
  (0x8106AC1635D2)
  Sep 26 12:50:50.571: As97 AAA/AUTHOR/IPCP: Start.  
  Her address 0.0.0.0, we want 172.22.60.2
  Sep 26 12:50:50.571: As97 AAA/AUTHOR/IPCP: Done.  
  Her address 0.0.0.0, we want 172.22.60.2
  Sep 26 12:50:50.571: As97 IPCP: O CONFNAK [ACKrcvd] id 3 len 10
  Sep 26 12:50:50.571: As97 IPCP:    Address 172.22.60.2 
  (0x0306AC163C02)
  Sep 26 12:50:50.683: As97 IPCP: I CONFREQ [ACKrcvd] id 4 len 16
  Sep 26 12:50:50.683: As97 IPCP:    Address 172.22.60.2 
  (0x0306AC163C02)
  Sep 26 12:50:50.683: As97 IPCP:    PrimaryDNS 172.22.53.210 
  (0x8106AC1635D2)
  Sep 26 12:50:50.683: As97 AAA/AUTHOR/IPCP: Start.  
  Her address 172.22.60.2, we want 172.22.60.2
  Sep 26 12:50:50.683: As97 AAA/AUTHOR/IPCP: Reject 172.22.60.2, 
  using 172.22.60.2
  Sep 26 12:50:50.687: As97 AAA/AUTHOR/IPCP: Done.  
  Her address 172.22.60.2, we want 172.22.60.2
  Sep 26 12:50:50.687: As97 IPCP: O CONFACK [ACKrcvd] id 4 len 16
  Sep 26 12:50:50.687: As97 IPCP:    Address 172.22.60.2 
  (0x0306AC163C02)
  Sep 26 12:50:50.687: As97 IPCP:    PrimaryDNS 172.22.53.210 
  (0x8106AC1635D2)
  
  ! -- クライアントの IP アドレスと、プライマリ DNS サーバの
  ! -- IP アドレスがネゴシエートされます。 
  
  Sep 26 12:50:50.687: As97 IPCP: State is Open

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 6303