IP : IP アドレッシング サービス

1 台の DHCP サーバを音声とデータのネットワークに使用する方法

2005 年 1 月 25 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 2 月 16 日) | フィードバック

目次

概要
前提条件
      要件
      使用するコンポーネント
      表記法
問題
解決方法
      ネットワーク設定
      MSFC を搭載した Catalyst 6000 の例
      外部ルータを使用した Catalyst 3524-XL の例
     
ソリューションの動作の仕組み
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

最適化された IP テレフォニー ネットワークでは、電話用の IP アドレスと PC 用の IP アドレスは、異なるネットワークセグメントで設定する必要があります。Dynamic Host Configuration Protocol(DHCP; ダイナミック ホスト コンフィギュレーション プロトコル)を使用してアドレスを割り当る場合、通常は 1 つのネットワーク セグメントに 1 台の DHCP サーバが必要です。ところが、IP ネットワーク内に DHCP リレー機能を備えたルータがあれば、1 台の DHCP サーバで両方の範囲のアドレスを割り当てることができます。この文書では、1 台のサーバを音声とデータ両方の IP アドレスに使用する方法、およびその仕組みについて説明します。

注:この文書の情報は、フル スイッチド ネットワークでは適用できず、またルーティング対応デバイスがない場合も適用できません。このような状況では、電話と PC に異なる IP アドレスを割り当てるには、2 枚のネットワーク インターフェイス カードを搭載した DHCP サーバを使用するか、2 台の DHCP サーバを使用する必要があります。

前提条件

要件

この文書に関する特別な要件はありません。

使用するコンポーネント

この文書は、特定のソフトウェアまたはハードウェアのバージョンに限定されるものではありません。

表記法

文書表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

問題

IP テレフォニー ネットワークを設置する場合、電話用の IP アドレスと PC 用の IP アドレスを、異なるネットワーク セグメントで割り当てる必要があります。このようなアドレス割り当てには、1 つのネットワーク セグメントに 1 台の DHCP サーバが必要になります。ここでは、DHCP サーバが 1 台しかない場合を仮定します。

解決方法

現在の DHCP サーバを使用して両方の VLAN のアドレスを割り当てるには、VLAN 間ルーティングを実行できるレイヤ 3(L3)デバイスをネットワークに用意する必要があります。

この文書の 2 つの例では、1 台の DHCP サーバを使用して、音声とデータ両方の IP アドレスを割り当てる方法を説明します。

ネットワーク設定

Cisco Catalyst 6000 または Catalyst 3524-XL-PWR が 1 台存在するネットワークを想定します。このネットワークでは、VLAN 10 は PC やサーバにより使用されるデータ VLAN として設定されています。同じ VLAN には、10.10.10.20 から 10.10.10.200 の範囲のアドレスを提供するための、Windows 2000 が稼動する DHCP サーバも存在します。この DHCP サーバの IP アドレスは 10.10.10.2 です。

dhcp-multintwk-1.gif

このネットワークに IP テレフォニーを追加するには、PC が接続されていた Catalyst ポートに、IP Phone を元の PC が後ろに来るように接続します。

MSFC を搭載した Catalyst 6000 の例

このシナリオには、Multilayer Switch Feature Card(MSFC; マルチレイヤ スイッチ フィーチャ カード)をルーティング対応デバイスとして搭載する Cisco Catalyst 6000 が存在します。

dhcp-multintwk-2.gif

同じ Catalyst ポート上で PC と電話が存在できるようにするには、次に示すように新しい音声 VLAN 110 で auxiliaryVLAN コマンドを設定する必要があります。

cat6k-access> (enable) set VLAN 110 name 11.1.1.0_voice
  cat6k-access> (enable) set VLAN 10 5/1-48
  cat6k-access> (enable) set port auxiliaryVLAN 5/1-48 110
  

データ VLAN 10 の現在の DHCP サーバを使用して、電話への IP アドレスの割り当てを可能にするには、次の手順に従います。

  1. データと音声の各 VLAN ごとに、MSFC でインターフェイスを作成します。

  2. VLAN 内の有効なアドレスを使用して各インターフェイスを設定します。

  3. インターフェイス VLAN 110 で、ip helper-address コマンドを追加します。

    このコマンドを使用すると、音声 VLAN 110 上の DHCP ブロードキャスト パケットを、データ VLAN 10 内の DHCP サーバへのユニキャスト パケットとして送信できるようになります。

    MSFC では次の設定を行う必要があります。

    cat6k-msfc(config)#interface vlan10
      cat6k-msfc(config-if)#ip address 10.10.10.19
      cat6k-msfc(config-if)#<description of data VLAN for PCs and where the DHCP
       server is located>
      cat6k-msfc(config)#interface vlan110
      cat6k-msfc(config-if)#ip address 11.1.1.19
      cat6k-msfc(config-if)#ip helper-address 10.10.10.2
      cat6k-msfc(config-if)#<description VLAN for voice>
      

    Cisco Catalyst 6000 の設定は変更しません。

  4. 音声 VLAN 110 内の電話用のアドレスの新しいスコープ(11.1.1.1.X)で、DHCP サーバを設定します。

    DHCP サーバに、リレー エージェントの IP アドレスに一致するスコープがないと、DHCP 要求は失敗します。電話への TFTP サーバ アドレスを提供するために、そのスコープ内にオプション 150 を追加する必要があります。電話用の DHCP サーバの設定の手順説明については、『Cisco CallManager 用の Windows 2000 DHCP サーバの設定』を参照してください。

外部ルータを使用した Catalyst 3524-XL の例

このシナリオでは、Cisco Catalyst 3524-XL-PWR が 1 台と、ルーティング対応デバイスとして機能する外部ルータが 1 台存在し、VLAN ごとに 1 つのインターフェイスがあります。

dhcp-multintwk-3.gif

同じ Catalyst ポート上に PC と電話を共存させるには、次に示すように、新しい音声 VLAN 110 でトランキングを設定します。

interface FastEthernet0/13
  description phone and PC
  switchport mode trunk
  switchport trunk encapsulation dot1q
  switchport voice vlan 110
  switchport trunk native vlan 10

PC が付属する電話機を接続した Catalyst のすべてのポートでこの設定作業を繰り返します。

データ VLAN 10 の現在の DHCP サーバを使用して、電話への IP アドレスの割り当てを可能にするには、次の手順に従います。

  1. 2 つのルータ インターフェイスを、Cisco Catalyst 3524-XL 上の 2 つのポート(一方を VLAN 10、もう一方を VLAN 110)に接続します。

  2. ルータ側では、各 VLAN での有効なアドレスを割り当てます。

    注:トランキングが設定されている場合は、Catalyst 3524-XL からルータに接続されている 1 つのポートで、これを実現することもできます。

  3. 音声 VLAN 110 に接続されているルータ インターフェイス上で ip helper-address コマンドを発行します。

    これにより、インターフェイス上で受信された DHCP ブロードキャスト パケットを、データ VLAN 10 内の DHCP サーバに対するユニキャスト パケットとして送信できるようになります。

    ルータでは次の設定を行う必要があります。

    router(config)#interface FastEthernet0/0
      router(config-if)#ip address 10.10.10.19 255.255.255.0
      router(config-if)#<description connected to catalyst port 0/10 
       data VLAN for PCs and DHCP server>
      router(config)#interface FastEthernet0/1
      router(config-if)#IP address 11.1.1.19 255.255.255.0
      router(config-if)#IP helper-address 10.10.10.2
      router(config-if)#<description connected to catalyst port 0/11 voice VLAN>
      

    Cisco Catalyst 3524-XL では次の設定を行う必要があります。

    router(config)interface FastEthernet0/10
      router(config-if)#switchport access vlan 10
      router(config-if)#<description port on data VLAN going to the router FE0/0>
      router(config)interface FastEthernet0/11
      router(config-if)#switchport access vlan 110
      router(config-if)#<description port on voice VLAN going to the router FE0/1>
      
  4. 音声 VLAN 110 内の電話機用のアドレスの新しいスコープ(11.1.1.1.X)で、DHCP サーバを設定します。

    DHCP サーバに、リレー エージェントの IP アドレスに一致するスコープがないと、DHCP 要求は失敗します。電話への TFTP サーバ アドレスを提供するために、そのスコープ内にオプション 150 を追加する必要があります。電話用の DHCP サーバの設定の手順説明については、『Cisco CallManager 用の Windows 2000 DHCP サーバの設定』を参照してください。

ソリューションの動作の仕組み

DHCP サーバでは、DHCP パケットの Relay Agent フィールドの使用に基づき、両方の VLAN 用の適切なスコープからアドレスを提供できます。リレー エージェントは、電話機により送信されたブロードキャスト DHCP パケットを、DHCP サーバに送信されるユニキャスト パケットに変換する役割があります。またこのエージェントは、DHCP サーバから送信されたユニキャスト DHCP パケットを、電話のネットワーク上で送信されるブロードキャスト パケットに変換する作業も行います。この例のリレー エージェントは、ip helper-address コマンドで設定された MSFC 上の VLAN 110 インターフェイスです。

DHCP サーバでは、Relay Agent フィールド内に現在の IP アドレスを持つ DHCP Discover メッセージを受信した場合、そのアドレスを使用して適切なスコープとの照合を行い、そのスコープから IP アドレスを割り当てます。このプロトコルの詳細情報は、RFC 3046 leavingcisco.com にあります。

この例で交換される DHCP パケットを次に示します。

dhcp-multintwk-4.gif

青い線は、IP Phone との間で送受信される DHCP パケットを表しています。これらは、DHCP サーバが電話と同じ Ethernet ネットワーク内に存在する場合に出現する唯一のパケットです。

黒い線は、リレー エージェントが DHCP サーバとの間で送受信する DHCP ユニキャスト パケットを表しています。

次の表に、この例のパケットの詳細を示します。DHCP のプロトコルとフィールドの詳細は、RFC 1541 leavingcisco.com を参照してください。

1 DHCP Discover

2 DHCP Discover

IP Source Address = [0.0.0.0]
  IP Destination Address = [255.255.255.255]
  DHCP Client IP Address = [0.0.0.0] 
  DHCP Relay Agent = [0.0.0.0]
  Client Hardware Address = 00070EEA5449 
  Message Type = 1 (DHCP Discover)
  Parameter Request List:
  ...
      150= Unknown Option 
  ... 
IP Source Address = [11.1.1.19]
  IP Destination Address =[10.10.10.2]
  DHCP Client IP Address = [0.0.0.0]
  DHCP Relay Agent = [11.1.1.19]
  Client Hardware Address = 00070EEA5449 
  Message Type = 1 (DHCP Discover)
  Parameter Request List:
  ...
      150= Unknown Option 
  ...

4 DHCP Offer

3 DHCP Offer

IP Source Address = [10.10.10.2]
  IP Destination Address = [255.255.255.255]
  DHCP Client IP Address = [11.1.1.25]
  DHCP Relay Agent = [11.1.1.19]
  Client Hardware Address = 00070EEA5449
  Message Type = 2 (DHCP Offer)
  ....
  Address Renewel Interval = 216000 (seconds)
  TFTF Server = "11.1.1.10"
  ...
IP Source Address = [10.10.10.2]
  IP Destination Address = [11.1.1.19]
  DHCP Client IP Address = [11.1.1.25]
  DHCP Relay Agent = [11.1.1.19]
  Client Hardware Address = 00070EEA5449 
  Message Type = 2 (DHCP Offer)
  ....
  Address Renewel Interval = 216000 (seconds)
  TFTF Server = "11.1.1.10"
  ...

5 DHCP Request

6 DHCP Request

IP Source Address = [0.0.0.0]
  IP Destination Address = [255.255.255.255]
  DHCP Client IP Address = [0.0.0.0]
  DHCP Relay Agent = [0.0.0.0]
  Client Hardware Address = 00070EEA5449 
  Message Type = 3 (DHCP Request)
  Request Specific IP Address = [11.1.1.25]
  Parameter Request List:
  ...
      150= Unknown Option 
  ...
IP Source Address = [11.1.1.19]
  IP Destination Address = [10.10.10.2]
  DHCP Client IP Address =  [0.0.0.0]
  DHCP Relay Agent = [11.1.1.19]
  Client Hardware Address = 00070EEA5449 
  Message Type = 3 (DHCP Request)
  Request Specific IP Address = [11.1.1.25]
  Parameter Request List:
  ...
      150= Unknown Option 
  ...

8 DHCP Ack

7 DHCP Ack

IP Source Address = [10.10.10.2]
  IP Destination Address = [255.255.255.255]
  DHCP Client IP Address = [11.1.1.25]
  DHCP Relay Agent = [11.1.1.19]
  Client Hardware Address = 00070EEA5449
  Message Type = 5 (DHCP Ack)
  ....
  Address Renewel Interval = 216000 (seconds)
  TFTF Server = "11.1.1.10"
  ...
IP Source Address = [10.10.10.2]
  IP Destination Address = [11.1.1.19]
  DHCP Client IP Address = [11.1.1.25]
  DHCP Relay Agent = [11.1.1.19]
  Client Hardware Address = 00070EEA5449 
  Message Type = 5 (DHCP Ack)
  ....
  Address Renewel Interval = 216000 (seconds)
  TFTF Server = "11.1.1.10"
  ...

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 19580