IP : IP マルチキャスト

ランデブー ポイントへのフィルタリング ポリシーの設定

2003 年 12 月 17 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 4 月 3 日) | フィードバック

目次

概要
はじめに
     表記法
     前提条件
     使用するコンポーネント
Auto-RP
RP アドレスのフィルタリング
     フィルタリングの例
確認
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書では、rendezvous point(RP; ランデブー ポイント)に対して、ダイナミック RP 設定(Auto-RP)が適用されているマルチキャスト環境にある RP マッピング エージェントを使用してフィルタリング ポリシーを適用する方法について説明します。

はじめに

表記法

文書表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

前提条件

設定を開始する前に、次の前提条件を満たしていることを確認してください。

  • Protocol Independent Multicast(PIM)に関する基本的な知識があること

使用するコンポーネント

この文書では、例として次の図で示す構成を全体で使用します。

rp_announce_02.gif

この文書で紹介する情報は、特定のラボ環境にあるデバイスを使用して作成されました。この文書で使用するすべてのデバイスは、クリアな状態(デフォルト)から設定作業を始めています。実稼動中のネットワークで作業する場合は、コマンドの実行によって生じる影響について、事前に理解しておいてください。

Auto-RP

Auto-RP とは、ネットワーク上の全ルータに関する RP 情報をダイナミックに学習する方法です。 これは、IP マルチキャストを使用して、すべての RP 対グループの情報を配布することで行われます。

PIM が有効になっているルータは、すべて自動的に Cisco RP ディスカバリ グループ(224.0.1.40)に参加します。これによって、すべての RP 対グループのマッピング情報を受信できるようになります。 この情報は、RP マッピング エージェントというエンティティによって配布されます。 マッピング エージェント自体は、他のグループ(Cisco RP アナウンス グループ(224.0.1.39))に参加しています。 すべての候補 RP は、RP アナウンス グループのアドレス宛ての定期的なマルチキャスト メッセージの中で、自分自身をアドバタイズします。

マッピング エージェントは、すべての RP 候補のアナウンスを受信し、その情報でテーブルを作成します。 複数の RP が自分自身をマルチキャスト グループの範囲にアナウンスした場合は、マッピング エージェントは、最も大きな IP アドレスを持つ RP を 1 つだけ選択します。 次に、RP ディスカバリ メッセージを使用して、その RP をネットワーク上のすべての PIM ルータにアドバタイズします。 マッピング エージェントは、この情報を 60 秒ごとに送信します(デフォルト設定)。

RP アドレスのフィルタリング

ip pim rp-announce-filter rp-list access-list group-list access-list コマンドを使用すると、特定のマルチキャスト グループに対する RP をフィルタリングできます。

ip pim rp-announce-filter rp-list access-list group-list access-list コマンドは、マッピング エージェントで設定された場合にだけ意味を持ちます。 rp-list access-list は、許可された場合に、group-list access-list で指定されたマルチキャストの範囲で受け入れられる候補 RP のアクセスリストを定義するものです。

注: このコマンドを使用する際には、注意してください。 rp-list に一致する RP(permit 文で許可)には、group-list でフィルタされるマルチキャスト グループがあります。拒否された RP(明示的あるいは暗黙の拒否)は、マルチキャスト グループのフィルタリングの対象にはならず、そのグループのすべてに対して候補 RP として「盲目的に」受容されます。 言い換えると、rp-list で許可されている RP には、group-list でフィルタされるマルチキャスト グループがあり、他のすべての RP はチェックなしで受容されます。

チェックなしで受容される RP を効率的にフィルタするには、RP アナウンス フィルタを追加する必要があります。 次の例では、この手順を示します。

フィルタリングの例

上の図では、R2 と R4 が自身を次のグループに対する候補 RP としてアナウンスしています(この情報は RP ディスカバリ メッセージを使用してアドバタイズされます)。

  • 224.1.0.1

  • 224.1.0.2

  • 224.1.0.3

R3 は、マッピング エージェントとして設定されており、この情報を収集し、テーブルを作成し、ただ 1 つの RP アドレスを R6 に送信します。R6 は唯一の PIM 対応ルータです。 この例では Intermediate System-to-Intermediate System(IS-IS)がユニキャスト ルーティング プロトコルとして使用されていますが、他のプロトコルもすべて動作しています。 PIM の sparseDense モードは、グループ 224.0.1.39 と 224.0.1.40 に宛てたマルチキャスト情報を、それらのグループのための RP 設定を行わないで受信するために必要です。 つまり、sparseDense モードは、既知の RP がない場合の高密度モードのように動作します。 RP が分かっている場合は、RP が自身をアドバタイズするグループに対して sparseDense モードが使用されます。

R2 の設定

hostname R2
 ip multicast-routing
 interface Loopback0
  ip address 50.0.0.2 255.255.255.255
  ip router isis
  ip pim sparse-dense mode
 interface Serial3/0
  ip address 10.2.0.2 255.255.255.0
  ip router isis
  ip pim sparse-dense mode
 router isis 
  net 49.0002.0000.0000.0002.00
 ip pim send-rp-announce Loopback0 scope 16 group-list groupB
 !         
 !         
 ip access-list standard groupB
  permit 224.1.0.1
  permit 224.1.0.2
  permit 224.1.0.3

R4 の設定

hostname R4
 ip multicast-routing
 interface Loopback0
  ip address 50.0.0.4 255.255.255.255
  ip router isis
  ip pim sparse-dense mode
 interface Serial3/0
  ip address 10.3.0.4 255.255.255.0
  ip router isis
  ip pim sparse-dense mode
 router isis 
  net 49.0002.0000.0000.0004.00
 ip pim send-rp-announce Loopback0 scope 16 group-list groupA
 !         
 !         
 ip access-list standard groupA
  permit 224.1.0.1
  permit 224.1.0.2
  permit 224.1.0.3

R3 の設定

hostname R3
 ip multicast-routing
 interface Loopback0
  ip address 50.0.0.3 255.255.255.255
  ip router isis
  ip pim sparse-dense mode
 interface Ethernet1/0.1
  encapsulation dot1Q 65
  ip address 65.0.0.3 255.255.255.0
  ip router isis 
  ip pim sparse-dense-mode
 interface Serial2/0
  ip address 10.2.0.3 255.255.255.0
  ip router isis 
  ip pim sparse-dense-mode
 interface Serial3/0
  ip address 10.3.0.3 255.255.255.0
  ip router isis 
  ip pim sparse-dense-mode
 router isis 
  net 49.0002.0000.0000.0003.00

R6 の設定

hostname R6
 ip multicast-routing
 interface Loopback0
  ip address 50.0.0.6 255.255.255.255
  ip router isis
 interface Ethernet1/0.1
  encapsulation dot1Q 65
  ip address 65.0.0.6 255.255.255.0
  ip router isis 
  ip pim sparse-dense-mode
 router isis 
  net 49.0002.0000.0000.0003.00

R4 をこれらのグループすべてに対して可能性のある RP としてフィルタしたく、また稼動中の RP が R2 だけである場合は、R3 で次のように RP アナウンス フィルタを設定します。

ip pim rp-announce-filter rp-list filtering-RP group-list filtering-group
 !         
 !         
 ip access-list standard filtering-RP
  permit 50.0.0.2
  deny    50.0.0.4
 
 !--- ACL「filtering-RP」では R2 を明確に許可し、R4 を明示的に否定。
 
 ip access-list standard filtering-group
  permit 224.1.0.1
  permit 224.1.0.2
  permit 224.1.0.3

次に、現在の RP 対グループの関係をクリアし、R3 と R6 の両方で clear ip pim rp-mapping コマンドを発行します。

しかし、R6 を見ると、情報が期待したものとは違うことが分かります。

R6# show ip pim rp mapping 
 PIM Group-to-RP Mappings
 Group(s) 224.1.0.1/32
   RP 50.0.0.4 (?), v2v1
 
 !--- RP が R4 になっています。
 
     Info source: 65.0.0.3 (?), elected via Auto-RP
          Uptime: 00:00:02, expires: 00:02:55
 Group(s) 224.1.0.2/32
   RP 50.0.0.4 (?), v2v1
 
 !--- RP が R4 になっています。
 
     Info source: 65.0.0.3 (?), elected via Auto-RP
          Uptime: 00:00:02, expires: 00:02:55
 Group(s) 224.1.0.3/32
   RP 50.0.0.4 (?), v2v1
 
 !--- RP が R4 になっています。
 
     Info source: 65.0.0.3 (?), elected via Auto-RP
          Uptime: 00:00:02, expires: 00:02:55

R3 を見ると、実際にはフィルタリングが何も行われていないことがわかります。

R3# show ip pim rp mapping
 PIM Group-to-RP Mappings
 This system is an RP-mapping agent
 
 !--- この行では、R3 マッピング エージェントとして確かに設定されています。
 
 Group(s) 224.1.0.1/32
   RP 50.0.0.4 (?), v2v1
 
 !--- フィルタリングが有効になっていません。
 
     Info source: 50.0.0.4 (?), elected via Auto-RP
 
 !--- R4 が選択されたのは、最も大きな IP アドレスが設定されているためです。
 
          Uptime: 00:09:06, expires: 00:02:53
   RP 50.0.0.2 (?), v2v1
     Info source: 50.0.0.2 (?), via Auto-RP
          Uptime: 00:09:29, expires: 00:02:27
 Group(s) 224.1.0.2/32
   RP 50.0.0.4 (?), v2v1
     Info source: 50.0.0.4 (?), elected via Auto-RP
          Uptime: 00:09:06, expires: 00:02:51
   RP 50.0.0.2 (?), v2v1
     Info source: 50.0.0.2 (?), via Auto-RP
          Uptime: 00:09:29, expires: 00:02:27
 Group(s) 224.1.0.3/32
   RP 50.0.0.4 (?), v2v1
     Info source: 50.0.0.4 (?), elected via Auto-RP
          Uptime: 00:09:06, expires: 00:02:51
   RP 50.0.0.2 (?), v2v1
     Info source: 50.0.0.2 (?), via Auto-RP
          Uptime: 00:09:29, expires: 00:02:28

上で説明したように、R4 のアドレスは明示的に否定され、マルチキャスト グループのフィルタリングの対象にはなっておらず、マッピング エージェントによって「盲目的に」受容されています。 マッピング エージェントでは、最も大きな IP アドレスを持っている RP を選択し(この例では 50.0.0.4)、この情報を R6 に転送します。

この R4 のアドレスを効率的にフィルタリングするには、別の RP フィルタで R4 を許可し、グループのすべてを否定するよう設定する必要があります。

ip pim rp-announce-filter rp-list filtering-R4 group-list filtering-groupR4
 ip access-list standard filtering-R4
  permit 50.0.0.4
 ip access-list standard filtering-groupR4
  deny   any

R3 を見て、R4 からの RP アナウンス メッセージを受信した直後に debug ip pim auto-rp コマンドを有効にすると、次のメッセージが表示されます。

R3#
 *Apr 30 09:09:06.651: Auto-RP(0): Received RP-announce, from 50.0.0.4, RP_cnt 1, ht 181
 *Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.1/32 for RP 50.0.0.4
 *Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.3/32 for RP 50.0.0.4
 *Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.2/32 for RP 50.0.0.4
 *Apr 30 09:09:06.651: Auto-RP(0): Received RP-announce, from 50.0.0.4, RP_cnt 1, ht 181
 *Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.1/32 for RP 50.0.0.4
 *Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.3/32 for RP 50.0.0.4
 *Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.2/32 for RP 50.0.0.4

次に、RP 対グループのテーブルを見ると、R2 だけが記録されています。

R3# show ip pim rp mapping 
 PIM Group-to-RP Mappings
 This system is an RP-mapping agent
 Group(s) 224.1.0.1/32
   RP 50.0.0.2 (?), v2v1
     Info source: 50.0.0.2 (?), elected via Auto-RP
          Uptime: 00:00:04, expires: 00:02:52
 Group(s) 224.1.0.2/32
   RP 50.0.0.2 (?), v2v1
     Info source: 50.0.0.2 (?), elected via Auto-RP
          Uptime: 00:00:04, expires: 00:02:54
 Group(s) 224.1.0.3/32
   RP 50.0.0.2 (?), v2v1
     Info source: 50.0.0.2 (?), elected via Auto-RP
          Uptime: 00:00:04, expires: 00:02:55

最後に、R2 を 224.1.0.1 の RP、R4 を 224.1.0.2 と 224.1.0.3 の RP にする場合は、R3 で次のように設定します。

hostname R3
 ip multicast-routing
 interface Loopback0
  ip address 50.0.0.3 255.255.255.255
  ip router isis
  ip pim sparse-dense mode
 interface Ethernet1/0.1
  encapsulation dot1Q 65
  ip address 65.0.0.3 255.255.255.0
  ip router isis
  ip pim sparse-dense-mode
 interface Serial2/0
  ip address 10.2.0.3 255.255.255.0
  ip router isis
  ip pim sparse-dense-mode
 interface Serial3/0
  ip address 10.3.0.3 255.255.255.0
  ip router isis
  ip pim sparse-dense-mode
 router isis
  net 49.0002.0000.0000.0003.00
 ip pim rp-announce-filter rp-list filtering-RP2 group-list filtering-group2
 ip pim rp-announce-filter rp-list filtering-RP4 group-list filtering-group4
 !        
 !        
 ip access-list standard filtering-RP2
  permit 50.0.0.2
 ip access-list standard filtering-RP4
  permit 50.0.0.4
 ip access-list standard filtering-group2
  permit 224.1.0.1
 ip access-list standard filtering-group4
  permit 224.1.0.2
  permit 224.1.0.3

確認

現在のところ、この設定を確認する手順はありません。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 41680