IP : IP ルーテッド プロトコル

レイヤ 2 トンネリング プロトコル バージョン 3 のスタティック方式とヘアピン方式の設定例

2004 年 2 月 10 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

目次

概要
前提条件
     要件
     使用するコンポーネント
     表記法
設定
     ネットワーク ダイアグラム
     設定
確認
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書では、レイヤ 2 トンネリング プロトコル バージョン 3(L2TPv3)のスタティック方式とヘアピン方式の設定例について説明します。

次の表は、Cisco IOS(R) ソフトウェア リリースの L2TPv3 のための修正サポートについて説明します。

Cisco IOS ソフトウェア リリース

L2TPv3 サポートの説明

12.0(21)S

L2TPv3 のデータ プレーンの最初のサポートが、Cisco 7200 シリーズ、Cisco 7500 シリーズ、Cisco 10720 および Cisco 12000 シリーズ プラットフォームで導入されました。

12.0(23)S

L2TPv3 の制御プレーンのサポートが、Cisco 7200 シリーズ、Cisco 7500 シリーズ、Cisco 10720 および Cisco 12000 シリーズ プラットフォームで導入されました。

12.3 (2)T

この機能が、Cisco IOS ソフトウェア リリース 12.3(2)T に統合されました。

L2TPv3 機能を使用するには、Cisco Express Forwarding(CEF)をイネーブルにする必要があります。 Xconnect 設定サブモードは、CEF がイネーブルになるまでブロックされます。 Cisco 7500 シリーズなどの分散プラットフォームでは、セッション確立中に CEF をディセーブルにすると、セッションが解除され、CEF が再度イネーブルになるまでダウンしたままになります。 CEF をイネーブルにするには、ip cef コマンドまたは ip cef distributed コマンドを使用します。

ループバック インターフェイスの設定では、送信元 IP アドレスを指定することを強く推奨いたします。 ループバック インターフェイスを設定しない場合、ルータは最適の利用可能アドレスを選択します。このアドレスは、コアに面したインターフェイス上に設定されたいずれかの IP アドレスになります。 この設定では、制御チャネルの確立が妨げられることがあります。 ループバック アドレスは、コア ネットワークから到達できる必要があります。

前提条件

要件

この設定を試す前に、次の項目に関して精通していることを確認してください。

使用するコンポーネント

この文書は、特定のソフトウェアまたはハードウェアに限定されるものではありません。

表記法

文書表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションでは、この文書で説明する機能を設定するための情報を提供します。

注:この文書で使用されているコマンドの詳細を調べるには、Command Lookup Toolを使用してください(登録ユーザのみ)。 

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

この文書では、次のネットワーク設定を使用します。

l2tp_v3_01.jpg

注:ルータ R2 と R3 を使用しているのはプロバイダーです。  ルータ R1、R4、R5 および R6 は、エンド ユーザです。 L2TPv3 を使用することによって、ルータ R4 は R5 に直接接続されているように見えます。これは、ルータ R1 と ルータ R6 間の接続にも当てはまります。

設定

この文書では、次の設定を使用します。

  • IP クラウドを介したスタティック擬似ワイヤ。 この設定の関連部分は、2 つの単方向トンネルが設定された R2 と R3 にあります。

  • ヘアピン擬似ワイヤ、または(同じルータ内の 1 つのポートから別のポートへの)ローカルスイッチング。 この設定は R2 上だけで実行され、2 つのループバックを示している 2 つの単方向トンネルの設定により構成されています。このトンネルはどちらもルータ R2 上にあります。

R2

R2# show running-config
   Building configuration...
   service timestamps debug uptime
   service timestamps log uptime
   no service password-encryption
   !
   hostname R2
   !
   !
   clock timezone EST 10
   ip subnet-zero
   ip cef
   no ip domain-lookup
   l2tp-class R2signal
    hello 10
    password 0 cisco
    cookie size 8
   !
   pseudowire-class wireR5R4
    encapsulation l2tpv3
    protocol l2tpv3 R2signal
    ip local interface Loopback0
    ip dfbit set
   !
   pseudowire-class wireR6R1
    encapsulation l2tpv3
    protocol l2tpv3 R2signal
    ip local interface Loopback1
    ip dfbit set
   !
   pseudowire-class wireR1R6
    encapsulation l2tpv3
    protocol l2tpv3 R2signal
    ip local interface Loopback2
    ip dfbit set
   !
   interface Loopback0
   description Used by wireR5R4 for Static Connection
    ip address 2.2.2.2 255.255.255.255
    no ip directed-broadcast
   !
   interface Loopback1
   description Used by wireR6R1 for Hair Pinning Connection
    ip address 2.2.2.6 255.255.255.255
    no ip directed-broadcast
   !
   interface Loopback2
   description Used by wireR1R6 for Hair Pinning Connection
    ip address 2.2.2.1 255.255.255.255
    no ip directed-broadcast
   !
   interface Ethernet0/0
   description Connection to R1
    no ip address
    no ip directed-broadcast
    xconnect 2.2.2.6 16 encapsulation l2tpv3 pw-class wireR1R6
   !
   interface Ethernet1/0
   description Connection to Pretend Cloud.
    ip address 20.20.20.2 255.255.255.0
    no ip directed-broadcast
    no cdp enable
   !
   interface Ethernet2/0
   description Connection to R5
    no ip address
    no ip directed-broadcast
    no cdp enable
    xconnect 3.3.3.3 12 encapsulation l2tpv3 pw-class wireR5R4
   !
   interface Ethernet3/0
   description Connection to R6
    no ip address
    no ip directed-broadcast
    xconnect 2.2.2.1 16 encapsulation l2tpv3 pw-class wireR6R1
   !
   ip classless
   ip route 3.3.3.3 255.255.255.255 20.20.20.3
   
   !--- ワイヤ R5R4 ループバック(3.3.3.3)のもう一端は、
   
   
   !--- このルータから到達できる必要があります。 ヘアピン ループバックは、
   
   
   !--- 到達可能です。追加ルータは不要です。
   
   !
   !
   line con 0
    exec-timeout 0 0
    privilege level 15
   line aux 0
   line vty 0 4
    login
   !
   end

 

R3

R3# show running-config
   Building configuration...
   version 12.0
   service timestamps debug uptime
   service timestamps log uptime
   no service password-encryption
   !
   hostname R3
   !
   !
   clock timezone EST 10
   ip subnet-zero
   ip cef
   !
   l2tp-class R3signal
    hello 10
    password 0 cisco
    cookie size 8
   !
   pseudowire-class wireR4R5
    encapsulation l2tpv3
    protocol l2tpv3 R3signal
    ip local interface Loopback0
    ip dfbit set
   !
   interface Loopback0
   description Use by wireR4R5 for static connection
    ip address 3.3.3.3 255.255.255.255
    no ip directed-broadcast
   !
   interface Ethernet0/0
    ip address 20.20.20.3 255.255.255.0
    no ip directed-broadcast
   !
   interface Ethernet1/0
    no ip address
    no ip directed-broadcast
    no cdp enable
    xconnect 2.2.2.2 12 encapsulation l2tpv3 pw-class wireR4R5
   !
   ip classless
   ip route 2.2.2.2 255.255.255.255 Ethernet0/0
   
   !--- ワイヤ R4R5 ループバック(3.3.3.3)のもう一端は、
   
   
   !--- このルータから到達できる必要があります。
   
   !
   line con 0
    exec-timeout 0 0
    privilege level 15
   line aux 0
   line vty 0 4
    login
   !
   end

カスタマー R1R6 トンネル(擬似ワイヤ)エンド ルータの設定:

R1

R1# show running-config
   Building configuration...
   version 12.0
   service timestamps debug uptime
   service timestamps log uptime
   no service password-encryption
   !
   hostname R1
   !
   !
   clock timezone EST 10
   ip subnet-zero
   no ip domain-lookup
   !
   interface Ethernet0/0
    ip address 10.10.10.1 255.255.255.0
    no ip directed-broadcast
   !
   ip classless
   !
   line con 0
    exec-timeout 0 0
    privilege level 15
   line aux 0
   line vty 0 4
    login
   !
   end

 

R6

R6# show running-config
   Building configuration...
   version 12.0
   service timestamps debug uptime
   service timestamps log uptime
   no service password-encryption
   !
   hostname R6
   !
   !
   clock timezone EST 10
   ip subnet-zero
   no ip domain-lookup
   !
   interface Ethernet0/0
    ip address 10.10.10.6 255.255.255.0
    no ip directed-broadcast
   !
   ip classless
   !
   line con 0
    exec-timeout 0 0
    privilege level 15
   line aux 0
   line vty 0 4
    login
   !
   end

カスタマー R4R5 トンネル(擬似ワイヤ)エンド ルータの設定:

R4

R4# show running-config
   Building configuration...
   version 12.0
   service timestamps debug uptime
   service timestamps log uptime
   no service password-encryption
   !
   hostname R4
   !
   !
   ip subnet-zero
   !
   interface Ethernet0/0
    ip address 30.30.30.4 255.255.255.0
    no ip directed-broadcast
   !
   router ospf 1
    log-adjacency-changes
    network 30.30.30.0 0.0.0.255 area 0
   !
   ip classless
   !
   line con 0
    exec-timeout 0 0
    privilege level 15
   line aux 0
   line vty 0 4
    login
   !
   end

 

R5

R5# show running-config
   Building configuration...
   version 12.0
   service timestamps debug uptime
   service timestamps log uptime
   no service password-encryption
   !
   hostname R5
   !
   !
   ip subnet-zero
   !
   interface Ethernet0/0
    ip address 30.30.30.5 255.255.255.0
    no ip directed-broadcast
   !
   router ospf 1
    log-adjacency-changes
    network 30.30.30.0 0.0.0.255 area 0
   !
   ip classless
   !
   line con 0
    exec-timeout 0 0
    privilege level 15
   line aux 0
   line vty 0 4
    login
   !
   end

確認

このセクションで提供する情報により、設定が適切に動作していることが確認できます。

R4# show ip ospf neighbor
   Neighbor ID  Pri  State     Dead Time	 Address     Interface
   30.30.30.5    1   FULL/DR   00:00:39	 30.30.30.5  Ethernet0/0
   R5# show ip ospf neighbor
   Neighbor ID  Pri  State     Dead Time	 Address     Interface
   30.30.30.4    1   FULL/BDR  00:00:38	 30.30.30.4  Ethernet0/0
   R1# show cdp neighbors
   Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
  		   S - Switch, H - Host, I - IGMP, r - Repeater
   Device ID   Local Intrfce  Holdtme Capability Platform  Port ID
   R6	      Eth 0/0	    158        R       7206VXR	 Eth 0/0

特定の show コマンドは、アウトプットインタープリタ登録ユーザのみ)でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。


一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。
  • show l2tun tunnel all - L2TPv3 セッションの現在の状態や、現在設定されているセッションの情報(ローカルおよびリモートの L2TP ホスト名など、の表示、集約パケット数、L2TP 制御チャネルなど)を表示するには、EXEC モードで show l2tun tunnel all コマンドを使用します。

    R2# show l2tun tunnel all
        Tunnel Information Total tunnels 3 sessions 3
       Tunnel id 54217 is up, remote id is 44186, 1 active sessions
            Tunnel state is established, time since change 00:12:07
            Tunnel transport is IP (115)
            Remote tunnel name is R2
            Internet Address 2.2.2.6, port 0
            Local tunnel name is R2
            Internet Address 2.2.2.1, port 0
            Tunnel domain is
            VPDN group for tunnel is -
            L2TP class for tunnel is R2signal
            88 packets sent, 87 received
            10086 bytes sent, 11092 received
            Control Ns 76, Nr 74
            Local RWS 1024 (default), Remote RWS 1024 (max)
            Tunnel PMTU checking disabled
            Retransmission time 1, max 1 seconds
            Unsent queuesize 0, max 0
            Resend queuesize 0, max 2
            Total resends 0, ZLB ACKs sent 72
            Current nosession queue check 0 of 5
            Retransmit time distribution: 0 0 0 0 0 0 0 0 0
            Sessions disconnected due to lack of resources 0
       Tunnel id 44186 is up, remote id is 54217, 1 active sessions
            Tunnel state is established, time since change 00:12:08
            Tunnel transport is IP (115)
            Remote tunnel name is R2
            Internet Address 2.2.2.1, port 0
            Local tunnel name is R2
            Internet Address 2.2.2.6, port 0
            Tunnel domain is
            VPDN group for tunnel is -
            L2TP class for tunnel is R2signal
            87 packets sent, 88 received
            11092 bytes sent, 10086 received
            Control Ns 74, Nr 76
            Local RWS 1024 (default), Remote RWS 1024 (max)
            Tunnel PMTU checking disabled
            Retransmission time 1, max 1 seconds
            Unsent queuesize 0, max 0
            Resend queuesize 0, max 1
            Total resends 0, ZLB ACKs sent 74
            Current nosession queue check 0 of 5
            Retransmit time distribution: 0 0 0 0 0 0 0 0 0
            Sessions disconnected due to lack of resources 0
       Tunnel id 24124 is up, remote id is 48735, 1 active sessions
            Tunnel state is established, time since change 00:11:00
            Tunnel transport is IP (115)
            Remote tunnel name is R3
            Internet Address 3.3.3.3, port 0
            Local tunnel name is R2
            Internet Address 2.2.2.2, port 0
            Tunnel domain is
            VPDN group for tunnel is -
            L2TP class for tunnel is R2signal
            155 packets sent, 158 received
            15230 bytes sent, 17586 received
            Control Ns 69, Nr 67
            Local RWS 1024 (default), Remote RWS 1024 (max)
            Tunnel PMTU checking disabled
            Retransmission time 1, max 1 seconds
            Unsent queuesize 0, max 0
            Resend queuesize 0, max 2
            Total resends 1, ZLB ACKs sent 65
            Current nosession queue check 0 of 5
            Retransmit time distribution: 0 0 1 0 0 0 0 0 0
            Sessions disconnected due to lack of resources 0
       R3# show l2tun tunnel all
        Tunnel Information Total tunnels 1 sessions 1
       Tunnel id 48735 is up, remote id is 24124, 1 active sessions
            Tunnel state is established, time since change 00:12:36
            Tunnel transport is IP (115)
            Remote tunnel name is R2
            Internet Address 2.2.2.2, port 0
            Local tunnel name is R3
            Internet Address 3.3.3.3, port 0
            Tunnel domain is
            VPDN group for tunnel is -
            L2TP class for tunnel is R3signal
            180 packets sent, 176 received
            19766 bytes sent, 17316 received
            Control Ns 77, Nr 79
            Local RWS 1024 (default), Remote RWS 1024 (max)
            Tunnel PMTU checking disabled
            Retransmission time 1, max 1 seconds
            Unsent queuesize 0, max 0
            Resend queuesize 0, max 1
            Total resends 1, ZLB ACKs sent 78
            Current nosession queue check 0 of 5
            Retransmit time distribution: 0 0 1 0 0 0 0 0 0
            Sessions disconnected due to lack of resources 0
    
  • show l2tun session all - レイヤ 2 セッションの現在の状態、L2TPv3 制御チャネルのプロトコル情報の表示を実行するには、EXEC モードで show l2tun session all コマンドを使用します。

    R2# show l2tun session all
        Session Information Total tunnels 3 sessions 3
       Session id 19996 is up, tunnel id 54217
            Call serial number is 1492400000
            Remote tunnel name is R2
            Internet address is 2.2.2.6
            Session is L2TP signalled
            Session state is established, time since change 00:15:37
            112 Packets sent, 111 received
            12309 Bytes sent, 13312 received
            Receive packets dropped:
             out-of-order: 0
             total: 0
            Send packets dropped:
             exceeded session MTU: 0
             total: 0
            Session vcid is 16
            Session Layer 2 circuit, type is Ethernet, name is Ethernet0/0
            Circuit state is UP
            Remote session id is 19999, remote tunnel id 44186
            DF bit on, ToS reflect disabled, ToS value 0, TTL value 255
            Session cookie information:
            local cookie, size 8 bytes, value 6E 47 8C 4A BA BF 7E A4
            remote cookie, size 8 bytes, value 7F 9F 65 C4 C7 5B 57 FF
            FS cached header information:
            encap size = 32 bytes
            00000000 00000000 00000000 00000000
            00000000 00000000 00000000 00000000
            Sequencing is off
       Session id 19999 is up, tunnel id 44186
            Call serial number is 1492400000
            Remote tunnel name is R2
            Internet address is 2.2.2.1
            Session is L2TP signalled
            Session state is established, time since change 00:15:38
            111 Packets sent, 112 received
            13312 Bytes sent, 12309 received
            Receive packets dropped:
             out-of-order: 0
             total: 0
            Send packets dropped:
             exceeded session MTU: 0
             total: 0
            Session vcid is 16
            Session Layer 2 circuit, type is Ethernet, name is Ethernet3/0
            Circuit state is UP
            Remote session id is 19996, remote tunnel id 54217
            DF bit on, ToS reflect disabled, ToS value 0, TTL value 255
            Session cookie information:
            local cookie, size 8 bytes, value 7F 9F 65 C4 C7 5B 57 FF
            remote cookie, size 8 bytes, value 6E 47 8C 4A BA BF 7E A4
            FS cached header information:
            encap size = 32 bytes
            00000000 00000000 00000000 00000000
            00000000 00000000 00000000 00000000
            Sequencing is off
       Session id 20005 is up, tunnel id 24124
            Call serial number is 1492400002
            Remote tunnel name is R3
            Internet address is 3.3.3.3
            Session is L2TP signalled
            Session state is established, time since change 00:14:29
            200 Packets sent, 204 received
            19650 Bytes sent, 22100 received
            Receive packets dropped:
             out-of-order: 0
             total: 0
            Send packets dropped:
             exceeded session MTU: 0
             total: 0
            Session vcid is 12
            Session Layer 2 circuit, type is Ethernet, name is Ethernet2/0
            Circuit state is UP
            Remote session id is 17834, remote tunnel id 48735
            DF bit on, ToS reflect disabled, ToS value 0, TTL value 255
            Session cookie information:
            local cookie, size 8 bytes, value 22 09 F1 E9 BC 8C 00 94
            remote cookie, size 8 bytes, value 39 DD CB 00 9C 4B 1C 8C
            FS cached header information:
            encap size = 32 bytes
            00000000 00000000 00000000 00000000
            00000000 00000000 00000000 00000000
            Sequencing is off
       R3# show l2tun session all
        Session Information Total tunnels 1 sessions 1
       Session id 17834 is up, tunnel id 48735
            Call serial number is 1492400002
            Remote tunnel name is R2
            Internet address is 2.2.2.2
            Session is L2TP signalled
            Session state is established, time since change 00:23:53
            327 Packets sent, 322 received
            33758 Bytes sent, 31248 received
            Receive packets dropped:
             out-of-order: 0
             total: 0
            Send packets dropped:
             exceeded session MTU: 0
             total: 0
            Session vcid is 12
            Session Layer 2 circuit, type is Ethernet, name is Ethernet1/0
            Circuit state is UP
            Remote session id is 20005, remote tunnel id 24124
            DF bit on, ToS reflect disabled, ToS value 0, TTL value 255
            Session cookie information:
            local cookie, size 8 bytes, value 39 DD CB 00 9C 4B 1C 8C
            remote cookie, size 8 bytes, value 22 09 F1 E9 BC 8C 00 94
            FS cached header information:
            encap size = 32 bytes
            00000000 00000000 00000000 00000000
            00000000 00000000 00000000 00000000
            Sequencing is off
    

トラブルシューティング

このセクションでは、設定のトラブルシューティングに役立つ情報を説明します。

これらの L2TPv3 機能関連の不具合の詳細については、Bug Toolkit登録ユーザのみ)をご使用ください。

  • CSCdz01467登録ユーザのみ) - 解決済み(R)L2TPv3: トンネル パケット カウンタによる不正確なカウントの表示

  • CSCeb56061登録ユーザのみ) - 解決済み(R)L2TPv3: L2TPv3oETH によるゾンビ トンネルの生成

  • CSCeb35497登録ユーザのみ)- 解決済み(R)L2TPv3 シーケンス: Tx Seqnum が 16777215 の後、1 にラップしない

  • CSCdz48481登録ユーザのみ) - 解決済み(R)L2TPv3: ヘアピン設定がサポートされない

  • CSCec00463登録ユーザのみ) - 解決済み(R)L2TPv3: Gig イーサネット ポート モード の decap 障害

  • CSCec44356登録ユーザのみ)- 解決済み(R)C10720: L2TPv3 ヘアピンでの 802.1P 不適合


一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 45660