IBM テクノロジー : IBM ネットワーキング

DLSw イーサネット冗長設定の例

2003 年 12 月 24 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 9 月 9 日) | フィードバック

目次

概要
前提条件
     要件
     使用するコンポーネント
     表記法
設定
     ネットワーク ダイアグラム
     設定ガイド
     設定
確認
トラブルシューティング
     トラブルシューティングのためのコマンド
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この設定例では、Cisco IOS(R) ソフトウェア イーサネット冗長機能を、Data-Link Switching(DLSw; データリンク スイッチング)ネットワークに実装します。 この文書には、本機能のデバッグ テクニックも記述されています。 イーサネット冗長機能は、Cisco IOS ソフトウェア リリース 12.0(5)T で追加されました。

この設定例では、イーサネット冗長機能の実装方法と、接続状態の監視に使用するコマンドについて説明します。 各ルータの動作を表示するため、デバッグ コマンド実行中に障害が発生した 3 種類のシナリオがシミュレートされています。

前提条件

要件

この文書に関する特別な要件はありません。

使用するコンポーネント

この文書は、特定のソフトウェアまたはハードウェアに限定されるものではありません。

表記法

文書表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

このセクションでは、この文書で説明する機能を設定するための情報を提供します。

注:この文書で使用されているコマンドの詳細を調べるには、Command Lookup Tool を使用してください(登録ユーザのみ)。 


一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。


ネットワーク ダイアグラム

この文書では次の図に示すネットワーク設定を使用しています。

8-a.gif

設定ガイド

  • コントローラ A は、2 つの Logical Link Control(LLC; 論理リンク制御副層)セッションをホストと確立するように設定されています。このコントローラは、それぞれに 0x04 と 0x08 という Local Service Access Point(LSAP; ローカル サービス アクセス ポイント)を使用します。 コントローラ B は、0x04 という LSAP を使用して、ホストと LLC セッション 1 つだけの確立を試みます。

  • この設定例の場合、両方の DLSw ルータがアップしていると、コントローラ A はルータ Avimimus を使用してホストに接続され、コントローラ B はルータ Turbo を使用してホストに接続されます。 ロード バランシングは、両方のルータがアップして稼動中の場合に実行されます。

  • コントローラの MAC アドレスと設定を次に示します。

    • コントローラ A

      smac = 0000.2222.0000 (cann), dmac = 0000.6666.0000 (cann)
         lsap = 0x04 and lsap = 0x08, dsap = 0x04 for both connections

      参照し易くするため、上記 MAC アドレスのビット交換値を次に示します。

      smac = 0000.4444.0000 (non-cann), dmac = 0000.6666.0000 (non-cann)
    • コントローラ B

      smac = 0000.1111.0000 (cann), dmac = 0000.7777.0000 (cann)
         lsap = 0x08, dsap = 0x04

      参照し易くするため、上記 MAC アドレスのビット交換値を次に示します。

      smac = 0000.8888.0000 (non-cann), dmac = 0000.EEEE.0000 (non-can)
  • ホストの MAC アドレスは次のようになっています。

    smac = 4000.3745.0000 (non-can)
       lsap = 0x04

    参照し易くするため、上記 MAC アドレスのビット交換値を次に示します。

    smac = 0200.eca2.0000 (cann)
       
  • Avimimus は、マスター DLSw ルータとして設定され、Turbo はスレーブ DLSw ルータとして設定されています。 この設定は、Avimimus に低い優先順位の値を割り当てることによって実現されます。 デフォルトの優先順位は 100 です。各ルータに優先順位を指定するコマンドを次に示します。

    • Avimimus - dlsw transparent redundancy-enable 9999.9999.9999 master-priority 10

    • Turbo - dlsw transparent redundancy-enable 9999.9999.9999

    通信を行うためには、両方のルータで同じマルチキャスト MAC アドレス(9999.9999.9999)を使用するように設定する必要があります。

  • Avimimus では次のように MAC アドレスが設定されています。

    Ethernet 0:
       smac = 0000.3333.0000 (cann), 0000.CCCC.0000 (non-cann)
  • Turbo では次のように MAC アドレスが設定されています。

    Ethernet 0:
       smac = 0000.5555.0000 (cann), 0000.AAAA.0000 (non-cann)
  • Avimimus では、次のように MAC アドレス マッピングを実行するように設定されています。

    local mac: 0000.6666.0000 --> remote mac: 0200.ECA2.0000 (cann)

    参照し易くするため、上記 MAC アドレスのビット交換値を次に示します。

    local mac: 0000.6666.0000 --> remote mac: 4000.3745.0000 (non-can)
  • Turbo では、次のように MAC アドレス マッピングを実行するように設定されています。

    local mac: 0000.7777.0000 --> remote mac: 0200.ECA2.0000 (cann)

    参照し易くするため、上記 MAC アドレスのビット交換値を次に示します。

    local mac: 0000.EEEE.0000 --> remote mac: 4000.3745.0000 (non-can)
  • 各 DLSw ルータで MAC アドレス マッピングを指定するコマンドを次に示します。

    • Avimimus - dlsw transparent map local-mac 0000.6666.0000 remote-mac 0200.eca2.0000 neighbor 0000.5555.0000

    • Turbo - dlsw transparent map local-mac 0000.7777.0000 remote-mac 0200.eca2.0000 neighbor 0000.3333.0000

    上記コマンドで設定されたすべての MAC アドレスは、正式な形式で表すことが必要です。 「local-mac」値は、イーサネットのエンド ステーションがポイントする Destination MAC(DMAC; 宛先 MAC)を表しています(この場合は 0000.6666.0000 と 0000.7777.0000)。 「remote-mac」値は、DLSw を介して到達しようとしているリモート ホストの正規の表記を表しています。 「neighbor」値は、他の DLSw 冗長ルータのイーサネット インターフェイスの MAC アドレスを表しています。

設定

この文書では、下記の設定を使用します。

マスター DLSw 冗長ルータ

avimimus# show run
   Building configuration...
   !
   hostname avimimus
   !
   dlsw local-peer peer-id 1.1.1.1
   dlsw remote-peer 0 tcp 3.3.3.1
   dlsw transparent switch-support
   !
   !
   interface Ethernet0
    mac-address 0000.3333.0000
    ip address 5.5.5.3 255.255.255.0
    no ip redirects
    no ip directed-broadcast
    media-type 10BaseT
    standby timers 3 10
    standby priority 150 preempt
    standby mac-address 0000.3333.3333
    standby ip 5.5.5.4
    dlsw transparent redundancy-enable 9999.9999.9999 master-priority 10
   
   !--- Avimimus の優先順位の値を指定するコマンドです。
   
    dlsw transparent map local-mac 0000.6666.0000 remote-mac 0200.eca2.0000 neighbor 0000.5555.0000
   
   !--- DLSw ルータの MAC アドレス マッピングを指定するコマンドです。
   
   !
   interface Serial0
    ip address 1.1.1.1 255.255.255.0
    no ip directed-broadcast
    no ip mroute-cache
    no fair-queue
    clockrate 4000000
   !
   end

 

スレーブ DLSw 冗長ルータ

turbo# show run
   Building configuration...
   !
   hostname turbo
   !
   dlsw local-peer peer-id 2.2.2.1
   dlsw remote-peer 0 tcp 3.3.3.1
   dlsw transparent switch-support
   !
   interface Ethernet0
    mac-address 0000.5555.0000
    ip address 5.5.5.1 255.255.255.0
    no ip redirects
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    standby timers 3 10
    standby priority 100
    standby mac-address 0000.3333.3333
    standby ip 5.5.5.4
   dlsw transparent redundancy-enable 9999.9999.9999
   
   !--- Turbo の優先順位の値を指定するコマンドです。
   
   dlsw transparent map local-mac 0000.7777.0000 remote-mac 0200.eca2.0000 neighbor 0000.3333.0000
   
   !--- DLSw ルータの MAC アドレス マッピングを指定するコマンドです。
   
   !
   interface Serial1
    ip address 2.2.2.1 255.255.255.0
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
   !
   end

 

トークン リング DLSw ルータ

limno# show run
   !
   hostname limno
   !
   source-bridge ring-group 100
   !
   dlsw local-peer peer-id 3.3.3.1
   dlsw remote-peer 0 tcp 2.2.2.1
   dlsw remote-peer 0 tcp 1.1.1.1
   !
   interface TokenRing0
    ring-speed 16
    source-bridge 10 1 100
    source-bridge spanning
   !
   interface Serial0
    ip address 1.1.1.2 255.255.255.0
    no ip directed-broadcast
    no ip mroute-cache
    no fair-queue
   !
   interface Serial1
    ip address 2.2.2.2 255.255.255.0
    no ip directed-broadcast
    no ip route-cache
    no ip mroute-cache
    clockrate 4000000
   !
   end

確認

このセクションで提供する情報により、設定が適切に動作していることが確認できます。 この設定でのすべての show コマンド出力を表示します。 重要な部分がわかるように、コマンド出力にコメントを追加しています。

特定の show コマンドは、アウトプットインタープリタ登録ユーザのみ)でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。


一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

このセクションは次のサブセクションに分けられます。

show dlsw circuits コマンドと show llc コマンドの出力

このセクションでは、show dlsw circuits コマンドと show llc コマンドの出力を表示します。

マスター DLSw 冗長ルータ

avimimus# show dlsw circuits
   Index	   local addr(lsap)   remote addr(dsap)  state	   uptime
   738197594 0000.4444.0000(04) 4000.3745.0000(04) CONNECTED 3d02h
   335544411 0000.4444.0000(08) 4000.3745.0000(04) CONNECTED 3d02h
   Total number of circuits connected: 2 

DLSw 回線は、エンドステーション MAC(0000.4444.0000)とホスト MAC 間で確立されます。 エンド ステーションが実際に 4000.3745.0000 をポイントしているわけではありませんが、ルータは dlsw transparent map コマンドで指定された MAC アドレス マッピングを実行しています。

マスター DLSw 冗長ルータ

avimimus# show llc brief
   LLC2 Connections: total of 3 connections
   Et0 NORMAL 0000.aaaa.0000 0000.cccc.0000 94 94
   Et0 NORMAL 0000.4444.0000 0000.6666.0000 04 04
   Et0 NORMAL 0000.4444.0000 0000.6666.0000 04 08

0x94 という SAP 値を使用して、DLSw イーサネット冗長ルータ間で、最初の LLC セッションが確立されます。 DLSw ルータの MAC アドレスは、正式ではない形式で表示されています。 詳細については、この文書の「show dlsw transparent コマンドの出力」のセクションを参照してください。

他の 2 つの LLC セッションは、ルータで設定された MAC アドレスを使用して通信しているエンド デバイスを参照します。 つまり、エンド ステーションで設定された DMAC アドレスは 0000.6666.0000 です。 すべての LLC セッションは、イーサネット 0 インターフェイス(Et0)から発信されていると表示されます。ところが、その後表示される MAC アドレスは正式ではない形式で表示されます。 このように表示されるのは、show dlsw コマンドでの参照を簡単にするためです。このコマンドは、すべての MAC アドレスを正式ではない形式で表示します。

マスター DLSw 冗長ルータ

avimimus# show llc
   LLC2 Connections: total of 3 connections
   Ethernet0 DTE: 0000.aaaa.0000 0000.cccc.0000 94 94 state NORMAL
   V(S)=5, V(R)=7, Last N(R)=5, Local window=7, Remote Window=127
   akmax=3, n2=8,
   xid-retry timer 0/0 ack timer 0/1000
   p timer 0/1000 idle timer 9480/10000
   rej timer 0/3200 busy timer 0/9600
   akdelay timer 0/100 txQ count 0/200
   Ethernet0 DTE: 0000.4444.0000 0000.6666.0000 04 04 state NORMAL
   V(S)=1, V(R)=1, Last N(R)=1, Local window=7, Remote Window=127
   akmax=3, n2=8,
   xid-retry timer 0/0 ack timer 0/1000
   p timer 0/1000 idle timer 8920/10000
   rej timer 0/3200 busy timer 0/9600
   akdelay timer 0/100 txQ count 0/200
   Ethernet0 DTE: 0000.4444.0000 0000.6666.0000 04 08 state NORMAL
   V(S)=1, V(R)=1, Last N(R)=1, Local window=7, Remote Window=127
   akmax=3, n2=8,
   xid-retry timer 0/0 ack timer 0/1000
   p timer 0/1000 idle timer 9100/10000
   rej timer 0/3200 busy timer 0/9600
   akdelay timer 0/100 txQ count 0/200

スレーブ DLSw 冗長ルータ

turbo# show dlsw circuits
   Index	    local addr(lsap)   remote addr(dsap)  state     uptime
   2634022913 0000.8888.0000(08) 4000.3745.0000(04) CONNECTED 4d00h
   Total number of circuits connected: 1
   turbo# show llc brief
   LLC2 Connections: total of 2 connections
   Et0 NORMAL 0000.cccc.0000 0000.aaaa.0000 94 94
   Et0 NORMAL 0000.8888.0000 0000.eeee.0000 04 08
   turbo# show llc
   LLC2 Connections: total of 2 connections
   Ethernet0 DTE: 0000.cccc.0000 0000.aaaa.0000 94 94 state NORMAL
   V(S)=7, V(R)=5, Last N(R)=7, Local window=7, Remote Window=127
   akmax=3, n2=8,
   xid-retry timer 0/0 ack timer 0/1000
   p timer 0/1000 idle timer 7480/10000
   rej timer 0/3200 busy timer 0/9600
   akdelay timer 0/100 txQ count 0/200
   Ethernet0 DTE: 0000.8888.0000 0000.eeee.0000 04 08 state NORMAL
   V(S)=1, V(R)=1, Last N(R)=1, Local window=7, Remote Window=127
   akmax=3, n2=8,
   xid-retry timer 0/0 ack timer 0/1000
   p timer 0/1000 idle timer 2410/10000
   rej timer 0/3200 busy timer 0/9600
   akdelay timer 0/100 txQ count 0/200

show dlsw transparent コマンドの出力

このセクションでは、show dlsw transparent コマンドの出力を表示します。

マスター DLSw 冗長ルータ

avimimus# show dlsw transparent neighbor
   Interface Ethernet0
   0000.cccc.0000 SELF Master
   0000.aaaa.0000 Rcvd Master-Accepted VALID

上記の show dlsw transparent neighbor コマンドは、透過ブリッジ ドメイン内の DLSw 隣接ルータを表示します。 リスト表示されるすべての MAC アドレスは、正式ではない形式で表示されます。 ただし、(dlsw transparent map コマンドを使用して)、隣接ルータを設定する場合は、正式な形式を使用してください。 ルータ Avimimus には一番低い優先順番が割り当てられているため、マスター ルータとなります。

マスター DLSw 冗長ルータ

avimimus# show dlsw transparent cache
   Interface Ethernet0
   Circuit Cache
   local addr(lsap)   remote addr(dsap)  state	Owner
   0000.4444.0000(04) 4000.3745.0000(04) POSITIVE SELF
   0000.4444.0000(08) 4000.3745.0000(04) POSITIVE SELF
   0000.8888.0000(08) 4000.3745.0000(04) NEGATIVE 0000.aaaa.0000
   Total number of circuits in the Cache: 3

上記の show dlsw transparent cache コマンドは、ブロードキャスト ドメインのマスター回線キャッシュを表示します。 このルータは、2 番目のルータ上で確立されている接続を認識します。これは、NEGATIVE 状態とマークを付けられたエントリに対応しています。

マスター DLSw 冗長ルータ

avimimus# show dlsw transparent map
   Interface Ethernet0
   LOCAL Mac	REMOTE MAC     BACKUP
   ---------	----------     ------
   0000.6666.0000 4000.3745.0000 0000.aaaa.0000 STATIC
   0000.eeee.0000 4000.3745.0000 0000.aaaa.0000 DYNAMIC(Passive)

上記出力では、ルータは、その設定(STATIC というマークが付けられたエントリを参照)で指定された変換と、2 番目のルータで設定されたエントリ(DYNAMIC というマークが付けられたエントリ)の両方を認識します。 LOCAL MAC アドレスとは、DMAC としてエンド ステーションが使用する必要がある MAC アドレスです。

次にルータは、REMOTE MAC 列の下に表示される MAC アドレスへの変換を実行します。 REMOTE MAC は、DLSw が接続を提供しているリモートの送信先の実際の MAC アドレスと一致している必要があります。

2 番目のエントリは Passive 状態です。これは、2 番目のルータが稼働状態で、自分の変換を処理していることを意味します。 障害が発生した場合、Avimimus はその処理を引き継ぎます。

スレーブ DLSw 冗長ルータ

turbo# show dlsw transparent neighbor
   Interface Ethernet0
   0000.aaaa.0000 SELF	  Slave
   0000.cccc.0000 Connected MASTER.
   turbo# show dlsw transparent cache
   Interface Ethernet0
   Circuit Cache
   local addr(lsap)   remote addr(dsap)	  state    Owner
   0000.8888.0000(08) 4000.3745.0000(04)	  POSITIVE SELF
   Total number of circuits in the Cache: 1
   turbo# show dlsw transparent map
   Interface Ethernet0
   LOCAL Mac	REMOTE Mac     BACKUP
   ---------	----------     ------
   0000.eeee.0000 4000.3745.0000 0000.cccc.0000 STATIC
   0000.6666.0000 4000.3745.0000 0000.cccc.0000 DYNAMIC(Passive)

トラブルシューティング

このセクションでは、設定のトラブルシューティングに役立つ情報を説明します。

トラブルシューティングのためのコマンド

このセクションでは、この構成ですべての debug コマンド出力を示します。 重要な部分がわかるように、コマンド出力にコメントを追加しています。

注:debug コマンドを使用する前に、「デバッグ コマンドの重要な情報」を参照してください。

このセクションは次のサブセクションに分けられます。

マスター ルータの障害シミュレーション中の debug dlsw transparent コマンドの出力

このセクションでは、マスター ルータの障害シミュレーション中に生成される、debug dlsw transparent コマンドの出力を示します。

  • debug dlsw transparent master - マスター - スレーブ イベントに関連するデバッグ メッセージを表示します。

  • debug dlsw transparent circuits - 透過ブリッジ ドメインのマスター回線キャッシュに関連するデバッグ メッセージを表示します。

  • debug dlsw transparent address-map - ローカル ルータ上の MAC アドレスマッピングと、ローカル ルータが隣接ピアに対するバックアップとして動作するためのマッピングに関連するデバッグ メッセージを表示します。

マスター DLSw 冗長ルータ

avimimus# show debug
   DLSw:
   DLSw Ethernet Redundancy - Master debugging is on
   DLSw Ethernet Redundancy - Circuits debugging is on
   DLSw Ethernet Redundancy - Address Map debugging is on
   Mar 5 18:07:10.039: DLSW-ER: Sending MP Frame
   Mar 5 18:07:30.039: DLSW-ER: Sending MP Frame
   Mar 5 18:07:40.039: DLSW-ER: Sending MP Frame
   Mar 5 18:07:50.039: DLSW-ER: Sending MP Frame
   Mar 5 18:08:00.047: DLSW-ER: Sending MP Frame
   Mar 5 18:08:10.051: DLSW-ER: Sending MP Frame
   Mar 5 18:08:20.051: DLSW-ER: Sending MP Frame
   Mar 5 18:08:30.051: DLSW-ER: Sending MP Frame
   Mar 5 18:08:40.051: DLSW-ER: Sending MP Frame
   Mar 5 18:08:50.051: DLSW-ER: Sending MP Frame

上記ルータは、10 秒ごとに Master Present(MP)フレームを送信します。

イーサネット インターフェイスをシャットダウンすることによって、障害が発生することを次に示します。

マスター DLSw 冗長ルータ

avimimus# configure terminal
   Enter configuration commands, one per line. End with CNTL/Z.
   avimimus(config)# interface ethernet0
   avimimus(config-if)# shut
   Mar 5 18:09:00.951: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Active -> Init
   Mar 5 18:09:02.951: %LINK-5-CHANGED: Interface Ethernet0, changed state to administratively down
   Mar 5 18:09:02.951: DLSW-ER:dm_action_b: LLC2 session dead freeing neighbor 0000.aaaa.0000
   Mar 5 18:09:02.951: DLSW-ER:Sourcing a TestFrame 0000.6666.0000 --> 0000.aaaa.0000 on Ethernet0
   Mar 5 18:09:02.951: DLSW-ER:Sourcing a TestFrame 0000.eeee.0000 --> 0000.aaaa.0000 on Ethernet0
   Mar 5 18:09:02.971: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.4444.0000:4
   Mar 5 18:09:02.979: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.4444.0000:8
   Mar 5 18:09:03.951: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed
    state to down

この障害発生中、スレーブ ルータから出力されたデバッグを次に示します。

スレーブ DLSw 冗長ルータ

turbo#
   Mar 5 18:09:10.251: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Standby -> Active
   Mar 5 18:09:10.583: DLSW-ER:dm_action_r: LLC2 session dead to neighbor 0000.cccc.0000
   Mar 5 18:09:10.587: DLSW-ER:Sourcing a TestFrame 0000.eeee.0000 --> 0000.cccc.0000 on Ethernet0
   Mar 5 18:09:10.591: DLSW-ER:Sourcing a TestFrame 0000.6666.0000 --> 0000.cccc.0000 on Ethernet0
   Mar 5 18:09:10.595: DLSW-ER: Sending MP Frame
   Mar 5 18:09:10.595: DLSW-ER:dm_action_u: Freeing current master 0000.cccc.0000
   Mar 5 18:09:10.599: DLSW-ER:dm_action_u: Changing state to Master
   Mar 5 18:09:20.595: DLSW-ER: Sending MP Frame
   Mar 5 18:09:30.595: DLSW-ER: Sending MP Frame

上記構文では、Turbo はマスター ルータとなり、Avimimus ルータで設定された変換も引き継ぎます。

Avimimus を経由して接続されているエンド ステーションが、ホストとの接続を再試行した場合の Turbo 上でのデバッグを次に示します。

スレーブ DLSw 冗長ルータ

turbo#
   Mar 5 18:09:40.595: DLSW-ER: Sending MP Frame
   Mar 5 18:09:40.927: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame
    from Ethernet0
   Mar 5 18:09:40.939: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame
    from Ethernet0
   Mar 5 18:09:40.995: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame
    from Ethernet0
   Mar 5 18:09:40.995: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.4444.0000:4
   Mar 5 18:09:40.999: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.4444.0000:4

上記構文では、コントローラ A から最初の LLC セッションをセットアップするために必要な変換を、Turbo が終了したことがわかります。この変換は以前は Avimimus が所有していました。 このセッションでは、LSAP 0x04 と RSAP 0x04 が使用されています。

スレーブ DLSw 冗長ルータ

Mar 5 18:09:41.963: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame
    from Ethernet0
   Mar 5 18:09:41.975: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame
    from Ethernet0
   Mar 5 18:09:41.979: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.4444.0000:8
   Mar 5 18:09:41.983: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.4444.0000:8

上記構文では、コントローラ A から 2 番目の LLC セッションをセットアップするために必要な変換を、Turbo が終了したことがわかります。この変換は以前は Avimimus が所有していました。 このセッションでは、LSAP 0x08 と RSAP 0x04 が使用されています。

スレーブ DLSw 冗長ルータ

Mar 5 18:09:41.991: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame
    from Ethernet0
   Mar 5 18:09:41.995: DLSW-ER:CSM->MS: C_INQ:PENDING: 4000.3745.0000:4 0000.4444.0000:4
   Mar 5 18:09:41.999: DLSW-ER:MS->CSM:UGotIt 4000.3745.0000:4 0000.4444.0000:4

上の例では、最初の DLSw 回線が確立されました。このことは、UGotIt フェーズによって示されます。

スレーブ DLSw 冗長ルータ

Mar 5 18:09:42.003: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 --->
    0000.6666.0000
   Mar 5 18:09:42.971: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame
    from Ethernet0
   Mar 5 18:09:42.975: DLSW-ER:CSM->MS: C_INQ:PENDING: 4000.3745.0000:4 0000.4444.0000:8
   Mar 5 18:09:42.983: DLSW-ER:MS->CSM:UGotIt 4000.3745.0000:4 0000.4444.0000:8

上の例では、2 番目の DLSw 回線が手続き完了しています。

スレーブ DLSw 冗長ルータ

Mar 5 18:09:42.987: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 --->
    0000.6666.0000
   Mar 5 18:09:50.595: DLSW-ER: Sending MP Frame

Turbo が Avimimus の処理を引き継いだこと、および全回線が Turbo を経由して接続されていることを表している、すべての DLSw コマンドを次に示します。

スレーブ DLSw 冗長ルータ

turbo# show dlsw transparent cache
   Interface Ethernet0
   Circuit Cache
   local addr(lsap)   remote addr(dsap)  state	Owner
   0000.4444.0000(04) 4000.3745.0000(04) POSITIVE SELF
   0000.4444.0000(08) 4000.3745.0000(04) POSITIVE SELF
   0000.8888.0000(08) 4000.3745.0000(04) POSITIVE SELF
   Total number of circuits in the Cache: 3
   turbo# show dlsw transparent map
   Interface Ethernet0
   LOCAL Mac	REMOTE Mac     BACKUP
   ---------	----------     ------
   0000.eeee.0000 4000.3745.0000 0000.cccc.0000 STATIC
   0000.6666.0000 4000.3745.0000 0000.cccc.0000 DYNAMIC(Active)

上記構文で、2 番目の変換状態が DYNAMIC(Active) になったことがわかります。この状態は、Avimimus がダウンしている可能性が高いことを示しています。

スレーブ DLSw 冗長ルータ

turbo# show dlsw circuits
   Index	     local addr(lsap)	 remote addr(dsap)   state     uptime
   4009754676  0000.4444.0000(04) 4000.3745.0000(04) CONNECTED  00:01:05
   1610612789  0000.4444.0000(08) 4000.3745.0000(04) CONNECTED  00:01:04
   2634022913  0000.8888.0000(08) 4000.3745.0000(04) CONNECTED  4d01h
   Total number of circuits connected: 3

マスター ルータ復旧中の debug dlsw transparent コマンドの出力

このセクションでは、マスター ルータの復元中に生成される、debug dlsw transparent コマンドの出力を示します。

マスター DLSw 冗長ルータ

avimimus# configure terminal
   Enter configuration commands, one per line. End with CNTL/Z.
   avimimus(config)# interface ethernet0
   avimimus(config-if)# no shut
   Mar 5 18:12:00.087: DLSW-ER: Sending MP Frame
   Mar 5 18:12:03.127: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
   Mar 5 18:12:03.595: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Listen -> Active
   Mar 5 18:12:04.127: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed
    state to up
   Mar 5 18:12:10.087: DLSW-ER: Sending MP Frame
   Mar 5 18:12:10.599: DLSW-ER: New neighbor: master 0000.cccc.0000, neighbor 0000.aaaa.0000
   Mar 5 18:12:10.599: DLSW-ER:dm_action_a: Rcvd MP with worse priority from 0000.aaaa.0000
   Mar 5 18:12:10.607: DLSW-ER:dm_action_l: LLC2 up for neighbor 0000.aaaa.0000
   Mar 5 18:12:10.607: DLSW-ER: Sending MC to 0000.aaaa.0000
   Mar 5 18:12:10.615: DLSW-ER:dm_action_d: Received MA from neighbor 0000.aaaa.0000 

上記構文では、Avimimus は Turbo から Master Accept(MA)メッセージを受信しました。このメッセージは、Avimimus が新しいマスターになったことを確認します。

次の例では、2 台のルータは設定されているマッピングのために BACKMEUP_REQ を交換します。 各要求の後に ACK が続く必要があります。

スレーブ DLSw 冗長ルータ

Mar 5 18:12:10.615: DLSW-ER: Sending BACKMEUP_REQ 0000.6666.0000 --> 4000.3745.0000 to
    neighbor 0000.aaaa.0000 (617321C8)
   Mar 5 18:12:10.615: DLSW-ER: Sending DN to 0000.aaaa.0000
   Mar 5 18:12:10.623: DLSW-ER:Rcvd BACKMEUP_REQ from 0000.aaaa.0000 for map entry 0000.eeee.0000
    --> 4000.3745.0000
   Mar 5 18:12:10.623: DLSW-ER: Sending BACKMEUP_ACK 0000.eeee.0000 --> 4000.3745.0000 to
    neighbor 0000.aaaa.0000 (617321C8)
   Mar 5 18:12:10.651: DLSW-ER:dm_action_f: Rcvd CO from 0000.aaaa.0000
   Mar 5 18:12:10.667: DLSW-ER:Rcvd BACKMEUP_REQ from 0000.aaaa.0000 for mapentry 0000.eeee.0000
    --> 4000.3745.0000
   Mar 5 18:12:10.667: DLSW-ER: Sending BACKMEUP_ACK 0000.eeee.0000 --> 4000.3745.0000 to
    neighbor 0000.aaaa.0000 (617321C8)
   Mar 5 18:12:19.731: DLSW-ER:dm_action_h: Rcvd CG <-
    0000.aaaa.0000 4000.3745.0000:4 0000.4444.0000:4
   Mar 5 18:12:19.735: DLSW-ER:dm_action_h: Rcvd CG <-
    0000.aaaa.0000 4000.3745.0000:4 0000.4444.0000:8
   Mar 5 18:12:20.087: DLSW-ER: Sending MP Frame
   Mar 5 18:12:20.647: DLSW-ER:Rcvd BACKMEUP_ACK from 0000.aaaa.0000 for mapentry 0000.6666.0000
    --> 4000.3745.0000
   Mar 5 18:12:20.647: DLSW-ER:Sourcing a TestFrame 0000.6666.0000 --> 0000.aaaa.0000 on Ethernet0
   Mar 5 18:12:30.087: DLSW-ER: Sending MP Frame

マスター ルータ Avimimus が起動中、Turbo から出力されるデバッグ情報を次に示します。

スレーブ DLSw 冗長ルータ

turbo#
   Mar 5 18:12:00.595: DLSW-ER: Sending MP Frame
   Mar 5 18:12:03.603: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Active -> Speak
   Mar 5 18:12:10.087: DLSW-ER: New neighbor: master 0000.aaaa.0000, neighbor 0000.cccc.0000
   Mar 5 18:12:10.091: DLSW-ER:dm_action_o: Rcvd MP with better priority: 0000.cccc.0000
   Mar 5 18:12:10.595: DLSW-ER: Sending MP Frame
   Mar 5 18:12:10.611: DLSW-ER:dm_action_l: LLC2 up for neighbor 0000.cccc.0000
   Mar 5 18:12:10.611: DLSW-ER: Sending MA to 0000.cccc.0000

上の例では、Turbo は Avimimus からのメッセージに確認応答した後、スレーブになります。

スレーブ DLSw 冗長ルータ

Mar 5 18:12:10.615: DLSW-ER: Sending BACKMEUP_REQ 0000.eeee.0000 --> 4000.3745.0000
    to neighbor 0000.cccc.0000 (45B47C)
   Mar 5 18:12:10.623: DLSW-ER:dm_action_c: Rcvd MC with better priority from 0000.cccc.0000
   Mar 5 18:12:10.627: DLSW-ER:dm_action_c: Changing state: Master to Slave

上の例では、ターボはスレーブ ルータになります。

スレーブ DLSw 冗長ルータ

Mar 5 18:12:10.627: DLSW-ER:Rcvd BACKMEUP_REQ from 0000.cccc.0000 for mapentry 0000.6666.0000
    --> 4000.3745.0000
   Mar 5 18:12:10.635: DLSW-ER:calling admin_stop for ckt(0000.4444.0000(4) 4000.3745.0000(4)) with
    lmac 0000.6666.0000
   Mar 5 18:12:10.643: DLSW-ER:calling admin_stop for ckt(0000.4444.0000(8) 4000.3745.0000(4)) with
    lmac 0000.6666.0000

上記構文では、Turbo は Avimimus が所有しているはずの DLSw 回線を終了します (マスターが復帰した場合、この回線を解除する必要があります)。 Turbo が Avimimus から BACKMEUP_REQ 受信した後、回線の終了が発生します。

スレーブ DLSw 冗長ルータ

Mar 5 18:12:10.643: DLSW-ER: dm_action_n: Rcvd DN frame from 0000.cccc.0000
   Mar 5 18:12:10.647: DLSW-ER:Sending CO frame # 0 to 0000.cccc.0000
   Mar 5 18:12:10.651: DLSW-ER:Rcvd BACKMEUP_ACK from 0000.cccc.0000 for mapentry 0000.eeee.0000
    --> 4000.3745.0000
   Mar 5 18:12:10.655: DLSW-ER:Sourcing a TestFrame 0000.eeee.0000 --> 0000.cccc.0000 on Ethernet0
   Mar 5 18:12:10.659: DLSW-ER:dm_action_s: LLC2 session up to neighbor 0000.cccc.0000
   Mar 5 18:12:10.659: DLSW-ER: Sending BACKMEUP_REQ 0000.eeee.0000 --> 4000.3745.0000
    to neighbor 0000.cccc.0000 (45B47C)
   Mar 5 18:12:10.671: DLSW-ER:Rcvd BACKMEUP_ACK from 0000.cccc.0000 for mapentry 0000.eeee.0000
    --> 4000.3745.0000
   Mar 5 18:12:10.675: DLSW-ER:Sourcing a TestFrame 0000.eeee.0000 --> 0000.cccc.0000 on Ethernet0
   Mar 5 18:12:13.603: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Speak -> Standby
   Mar 5 18:12:19.723: DLSW-ER:CG -> 0000.cccc.0000: 4000.3745.0000:4 0000.4444.0000:4
   Mar 5 18:12:19.727: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.4444.0000:4
   Mar 5 18:12:19.731: DLSW-ER:CG -> 0000.cccc.0000: 4000.3745.0000:4 0000.4444.0000:8
   Mar 5 18:12:19.735: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.4444.0000:8
   Mar 5 18:12:20.643: DLSW-ER: Sending BACKMEUP_ACK 0000.6666.0000 --> 4000.3745.0000
    to neighbor 0000.cccc.0000 (45B47C)
   turbo# show dlsw circuits
   Index	      local addr(lsap)	  remote addr(dsap)   state	uptime
   2634022913  0000.8888.0000(08)   4000.3745.0000(04) CONNECTED	4d01h
   Total number of circuits connected: 1

次の構文では、エンド ステーションが接続を再確立しようとした場合に生成されるデバッグ情報を示します。 Avimimus が復帰し、マスター ルータとして動作します。

マスター DLSw 冗長ルータ

avimimus#
   Mar 5 18:12:40.071: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame
    from Ethernet0
   Mar 5 18:12:40.071: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame
    from Ethernet0
   Mar 5 18:12:40.079: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame
    from Ethernet0
   Mar 5 18:12:40.079: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.4444.0000:4
   Mar 5 18:12:40.079: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.4444.0000:4
   Mar 5 18:12:40.087: DLSW-ER: Sending MP Frame
   Mar 5 18:12:41.071: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame
    from Ethernet0
   Mar 5 18:12:41.075: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame
    from Ethernet0
   Mar 5 18:12:41.075: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.4444.0000:8
   Mar 5 18:12:41.075: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.4444.0000:8
   Mar 5 18:12:41.079: DLSW-ER:MS->CSM:UGotIt 4000.3745.0000:4 0000.4444.0000:4
   Mar 5 18:12:41.079: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 --->
    0000.6666.0000
   Mar 5 18:12:42.075: DLSW-ER:MS->CSM:UGotIt 4000.3745.0000:4 0000.4444.0000:8
   Mar 5 18:12:42.075: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 --->
    0000.6666.0000
   avimimus# show dlsw circuits
   Index	      local addr(lsap)	  remote addr(dsap)   state	uptime
   3070230625  0000.4444.0000(04)  4000.3745.0000(04) CONNECTED  00:00:08
   4194304098  0000.4444.0000(08)  4000.3745.0000(04) CONNECTED  00:00:08
   Total number of circuits connected: 2

スレーブ ルータ DLSw 回線確立中の debug dlsw transparent コマンドの出力

このセクションでは、スレーブ ルータが DLSw 回線を確立しようとしている間に生成される debug dlsw transparent コマンドの出力を示します。

この出力は、スレーブによる回線の許可の受信に先立ち、スレーブとマスター間の通信を検証する場合に有効です。

このシナリオは、スレーブ ルータ上の既存 DLSw 回線を解除することによって、シミュレートされます。

スレーブ DLSw 冗長ルータ

turbo# show dlsw circuits
   Index	      local addr(lsap)	  remote addr(dsap)   state	uptime
   2634022913  0000.8888.0000(08)  4000.3745.0000(04) CONNECTED	4d02h
   Total number of circuits connected: 1
   turbo# clear dlsw circuits 2634022913
   turbo#
   Mar 5 20:02:37.426: DLSW-ER:CG -> 0000.cccc.0000: 4000.3745.0000:4 0000.8888.0000:8
   Mar 5 20:02:37.430: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.8888.0000:8 

上の例では、Turbo は、解除したばかりの回線のキャッシュ エントリをクリアするように、マスター ルータに通知します。

スレーブ DLSw 冗長ルータ

Mar 5 20:03:07.398: DLSW-ER:Replacing dmac 0000.eeee.0000 with 4000.3745.0000 on a frame
    from Ethernet0
   Mar 5 20:03:07.462: DLSW-ER:Replacing dmac 0000.eeee.0000 with 4000.3745.0000 on a frame
    from Ethernet0
   Mar 5 20:03:07.466: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.8888.0000:8
   Mar 5 20:03:07.470: DLSW-ER:IW -> 0000.cccc.0000: 4000.3745.0000:4 0000.8888.0000:8
   

上の例では、Turbo は、エンド ホストに接続するため、エンド デバイスからの着信要求を受信します。 Turbo は 20:03:07.470 で、この要求をマスター ルータに通知します。

スレーブ DLSw 冗長ルータ

Mar 5 20:03:07.474: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.8888.0000:8
   Mar 5 20:03:08.458: DLSW-ER:Replacing dmac 0000.eeee.0000 with 4000.3745.0000 on a frame
    from Ethernet0
   Mar 5 20:03:08.462: DLSW-ER:CSM->MS: C_INQ:PENDING: 4000.3745.0000:4 0000.8888.0000:8
   Mar 5 20:03:08.474: DLSW-ER:dm_action_k: Rcvd UG for 4000.3745.0000:4 0000.8888.0000:8
   Mar 5 20:03:08.478: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 --->
    0000.eeee.0000
   

上の例では、Turbo はマスターから UG を受け取り、回線が確立します。

スレーブ DLSw 冗長ルータ

turbo# show dlsw circuits
   Index	      local addr(lsap)	  remote addr(dsap)   state	uptime
   385876023   0000.8888.0000(08)  4000.3745.0000(04) CONNECTED  00:00:33
   Total number of circuits connected: 1

スレーブが回線を確立しようとしたときに、マスター ルータから取得したデータを次に示します。

マスター DLSw 冗長ルータ

avimimus# show dlsw circuits
   Index	      local addr(lsap)	  remote addr(dsap)   state	uptime
   3070230625  0000.4444.0000(04)  4000.3745.0000(04) CONNECTED  01:49:13
   4194304098  0000.4444.0000(08)  4000.3745.0000(04) CONNECTED  01:49:13
   Total number of circuits connected: 2
   avimimus# show dlsw transparent cache
   Interface Ethernet0
   Circuit Cache
   local addr(lsap)	 remote addr(dsap)     state	 Owner
   0000.4444.0000(04)	4000.3745.0000(04)   POSITIVE	 SELF
   0000.4444.0000(08)	4000.3745.0000(04)   POSITIVE	 SELF
   0000.8888.0000(08)	4000.3745.0000(04)   NEGATIVE	 0000.aaaa.0000
   Total number of circuits in the Cache: 3
   Mar 5 20:02:37.433: DLSW-ER:dm_action_h: Rcvd CG <-
    0000.aaaa.0000 4000.3745.0000:4 0000.8888.0000:8
   Mar 5 20:02:41.409: DLSW-ER: Sending MP Frame
   Mar 5 20:02:51.409: DLSW-ER: Sending MP Frame
   Mar 5 20:03:01.417: DLSW-ER: Sending MP Frame
   Mar 5 20:03:07.473: DLSW-ER:dm_action_j: Rcvd IW <-
    0000.aaaa.0000 4000.3745.0000:4 0000.8888.0000:8
   Mar 5 20:03:08.473: DLSW-ER:UG -> 0000.aaaa.0000: 4000.3745.0000:4 0000.8888.0000:8
   Mar 5 20:03:11.421: DLSW-ER: Sending MP Frame
   Mar 5 20:03:21.421: DLSW-ER: Sending MP Frame
   Mar 5 20:03:31.421: DLSW-ER: Sending MP Frame
   Mar 5 20:03:41.421: DLSW-ER: Sending MP Frame
   Mar 5 20:03:51.421: DLSW-ER: Sending MP Frame
   avimimus#un all


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 12345