LAN スイッチング : EtherChannel

CatOS スイッチと外部ルータ間での FEC と ISL/802.1q トランキングの設定

2003 年 9 月 17 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 9 月 1 日) | フィードバック

目次

概要
はじめに
      表記法
      前提条件
     特記事項
      使用するコンポーネント
     EtherChannel
     トランキング
設定
     ネットワーク ダイアグラム
     設定
確認
     Catalyst 6500 の show コマンド
     Cisco 7500 ルータの show コマンド
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書では、CatOS を実行している Catalyst 6500 スイッチと Cisco 7500 ルータ間の Fast EtherChannel(FEC)、InterSwitch Link(ISL)、および 802.1q トランキングの設定例について説明します。 各コマンドの結果は、そのコマンドを実行するたびに表示されます。 この設定では Catalyst 6000 スイッチが使用されていますが、CatOS を実行している Catalyst 4000 または Catalyst 5000 ファミリ スイッチと置き換えることもできます。

はじめに

表記法

文書表記の詳細は、「シスコ テクニカル ティップスの表記法」を参照してください。

前提条件

この文書の情報は、次のソフトウェアとハードウェアのバージョンに基づいています。

  • Catalyst 6000 シリーズ スイッチ

    • EtherChannel をサポートするには、CatOS リリース 5.1(1) CSX 以降が必要です。

  • Cisco 7000 または 7500 シリーズ ルータ

    • 7000 シリーズ ルータ スイッチ プロセッサ(RSP7000)や 7000 シリーズ シャーシ インターフェイス(RSP7000CI)を搭載した Cisco 7000 シリーズ ルータ、または、Fast Ethernet Interface Processor(FEIP; ファースト イーサネット インターフェイス プロセッサ)あるいは Versatile Interface Processor(VIP2; 多用途インターフェイス プロセッサ)ポート アダプタを搭載した Cisco 7500 シリーズ ルータ

    • PA-2FEISL ポート アダプタを使用する場合は、ハードウェアのリビジョン 1.2 が必要です。 2 ポート ファースト イーサネット ISL(PA-2FEISL)の詳細については、『Field Notice: 交換の推奨事項』を参照してください。

    • encapsulation dot1Q native コマンドは、12.1(3)T で導入されました。このコマンドは設定を変更します。 このコマンドの詳細については、この文書の 12.1(3)T の項ではなく、「12.1(3)T より前の Cisco IOS(R) バージョンの Cisco 7500 上での 802.1q の設定」を参照してください。

    • Cisco 7500 シリーズ ルータでは、デフォルトで Cisco Express Forwarding がイネーブルに設定されています。 しかし、IEEE 802.1q VLAN 間の IP ルーティング用の Cisco Express Forwarding のサポートは、Cisco IOS 12.2 および 12.2T リリースまでは利用できませんでした。 これよりも前のリリースで 802.1q カプセル化を設定することは可能ですが、最初にグローバルな no ip cef コマンドを実行して、Cisco Express Forwarding をディセーブルする必要があります。

    • 7500 シリーズ ルータが MPLS と FEC 用に設定されている場合、MPLS インターフェイスから FEC インターフェイスへ流れるルーティング(MPLS -> IP)パケットは、現在サポートされていません。 したがって、1 台のルータ上で、MPLS と FEC の設定を共存させることはお勧めしません。

    • EtherChannel のサポートには Cisco IOS リリース 11.1(14)CA 以降が必要です。 ISL トランキングのサポートには、Cisco IOS バージョン 11.3(1)T(任意の機能追加セット)以降が必要です。 IEEE 802.1q トランキングのサポートには、Cisco IOS バージョン 12.0(1)T(任意の機能追加セット)以降が必要です。

特記事項

  • Catalyst 4000 シリーズ スイッチは、ISL トランキングをサポートしていない点に留意してください。 また、Catalyst 5000 シリーズ スイッチのスイッチング モジュールの中には、EtherChannel に対応していないものがあります。 特定のモジュールが EtherChannel 対応かどうか、およびそのモジュールはどのトランキング カプセル化をサポートしているかを特定するには、show port capabilities <mod> コマンドを実行して確認してください。

  • EtherChannel およびトランキングの設定に関しては、いくつかのガイドラインがあります。 必ず、使用中のスイッチのソフトウェア マニュアルを参照してください。 たとえば、Catalyst 5000 上でソフトウェア リリース 5.5.x を実行している場合、『ソフトウェア コンフィギュレーション ガイド(5.5)』を参照し、「Fast EtherChannel および Gigabit EtherChannel の設定」という節に記載されている設定のガイドラインと制限事項を慎重に確認してください。

使用するコンポーネント

この設定に使用されている Catalyst 6500 は、CatOS バージョン 5.5.14 を実行しています。 この設定に使用されている Cisco 7500 ルータは、Cisco IOS バージョン 12.2.7b を実行しています。

この文書の設定は、隔離されたラボ環境で実装されました。 すべてのデバイスを確実にデフォルト設定にするため、ルータ上で write erase コマンドを実行し、すべてのスイッチ上で clear config all を実行して、設定をクリアしてください。 すべての設定またはコマンドは、それらによるネットワーク上での潜在的な影響を必ず理解したうえで使用してください。

EtherChannel

FEC または Gigabit EtherChannel(GEC)機能を使用すると、複数のポイントツーポイント リンクを 1 つの論理リンクにバンドルできます。 Catalyst 6000 は全二重モードで最大 8 ポートをサポートし、FEC に対しては 1600 Mbps(1.6 Gbps)、GEC に対しては 16 Gbps のスループットを提供します。 Cisco 7500 シリーズは最大 4 ポートをサポートし、FEC で 800 Mbps を提供します。 EtherChannel の機能とパフォーマンスは、スイッチまたはルータによって異なります。 詳細については、「Catalyst スイッチに EtherChannel を実装するためのシステム要件」を参照してください。

EtherChannel はトラフィックをすべてのリンクに分散し、1 つまたは複数のリンクで障害が発生した場合に冗長性を提供します。 EtherChannel の詳細と設定例については、「Catalyst スイッチでの EtherChannel のロード バランシングと冗長性についてを参照してください。

詳細については、テクニカル サポート エリアの「Etherchannel」のページを参照してください。

トランキング

トランキングは、複数の VLAN からのトラフィックを、2 台のデバイス間のポイントツーポイント リンクまたは EtherChannel バンドル上で伝送する方法です。 イーサネット トランキングの実装方法には、次の 2 種類があります。

  • ISL(シスコ独自のトランク カプセル化)

  • 802.1q(IEEE 標準トランクカプセル化)

詳細については、テクニカル サポート エリアの「トランキング」のページを参照してください。

設定

この項では、この文書で説明する機能を設定するために必要な情報を提供します。

注:この文書で使用されているコマンドの詳細を調べるには、Command Lookup ツールを使用してください(登録ユーザのみ)。


一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。


次の構成例を以降に示します。

  • Catalyst 6500 上での、VLAN 1 のワークステーション 1 用と VLAN 2 のワークステーション 2 用の 2 つのアクセス ポートの設定

  • Cisco 7500 上での、ワークステーション 1 のデフォルト ゲートウェイの 10.10.10.1 /24 への設定と、ワークステーション 2 のデフォルト ゲートウェイの 10.10.11.1/24 への設定

  • Catalyst 6500 スイッチと Cisco 7500 ルータ間での、2 ポート FEC を介した ISL および 802.1q トランクの設定

  • InterVLAN ルーティング用の IP アドレスを割り当てられた 2 ポートチャネル サブインターフェイスの設定

ネットワーク ダイアグラム

この文書では次の図に示すネットワーク構成を使用しています。

141-a.gif

設定

この文書では、次に示す設定を使用しています。

Catalyst 6500 スイッチ

  
  
  !--- 管理用 VLAN 1 の IP アドレスとデフォルト ゲートウェイを設定します。
  
  Catalyst6500> (enable) set int sc0 10.10.10.2 255.255.255.0
  Interface sc0 IP address and netmask set. 
  Catalyst6500> (enable) set ip route default 10.10.10.1
  Route added.
  
 
  
  !--- VTP モードを設定します。
  !--- この例では、モードを透過モードに設定しました。
  !--- お使いのネットワークに合わせて、VTP モードを設定してください。
  !--- VTP の詳細については、「VLAN トランク プロトコル(VTP)の説明と設定」を参照してください。
  
  Catalyst6500> (enable) set vtp mode transparent
  VTP domain modified
  
  
  !--- VLAN 2 を追加します。VLAN 1 はデフォルトで存在しています。
  
  Catalyst6500> (enable) set vlan 2
  VLAN 2 configuration successful
  
  
  !--- ポート 3/4 を VLAN 2 に追加します。ポート 3/3 は、デフォルトで VLAN 1 内に存在しています。
  
  Catalyst6500> (enable) set vlan 2 3/4
  VLAN 2 modified.
  VLAN 1 modified.
  VLAN  Mod/Ports
  ---- -----------------------
  2     3/4
  
  
  !---ポートの速度とディプレックスを 100 と全二重に設定します。 EtherChannel が
  !--- 動作するための要件の 1 つは、両サイドで
  !--- 速度とディプレックスを同じ設定に設定する
  !--- ことです。 確実にこれを実行するため、ポート 3/1 と 3/2 で、速度と
  !--- デュプレックスの両方をハードコード化する予定です。
  
  Catalyst6500> (enable) set port speed 3/1-2 100
  Ports 3/1-2 transmission speed set to 100Mbps.
  Catalyst6500> (enable) set port duplex 3/1-2 full
  Ports 3/1-2 set to full-duplex.
  
  
  !--- ポート 3/1 と 3/2 で、FEC をイネーブルにします。
  !--- ルータは Port Aggregation Protocol
  !--- (PAgP; ポート集約プロトコル) を認識しないため、
  !--- チャネル モードを、paGp フレームを生成する
  !--- モードではなく、ポートをチャネル化する
  !--- モードに設定しました。 
  
  Catalyst6500> (enable) set port channel 3/1-2 on
  Port(s) 3/1-2 are assigned to admin group 105.
  Port(s) 3/1-2 channel mode set to on.
  
  
  !--- ポート 3/1 と 3/2 で、トランキングをイネーブルにします。
  !--- ルータは Dynamic Trunking Protocol
  (DTP; ダイナミック トランキング プロトコル)を認識しないため、
  !--- トランキング モードを、DTP  フレームを生成する
  !--- モードではなく、ポートでトランキングを発生させる
  !--- nonegotiate に設定しました。 
  !--- 最初に EtherChannel が
  !--- 設定されているため、
  !--- 1 つのポートに適用されたトランク設定が、チャネル内の
  !--- 他のすべてのポートに自動的に適用される点に注意してください。
  !--- トランキング カプセル化として入力するのは、isl ... 
  
  Catalyst6500> (enable) set trunk 3/1 nonegotiate isl 
  Port(s) 3/1-2 trunk mode set to nonegotiate. 
  Port(s) 3/1-2 trunk type set to isl. 
  
  
  !--- ... または dot1q のどちらかです。 
  !--- ネイティブ VLAN(デフォルトでは VLAN 1)がリンク全体で 
  !--- 一致しているかどうか確認してください。  
  !--- ネイティブ VLAN と 802.1q トランキングの 
  !--- 詳細については、802.1q カプセル化を使用している
  !--- Catalyst 4000、5000、6000 ファミリ スイッチ間の
  !--- トランキングを参照してください。
  
  Catalyst6500> (enable) set trunk 3/1 nonegotiate dot1q
  Port(s) 3/1-2 trunk mode set to nonegotiate.
  Port(s) 3/1-2 trunk type set to dot1q.
  --------------------------------------------------------------------------------
  Catalyst6500> (enable) show config
  This command shows non-default configurations only.
  Use 'show config all' to show both default and non-default configurations.
  .........
  ..................
  ..
  begin
  !
  # ***** NON-DEFAULT CONFIGURATION *****
  !
  !
  #time: Thu May 2 2002, 01:26:26 
  !
  #version 5.5(14)
  !
  !
  #system
  set system name  Catalyst6500
  !
  #!
  #vtp
  set vtp mode transparent
  set vlan 1 name default type ethernet mtu 1500 said 100001 state active 
  set vlan 2 name VLAN0002 type ethernet mtu 1500 said 100002 state active 
  set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active 
  set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state active stp ieee 
  set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active stp ibm 
  set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state active 
  mode srb aremaxhop 7 stemaxhop 7 
  backupcrf off 
  !
  #ip
  set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255
  set ip route 0.0.0.0/0.0.0.0         10.10.10.1     
  !
  #set boot command
  set boot config-register 0x2102
  set boot system flash bootflash:cat6000-sup.5-5-14.bin
  !
  #port channel
  set port channel 3/1-2 105
  !
  # default port status is enable
  !
  !
  #module 1 empty
  !
  #module 2 : 2-port 1000BaseX Supervisor
  !
  #module 3 : 48-port 10/100BaseTX Ethernet
  set vlan 2    3/4
  set port disable    3/5
  set port speed      3/1-2  100
  set port duplex     3/1-2  full
  set trunk 3/1  nonegotiate isl 1-1005
  set trunk 3/2  nonegotiate isl 1-1005
  
  
  !--- IEEE 802.1q が設定されている場合は、
  !--- 代わりに、次の出力が表示されます。
  set trunk 3/1  nonegotiate dot1q 1-1005
  set trunk 3/2  nonegotiate dot1q 1-1005
  
  set port channel 3/1-2 mode on
  !
  #module 4 : 24-port 100BaseFX MM Ethernet
  !
  #module 5 empty
  !
  #module 6 empty
  !
  #module 15 empty
  !
  #module 16 empty
  end
  

 

Cisco 7500 ルータ

Cisco 7500 Router 
  
  
  !--- FEC をイネーブルにするように、ポート チャネル インターフェイスを設定します。
  
  7500#configure terminal
   Enter configuration commands, one per line. End with CNTL/Z.
  7500(config)#int port-channel 1
  01:34:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
   state to down
  
  
  !--- Catalyst スイッチ側の設定と一致するように、
  !--- デュプレックスの設定を全二重に設定します。
  
  7500(config-if)#full-duplex
  7500(config-if)#exit
  
  
  !--- ISL トランキングを使っている場合、
  !--- 2 つのポート チャネル サブインターフェイスを設定し、
  !--- encapsulation isl <VLAN>  コマンドを実行して、ISL トランキングをイネーブルにします。
  !--- InterVLAN ルーティングの IP アドレスを設定します。
  
  7500(config)#int port-channel 1.1
  7500(config-subif)#encapsulation isl 1
  7500(config-subif)#ip address 10.10.10.1 255.255.255.0
  7500(config-subif)#exit
  7500(config)#int port-channel 1.2
  7500(config-subif)#encapsulation isl 2
  7500(config-subif)#ip address 10.10.11.1 255.255.255.0
  7500(config-subif)#exit
  
  
  !--- 802.1q トランキングを使用している場合、
  !--- 2 つのポート チャネル  サブインターフェイスを設定し、
  !--- encapsulation dot1Q <vlan> native コマンドを実行して、
  !--- 802.1q トランキングをイネーブルにした後、
  !--- InterVLAN ルーティングの IP アドレスを設定します。
  
  

注:カプセル化 dot1Q 1 ネイティブ コマンドが、Cisco IOS バージョン 12.1(3)T で追加されました。 Cisco IOS の以前のバージョンを使用している場合、ルータで 802.1q トランキングを設定するには、この文書の「12.1(3)T より前の Cisco IOS バージョンの Cisco 7500 上での 802.1q の設定」の節を参照してください。

  
  
  !--- ネイティブ VLAN(デフォルトでは VLAN 1)がリンク全体で 
  !--- 一致しているかどうか確認してください。  
  !--- ネイティブ VLAN と 802.1q トランキングの 
  !--- 詳細情報は
  !--- 802.1q カプセル化を使用している Catalyst 4000、5000、6000 ファミリ スイッチ間の
  !--- トランキングを参照してください。
  
  7500(config)#int port-channel 1.1
  7500(config-subif)#encapsulation dot1Q 1 native
  7500(config-subif)#ip address 10.10.10.1 255.255.255.0
  7500(config-subif)#exit
  7500(config)#int port-channel 1.2
  7500(config-subif)#encapsulation dot1Q 2
  7500(config-subif)#ip address 10.10.11.1 255.255.255.0
  7500(config-subif)#exit
  
  
  !--- ポート アダプタに応じて、FastEthernet インターフェイスを
  !--- 速度 100 に設定します。 
  !--- FastEthernet ポート アダプタの中には、速度(10 または 100)と
  !--- デュプレックス(半二重または全二重)を自動ネゴシエートできるものがあります。 
  !--- それ以外のアダプタでは、100(半二重または全二重)しか設定できません。
  
  7500(config)#int fa5/1/0
  7500(config-if)#speed 100
  
  
  !--- channel-group コマンドを実行して、FastEthernet インターフェイスを
  !--- ポートチャネル 1 のメンバに設定します。
  
  7500(config-if)#channel-group 1
  %Interface MTU set to channel-group MTU 1500.
  7500(config-if)#no shut
  7500(config-if)#
  %Interface MTU set to channel-group MTU 1500.
  FastEthernet5/1/0 added as member-1 to port-channel1
  01:46:09: %LINK-3-UPDOWN: Interface FastEthernet5/1/0, changed state to up
  01:46:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/0,
  changed state to up
  01:46:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1,
  changed state to up
  Router(config-if)#exit
  Router(config)#int fa 5/1/1
  Router(config-if)#speed 100
  Router(config-if)#channel-group 1
  %Interface MTU set to channel-group MTU 1500.
  Router(config-if)#no shut
  Router(config-if)#
  %Interface MTU set to channel-group MTU 1500.
  FastEthernet5/1/1 added as member-2 to port-channel1
  01:54:52: %LINK-3-UPDOWN: Interface FastEthernet5/1/1, changed state to up
  01:54:53: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/1,
  changed state to up
  Router(config-if)#exit
  
  
  !--- 必ず設定を保存してください。
  
  7500#write memory
  Building configuration...
  [OK]
  7500#

注:この設定を動作させ、ワークステーション 1 とワークステーション 2 の間で ping を正常に実行するには、ワークステーションのデフォルト ゲートウェイが適切に設定されていることを確認する必要があります。 Workstation 1 ではデフォルト ゲートウェイが 10.10.10.1、Workstation 2 ではデフォルト ゲートウェイが 10.10.11.1 になります。

--------------------------------------------------------------------------------
  7500#show running-config
  Building configuration...
  Current configuration : 1593 bytes
  !
  version 12.2
  no service pad
  service timestamps debug uptime
  service timestamps log uptime
  no service password-encryption
  no service single-slot-reload-enable
  !
  hostname 7500
  !
  boot system disk1:rsp-jsv-mz.122-7b.bin
  !
  ip subnet-zero
  !
  ip cef
  call rsvp-sync
  !
  !
  !
  interface Port-channel1
   no ip address
   full-duplex
   hold-queue 300 in
  !
  interface Port-channel1.1
   encapsulation isl 1
   ip address 10.10.10.1 255.255.255.0
  !
  interface Port-channel1.2
   encapsulation isl 2
   ip address 10.10.11.1 255.255.255.0
  
  
  !--- 802.1q トランキングが設定されている場合は、
  !--- 代わりに、次の出力が表示されます。 
  interface Port-channel1.1
   encapsulation dot1Q 1 native
   ip address 10.10.10.1 255.255.255.0
  !
  interface Port-channel1.2
   encapsulation dot1Q 2
   ip address 10.10.11.1 255.255.255.0
  
  !
  interface FastEthernet5/1/0
   no ip address
   no ip mroute-cache
   speed 100
   full-duplex
   channel-group 1
  !
  interface FastEthernet5/1/1
   no ip address
   no ip mroute-cache
   speed 100
   full-duplex
   channel-group 1
  !
  !
  ip classless
  no ip http server
  ip pim bidir-enable
  !
  !
  !
  !
  line con 0
  line aux 0
  line vty 0 4
   login
  !
  end
  7500#

12.1(3)T より前の Cisco IOS バージョンの Cisco 7500 上での 802.1q の設定

12.1(3)T よりも前のバージョンの Cisoco IOS では、サブインターフェイスで encapsulation dot1Q 1 native コマンドを使用できません。 ただし、上記のとおり、リンク間で本来の VLAN を一致させる必要があることに変わりありません。

12.1(3)T よりも前のバージョンのソフトウェアで 802.1q トランキングを設定するには、VLAN 1 の IP アドレスをポートチャネル サブインターフェイスではなく、メイン ポートチャネル 1 インターフェイスで設定します。

  
  
  !--- FEC をイネーブルにするように、ポート チャネル インターフェイスを設定します。
  
  7500#configure terminal
   Enter configuration commands, one per line. End with CNTL/Z.
  7500(config)#int port-channel 1
  01:34:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
   state to down
  
  
  !--- Catalyst スイッチ側の設定と一致するように、
  !--- デュプレックスの設定を全二重に設定します。 
  
  7500(config-if)#full-duplex 
  7500(config-if)#exit
  
  
  !--- インターフェイス ポート チャネル 1.1 を設定しないでください。
  !--- その代わり、ポート チャネル 1 メイン インターフェイスを作成して、
  !--- ここで、VLAN 1 の IP アドレスを設定してください。 
  
  7500(config)#int port-channel 1
  7500(config-if)#full-duplex
  7500(config-if)#ip address 10.10.10.1 255.255.255.0
  7500(config-if)#exit
  7500(config)#
  
  
  !--- この場合でも、VLAN 2 のサブインターフェイスを作成する必要があります。
  
  7500(config)#int port-channel 1.2
  7500(config-subif)#encapsulation dot1Q 2
  7500(config-subif)#ip address 10.10.11.1 255.255.255.0
  7500(config-subif)#exit
  
  
  !--- ポート アダプタに応じて、FastEthernet インターフェイスを
  !--- 速度 100 に設定します。 
  !--- FastEthernet ポート アダプタの中には、速度(10 または 100)と
  !--- デュプレックス(半二重または全二重)を自動ネゴシエートできるものがあります。 
  !--- それ以外のアダプタでは、100(半二重または全二重)しか設定できません。
  
  7500(config)#int fa5/1/0
  7500(config-if)#speed 100
  
  
  !--- channel-group コマンドを実行することによって、
  !--- FastEthernet インターフェイスをポート チャネル 1 の
  !--- メンバとして設定します。
  
  7500(config-if)#channel-group 1
  %Interface MTU set to channel-group MTU 1500.
  7500(config-if)#no shut
  7500(config-if)#
  %Interface MTU set to channel-group MTU 1500.
  FastEthernet5/1/0 added as member-1 to port-channel1
  01:46:09: %LINK-3-UPDOWN: Interface FastEthernet5/1/0, changed state to up
  01:46:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/0,
  changed state to up
  01:46:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1,
  changed state to up
  Router(config-if)#exit
  Router(config)#int fa 5/1/1
  Router(config-if)#speed 100
  Router(config-if)#channel-group 1
  %Interface MTU set to channel-group MTU 1500.
  Router(config-if)#no shut
  Router(config-if)#
  %Interface MTU set to channel-group MTU 1500.
  FastEthernet5/1/1 added as member-2 to port-channel1
  01:54:52: %LINK-3-UPDOWN: Interface FastEthernet5/1/1, changed state to up
  01:54:53: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/1,
  changed state to up
  Router(config-if)#exit
  
  
  !--- 必ず設定を保存してください。
  
  7500#write memory
  Building configuration...
  [OK]
  7500#
  

注:7000/7500 シリーズ用の 12.2 または 12.2T より以前のソフトウェアのバージョンでは、サブインターフェイスで 802.1q トランキングを設定する前に、no ip cef コマンドをグローバルに実行する必要があるということも忘れないでください。 この操作を実行しない場合、次のエラー メッセージが表示される可能性があります。 このインターフェイスで設定されている CEF では、802.1q カプセル化はサポートされていません。 詳細については、この文書の「ハードウェアの要件とソフトウェアの要件」の節を参照してください。

7500#show running-config
  Building configuration...
  Current configuration : 1593 bytes
  !
  version 12.1
  no service pad
  service timestamps debug uptime
  service timestamps log uptime
  no service password-encryption
  !
  hostname 7500
  !
  !
  ip subnet-zero
  !
  no ip cef
  !
  !
  !
  interface Port-channel1
  ip address 10.10.10.1 255.255.255.0
   full-duplex
   hold-queue 300 in
  !
  interface Port-channel1.2
   encapsulation dot1Q 2
   ip address 10.10.11.1 255.255.255.0
  !
  interface FastEthernet5/1/0
   no ip address
   no ip mroute-cache
   speed 100
   full-duplex
   channel-group 1
  !
  interface FastEthernet5/1/1
   no ip address
   no ip mroute-cache
   speed 100
   full-duplex
   channel-group 1
  !
  !
  ip classless
  no ip http server
  !
  !
  !
  line con 0
  line aux 0
  line vty 0 4
   login
  !
  end
  7500#
  

確認

この項では、設定が正しく動作していることを確認するために使用できる情報を提供します。

Catalyst 6500 の show コマンド

  • show interface - sc0 管理インターフェイス IP アドレスと VLAN を表示します。 この例では、VLAN 1 というデフォルトの VLAN が使用されています。

    Catalyst6500> (enable) show interface
      sl0: flags=51<UP,POINTOPOINT,RUNNING>
              slip 0.0.0.0 dest 0.0.0.0
      sc0: flags=63<UP,BROADCAST,RUNNING>
              VLAN 1 inet 10.10.10.2 netmask 255.255.255.0 broadcast 10.10.10.255
      Catalyst6500> (enable)
      
  • show ip route - デフォルト ゲートウェイを表示します。 この例で、10.10.10.1 はポートチャネル 1(802.1q トランキングの場合)またはポートチャネル 1.1(ISL トランキングの場合)の IP アドレスです。

    Catalyst6500> (enable) show ip route
      Fragmentation   Redirect   Unreachable
      -------------   --------   -----------
      enabled         enabled    enabled
      The primary gateway: 10.10.10.1
      Destination      Gateway          RouteMask    Flags   Use       Interface
      ---------------  ---------------  ----------   -----   --------  ---------
      default          10.10.10.1       0x0          UG      0           sc0
      10.10.10.0       10.10.10.2       0xffffff00   U       8           sc0
      default          default          0xff000000   UH      0           sl0
      Catalyst6500> (enable)
      
  • showport capabilities <mod/part> - スイッチング モジュールのハードウェア機能の概要を表示します。 この例では、ポート 3/1(3/2 と同じ)が EtherChannel 対応で、どのトランキング カプセル化がサポートされているか、などの情報が表示されます。

    Catalyst6500> (enable) show port capabilities 3/1
      Model                    WS-X6248-RJ-45
      Port                     3/1
      Type                     10/100BaseTX
      Speed                    auto,10,100
      Duplex                   half,full
      Trunk encap type         802.1q,ISL
      Trunk mode               on,off,desirable,auto,nonegotiate
      Channel                  yes
      Broadcast suppression    percentage(0-100)
      Flow control             receive-(off,on),send-(off)
      Security                 yes
      Membership               static,dynamic
      Fast start               yes
      QOS scheduling           rx-(1q4t),tx-(2q2t)
      CoS rewrite              yes
      ToS rewrite              DSCP
      UDLD                     yes
      Inline power             no
      AuxiliaryVlan            1..1000,untagged,dot1p,none
      SPAN                     source,destination
      COPS port group          not supported
      Catalyst6500> (enable)
      
  • show port counters <mod/port> - 考えられるポート エラーの概要を表示します。 この例では、このポートにまったくエラーが発生していません。 ポート エラーが発生する場合、詳細については「 トラブルシューティング:スイッチ ポートの問題」を参照してください。

    Catalyst6500> (enable) sh port counters 3/1
      Port  Align-Err  FCS-Err    Xmit-Err   Rcv-Err    UnderSize
      ----- ---------- ---------- ---------- ---------- ---------
       3/1           0          0          0          0         0
      Port  Single-Col Multi-Coll Late-Coll  Excess-Col Carri-Sen Runts     Giants
      ----- ---------- ---------- ---------- ---------- --------- --------- ---------
       3/1           0          0          0          0         0         0         -
      Last-Time-Cleared
      --------------------------
      Thu May 2 2002, 02:11:55
      Catalyst6500> (enable)
      
  • show port <mod> - ポートの状態、VLAN、トランク、および速度/デュプレックス情報を表示します。 この例では、ワークステーション 1 のアクセス ポートは 3/3 で、VLAN 1 にあります。 ワークステーション 2 のアクセス ポートは 3/4 で、VLAN 2 にあります。 ポート 3/1 と 3/2 は、シスコのトランキングおよび FEC ポートです。

    Catalyst6500> (enable) show port 3
      Port  Name                 Status     VLAN       Duplex Speed Type
      ----- -------------------- ---------- ---------- ------ ----- ------------
       3/1                       connected  trunk        full   100 10/100BaseTX
       3/2                       connected  trunk        full   100 10/100BaseTX
       3/3                       connected  1          a-half  a-10 10/100BaseTX
       3/4                       connected  2          a-full a-100 10/100BaseTX
      
      --- output suppressed ---
      
      
  • show vlan - 特定の VLAN に割り当てられているポートを表示します。 この例のトランク ポート(3/1 および 3/2)はこの出力に表示されていませんが、これは正常です。

    Catalyst6500> (enable) show vlan
      VLAN Name                             Status    IfIndex Mod/Ports, Vlans
      ---- -------------------------------- --------- ------- ------------------------
      1    default                          active    119     2/1-2
                                                              3/3,3/5-48
                                                              4/1-24
      2    VLAN0002                         active    124     3/4
      
      --- output suppressed ---
      
      
  • show trunk - トランキング モード、カプセル化のタイプ、許可されている VLAN、およびアクティブな VLAN を表示します。 この例では、VLAN 1(デフォルトで常に許可されアクティブ)および VLAN 2 がトランクに対して現在アクティブな VLAN です。 両方のトランク ポートが VLAN 1 にある点に注意してください。

    Catalyst6500> (enable) sh trunk
      * - indicates vtp domain mismatch
      Port      Mode         Encapsulation  Status        Native vlan
      --------  -----------  -------------  ------------  -----------
       3/1      nonegotiate  isl            trunking      1
       3/2      nonegotiate  isl            trunking      1
      Port      VLANs allowed on trunk
      --------  ---------------------------------------------------------------------
       3/1      1-1005
       3/2      1-1005
      Port      VLANs allowed and active in management domain 
      --------  ---------------------------------------------------------------------
       3/1      1-2
       3/2      1-2
      Port      VLANs in spanning tree forwarding state and not pruned
      --------  ---------------------------------------------------------------------
       3/1      1-2
       3/2      1-2
      

    802.1q トランキングの場合、上記のコマンドの出力は、次のように変わります。

    Catalyst6500> (enable) show trunk
      * - indicates vtp domain mismatch
      Port      Mode         Encapsulation  Status        Native VLAN
      --------  -----------  -------------  ------------  -----------
       3/1      nonegotiate  dot1q          trunking      1
       3/2      nonegotiate  dot1q          trunking      1
      Port      VLANs allowed on trunk
      --------  ---------------------------------------------------------------------
       3/1      1-1005
       3/2      1-1005
      Port      VLANs allowed and active in management domain 
      --------  ---------------------------------------------------------------------
       3/1      1-2
       3/2      1-2
      Port      VLANs in spanning tree forwarding state and not pruned
      --------  ---------------------------------------------------------------------
       3/1      1-2
       3/2      1-2
      Catalyst6500> (enable)
      
  • show port channel - Etherchannel の状態を表示します。 次の例では、2 ポート FEC(ポート 3/1 と 3/2)が使われています。PAgP フレームの送信を防止するため、FEC はオンになっています。 7500 ルータのリモートチャネル インターフェイスも表示されます。

    Catalyst6500> (enable)  show port channel
      Port  Status     Channel              Admin Ch
                       Mode                 Group Id
      ----- ---------- -------------------- ----- -----
       3/1  connected  on                     105   833
       3/2  connected  on                     105   833
      ----- ---------- -------------------- ----- -----
      Port  Device-ID                       Port-ID                   Platform
      ----- ------------------------------- ------------------------- ----------------
      3/1  7500                            Port-channel1.1           cisco RSP4
      3/2  
      ----- ------------------------------- ------------------------- ----------------
      Catalyst6500> (enable)
      

    802.1q トランキングを使った FEC の場合、上記のコマンドの出力は、次のように変わります。

    Catalyst6500> (enable) sh port channel
      Port  Status     Channel              Admin Ch
                       Mode                 Group Id
      ----- ---------- -------------------- ----- -----
       3/1   connected  on                    257   769
       3/2   connected  on                    257   769
      ----- ---------- -------------------- ----- -----
      Port  Device-ID                       Port-ID                   Platform
      ----- ------------------------------- ------------------------- ----------------
       3/1       7500                            FastEthernet5/1/0         cisco RSP4
       3/2       7500                            FastEthernet5/1/1         cisco RSP4
      ----- ------------------------------- ------------------------- ----------------
      Catalyst6500> (enable)
      

ご使用のシスコ デバイスの、show-tech support コマンドの出力データがあれば、 を使用して今後予想される障害と修正を表示できます。を使用するには、登録ユーザとしてログインしており、JavaScript を有効化している必要があります。


一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。


Cisco 7500 ルータの show コマンド

  • show int port-channel channel number - 物理インターフェイスのメンバ状態を表示します。 この例では、Catalyst 6000 上の 3/1-2 ポートと、7500 上の FastEthernet 5/1/0 と 5/1/1 インターフェイスの間で、2 ポート FEC を設定しました。 ポート チャネル 1 は、up/up と表示されます。

    このポートチャネルには IP アドレスが設定され、この例では 802.1q トランキング用の本来の VLAN IP アドレスになっています。 詳細については、この文書の 12.1(3)T の項ではなく、「12.1(3)T より前の Cisco IOS バージョンの Cisco 7500 上での 802.1q」の設定を参照してください。 VLAN 2 802.1q サブインターフェイスである内部ポートチャネル 1.2 に関する出力も示します。

    7500#sh int port-channel 1
      Port-channel1 is up, line protocol is up
        Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
        Internet address is 10.10.10.1/24
        MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
           reliability 255/255, txload 1/255, rxload 1/255
        Encapsulation ARPA, loopback not set
        Keepalive set (10 sec)
        Full-duplex, Unknown Speed
        ARP type: ARPA, ARP Timeout 04:00:00
          No. of active members in this channel: 2
              Member 0 : FastEthernet5/1/0
              Member 1 : FastEthernet5/1/1
        Last input 00:00:14, output never, output hang never
        Last clearing of "show interface" counters never
        Input queue: 0/300/0/0 (size/max/drops/flushes); Total output drops: 0
        Queueing strategy: fifo
        Output queue :0/40 (size/max)
        5 minute input rate 0 bits/sec, 0 packets/sec
        5 minute output rate 0 bits/sec, 0 packets/sec
           6720 packets input, 923310 bytes, 0 no buffer
           Received 5010 broadcasts, 0 runts, 0 giants, 0 throttles
           0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
           0 watchdog
           0 input packets with dribble condition detected
           1902 packets output, 573088 bytes, 0 underruns
           0 output errors, 0 collisions, 0 interface resets
           0 babbles, 0 late collision, 0 deferred
           0 lost carrier, 0 no carrier
           0 output buffer failures, 0 output buffers swapped out
      7500#
      7500#sh int port-channel 1.2
      Port-channel1.2 is up, line protocol is up
        Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
        Internet address is 10.10.11.1/24
        MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
           reliability 255/255, txload 1/255, rxload 1/255
        Encapsulation 802.1q Virtual LAN, Vlan ID  2.
        ARP type: ARPA, ARP Timeout 04:00:00
      

    ISL トランキングおよび FEC に関する出力を次に示します。

    7500#sh int port-channel 1
      Port-channel1 is up, line protocol is up 
        Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
        MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec, 
           reliability 255/255, txload 1/255, rxload 1/255
        Encapsulation ARPA, loopback not set
        Keepalive set (10 sec)
        Full-duplex, Unknown Speed
        ARP type: ARPA, ARP Timeout 04:00:00
          No. of active members in this channel: 2 
              Member 0 : FastEthernet5/1/0 
              Member 1 : FastEthernet5/1/1 
        Last input 00:00:01, output never, output hang never
        Last clearing of "show interface" counters never
        Input queue: 0/300/0/0 (size/max/drops/flushes); Total output drops: 0
        Queueing strategy: fifo
        Output queue :0/40 (size/max)
        5 minute input rate 0 bits/sec, 1 packets/sec
        5 minute output rate 0 bits/sec, 0 packets/sec
           113 packets input, 7278 bytes, 0 no buffer
           Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
           0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
           0 watchdog
           0 input packets with dribble condition detected
        13 packets output, 2264 bytes, 0 underruns
           0 output errors, 0 collisions, 0 interface resets
           0 babbles, 0 late collision, 0 deferred
           0 lost carrier, 0 no carrier
           0 output buffer failures, 0 output buffers swapped out
      7500#sh int port-channel 1.1
      Port-channel1.1 is up, line protocol is up 
        Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
        Internet address is 10.10.10.1/24
        MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec, 
           reliability 255/255, txload 1/255, rxload 1/255
        Encapsulation ISL Virtual LAN, Color 1.
        ARP type: ARPA, ARP Timeout 04:00:00
      7500#sh int port-channel 1.2
      Port-channel1.2 is up, line protocol is up 
        Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
        Internet address is 10.10.11.1/24
        MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec, 
           reliability 255/255, txload 1/255, rxload 1/255
        Encapsulation ISL Virtual LAN, Color 2.
        ARP type: ARPA, ARP Timeout 04:00:00
      
  • show interfaces fastethernet <slot/port-adapter/port> - ルータの物理的インターフェイスの状態と、そのインターフェイスでエラーが発生しているかどうかを表示します。 この例では、エラーが発生していません。

    7500#sh int fa5/1/0
      FastEthernet5/1/0 is up, line protocol is up
        Hardware is cyBus FastEthernet Interface, address is 0001.6490.f8a8 (bia 0001.
      6490.f8a8)
        MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
           reliability 255/255, txload 1/255, rxload 1/255
        Encapsulation ARPA, loopback not set
        Keepalive set (10 sec)
        Full-duplex, 100Mb/s, 100BaseTX/FX
        ARP type: ARPA, ARP Timeout 04:00:00
        Last input 1d00h, output 00:00:07, output hang never
        Last clearing of "show interface" counters 1d00h
        Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
        Queueing strategy: fifo
        Output queue :0/40 (size/max)
        5 minute input rate 0 bits/sec, 0 packets/sec
        5 minute output rate 0 bits/sec, 0 packets/sec
           2929 packets input, 425318 bytes, 0 no buffer
           Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
           0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
           0 watchdog
           0 input packets with dribble condition detected
           12006 packets output, 1539768 bytes, 0 underruns
           0 output errors, 0 collisions, 6 interface resets
           0 babbles, 0 late collision, 0 deferred
           0 lost carrier, 0 no carrier
           0 output buffer failures, 0 output buffers swapped out
      7500#
      

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 23307