ダイヤルとアクセス : バーチャル プライベート ダイヤルアップ ネットワーク(VPDN)

AAA なしの VPDN 設定

2004 年 5 月 16 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 9 月 9 日) | フィードバック

目次


概要

この文書では、Virtual Private Dialup Network(VPDN)Layer 2 Tunneling Protocol(L2TP; レイヤ 2 トンネリング プロトコル)が、ISDN およびアナログ ダイヤルイン コール用に設定される設定例について説明します。このセットアップには、Authentication, Authorization, and Accounting(AAA; 認証、許可、アカウンティング)サーバは含まれていません。

L2TP とは、Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)の規格で、次の 2 つの既存のトンネリング プロトコルの最高の機能を持ち合わせています。

  • Cisco Layer 2 Forwarding(L2F)
  • Microsoft Point-to-Point Tunneling Protocol(PPTP)

このセットアップでは、protocol L2TP コマンドを追加することによって、L2TP を使用しています。L2F がデフォルトです。

シスコは、L2TP Access Concentrator(LAC)と L2TP Network Server(LNS)の両方で VPDN パラメータを定義するため、Cisco IOS(R) ソフトウェア リリース 12.0(1)T で導入された vpdn-group コマンドの使用を推奨します。ただし、vpdn incoming コマンドと vpdn outgoing コマンドを使用する場合は、『バーチャル プライベート ダイヤルアップ ネットワークの設定』を参照してください。

このセットアップの主な特徴は次の通りです。

  • LAC:
    • 認証(このセットアップでは Challenge Handshake Authentication Protocol [CHAP])応答で受信したドメイン名に基づいて、VPDN クライアントを識別します。
    • ローカル VPDN パラメータを使って、LNS とのトンネルとセッションを確立します。
  • LNS:
    • ローカル VPDN パラメータを使って、LAC との VPDN トンネルとセッションを承認します。
    • リモート ユーザをローカルに認証します。
    • ローカル プールからクライアントへ IP アドレスを割り当てます。

設定

この項では、この文書で説明する機能を設定するための情報を提供します。

注: この文書で使用されているコマンドの詳細を調べるには、「Command Lookup ツール」を使用してください(登録ユーザのみ)。

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

この設定で使用されているコンポーネント

この設定は、次のソフトウェアとハードウェアのバージョンを使用して開発およびテストされました。

  • Cisco IOS(R) ソフトウェア リリース 12.2 メイン ライン。VPDN には IP+ 機能が必要です。
  • E1 カードと Mica カードを搭載した Cisco AS5300(LAC)。ISDN とアナログ コールを扱うことができます。
この文書で紹介する情報は、特定の実験環境にあるデバイスを使用して作成されました。この文書内で使用されているデバイスはすべて、クリアな状態(デフォルト)から設定作業を始めています。実稼動中のネットワークで作業する場合は、コマンドの実行によって生じる影響について、事前に理解しておいてください。

ネットワーク ダイアグラム


設定

LAC
version 12.2 
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname LAC
!
spe 2/0 2/9
firmware location system:/ucode/mica_port_firmware
!
!
modem country mica belgium
!
vpdn enable
! -- VPDN をイネーブルにします。
!
vpdn search-order domain
! -- VPDN トンネル認証は、ドメイン名に基づいています ! -- (デフォルトは DNIS です)。
!
vpdn-group GroupCisco
request-dialin
! -- LAC をイネーブルにして、ダイヤルイン用の次の IP アドレス ! -- (10.48.74.35) に VPDN 要求を行います。
protocol l2tp
! -- デフォルト(L2F)の代わりに、L2TP が使われます。
domain cisco.com
! -- ユーザから CHAP 応答を受信した場合、VPDN ユーザを識別するため、 ! -- ドメイン名 cisco.com が使われます。
initiate-to ip 10.48.74.35
! -- トンネルとセッションが、LNS 10.48.74.35 のイーサネット IP アドレスに ! -- 初期化されます。 l2tp tunnel password cisco
! -- トンネル認証用。
!
isdn switch-type primary-net5
!
controller E1 0
clock source line primary
pri-group timeslots 1-31
!
interface Ethernet0
ip address 10.48.75.7 255.255.254.0
!
interface Serial0:15
no ip address
encapsulation ppp
dialer rotary-group 1
isdn switch-type primary-net5
isdn incoming-voice modem
!
interface Group-Async1
no ip address
encapsulation ppp
async mode dedicated
ppp authentication chap pap
group-range 1 120
!
interface Dialer1
no ip address
encapsulation ppp
ppp authentication chap pap
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.48.74.1
!
line con 0
exec-timeout 0 0
line 1 120
modem InOut
transport input all
line aux 0
line vty 0 4
exec-timeout 0 0
password cisco
login
!
LNS
  version 12.2 
service timestamps debug datetime msec service timestamps log datetime msec
!
hostname LNS
!
username UserISDN@cisco.com password 0 cisco
username UserAnalog@cisco.com password 0 cisco
! -- LNS は、リモート ユーザをローカルに認証します。
!
vpdn enable
! -- VPDN をイネーブルにします。
!
vpdn-group VPDN
accept-dialin
! -- LNS をイネーブルにして、VPDN 要求を受付けます。
protocol l2tp
!-- L2F(デフォルト)の代わりに、L2TP が使われます。
virtual-template 1
! -- PPP セッションを終了するため、ユーザごとに仮想テンプレート 1 が使われます。
terminate-from hostname LAC
! -- LNS は、ルータ LAC からの VPDN 要求を受付けます。
l2tp tunnel password cisco
! -- トンネル認証用。
!
!
!
!
interface Loopback1
ip address 12.12.12.1 255.255.255.255
no ip route-cache
no ip mroute-cache
!
interface Ethernet0
ip address 10.48.74.35 255.255.254.0
no ip route-cache
no ip mroute-cache
no cdp enable
!
interface Virtual-Template1
! -- この仮想テンプレートから複製された仮想アクセスで ! -- PPP セッションが終了します。
ip unnumbered Loopback1
peer default ip address pool GroupCisco
ppp authentication chap pap
!
ip local pool GroupCisco 12.12.12.2 12.12.12.50
! -- LNS は、リモート ユーザに IP アドレスを割り当てます。
ip classless
ip route 0.0.0.0 0.0.0.0 10.48.74.1

注 1: 上記設定では、最小の Point to Point Protocol(PPP)オプションを使って、ダイヤラ 1 インターフェイスとグループ非同期 1 インターフェイスを設定しています。

PPP レベルでの機能向上を可能にする(PPP マルチリンク、圧縮など)ため、LNS の該当するインターフェイスや仮想テンプレート 1 にこれらの機能を追加する必要があります。

重要: ダイヤラ 1 インターフェイスとグループ非同期 1 インターフェイスで定義したすべての PPP オプションは、必ず LNS の仮想テンプレート 1 で設定する必要があります。

仮想テンプレート 1 は、LAC とクライアント間でネゴシエートされた LCP オプションの「コピー」を受信します。LAC とクライアント間でネゴシエートされたオプションが仮想テンプレート 1 で設定されていない場合、LNS は VPDN セッションをクリアします。ただし、LNS にクライアントとの LCP の再ネゴシエートを許可するためには、VPDN グループ内で lcp renegotiation always コマンドか、lcp renegotiation on-mismatch コマンドを設定する必要があります。

注 2: デフォルトでは、LAC と LNS は、L2TP 交換パケットで自分のホスト名を使用します。この動作を変更するには、vpdn グループ内で local name コマンドを定義します。LNS の設定例を次に示します。

   vpdn-group VPDN 
     accept-dialin 
     protocol l2tp 
     virtual-template 1 
     terminate-from hostname LAC 
     local name LNS-cental 
  

確認

この項では、設定が正しく動作することを確認するために使用できる情報を提供します。

特定の show コマンドは、Output Interpreter ツール登録ユーザのみ)でサポートされています。このツールを使用すると show コマンドの出力を分析できます。

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

  • show vpdn tunnel - すべてのアクティブな L2F と L2TP トンネルに関する情報が要約形式で表示されます。
  • show caller ip - 入力した IP アドレスの発信者情報の要約が表示されます。

トラブルシューティング

この項では、設定のトラブルシューティングに役立つ情報を説明します。

トラブルシューティングのためのコマンド

注:debug コマンドを使用する前に、「debug コマンドに関する重要な情報」を参照してください。

LAC 側:

  • debug vpdn event - VPDN に関する通常のトンネル確立またはシャットダウンの一部である、L2TP エラーとイベントを表示します。
  • debug vpdn l2x-event - 12x に関する通常のトンネル確立またはシャットダウンの一部であるイベントに関するメッセージを表示します。
  • debug vpdn l2x-error - l2x の確立や通常の動作を妨げる l2x プロトコル エラーを表示します。
  • debug ppp negotiation - debug ppp コマンドにより、PPP スタートアップ中(このとき PPP オプションがネゴシエートされます)に送信された PPP パケットを表示させます。
  • debug isdn q931 - ローカル ルータ(ユーザ側)とネットワーク間の ISDN ネットワーク接続(レイヤ 3)のコールの確立と解放に関する情報を表示します。
  • debug modem - アクセス サーバのモデム回線アクティビティを表示します。

LNS 側:

  • debug vpdn event
  • debug vpdn l2x-event
  • debug vpdn l2x-error
  • debug vtemplate - 仮想アクセス インターフェイスが仮想テンプレートから複製されたときから、コールが終了して仮想アクセスインターフェイスがダウンするまでの、仮想アクセス インターフェイスの複製情報を表示します。
  • debug ppp negotiation

次に、クライアント UserISDN@cisco.com からの ISDN コールを示します。

LAC 上の debug コマンド

LAC は、番号 8101 からの ISDN コールを受信します。

   LAC# 
     *Feb 1 14:45:09.684: ISDN Se0:15: RX <- SETUP pd = 8 callref = 0x3D03 
     *Feb 1 14:45:09.688: Sending Complete 
     *Feb 1 14:45:09.688: Bearer Capability i = 0x8890 
     *Feb 1 14:45:09.688: Channel ID i = 0xA18387 
     *Feb 1 14:45:09.688: Calling Party Number i = 0xA1, '8101', Plan:ISDN, 
      Type:National    
     *Feb 1 14:45:09.688: Called Party Number i = 0x81, '214', Plan:ISDN, 
      Type:Unknown    
     *Feb 1 14:45:09.692: %LINK-3-UPDOWN: Interface Serial0:6, 
      changed state to up    
     *Feb 1 14:45:09.692: Se0:6 PPP: Treating connection as a callin 
     *Feb 1 14:45:09.692: Se0:6 PPP: Phase is ESTABLISHING, Passive Open 
      [0 sess, 0 load] 
     *Feb 1 14:45:09.692: Se0:6 LCP: State is Listen 
     *Feb 1 14:45:09.696: ISDN Se0:15: TX -> CALL_PROC pd = 8 callref = 0xBD03    
     *Feb 1 14:45:09.696: Channel ID i = 0xA98387 
     *Feb 1 14:45:09.696: ISDN Se0:15: TX -> CONNECT pd = 8 callref = 0xBD03 
     *Feb 1 14:45:09.696: Channel ID i = 0xA98387
     ! -- LAC が RX <- CONNECT_ACK を受信すると、
     ! -- ただちに ISDN フェーズが終了し、B チャネルが確立します。
     *Feb 1 14:45:09.752: ISDN Se0:15: RX <- CONNECT_ACK pd = 8 callref = 0x3D03    
     *Feb 1 14:45:09.752: ISDN Se0:15: CALL_PROGRESS: CALL_CONNECTED call id
     0x90, bchan 6, dsl 0
     ! -- PPP で LCP フェーズが開始されます。認証プロトコルとその他の LCP 
     ! -- オプション(圧縮、マルチリンクなど)がネゴシエートされます。
     ! -- 次の debug では、CHAP だけがネゴシエートされます。
     *Feb 1 14:45:09.844: Se0:6 LCP: I CONFREQ [Listen] id 179 len 10 
     *Feb 1 14:45:09.844: Se0:6 LCP: MagicNumber 0x5B90B785 (0x05065B90B785) 
     *Feb 1 14:45:09.844: Se0:6 LCP: O CONFREQ [Listen] id 1 len 15 
     *Feb 1 14:45:09.844: Se0:6 LCP: AuthProto CHAP (0x0305C22305) 
     *Feb 1 14:45:09.844: Se0:6 LCP: MagicNumber 0x1A9DC8A5 (0x05061A9DC8A5) 
     *Feb 1 14:45:09.844: Se0:6 LCP: O CONFACK [Listen] id 179 len 10 
     *Feb 1 14:45:09.844: Se0:6 LCP: MagicNumber 0x5B90B785 (0x05065B90B785) 
     *Feb 1 14:45:09.876: Se0:6 LCP: I CONFACK [ACKsent] id 1 len 15 
     *Feb 1 14:45:09.876: Se0:6 LCP: AuthProto CHAP (0x0305C22305) 
     *Feb 1 14:45:09.876: Se0:6 LCP: MagicNumber 0x1A9DC8A5 (0x05061A9DC8A5) 
     *Feb 1 14:45:09.876: Se0:6 LCP: State is Open 
     *Feb 1 14:45:09.876: Se0:6 PPP: Phase is AUTHENTICATING, by this end 
      [0 sess, 0 load]
     ! -- LAC はクライアントに CHAP チャレンジを送信します。
     *Feb 1 14:45:09.876: Se0:6 CHAP: O CHALLENGE id 1 len 24 from "LAC".
     ! -- LAC は、UserISDN@cisco.com というユーザ名が付いたクライアントから 
     ! -- CHAP 応答を受信します。.
     *Feb 1 14:45:09.924: Se0:6 CHAP: I RESPONSE id 1 len 39 
      from "UserISDN@cisco.com"
     ! -- LAC は、UserISDN@cisco.com が VPDN クライアントかどうかをチェックします。
     ! -- ドメイン  cisco.com は vpdn グループ GroupCisco 内で設定されているため、
     ! -- UserISDN@cisco.com は VPDN クライアントです。LAC は、
     ! -- ドメイン名 cisco.com が存在する vpdn グループ内で 
     ! -- VPDN パラメータを取得します。
     *Feb 1 14:45:09.924: Se0:6 PPP: Phase is FORWARDING [0 sess, 0 load] 
     *Feb 1 14:45:09.924: Se0:6 VPDN: Got DNIS string 214 
 
     *Feb 1 14:45:09.924: Se0:6 VPDN: Looking for tunnel -- cisco.com -- 
     *Feb 1 14:45:09.928: Se0:6 VPDN/RPMS/GroupCisco: 
      Got tunnel info for cisco.com    
     *Feb 1 14:45:09.928: Se0:6 VPDN/RPMS/GroupCisco: LAC 
     *Feb 1 14:45:09.928: Se0:6 VPDN/RPMS/GroupCisco: l2tp-busy-disconnect yes 
     *Feb 1 14:45:09.928: Se0:6 VPDN/RPMS/GroupCisco: IP 10.48.74.35 
     *Feb 1 14:45:09.928: Se0:6 VPDN/GroupCisco: curlvl 1 Address 0: 10.48.74.35, 
     priority 1 
     *Feb 1 14:45:09.928: Se0:6 VPDN/GroupCisco: 
      Select non-active address 10.48.74.35, 
     priority 1 
     *Feb 1 14:45:09.928: Se0:6 VPDN: Find LNS process created 
     *Feb 1 14:45:09.928: Tnl 2027 L2TP: SM State idle
     ! -- トンネルを確立するため、LAC は Start Control Connection Request(SCCRQ)を  
     ! -- LNS に送信します。
     ! -- パケットには CHAP チャレンジが 1 つ含まれています。
     *Feb 1 14:45:09.928: Tnl 2027 L2TP: O SCCRQ 
     *Feb 1 14:45:09.928: Tnl 2027 L2TP: Tunnel state change from idle to 
      wait-ctl-reply    
     *Feb 1 14:45:09.928: Tnl 2027 L2TP: SM State wait-ctl-reply 
     *Feb 1 14:45:09.928: Se0:6 VPDN: Forward to address 10.48.74.35 
     *Feb 1 14:45:09.928: Se0:6 VPDN: Pending 
     *Feb 1 14:45:09.932: Se0:6 VPDN: Process created
     ! -- LAC は、LNS から Start Control Connection Reply(SCCRP)を受信します。
     ! -- パケットには、自分のチャレンジへの応答と、LNS からの別の CHAP チャレンジとが、
     ! -- 含まれています。
     *Feb 1 14:45:09.956: Tnl 2027 L2TP: I SCCRP from LNS 
     *Feb 1 14:45:09.956: Tnl 2027 L2TP: Got a challenge from remote peer, LNS 
     *Feb 1 14:45:09.956: Tnl 2027 L2TP: Got a response from remote peer, LNS 
     *Feb 1 14:45:09.956: Tnl 2027 L2TP: Tunnel Authentication success 
     *Feb 1 14:45:09.956: Tnl 2027 L2TP: Tunnel state change from wait-ctl-reply 
     to established
     ! -- LAC は、Start Control Connection Connected(SCCCN)を LNS へ送信します。
     ! -- LNS のチャレンジへの応答は、このパケットに含まれています。 
     *Feb 1 14:45:09.956: Tnl 2027 L2TP: O SCCCN to LNS tnlid 11514 
     *Feb 1 14:45:09.956: Tnl 2027 L2TP: SM State established 
     *Feb 1 14:45:09.956: Se0:6 VPDN: Forwarding... 
     *Feb 1 14:45:09.956: Se0:6 VPDN: Bind interface direction=1 
     *Feb 1 14:45:09.956: Tnl/Cl 2027/18 L2TP: Session FS enabled 
     *Feb 1 14:45:09.956: Tnl/Cl 2027/18 L2TP: Session state change from idle to 
     wait-for-tunnel 
     *Feb 1 14:45:09.960: Se0:6 Tnl/Cl 2027/18 L2TP: Create session 
     *Feb 1 14:45:09.960: Tnl 2027 L2TP: SM State established
     ! -- トンネルが確立します。LAC は、ユーザ UserISDN@cisco.com に対するセッションを確立します。
     ! -- さらに、そのセッションに対して Incoming Call ReQuest(ICRQ)を送信します。
     *Feb 1 14:45:09.960: Se0:6 Tnl/Cl 2027/18 L2TP: O ICRQ to LNS 11514/0 
     *Feb 1 14:45:09.960: Se0:6 Tnl/Cl 2027/18 L2TP: Session state change from 
     wait-for-tunnel to wait-reply 
     *Feb 1 14:45:09.960: Se0:6 VPDN: UserISDN@cisco.com is forwarded
     ! -- Incoming Call Reply(ICRP)(debug では表示されません)を受信した後、
     ! -- LAC は Incoming Call Connected.(ICCN)を送信します。VPDN セッションが確立されます。
     ! -- 次に LAC は、クライアントとネゴシエートした情報(LCP オプション)を LNS に転送します。
     ! -- このとき、クライアントのユーザ名と CHAP パスワードもあわせて転送されます。
     *Feb 1 14:45:10.008: Se0:6 Tnl/Cl 2027/18 L2TP: O ICCN to LNS 11514/6 
     *Feb 1 14:45:10.008: Se0:6 Tnl/Cl 2027/18 L2TP: Session state change from 
     wait-reply to established 
     *Feb 1 14:45:10.960: %LINEPROTO-5-UPDOWN: Line protocol on Interface 
     Serial0:6, changed state to up 
     *Feb 1 14:45:15.692: %ISDN-6-CONNECT: 
      Interface Serial0:6 is now connected to 8101
     UserISDN@cisco.com 
     LAC#

LNS 上の debug コマンド

LNS は、LAC から SCCRQ を受信します。

   LNS# 
     *Mar 1 02:13:06.499: L2TP: I SCCRQ from LAC tnl 2027 
     *Mar 1 02:13:06.507: Tnl 11514 L2TP: Got a challenge in SCCRQ, LAC 
     *Mar 1 02:13:06.511: Tnl 11514 L2TP: New tunnel created for remote LAC, address
     10.48.75.7
     ! -- LNS は、LAC のチャレンジに対する CHAP  応答と、CHAP  チャレンジを含む SCCRP とで
     ! -- 応答します。
     *Mar 1 02:13:06.515: Tnl 11514 L2TP: O SCCRP to LAC tnlid 2027 
     *Mar 1 02:13:06.523: Tnl 11514 L2TP: Tunnel state change from idle to 
      wait-ctl-reply
     ! -- LNS は SCCCN を受信します。
     *Mar 1 02:13:06.535: Tnl 11514 L2TP: I SCCCN from LAC tnl 2027 
     *Mar 1 02:13:06.539: Tnl 11514 L2TP: Got a Challenge Response in SCCCN from LAC 
     *Mar 1 02:13:06.543: Tnl 11514 L2TP: Tunnel Authentication success 
     *Mar 1 02:13:06.543: Tnl 11514 L2TP: Tunnel state change from wait-ctl-reply 
     to established 
     *Mar 1 02:13:06.547: Tnl 11514 L2TP: SM State established
     ! -- トンネルが確立します。LNS は、ICRQ を受信し、セッションを確立します。
     *Mar 1 02:13:06.555: Tnl 11514 L2TP: I ICRQ from LAC tnl 2027 
     *Mar 1 02:13:06.559: Tnl/Cl 11514/6 L2TP: Session FS enabled 
     *Mar 1 02:13:06.563: Tnl/Cl 11514/6 L2TP: Session state change from idle 
      to wait-connect 
     *Mar 1 02:13:06.567: Tnl/Cl 11514/6 L2TP: New session created
     ! -- LNS は Incoming Call Reply(ICRP)で応答します。
     *Mar 1 02:13:06.567: Tnl/Cl 11514/6 L2TP: O ICRP to LAC 2027/18
     ! -- LNS は Incoming Call coNnected(ICCN)を受信します。VPDN セッションが確立します。
     ! -- 次に LNS はクライアントのユーザ名と CHAP パスワードと一緒に
     ! -- LCP レイヤを受信します。
     ! -- 仮想テンプレート 1 から仮想アクセスが複製されます。
     *Mar 1 02:13:06.583: Tnl/Cl 11514/6 L2TP: I ICCN from LAC tnl 2027, cl 18    
     *Mar 1 02:13:06.591: Tnl/Cl 11514/6 L2TP: Session state change from 
     wait-connect to established 
     *Mar 1 02:13:06.591: Vt1 VTEMPLATE: Unable to create and clone vaccess 
     *Mar 1 02:13:06.595: Vi1 VTEMPLATE: Reuse Vi1, recycle queue size 1 
     *Mar 1 02:13:06.595: Vi1 VTEMPLATE: Hardware address 0000.0c4a.4314 
     *Mar 1 02:13:06.599: Vi1 VPDN: Virtual interface created for UserISDN@cisco.com    
     *Mar 1 02:13:06.603: Vi1 PPP: Phase is DOWN, Setup [0 sess, 0 load] 
     *Mar 1 02:13:06.603: Vi1 VPDN: Clone from Vtemplate 1 filterPPP=0 blocking 
     *Mar 1 02:13:06.607: Vi1 VTEMPLATE: Has a new cloneblk vtemplate, 
      now it has vtemplate
     *Mar 1 02:13:06.611: Vi1 VTEMPLATE: ************* CLONE VACCESS1
     ***************** 
     *Mar 1 02:13:06.615: Vi1 VTEMPLATE: Clone from Virtual-Template1 
     interface Virtual-Access1 
     default ip address 
     no ip address 
     encap ppp 
     ip unnumbered Loopback1 
     end
     *Mar 1 02:13:07.095: %LINK-3-UPDOWN: Interface Virtual-Access1, 
      changed state to up 
     *Mar 1 02:13:07.099: Vi1 PPP: Using set call direction 
     *Mar 1 02:13:07.103: Vi1 PPP: Treating connection as a callin 
     *Mar 1 02:13:07.103: Vi1 PPP: Phase is ESTABLISHING, Passive Open 
      [0 sess, 0 load] 
     *Mar 1 02:13:07.107: Vi1 LCP: State is Listen 
     *Mar 1 02:13:07.111: Vi1 VPDN: Bind interface direction=2 
     *Mar 1 02:13:07.111: Vi1 LCP: I FORCED CONFREQ len 11 
     *Mar 1 02:13:07.115: Vi1 LCP: AuthProto CHAP (0x0305C22305) 
     *Mar 1 02:13:07.119: Vi1 LCP: MagicNumber 0x1A9DC8A5 (0x05061A9DC8A5) 
     *Mar 1 02:13:07.119: Vi1 VPDN: PPP LCP accepted rcv CONFACK 
     *Mar 1 02:13:07.123: Vi1 LCP: I FORCED CONFACK len 6 
     *Mar 1 02:13:07.127: Vi1 LCP: MagicNumber 0x5B90B785 (0x05065B90B785) 
     *Mar 1 02:13:07.131: Vi1 VPDN: PPP LCP accepted sent CONFACK
     ! -- LNS はユーザを認証します。LNS は LAC から CHAP チャレンジと応答を受信した後、
     ! -- (debug で混乱を招く可能性があるため)
     ! -- 新しい CHAP チャレンジを送信しません。
     *Mar 1 02:13:07.131: Vi1 PPP: Phase is AUTHENTICATING, by this end 
      [0 sess, 0 load] 
     *Mar 1 02:13:07.135: Vi1 CHAP: O CHALLENGE id 2 len 24 from "LNS"    
     *Mar 1 02:13:07.143: Vi1 CHAP: I RESPONSE id 1 len 39 from "UserISDN@cisco.com"    
     *Mar 1 02:13:07.151: Vi1 CHAP: O SUCCESS id 1 len 4 
     *Mar 1 02:13:07.155: Vi1 PPP: Phase is UP [0 sess, 0 load]
     ! -- IPCP フェーズが開始されます。
     ! -- IP アドレス 12.12.12.2 がクライアントに割り当てられます。
     *Mar 1 02:13:07.159: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10 
     *Mar 1 02:13:07.163: Vi1 IPCP: Address 12.12.12.1 (0x03060C0C0C01) 
     *Mar 1 02:13:07.215: Vi1 IPCP: I CONFREQ [REQsent] id 34 len 10 
     *Mar 1 02:13:07.219: Vi1 IPCP: Address 0.0.0.0 (0x030600000000) 
     *Mar 1 02:13:07.223: Vi1 IPCP: Pool returned 12.12.12.2 
     *Mar 1 02:13:07.227: Vi1 IPCP: O CONFNAK [REQsent] id 34 len 10 
     *Mar 1 02:13:07.231: Vi1 IPCP: Address 12.12.12.2 (0x03060C0C0C02) 
     *Mar 1 02:13:07.235: Vi1 IPCP: I CONFACK [REQsent] id 1 len 10 
     *Mar 1 02:13:07.239: Vi1 IPCP: Address 12.12.12.1 (0x03060C0C0C01) 
     *Mar 1 02:13:07.271: Vi1 IPCP: I CONFREQ [ACKrcvd] id 35 len 10 
     *Mar 1 02:13:07.275: Vi1 IPCP: Address 12.12.12.2 (0x03060C0C0C02) 
     *Mar 1 02:13:07.279: Vi1 IPCP: O CONFACK [ACKrcvd] id 35 len 10 
     *Mar 1 02:13:07.283: Vi1 IPCP: Address 12.12.12.2 (0x03060C0C0C02) 
     *Mar 1 02:13:07.287: Vi1 IPCP: State is Open 
     *Mar 1 02:13:07.295: Vi1 IPCP: Install route to 12.12.12.2
     ! -- 仮想アクセスが確立します。.
     *Mar 1 02:13:08.159: %LINEPROTO-5-UPDOWN: Line protocol on Interface
     Virtual-Access1, changed state to up 
     LNS#

show コマンド

LAC#show vpdn tunnel
  L2TP Tunnel Information Total tunnels 1 sessions 1
  LocID RemID Remote Name State Remote Address Port Sessions 
     36556 45655 LNS est 10.48.74.35 1701 1
  %No active L2F tunnels
  %No active PPTP tunnels
  %No active PPPoE tunnels 
  LAC# 
  
LNS#show vpdn tunnel
  L2TP Tunnel Information Total tunnels 1 sessions 1
  LocID RemID Remote Name State Remote Address Port Sessions 
     45655 36556 LAC est 10.48.75.7 1701 1
  %No active L2F tunnels
  %No active PPTP tunnels
  %No active 
  
   LNS#show caller ip 
     Line User IP Address Local Number Remote Number <-> 
     Vi1 UserISDN@cisco.com \ 
     12.12.12.2 214 8101 in 
     LNS# 


関連情報


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 19141