IP : IP ルーテッド プロトコル

Catalyst 3550 シリーズ スイッチの設定例を使ったポリシー ルーティング

2004 年 4 月 9 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 11 月 16 日) | フィードバック

目次

概要
前提条件
     要件
     使用するコンポーネント
     表記法
設定
     ネットワーク ダイアグラム
     設定
確認
トラブルシューティング
     トラブルシューティングのためのコマンド
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書では、Catalyst 3550 シリーズ スイッチにおけるポリシー ルーティングの設定例について説明します。ポリシー ルーティングを設定する前に、Switch Database Management(SDM; スイッチ データベース管理)テンプレートを修正して、スイッチが 144 ビット レイヤ 3 Ternary Content Addressable Memory(TCAM)をサポートできるようにする必要があります。SDM の詳細については、『Catalyst 3550 シリーズ スイッチの Switching Database Manager の説明と設定』を参照してください。

注: Catalyst 3550 では、使用可能な route-maps コマンドに制限があります。

前提条件

要件

この設定を試す前に、次の項目に関して精通しているか確認してください。

使用するコンポーネント

この文書の情報は、次のソフトウェアとハードウェアのバージョンに基づいています。

  • Cisco IOS(R) ソフトウェア リリース 12.1.19-EA1a

  • Cisco Catalyst 3550

この文書の情報は、特定のラボ環境にあるデバイスに基づいて作成されています。この文書内で使用されているデバイスはすべて、クリアな状態(デフォルト)から設定作業を始めています。 対象のネットワークが実稼動中である場合には、すべてのコマンドによる潜在的な影響について確実に理解しておく必要があります。

表記法

文書表記の詳細は、「シスコ テクニカル ティップスの表記法」を参照してください。

設定

この項では、この文書で説明する機能を設定するための情報を提供します。

注: この文書で使用されているコマンドの詳細を調べるには、Command Lookup ツールを使用してください(登録ユーザ専用)。

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ポリシー ルーティングをイネーブルにする前に、グローバル コンフィギュレーション モードで次のいずれかのコマンドを設定し、設定を記述し、スイッチをリロードする必要があります。

  • sdm prefer extended-match

  • sdm prefer access extended-match

  • sdm prefer routing extended-match

CAT3550(config)# access-list 10 permit 20.20.20.0 0.0.0.255
   CAT3550(config)# route-map pbr permit 10
   CAT3550(config-route-map)# match ip address 10
   CAT3550(config-route-map)# set ip next-hop 12.12.12.12
   CAT3550(config)# int vlan 3
   CAT3550(config-if)# ip policy route-map pbr
   CAT3550(config-if)#
   06:12:31: %L3TCAM-3-SIZE_CONFLICT: PBR requires enabling extended routing
   CAT3550# show run int vlan 3
   Building configuration...
   Current configuration : 60 bytes
   !
   interface Vlan3
   ip address 55.55.55.1 255.255.255.0
   
   !--- 処理されないコマンド。SDM をイネーブルにする必要があります。
   
   end
   CAT3550# conf t
   Enter configuration commands, one per line. End with CNTL/Z.
   CAT3550(config)# sdm prefer extended-match
   Changes to the running SDM preferences have been stored, but cannot take effect 
   until the next reload.
   Use 'show sdm prefer' to see what SDM preference is currently active.
   CAT3550(config)# end
   CAT3550# write
   06:14:11: %SYS-5-CONFIG_I: Configured from console by console
   Building configuration...
   [OK] 
   ltd-1-2# reload
   Proceed with reload? [confirm]

サポート対象外のコマンドを認識しておく必要があります。この設定が存在する場合は、『サポート対象外の route map コマンド』を参照してください。

!
   access-list 10 permit 20.20.20.0 0.0.0.255
   route-map pbr permit 10
   match ip address 10
   set ip default next-hop 12.12.12.12
   !

インターフェースで、ポリシー ルート マップを設定しようとすると、次のエラー メッセージが生成されます。

CAT3550(config)# int vlan 3
   CAT3550(config-if)# ip policy route-map pbr
   CAT3550(config-if)# end
   CAT3550#
   00:02:29: %PBR-3-UNSUPPORTED_RMAP: Route-map pbr not supported for Policy-Based Routing
   

ネットワーク ダイアグラム

この文書では、次のネットワーク設定を使用します。

cat3550pbr_01.jpg

設定

この文書では次の設定を使用します。

この設定では、トラフィック ソースを 20.20.20.X(アクセス リスト 10)から取得し、取得したトラフィック ソースを 30.30.30.2 に送信します。この設定により、10.10.10.2 に設定されていたデフォルト ゲートウェイが上書きされます。

CAT3550(Cisco Catalyst 3550)

CAT3550# show running-config 
   Building configuration...
   .
   .
   !
   interface Vlan1
    ip address 10.10.10.1 255.255.255.0
   !
   interface Vlan2
    ip address 20.20.20.1 255.255.255.0
    ip policy route-map pbr
   !
   interface Vlan3
    ip address 30.30.30.1 255.255.255.0
   !
   ip route 0.0.0.0 0.0.0.0 10.10.10.2
   ip classless
   ip http server
   !
   !
   access-list 10 permit 20.20.20.0 0.0.0.255
   route-map pbr permit 10
    match ip address 10
    set ip next-hop 30.30.30.2
   !
   .
   !
   end

確認

現在のところ、この設定を確認する手順はありません。

トラブルシューティング

この項では、設定のトラブルシューティングに役立つ情報を説明します。

トラブルシューティングのためのコマンド

特定の show コマンドは、Output Interpreter ツール登録ユーザのみ)でサポートされています。このツールを使用すると show コマンドの出力を分析できます。

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

注: debug コマンドを使用する前に、「debug コマンドに関する重要な情報」を参照してください。

  • debug ip policy - 「ポリシー ルーティングされた」、または「ポリシー拒否された」パケットを表示します。debug ip policy コマンドの出力例を次に示します。

  *Dec 5 13:33:23.607: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4, len 100, policy match
     *Dec 5 13:33:23.607: IP: route map pbr, item 10, permit
     *Dec 5 13:33:23.607: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4 (Vlan3),len 100, policy routed
     *Dec 5 13:33:23.607: IP: Vlan2 to Vlan3 30.30.30.1
     *Dec 5 13:33:23.707: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4, len 100, policy match
     *Dec 5 13:33:23.707: IP: route map pbr, item 10, permit
     *Dec 5 13:33:23.707: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4 (Vlan3),len 100, policy routed
     *Dec 5 13:33:23.707: IP: Vlan2 to Vlan3 30.30.30.1
     *Dec 5 13:33:23.847: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4, len 100, policy match
     *Dec 5 13:33:23.847: IP: route map pbr, item 10, permit

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 47900