ダイヤルとアクセス : 総合デジタル通信網(ISDN)、個別線信号方式(CAS)

設定例: 基本 ISDN 設定

2003 年 4 月 29 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2014 年 9 月 6 日) | 英語版 (2014 年 8 月 12 日) | フィードバック

概要

この文書では、簡単な Integrated Services Digital Network(ISDN; サービス統合デジタル ネットワーク)の設定例を示し、一部の設定コマンドについて説明します。 コマンドの詳細については、「ルータ製品コマンド リファレンス」を参照してください。

次の例では、Cisco 3103(1E/1BRI)が使われています。 Cisco 3103 は、Dial-on-Demand Routing(DDR; ダイヤルオンデマンド ルーティング)リンクを介して IP をルーティングするように設定されています。 スイッチ タイプとは、スイッチ上で実行されている ISDN ソフトウェアを指すもので、メーカーやモデルを指すものではありません。 この文書を理解するには、IP ルーティングの基本を理解している必要があります。 詳細については、「新規ユーザのための IP の基本事項」のテクニカル ティップスを参照してください。

設定例

この例では、スタティック ルーティングを使用しています。また、この例に関係のある必要コマンドだけが取り上げられています。 いずれのルータでも接続を開始することが可能で、すべての IP パケットが「対象パケット」です。これはすべてのパケットによってダイヤルが発呼され、DDR アイドル タイマーがリセットされることを意味します。 ルーティングがアップデートされると、リンクが無制限にアップされ続け、使用料金の請求が発生するため、この例では、ルーティング プロトコルは設定されていません。 この設定は、IP が唯一の使用プロトコルである家庭やリモート オフィスに適しています。

リモート ルータの設定 メイン ルータの設定
  hostname branch1  
  !
  username main password secret1
  !
  isdn switch-type basic-dms100
  !
  interface Ethernet 0 
  ip address 131.108.64.190
       255.255.255.0
  !
  interface BRI 0
  encapsulation PPP
  ip address 131.108.157.1
       255.255.255.0
  isdn spid1 415988488501 9884885
  isdn spid2 415988488602 9884886
  ppp authenticate chap
  dialer idle-timeout 300
  dialer map IP 131.108.157.2 name
       main 4883
  dialer-group 1
  !
  ip route 131.108.0.0 255.255.0.0
       131.108.157.2
  ip route 0.0.0.0 0.0.0.0 131.108.157.2
  !
  dialer-list 1 protocol ip permit
  hostname main
  !
  username branch1 password secret1
  username branch2 password secret2
  !
  isdn switch-type basic-dms100
  !
  interface Ethernet 0
  ip address 131.108.38.1
       255.255.255.0
  !
  interface BRI 0
  encapsulation PPP
  ip address 131.108.157.2
       255.255.255.0
  isdn spid1 415988488201 9884882
  isdn spid2 415988488302 9884883
  ppp authenticate chap
  dialer idle-timeout 300
  dialer map IP 131.108.157.1 name
       branch1 4885
  dialer-group 1
  !
  ip route 131.108.64.0
       255.255.255.0 131.108.157.1
  !
  dialer-list 1 prot ip list 110
  access-list 110 deny igrp any any
  access-list 110 permit ip any any
  

主要な設定パラメータ

hostname 名前

ルータのホスト名は、Challenge Handshake Authentication Protocol(CHAP)メッセージを送信する場合に、あるルータを別のルータに対して特定するために使用します。

username 名前 password シークレット

username コマンドは、別のルータによるチャレンジを受けた場合に CHAP シークレット メッセージを特定するために必要です。 対話を行う 2 台のルータは、同じパスワードを共有する必要があります。

isdn switch-type スイッチタイプ
isdn spid1 spid 番号 [ldn], isdn spid2 spid 番号 [ldn]

このルータは、Northern Telecom DMS-100 スイッチとの接続を確立します。 ステーションの Service Profile Identifier(SPID; サービス プロファイル識別子)は 15988488501 と 415988488602 です。 これらの番号はスイッチ上で設定され、ローカル サービス プロバイダーによってユーザに与えられます。 9884885 と 9884886 は、2 チャンネル用の通常の電話番号です。 これは通常 Local Directory Number(LDN; 市内電話番号)と呼ばれています。 isdn spid1isdn spid2 コマンドは、ポイントツーポイント操作用に設定された AT&T 5ESS スイッチでは必要ありませんが、National ISDN-1(NI1)ソフトウェアで必要です。 この文書でのスイッチ タイプとは、スイッチ上で実行されている ISDN ソフトウェアを指すもので、メーカーやモデルを指すものではありません。

必要な ISDN 固有コマンドはこれだけです。 この設定の残りは、実際には Dial-on-Demand Routing(DDR; ダイヤルオンデマンド ルーティング)の設定であり、他の種類の DDR インターフェイス(インバンド、非同期など)に適用されます。

dialer-group グループ番号
dialer-list 発信者グループ protocol プロトコル名 {permit | deny}
dialer-list 発信者グループ protocol プロトコル名 list アクセス リスト番号

これは「対象」パケット タイプを定義するために必要です。 対象パケットは、ダイヤリング シーケンスをアクティブにし、「アイドル タイムアウト」タイマーをリセットするパケットです。 この例では、一方の側ではすべての IP パケットが対象パケットであり、2 つの形式のコマンドを示すため、もう一方でアクセス リストが使用されます。 ブランチ 1 では、すべての IP パケットが対象パケットですが、メイン ルータでは、Interior Gateway Routing Protocol(IGRP)パケット以外のパケットが対象パケットとなります。

ppp authentication chap

このインターフェイスで CHAP 認証が使われることを指定します。 詳細については、dialer map コマンドの説明を参照してください。

dialer idle-timeout

このコマンドによって、ルータは、設定した時間の間に対象トラフィックがなかったコールを切断するようになります。 アイドル タイマーをリセットするのは発信パケットだけです。

dialer map プロトコル name リモート名ブロードキャスト speed 56 電話番号

ダイヤラ マップは、さまざまな場合に接続可能な、複数のリモート サイトの識別に使用します。 サイトおよび使用プロトコルごとに 1 マップが必要です。 リモート名は、もう一方のルータのホスト名です。 ブロードキャスト フラグは、指定したプロトコルのルーティング アップデートなどのブロードキャスト パケットが、指定した側に送信されるかどうかを指定します。 この例では、この設定はオフです。 speed パラメータのデフォルト値は 64 です。エンドツーエンド ISDN でないネットワークを介してコールを正常に終了するためには、このパラメータを 56 に設定する必要がある場合があります。 電話番号は、発呼、または発信番号の配信を行うネットワークでコールの認証を行う場合に使用します。 この番号は、「受信専用」ダイヤラ マップを作成するためには、省略することもできます。 この例では、4 桁のオフィス間内線番号を示しますが、任意の長さの有効な電話番号が正常に動作します。

ルータがインターフェイスでのカプセル化またはパケットの送信を正常に行うために必要なネットワーク レイヤ - リンク レイヤ マッピングが、ダイヤラ マップによって提供されます。 この例では、ダイヤラ マップには、発信先の電話番号と、もう一方のルータの名前が含まれています。 この名前は、CHAP を使って発信先のルータを特定するために必要不可欠です。 CHAP によって一部のセキュリティも提供されますが、この基本設定では CHAP は主として発信先ルータの識別に使われています。 一般的なケースでは、CHAP は発信先ルータの識別に必要です。これは発信先番号の配信が常に可能とは限らないためです。

ip route ネットワーク [マスク] {アドレス | インターフェイス} [距離]

パケットを適切なネクスト ホップにルーティングするために必要なスタティック ルーティング情報を提供します。 DDR インターフェイスへのパケットのルーティングによってデマンドが生成されます。これは、その名前が示すように、DDR の必要不可欠な部分です。

要約

これは、ISDN インターフェイスを介して DDR を実行している 2 台のルータ間でスタティック ルーティングを使用している場合に、IP トラフィックに対して使用可能なシンプルな設定です。 すべてのユニキャスト IP パケットによってダイヤリングのトリガが可能で、アイドル タイマーがリセットされます。 CHAP は発呼側ルータの識別に使用され、一般的なケースでは CHAP が必要です。

関連情報


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 14221