IP : IP アドレッシング サービス

DHCP サーバ オプションのダイナミックな設定

2009 年 10 月 29 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 10 月 12 日) | フィードバック

目次


概要

DHCP により、再使用可能な IP アドレスが自動的に DHCP クライアントに割り当てられるようになります。このドキュメントは、Domain Name System(DNS; ドメイン ネーム システム)や Windows Internet Name Service(WINS; Windows インターネット ネーム サービス)アドレスなどの DHCP オプションを設定する方法を例示して、Customer Premises Equipment(CPE; 宅内装置)の背後にあるローカル クライアントからの DHCP 要求に対応しています。

以前は、ネットワーク管理者はこの機能が有効にされているすべてのデバイスで、Cisco IOS(R) DHCP サーバを手動で設定する必要がありました。ルータが配置された後に、それぞれの場所に行って修正を加えるので、手間、時間、および費用がかかります。

このため、Cisco IOS DHCP サーバが拡張され、構成情報が自動的にアップデートされるようになりました。ネットワーク管理者は、1 つ以上の中央集中型 DHCP サーバを設定することで、DHCP プール内の特定の DHCP オプションをアップデートできます。これらのオプション パラメータを、リモート サーバから中央のサーバに要求したり、リモート サーバにインポートしたりできます。



前提条件

要件

このドキュメントの読者は、次の項目の知識を持っていることが推奨されます。

  • DHCP

  • ドメイン ネーム システム(DNS)

  • Windows インターネット ネーム サービス(WINS)



使用するコンポーネント

この設定は、次のバージョンのソフトウェアとハードウェアを使用して作成およびテストされています。

  • Cisco IOS(R) ソフトウェア リリース 12.2(27)

  • NM-1E で PC とクライアントに接続された 2 台の Cisco 3660 ルータ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。このドキュメントで使用するすべてのデバイスは、デフォルトの設定で作業を開始しています。対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

注:Cisco IOS DHCP サーバの機能は、Cisco IOS ソフトウェア リリース 12.0(1)T で導入されています。Cisco 1700 シリーズ ルータで使用するには、Cisco IOS(R) ソフトウェア リリース 12.0(2)T 以降が必要です。DHCP サーバ機能をサポートするルータの詳細は、『Cisco IOS DHCP サーバ』の「サポート対象プラットフォーム」セクションを参照してください。



表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。



設定

このセクションは、DNS および WINS 用の DHCP サーバ オプションの設定について説明しています。これらのサーバ オプションは「中央」のルータで設定され、「リモート」のルータがインポートします。リモートの PC またはクライアントは、これらのインポートされたオプションを DHCPACK の段階で「リモート」のルータから受け取ります。

注: このドキュメントで使用されているコマンドの詳細を調べるには、DHCP Commands または Command Lookup Tool登録ユーザ専用)を使用してください。
一部のツールについて、ゲスト登録のお客様はアクセスできない場合があることをあらかじめご了承ください。



ネットワーク ダイアグラム

このドキュメントは、次のダイヤグラムに示すネットワーク構成を使用しています。

ネットワーク構成



設定例

このドキュメントは、次の設定を使用しています。

中央のサーバ(3660)
Central# show running-config 
Building configuration...
.
.
.
ip dhcp excluded-address 10.0.0.1 10.0.0.5

!--- この範囲を DHCP クライアントに割り当てることはできません。

!
ip dhcp pool Central   
   network 10.0.0.0 255.255.255.0

! --- DHCP クライアントのネットワーク番号とマスクを指定します。
   
   domain-name Central

!--- クライアントののドメイン名を指定します。
   
   dns-server 10.0.0.2

!--- ホスト名と IP アドレスの関連付けが必要な DHCP クライアント


!--- に応答する DNS サーバを指定します。
   
   netbios-name-server 10.0.0.2

!--- Network Basic Input/Output System(NetBIOS)の


!--- WINS サーバを指定します(Microsoft DHCP クライアントの場合)。
 
!
.
.
!
interface FastEthernet0/0 
 ip address 10.0.0.1 255.255.255.0 
 duplex auto 
 speed auto
!
.
.
!
end

注:Cisco ルータを DHCP サーバとして使用する場合は、DHCP プールごとに 1 つのドメインのみ使用できます。つまり、ルータは、ドメイン名を 2 つ持つクライアントに DHCP リースを送信できません。ダイナミック プールにスタティック マッピングを混在させることはできません。混在させると、% This command may not be used with network, origin, vrf, or relay pools というエラー メッセージが表示されます。

リモート サーバ(3660)

Remote# show running-config 
Building configuration...
.
.
.
ip dhcp excluded-address 192.168.1.1

!--- この IP アドレスを DHCP クライアントに割り当てることはできません。

!
ip dhcp pool Client   
   import all

!--- DHCP オプション パラメータをデータベースにインポートします。
   
   network 192.168.1.0 255.255.255.248

! --- DHCP クライアントのネットワーク番号とマスクを指定します。

   default-router 192.168.1.1

! --- DHCP クライアントのデフォルト ゲートウェイを指定します。
    
!
.
.
!
interface FastEthernet0/0 
 ip address dhcp 
 duplex auto 
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.1.1 255.255.255.248
 duplex auto
 speed auto
!
end

service config コマンドは、boot host または boot network コマンドと組み合せて使用します。service config コマンドが入力されて、boot host または boot network コマンドで指定されたファイルから、ルータで自動的にシステム設定が行われるようにされます。

また、service config コマンドは、boot host または boot network コマンドなしでも使用できます。ホストまたはネットワークのコンフィギュレーション ファイル名を指定しない場合、ルータはデフォルトのコンフィギュレーション ファイルを使用します。デフォルトのネットワーク コンフィギュレーション ファイルは network-config です。デフォルトのホスト コンフィギュレーション ファイルは host-config であり、ここで host はルータのホスト名です。Cisco IOS ソフトウェアでこのホスト名を解決できない場合は、デフォルトのホスト コンフィギュレーション ファイルは router-config になります。

boot host コマンドは、service config コマンドと組み合せて使用します。service config コマンドがない場合、ルータは boot host コマンドを無視して、NVRAM にある構成情報を使用します。NVRAM の構成情報が無効であるか、または欠落している場合、service config コマンドが自動的に有効になります。ネットワーク サーバは、リモート ホストから 2 つのコンフィギュレーション ファイルのロードを試みます。1 つ目は、ネットワーク内のすべてのネットワーク サーバに適用されるコマンドを含んだネットワーク コンフィギュレーション ファイルです。boot network コマンドを使用して、ネットワーク コンフィギュレーション ファイルを識別します。2 つ目は、特定のネットワーク サーバに適用されるコマンドを含んだホスト コンフィギュレーション ファイルです。boot host コマンドを使用して、ホスト コンフィギュレーション ファイルを識別します。

デフォルトでは TFTP サーバを監視するようになっており、オプション 150 はクライアント側ではなくサーバ側で拒否されるため、オプション 150 が設定されていても、クライアントはブロードキャストを送信します。TFTP 以外でも、次のケースで 150 オプションが使用可能です。

  • 150 Etherboot

  • 150 GRUB コンフィギュレーション パス名

DHCP オプションは、option code ascii string tftp-server-name コマンドで設定できます。サーバに名前がなく、IP アドレスだけが設定されている場合は、option code ip ip address コマンドを使用します。



確認

このセクションは、設定が正しく機能していることを確認するために使用できる情報を提供しています。

特定の show コマンドは、アウトプットインタープリタ登録ユーザ専用)でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。
一部のツールについて、ゲスト登録のお客様はアクセスできない場合があることをあらかじめご了承ください。

  • show ip dhcp import:DHCP サーバのデータベースにインポートされたオプション パラメータを表示します。

Remote#show ip dhcp import
Address Pool Name: Client
Domain Name Server(s): 10.0.0.2
NetBIOS Name Server(s): 10.0.0.2
Domain Name Option: Central
Central#show ip dhcp server statistics
Memory usage         13906
Address pools        1
Database agents      1
Automatic bindings   1
Manual bindings      0
Expired bindings     0
Malformed messages   0

Message              Received
BOOTREQUEST          0
DHCPDISCOVER         1
DHCPREQUEST          1
DHCPDECLINE          0
DHCPRELEASE          0
DHCPINFORM           0

Message              Sent
BOOTREPLY            0
DHCPOFFER            1
DHCPACK              1
DHCPNAK              0
  • show ip dhcp binding:Cisco IOSDHCP サーバでのアドレス バインディングを表示します。

Central#show ip dhcp binding
IP address       Client-ID/Hardware address             Lease expiration            Type
10.0.0.6         0063.6973.636f.2d30.                   Apr 25 2005 12:30 AM        Automatic
                 3036.302e.3563.6634.
                 2e61.3961.382d.4574.        
                 30


トラブルシューティング

このセクションは、設定のトラブルシューティングに役立つ情報を紹介しています。



トラブルシューティングのためのコマンド

注:debug コマンドを発行する前に、『debug コマンドの重要な情報』を参照してください。

Microsoft Windows オペレーティング システムが使用されている PC またはクライアントからの ipconfig /all コマンドの出力には、DHCP によって設定された TCP/IP コンフィギュレーションの値が含まれます。DHCP オプションの詳細は、RFC 2132 を参照してください。

C:\>ipconfig /all 
  
Windows 2000 IP Configuration 
  
  Host Name . . . . . . . . . . . . : PC 
  Primary DNS Suffix . . . . . . .  : cisco.com 
  Node Type . . . . . . . . . . . . : Hybrid 
  IP Routing Enabled. . . . . . . . : No
  WINS Proxy Enabled. . . . . . . . : No 
  DNS Suffix Search List. . . . . . : cisco.com 
                                       
Ethernet adapter Local Area Connection :
         
  Connection-specific DNS Suffix . : Central 
  Description . . . . . . . . . .  : 3Com EtherLink XL 10/100 PCI TX NIC(3C905B-TX) 
  Physical Address. . . . . . . .  : 00-10-5A-86-5A-CA 
  DHCP Enabled. . . . . . . . . .  : Yes 
  Autoconfiguration Enabled . . .  : Yes 
  IP Address. . . . . . . . . . .  : 192.168.1.2 
  Subnet Mask . . . . . . . . . .  : 255.255.255.248 
  Default Gateway . . . . . . . .  : 192.168.1.1
  DHCP Server . . . . . . . . . .  : 10.0.0.6 
  DNS Servers . . . . . . . . . .  : 10.0.0.2 
  Primary WINS Server . . . . . .  : 10.0.0.2 
  Lease Obtained. . . .  . . . . . : Tuesday, April 26, 2005 6:04:29 PM 
  Lease Expires . . . . . . . .. . : Wednesday, April 27, 2005 6:04:29 PM



関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報




Document ID: 22920