ダイヤルとアクセス : ダイヤルオンデマンド ルーティング(DDR)

設定例: フローティング スタティック ルートとダイヤルオンデマンド ルーティングの使用

2004 年 2 月 20 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 9 月 15 日) | フィードバック

目次

概要
前提条件
     要件
     使用するコンポーネント
     表記法
設定
     ネットワーク ダイアグラム
     設定
確認
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書の目的は、フレームリレー回線の障害に備え、リモート サイトにダイヤルしてトラフィックを搬送できるように、ISDN の Basic Rate Interface(BRI; 基本速度インターフェイス)を設定することです。

BRI では Enhanced Interior Gateway Routing Protocol(EIGRP)は実行されません。そこでこの例では、EIGRP を通じてフレームリレー回線経由で学習した経路が喪失した場合にだけ、フローティング スタティック ルートを使用してトラフィックを BRI 経由でフォワードします。

すべてのルータで、ip classless が有効であることを確認します。

前提条件

要件

この文書に関する特別な要件はありません。

使用するコンポーネント

この文書は、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

この文書の情報は、特定のラボ環境にあるデバイスに基づいて作成されています。この文書内で使用されているデバイスはすべて、クリアな状態(デフォルト)から設定作業を始めています。対象のネットワークが実稼動中である場合には、すべてのコマンドによる潜在的な影響について確実に理解しておく必要があります。

表記法

文書表記の詳細は、「シスコ テクニカル ティップスの表記法」を参照してください。

設定

これらの設定は、設定の一部分です。

ネットワーク ダイアグラム

この文書では次のダイアグラムに示すネットワーク構成を使用しています。

bri0-1.jpg

設定

ルータ C194u は 2 台のディストリビューション レイヤ ルータのうちの 1 つです。この例では、ルータ C194u はリモート サイトに対して BRI を使って接続します。他方のディストリビューション レイヤ ルータ C194n は、シリアル インターフェイスを使ったフレーム リレー回路を使用しています。

ディストリビューション レイヤ ルータ #1

hostname c194u  
   !   
   
   !--- リモート サイトで、ルータのユーザ名を作成します。
   
   username c194s password 7 XXXXXXXX    
   !         
   ip subnet-zero      
   isdn switch-type basic-dms100 
   !         
   interface Loopback0 
    ip address 192.168.11.141 255.255.255.252        
   !         
   interface Ethernet0 
    ip address 163.241.222.93 255.255.255.0
    media-type 10BaseT 
   !         
   interface BRI0      
    description to Remote Site c194s, (this end 08358662 08358664)       
    ip address 192.168.11.138 255.255.255.252        
    no ip mroute-cache 
    encapsulation ppp  
    no ip route-cache  
    isdn spid1 0835866201        
    isdn spid2 0835866401        
    dialer idle-timeout 600      
    dialer wait-for-carrier-time 10        
    dialer map ip 192.168.11.137 name c194s broadcast 8358661  
    dialer map ip 192.168.11.137 name c194s broadcast 8358663  
    dialer hold-queue 5
    dialer load-threshold 128  outbound    
    dialer-group 1     
    no fair-queue      
    ppp authentication chap      
    ppp multilink      
   !         
   router eigrp 65535
   
   !--- 次に掲載するスタティック ルートが再配信されます。したがって、フレーム
   !--- リレー ネットワークで障害が発生した場合、この Autonomous System(AS; 自律システム)内の他のルータは 
   !--- このルータからアドバタイズされるリモート ネットワークを認識するようになります。通常、これらの
   !--- ルータはフレーム リレー リンクにまたがる EIGRP を介して認識されます。
   !--- BRI インターフェイスを非アクティブにします。代替案は、ダイアラリストを使って、
   !--- EIGRP パケットを「処理対象外」パケットとして識別することです。
   
   redistribute static      
    passive-interface BRI0   
    network 192.168.11.0         
    network 163.241.0.0
    default-metric 64 200 255 1 1500       
    no auto-summary    
    eigrp log-neighbor-changes   
   !         
   ip classless
   
   !--- 両方のディストリビューション レイヤ ルータには、自分の Null インターフェイスへのデフォルト ルートが設定されています。
   !--- これは、ルータが AS 内の他のすべてのルータに 0/0 ネットワークをアドバタイズするためです。
   
   ip route 0.0.0.0 0.0.0.0 Null0
   
   !--- リモート サイトの C194s ルータの後ろに、各ネットワーク用のスタティック ルートが存在しなければ 
   !--- なりません。ルータ C194s の BRI インターフェイスの IP アドレスを使って、
   !--- アドミニストレーティブ ディスタンスが 240 であることを確認します。
   !--- : 使用しているアドレッシング スキームが自動要約を実行する場合、これらのルートを 
   !--- 要約してください。フレーム リレー ネットワークで障害が発生した場合、
   !--- リモート サイトに宛てられたパケットは強制的に BRI インターフェイスに出力され、
   !--- BRI インターフェイスによるダイヤルと接続の復元が実行されます。 
   
   ip route 192.168.11.0 255.255.255.224 192.168.11.137 240
   ip route 192.168.11.32 255.255.255.224 192.168.11.137 240         
   ip route 192.168.11.64 255.255.255.224 192.168.11.137 240         
   ip route 192.168.11.132 255.255.255.252 192.168.11.137 240        
   !         
   access-list 100 deny   icmp any any     
   access-list 100 permit ip any any    
   dialer-list 1 protocol ip list 100      
   !         
   end

ルータ C194u に対する show dialer コマンドの出力例を次に示します。

ディストリビューション レイヤ ルータ #1

c194u#show dialer     
   BRI0 - dialer type = ISDN     
   Dial String      Successes   Failures    Last called   Last status    
   8358663        4       1311    01:32:08 failed    
   8358661     1874       1315    00:02:07       successful    
   0 incoming call(s) have been screened.  
   BRI0:1 - dialer type = ISDN   
   Idle timer (600 secs), Fast idle timer (20 secs)  
   Wait for carrier (5 secs), Re-enable (15 secs)    
   Dialer state is physical layer up       
   Dial reason: ip (s=192.168.11.138, d=192.168.11.137)
   

次のルータ C194n は、この図ではフレーム リンク ルータであるため、2 台目のディストリビューション レイヤ ルータになります。このルータには特別な設定はありません。EIGRP に再配送されるデフォルト ルートだけが設定されています。

ディストリビューション レイヤ ルータ #2

hostname c194n  
   !         
   !         
   interface Ethernet0 
    ip address 163.241.222.98 255.255.255.0
   !         
   interface Serial1   
    no ip address      
    bandwidth 1544     
    no ip mroute-cache 
    encapsulation frame-relay    
    no fair-queue      
   !         
   interface Serial1.301 point-to-point    
    ip address 192.168.11.130 255.255.255.252        
    bandwidth 32       
    frame-relay interface-dlci 301         
   !         
   router eigrp 65535  
    redistribute static      
    network 192.168.11.0         
    network 163.241.0.0
    default-metric 64 200 255 1 1500       
    no auto-summary    
    eigrp log-neighbor-changes   
   !         
   ip classless        
   ip route 0.0.0.0 0.0.0.0 Null0      
   !

次のルータ C194s はリモート サイト ルータで、アクセス レイヤ ルータです。このルータは、ディストリビューション レイヤ ルータを経由してリモート ネットワークをバックボーンに接続します。

アクセス レイヤ ルータ

!         
   hostname c194s  
   !
   
   !--- ディストリビューション レイヤ ルータのユーザ名を作成します。
   
   username c194u password 7 XXXXXXXXX    
   !         
   isdn switch-type basic-dms100 
   !         
   interface Loopback0 
    ip address 192.168.11.133 255.255.255.252        
   !         
   interface Ethernet0 
    ip address 192.168.11.2 255.255.255.224
   !         
   interface Serial0   
    no ip address      
    bandwidth 64       
    encapsulation frame-relay    
   !         
   interface Serial0.300 point-to-point    
    ip address 192.168.11.129 255.255.255.252        
    bandwidth 32       
    frame-relay interface-dlci 300         
   !         
   interface BRI0      
    description to Hub Site c194u, (this end 08358661 08358663)
    ip address 192.168.11.137 255.255.255.252        
    no ip mroute-cache 
    encapsulation ppp  
    no ip route-cache  
    isdn spid1 0835866101        
    isdn spid2 0835866301        
    dialer idle-timeout 600      
    dialer wait-for-carrier-time 10        
    dialer map ip 192.168.11.138 name c194u broadcast 8358662  
    dialer map ip 192.168.11.138 name c194u broadcast 8358664  
    dialer hold-queue 5
    dialer load-threshold 128    
    dialer-group 1     
    no fair-queue      
    ppp multilink      
    ppp authentication chap      
   !         
   router eigrp 65535
   
   !--- スタティック ルートを再配布して、イーサネット ネットワーク 192.168.11.0/27 にアタッチした
   !--- ルータがこのルータを残りのネットワークへの出口として認識するように
   !--- します。ただし、このデフォルト ルートが
   !--- 使用しているディストリビューション レイヤ ルータに戻らないようにしてください。アドバタイズメントのブロックに、 
   !--- ディストリビュート リストが使われます。
   
   redistribute static      
    passive-interface BRI0   
    network 192.168.11.0         
    default-metric 64 200 255 1 1500
    distribute-list 2 out Serial0.300      
    no auto-summary    
    eigrp log-neighbor-changes   
   !         
   ip classless
   
   !--- ディストリビューション レイヤ ルータの BRI インターフェイスの IP アドレスを使って、
   !--- デフォルト ルートを追加します。フレーム ネットワークがダウンすると、本ルートによって
   !--- トラフィックが BRI インターフェイスにプッシュ アウトされ、BRI インターフェイスによるダイヤルと
   !--- 接続の復元が実行されます。
   
   ip route 0.0.0.0 0.0.0.0 192.168.11.138 240   
   !         
   access-list 1 permit any      
   ! 
   access-list 2 deny   0.0.0.0
   access-list 2 permit any  
   !        
   dialer-list 1 protocol ip list 1        
   !         
   end       
   !

次のルータは、リモート サイト ネットワークを表しています。ここでは、アクセス レイヤ ルータの IGP ダイナミック ルーティング プロトコルである EIGRP を動作させることを除いて、特別な設定は不要です。

リモート サイト ルータ

hostname c194ec 
   !         
   !         
   interface Loopback0 
    ip address 192.168.11.65 255.255.255.224         
   !         
   interface Ethernet0 
    ip address 192.168.11.1 255.255.255.224
   !         
   interface Ethernet1 
    ip address 192.168.11.33 255.255.255.224         
   !         
   !         
   router eigrp 65535  
    network 192.168.11.0         
    default-metric 64 200 255 1 1500       
    no auto-summary    
    eigrp log-neighbor-changes   
   !         
   ip classless        
   !         
   end

確認

この項では、設定が正しく動作することを確認するために使用できる情報を提供します。

特定の show コマンドは、Output Interpreter ツール登録ユーザのみ)でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

フレームリレー ネットワークをダウンさせた状態で、リモート サイトでネットワークから traceroute を試みます。上記のネットワーク ダイアグラムから、対象の IP アドレスはハブ サイト ルータのループバック インターフェイスになります。

c194ec#trace        
   Target IP address: 192.168.11.141       
   Source address: 192.168.11.65 
   Tracing the route to 192.168.11.141     
     1 192.168.11.2 4 msec 4 msec 4 msec   
     2  *  *  *        
     3  *  * 
       192.168.11.138 24 msec

複数のパケットを使用して、BRI インターフェイスがどのようにアップされているかに注目してください。BRI が非アクティブになり、パケットが失われる前にもう一度 traceroute を実行してください。

c194ec#traceroute 192.168.11.141        
   Tracing the route to 192.168.11.141     
     1 192.168.11.2 4 msec 4 msec 4 msec   
     2 192.168.11.138 20 msec *  20 msec 

再びフレーム スイッチをアップさせます。フレームリレー ネットワークが稼働状態になったので、ISDN は使用しません。

c194ec#traceroute 192.168.11.141        
   Tracing the route to 192.168.11.141     
     1 192.168.11.2 4 msec 4 msec 4 msec   
     2 192.168.11.130 36 msec 36 msec 32 msec        
     3 163.241.222.93 36 msec *  32 msec

稼働状態のフレームリレー ネットワークのルーティング テーブルを次に示します。ハブ サイトにあるネットワークの個々の経路が EIGRP を通じてどのように学習されるのかに注目してください。EIGRP を通じて学習されたデフォルト ルートも存在します。

c194ec#show ip route  
   Gateway of last resort is 192.168.11.2 to network 0.0.0.0   
        163.241.0.0 255.255.255.0 is subnetted, 1 subnets      
   D       163.241.222.0 [90/2221056] via 192.168.11.2, 00:02:09, Ethernet0        
        192.168.11.0 is variably subnetted, 7 subnets, 2 masks 
   C       192.168.11.64 255.255.255.224 is directly connected, Loopback0
   C       192.168.11.32 255.255.255.224 is directly connected, Ethernet1
   C       192.168.11.0 255.255.255.224 is directly connected, Ethernet0 
   D       192.168.11.128 255.255.255.252  
    [90/2195456] via 192.168.11.2, 00:02:13, Ethernet0         
   D       192.168.11.132 255.255.255.252  
    [90/409600] via 192.168.11.2, 01:23:14, Ethernet0
   D       192.168.11.136 255.255.255.252  
    [90/40537600] via 192.168.11.2, 01:23:14, Ethernet0        
   D       192.168.11.140 255.255.255.252  
    [90/2349056] via 192.168.11.2, 00:02:10, Ethernet0         
   D*EX 0.0.0.0 0.0.0.0 [170/40614400] via 192.168.11.2, 00:02:10, Ethernet

フレームリレー ネットワークがダウンしたときのルーティング テーブルを次に示します。デフォルト ルートは依然として存在しますが、ハブ サイトの向こう側にあるネットワークの個々の経路がいくつか喪失しています。しかし ip classless が有効で、デフォルト ルートが設定されているため、ネットワーク内のどこにでもアクセスできます。

c194ec#show ip route
   Gateway of last resort is 192.168.11.2 to network 0.0.0.0   
        192.168.11.0 is variably subnetted, 5 subnets, 2 masks 
   C       192.168.11.64 255.255.255.224 is directly connected, Loopback0
   C       192.168.11.32 255.255.255.224 is directly connected, Ethernet1
   C       192.168.11.0 255.255.255.224 is directly connected, Ethernet0 
   D       192.168.11.132 255.255.255.252  
    [90/409600] via 192.168.11.2, 01:25:27, Ethernet0
   D       192.168.11.136 255.255.255.252  
    [90/40537600] via 192.168.11.2, 01:25:27, Ethernet0        
   D*EX 0.0.0.0 0.0.0.0 [170/40076800] via 192.168.11.2, 00:00:15, Ethernet

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 10212