音声 : 音声品質

QOS を実装した PPP リンク上での VoIP(LLQ / IP RTP プライオリティ、LFI、cRTP)

2004 年 3 月 22 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2006 年 2 月 2 日) | フィードバック

目次

概要
はじめに
     表記法
     前提条件
     使用するコンポーネント
PPP リンクによる VoIP の QoS 設計ガイドライン
     音声トラフィックのための完全な優先権(IP RTP プライオリティ、あるいは、LLQ)
     LLQ 設定ガイドライン
     IP RTP プライオリティ設定ガイドライン
     Link Fragmentation and Interleaving(LFI; リンク フラグメンテーションおよびインターリービング): マルチリンク PPP
     Compressed Real-time Protocol(cRTP; 圧縮リアルタイム プロトコル)
     帯域幅節約のその他のヒント
ネットワーク ダイアグラム
設定
検証とトラブルシューティングのためのコマンド
show と debug の出力例
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この設定例では、低帯域幅の専用回線構成を使用した、Point to Point Protocol(PPP; ポイントツーポイント プロトコル)による VoIP について説明しています。 この文書には、設定された機能、設計ガイドライン、および基本的な検証とトラブルシューティングの方法について、背景となる技術情報が記載されています。

以下の設定では、2 台のルータが専用回線を使用してバックツーバックで接続されていることに注意してください。 ただし、ほとんどのトポロジにおいて、音声対応ルータは任意の場所に配置できます。 通常、音声ルータは LAN 接続を使用して、WAN に接続されている他のルータに接続します(つまり、PPP 専用回線)。 音声ルータが専用回線上での PPP を介して直接接続されていない場合は、下記の設定に示されているように、すべての WAN 設定コマンドを、音声ルータではなく WAN に接続されているルータに設定する必要があるため、この点が重要となります。

はじめに

表記法

文書表記の詳細については、「シスコ テクニカル ティップスの表記法」を参照してください。

前提条件

この文書に関する特別な前提条件はありません。

使用するコンポーネント

これらの設定は、次の機器を使用してテストしました。

  • Cisco IOS(R) ソフトウェア リリース 12.2.6a(IP Plus)が稼動している 2 台の Cisco 3640

  • IP RTP プライオリティは Cisco IOS リリース 12.0(5)T でサポートされています。

  • LLQ は Cisco IOS リリース 12.0(7)T でサポートされています。

  • LFI は Cisco IOS リリース 11.3 でサポートされています。

  • Cisco IOS リリース 12.0.5T 以降では cRTP の大幅なパフォーマンス改善がなされました。

PPP リンクによる VoIP の QoS 設計ガイドライン

この項では、PPP 専用回線で Voice over IP を設定する設計ガイドラインを(特に低速リンクを強調して)示しています。 良好な音声品質を得るためには、次の 2 つの基本的な要件があります。

上記の要件を満たすための重要なガイドラインを次に示します。

ガイドライン

説明

音声トラフィックのための完全な優先権(IP RTP プライオリティ、あるいは、LLQ)

音声トラフィックに完全な優先権を与える方法

Link Fragmentation and Interleaving(LFI; リンク フラグメンテーションおよびインターリービング)

低速の回線にはたいていの場合必須。

RTP 圧縮

良好な音声品質を得るためには不要ですが、コールによる帯域幅の消費を抑制できます。 RTP 圧縮に関する一般的なアドバイスとして、RTP 圧縮は、良好な音声品質が得られる動作設定が整った後で適用するようにします(トラブルシューティングを簡単にするため)。

コール アドミッション制御(CAC)

この文書では説明していません。 CAC は、リンク上で確立可能なコール数を制御するために使用します。 たとえば、2 つのゲートウェイ間の WAN リンクで VoIP コールを 2 回だけ伝送できる場合、3 回目のコールを許可すると、3 コールすべての音声品質が低下する可能性があります。 詳細は次を参照してください。 VoIP コール アドミッション制御

要するに、音声トラフィックを唯一のソースとしてみた場合、ルータまたはゲートウェイを備えた低速の PPP 回線を使用するには、次の 2 つの機能が必須になります。

  1. 音声トラフィックのための完全な優先権

  2. Link Fragmentation and Interleaving(LFI; リンク フラグメンテーションおよびインターリービング)

音声トラフィックのための完全な優先権(IP RTP プライオリティ、あるいは、LLQ)

Cisco IOS(R) ソフトウェア リリース 12.2 までのところ、音声トラフィックに完全な優先権を与えるには、2 つの基本的な方法があります。

  • IP RTP プライオリティ(別名 PQ/WFQ: Priority Queue / Weighted Fair Queuing)

  • 低遅延キューイング(別名 PQ/CBWFQ: Priority Queue / Class Based Weighted Fair Queuing)

IP RTP プライオリティ

IP RTP プライオリティでは、ある範囲の UDP 宛先ポートに属する一連の RTP パケット フロー向けに、完全優先キューを作成します。 実際に使用されるポートはエンドデバイスまたはゲートウェイの間でダイナミックにネゴシエートされますが、Cisco VoIP 製品はすべて同じ UDP ポート範囲(16384〜32767)を利用します。 ルータは VoIP トラフィックを検出すると、完全優先キューに置きます。 この優先キューが空の場合は、Weighted Fair Queuing(WFQ; 重み付け均等化キューイング)の基準に従って、他のキューが処理されます。 IP RTP プライオリティは、インターフェイスで輻輳が発生しない限りアクティブにはなりません。 次の図は IP RTP プライオリティの動作の仕組みを示しています。

pq-wfq.gif

注: IP RTP プライオリティは、デフォルト キュー(WFG)に利用可能な帯域幅があると、優先キューのバーストを許可しますが、そのインターフェイスに輻輳が発生している場合には、優先キューのコンテンツの厳密なポリシングを行います。

低遅延キューイング

LLQ とは、Class-Based Weighted Fair Queuing (CBWFQ; クラスベース重み付け均等化キューイング)に完全優先キュー(PQ)を付加する機能です。 LLQ を使用すると、クラス レベルの CBWFQ 内で単一の完全 PQ が使用可能になります。 LLQ では、(PQ 内にある)遅延に影響されやすいデータが最初に取り出され、送信されます。 LLQ 実装を備えた VoIP では、音声トラフィックが完全 PQ に入れられます。

PQ は均等化キューが帯域幅不足に陥らないようにポリシングされます。 PQ を設定するときには、その PQ で使用できる帯域幅の最大量を Kbps で指定します。 インターフェイスで輻輳が発生すると、負荷が priority 文で設定された Kbps 値に達するまで PQ の処理が行われます。 下位のプライオリティ キューが処理されなくなるという、シスコの従来のプライオリティ グループ機能の問題を避けるために、超過トラフィックは廃棄されます。

llq.gif

この方法は IP RTP プライオリティよりも複雑ですが、より柔軟な制御が可能です。 どちらの方法を選択するかは、実際のネットワークでのトラフィック パターンと実際のニーズに基づきます。

LLQ と IP RTP プライオリティ

次の表は LLQ と IP RTP プライオリティの主な違いをまとめたもので、どのような場合にそれぞれの方法を使用すればよいかを示すガイドラインになります。

低遅延キューイング(LLQ)

IP RTP プライオリティ

次に基づき音声トラフィックを照合:

  • アクセスリスト(UDP ポート範囲、ホスト アドレス、IP ヘッダー ToS フィールド: IP Precedence、DSCP、など)

  • IP RTP ポート範囲

  • IP ToS(タイプ オブ サービス)フィールド: DCSP または IP Precedence、あるいは、その両方

  • プロトコルと入力インターフェイス

  • CBWFQ で使用される有効な照合基準すべて

利点:

  • トラフィックを照合し、完全 PQ と CBWFQ に誘導するさらに柔軟な方法。

  • 次のような別のトラフィックに帯域幅を保証する追加クラスの設定が可能。 VoIP シグナリングと画像

欠点:

  • 設定が複雑

次に基づき音声トラフィックを照合:

  • 次の RTP/UDP ポート範囲に基づく: 16384-32767

利点:

  • 簡単な設定

欠点:

  • WFQ キューで機能する RTCP トラフィック(VoIP シグナリング)

    注:RTP プロトコルは RTCP(Real Time Control Protocol)により、RTP パケットの配送を制御します。  16384-32767 の範囲で RTP ポートは偶数番号を使い、RTCP ポートは奇数番号を使います。IP RTP プライオリティが RTP ポートを PQ に置くと、RTCP ポートはデフォルトの重み付け均等化キューで処理されます。

  • VoIP トラフィックを PQ で処理。しかし、優先処理と帯域幅の保証を必要とするその他のトラフィックは WFQ で処理されます。 WFQ はフローを(IP Precedence に基づく)重み付けで差別化しますが、どのフローに対しても帯域幅の保証はできません。

ガイドライン

  • どちらの方法を選択するかは、実際のネットワークでのトラフィック パターンと個々の実質的なニーズに基づきます。

  • 音声トラフィックに完全な優先権を付加する必要があれば、他のトラフィックは単一のタイプ(データ)として扱えます。これにより、IP RTP プライオリティは、簡単な設定でネットワークを適確に制御します。

  • UDP port 以外の基準(たとえば DiffServ PHB)により音声トラフィックの優先付けをするのであれば、LLQ が必要です。

キューイング方法の違いを対比した詳細は、「輻輳管理の概要」を参照してください。

LLQ 設定ガイドライン

LLQ の設定は、次のガイドラインに従います。

  1. VoIP トラフィックのためのクラス マップを作成して、照合基準を定義する。

    次のコマンドがこの方法を示しています。

    maui-voip-sj(config)#class-map ?
             WORD 		class-map name
             match-all 	Logical-AND all matching statements under this classmap
             match-any 	Logical-OR all matching statements under this classmap
      maui-voip-sj(config)#class-map match-all voice-traffic 
      
      !-- 説明的 class_name を選択します。 
      
      maui-voip-sj(config-cmap)#match ?  
      access-group         Access group  
      any                  Any packets  
      class-map            Class map  
      cos                  IEEE 802.1Q/ISL class of service/user priority values  
      destination-address  Destination address  
      input-interface      Select an input interface to match  
      ip                   IP specific values  
      mpls                 Multi Protocol Label Switching specific values  
      not                  Negate this match result  
      protocol             Protocol 
      qos-group            Qos-group  
      source-address       Source address
      
      !-- この例では、柔軟性のために、アクセスグループ照合オプションを使っています。
      !-- (アクセスリストが使われています。)
      
      maui-voip-sj(config-cmap)#match access-group ?
        <1-2699>  Access list index  name      Named Access List
      maui-voip-sj(config-cmap)#match access-group 102
      
      !-- ここで、クラス マップ アクセス グループと照合するアクセス リストを作成します。
      
      maui-voip-sj(config)#access-list 102 permit udp any any range 16384 32776
      
      
      !-- 最も安全で簡単な方法は UDP ポート範囲 16384-32767 との照合です。
      !-- これは Cisco IOS H.323 製品で
      !-- VoIP パケットの伝送に使われているポート範囲です。
      
      

    match access-group コマンドを使うと、次のアクセスリストによる音声トラフィックの照合が可能です。

      access-list 102 permit udp any any precedence critical 
      !-- このリストは、次の IP パケット TOS 優先順位フィールドに基づいて、トラフィックをフィルタリングします。  
      !-- 注: 他の非音声トラフィックが同じ優先順位の値を使用していないことを
      !-- 確認します。              
      access-list 102 permit udp any any dscp ef
      !-- このリストが機能するには、VoIP パケットが LLQ WAN インターフェイスに出る前に 
      !-- dscp ef コードでタグ付けされているのを確認します。 
      !-- DSCP に関する詳細は、次を参照してください。 
      !-- DSCP による QOS ポリシーの実装
      !-- : パケット マーキングについてエンドポイントが信頼できない場合は、
      !-- 着信インターフェイスに着信サービス ポリシーを適用することで、
      !-- 着信トラフィックをマーキングできます。 この手順は、この文書ではとり上げられていません。
      Access-list 102 permit udp host 192.10.1.1 host 192.20.1.1
      
      !-- このアクセスリストは、VoIP デバイスが
      !-- 優先順位付けや dscp マーキングができず、
      !-- VoIP UDP ポート範囲も指定できないケースで使用します。 
      
      

    access-group の代わりに使用できる別の照合方法を次に示します。

    • Cisco IOS リリース 12.1.2.T から、IP RTP プライオリティ機能は LLQ を実装しています。 この機能は、設定された UDP ポートを参照してプライオリティ クラス コンテンツを照合しますが、PQ 内の偶数ポートだけを取り扱うという制限があります。

        class-map voice 
          match ip rtp 16384 16383 
        
        
    • 次の 2 つの方法は、VoIP パケットが送信 LLQ 動作が適用される以前に、送信元ホストでマーキングされており、ルータで照合とマーキングがされていることを前提に機能します。

        class-map voice 
          match ip precedence 5 
        

      または

        class-map voice 
          match ip dscp ef 
        

      注:IOS リリース 12.2.2T から、VoIP ダイヤルピアで、LLQ 動作よりも先に音声ベアラとシグナリング パケットのマーキングができるようになりました。  これにより、LLQ のための、DSCP コード値による VoIP パケットのマーキングと照合のスケーラブルな方法が実現しました。

  2. VoIP シグナリングのためのクラス マップを作成して、照合基準を定義する。(オプション)

    次のコマンドがこの方法を示しています。

       class-map voice-signaling
        match access-group 103
       !
       access-list 103 permit tcp any eq 1720 any 
       access-list 103 permit tcp any any eq 1720
      

    注:VoIP コールは、H.323、SIP、MGCP、あるいは、Skinny(Cisco Call Manager で使われる専用プロトコル)により確立が可能です。  上記の例では H.323 Fast Connect を想定しています。 次のリストは、VoIP シグナリングおよび制御チャネルで使用されるポートのリファレンスとして役立ちます。

    • H.323/H.225 = TCP 1720

    • H.323/H.245 = TCP 11xxx(Standard Connect)

    • H.323/H.245 = TCP 1720(Fast Connect)

    • H.323/H.225 RAS = TCP 1719

    • Skinny = TCP 2000〜2002(CM Encore)

    • ICCP = TCP 8001〜8002(CM Encore)

    • MGCP = UDP 2427、TCP 2428(CM Encore)

    • SIP= UDP 5060、TCP 5060(設定可能)

  3. ポリシー マップを作成して、VoIP クラスマップへ関連付ける。

    ポリシー マップの目的は、リンク リソースが共有され、他のマップ クラスに割り当てられる方法を定義することです。 次のコマンドがこの方法を示しています。

    maui-voip-sj(config)#policy-map VOICE-POLICY
      
      !-- 説明的 policy_map_name を選択します。
      
      maui-voip-sj(config-pmap)#class voice-traffic
      maui-voip-sj(config-pmap-c)#priority ?  
      <8-2000000>  Kilo Bits per second
      
      !-- voice-traffic クラスを完全優先キューに設定して(priority コマンド)
      !-- 帯域幅を割り当てます。
      
      maui-voip-sj(config-pmap)#class voice-signaling
      maui-voip-sj(config-pmap-c)#bandwidth 8
      
      !-- voice-signaling クラスに 8 Kbps を割り当てます。
      
      maui-voip-sj(config-pmap)#class class-default
      maui-voip-sj(config-pmap-c)#fair-queue 
      
      !-- 残りのデータ トラフィックは均等化キューイングとして取り扱われます。
      
      

    注:さまざまなタイプのリアルタイム トラフィックを PQ にキューイングするのは可能ですが、PQ には音声トラフィックだけを置くことを推奨します。  ビデオなどのリアルタイム トラフィックは、遅延に変動を生じさせる可能性があります(PQ は FIFO(First In, First Out)キューであるため)。 音声トラフィックでは、ジッタを避けるために遅延を一定にする必要があります。

    注:priority 文と bandwidth 文での値の合計は、リンク帯域幅の 75 % 以下である必要があります。  そうしないと、service-policy をリンクに割り当てることができません。(エラー メッセージを表示させるには、logging console がコンソール アクセスで有効になっており、terminal monitor が Telnet アクセスで有効になっているのを確認してください。)

    注:VoIP を 64 Kbps リンクで 2 つの音声コールをサポートするように設定する場合は、PQ にリンク帯域幅の 75 %(48 Kbps)以上を割り当てるのが一般的です。  この場合、コマンド max-reserved-bandwidth 80 を使って、利用可能な帯域幅を 80 %(51 Kbps)に上げることができます。

    bandwidthpriority コマンドに関する詳細は、次を参照してください。 QoS サービス ポリシーの bandwidth と priority コマンドの比較

  4. LLQ を有効にする: ポリシー マップを出力 WAN インターフェイスに適用します。

    次のコマンドがこの方法を示しています。

    maui-voip-sj(config)#interface multilink 1
      maui-voip-sj(config-if)#service-policy output VOICE-POLICY
      
      !-- このシナリオ(MLPPP LFI)では、サービス ポリシーは
      !-- マルチリンク インターフェイスに適用されます。
      
      
      

IP RTP プライオリティ設定ガイドライン

IP RTP プライオリティを設定するには、次のガイドラインに従ってください。

  • Router(config-if)#ip rtp priority starting-rtp-port-#port-#-rangebandwidth
      
      

    コマンド

    説明

      starting-rtp-port-number
      

    UDP ポートの下限。 これはパケットが送信される最小のポート番号です。 VoIP の場合は、この値を 16384 に設定します。

      port-number-range
      

    UDP 宛先ポートの範囲。 starting-rtp-port-number に付ける番号は、最も高い UDP ポート番号を表します。 VoIP の場合は、この値を 16383 に設定します(32767 - 16384 = 16383)。

      bandwidth
      

    プライオリティ キューで許可される最大の帯域幅(kbps)。 この数値は、システムでサポートする最大同時コール数に従って設定します。

    サンプル設定:

    interface Multilink1
      
         !--- 出力を一部省略
      
         bandwidth 64
         ip address 172.22.130.2 255.255.255.252
         ip tcp header-compression
         fair-queue
         no cdp enable
         ppp multilink
         ppp multilink fragment-delay 10
         ppp multilink interleave
         multilink-group 1
         ip rtp header-compression iphc-format
         ip rtp priority 16384 16383 45
      

Link Fragmentation and Interleaving(LFI; リンク フラグメンテーションおよびインターリービング): マルチリンク PPP

データ パケットの一般的なサイズは 1500 バイトですが、通常の VoIP パケット(G.729 音声フレーム搬送)は 66 バイト前後(20 バイトの音声ペイロード、6 バイトのレイヤ 2 ヘッダー、20 バイトの RTP と UDP のヘッダー、20 バイトの IP ヘッダー)です。

ここで、音声トラフィックとデータ トラフィックが共存している 56Kbps の専用回線リンクを想像してみてください。 データ パケットがリンク上への伝送され始めた時点で音声パケットがシリアル化されようとすると、問題が生じます。 遅延に影響されやすい音声パケットが送信までに 214 ミリ秒待機することになります(1500 バイトのパケットを 56Kbps のリンクでシリアル化するには 214 ミリ秒かかります)。

つまり、大きなデータ パケットのために、小さな音声パケットの配送に遅延をきたし、このために通話品質が劣化します。 このような大きなデータ パケットを小さなものにフラグメントし、この間に音声パケットを挿入(インターリービング)すれば、ジッタや遅延を減らすことができます。 Cisco IOS の Link Fragmentation and Interleaving(LFI; リンク フラグメンテーションおよびインターリービング)機能は VoIP のリアルタイム配送要件を充足する上で有効です。 次の図は LFI プライオリティの動作の仕組みを示しています。

lfi.gif

表 1 に示されているように、エンドツーエンド片方向遅延の目標値が 150 ミリ秒を超えてはならない点を考慮すると、低速 WAN リンクで発生するシリアル化遅延の累計(ビット列を実際にインターフェイスに送り出すのに要する時間)はかなりの大きさになる可能性があります。 (ITU-T G.114 の推奨では、エンドツーエンド片方向遅延の最大値は 150 ミリ秒と定められています。)

表 1:低速リンク上のさまざまなフレーム サイズでのシリアル化遅延(シリアル化遅延 = フレーム サイズ [ビット] / リンク帯域幅 [bps])

1 バイト

64 バイト

128 バイト

256 バイト

512 バイト

1024 バイト

1500 バイト

56 kbps

143 マイクロ秒

9 ミリ秒

18 ミリ秒

36 ミリ秒

72 ミリ秒

144 ミリ秒

214 ミリ秒

64 kbps

125 マイクロ秒

8 ミリ秒

16 ミリ秒

32 ミリ秒

64 ミリ秒

126 ミリ秒

187 ミリ秒

128 kbps

62.5 マイクロ秒

4 ミリ秒

8 ミリ秒

16 ミリ秒

32 ミリ秒

64 ミリ秒

93 ミリ秒

256 kbps

31 マイクロ秒

2 ミリ秒

4 ミリ秒

8 ミリ秒

16 ミリ秒

32 ミリ秒

46 ミリ秒

512 kbps

15.5 マイクロ秒

1 ミリ秒

2 ミリ秒

4 ミリ秒

8 ミリ秒

16 ミリ秒

32 ミリ秒

768 kbps

10 マイクロ秒

640 マイクロ秒

1.28 ミリ秒

2.56 ミリ秒

5.12 ミリ秒

10.24 ミリ秒

15 ミリ秒

1536 kbps

5 マイクロ秒

320 マイクロ秒

640 マイクロ秒

1.28 ミリ秒

2.56 ミリ秒

5.12 ミリ秒

7.5 ミリ秒

注:音声アプリケーション用には、推奨シリアル化遅延(ホップ ベース単位)は 10 ミリ秒で、20 ミリ秒を超えてはなりません。 

リンク フラグメント サイズは、ppp multilink fragment-delay コマンドにより、ミリ秒(msec)単位で設定できます。 LFI には、ppp multilink interleave を有効にしたインターフェイスで ppp multilink が設定されている必要があります。 LFI 設定に関する詳細は、この項を参照してください。

注:専用のハーフ T1 接続(768 Kbps)以上の速度がある場合は、フラグメンテーション機能は不要です。  (しかし、LLQ や IP RTP プライオリティなどの QoS のメカニズムは必要です)。 ハーフ T1 では、音声パケットのキューへの出し入れを、遅延を発生させずに行えるだけの十分な帯域幅が供給されます。 また、ハーフ T1 のケースでは、Compression for Real-time Protocol(cRTP; 圧縮リアルタイム プロトコル)(IP RTP ヘッダーを圧縮して帯域幅を節約する機能)も不要の場合があります。

Compressed Real-time Protocol(cRTP; 圧縮リアルタイム プロトコル)

注:良好な音声品質を確保するためには cRTP は必要ではありません。  これは帯域幅の消費を抑制するための機能です。 cRTP は、他の条件がすべて満たされていて、音声品質が良好な場合に設定してください。 こうすれば、可能性のある cRTP の問題が切り離されるため、トラブルシューティング時間を節約できます。

RFC 2508 で規定されている RTP ヘッダー圧縮機能は、IP/UDP/RTP パケットのヘッダーを 40 バイトから 2 または 4 バイトに圧縮し、無駄な帯域幅の使用を減らします。 これはホップ単位の圧縮スキームなので、cRTP はリンクの両端で設定されている必要があります。(ただし、passive オプションが設定されている場合はこの限りではありません。) cRTP を設定するには、インターフェイス レベルで次のコマンドを使用します。

  • Router(config-if)#ip rtp header-compression [passive]

圧縮プロセスは CPU に高い負荷をかけるため、RTP ヘッダー圧縮は、IOS リリース 12.0.(7)T から高速のスイッチングおよび CEF スイッチング パスに実装されます。 これらの実装がうまくいかず、唯一プロセス スイッチだけが動作する実装となる場合もあります。 シスコでは、ルータの CPU 使用率が高い場合を除き、768 Kbps よりも低速のリンクで cRTP を使用することを推奨しています。 ルータの CPU 使用率を監視し、使用率が 75 % を超えた場合は cRTP を無効にしてください。

注: コマンド ip rtp header-compression を設定する場合、ルータでは、デフォルトで、コマンド ip tcp header-compression を設定に追加します。 これはヘッダーの TCP/IP パケットを圧縮するために使用されます。 ヘッダー圧縮は、多数の Telnet 接続をサポートしているなど、小さなパケットが大きな比率を占めるネットワークで特に有効です。 TCP ヘッダー圧縮技術は、RFC 1144 で完全に説明されており、HDLC または PPP カプセル化を使用して、シリアル回線上でサポートされています。

cRTP を有効にしないで TCP ヘッダーを圧縮するには、次のコマンドを使用します。

  • Router(config-if)#ip tcp header-compression [passive] 

詳細は次を参照してください。 圧縮リアルタイム転送プロトコル

帯域幅節約のその他のヒント

  • VoIP コール レッグでは、低ビットレートのコーダ/デコーダ(コーデック)、G.729(8 Kbps)の使用を推奨します。 (これは VoIP ダイヤルピアでのデフォルトのコーデックです)。 異なるコーデックを設定するには、任意の VoIP ダイヤルピアでコマンド router(config-dial-peer)#codec を使用します。

  • G.711 のような高ビットレートの音声コーデックを使用すると、通常 dual tone multifrequency(DTMF)は正確に転送されますが、低ビットレートのコーデック(G.729 および G.723.1)は音声パターンに高度に最適化され、DTMF トーンを歪ませる傾向があります。 そのため、このアプローチを使用すると Interactive Voice Response(IVR; 対話式音声自動応答)システムへのアクセス時に問題が生じるおそれがあります。 dtmf relay コマンドを使うと、DTMF トーンが「帯域外」で転送されるか、あるいは、コード化音声ストリームから切り離して転送されるので、DTMF の歪みの問題が解消されます。 低ビットレートのコーデック(G.729、G.723)を使用する場合は、VoIP ダイヤルピアで dtmf relay を有効にします。

  • 標準的な会話には 35〜50 % の無音部分があります。 Voice Activity Detection(VAD)を使用すると、無音パケットが抑制されます。 VoIP 帯域幅計画の作成時は、VAD によって帯域幅が 35 % 削減されると想定してください。 VAD は VoIP ダイヤルピアの下で、デフォルトで設定されています。 VAD の有効化/無効化を行うには、任意の VoIP ダイヤルピアでコマンド router(config-dial-peer)#vadrouter(config-dial-peer)# no vad を使用します。

ネットワーク ダイアグラム

mlppp.gif

設定

maui-voip-sj(Cisco 3640)

version 12.2service timestamps debug datetime msec
  
  !-- <一部の出力を省略>
  
  !
  hostname maui-voip-sj
  !
  ip subnet-zero
  !
  no ip domain-lookup
  !
  
  !-- 音声シグナリングとトラフィック クラス マップの定義
  !-- 「voice-traffic」クラスでは、照合基準にアクセスリスト 102 を使用します。
  !-- 「voice-signaling」クラスでは、照合基準にアクセスリスト 103 を使用します。
  
  
  Class-map match-all voice-signaling
    match access-group 103
  class-map match-all voice-traffic
    match access-group 102
  !
  
  !-- ポリシーマップでは、リンク リソースを別々のマップ クラスに
  !-- どのように割り当てるかを定義します。 この設定では、
  !-- 「voice-traffic」クラスに(クラス音声の ACL に基づき)最大帯域幅
  !-- 45 Kbps で完全プライオリティ キューを割り当てます。 
  
  policy-map VOICE-POLICY
    class voice-traffic
      priority 48
   class voice-signaling
     bandwidth 8
  
      !-- 8 Kbps 保証の「voice-signaling」トラフィックにキューを割り当てます。
      !-- このオプションは、シグナリングを保証するものであり、音声の品質向上には
      !-- 無効な点に注意してください。
  
    class class-default
     fair-queue
  
      !-- この「class-default」クラスは、定義済のクラスに当てはまらないトラフィックの
      !-- 分類に使用されます。
      !-- 「fair-queue」コマンドは、デフォルト クラス WFQ キューイングを関連付けます。
  
  !
  call rsvp-sync
  !
  
  !-- MLPPP は LFI メカニズムそのものであることに注意してください。 これは
  !-- 名前が示すのと同じ仮想インターフェイスに複数のシリアル インターフェイスをバンドルすることはありません。
  !-- (このバンドルはデータに対して行われるもので、
  !-- 音声に推奨されるものではありません。) この最終結果は、ジッタと無音声となって現れます。
  
  interface Multilink1
   ip address 172.22.130.1 255.255.255.252
   ip tcp header-compression iphc-format
   service-policy output VOICE-POLICY
  
    !-- LLQ は出力動作であり、
    !--- 出力 WAN インターフェイスに適用されます。
  
   no cdp enable
   ppp multilink
   ppp multilink fragment-delay 10
    
  !-- 設定値の 10 により、すべてのフラグメントで 10 ミリ秒の最長シリアル化遅延があるように、
    !-- フラグメント サイズを設定します。
  
   ppp multilink interleave
   multilink-group 1
    ip rtp header-compression iphc-format
  !
  interface Ethernet0/0
   ip address 172.22.113.3 255.255.255.0
   no keepalive
   half-duplex
  !
  interface Serial0/0
   bandwidth 128
  
    !-- bandwidth コマンドは、正確なフラグメント サイズが算出されるように
    !-- 正しく設定される必要があります。
  
   no ip address
   encapsulation ppp
   clockrate 128000
   ppp multilink
   multilink-group 1
  
    !-- このコマンドにより、マルチリンク インターフェイスを
    !--- 物理的なシリアル インターフェイスにリンクします。
  
  !
  router eigrp 69 
   network 172.22.0.0
   auto-summary
   no eigrp log-neighbor-changes
  !
  
  !-- アクセスリスト 102 は UDP のポート範囲に基づき VoIP トラフィックを照合します。
  !-- 偶数、奇数両方のポートが PQ に置かれます。
  !-- アクセスリスト 103 は VoIP シグナリング プロトコルの照合に使用されます。 この場合は
  !-- ファースト スタート機能付きの H.323 V2 を使っています。
  
  access-list 102 permit udp any any range 16384 32767
  access-list 103 permit tcp any eq 1720 any
  access-list 103 permit tcp any any eq 1720
  !
  voice-port 1/0/0
  !
  voice-port 1/0/1
  !
  voice-port 1/1/0
  !
  voice-port 1/1/1
  !
  dial-peer cor custom
  !
  dial-peer voice 1 pots
   destination-pattern 5000
   port 1/0/0
  !
  dial-peer voice 2 voip
   destination-pattern 6000
   session target ipv4:172.22.130.2
  


maui-voip-austin(Cisco 3640)

version 12.2
  service timestamps debug datetime msec
  !
  hostname maui-voip-austin
  !
  boot system flash slot1:c3640-is-mz.122-6a.bin
  !
  ip subnet-zero
  !
  class-map match-all voice-signaling
    match access-group 103
  class-map match-all voice-traffic
    match access-group 102
  !
  policy-map voice-policy
    class voice-signaling
     bandwidth 8
    class voice-traffic
      priority 48
    class class-default
     fair-queue
  !
  interface Multilink1
   bandwidth 128
   ip address 172.22.130.2 255.255.255.252
   ip tcp header-compression iphc-format
   service-policy output voice-policy
   no cdp enable
   ppp multilink
   ppp multilink fragment-delay 10
   ppp multilink interleave
   multilink-group 1
   ip rtp header-compression iphc-format
  
   !-- 稼動中の設定があるとして、設定済みの cRTP。
   !-- これは、潜在的な cRTP の問題を割り出すのに有効です。
  
  !
  Interface Ethernet0/0
   ip address 172.22.112.3 255.255.255.0
   no keepalive
   half-duplex
  !
  interface Serial0/0
   bandwidth 128
   no ip address
   encapsulation ppp
   no ip mroute-cache
   ppp multilink
   multilink-group 1
  !
  router eigrp 69
   network 172.22.0.0
   auto-summary
   no eigrp log-neighbor-changes
  !
  access-list 102 permit udp any any range 16384 32767
  access-list 103 permit tcp any eq 1720 any
  access-list 103 permit tcp any any eq 1720
  !
  voice-port 1/0/0
  !
  voice-port 1/0/1
  !
  voice-port 1/1/0
  !
  voice-port 1/1/1
  !
  dial-peer cor custom
  !
  dial-peer voice 1 pots
   destination-pattern 6000
   port 1/0/0
  !
  dial-peer voice 2 voip
   destination-pattern 5000
   session target ipv4:172.22.130.1
  

検証とトラブルシューティングのためのコマンド

debug コマンド類を発行する前に、「デバッグ コマンドに関する重要な情報」を参照してください。 次のコマンドに関する詳細は、この文書の「show と debug の出力例」の項を参照してください。

インターフェイス コマンド

  • show interface [serial | multilink]:このコマンドを使ってシリアル インターフェイスのステータスをチェックします。 シリアルおよびマルチリンクのインターフェイスが、アップおよびオープンの状態であることを確認してください。

  • シリアル リンクの問題のトラブルシューティング

LFI コマンド:

  • show ppp multilink:このコマンドにより、マルチリンク PPP バンドルのバンドル情報を表示します。

  • debug ppp multilink fragments:この debug コマンドにより、個別のマルチリンク フラグメントとインターリビング イベントに関する情報を表示します。 このコマンドの出力では、パケットのシーケンス番号とフラグメント サイズも分かります。

LLQ / IP RTP プライオリティ コマンド:

  • show policy-map interface multilink interface#:このコマンドは、LLQ の動作と PQ での廃棄を表示するのに便利です。 このコマンドのさまざまなフィールドの詳細は、次を参照してください。 show policy-map interface 出力内のパケット カウンタについて

  • show policy-map policy_map_name:ポリシーマップ設定に関する情報を表示します。

  • show queue interface-type interface-number:特定のインターフェイスの均等化キューイング設定と統計情報を表示します。

  • Debug priority:この debug コマンドは、優先キューイング イベントを表示して、そのキューで廃棄が発生しているかどうかを示します。 次も参照してください。 優先キューイングによる出力廃棄のトラブルシュート

  • show class-map class_name:クラスマップ設定に関する情報を表示します。

  • Show call active voice:このコマンドは、DSP レベルで損失パケットをチェックするのに便利です。

その他のコマンドおよび参照先:

確認されている問題:

  • CSCds43465: 「LLQ、Policer、Shaper は、CRTP 圧縮のフィードバックを反映する必要があります」リリース ノートを見るには、Bug ToolKit を参照してください。 このツールを使用するには、登録が必要です。

    一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ガイドライン:

ppp リンクがアップし、実行状態になった時点での基本的なトラブルシューティング手順(MLPPP、フラグメンテーション、インターリーブ):

  1. show call active voice:DSP レベルで損失パケットをチェックします。

  2. show interface:一般的なシリアル回線とインターフェイスの問題をチェックします。 このインターフェイスでのパケットの廃棄は、必ずしも問題があるとは言えませんが、パケットの廃棄は、低いプライオリティのキューがインターフェイス キューに到達する前に行う方が好ましいと言えます。

  3. show policy-map interface:LLQ の廃棄とキューイング設定をチェックします。 ポリシーに違反する廃棄は報告する必要がありません。

  4. show ip rtp header-compression:cRTP 特有の問題をチェックします。

show と debug の出力例

 
  
  !-----------------------------------------------
   !-----------------------------------------------
   !---- この出力の項をキャプチャするために、LLQ PQ の帯域幅を
   !---- 狭くし、リンク上に大量のデータ トラフィックを流して
   !---- 一部のパケットが強制的に廃棄されるようにしています。
   !-----------------------------------------------
   !-----------------------------------------------
   !---- パケット廃棄の検証(アクティブ コール中)
   !--- ppp リンクがアップで稼動中であると仮定して、音声品質の問題を検証する
   !--- 最初のステップとして、DSP での
   !--- 損失パケットをチェックします。 次のコマンドを使用します:show call active voice」 
   !--- : 「show call active voice brief」ではありません。
  
  
   maui-voip-austin#show call active voice
   Total call-legs: 2
  
  
   !--- 接続が確立され、両方のレッグが存在することが示されています。
  
  
   GENERIC:
            SetupTime=155218260 ms
            Index=1
            PeerAddress=5000
            PeerSubAddress=
            PeerId=2
            PeerIfIndex=13
            LogicalIfIndex=0
            ConnectTime=155218364
            CallDuration=00:00:27
            CallState=4
  
   !--- アクティブ コールであることが示されています。
   !--- (#define D_callActiveCallState_active 4)
            CallOrigin=2
            ChargedUnits=0
            InfoType=2
            TransmitPackets=365
            TransmitBytes=7300
            ReceivePackets=229
            ReceiveBytes=4580
   VOIP:
  
   !--- このコールの場合、これが終端ゲートウェイでした。
   !--- このゲートウェイでは、コールが VoIP レッグから開始されています。
  
            ConnectionId[0x18872BEB 0x1A8911CC 0x808CBE60 0x6D946FC6]
            IncomingConnectionId[0x18872BEB 0x1A8911CC 0x808CBE60 0x6D946FC6]
            RemoteIPAddress=172.22.130.1
  
   !--- どの IP アドレスから RTP ストリームが送信されているかが表示されています。
  
            RemoteUDPPort=18778
            RemoteSignallingIPAddress=172.22.130.1
  
   !--- どの IP アドレスからシグナリング メッセージが送られているかが表示されています。
  
            RemoteSignallingPort=11010
            RemoteMediaIPAddress=172.22.130.1
            RemoteMediaPort=18778
            RoundTripDelay=50 ms
            SelectedQoS=best-effort
            tx_DtmfRelay=inband-voice
            FastConnect=TRUE
   Separate H245 Connection=FALSE
   H245 Tunneling=FALSE
   SessionProtocol=cisco
   SessionTarget=
   OnTimeRvPlayout=4570
   GapFillWithSilence=20 ms
   GapFillWithPrediction=1840 ms
   GapFillWithInterpolation=0 ms
   GapFillWithRedundancy=0 ms
   HiWaterPlayoutDelay=70 ms
   LoWaterPlayoutDelay=51 ms
   ReceiveDelay=51 ms
   LostPackets=90
   EarlyPackets=1
   LatePackets=0
  
   !--- ジッタ、損失パケット、あるいは、破損パケットの
   !--- 存在が表示されています。
  
   VAD = enabled
   CoderTypeRate=g729r8
   CodecBytes=20
   GENERIC:
            SetupTime=155218260 ms
            Index=2
            PeerAddress=6000
            PeerSubAddress=
            PeerId=1
            PeerIfIndex=12
            LogicalIfIndex=6
            ConnectTime=155218364
            CallDuration=00:00:34
            CallState=4
            CallOrigin=1
            ChargedUnits=0
            InfoType=2
            TransmitPackets=229
            TransmitBytes=4580
            ReceivePackets=365
            ReceiveBytes=7300
   TELE:
            ConnectionId=[0x18872BEB 0x1A8911CC 0x808CBE60 0x6D946FC6]
            IncomingConnectionId=[0x18872BEB 0x1A8911CC 0x808CBE60 0x6D946FC6]
            TxDuration=35360 ms
            VoiceTxDuration=730 ms
            FaxTxDuration=0 ms
            CoderTypeRate=g729r8
            NoiseLevel=-46
            ACOMLevel=2
            OutSignalLevel=-58
            InSignalLevel=-42
            InfoActivity=2
            ERLLevel=7
            SessionTarget=
            ImgPages=0Total call-legs: 2
  
   !----------------------------------------------------------
   !--- インターフェイスの検証
   !--- 次の表示を確認してください:
   !--- LCP Open、multilink Open: Link control protocol(LCP)の open 文により
    !--- 接続の確立が示されています。
   !--- Open:IPCP。 PPP リンク経由で IP トラフィックを伝送できることが示されています。
  
   maui-voip-sj#show interface multilink 1
   Multilink1 is up, line protocol is up
     Hardware is multilink group interface
     Internet address is 172.22.130.1/30
     MTU 1500 bytes, BW 128 Kbit, DLY 100000 usec,
        reliability 255/255, txload 1/255, rxload 1/255
     Encapsulation PPP, loopback not set
     Keepalive set (10 sec)
     DTR is pulsed for 2 seconds on reset
     LCP Open, multilink Open
     Open: IPCP
     Last input 00:00:01, output never, output hang never
     Last clearing of "show interface" counters 00:25:20
     Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 91
     Queueing strategy: weighted fair
     Output queue: 0/1000/64/37/383 (size/max total/threshold/drops/interleaves)
        Conversations  0/3/32 (active/max active/max total)
        Reserved Conversations 1/1 (allocated/max allocated)
        Available Bandwidth 38 kilobits/sec
     5 minute input rate 0 bits/sec, 0 packets/sec
     5 minute output rate 0 bits/sec, 0 packets/sec
        8217 packets input, 967680 bytes, 0 no buffer
        Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
        0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
        13091 packets output, 1254194 bytes, 0 underruns
        0 output errors, 0 collisions, 0 interface resets
        0 output buffer failures, 0 output buffers swapped out
        0 carrier transitions
  ----------------------------------------------------------------
  
  !--- 注: インターフェイス レベルでは廃棄は発生していません。
  !-- ポリシングのために廃棄されたトラフィックは、すべて
  !-- インターフェイス キューに達する前に廃棄されています。
  
  maui-voip-austin#show interface
   serial 0/0Serial0/0 is up, line protocol is up
    Hardware is QUICC Serial
    MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
       reliability 255/255, txload 49/255, rxload 47/255
    Encapsulation PPP, loopback not set
    Keepalive set (10 sec)
    LCP Open, multilink Open
    Last input 00:00:00, output 00:00:00, output hang never
    Last clearing of "show interface" counters 00:22:08
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: weighted fair  [suspended, using FIFO]
    FIFO output queue 0/40, 0 drops
    5 minute input rate 24000 bits/sec, 20 packets/sec
    5 minute output rate 25000 bits/sec, 20 packets/sec     4851 packets input, 668983 bytes, 0 no buffer
       Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
       0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
       4586 packets output, 657902 bytes, 0 underruns
       0 output errors, 0 collisions, 0 interface resets
       0 output buffer failures, 0 output buffers swapped out
       0 carrier transitions
       DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
  
  !-----------------------------------
  !--- LLQ の検証
  
  
  maui-voip-austin#show policy-map int multilink 1
   Multilink1
   Service-policy output: voice-policy
   Class-map: voice-signaling (match-all)
  
  !--- これは音声シグナリング トラフィックのクラスです。
  
           10 packets, 744 bytes
           5 minute offered rate 0 BPS, drop rate 0 BPS
           Match: access-group 103
           Weighted Fair Queueing
           Output Queue: Conversation 42
           Bandwidth 8 (kbps) Max Threshold 64 (packets)
           (pkts matched/bytes matched) 10/744
           (depth/total drops/no-buffer drops) 0/0/0
   Class-map: voice-traffic (match-all)
  
  !--- これは音声トラフィックの PQ クラスです。
  
           458 packets, 32064 bytes
           5 minute offered rate 0 BPS, drop rate 0 BPS
           Match: access-group 102
           Weighted Fair Queueing
           Strict Priority
           Output Queue: Conversation 40
           Bandwidth 15 (kbps) Burst 375 (Bytes)
  !--- パケットを強制的に廃棄するために PQ 帯域幅が縮小されていることに注意してください。
           (pkts matched/bytes matched) 458/29647
           (total drops/bytes drops) 91/5890
  !--- 一部のパケットが廃棄されています。 適切に設計されたリンクでは、
  !--- PQ クラスの廃棄はまったく発生しないか、発生したとしてもごくわずかです。
   Class-map: class-default (match-any)
           814 packets, 731341 bytes
           5 minute offered rate 27000 BPS, drop rate 0 BPSMatch: any
           Weighted Fair Queueing
           Flow Based Fair Queueing
           Maximum Number of Hashed Queues 32
           (total queued/total drops/no-buffer drops) 0/0/0
  
  !---------------------------------------------
  
  
  !--- クラスマップの設定を検証します。
  
  maui-voip-austin#show class-map
   Class Map match-all voice-signaling (id 2)
     Match access-group  103
   Class Map match-any class-default (id 0)
           Match any
   Class Map match-all voice-traffic (id 3)
           Match access-group 102
  
  !--- クラスマップのアクセスリストを検証します。
  
  maui-voip-austin#show access-lists
  Extended IP access list 102
      permit udp any any range 16384 32767 (34947 matches)
  Extended IP access list 103
      permit tcp any eq 1720 any (187 matches)
      permit tcp any any eq 1720 (86 matches)
  
  !--- ポリシーマップの設定を検証します。
  
  maui-voip-austin#show policy-map voice-policy
    Policy Map voice-policy
      Class voice-signaling
        Weighted Fair Queueing
              Bandwidth 8 (kbps) Max Threshold 64 (packets)
      Class voice-traffic
        Weighted Fair Queueing
              Strict Priority
              Bandwidth 50 (kbps) Burst 1250 (Bytes)
      Class class-default
        Weighted Fair Queueing
              Flow based Fair Queueing Max Threshold 64 (packets)
  ---------------------------
  
  !--- Debug priority コマンドにより、VoIP のパケット廃棄が発生すると
  !-- 即座にフィードバックが返されます。  
  !--- 次の出力は VoIP パケットが完全優先キューから廃棄されている際の
  !--- エラー メッセージを示しています。 
  
  maui-voip-sj#debug priority
  priority output queueing debugging is on
  maui-voip-sj#
  Mar 17 19:47:09.947: WFQ: dropping a packet from the priority queue 0
  Mar 17 19:47:09.967: WFQ: dropping a packet from the priority queue 0
  Mar 17 19:47:09.987: WFQ: dropping a packet from the priority queue 0
  -------------------------------------------------------------------
  
  
  !--- Link Fragmentation and Interleaving(LFI; リンク フラグメンテーションおよびインターリービング)の検証 
  
  
  maui-voip-sj#show ppp multilink
  
  !--- フラグメンテーション サイズとマルチリンクを検証します。 
  
  Multilink1, bundle name is maui-voip-austin
           Bundle up for 00:08:04
           0 lost fragments, 0 reordered, 0 unassigned
           0 discarded, 0 lost received, 1/255 load
           0x6D received sequence, 0x6E sent sequence
           Member links: 1 active, 0 inactive (max not set, min not set)
           Serial0/0, since 00:08:09, last rcvd seq 00006C 160 weight
  
    !--- フラグメンテーション サイズが 160 バイトである点に注意してください。 リンクの設定では、帯域幅を 128 Kbps に、
    !--- シリアル化遅延を 10 ミリ秒にします。 
    !--- フラグメント サイズ(単位ビット) = 帯域幅 * シリアル化遅延
    !--- : 1 バイトは 8 ビットです。
  
  -------------------------------------------------------
  
  
  !--- Link Fragmentation and Interleaving(LFI; リンク フラグメンテーションおよびインターリービング)の検証 
  !--- マルチリンク PPP リンク LFI のテスト
  !--- 次の出力は、128 kbps の PPP リンクで大きなデータと VoIP パケットがロードされた際の
  !--- フラグメンテーションとインターリービングの情報を表示しています。
  
  maui-voip-sj#debug ppp multilink fragments
  Multilink fragments debugging is on
  1w3d: Se0/0 MLP: O frag 800004CF size 160
  1w3d: Se0/0 MLP: O frag 000004D0 size 160
  1w3d: Se0/0 MLP: I ppp IP (0021) size 64 direct
  1w3d: Mu1 MLP: Packet interleaved from queue 40
  1w3d: Se0/0 MLP: O ppp IP (0021) size 64
  1w3d: Se0/0 MLP: I ppp IP (0021) size 64 direct
  1w3d: Se0/0 MLP: O frag 400004D1 size 106
  1w3d: Se0/0 MLP: O ppp IP (0021) size 64
  1w3d: Se0/0 MLP: I ppp IP (0021) size 64 direct
  1w3d: Se0/0 MLP: O ppp IP (0021) size 64 direct
  1w3d: Se0/0 MLP: I frag 800004E0 size 160 direct
  1w3d: Se0/0 MLP: I frag 000004E1 size 160 direct
  1w3d: Se0/0 MLP: I ppp IP (0021) size 64 direct
  -------------------------------------------------------------------
  
  !--- show ip rtp header-compression コマンドの出力例
  
  maui-voip-sj#show ip tcp header-compression
  TCP/IP header compression statistics:  Interface Multilink1:
      Rcvd:    10 total, 6 compressed, 0 errors
               0 dropped, 0 buffer copies, 0 buffer failures
      Sent:    10 total, 7 compressed,
               230 bytes saved, 99 bytes sent
               3.32 efficiency improvement factor
      Connect: 16 rx slots, 16 tx slots,
               2 long searches, 1 misses 0 collisions, 0 negative cache hits
               90% hit ratio, five minute miss rate 0 misses/sec, 0 max
  ----------------------------------------------------------------------
  
  !--- このコマンドは VoIP ダイヤルピアの情報を表示します。  
  
  maui-voip-sj#show dial-peer voice 2
  VoiceOverIpPeer2
          information type = voice,
          tag = 2, destination-pattern = `6000',
          answer-address = `', preference=0,
          group = 2, Admin state is up, Operation state is up,
          incoming called-number = `', connections/maximum = 0/unlimited,
          application associated:
          type = voip, session-tMarget = `ipv4:172.22.130.2',
          technology prefix:
          ip precedence = 0, UDP checksum = disabled,
          session-protocol = cisco, req-qos = best-effort,
          acc-qos = best-effort,
          fax-rate = voice,   payload size =  20 bytes
          codec = g729r8,   payload size =  20 bytes,
          Expect factor = 10, Icpif = 30,signaling-type = cas,
          VAD = enabled, Poor QOV Trap = disabled,
          Connect Time = 283, Charged Units = 0,
          Successful Calls = 1, Failed Calls = 0,
          Accepted Calls = 1, Refused Calls = 0,
          Last Disconnect Cause is "10  ",
          Last Disconnect Text is "normal call clearing.",
          Last Setup Time = 93793451.
  -------------------------------------------------------------------------
  
  !--- どの 5 分間隔においても、ルータの CPU 使用率が
  !--- 50 〜 60 % を超えることはできません。
  
  maui-voip-austin#show processes cpu
  CPU utilization for five seconds: 12%/8%; one minute: 11%; five minutes: 9%
   PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
     1         148    310794          0  0.00%  0.00%  0.00%   0 Load Meter
     2          76        23       3304  0.81%  0.07%  0.01%   0 Exec
  


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 7111