IP : IP マルチキャスト

PIM 希薄モードで HSRP アドレスに対するスタティック ルートが処理されない理由

2003 年 12 月 30 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

目次

概要
はじめに
     表記法
     前提条件
     使用するコンポーネント
ネットワーク ダイアグラム
     設定
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書では、Protocol Independent Multicast(PIM)希薄モードと Hot Standby Router Protocol(HSRP; ホット スタンバイ ルータ プロトコル)を設定しているときにマルチキャスト パケットが受信されない理由を説明します。

はじめに

表記法

文書の表記法の詳細は、「シスコ テクニカル ティップスの表記法」を参照してください。

前提条件

この文書の読者は次の項目に関する知識が必要です。

  • HSRP

  • PIM 希薄モード

使用するコンポーネント

この文書は、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

ネットワーク ダイアグラム

hsrpmcasta.gif

>>画像拡大

上記の図で、ルータ 2 および 3 は、サブネット 10.1.3.0 上では HSRP が動作しており、ルータ 2 がアクティブ ルータです。 ルータ 1、2、および 3 では、Enhanced Interior Gateway Routing Protocol(EIGRP)が動作し、ルータ 4 には HSRP 仮想アドレスに対するデフォルトのスタティック ルートがあります。

設定

ルータ 1

ルータ 2

Current configuration:
   ! 
   ip multicast-routing 
   ! 
   ! 
   interface Loopback0 
   ip address 10.10.10.10 255.255.255.255 
   no ip directed-broadcast 
   ! 
   interface Ethernet0 
   no ip address 
   no ip directed-broadcast 
   shutdown 
   ! 
   interface Ethernet1 
   ip address 10.1.1.1 255.255.255.0 
   no ip directed-broadcast 
   ip pim sparse-mode 
   ! 
   interface Serial1 
   no ip address 
   no ip directed-broadcast 
   encapsulation frame-relay 
   ! 
   interface Serial1.1 point-to-point 
   ip address 10.1.2.1 255.255.255.252 
   no ip directed-broadcast 
   ip pim sparse-mode 
   frame-relay interface-dlci 612 
   ! 
   ! 
   interface Serial1.2 point-to-point 
   ip address 10.1.2.5 255.255.255.252 
   no ip directed-broadcast 
   ip pim sparse-mode 
   frame-relay interface-dlci 613 
   ! 
   router eigrp 1 
   network 10.0.0.0 
   no auto-summary 
   ! 
   ip classless 
   no ip http server 
   ip pim rp-address 10.10.10.10 
   ! 
   end
   
Current configuration:
   ! 
   ip multicast-routing 
   ip dvmrp route-limit 20000 
   ! 
   ! 
   interface Ethernet1 
   ip address 10.1.3.1 255.255.255.0 
   no ip redirects 
   ip pim sparse-mode 
   standby 1 priority 110 preempt 
   standby 1 ip 10.1.3.3 
   ! 
   interface Serial1 
   no ip address 
   encapsulation frame-relay 
   ! 
   interface Serial1.1 point-to-point 
   ip address 10.1.2.2 255.255.255.252 
   ip pim sparse-mode 
   frame-relay interface-dlci 621 
   ! 
   router eigrp 1 
   network 10.0.0.0 
   no auto-summary 
   ! 
   ip classless 
   ip pim rp-address 10.10.10.10 
   !
   end
   

ルータ 3

ルータ 4

Current configuration:
   ! 
   ip multicast-routing 
   ip dvmrp route-limit 20000 
   ! 
   interface Ethernet1 
   ip address 10.1.3.2 255.255.255.0 
   no ip redirects 
   ip pim sparse-mode 
   standby 1 priority 100 preempt 
   standby 1 ip 10.1.3.3 
   ! 
   interface Serial1 
   no ip address 
   encapsulation frame-relay 
   ! 
   interface Serial1.2 point-to-point 
   ip address 10.1.2.6 255.255.255.252 
   ip pim sparse-mode 
   frame-relay interface-dlci 631 
   ! 
   router eigrp 1 
   network 10.0.0.0 
   no auto-summary 
   eigrp log-neighbor-changes 
   ! 
   ip classless 
   no ip http server 
   ip pim rp-address 10.10.10.10 
   !
   end
   
Current configuration:
   ip multicast-routing 
   ip dvmrp route-limit 20000 
   ! 
   ! 
   ! 
   interface Ethernet0 
   ip address 10.1.4.1 255.255.255.0 
   no ip directed-broadcast 
   ip igmp join-group 239.1.2.3 
   ! 
   interface Ethernet1 
   ip address 10.1.3.4 255.255.255.0 
   no ip directed-broadcast 
   ip pim sparse-mode 
   ! 
   no ip http server 
   ip classless 
   ip route 0.0.0.0 0.0.0.0 10.1.3.3 
   ip pim rp-address 10.10.10.10 
   !
   end
   

イーサネット 0 上のホストをシミュレートするために、ルータ 4 のこのインターフェイスで ip igmp join-group コマンドが設定されました。

router4#ip igmp join-group 
   IGMP Connected Group Membership 
   Group Address Interface Uptime Expires Last Reporter 
   224.0.1.40 Ethernet1 4d23h never 10.1.3.1 
   239.1.2.3 Ethernet0 4d23h never 10.1.4.1 
   

ルータ 4 は rendezvous point(RP; ランデブー ポイント)アドレスも ping できます。

Type escape sequence to abort. 
   Sending 5, 100-byte ICMP Echos to 10.10.10.10, timeout is 2 seconds: 
   !!!!! 
   Success rate is 100 percent (5/5), round-trip min/avg/max = 60/61/68 ms

マルチキャスト ルート(mroute)テーブルを見てみましょう。

Router4#show ip mroute 239.1.2.3 
   IP Multicast Routing Table 
   Flags: D - Dense, S - Sparse, C - Connected, L - Local, P - Pruned 
   R - RP-bit set, F - Register flag, T - SPT-bit set, J - Join SPT 
   X - Proxy Join Timer Running 
   Timers: Uptime/Expires 
   Interface state: Interface, Next-Hop or VCD, State/Mode 
   (*, 239.1.2.3), 00:04:28/00:00:00, RP 10.10.10.10, flags: SJCL 
   Incoming interface: Ethernet1, RPF nbr 10.1.3.3 
   Outgoing interface list: 
   Ethernet0, Forward/Sparse, 00:02:12/00:02:53 
   

(ルータ 4 で使用される ip igmp join-group コマンドのために)このグループにはレシーバがあるので、(*,G)エントリを mroute テーブルに作成します。 (*,G) エントリに対する Reverse Path Forwarding(RPF; リバース パス転送)の近接ルータは、10.1.3.3 で、これは HSRP スタンバイ アドレスです。 しかし、(S,G) エントリはありません。これは、トラフィックがソースから受信されていないことを意味します。

ルータ 4 はグループに対して対象となるレシーバがあるため、PIM Join/Prune メッセージを PIM 近接ルータに送信する必要があります。 ルータ 4 の PIM 近接ルータを表示するには、次に示すように show ip pim neighbor コマンドを使用します。

Router4#show ip pim neighbor 
   PIM Neighbor Table 
   Neighbor Address Interface Uptime Expires Ver Mode 
   10.1.3.1 Ethernet1 4d23h 00:01:41 v2 
   10.1.3.2 Ethernet1 4d23h 00:01:36 v2

debug ip pim 239.1.2.3 コマンドが有効にされた場合、ルータ 4 は、この PIM Join/Prune メッセージを作成しますが、実際には送信しません。

*Mar 6 18:32:48: PIM: Received RP-Reachable on Ethernet1 from 10.10.10.10 *Mar 6 18:32:48: for group 239.1.2.3 *Mar 6 18:33:14: PIM: Building Join/Prune message for 239.1.2.3 *Mar 6 18:34:13: PIM: Building Join/Prune message for 239.1.2.3

ルータは、なぜ Join/Prune メッセージを送信しないのでしょうか? RFC 2362 leavingcisco.comには、「a router sends a periodic Join/Prune message to each distinct RPF neighbor associated with each (S,G), (*,G) and (*,*,RP) entry. Join/Prune messages are sent only if the RPF neighbor is a PIM neighbor.」と記述されています。

この例では、RPF 近接ルータは 10.1.3.3 で、これはデフォルトのスタティック ルートによって使用される HSRP スタンバイ アドレスです。 しかし、このアドレスは PIM 近接ルータとしてはリストされません。 HSRP スタンバイ アドレスが PIM 近接ルータとしてリストされない理由は、HSRP を実行している 2 台のルータ(ルータ 2 および 3)では PIM 近接メッセージの送信元が HSRP スタンバイ アドレスにならないからです。

問題を解決するには、RPF 近接ルータが PIM 近接ルータにもなるようルータ 4 の設定を変更します。 これは、ルータ 4 を EIGRP プロセスに含めて、ルータ 4 が EIGRP を介して RP アドレスを学習するようにすることで行います。

注: ルータ 4 には、ルーティング プロトコルを実行する機能があるため、接続を HSRP スタンバイ アドレスに依存する必要はありません。 HSRP の開発目的は、ホストに迅速かつ効果的な冗長性やフェールオーバーを獲得する方法を提供することでした。

EIGRP を有効にしたルータ 4 の新しい設定を次に示します。

ip multicast-routing 
   ip dvmrp route-limit 20000 
   ! 
   ! 
   ! 
   interface Ethernet0 
   ip address 10.1.4.1 255.255.255.0 
   no ip directed-broadcast 
   ip igmp join-group 239.1.2.3 
   ! 
   interface Ethernet1 
   ip address 10.1.3.4 255.255.255.0 
   no ip directed-broadcast 
   ip pim sparse-mode 
   !
   router eigrp 1
   network 10.0.0.0
   no auto-summary
   ! 
   no ip http server 
   ip classless 
   ip route 0.0.0.0 0.0.0.0 10.1.3.3 
   ip pim rp-address 10.10.10.10 
   !
   end 
   

注: ルータ 4 を EIGRP プロセスに含める(推奨される方法)代わりに、スタティック mroute をルータ 4 に追加して、実際のルータの IP アドレスに対する RPF にします。mroute は、RPF チェックでユニキャスト ルーティングより優先されるからです。 たとえば、ip mroute 0.0.0.0 0.0.0.0 10.1.3.2 を追加します。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 13783