IP : IP バージョン 6(IPv6)

IPv6 の 6to4 トンネルを使用した 6bone 接続

2004 年 4 月 27 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2005 年 8 月 10 日) | フィードバック

目次

概要
前提条件
     要件
     使用するコンポーネント
     表記法
6to4 トンネルの仕組み
     6to4 トンネルの制限事項
トンネリング シナリオ
設定
     ネットワーク ダイアグラム
     設定
確認
トラブルシューティング
関連するシスコ サポート コミュニティ ディスカッション
関連情報

概要

この文書では、企業/キャンパスのお客様(教育機関、小規模ソフトウェア企業、小規模製造企業など)が、6to4 トンネルを使用して 6bone に接続する方法について説明します。6bone は、インターネットでの IPv6 の発展と導入を支援するために設定された、IP version 6(IPv6)のテスト ネットワークです。

この文書は、IPv6 設計ガイドで入手可能な「IPv6 の導入戦略」に関する出版物をサポートおよび補足する、一連の文書の 1 つです。

この文書と「IPv6 の導入戦略」を併読し、IPv6 の導入前の作業をよりよく理解しておく必要があります。

前提条件

要件

6bone に対する 6to4 トンネルを実装する前には、次の作業を実行する必要があります。

  • デュアルスタックを実行するように設定されたサイトで、境界ルータを特定する。この境界ルータは、静的でグローバルにルーティング可能な IPv4 アドレスを保持している必要があります。

  • 6bone ISP から、6bone アクセスに使用する 6to4 リレー ルータの IPv4 アドレスを取得する。

    注: エンタープライズ境界ルータに対してトンネルを設定する場合は、グローバルにルーティング可能な IPv4 アドレスを使用する必要があります。この文書の設定例で使用されている IPv4 アドレスは、グローバルにルーティング可能なアドレスではなく、説明だけを目的として提供されています。

  • DNS が、IPv6 の DNS の主要コンポーネントの実装を提供する Berkeley Internet Name Domain(BIND)のバージョン 9 を実行している(または同等の機能を持っている)ことを確認する。DNS の設定は、この文書の範囲を越えています。

  • Cisco IOS ソフトウェアにおける現在のデュアルスタック実装が、(TFTP、ping、Telnet、および traceroute などのアプリケーションを、IPv4 または IPv6 トランスポートのどちらでも実行できるようにする)暫定的なネットワーク管理ソリューションを可能にしていることを確認する。

  • ネットワーク設定に適切な、RIPng など IPv6 内部ルーティング プロトコルを選択する。単純にするため、この文書で説明するでソリューションではスタティック ルートを使用します。関連する IPv4 外部ルーティング プロトコルは、外部ルーティングを処理します。

  • すべてのデュアルスタック ルータを、RIP を使用するように設定する。

IPv6 用にネットワークを設定する方法の詳細については、「Cisco IOS IPv6 コンフィギュレーション ライブラリ」を参照してください。

使用するコンポーネント

この文書の情報は、IPv6 をサポートする Cisco IOS イメージに基づいています。

この文書の情報は、特定のラボ環境にあるデバイスに基づいて作成されています。また、この文書で使用するデバイスは、すべて初期(デフォルト)の設定で起動しています。対象のネットワークが実稼動中である場合には、すべてのコマンドによる潜在的な影響について確実に理解しておく必要があります。

次の図に、企業/キャンパスのお客様の、最初の IPv4 ネットワーク トポロジを示します。このネットワークでは複数のルータを使用して、ローカル ユーザ間での IP 接続を提供します。Internet Service Provider(ISP; インターネット サービス プロバイダー)への永続的な IPv4 接続が、外部接続を提供します。

72215.jpg

次の表で、このソリューションで使用するデバイスを説明します。

デバイス

エンタープライズ境界ルータ

6bone ISP ルータ

ホスト名

6bone-gw

ipv6-router

シャーシの種類

Cisco 3660 ルータ

Cisco 7206 ルータ

物理インターフェイス

2 イーサネット

2 ファースト イーサネット

4 シリアル

4 イーサネット

2 ファースト イーサネット

4 シリアル

ロード済みソフトウェア

Cisco IOS リリース 12.2(4)T

Cisco IOS リリース 12.2(4)T

メモリ

64MV RAM、16 MB フラッシュ

128 MB RAM、20 MB フラッシュ

IP アドレス

Ethernet0: IPv4 192.168.99.1

Tunnel2002: IPv6 2002:C0A8::1/128

Ethernet0/0: IPv4 192.168.33.1

Tunnel2002: IPv6 2002:C0A8:2102::1/128

表記法

文書の表記法の詳細は、「シスコ テクニカル ティップスの表記法」を参照してください。

6to4 トンネルの仕組み

6to4 トンネルは、エンタープライズ デュアルスタック境界ルータで設定されます。6bone へのすべてのエンタープライズ IPv6 トラフィックは、IPv4 でトンネルを経由して、6bone ISP 6to4 リレー ルータへルーティングされます。6bone からエンタープライズ ホストへのトラフィックは、IPv4 でトンネルを経由してエンタープライズ デュアルスタック境界ルータへルーティングされ、続いて IPv6 宛先ホストにルーティングされます。

企業にとって 6to4 トンネルを使用する利点には、次のものがあります。

  • Cisco IOS ソフトウェアは 6to4 トンネルをサポートしている。

  • エンドユーザ ホスト設定がシンプルである(最低限の管理オーバーヘッドしか必要としない)。

  • トンネルは自動である。6to4 リレー サイトでは企業に固有の設定が必要でない。6to4 トンネルはスケーラビリティに優れている。

  • このソリューションは、企業でのダイナミック IP アドレスに対応する。

  • トンネルは、セッションの期間中だけ存在する。

  • 6to4 トンネルは、ISP で 1 回だけ設定を行う必要がある。これにより、6to4 リレー サービスは多くの企業で同時に使用できるようになる。

6to4 トンネルの制限事項

6to4 トンネルの利用には、次の制限事項があります。

  • 独立して管理される NAT は、トンネルのパスでは使用できない。

  • マルチホーミングを簡単に実装できない。

  • 6to4 トンネル メカニズムは /48 アドレス ブロックを提供するため、それ以上のアドレスが使用できない。

  • 6to4 トンネルは多対一で設定され、トンネル トラフィックは複数のエンドポイントから発信可能であるため、6to4 トンネルが ISP に提供できるのは全般的なトラフィック情報だけである。

  • 基本の IPv4 アドレスがエンタープライズ 6to4 IPv6 アドレスのプレフィックスを決定するため、ネイティブ IPv6 への移行にはネットワークの再番号付けが必要になる。

  • このソリューションはスタティックまたは BGP4+ ルーティングに限られる。

トンネリング シナリオ

(一般的な企業/キャンパス環境と考えられる)IPv4 ネットワークを構築している小規模のソフトウェア企業が、ネットワークで IPv6 を稼働させている別の企業との合併を検討しているとします。合併した企業への合併の接続上の影響を評価するため、お客様は 6bone に接続することにより IPv6 の知識を広めたいと考えています。この文書で説明する、企業/キャンパスのお客様のビジネス上の目標は次のとおりです。

  • 最小限の投資で、既存の IPv4 トポロジを使用して、確立されている IPv6 バックボーンで IPv6 を体験する。

  • IPv6 を配備する前に、実際の IPv6 環境における移行および運用手順をテストする。

    移行手順は、IPv4 から IPv6 に移行するために必要な手順です。移行手順には、デュアルスタック ルータとエンド システム、トンネリング メカニズム、Domain Name System(DNS; ドメイン ネーム システム)サーバの設定が含まれ、また将来には Network Address Translation-Protocol Translation(NAT-PT)のテストが含まれます。

    運用手順は、ネットワーク管理、デュアルスタック ホストとエンド システムの要素管理、およびその他の類似機能に関連します。

  • ローカル ワークステーションで IPv6 のアプリケーションと実装をテストする。

  • 6bone 接続に関連する管理オーバーヘッドを最小限にする。

    注: 6bone は多くの種類の組織(教育/政府機関、ハードウェア/ソフトウェア ベンダー、およびサービス プロバイダー)から構成されますが、この文書では 6bone の終端に接続している組織 を「6bone ISP」という用語で示します。

設定

境界ルータの IPv4 アドレスは 192.168.99.1 です。IPv4 アドレスの 10 進数のコンポーネントを 16 進数に変換してから、その 16 進数に「2002」のプレフィックスを追加することにより、IPv4 アドレスから 6to4 プレフィックスを導きます。よって、ネットワーク内の IPv6 ノードの 6to4 プレフィックスは「2002:C0A8:6301::/128」となります。

表 6 に示すように、上記の IPv6 アドレスの「C0A8:6301」の部分は、ドット付き 10 進数表記の各オクテットを対応する 16 進数の値に変換することで、IPv4 アドレスから形成されたものです。

10 進数

16 進数

192

C0

168

168

99

63

1

01

この項では、この文書で説明する機能を設定するために必要な情報を提供します。

注:この文書で使用されているコマンドの詳細を調べるには、Command Lookup Tool を使用してください(登録ユーザのみ)。

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

ネットワーク ダイアグラム

この文書では次の図に示すネットワーク設定を使用しています。

次の図に、一般的な 6bone への 6to4 トンネルのトポロジを示します。

72221.jpg

設定

6bone ISP は、6bone 境界ルータの IPv4 アドレス 192.168.33.1 を提供しています。次のコマンドを入力して、上記のアドレスを使用し、特定されたデュアルスタック境界ルータで 6to4 トンネルを設定します。

エンタープライズ ルータ

ipv6 unicast-routing
   interface Ethernet0
    description connection to 6bone ISP
    ip address 192.168.99.1 255.255.255.0
   interface Tunnel2002
    description 6to4 tunnel to 6bone ISP
    no ip address
    no ip redirects
    ipv6 address 2002:C0A8:6301::1/128
    tunnel source ethernet0
    tunnel mode ipv6ip 6to4
   ipv6 route 2002::/16 Tunnel2002
   ipv6 route ::/0 2002:C0A8:2101::1

2 つ目の ipv6 route コマンドの「2002:C0A8:2101::1」は、6bone へのアクセスを提供する ISP 6to4 リレー ルータの IPv6 アドレスです。アドレスの「C0A8:2101」の部分は、表 6 と同じような方法で 6to4 リレー ルータの IPv4 アドレス(192.168.33.1)から導かれたものです。

トンネルのもう一方の端で、6bone ISP の境界ルータには、次の IPv6 ユニキャスト ルーティングの例のような設定があります。

ISP 6to4 リレー ルータ

ipv6 unicast-routing
   interface ethernet0/0
    description connection to enterprise
    ip address 192.168.33.1 255.255.255.0
   interface Tunnel2002
    description 6to4 relay service
    no ip address
    no ip redirects
    ipv6 address 2002:C0A8:2101::1/128
    tunnel source ethernet0/0
    tunnel mode ipv6ip 6to4
   ipv6 route 2002::/16 tunnel2002

エンタープライズ ルータ 6bon2-gw

maui-soho-01# show running-config 
    Building configuration...
    .
    .
    .
    username maui-nas-05 password cisco
    ! Identify the version of Cisco IOS software running on the router
   !
   version 12.2
   !
   ! Include timestamps on log and debug entries that are useful for
   ! troubleshooting and optimizing the network.
   !
   service timestamps debug datetime localtime show-timezone
   service timestamps log datetime localtime show-timezone
   !
   ! Specify that passwords will be encrypted in configuration output.
   !
   service password-encryption
   !
   ! Configure the router name
   !
   hostname 6bone-gw
   !
   ! Configure boot options
   !
   boot system flash slot0:
   boot system flash bootflash:
   !
   ! Configure logging
   !logging buffered 10000 debugging
   !
   ! Configure secret password
   !
   enable secret 5 [removed]
   !
   ! Configure clock timezone and summertime rule
   !
   clock timezone PST -8
   clock summer-time PDT recurring
   !
   !
   ip subnet-zero
   no ip source-route
   no ip rcmd domain-lookup
   !
   ! Configure router domain name
   !
   ip domain-name EnterpriseDomain.com
   !
   ! Configure DNS name servers
   !
   ip name-server 192.168.1.10
   ip name-server 192.168.2.21
   ip name-server 2002:C0A8:6301:1::21
   !
   ! Enable IPv6 routing
   !
   ipv6 unicast-routing
   !
   ! Configure Tunnel interface
   !
   interface Tunnel2002
    description 6to4 tunnel to 6bone ISP
    no ip address
    no ip redirects
    ipv6 address 2002:C0A8:6301::1/128
    tunnel source ethernet0
    tunnel mode ipv6ip 6to4
   !
   ! Configure physical interface
   !
   interface Ethernet0
    description connection to 6bone ISP
    ip address 192.168.99.1 255.255.255.0
   !
   interface Ethernet1
    description connection to Lab interface router
    ip address 192.168.99.40 255.255.255.0
    ipv6 address 3FFE:FFFF:8023:100::1/64
    ipv6 rip v6rip enable
   !
   interface FastEthernet2/0
    description connection to core router
    ip address 192.168.99.41 255.255.255.0
    ipv6 address 3FFE:FFFF:8023:200::1/64
    ipv6 rip v6rip enable
   !
   interface FastEthernet3/0
    description connection to IPv4-only core router
    ip address 192.168.99.42 255.255.255.0
   !
   ! Other interfaces are all unused
   !
   interface Serial4/0
    no ip address
    shutdown
   !
   interface Serial4/1
    no ip address
    shutdown
   !
   interface Serial4/2
    no ip address
    shutdown
   !
   interface Serial4/3
    no ip address
    shutdown
   !
   ! Configure basic IP routing
   !
   ip default-gateway 192.168.33.1
   ip classless
   ip route 0.0.0.0 0.0.0.0 192.168.33.1
   !
   ! Configure IPv6 static route
   !
   ipv6 route 2002::/16 tunnel2002
   ipv6 route ::/0 2002:C0A8:2101::1
   ipv6 router rip v6rip
   !
   end
    end

6bone IPv6 ISP ルータ

maui-soho-01# show running-config 
    Building configuration...
    .
    .
    .
    username maui-nas-05 password cisco
    ! Identify the version of Cisco IOS software running on the router
   !
   version 12.2
   !
   ! Include timestamps on log and debug entries that are useful for
   ! troubleshooting and optimizing the network.
   !
   service timestamps debug datetime localtime show-timezone
   service timestamps log datetime localtime show-timezone
   !
   ! Specify that passwords will be encrypted in configuration output.
   !
   service password-encryption
   !
   ! Configure the router name
   !
   hostname ipv6-router
   !
   ! Configure boot options
   !
   boot system flash slot0:
   boot system flash bootflash:
   !
   ! Configure logging
   !
   logging buffered 10000 debugging
   !
   ! Configure secret password
   !
   enable secret 5 [removed]
   !
   ! Configure clock timezone and summertime rule
   !
   clock timezone PST -8
   clock summer-time PDT recurring
   !
   !
   ip subnet-zero
   no ip source-route
   no ip rcmd domain-lookup
   !
   ! Configure router's domain name
   !
   ip domain-name 6boneISP.com
   !
   ! Configure DNS name servers
   !
   ip name-server 192.168.33.4
   ip name-server 192.168.33.5
   ip name-server 3FFE:FFFF:8001::4
   !
   ! Enable IPv6 routing
   !
   ipv6 unicast-routing
   !
   ! Configure Tunnel interface
   !
   interface Tunnel2002
    description 6to4 relay service
    no ip address
    no ip redirects
    ipv6 address 2002:C0A8:2101::1/128
    tunnel source ethernet0/0
    tunnel mode ipv6ip 6to4
   !
   ! Configure physical interface
   !
   interface Ethernet0/0
    description connection to enterprise
    ip address 192.168.33.1 255.255.255.0
   !
   interface Ethernet0/1
    no ip address
    shutdown
   !
   interface Ethernet0/2
    no ip address
    shutdown
   !
   interface Ethernet0/3
    no ip address
    shutdown
   !
   interface FastEthernet1/0
    description connection to ISP-core-A
    ip address 192.168.34.10 255.255.255.0
    ipv6 address 3FFE:FFFF:8023:2::6/64
    duplex auto
    speed auto
   !
   interface FastEthernet2/0
    description connection to ISP-core-B
    ip address 192.168.35.22 255.255.255.0
    ipv6 address 3FFE:FFFF:8023:2::8/64
    duplex auto
    speed auto
   !
   ! Other interfaces are all unused
   !
   interface Serial4/0
    no ip address
    shutdown
   !
   interface Serial4/1
    no ip address
    shutdown
   !
   interface Serial4/2
    no ip address
    shutdown
   !
   interface Serial4/3
    no ip address
    shutdown
   !
   ! Configure basic IP routing
   !
   ip default-gateway 192.168.30.1
   ip classless
   ip route 0.0.0.0 0.0.0.0 192.168.30.1
   !
   ! Configure IPv6 static route
   !
   ipv6 route 2002::/16 tunnel2002
   !
   end

確認

このオプションの作業では、トンネルが正しく設定され動作していることを確認する方法を説明します。作業手順に含まれているコマンドはどのシーケンスでも使用可能で、また繰り返す必要があることもあります。

特定の show コマンドは、Output Interpreter ツール登録ユーザのみ)でサポートされています。このツールを使用すると、show コマンドの出力を分析できます。

一部ツールについては、ゲスト登録のお客様にはアクセスできない場合がありますことを、ご了承ください。

  • enable

  • show interfaces tunnel number [accounting]

  • ping [protocol] destination

  • show ip route [address [mask]]

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 45741